Applets which don't run

Hello,
I have any applets which run with Appletviewer or the development tool "Forte for Java" but they don't run on the web browser whereas I have others applets (with almost the same code) which run in the both cases.
In fact, on the web browser, you can see the static components (buttons, choices...) but these ones have no effects.
And, the access to the database seems not to run.
I think it's an problem which doesn't come from the code but I don't know what.
Can you help me ?
Thank you.

Browsers have in-built support for JDK 1.1 If you are using packages not suported by JDK1.1 for example Swing, the applets won't work without downloading a plugin. The first thing you should do is check if you are using packages not suported by the JDK1.1 Also check if your browser does use a plugin.
You can download the plugin from this site:
http://java.sun.com/getjava/download.html
When you are downloading the plugin you can specify that it is used by your browser by default. This means that you do not have to modify your HTML file.
The following is relevant if you intend to put your applet up on the web:
The user may not have their browser set up to automatically use a plugin. This means that you may need to convert your HTML file so that the plugin is used to run the applet and it works corrrectly for different browsers. Also if the user does not have the correct plugin your web page prompts them to download it.
This site explains how the HTML code is modified:
http://java.sun.com/products/plugin/1.2/docs/tags.html
There is a way to do this conversion process automatically - by using the HTMLConverter in the bin directory of your JDK. The following site gives directions on how to use it:
http://java.sun.com/products/plugin/1.3/docs/htmlconv_01.html
If you are putting the applet up on the web maybe you should consider rewriting it so that it only uses packages supported by the JDK1.1 That way the user will automatically be able to view the applet without downloading any plugin and you will not need to convert the HTML file.
I hope this helps,
RC

Similar Messages

  • Java 1.1.5 applets don't run in Netscape 6.1/6.2

    I try to access a website with java-applets.
    With Netscape 4.7x it's no problem. Java-Console says "Java 1.1.5". No java-plugin's installed.
    With IE 5.x and 6 no problem.
    Java Virtual Machine Build 3234 is installad
    Systems NT4.0 and Win2000
    With Netscape 6.1 and 6.2 those applets don't run (there is only a grey-area open where the applet should build up the content). I've seen there are couple of java-plugin's loaded in the Netscape 6 (NPOJI600.dll, NPJava130_01.dll, NPJava130_01a.dll, NPJava130_01b.dll and NPJava130_01c). As an idea I temporarly deleted them in the hope it would use JVM, as I suppose happens in Netscape 4.7x, were no java-plugin's are installed. But unfortunately it doesn't work either. It looks like Netscape 6.x can not refer to those java-components that the Netscape 4.7x uses.
    Can I get somewhere the missing old plugin (1.1.5) or is there another way to make it work?
    My search in java.sun.com told me that there seems to be no java 1.1.5 at all, so how can
    Netscape talk about 1.1.5?
    Thanks for any help....
    Peter
    PS) I have no experience in Java at all.

    Hello,
    If you look at the release notes of Netscape they mention that Netscape 6.x will not run Java codes unless there 1.3.0_01 and above
    Sometime you wonder where they get these ideas, that means that if you have an old applet it won't run with the new browser. I guess they never heard about backward compatibility
    Yanick

  • Sometimes a plugin-container.exe instance starts hogging a ton of memory -- I would like to know which plugin is running inside that plugin-container without having to one-by-one disable the plugins. Which process called plugin-container.exe?

    As described above, I have several instances of plugin-container.exe running, which is OK. It would make me feel safer to know which plugins are running inside each of these, since I would be better able to know whether there is malware running inside one of them, or which website might have made the process start hogging memory.
    I am a power user, I usually have 80-100 tabs open, and of course it is hard to track the website or plugin down without having to waste a lot of time.
    Could you provide in future releases this information?
    Is it already available under one of the about: pages (e.g. config, plugins, memory, etc?)

    Thanks Efreak! <br><br>
    Maybe I was not clear. I usually have 4-5 plugin-container.exe processes running. I know now that the large one that hogs is the Adobe Flash player, but, for example I don't know which plug-in initiated the other plugin-container.exe instances.<br><br>
    One of them actually says "googletalkplugin.exe" if you dig deep, which is OK. At least I know why the plugin-container.exe was started. But there are other instances that are just there and there is no way to figure out which plug-in initiated it.<br><br>
    This would of course also help figure out if it is really the Adobe Flash plug in that is hogging all the memory, OR even if within Firefox in the about: pages one could figure out which TABS are using which plug-ins.
    Like that you could freely choose to terminate the process directly, or close the TAB.<br><br>
    1) What I am looking for is a way to determine which plug-in is running under which instance of plugin-container.exe<br>
    2) Additionally it would be great to have a summary of which TABS are using which plugins (e.g. in the about:plugins page or yet another about: page)
    <br><br>
    Thank you

  • Hi. My iMac hard drive is running Mavericks.  I have an old version of Quark Xpress (3.32) which won't run in Mavericks.  Can I partition my hard drive and run an older system on one partition, so I can access my Quark?  Is that possible?

    Hi. My iMac hard drive is running Mavericks.  I have an old version of Quark Xpress (3.32) which won't run in Mavericks.  Can I partition my hard drive and run an older system on one partition, so I can access my Quark?  Is that possible?

    Hi ancelau,
    QuarkXPress 3 is a Classic Mac OS application, so you need a version of OS X that still supports Classic. I believe 10.4 was the last one.
    So if you have an iMac that boots with 10.4, then yes that is possible. I doubt though that newer Macs boot with OS X 10.4.
    So why don't you upgrade QuarkXPress 3 to a newer version? I am not just asking that because I want you to spend money with us.
    Typically using software that was released almost 20 years ago is just feasible when you keep an environment that was current at the time of release or a few years after, so an older Mac with a operating system present at that time. 20 years in IT is a lot.
    So my opinion is that on a new Mac with a brand new operating system you need to use something a bit more current.
    How about QuarkXPress 9 (released 3 years ago) or QuarkXPress 10? You are better off with v9, as QuarkXPress 10 only opens v7 and higher (whereas QuarkXPress 9 opens v3.1 and higher).
    Or - I am even happy to make an exception - upgrade to 9 and we give you 10 for free? Let me know please.
    Thanks
    Matthias

  • I start the computer the screen has blue vertical stripes and says that the Adobe Air application can not be found. Some of my programs don't run and say: You: Error access violation at 0x0055F525

    I start the computer the screen has blue vertical stripes and says that the Adobe Air application can not be found. Some of my programs don't run and say:
    You: Error access violation at 0x0055F525. I reinstalled Adobe Air. No change. I went to the Adobe webside and they said to repair it with a program. I bought RegCure. Didn't change anything. What to do?

    Hello cor-el, thanks for your reply. I changed my settings for downloads to desktop and it has appeared on there. When I double click I am asked which program I want to open file. I click firefox and another box "opening install" says I have chosen to open the file which is an application and do I want to save it. This is the only real option so I press save file. I get a box saying this is an executable file which may contain viruses - do you want to run. I press ok and the final box showing C drive file name and desktop appears stating application not found.
    This happens the same whenever I try to install.
    To my untrained eye the application is not being recognised as an application and I cannot work out how to get it to do that.
    My plugin is still showing as out of date.
    Is there anything you could suggest. Thanks for your time.

  • Any good way to find out which process is running on which CPU, how long it

    Hi All
    any good way to find out which process is running on which CPU, how long it took, how many threads it has forked, which thread went to which CPU, etc. .
    RPS
    Message was edited by:
    RajeshPS

    Hi All
    any good way to find out which process is running on
    which CPU, how long it took, how many threads it has
    forked, which thread went to which CPU, etc. .Because the scheduler moves threads from CPU to CPU all the time, that would be a lot of information to store. I don't know any easy way to gather it.
    Under Solaris 10, you could write a dtrace script that noted every time one of the processes thread was enqueued or dequeued on a cpu and post-process that.
    That's probably the best way.
    Darren

  • The installer don't run when install oracle 9.2.0.1 on redhat 9 at 41%

    The installer don't run when install oracle 9.2.0.1 on redhat 9 at 41%
    just installed component of 'oracle intermedia ',the installer don't go on.i wait it pass five hour,but the installer's process still on 41%
    my set shmmax 1G and my physics memory is 512m
    please help me !

    Oracle is NOT certified on RedHat 9, only on RedHat AS 2.1. It is possible to make it work though. Refer to the following web site which has a very good list of problems and work arounds for installing Oracle on RedHat:
    www.puschitz.com

  • I have an iMac 21.5" which is currently running 10.7. It takes between 5-10minutes to boot into system and i have noticed a continuous error log on console: 12/3/2014 5:17:49.000 PM kernel: USBF:     1586.748     AppleUSBHubPort[0xffffff800e51b600]::Fatal

    I have an iMac 21.5" which is currently running 10.7. It takes between 5-10minutes to boot into system and i have these console error messages  listed below:
    12/3/2014 5:17:49.000 PM kernel: USBF:          1586.748          AppleUSBHubPort[0xffffff800e51b600]::FatalError - Port 2 of Hub at 0xfa110000 reported error 0xe00002c0 while doing clearing port feature (2)
    12/3/2014 5:17:49.000 PM kernel: USBF:          1587. 26          AppleUSBHubPort[0xffffff800f55a800]::FatalError - Port 3 of Hub at 0xfa110000 reported error 0xe00002c0 while doing clearing port feature (1)
    12/3/2014 5:17:49.000 PM kernel: USBF:          1587. 27          AppleUSBHubPort[0xffffff800f575200]::FatalError - Port 1 of Hub at 0xfa110000 reported error 0xe00002c0 while doing clearing port feature (1)
    12/3/2014 5:17:53.000 PM kernel: USBF:          1590.840          AppleUSBHubPort[0xffffff800e51b600]::FatalError - Port 1 of Hub at 0xfa110000 reported error 0xe000404f while doing getting port status (4)
    12/3/2014 5:17:53.000 PM kernel: USBF:          1590.840          AppleUSBHubPort[0xffffff800e51b600]::FatalError - Port 1 of Hub at 0xfa110000 reported error 0xe00002c0 while doing clearing port feature (2)
    12/3/2014 5:17:54.000 PM kernel: USBF:          1591.122          AppleUSBHubPort[0xffffff800f55a800]::FatalError - Port 2 of Hub at 0xfa110000 reported error 0xe00002c0 while doing clearing port feature (1)
    Any help as i notice it has something to do with the usb but i cant tell which device. also it has been behaving the same in Mountain Lion as well. Any help will be greatly appreciated.

    If you don't have a hub attached, then I suggest a visit to an Apple repair station. I don't have one and don't see any of those kinds of messages in any Console log.

  • TS4268 iMessage don't run but I paid 30 cent for activation. Solutions?!?

    iMessage don't run but I paid 30 cent for activation. Solutions?!?
    Thanks

    In main() when you coded Thread.sleep(..) you wanted main thread to sleep so your xmitt could run. I think you can leave it as it is even with your terminating button.
    I do not want to critisize but it looks like your concept is wrong. Usually this kind of program have kind of diffrent design. Not going into details like this:
    class Xmitt implements Runnable {
    volatile boolean keepRunning;
    other members ....
    public void run() {
    transmit();
    public void transmit() {
    keepRunning = true;
    while(keepRunning) {
    try{...}
    catch{}
    public void stopTransmitting() {
    keepRunning = false;
    //maybe Thread.currentThread().interrupt() or stop() //which is deprecated
    public class TransTest extends JPanel {
    Xmitt xmitt;
    JButton start;
    JButton stop;
    public TransTest() {
    add buttons with actionlisteners:
    if(startbutton) {
    Thread xmittthread = new Thread(xmitt);
    xmittthread.start();
    if(stopbutton) {
    xmitt.stopTransmitting();
    public static void main(String[] args) {
    TransTest tt = new TransTest();
    JFrame f = new JFrame("Transmitter");
    f.setContentPane(tt);
    f.setSize(..);
    f.setVisible();
    System.exit(0);
    You can use other methods then boolean to stop if there are i/o operations which can be tough to interrut.
    Anyway, to implement this program nicely, you need to learn more about threads, it's not that easy.
    Happy transmitting!

  • Select rows from the table which don't exist in another table

    Hi, in this relatively simple task I have some problem. I need to get the records from the T1 which don't exist in T2, based on some criteria.
    here is my query:
    select a.ordernum, sum(totchg), b.tracknum, rownum from T1 a, T2 b where 1=1 and a.ordernum not in( select ordernum from T2 ) and entrydate between to_date('06/23/2007','MM/dd/yyyy') and to_date('06/30/2007','MM/dd/yyyy') group by a.ordernum, b.tracknum, rownum
    it suppose to return me "TRACKNUM" empty, however it's being returned populated.
    I also tried :
    select a.ordernum, sum(totchg),b.tracknum, rownum from T1 a,
    T2 b where[b] not exists( select '1' from T2 where a.ordernum = b.ordernum )
    and entrydate between to_date('06/23/2007','MM/dd/yyyy') and to_date('06/30/2007','MM/dd/yyyy') group by a.ordernum, b.tracknum, rownum
    the results are the same.
    please advise.

    You are trying to get a returned value field from T2 when you just said that the
    records returned from Only T1 are not found in T2, therefore no T2 record to return.
    You only get T1 records where the Ordernum key is not found in T2.
    select ordernum, tracknum, rownum, sum(totchg)
    from T1
    where ordernum not in( select ordernum from T2 )
    and (entrydate between to_date('06/23/2007','MM/dd/yyyy') and
    to_date('06/30/2007','MM/dd/yyyy') )
    group by ordernum, tracknum, rownum

  • I am trying to edit my music list and then sync it to my iPhone 5 so I don't run out of storage space. However, I see the check marks on the iTunes library but am unable to uncheck them? How do I manually edit what will be synced to my phone?

    I am trying to edit my music list and then sync it to my iPhone 5 so I don't run out of storage space. However, I see the check marks on the iTunes library but am unable to uncheck them? How do I manually edit what will be synced to my phone? (the check marks are not bolded, does this mean they are not in my library but only on my phone?)

    You uncheck the music in your iTunes library on your computer and along with sync only checked songs and videos selected under the Summary selection for your iPhone sync preferences with iTunes, only checked songs in your iTunes library will be transferred to your iPhone or remain on your iPhone and the unchecked songs in your iTunes library that are currently on your iPhone will be removed when syncing.
    Or make use of iTunes playlists and choose selected playlists, albums, artists under the Music selection for your iPhone sync preferences with iTunes and select the playlists below that you want transferred to your iPhone.

  • I have an early 2011 MacBook Pro which has been running slow for a while. After looking at responses to similar problems I have downloaded and run EtreCheck and will post the output. Please can someone help me with what it all means.Thanks in advance

    I have an early 2011 MacBook Pro which has been running slow for a while. After looking at responses to similar problems I have downloaded and run EtreCheck. Please can someone help me with what it all means.
    Thanks in advance.
    EtreCheck version: 1.9.15 (52)
    Report generated 19 September 2014 08:07:14 GMT+8
    Hardware Information: ?
      MacBook Pro (13-inch, Early 2011) (Verified)
      MacBook Pro - model: MacBookPro8,1
      1 2.3 GHz Intel Core i5 CPU: 2 cores
      4 GB RAM
    Video Information: ?
      Intel HD Graphics 3000 - VRAM: 384 MB
      Color LCD 1280 x 800
    System Software: ?
      OS X 10.9.4 (13E28) - Uptime: 0 days 0:4:29
    Disk Information: ?
      Hitachi HTS545032B9A302 disk0 : (320.07 GB)
      S.M.A.R.T. Status: Verified
      EFI (disk0s1) <not mounted>: 209.7 MB
      Macintosh HD (disk0s2) / [Startup]: 319.21 GB (147 GB free)
      Recovery HD (disk0s3) <not mounted>: 650 MB
      MATSHITADVD-R   UJ-898 
    USB Information: ?
      Apple Inc. FaceTime HD Camera (Built-in)
      Apple Inc. BRCM2070 Hub
      Apple Inc. Bluetooth USB Host Controller
      Apple Inc. Apple Internal Keyboard / Trackpad
      Apple Computer, Inc. IR Receiver
    Thunderbolt Information: ?
      Apple Inc. thunderbolt_bus
    Gatekeeper: ?
      Mac App Store and identified developers
    Kernel Extensions: ?
      [not loaded] com.seagate.driver.PowSecDriverCore (5.2.4 - SDK 10.4) Support
      [not loaded] com.seagate.driver.PowSecLeafDriver_10_4 (5.2.4 - SDK 10.4) Support
      [not loaded] com.seagate.driver.PowSecLeafDriver_10_5 (5.2.4 - SDK 10.5) Support
      [not loaded] com.seagate.driver.SeagateDriveIcons (5.2.4 - SDK 10.4) Support
      [loaded] com.sophos.kext.sav (9.1.55 - SDK 10.7) Support
      [loaded] com.sophos.nke.swi (9.1.50 - SDK 10.8) Support
    Launch Daemons: ?
      [loaded] com.adobe.fpsaud.plist Support
      [loaded] com.microsoft.office.licensing.helper.plist Support
      [running] com.sophos.autoupdate.plist Support
      [running] com.sophos.configuration.plist Support
      [running] com.sophos.intercheck.plist Support
      [running] com.sophos.notification.plist Support
      [running] com.sophos.scan.plist Support
      [running] com.sophos.sxld.plist Support
      [running] com.sophos.webd.plist Support
      [running] com.trusteer.rooks.rooksd.plist Support
    Launch Agents: ?
      [loaded] com.divx.dms.agent.plist Support
      [loaded] com.divx.update.agent.plist Support
      [running] com.sophos.uiserver.plist Support
      [running] com.trusteer.rapport.rapportd.plist Support
    User Launch Agents: ?
      [loaded] com.adobe.ARM.[...].plist Support
      [running] com.amazon.music.plist Support
      [loaded] com.google.keystone.agent.plist Support
      [not loaded] jp.co.canon.Inkjet_Extended_Survey_Agent.plist Support
    User Login Items: ?
      iTunesHelper
      TomTomHOMERunner
      AdobeResourceSynchronizer
      Dropbox
    Internet Plug-ins: ?
      FlashPlayer-10.6: Version: 15.0.0.152 - SDK 10.6 Support
      DivX Web Player: Version: 3.2.1.977 - SDK 10.6 Support
      AdobePDFViewerNPAPI: Version: 11.0.09 - SDK 10.6 Support
      AdobePDFViewer: Version: 11.0.09 - SDK 10.6 Support
      Flash Player: Version: 15.0.0.152 - SDK 10.6 Support
      EPPEX Plugin: Version: 10.0 Support
      Default Browser: Version: 537 - SDK 10.9
      OVSHelper: Version: 1.1 Support
      QuickTime Plugin: Version: 7.7.3
      SharePointBrowserPlugin: Version: 14.4.4 - SDK 10.6 Support
      iPhotoPhotocast: Version: 7.0 - SDK 10.7
    Safari Extensions: ?
      Ultimate
    Audio Plug-ins: ?
      BluetoothAudioPlugIn: Version: 1.0 - SDK 10.9
      AirPlay: Version: 2.0 - SDK 10.9
      AppleAVBAudio: Version: 203.2 - SDK 10.9
      iSightAudio: Version: 7.7.3 - SDK 10.9
    iTunes Plug-ins: ?
      Quartz Composer Visualizer: Version: 1.4 - SDK 10.9
    3rd Party Preference Panes: ?
      Flash Player  Support
      Perian  Support
      Trusteer Endpoint Protection  Support
    Time Machine: ?
      Skip System Files: NO
      Auto backup: YES
      Volumes being backed up:
      Macintosh HD: Disk size: 297.29 GB Disk used: 160.38 GB
      Destinations:
      Data [Network] (Last used)
      Total size: 2 TB
      Total number of backups: 99
      Oldest backup: 2012-04-20 17:05:32 +0000
      Last backup: 2014-09-18 23:49:25 +0000
      Size of backup disk: Excellent
      Backup size 2 TB > (Disk size 297.29 GB X 3)
      Time Machine details may not be accurate.
      All volumes being backed up may not be listed.
    Top Processes by CPU: ?
          6% InterCheck
          5% iCalExternalSync
          3% WindowServer
          2% CalendarAgent
          2% SystemUIServer
    Top Processes by Memory: ?
      152 MB SophosScanD
      147 MB InterCheck
      106 MB SophosAntiVirus
      66 MB Dropbox
      57 MB com.apple.iTunesLibraryService
    Virtual Memory Information: ?
      161 MB Free RAM
      1.55 GB Active RAM
      1.41 GB Inactive RAM
      902 MB Wired RAM
      611 MB Page-ins
      0 B Page-outs

    Uninstall Trusteer software
    http://www.trusteer.com/support/uninstalling-rapport-mac-os-x
    Remove Sophos
    https://discussions.apple.com/message/21069437#21069437

  • Sharepoint 2013 - Which Server Should Run Microsoft SharePoint Foundation Sandboxed Code Service

    We have just deployed Sharepoint 2013 and also CRM 2011..
    Our Sharepoint 2013 Environment has a WFE and an APP server and we have a CRM 2011 box.
    We have been getting the following error in IE when Users in CRM are clicking on the Document Link under accounts which links to Sharepoint 2013
    "This Content cannot be displayed in a frame
    To help protect the security of information you enter into this website, the publisher of this content does not allow it to be displayed in a frame."
    It seems like it is a IE Security Issue, but I am suspecting it could be the Microsoft SharePoint Foundation Sandboxed Code Service.
    Which server should be running the Microsoft SharePoint Foundation Sandboxed Code Service| WFE or APP.
    Also which server should run the Windows Service: SharePoint User Code Host
    Thank you in advance.

    Hi,
    Please have a look at the following post:
    http://technet.microsoft.com/en-us/library/jj219591.aspx
    As it describes, the recommendation is for both services to start it on the Web Front End servers.
    Cheers,
    Vincent

  • I am trying to use a site that i have to do homework on but my security settings keep blobking some applet in needs to run for it to work.

    I am trying to use a site that i have to do homework on but my security settings keep blocking some applet in needs to run for it to work. I have tried to make exceptions in the security settings but it has not worked.

    There are other things that need your attention.
    Your System Details List shows multiple Flash plugins.
    * Shockwave Flash 14.0 r0
    *Shockwave Flash 11.6 r602
    You can find the installation path of all plugins on the <b>about:plugins</b> page.
    *http://kb.mozillazine.org/Issues_related_to_plugins#Identifying_installed_plugins
    You can check the Flash player installation folder for multiple Flash player plugins and remove older version(s) of the plugin (NPSWF32) and possibly (re)install the latest Flash player.
    *(32 bit Windows) C:\Windows\System32\Macromed\Flash\
    *(64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\

  • How to find out which server is running on which port

    hi all,
    how to find out which server is running on which port, i want to know both
    from front end and backend?
    thanks and regards
    srikanth

    The best source to get all the ports you have is the Context Files.
    All ports are defined in the Context Files through "AutoConfig Variable". You can get the list of those variables by referring to the following note under "What is the port pool? What if I want to give a specific value to a Server Port?"
    Note: 216664.1 - FAQ: Cloning Oracle Applications Release 11i
    https://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=216664.1
    You can also get that list via OAM.
    Referring to the installation log file should also be helpful (Unless you have changed any of the ports after the installation).

Maybe you are looking for

  • Updating the OLD open items of a Customer in the Report Cash Man.& Forecast

    Hi All, I've filled the "Cash Managemeng Group" in the master data of a Customer. The report Cash Manag.& Forecast doesn't update its old open line Items. Only the documents successive to the insertion of the "Cash Managemeng Group" in the master dat

  • I need a solution for a lab view apllication and installer problem

    I ,ve already deployed an application and an installer, when i run the executable and the installer on my laptop it run well, but when i run them on a computer that does'nt have a labview it gives me a messege says that i need to install the labview

  • Problems sharing internet connection - works only one way...

    hey all, i'm having a problem sharing my internet connection between our "new" iBook G4 and "old" iMac G5. (both machines are running 10.4.10.) i've seen several posts here that seem related, but no answers that have worked in my case. here's the gis

  • Employee Photo enclosing

    Hi everyone, Please explain me how i enclose the photo of an employee.Infotypes usable in it.It would be a great help.

  • Gmail Exchange Activesync Now Works??

    So I had exchange activesync set up through gmail for my calendar and I had the mail turned on and it always gave an error because it didnt work with gmail. Well today all of a sudden it has started bringing the mail through. Anyone know if it offici


HashFlare