ARP table not populating mac address for previously reachable IP address

Router has been online and working fine with one BGP neighbor for almost 2 years and no downtime.  2 weeks ago, added a 2nd BGP peer.  Everything worked fine for 2 weeks, then all of a sudden yesterday the 2nd BGP peer is disconnected and does not come back.  ISP checks and sees everything looks fine on their end.  We cannot even ping each other now.
Upon investigation, the ARP table is not even populating the MAC address for the BGP peer IP anymore (same local subnet).  Stays "incomplete" in the table no matter what we do, including clearing arp table, changing IP address, etc.
Plug a laptop directly into the 2nd BGP peer FE port and replicate the IP addressing.  Laptop cannot ping Router, but Router CAN ping laptop.  Check ARP table, but STILL no mac address assigned and now not even the ARP table showing "incomplete".
Thinking it could be the FE interface, switch to the 2nd FE interface and perform same laptop test, this time with arbitrary IP addressing.  Now cannot ping each other, no MAC in ARP table.
End up rebooting the router and lo-and-behold, everything is working normally again.  2nd BGP peer peers up instantly.
I should also mention that the 1st BGP peer worked flawlessly throughout, taking all the Internet load and having no issues throughout.
Also, the FE ports for the 2nd BGP peer are on an HWIC FE card plugged into the router.  The 1st BGP peer is plugged into the built-in GE interface.  2901 running: c2900-universalk9-mz.SPA.151-4.M4.bin
Lastly, no router resource issues, no error messages, no logs.  Just the BGP peer disconnecting.
I have never, in 20 years working with Cisco routers seen something like this before.  This is the most fundamental aspect of IP and Ethernet that was not working.
Has anyone ever seen this behavior before??
Here is the router config (IP's changed):
version 15.1
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service internal
service sequence-numbers
boot-start-marker
boot-end-marker
logging buffered 150000
aaa new-model
aaa authentication login LAUTHEN local
aaa authentication login TAUTHEN local group tacacs+ enable
aaa authorization console
aaa authorization exec LAUTHOR local if-authenticated
aaa authorization exec TAUTHOR local group tacacs+ if-authenticated
aaa session-id common
clock timezone PST -8 0
clock summer-time PDT recurring
no ipv6 cef
no ip source-route
ip cef
no ip domain lookup
multilink bundle-name authenticated
username ubiadmin privilege 15 secret 4 .JbeuWXuZvchrG0OL.5BftFtqrrEyxcnVHn5rIuCnTk
username umitsnoc01 privilege 15 secret 4 cUmoRUjey9O1x.wk9S.kleX.iAAhCwihupr6Z98p6OA
redundancy
ip ssh version 2
track 1 interface GigabitEthernet0/0 line-protocol
class-map match-any AutoQoS-VoIP-RTP-Trust
 match access-group name SIP-Media-INBOUND
class-map match-any AutoQoS-VoIP-Control-Trust
 match ip dscp cs3
 match ip dscp af31
class-map match-any Customer-Voice
 match access-group name Customer-VPNs
class-map match-any media
 match access-group name SIP-Media
class-map match-any signaling
 match access-group name SIP-Signaling
policy-map AutoQoS-Policy-Trust
 class AutoQoS-VoIP-RTP-Trust
  priority percent 70
 class AutoQoS-VoIP-Control-Trust
  bandwidth percent 5
 class class-default
  fair-queue
policy-map queue
 class signaling
  bandwidth percent 5
 class media
  priority percent 50
 class Customer-Voice
  priority percent 40
 class class-default
  fair-queue
policy-map shape
 class class-default
  shape average 10000000
  service-policy queue
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
interface GigabitEthernet0/0
 description BGP Peer 1
 ip address 2.2.2.2 255.255.255.252
 no ip redirects
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
 service-policy output shape
interface GigabitEthernet0/1
 description LAN
 ip address 1.2.3.4 255.255.255.0
 no ip redirects
 ip flow ingress
 ip flow egress
 standby 255 ip 1.2.3.1
 standby 255 priority 105
 standby 255 preempt
 standby 255 mac-address 1a2b.3c4d.5e6f
 standby 255 track 1 decrement 10
 duplex auto
 speed auto
 service-policy output AutoQoS-Policy-Trust
interface FastEthernet0/0/0
 description BGP Peer 2
 ip address 1.1.1.1 255.255.255.252
 ip flow ingress
 ip flow egress
 duplex full
 speed 100
 service-policy output shape
interface FastEthernet0/0/1
 no ip address
 shutdown
 duplex auto
 speed auto
router bgp 7777
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 network 1.2.3.0 mask 255.255.255.0
 neighbor 1.1.1.2 remote-as 5555
 neighbor 1.1.1.2 update-source FastEthernet0/0/0
 neighbor 1.1.1.2 prefix-list L3-DEFGW in
 neighbor 1.1.1.2 route-map L3-LPREF-IN in
 neighbor 2.2.2.1 remote-as 6666
 neighbor 2.2.2.1 ebgp-multihop 2
 neighbor 2.2.2.1 update-source GigabitEthernet0/0
 neighbor 2.2.2.1 send-community
 neighbor 2.2.2.1 prefix-list COLO-DEFGW in
 neighbor 2.2.2.1 route-map COLO-LPREF-IN in
 neighbor 2.2.2.1 route-map COLO-OUT out
ip forward-protocol nd
ip bgp-community new-format
ip as-path access-list 5 permit _5555_
ip as-path access-list 5 deny .*
ip as-path access-list 10 permit ^6666$
no ip http server
no ip http secure-server
ip flow-top-talkers
 top 50
 sort-by bytes
ip route 0.0.0.0 0.0.0.0 1.1.1.2 254 name L3
ip route 0.0.0.0 0.0.0.0 2.2.2.1 255 name COLO1
ip route 10.0.0.0 255.0.0.0 10.10.10.10 name FW_OUTSIDE
ip tacacs source-interface GigabitEthernet0/1
ip access-list standard SNMP_SOURCES
 permit 12.12.12.0 0.0.0.255
 deny   any log
ip prefix-list L3-DEFGW seq 5 permit 0.0.0.0/0
ip prefix-list COLO-DEFGW seq 5 permit 0.0.0.0/0
ip prefix-list COLO-LPREF-OUT seq 5 permit 1.2.3.0/24
route-map COLO-LPREF-IN permit 5
 match as-path 5
 set local-preference 250
route-map COLO-LPREF-IN permit 10
 set local-preference 150
route-map COLO-LPREF-IN permit 20
route-map COLO-OUT permit 10
 match ip address prefix-list COLO-LPREF-OUT
 set as-path prepend 7777 7777 7777
 set community 29795:1004
route-map COLO-OUT permit 20
route-map L3-LPREF-IN permit 10
 match as-path 10
 set local-preference 200
route-map L3-LPREF-IN permit 20
 set local-preference 150
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps vrrp
snmp-server enable traps flowmon
snmp-server enable traps transceiver all
snmp-server enable traps ds1
snmp-server enable traps call-home message-send-fail server-fail
snmp-server enable traps tty
snmp-server enable traps license
snmp-server enable traps envmon
snmp-server enable traps ethernet cfm cc mep-up mep-down cross-connect loop config
snmp-server enable traps ethernet cfm crosscheck mep-missing mep-unknown service-up
snmp-server enable traps flash insertion removal
snmp-server enable traps mac-notification
snmp-server enable traps aaa_server
snmp-server enable traps cef resource-failure peer-state-change peer-fib-state-change inconsistency
snmp-server enable traps memory bufferpeak
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps config-ctid
snmp-server enable traps event-manager
snmp-server enable traps hsrp
snmp-server enable traps cpu threshold
snmp-server enable traps rsvp
snmp-server enable traps syslog
snmp-server enable traps vtp
snmp-server enable traps ipsla

When you were checking the ARP table was there an entry for Fast0/0/0?
HTH
Rick

Similar Messages

  • I want to use Mac Mail for my work email address, which containts multiple outbound options (i.e. hr@, me@ etc). Is there a way to set up Mac Mail to have an account with multiple outbound addresses rather than adding in multiple accounts?

    I want to use Mac Mail for my work email address, which containts multiple outbound options (i.e. hr@, me@ etc). Is there a way to set up Mac Mail to have an account with multiple outbound addresses rather than adding in multiple accounts?

    This sounds like the age old problem with keychain & Safari. I don't know of a way to solve it without using something like 1Password.
    The iOS app has it's own built in browser, so it has more control over what gets autofilled. Safari on OS X has an 1Password extension that handles account selection & autofill etc.
    Keychain is great in principle, but it quickly falls down when you need tight integration with many ID's & different use cases (work, home etc).
    I'd suggest you submit feedback to Apple about your thoughts. I did so years ago about this issue & this is how far we have come (back to the point where me.com synced passwords) :^)
    http://apple.com/feedback/macosx.html
    Other tools like lastpass or keypassx may also help if you want to truly segregate password storage, but that doesn't fix autofill, the way around that issue is to dedicate one browser for work.

  • ARP cache not adding MAC address

    Hi,
    We have a network in the company where visitors\customers can connect their PCs to pick up a IP address & access the internet via our cluster of Checkpoint firewalls. The problem we are having is that whenever somebody with a Mac tries to use this network they cannot access the internet although it works fine for all Windows based PCs. So to investigate I got hold of a IBook & made the following observations.
    The gateway provided by the DHCP servers is a IP address (192.168.48.203) on a multicast mac address that represents both of the firewalls, which in turn have a physical address of 192.168.48.201 & 192.168.48.202 respectively. This is done to provide redundancy.
    What happens on the IBook is that it picks up a DHCP address as well as the DNS & gateway address as supplied by the DHCP server, but then when you try to access the internet you have no joy. If you check the arp table you will then notice that the table have not been updated with the mac address of the 192.168.48.203 gateway. If you then manualy add the mac address of 192.168.48.203, using arp -s, it works fine or if you staticaly configure the IP address settings to use either 192.168.48.201 or 202 as gateways (which have unicast mac addresses) it also solves the problem & immediately updates the arp cache with the mac addresses of either of these two interfaces depending on which one you are using.
    We put a sniffer on the network & could see that the mac address for 192.168.48.203 is being passed on to the IBook but for some reason it just does not update the arp cache with this details. Also tried this on some of the other networks we are running that uses the same concept & the same thing happens. As I mentioned no Windows hosts are having this problem & immediately updates their arp details to include the mac address of the .203 address.
    On a Mac after obataining a DHCP address & running "netstat -r" you get the following:
    Internet:
    Destination Gateway Flags Refs Use Netif Expire
    default 192.168.48.203 UGSc 5 5 en1
    127 localhost UCS 0 0 lo0
    localhost localhost UH 9 2477 lo0
    169.254 link#5 UCS 0 0 en1
    192.168.48/22 link#5 UCS 1 0 en1
    192.168.48.203 link#5 UHRLW 4 30 en1
    192.168.51.1 localhost UHS 0 1 lo0
    Then after adding the mac address manualy it looks as follows & works fine:
    Internet:
    Destination Gateway Flags Refs Use Netif Expire
    default 192.168.48.203 UGSc 26 6 en1
    127 localhost UCS 0 0 lo0
    localhost localhost UH 9 12353 lo0
    169.254 link#5 UCS 0 0 en1
    192.168.48/22 link#5 UCS 0 0 en1
    192.168.48.203 1:0:5e:7c:0:48 UHLS 26 28 en1
    192.168.51.1 localhost UHS
    Any ideas why this is happening ?
    Regards
    IBook G4   Mac OS X (10.4.3)  

    Hi,
    I am facing exactly the same problem here with an iMac G5. I have called the apple support and the conclusion was that they have no clue for that and we should wait for an update that will hopefully resolve this.
    I was also aksing them if there was a way in the mac to set a static mac address for the gateway in the macintosh so I don't have to run the terminal and type the arp -s every time I start up. They said it is out of the kind of support they can provide... Do you have an idea on how to add a static ARP entry in the table ?
    Thank you.

  • Sh arp does not show mac address of IP --- ASA

    Hi Everyone,
    I can ping the IP from the ASA but when i do sh arp it does not show me mac address od that IP.
    Need to know the reason behind this.
    Regards
    MAhesh

    So your ASA should have a route on the inside interface to internal networks. The address of that next hop in the routing table is the one you should have in your arp table allowing you to reach non-directly-connected (subnet-wise) hosts within the scope of that route statement.
    Think through the logic - ASA pings a host. It needs to determine proper egress interface. It checks and asks "Is it reachable via a directly connected interface (most preferred route)?" Answer no. "Do I have a route statement telling me how to get to it?" Answer yes (otherwise use default). OK - so ASA sends packet out egress interface defined in that route statement to the next hop as defined in route statement and waits for reply.

  • Filter in query result table not populated by criteria previously selected.

    Hi Experts,
    I'm currently working on the the Upgrade of our BW production line from
    release 3.0b to 7.0:
    Configuration of target system
    BW system : Release 7.0
    BEx Analyser : Release 2004s, Support Package9, Patch 1, Revision 321
    Sap Gui 6.4
    We're especially trying to check the non-regression of the non-converted queries in the new system (release 7.0).
    And we get the following issue: After having selected the selection criteria in the selection window, the reminder of selected criteria is not done in the filter part of the target query result. Is it a normal behavior or not ?
    Indeed, in the previous system configuration (BW 3.0b), the user is accustomed to seeing just above his result table the selection criteria that he had previously filled in in the selection window.
    Please find herewith an example describing the problem.
    Thanks in advance for your help.

    In order to be more clear, hereunder an example:
    - I have a field untitled "Business Division"in the selection window.*
    - I fill in this field with the value "OND"
    - I execute the query with this value for this field.
    - The query result correclty appears.
    - I click on the "Filter" button to display the Filter table with the columns "Navigation pane" and "Filter criteria".
    - In the "Navigation pane", there is the field "Business Division".
    - For me, the corresponding "Filter criteria" should be the value "OND", but nothing is displayed...
    Thanks in advance foryour help.
    Regards,
    Steph

  • BSIS/BSAS tables not populated

    Dear Experts,
    I have a GL/account having too many items but FAGLL03 returns no items.
    I have found that the reason is that tables BSIS and BSAS are not being populated with line items. however tables BKPF and BSEG in addition to FAGLFLEXA are all populated.
    can you please assist why BSIS/BSAS are not populated thus FAGLL03 is not working? what is wrong with this GL account?
    Thanks for your assistance.
    Samir

    Hmmm... Is it normal FI document or it's posted through some interface? If it's normal document and the following is right:
    a) G/L account of the document is defined with 'line item' flag in this company code (SKB1 table)
    b) the document exists in BSEG
    c) BSEG-XKRES flag is 'X' on the line for this account
    Then, if all mentioned above is correct, I'd open OSS note.
    Regards,
    Eli

  • ASR901 y.1731 Latest Data Table Not Populated

    Why would SNMP data for a y.1731 test on an ASR901 not be populated in the ipslaEtherJitterLatestStatsEntry table?
    All the data in the table is being populated with zeros, even though valid tests are being performed.  There is data in the ipslaEtherJitterAggStatsEntry but only getting zeros when polling the latest table.
    I have verified that following objects exist per the MIB:
    - rttMonCtrlAdminRttType
    - rttMonEchoAdminProtocol
    Please let me know if you need anything else.

    Hi,
    Q Table is generated if we have time dependent display attributes for base Info Object where as Y Table is generated if we have at least one attribute defined as time-dependent navigational attribute.
    Normally both Q and Y table contain same no.of entries, however in your case the reason could be that SID for some records might not have generated(assuming this could be the reason) hence you are seeing this discrepancy in record count.
    Also before you proceed with any action in RSRV, you can check the records which are missing from Y table and analyze the reason for it. In RSRV if there is any is inconsistency we can see reason(error message) for inconsistency which helps us to understand the cause for this inconsistency.
    By analyzing this way we can know reason for discrepancy.
    Regards,
    Venu Gopal

  • GLPCA table not getting updated correctly for VBUND

    Hi All,
    I have come across one issue that the value of trading partner field (VBUND) in table GLPCA are not getting updated correctly for document type KP.
    In vendor master this field has different value versus it is showing in GLPCA-VBUND.
    Does any one knows about ?
    Thanks for your help on it.
    Regards,
    Manoj

    Hi Sridhar,
    Thanks for your response on it.
    This note is not applicable for our system as we are working on 4.0B with support pack 52.
    Also we are getting this worng update of this field (GLPCA-VBUND) while doing MR11 creating document with doc. type KP. This value is not picking from vendor master (LAF1-VBUND) and randamly picking any value. Not sure from where ?
    Please advise your thought.
    Thanks,
    Manoj

  • Higher Edu.Cess is not populating in GR for Import POs

    Hi Gurus,
    could you please let me know the exact reason why the higher education cess is not populating in Import P O MIGO. We are using TAXINN Procedure and all the excise default setting has been completed. We have not maintained any condition records for import orders( as  suggested by SAP India) All other conditons like CVD, AED & ECESS is getting populated in MIGO.
    Please advise.
    Regards
    Vrish

    Hi Vrish,
    This is a problem when i was also doing an implementation project.
    There is a Note for this provided by SAP...
    have you got ADC Condition at the last in Maintain Excise defaults customizing setting
    Note 964190 - ADC on domestic purchase of imported goods -
    USe this note in case if u have not got that ADC condition there... and also please check the relavent notes as well..
    Please maintian the Condition types relevant to these conditions in this SPRO setting
    Thanks & Regards,
    Kiran
    Edited by: Kiran. V on Apr 29, 2008 2:39 PM

  • Values not populated in S_ALR_87012806 for a specific cost element

    Hi all,
    Postings made to specific cost element are not populated in report S_ALR_ 87012806. Can anyone throw some light on this?
    Thanks
    Shravan

    Hi Krishna
    I dont think "Cost Accounting > LIne Item" would work for Master Data
    You can use exit COOPA_01 (SMOD) > Include ZXAUFU08 (Part of EXIT_SAPLKOAU_002)... I have used this for similar purposes in the past
    Regards
    Ajay M
    Edited by: Ajay Maheshwari on Nov 12, 2010 12:45 PM

  • ESS Bsns pkg  Bnfts &Pymnt - Overview Drop down and table not populated

    Hi All,
      We have configured ESS business package. Payslips in form of PDF are available in Benefits and payment.
    Overview dropdown and table are not getting populated.
    I checked context node rem, vcdata and attribute overview_sel in VcRem2Selection comp.
    They are not populated at any place as well. How does this work?
    Please guide
    Regards,
    Ganga

    Hi Gangadharayya,
    There are 2 ways of populating the dropdown.
    Either u can create a simple type and bind the attribute to the SimpleType, or use the class ISimpleTypeModifiable and IModifiableValueSet to populate the values at run-time.
    Hope this helps u
    Regards,
    Poojith M V

  • Sending to a group:  Which address for member with multiple addresses?

    Hi. I've created a Group of people to send emails to. Some of these people have more than one email address. How do I change the default email address for individuals within a group?
    Thanks!

    Searching for "group address" (without the quotes) in Address Book Help would lead you to the following article:
    Selecting which addresses to use for members of a group
    iMac G5 17" (iSight)   Mac OS X (10.4.4)  

  • PO Address for the Partner Order address.

    Hi,
    We have a problem with the address in the PO. We want to complete automatically the address from the partner Order address that has different address than the vendor.
    So Vendor Number 1000 address in Madrid has the Partner Order address 1001 with address in Barcelona. We want to complete the address in the PO with the partner Order address from Barcelona. However the system always gets the address for the vendor in Madrid.
    How can we do this process? The standard should be works like this. Otherwise we have to develop this procedure. But Are there any easy way by program to complete the address in the PO process or after that?
    Thank you and best regards.

    the address from the OA partner is taken for the print out, where and why do you want to maintain it in the PO?

  • CDHRD table not populated for DFKKCOLL entries

    Hi All,
    On checking table TCDOB, the Change doc. object maintained for table DFKKCOLL is INKASSO_01. Even after changing the entries in DFKKCOLL table, CDHRD table has no entries for INKASSO_01. Can you please suggest what the problem might be?
    Thanks,
    Vaasuu

    Check object INKASSO_01 in SCDO transaction.
    Whether generation information exist for this object and for its includes and function module?
    If no u2013 execute "Generate update pgm." for this object.
    If yes u2013 may be will help you following notes (depending on release of components of your system):
       - 788337 - Change document not created during clearing/reversing,
       - 811604 - Coll/ agency: Change doc/ not created d/ dunning notice rev/,
       - 868128 - RFKKCOLL: An enqueue/dequeue is missing.

  • Table not populating values

    Hello All,
    I am populating Table for a Search Region and the values are not getting populated. I am altering the where clause in PFR of the CO. Please find the code in PFR.
    String eNum = pageContext.getParameter("SearchEmpNum");
    System.out.println("Employee Number " + eNum);
    System.out.println("Post initQuery ");
    OAViewObject vo = (OAViewObject)am.findViewObject("ZenPerSearchVO1");
    if (vo != null) {
    vo.clearCache();
    vo.setWhereClause(null);
    vo.setWhereClause("PERSON_ID in (select selected_person_id from hr_working_person_lists where owning_person_id = zen_person_details.get_person_id(:1))");
    vo.setWhereClauseParams(null);
    vo.setWhereClauseParam(0, eNum);
    System.out.println("Params " + eNum);
    //System.out.println("Post Clause " + vo.getQuery());
    vo.executeQuery();
    System.out.println("Post whereclause ");
    The following is the Page
    <?xml version = '1.0' encoding = 'UTF-8'?>
    <page xmlns:jrad="http://xmlns.oracle.com/jrad" xmlns:oa="http://xmlns.oracle.com/oa" xmlns:ui="http://xmlns.oracle.com/uix/ui" version="10.1.3_1312" xml:lang="en-US" xmlns:user="http://xmlns.oracle.com/jrad/user" xmlns="http://xmlns.oracle.com/jrad" file-version="$Header$">
    <content>
    <oa:pageLayout id="PageLayoutRN" amDefName="zenith.oracle.apps.hxc.asg.server.ZenPerSearchAM" windowTitle="Employee Search Window" title="Employees">
    <ui:corporateBranding>
    <oa:image id="corporateBrandingImage" source="/OA_MEDIA/FNDSSCORP.gif"/>
    </ui:corporateBranding>
    <ui:contents>
    <oa:query id="QueryRN" dispSimple="true" dispCustomized="false" dispAdvanced="false" mode="autoCustomizationCriteria" amDefName="zenith.oracle.apps.hxc.asg.server.ZenPerSearchAM" controllerClass="zenith.oracle.apps.hxc.asg.webui.ZenPersonSearchCO">
    <ui:contents>
    <oa:table id="ResultsTable" userCustomizable="true" shortDesc="Employees Assigned Table" amDefName="zenith.oracle.apps.hxc.asg.server.ZenPerSearchAM">
    <ui:contents>
    <oa:messageStyledText id="EmpNum" viewName="ZenPerSearchVO1" viewAttr="EmployeeNumber" queryable="true" sortState="ascending" prompt="Employee Number" selectiveSearchCriteria="true" initSortSeq="first" userCustomizable="true"/>
    <oa:messageStyledText id="EmpName" queryable="true" sortState="no" viewName="ZenPerSearchVO1" viewAttr="FullName" prompt="Employee" unvalidated="true" selectiveSearchCriteria="true" userCustomizable="true"/>
    </ui:contents>
    </oa:table>
    </ui:contents>
    <oa:simpleSearchPanel>
    <oa:header text="Employee Search" id="SimpleSearchHdr">
    <ui:contents>
    <oa:messageComponentLayout id="CustomSimpleSearch">
    <ui:contents>
    <oa:messageLovInput id="SearchEmpName" selectiveSearchCriteria="true" prompt="Employee Name" unvalidated="true" externalListOfValues="/zenith/oracle/apps/hxc/asg/lov/webui/ZenEmpLovRN" required="yes">
    <lovMappings>
    <lovMap id="EnameMap" lovItem="EmpName" resultTo="SearchEmpName" criteriaFrom="SearchEmpName"/>
    <lovMap id="ENumMap" lovItem="EmpNum" resultTo="SearchEmpNum" criteriaFrom="SearchEmpNum"/>
    </lovMappings>
    </oa:messageLovInput>
    <oa:messageTextInput id="SearchEmpNum" selectiveSearchCriteria="true" prompt="Employee Number"/>
    </ui:contents>
    </oa:messageComponentLayout>
    </ui:contents>
    </oa:header>
    </oa:simpleSearchPanel>
    <oa:simpleSearchMappings>
    <oa:queryCriteriaMap id="EmpNameMap" criteriaItem="SearchEmpName" resultsItem="EmpName"/>
    <oa:queryCriteriaMap id="EmpNumMap" criteriaItem="SearchEmpNum" resultsItem="EmpNum"/>
    </oa:simpleSearchMappings>
    </oa:query>
    <oa:defaultSingleColumn id="ApplyRN">
    <ui:contents>
    <oa:submitButton id="SButton" text="Save" prompt="Save">
    <ui:primaryClientAction>
    <ui:fireAction/>
    </ui:primaryClientAction>
    </oa:submitButton>
    </ui:contents>
    </oa:defaultSingleColumn>
    </ui:contents>
    </oa:pageLayout>
    </content>
    </page>

    Hi,
    Some of the column values are not getting populated or few rows which you are expecting is not getting populated?
    Could you please try the following 2 changes, in both the cases, after executing the query, print all the query and rows in the VO using the below code (change your object names accordingly).
    if(appraisalVO !=null)
    AppraisalVORowImpl appraisalVORow = (AppraisalVORowImpl) appraisalVO.first();
    if(appraisalVORow !=null)
    int attrCount = appraisalVO.getAttributeCount();
    writeLog("XXRBG",pageContext,"Attrbuute count "+attrCount);
    String[] attributeNames = appraisalVORow.getAttributeNames();
    for (int i = 0 ;i< attributeNames.length ;i++ )
    writeLog("XXRBG",pageContext," Name "+attributeNames[i] +" = "+appraisalVORow.getAttribute(i));
    1)
    instead of calling the function to get the owning_person_id, hard code the value and check you are getting the expected result.
    like,
    vo.setWhereClause("PERSON_ID in (select selected_person_id from hr_working_person_lists where owning_person_id = 54)");
    2)
    instead of the below code
    vo.setWhereClause("PERSON_ID in (select selected_person_id from hr_working_person_lists where owning_person_id = zen_person_details.get_person_id(:1))");
    vo.setWhereClauseParams(null);
    vo.setWhereClauseParam(0, eNum);
    System.out.println("Params " + eNum);
    try without binding the parameter like,
    vo.setWhereClause("PERSON_ID in (select selected_person_id from hr_working_person_lists where owning_person_id = zen_person_details.get_person_id("+eNum+"))");
    Thanks.
    With Regards,
    Kali.
    OSSi.

Maybe you are looking for

  • Itunes 11.1.2.3.1 and Windows 8.1

    I got to ask this question to see if others are having the same problem , When you plug your Iphone or Ipad into your PC ( In my case an Iphone 4S & Ipad 2 with an Asus Laptop PC running MS Windows 8.1 and Itunes version 11.1.2.3.1 installed) when yo

  • Video not working on the first run of Android app

    I couldn't find any results regarding this problem. Maybe I'm just using wrong keywords as it is difficult to explain. Has anyone else encountered that video is not working on the first run of Android app? By first run I mean directly after installin

  • How do I change the dimensions of an image? The Image Size dialog box will not allow me to change it

    How do I change the dimensions of an image? The Image Size dialog box will not allow me to change dimensions.  I am taking an online class and the Image Size dialog box looks different than the one I am seeing in Photoshop CC.  It has the option to c

  • Store and restore a sys_refcursor

    Hi I'm building a simple reporting system, and need to cache SQL results. As of the current implementation I use .NET to get a dataset and store that dataset to the database to be able to restore it later. I wondered if there is a generic way to take

  • Dynamic radio button display

    Hi all, when we click on the radio button of the selection screen if should display further more radio buttons down on the same screen, Can anybody please say me how it can be done.