Can't get the internal table values

hi all,
i have created a report in which i have DISPLAY EKPO-BANFN and EKKO-EBLEN.For this reason i have created an internal table gi_final,in which my values of both table are coming through.Following are the codes and structure of internal table:
BEGIN OF gi_final OCCURS 0,
       matnr  LIKE  ekpo-matnr,
       ematn  LIKE  ekpo-ematn, "Material Number
       txz01  LIKE  ekpo-txz01, "Mareial Description
       ktmng  LIKE  ekpo-ktmng, "Quantity
       netpr  LIKE  ekpo-netpr, "Rate
       anfnr  LIKE  ekpo-anfnr, "RFQ No.
       banfn  LIKE  ekpo-banfn, "Purchase Requisition Number
       ebeln  LIKE  ekko-ebeln, "Purcahse Order
       ekorg  LIKE  ekko-ekorg,
       bstyp  LIKE  ekko-bstyp, "Purchasing Document Category
       submi  LIKE  ekko-submi, "Collective Number
       lifnr  LIKE  ekko-lifnr, "Vendor Number
       bedat  LIKE  ekko-bedat, "Purchase Order Date
    END OF gi_final.
  select ekko~ebeln ematn txz01 ktmng banfn
  from
    ekpo
    inner join ekko on
    ekpo~ebeln eq ekko~ebeln
  into
    corresponding fields of table gi_final
  where
    ekko~ekorg  in s_ekorg  and
    ekko~ebeln  in s_ebeln  and
    ekko~submi  in s_submi  and
    ekko~lifnr  in s_lifnr.
    READ TABLE gi_final WITH KEY  ebeln = gi_final-ebeln.
    MOVE gi_final-banfn to gi_detail-banfn.
    MOVE lv_netpr     to gi_detail-netpr.
    MOVE gi_final-ematn TO gi_detail-ematn.
    MOVE gi_final-txz01 TO gi_detail-txz01.
    MOVE gi_final-ktmng TO gi_detail-ktmng.
Probelm is that when i execute it with Debugger my internal table can't get the values of EBELN and BANFN.
Thanks & Regards,
sapabappk
Edited by: sapabappk on Sep 26, 2010 10:32 AM

HI ,
BEGIN OF gi_final OCCURS 0,
       matnr  LIKE  ekpo-matnr,
       ematn  LIKE  ekpo-ematn, "Material Number
       txz01  LIKE  ekpo-txz01, "Mareial Description
       ktmng  LIKE  ekpo-ktmng, "Quantity
       netpr  LIKE  ekpo-netpr, "Rate
       anfnr  LIKE  ekpo-anfnr, "RFQ No.
       banfn  LIKE  ekpo-banfn, "Purchase Requisition Number
       ebeln  LIKE  ekko-ebeln, "Purcahse Order
       ekorg  LIKE  ekko-ekorg,
       bstyp  LIKE  ekko-bstyp, "Purchasing Document Category
       submi  LIKE  ekko-submi, "Collective Number
       lifnr  LIKE  ekko-lifnr, "Vendor Number
       bedat  LIKE  ekko-bedat, "Purchase Order Date
    END OF gi_final.
  select ekko~ebeln ematn txz01 ktmng banfn
  from
    ekpo
    inner join ekko on
    ekpoebeln eq ekkoebeln
  into
    corresponding fields of table gi_final
  where
    ekko~ekorg  in s_ekorg  and
    ekko~ebeln  in s_ebeln  and
    ekko~submi  in s_submi  and
    ekko~lifnr  in s_lifnr.
    READ TABLE gi_final WITH KEY  ebeln = gi_final-ebeln.
    MOVE gi_final-banfn to gi_detail-banfn.
    MOVE lv_netpr     to gi_detail-netpr.
    MOVE gi_final-ematn TO gi_detail-ematn.
    MOVE gi_final-txz01 TO gi_detail-txz01.
    MOVE gi_final-ktmng TO gi_detail-ktmng.
Why you are  reading gi_final table  and comparing same table field gi_final-ebeln ?
  how is gi_detail table declared   ?
just do like this
loop at  gi_final .
    MOVE gi_final-banfn to gi_detail-banfn.
    MOVE gi_final-ematn TO gi_detail-ematn.
    MOVE gi_final-txz01 TO gi_detail-txz01.
    MOVE gi_final-ktmng TO gi_detail-ktmng.
append  gi_detail .
clear gi_detail
endloop.
and From where you are getting value of    lv_netpr 
MOVE lv_netpr     to gi_detail-netpr.
then you will get data in gi_detail
Regards
Deepak.

Similar Messages

  • Getting the internal table of standard program to my custom program

    Hi All,
    I have a requirement in which i have to get the data from internal table ALV_ITAB from program HKBRO20. As this is the standard program, i have copied this program into Z custom program and using export parameter i am getting the data from internal table ALV_ITAB to my custom program (Using submit of the Z of the standard program). Can any one pls tell me whether the process i am following is correct if not pls tell me how to get the internal table from standard program to our custom program.
    the process i am following
    submit ZHBRO20 and return. IMPORT ALV_ITAB  FROM MEMORY ID 'ABC'.
    copied HBRO20 to ZHBRO20.
    Thanks,
    Raju

    Hi,
    you could also try
    FIELD-SYMBOLS: <fc> .
    CONSTANTS: c_table(21)  VALUE '(PROGRAM_NAME)INTERNAL_TABLENAME[]'.
    ASSIIGN (c_table) TO <fc>.
    Depends on the process, of course.
    Cheers,
    Stefan.

  • *How can we use the internal table in module pool programming? Clarify plz*

    If we creating a screen using the table having four fields(for e.g.). The screen has the functions of display, modify, delete, save, exit etc for the fields. The front-end of the screen having I/O fields of the table using internal table. How can we declare the internal table in the screen?

    HI,
    Create one WA for your Internal table and then map it to your fields.
    For Example,
    Data : begin of wa,
              name(10),
              age type i,
               end of wa.
    data : it like table of wa with header line.
    Then in screen create input fields with the name, age and ***.
    Then the user entered values are stored in name age and ***.
    then you can manipulate with that values using wa.
    Thanks.

  • How can i get the h:selectOneRadio value with javascript

    Hi all.
    I have this code
    <h:selectOneRadio id="color" style="font-family: Arial;font-weight:lighter;font-size: 12px" onclick="showColor()" >
    <f:selectItem itemLabel="RED" itemValue="1" />
    <f:selectItem itemLabel="BLUE" itemValue="2" />
    </h:selectOneRadio>
    And javascript function is
    function showColor()
    var tipoRelacion = document.getElementById("form:color").value;
    alert("color" + tipoRelacion);
    And what i get is that color is undefined. How can i get the value of the selected radio?
    Thanks a lot

    you just need to pass this while calling javascript function
    check this-
    <h:selectOneRadio id="color" style="font-family: Arial;font-weight:lighter;font-size: 12px" onclick="showColor(this)" >
    <f:selectItem itemLabel="RED" itemValue="1" />
    <f:selectItem itemLabel="BLUE" itemValue="2" />
    </h:selectOneRadio>
    And javascript function is
    function showColor(obj)
    var val = obj.value
    alert("color" +val);
    }

  • Pro: in RF Development  how can i get the scaned barcode value to Tcode

    Hi,
        I need to develop a custom RF settings for Scaner. I have gone through the SAP Provided documentation. SAP Has given in report we need to call Screen.
    Every thing is clear for me... creating report, screen, triggering messages, customization.. etc. <b>My question</b> is what are naming conventions i need to use. it's custom Transaction. When ever we scan the Barcode, how that value is passing to initial screen of my Program. how can i keep it in SAP Memory. once after getting the value it's anormal transaction. i can code for that. how can i get the scaned value.

    Hi!
    Most (of my) customers use their scanners in keyboard simulation mode. Than it's like typing the number (or character) of the barcode. -> You need an input (char) field. Most (all?) scanners can be programmed to add a constant at the end -> use 'enter' and you get your PAI triggered.
    Then scanning is same as typing 11 (or 13 or whatever) numbers on keyboard.
    Other option would be, using scanner in native mode. But then you need a kind of device driver, which calls SAP via RFC. Possible, but more complex (because of missing alternative 'keyboard' in case of trouble).
    What happens, if scanner can't read barcode, but user can identify numbers below -> you need anyway char-input field  reacting on keyboard, too.
    Regards,
    Christian

  • Where can I get the International Geography Information?

    Hi,
    I am designing a geography dimension table. I already have data for American and Canada. Where can I get the geography information for West Europe? Such as zip code, city, countyName, state, etc.
    Thanks a lot for any input,

    Hi SarahLiu,
    According to your description, you want to get the spatial data for Europe. Right?
    Please refer to the link below, you can download the sharpfile and upload the data into the database:
    SQL SERVER – World Shapefile Download and Upload to Database – Spatial Database
    If you have any question, please feel free to ask.
    Best Regards,
    Simon Hou
    TechNet Community Support

  • Summing the internal table values

    Hi Experts,
    I have requirement in report to add the values in the internal table based on document no.
    for example
    Document no         date                         Amount                Exchange Rate
    190000012         05.04.2009                     100                                1
    190000012         05.04.2009                     200                                1
    190000012         05.04.2009                     300                                1
    190000013         05.04.2009                     100                                1
    190000013         05.04.2009                     200                                1
    190000014         05.04.2009                     100                                1
    If i use Collect or  On change statements , the exchange rate is also adding
    Document no         date                         Amount                Exchange Rate
    190000012         05.04.2009                     600                                3
    190000013         05.04.2009                     300                                2
    190000014         05.04.2009                     100                                1
    But i want to add only the amount field not the exchange rate .Please suggest me the best solutions.
    I want to display as
    Document no         date                         Amount                Exchange Rate
    190000012         05.04.2009                     600                                1
    190000013         05.04.2009                     300                                1
    190000014         05.04.2009                     100                                1
    Thanks in advance
    satish

    hi,
    check this
    Sort itab by documentno.
    Loop at itab1.
    on change of itab1-dcno.
    clear total.
    move itab1-docno to itab2-docno.
    itab2-total = itab-amont.
    move itab1-total to itab2-total.
    move itab1-date to itab2-date.
    move itab1-rate to itab2-rate.
    flag = '  '.
    append itab2.
    clear itab2.
    else.
    itab2-total = itab2-total + itab-amont.
    endon
    Endloop.
    it will work for  adjest append statement according to the out put .
    ~linganna

  • Remote access VPN with Cisco Router - Can not get the Internal Lan .

    Dear Sir ,
    I am doing Remote Access VPN through Cisco Router. Before the real deployment, I want to simulate it with GNS3.Need you help to complete the job .Please see the attachment for Scenario, Configuration and Ping status.
    I am getting IP address when i connect through VPN client .But I can not ping to the internal lan -192.168.1.0.Need your help to sole the issue.
    Below is the IP address of the device.
    Local PC connect with Router -2 (Through MS Loopback) Router -2 Router-1 PC -01
    IP Address :10.10.10.2 Mask : 255.255.255.0 F0/01
    IP address:10.10.10.1
    Mask:255.255.255.0 F0/0
    IP Address :20.20.20.1
    Mask :255.255.255.0
    F0/1
    IP address :192.168.1.3
    Mask:255.255.255.0
    F0/0
    IP address :20.20.20.2
    Mask :255.255.255.0
    F0/1
    IP address :192.168.1.1
    Mask:255.255.255.0
    I can ping from local PC to the network 10.10.10.0 and 20.20.20.0 .Please find the attach file for ping status .So connectivity is ok from my local PC to Remote Router 1 and 2.
    Through Cisco remote vpn client, I can get connected with the VPN Router R1 (Please see the VPN Client pic.)But cannot ping the network 192.168.1.0
    Need your help to fix the problem.
    Router R2 Configuration :!
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname R2
    boot-start-marker
    boot-end-marker
    no aaa new-model
    memory-size iomem 5
    no ip icmp rate-limit unreachable
    ip cef
    no ip domain lookup
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    ip tcp synwait-time 5
    interface FastEthernet0/0
    ip address 20.20.20.2 255.255.255.0
    duplex auto
    speed auto
    interface FastEthernet0/1
    ip address 10.10.10.1 255.255.255.0
    duplex auto
    speed auto
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    control-plane
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line vty 0 4
    login
    end
    Router R1 Configuration :
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname R1
    boot-start-marker
    boot-end-marker
    aaa new-model
    aaa authentication login USERAUTH local
    aaa authorization network NETAUTHORIZE local
    aaa session-id common
    memory-size iomem 5
    no ip icmp rate-limit unreachable
    ip cef
    no ip domain lookup
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    username vpnuser password 0 strongpassword
    ip tcp synwait-time 5
    crypto keyring vpnclientskey
    pre-shared-key address 0.0.0.0 0.0.0.0 key cisco123
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    crypto isakmp client configuration group remotevpn
    key cisco123
    dns 192.168.1.2
    wins 192.168.1.2
    domain mycompany.com
    pool vpnpool
    acl VPN-ACL
    crypto isakmp profile remoteclients
    description remote access vpn clients
    keyring vpnclientskey
    match identity group remotevpn
    client authentication list USERAUTH
    isakmp authorization list NETAUTHORIZE
    client configuration address respond
    crypto ipsec transform-set TRSET esp-3des esp-md5-hmac
    crypto dynamic-map DYNMAP 10
    set transform-set TRSET
    set isakmp-profile remoteclients
    crypto map VPNMAP 10 ipsec-isakmp dynamic DYNMAP
    interface FastEthernet0/0
    ip address 20.20.20.1 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    crypto map VPNMAP
    interface FastEthernet0/1
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    ip local pool vpnpool 192.168.50.1 192.168.50.10
    ip forward-protocol nd
    ip route 10.10.10.0 255.255.255.0 FastEthernet0/0
    no ip http server
    no ip http secure-server
    ip nat inside source list NAT-ACL interface FastEthernet0/0 overload
    ip access-list extended NAT-ACL
    deny ip 192.168.1.0 0.0.0.255 192.168.50.0 0.0.0.255
    permit ip 192.168.1.0 0.0.0.255 any
    ip access-list extended VPN-ACL
    permit ip 192.168.1.0 0.0.0.255 192.168.50.0 0.0.0.255
    control-plane
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line vty 0 4
    end

    Dear All,
    I am doing Remote Access VPN through Cisco Router. Before the real deployment, I want to simulate it with GNS3.Need you help to complete the job .
    Please see the attachment for Scenario, Configuration and Ping status. I am getting IP address when i connect through VPN client .But I can not ping to the internal lan -192.168.1.0.Need your help to sole the issue.
    Waiting for your responce .
    --Milon

  • How can i use the internal table as a WHERE clause ?

    Dear Support ,
    I have one internal table that save the material information ...
    data : begin of itab ,
              matnr like mara-matnr ,
    end of itab .
    And now i want to fetch the material desription text base on this internal table .
    As i know that the "FOR ALL ENTRIES" statement is not allowed us to use "IN" this keyword ....
    So , Has another solution for this case ? I don't want to use "LOOP AT ...." this way ...
    Many thanks .
    Carlos

    Why can't you do
    SELECT MATNR MAKTX INTO TABLE ITAB2 FROM MAKT FOR ALL ENTRIES IN ITAB WHERE MATNR = ITAB-MATNR.

  • Get the master table value based on multiple fact tables

    I have an master table which has to filter data based on multiple fact tables
    In the below sample, i need to get the list of MasterTable SId in an single query for fetching data from all the fact tables with an criteria.
    Can u let me know the single query to handle the below situation
    Select count(1) from dbo.DimMaster where sid in
    (Select Master_sid from dbo.factsales where SalesDate < '20141231')
    Select count(1) from dbo.DimMaster where sid in
    (Select Master_sid from dbo.factPurchase where PurchaseDate < '20141231')
    Select count(1) from dbo.DimMaster where sid in
    (Select Master_sid from dbo.factSalary where SalaryDate < '20141231')
    Select count(1) from dbo.DimMaster where sid in
    (Select Master_sid from dbo.factMarket where MarketDate < '20141231')
    ShanmugaRaj

    Please try below:
    SELECT
    (SELECT count(1)
    FROM dbo.DimMaster
    WHERE sid IN (
    SELECT Master_sid
    FROM dbo.factsales
    WHERE SalesDate < '20141231'
    )) as C1,
    (SELECT count(1)
    FROM dbo.DimMaster
    WHERE sid IN (
    SELECT Master_sid
    FROM dbo.factPurchase
    WHERE PurchaseDate < '20141231'
    )) as C2,
    (SELECT count(1)
    FROM dbo.DimMaster
    WHERE sid IN (
    SELECT Master_sid
    FROM dbo.factSalary
    WHERE SalaryDate < '20141231'
    )) as C3 ,
    (SELECT count(1)
    FROM dbo.DimMaster
    WHERE sid IN (
    SELECT Master_sid
    FROM dbo.factMarket
    WHERE MarketDate < '20141231'
    )) as C4
    -Vaibhav Chaudhari

  • Can not get the proper angle value

    Hello,
    I have drawed a circle on the canvas control, and want to capture an arbitrary point in the circle, where the point's coordinate is determined by the "GetRelativeMouseState()" function. The whole idea is this:  once click in the circle, I can get the coordinate of the clicking point by using "GetRelativeMouseState()", then drawing a line from the circle's midpoint to the point, expecting to calculate the angle between the line and the X axis. I post the sketch to explain how the process is treated :
    the coordinate of the midpoint is (width/2, height/2), so if want to calculate the theta angle, I can get the formular: theta = atan((height/2 - yCoor) / (width/2 - xCoor)), there is a strange condition: if the line is near to the X axis (in fact, the line turn to angle exceed 135 degree (as to the counterclockwise) but there is a distinct angle between the X axis, the theta), I always get a zero angle value(the theta).
    Please help whether  the "GetRelativeMouseState()" can provide an exact position?
    David

    How are you calculating the angles? With some basic trigonometry and atan2 () function I always get the correct angles: take a look at the attached canvas.prj sample which I modified adding the necessary functions (click Draw Circle and check Angle drawing: when clicking on the canvas the program will draw the line and calculate the corresponding angle)
    Proud to use LW/CVI from 3.1 on.
    My contributions to the Developer Zone Community
    If I have helped you, why not giving me a kudos?
    Attachments:
    canvas.zip ‏10 KB

  • Splitting the internal table values

    I have a internal table with say 10000 lines i want to split it as 5000 and 5000 lines.How to code it?
    Moderator message: please try solving this yourself before asking, e.g. by studying the options of the LOOP statement.
    Edited by: Thomas Zloch on Nov 24, 2010 4:20 PM

    e.g.:
    loop at itab.
      add 1 to count.
      if count <= 500.
      move-corresponding itab to itab2.
      collec titab2.
      else.
      move-corresponding itab to itab3.
      collec titab3.
    endloop.

  • New iMac: how can I get the internal mic to turn off?

    I always have Facetime cameras and internal mics disabled for privacy. Cameras are easy to block, but the Sound pane doesn't allow me to disable the mic, only turn the input down to the bottom. Supposedly, its off, right?
    Poking around in Prefs, I saw that my supposedly "disabled" microphone showed a response in the Dictation & Speech pane VU meter when I would snap my fingers around the bezel. Even worse, it showed a response to conversation in another room, the refrigerator starting up in the kitchen 25 feet away, and even an increase in ambient noise. Going back to the Sound prefs, the mic input is still turned "down" and doesn't show a response when I snap my fingers.
    So... how is it that this supposedly defeated mic is working normally, and in fact exceeding expectations, despite being effectively turned "off" in the Sound pane?
    Basically, this iMac is a very expensive bug sitting on my desk. Is there a way to properly disable the mic in the system? I can't even find the thing to block it physically, like with bezel cameras. There is no place for an external mic to plug in either, which would physically bypass any internal mic on my previous Macs.

    Interested parties may want to know...
    I went to the Apple Store two weeks ago for a replacement Airport Express. While I was waiting for it, I struck up a conversation with one of the store staff, and brought up the mic issue. We spent a good ten minutes going through the few ways of securing the mic, and we determined that every iMac made has the ability to continue listening evne though dictation is shut off. Unlike old Macs, you can't disable the mic in the Sound prefs. You can't turn off listening in the Dictation prefs - even though turning off "dictation" means the dictation part of the OS stops listening. The only way to definintely shut off the "listening" part is to keep the Audio Devices panel open, select Built-in Microphone, and make sure the master mute button is checked. Also, you have to leave the Dictation & Speech pane open in Preferences to watch the mic display.
    Even so, going to any other preference panel and then back to Dictation & Speech means that the master mute will uncheck itelf and the mic goes back to listening mode.
    The staff member was quite frustrated by this and said it appears the only way to stop the iMac from listening with any certainty would be to block the mic, just like millions of users block the Facetime camera with a piece of tape.
    I suppose I should admit defeat at this point, and maybe I should have long ago recognized that no matter what the system tells us, we shouldn't trust it. Simply clicking on a radio button to disable what in all actuality is really a room bug shouldn't have us letting out a sigh of relief and saying "Wow I'm glad I was able to stop that security issue by trusting the machine to let me know when it was listening."
    In another year my Apple Care will run out. Then I'm going to take this iMac to my local authorized service center to have a hybrid drive installed and the internal memory maxed out. While they're in there, I'll have the mic physically removed.

  • Can't get the correct return value ?

    Hi,
    I'am using JDBC/ODBC to connect to a MS SQL Server 7 database. I run a stored procedure which updates a table. An update trigger however may rollback the entire transaction and issue a RAISERROR. A return value should be returned after this.
    However, in my servlet, I always retrieve the return value 1 (whether the transaction was rolled back or committed). What am I doing wrong ?
    Forgive me, all you experts out there, I am a beginner ...

    A RAISERROR should produce an exception. Checking the return value shouldn't matter nor be possible.
    What error number is being used for the RAISERROR? I tried different numbers and ended up using the standard 16. Is the trigger returning immediately following the RAISERROR? I remember problems with that, the stored proc would continue if I didn't.

  • How can we get the values from the view?

    Hi All,
    my scenario is i have two fields in my view .one is parameter.and another on is select-options.how can i get the user entered values into my selection screen.?
    for the select options i get the values into field-symbol.for parameter i get the value using get_attribute.
    can i use like this in select statement.
    WHERE SERVICE_ID  = ZSD_DD_AUFNRS
                       AND CRE_DT IN <FS_DATE>.
    Regards,
    Ravi.

    Hi Sravan,
    when i am using the below code to generate self defined functions i m getting a error .
    *Generate an object for self defined functions
      DATA: lo_self_functions TYPE REF TO if_salv_wd_function_settings,
    *Generate an object for button 'Confirm'
           lr_button TYPE REF TO cl_salv_wd_fe_button,
           lo_self_function TYPE REF TO cl_salv_wd_function,
                  l_text type string.
    *Set Self-defined functions
    *'Confirm' Button
      lo_self_functions ?= l_value..
      lo_self_function = lo_self_functions->create_function( 'CONFIRM'  ).
      CREATE OBJECT lr_button.
      CLEAR l_text.
      l_text = 'Confirm'.
      lr_button->set_text( l_text ).
      lr_button->set_image_source( '' ).
      lr_button->set_image_first( 'X' ).
      lo_self_function->set_editor( lr_button ).
    Error when processing your request
    What has happened?
    The URL http://cgslsvr3.cgsl.com:8020/sap/bc/webdynpro/sap/zsdr_cash_work_list/ was not called due to an error.
    Note
    The following error text was processed in the system CGD : WebDynpro Exception: IDs Can Only Contain Characters of Syntactical Character Set
    The error occurred on the application server cgslsvr3_CGD_20 and in the work process 0 .
    The termination type was: RABAX_STATE
    The ABAP call stack was:
    Method: RAISE of program CX_WD_GENERAL=================CP
    Method: CONSTRUCTOR of program CL_WDR_VIEW_ELEMENT===========CP
    Method: CONSTRUCTOR of program CL_WD_TOOLBAR_BUTTON==========CP
    Method: NEW_TOOLBAR_BUTTON of program CL_WD_TOOLBAR_BUTTON==========CP
    Method: IF_SALV_WD_COMP_TABLE_UI~CREATE_TOOLBAR_ITEM of program CL_SALV_WD_C_TABLE_V_TABLE====CP
    Method: IF_SALV_WD_COMP_TABLE_UI~CREATE_TOOLBAR_ITEMS of program CL_SALV_WD_C_TABLE_V_TABLE====CP
    Method: IF_SALV_WD_COMP_TABLE_UI~UPDATE_TOOLBAR_ITEMS of program CL_SALV_WD_C_TABLE_V_TABLE====CP
    Method: IF_SALV_WD_COMP_TABLE_UI~UPDATE_TOOLBAR of program CL_SALV_WD_C_TABLE_V_TABLE====CP
    Method: IF_SALV_WD_COMP_TABLE_UI~UPDATE of program CL_SALV_WD_C_TABLE_V_TABLE====CP
    Method: IF_SALV_WD_VIEW~MODIFY of program CL_SALV_WD_C_TABLE_V_TABLE====CP
    What can I do?
    If the termination type was RABAX_STATE, then you can find more information on the cause of the termination in the system CGD in transaction ST22.
    If the termination type was ABORT_MESSAGE_STATE, then you can find more information on the cause of the termination on the application server cgslsvr3_CGD_20 in transaction SM21.
    If the termination type was ERROR_MESSAGE_STATE, then you can search for more information in the trace file for the work process 0 in transaction ST11 on the application server cgslsvr3_CGD_20 . In some situations, you may also need to analyze the trace files of other work processes.
    If you do not yet have a user ID, contact your system administrator.
    Error code: ICF-IE-http -c: 110 -u: CT-0024 -l: E -s: CGD -i: cgslsvr3_CGD_20 -w: 0 -d: 20080414 -t: 105835 -v: RABAX_STATE -e: UNCAUGHT_EXCEPTION
    HTTP 500 - Internal Server Error
    Your SAP Internet Communication Framework Team
    How can i resolve it?
    Regards,
    Ravi

Maybe you are looking for

  • Java mail api - sending mails to gmail account

    Hello I am using java mail api to send mails.when i send mails to gmail from ids which are not in gmail friends list, most of the mails are going to spam.Ofcourse, some of them go to inbox.I tried in lot of ways to analyse the problem.But nothing cou

  • Need HELP with JetDirect 500x - I'm New to this Apple Thing!

    Hello. I am very new to Apple. I have been using PC's for years and I am over them. I am slowly trying to understand the differences and where to begin. I need help getting my printers setup with a JetDirect Box. Here is what I have. HP JetDirect 500

  • Spry validation and CFFORM

    I am using Spry validation on some of my forms and noticed that if I am using CFFORM, the validation works, but the form is still allowed to submit if the validation fails. If I change the cfform tags to regular form tags the validation works and the

  • PLD Header Detail

    hi,   I have an UserDefined Master and Detail table , i want to show report like header and detail (like A/R Invoice) , is it possible using PLD?   I put the field in area header then , blank value is showing , if i put the field in Page Header then

  • Outlook Express address book to Entourage

    Changing from a PC to a MacBook Pro - Is there any way I can export my PC Outlook Express address book to my MacBook Pro? I am using Entourage and would like to have my address book exported rather than having to type everything. Is this possible or