Can you help? Two dialer interfaces with IP SLA for default route failover - issues

I have an issue with a Cisco 2821, it has an ADSL2+ HWIC  whose ATM interfaces is linked to dialer 1 and a Gi0/1 interface with a pppoe client which is linked to dialer 2.  Both dialer interfaces are up with their respective IP addresses.  If the ADSL on dialer 1 fails i want the IP SLA to kick and and replace the default route for dialer 1 with one for dialer 2.
This config works if you manually shut down the dialer 1 interface, it injects the default route for dialer 2 and then when you unshut the interface, the default route for dialer 1 comes back.  The problem i have is if you take out the cable for the ATM interface and take it down, it does not take the route out the routing table and the default route for dialer2,  which works if you just shut down dialer 1 does not appear.
whats the difference between shutting down dialer1 and it fails over the default route and taking the cable out then it does not?
Here is my config, i'm sure its something simple i'm doing wrong, can anyone help???
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname Router
boot-start-marker
boot-end-marker
logging message-counter syslog
enable secret 5 $1$qOOJ$HV5AH6US/YZMuCGPYp3pP.
no aaa new-model
dot11 syslog
ip source-route
ip cef
ip dhcp excluded-address 192.168.0.1
ip dhcp pool pool1
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 188.92.232.50 188.92.232.100
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
voice-card 0
 no dspfarm
archive
 log config
  hidekeys
track 1 ip sla 1 reachability
interface GigabitEthernet0/0
 description Gi0/30 Local LAN
 ip address 192.168.0.1 255.255.255.0
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat inside
 ip virtual-reassembly
 no ip mroute-cache
 duplex auto
 speed auto
 snmp trap ip verify drop-rate
 no mop enabled
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 2
interface ATM0/2/0
 description ATM0_DSL
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 logging event atm pvc state
 logging event subif-link-status
 no atm ilmi-keepalive
 dsl operating-mode auto
 dsl enable-training-log
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
interface Dialer1
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 keepalive 1 3
 no cdp enable
 ppp lcp predictive
 ppp authentication pap chap callin
 ppp chap hostname ********@ccsleeds.net
 ppp chap password 0 ********
 ppp pap sent-username *******@ccsleeds.net password 0 ********
interface Dialer2
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1492
 encapsulation ppp
 dialer pool 2
 keepalive 1 3
 no cdp enable
 ppp lcp predictive
 ppp authentication pap chap callin
 ppp chap hostname **********@adsllogin.co.uk
 ppp chap password 0 *********
 ppp pap sent-username *********@adsllogin.co.uk password 0 ***********
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1 track 1
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer2 10
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
ip sla 1
icmp-echo 8.8.8.8 source-interface di1
timeout 1000
threshold 100
frequency 3
ip sla schedule 1 life forever start-time now
access-list 1 permit 192.168.0.0 0.0.0.255
control-plane
gatekeeper
 shutdown
line con 0
line aux 0
line vty 0 4
 password test
 login
scheduler allocate 20000 1000
end

Sure that EEM can shut/unshut interface...you have "event track" in EEM for monitoring track events...for example:
event manager applet test
event track 1 state down
action 1.0 command "enable"
action 1.1 command "conf t"
action 1.2 command "interfac dialer 1"
action 1.3 command "shut"
action 1.4 syslog "Dialer 1 down!!!"
action 1.5 end
This would be an example from head :)
You would need another EEM similar to this one for unshutting interface with "event track 1 state up" for bringing interface up again.
Again as I said you would need to test this before putting in production and you would maybe need to tweak this a little bit acording to your needs...
BR,
Dragan

Similar Messages

  • Can you have two different users with itune accounts on the same computer?

    Can you have two different users with separate itune accounts on the same Ipad?

    Yes, create another user profile on the computer and each user can log into their own profile that way.

  • With MacBooks Retina 13" can you connect two external monitors with resolution each 2560x1600?

    I'm not talking about Thunderbolt displays, but other brands like ASUS, LG, SAMSUNG, etc.
    Has anyone tested?

    You can connect two displays to the two Thunderbolt ports with appropriate Mini DisplayPort cables or adapters.
    <http://www.apple.com/macbook-pro/specs-retina/>
    "Simultaneously supports full native resolution on the built-in display and up to 2560 by 1600 pixels on up to two external displays"
    If the display supports HDMI, you could connect one to the computer's HDMI port, but not at 60Hz.
    "Support for 3840-by-2160 resolution at 30Hz"

  • Can you have two iTunes accounts on same laptop for different iPads

    Can you set up a second Itunes account for a different person with a different iPad &amp; iPod, I already have one but do not want other persons iPad sharing same apps and details etc
    How do I set up a new iTunes account for someone else without mucking mine up
    Thanks

    How to user multiple iDevices with one computer: http://support.apple.com/kb/ht1495

  • Can you sync your iPod touch with computer 1 for computer 1's iCal items and also sync the same iPod touch with computer 2 for computer 2's music, apps, etc. items?

    I have a MacBook Pro through my college, and I have all my iCal items on that computer, but I have all my music, apps, etc. on a PC desktop that is my personal home computer.  I am wondering if I can sync my iPod touch with my MacBook for the iCal items and also with my PC for the music and such without loosing either of the two when trying to sync with the other computer?

    Have a look Here  >  Managing content manually
    From Here  >  http://www.apple.com/support/iphone/syncing/

  • HT204053 Can you merge two Apple IDs into one?  It was a common issue caused by the iPhone 4 and has been corrected, but transferring purchases in iTunes is a pain with two IDs.

    For a brief time when iPhone 4, iOS 4 came out, many of us ended up with two Apple IDs.  I want to know if anyone can please provide me with simple step-by-step instructions on merging two Apple IDs into one?  It would make transferring purchases on iTunes much easier and reliable.  I realize i desperately need an iOS update, but i had no laptop for over two years!  I'm posting a cry for help on that in another community.  Thank you all.

    No,
    Apple IDs cannot be merged. You should use your preferred Apple ID from now on, but you can still access your purchased items such as music, movies, or software using your other Apple IDs.

  • Can you help me use PSE9 with CS5 as an external editor?

    Hello,
    I much prefer the Elements Organizer to Bridge, and have a large catalog with tags that I don't want to give up.  95% of the time, I am perfectly happy with the PSE9 editor.  However, for the other 5% of the time, CS5 is the ticket (even if only for the better Camera RAW processing).  However, I can't seem to save the resulting edited photo in a version set with the original, and for that matter, it seems to get lost somewhere in the ether but PSE9 continues to believe that the file is being edited.
    Any help would be appreciated.
    Thanks in advance,
    Claude

    In the Organizer go to Edit >>Preferences >>Editing
    Under supplementary editing browse to the CS5 editing application and select it, then click OK.
    To edit an image select it in Organizer and click Edit >>With CS5.
    A new image will be launched automatically and when saved in CS5 will be found next to the original in a version set in the Organizer.
     

  • Can you help me editing the credit card no. for the monthly payment of my team account (Creative Cloud for teams for A\Tratti)?

    How can I do?

    Change/Verify Account https://forums.adobe.com/thread/1465499 may help
    -Credit card https://helpx.adobe.com/x-productkb/policy-pricing/membership-subscription-troubleshooting -creative-cloud.html
    -or by telephone http://helpx.adobe.com/x-productkb/global/phone-support-orders.html

  • Can you help? Converting from PC to Mac for Design Standard CS6

    Hello,
    I have recently purchased a macbook pro and downloaded the files for Design Standard CS6, I install the application and then enter my product key which works however it says
    "this product is valid but we could not find a qualifying product on this computer"
    It then tells me that if I want to use the code I must have one of the following products and the serial code, then it gives me a list of products none of which I want such as Design Standard 5, Web Premium etc
    I didn't need any of these on my PC I just downloaded the application and used my code
    Can anyone offer any advice here?
    Thanks
    S

    Order product | Platform, language swap
    For anything else you need to contact support by web chat.
    Mylenium

  • £37 has disappeared from my iTunes account. But no apps or music or tv/movies have been bought. Has it been hacked and can you help please?

    £37 has disappeared from my iTunes account. But no apps or music or tv/movies have been bought. Has it been hacked and can you help please?

    Report it to Apple:
    How to report an issue with your iTunes Store purchase - http://support.apple.com/kb/HT1933 - working through iTunes application and iTunes Store interface.
    iTunes Customer Service Contact - http://www.apple.com/support/itunes/contact.html
    Change the password on your account.

  • I am trying to connect my Apple TV to an older Panasonic projection TV using an HDMI to a DVI cable to the Digital IN. I cannot get any sound. Can you help?

    I am trying to connect my Apple TV to an older Panasonic projection TV using an HDMI to a DVI cable to the Digital IN. I cannot get any sound. Can you help?

    DVI interface does't allow audio. Is there optical IN from your Panasonic TV? By then you can connect your ATV to Panasonic using optical together. It will work.

  • Firefow auto updated "5 beta", lost all previous tabs, "unresponsive script" opens w/each new window...Can you help?

    firefox auto updated to "5.0", then when opening firefox, got "unresponsive script"(which had to be closed to start firefox, and then the same opening w/each new window...(In doing this I then lost all previous tabs).
    Can you help?

    ''FredMcD [[#answer-691408|said]]''
    <blockquote>
    That is a known issue.
    '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox Full Installer For All languages And Systems]''' {web link}
    </blockquote>
    Fred,
    Thanks so much for the reply. Amy way you could elaborate on the "known issue" aspect? Is there another thread I missed? Some sort of Knowledge base article? also, I'm not sure why you linked to the page you did. FF is installed on all my machines and I can of course download the latest version every couple of weeks and push it to all my lab iMacs using ARD, so I'm confused as to why you linnked me to FF's installer page - is there something I can do with the installer that will alow auto-updates that I'm missing/not aware of?
    Again, thanks for the heads-up and any further elaboration on either further info on the issue or how I might use the installer to auto-update all my machines will be appreciated.

  • I am looking for a way to develop a grammar checker for the web like spellcheckerplus can you help?

    I am looking for a way to develop a grammar checker for the web like spellcheckerplus can you help? I have my own dictionary for comparing and replacing words.

    Hi,
    The forum is about install/uninstall .NET Framework, please post your issue to dev related forum instead of here.
    Best regards,
    Barry
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • How to Setup Forward Error Handling in PI Scenarios. Can you help me with the same with screen shots if possible?

    Dear all
    How to Setup Forward Error Handling in PI Scenarios. Can you help me with the same with screen shots if possible?
    Thanks
    Regards
    karan

    Hello
    These are the following errors
    1. Trace level="1" type="T">no interface action for sender or receiver found</Trace>
    2. <Trace level="1" type="System_Error">Application-Error exception return from pipeline processing!
    3.
    <Trace level="1" type="T">Application Error at Receiver... => ROLLBACK WORK</Trace>  
    <Trace level="1" type="T">System Error at Receiver... => ROLLBACK WORK</Trace>  
    <Trace level="1" type="B" name="CL_XMS_MAIN-WRITE_MESSAGE_LOG_TO_PERSIST" />  
    <Trace level="1" type="System_Error">Application-Error exception return from pipeline processing!</
    Trace level="3" type="T">No persisting of message after plsrv call, because of config</Trace>Trace level="3" type="T">Error of the prevous version:</TraceTrace level="3" type="T">Error ID APPLICATION_ERROR</Trace>
    tThere are repeating errors also.
    TThanks
    Regards
    kkaran

  • I have a mac pro wich will not open windows in boot camp i get to the two options select windows but iyt will not load can you help please

    i have a mack pro which will not open in windows from boot camp get to the two options and select windows drive but it will not open can you help Please

    Hi there, Well, i thing i might have had the same problem (if you dont mean the selecting part, then try keyboad with usb and without if u dont have a macbook pro or so), i did the same and after selecting windows it said "No bootable disk" or " no boot disk" or something like that and the installer wont start when i was trying to install via CD/DVD.
    The sulution is to use 2 usb-drives, one for the support drivers from apple and one for the windows it self after burning the CD/DVD to the usb on a PC using the windows own tools and creating a ISO file.
    (there might be problems whit CD/DVD install sometimes)
    The ISO file on a own USB is the most importat thing!! (and even apple and windows didnt know that but me and a technikal support guy from the store i bought it managed to fix it after like 4 days )
    Hope it work now mate!

Maybe you are looking for

  • Error while opening systemproperties it say reinstall UCM without root uses

    UCM 11g gives error while opening Systemproperties applet, it says UCM is installed by root user reinstall it without root user. We have installed the UCM from a non root user however we are getting this error and non of the applet is opening which a

  • Forward Error Correction

    I'm trying to find a way to implement Forward Error Correction (FEC) in Java, and if possible, find a code that someone has wirtten b4. Can any1 plz help me? I need this FEC in a one way communication.

  • Monthly Payments Iphone 4

    Hey I was just curious to what the average monthy bill is that people are paying? People who are on their own plan only please. I know most of my friends pay around 100 a month with the iphone 4 but im curious to what the average is? Whats the lowest

  • Dump when displaying target group

    Hi, When I try to display a target group I get this error: Line types of an internal table and a work area not compatible The problem is that in method SELECT_BP_ENHANCEMENTS from class CL_DEF_IM_CRM_MKTTG_SEG_MEM_EX, the method tries to insert a lin

  • Its xperia z all over again!

    Yesterday in the afternoon i found out that my 2 and a half months old xperia z3's front panel has raised slightly!!!! I had found the same kind of problem in my xperia z! Which was my previous phone!! I thought that after 2 fricking years they shoul