Cloning a Mac OS X Server to a remote location

Scenario: A Mac Mini running Mac OS X Server is in location A and a second Mac Mini running Mac OS X Server is to be acquired and setup at a remote location.
Desire: Do a nightly backup of Server A to the second Mac Mini so that Server B is a bootable clone of the primary server.
Question: What is the best software/approach to do this?
Discussion: I'm familiar with and use SuperDuper, Synchronize Pro and Carbon Copy Cloner for performing file by file backups and synchronization where the hard drives are on the same server ... but I'm not sure if any of these are the best alternative to backup a MAMP Pro installation on the Server (along with other applications and data) to a remote server box.
I realize that particularly within the Moodle VLE (that will be running on the servers) that absolute links will still point to the primary server but that is not an issue for me. In the event of a catastrophic failure of Server A at least there would be an offsite clone that could be accessed if a few settings were changed.
BTW: Server A is hosted by a commercial hosting service and no backup drive is available on-site for a file x file backup/synchronization. We do have full access to the server via ARD, Timbuktu Pro, AFP, etc.

Can you expand your info on the use of these two approaches, particularly the mysql replication
Well, my approach requires that there's some kind of connectivity between the two machines - preferably a VPN network to secure the traffic, but it doesn't have to be done that way.
rsync essentially takes two directories - one local and one remote - and compares the differences. Depending on the switches you use it will copy the changes from one system to the other (or both if that's what you prefer). In this case I'd set it to copy the local web directory to the remote machine, so the remote machine has a copy of all the files.
rsync works best for static files (e.g. .html, .php, etc. in the case of a web application), but shouldn't be used for dynamic files such as your database files.
As for the data, MySQL has substantial built-in replication routines that are designed to keep multiple database servers in sync. There's far more to it than I can go into here, suffice to say it can maintain a real-time copy of your data on a second, remote machine, and you should read the documentation for the specifics.

Similar Messages

  • I need helping!!! configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.

    I need helping configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.
    I have attempted to configure rdp access but it does not seem to be working for me Could I please ask someone to help me modify my current configuration to allow this? Please do step by step as I could use all the help I could get.
    I need to allow the following IP addresses to have RDP access to my server:
    66.237.238.193-66.237.238.222
    69.195.249.177-69.195.249.190
    69.65.80.240-69.65.80.249
    My external WAN server info is - 99.89.69.333
    The internal IP address of my server is - 192.168.6.2
    The other server shows up as 99.89.69.334 but is working fine.
    I already added one server for Static route and RDP but when I try to put in same commands it doesnt allow me to for this new one. Please take a look at my configuration file and give me the commands i need in order to put this through. Also please tell me if there are any bad/conflicting entries.
    THE FOLLOWING IS MY CONFIGURATION FILE
    Also I have modified IP information so that its not the ACTUAL ip info for my server/network etc... lol for security reasons of course
    Also the bolded lines are the modifications I made but that arent working.
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password DowJbZ7jrm5Nkm5B encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.6.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 99.89.69.233 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group network EMRMC
    network-object 10.1.2.0 255.255.255.0
    network-object 192.168.10.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 172.16.0.0 255.255.0.0
    network-object 192.168.9.0 255.255.255.0
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service GMED tcp
    description GMED
    port-object eq 3390
    object-group service MarsAccess tcp
    description MarsAccess
    port-object range pcanywhere-data 5632
    object-group service MarsFTP tcp
    description MarsFTP
    port-object range ftp-data ftp
    object-group service MarsSupportAppls tcp
    description MarsSupportAppls
    port-object eq 1972
    object-group service MarsUpdatePort tcp
    description MarsUpdatePort
    port-object eq 7835
    object-group service NM1503 tcp
    description NM1503
    port-object eq 1503
    object-group service NM1720 tcp
    description NM1720
    port-object eq h323
    object-group service NM1731 tcp
    description NM1731
    port-object eq 1731
    object-group service NM389 tcp
    description NM389
    port-object eq ldap
    object-group service NM522 tcp
    description NM522
    port-object eq 522
    object-group service SSL tcp
    description SSL
    port-object eq https
    object-group service rdp tcp
    port-object eq 3389
    access-list outside_1_cryptomap extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 192.168.0.0 255.255.0.0
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-data
    access-list outside_access_in extended permit udp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-status
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ftp
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ldap
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq h323
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq telnet
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq www
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group SSL
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM522
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM1731
    access-list outside_access_in extended permit tcp 173.197.144.48 255.255.255.248 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp any interface outside eq 3389
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333 object-group rdp
    access-list outside_access_in extended permit tcp any host 99.89.69.333 object-group rdp
    access-list out_in extended permit tcp any host 192.168.6.2 eq 3389
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp 99.89.69.334 3389 192.168.6.1 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 99.89.69.338 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.6.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 68.156.148.5
    crypto map outside_map 1 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    tunnel-group 68.156.148.5 type ipsec-l2l
    tunnel-group 68.156.148.5 ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:f47dfb2cf91833f0366ff572eafefb1d
    : end
    ciscoasa(config-network)#

    Unclear what did not work.  In your original post you include said some commands were added but don't work:
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    and later you state you add another command that gets an error:
    static (inside,outside) tcp 99.89.69.333 3389 192.168.6.2 3389 netmask 255.255.255.255
    You also stated that 99.89.69.333 (actually 99.89.69.233, guessing from the rest of your config and other posts) is your WAN IP address.
    The first static statement matches Cisco's documentation, which states that a static statement must use the 'interface' directive when you are trying to do static PAT utilizing the IP address of the interface.  Since 99.89.69.333 is the assigned IP address of your WAN interface, that may explain why the second statement fails.
    Any reason why you are using static PAT (including the port number 3389) instead of just skipping that directive?  Static PAT usually makes sense when you need to change the TCP port number.  In your example, you are not changing the TCP port 3389.

  • What ports need to be open to control Lion Server from a remote location (through Server.app)?

    I need to control a Lion Server from a remote location and need to poke some holes in the firewall, unfortunately, I have no idea what ports those need to be. I can control the Server via the Server Admin application, but it will simply not connect via the Server.app.
    Suggestions?
    Thanks in advance.
    Marius

    Try in the Lion Server Forum?
    Regards,
    Colin R.

  • Mac os x server software update data location

    Does anyone know how to change the data location of Mac OS X Server (v3) Software Update?
    I'd like to move it to a large RAID permanently connected to the server but I can't find the command in serveradmin.
    Cheers,
    Kirk

    Why not move the whole boot disk and Serve.app and the rest out to the RAID array?  It's not like OS X is that big a hunk lately in comparison with the size of various RAID arrays, and relocating the whole configuration means you won't have to deal with a piecemeal relocation, nor any future upgrade weirdnesses that might arise from the relocation.
    That approach aside, Mavericks Server storage is mostly under the /Library/Server path.  I haven't tried relocating indidual hunks yet, either.
    Ah, slightly misread...  You could shut off Software Update entirely, and use Reposado.  That'll let you do what you want. 
    The other hunk you'd probably want to move is the Caching Server.

  • Login to Oracle 8i Server from a remote location.

    Hi Experts,
    I wish to connect to Oracle 8i Server at Site 1 from Site 2.
    Situation
    Site 1     -     Oracle 8i on Win 2K. This is behind a firewall FW1. Is in Win NT Domain1.
    Site 2     -     Oracle 8i Client on Win 98. This is also behind (a separate) firewall FW2. Is in Win NT Domain2. There is no oracle instance running at Site 2.
    Also -
    a. There is a secure VPN between Site 1 and 2 (through separate Firewalls. one at each site).
    b. Site 1 and Site 2 use different set of IP-Address and also different set of Subnet Mask.
    c. Both, the Client at Site 2 & Oracle 8i Server at Site 1, are able to ping each other successfully.
    d. As there is no oracle database at Site 2, a Database Link cannot be created.
    At Site 2, I have tried the following -
    1. Installed Oracle 8i Client.
    Configured the tnsnames.ora file.
    The Port used is 1521.
    Tried to connect from SQL*Plus but do not connect.
    2. Installed development version of Oracle Forms 6i (surely after removing Oracle 8i client).
    This also installs SQL*Plus.
    Configured the tnsnames.ora file.
    The Port used is 1521.
    Tried to connect from SQL*Plus but do not connect.
    Tried to connect from Oracle Forms 6i but login fails.
    However, other Win98 clients (of Win NT Domain1) at Site 1 use the same settings of tnsnames.ora file to connect to the Oracle 8i Server.
    3. Changed the IP address (of Win98 client at Site 2) to become a member of Win NT domain1 (same domain as that of Oracle 8i Server).
    Repeated the above steps 1 & 2 but login still fails.
    What more needs to be done?
    Thanks in Advance.
    Lokesh

    Hi Fredrik,
    You r right. But I have its entry in tnsnames.ora file. The entry looks like this -
    My_Service_Name.world =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS =
    (COMMUNITY = tcp.world)
    (PROTOCOL = TCP)
    (Server = Computer_Name_of_Server_having_Ora8i)
    (Host = IP_Add_of_Server_having_Ora8i)
    (Port = 1521)
    (Pipe = ORAPIPE)
    (CONNECT_DATA = (SID = ORCL)
    The same entry exists in the tnsnames.ora file on the local PCs (same office where the Oracle 8i Server is present) at Site 1 and these PCs connect the server without any problem.
    Thanks
    Lokesh

  • Using Serial Port as Console (not Mac OS X Server)

    Folks using other Unix-y operating systems, as well as Mac OS X Server, can use a terminal plugged into their machine's serial port as a console to access the shell. I've searched high and low for a way to do this with regular Mac OS X Leopard with no luck. None of the solutions for Linux/*BSD/etc... work.
    Any ideas?
    (FYI: I'm using a USB to 9pin RS-232 cable. I've confirmed that my Mac can talk to the machine attached via this interface.)

    I fixed it. It turns out that the Leopard -> Snow Leopard Migration screwed up the Subversion repository various credentials for user/group and other during the migration copy. Fortunately I had "cloned" my entire Leopard disk. I copied the cloned repository into the Snow Leopard disk and everything works. It looks like this was the fault of the Apple Migration process.

  • Using my home Mac as a server

    I would like to put my pictures on the web so that certain clients can view their photos with password. I photograph weddings and would prefer to make html slide shows of their wedding pictures so that they can view them anywhere with any computer. I would like the setup to be as simple and reliable as possible. I have an additional 250GB drive in the Mac that I wish to use as the storage of individual folders that contain the slide shows. If it would help I can get a dedicated 2nd Mac as the server if necessary. I was told that I would need a static IP address and some kind of software. I thought I could use file sharing on my computer but after reading numerous articles over the net, I am quite confused as to what I need. All I want to post is photo galleries that have about 600 to 700 pictures each that a client can view and that I can delete some or all of them after 30 days to be replaced by new ones. What software, hardware, etc. would be necessary to do this. Any suggestions welcome.

    OSX server or client are both capable of handling this, as long as you have enough disk space. A site like this would probably only require a simple script on the server, server side includes (.shtml) and some javascript in the page itself. Frequently changing directories with basic authentication would probably best be done with .htaccess files. It isn't brain surgery, but there are reasons that people can make a living doing this kind of work.
    A static IP would be needed so that when the users aim their browser at your site, they're not aiming at a moving target. Be aware that many/most/all ISPs that have home broadband networks block web servers.
    Try turning on the web sharing, and try making one of these sites and see what comes of it. One cavaet that I see coming, is that the names of the images will probably vary from one shoot to the next, so that's why I was thinking that a server script to list the the image names and put them into a javascript array for the page to use to call for the different images.
    Roger

  • Small Business w/Mac Mini Running Server OSX, Connect From Home Solution - VPN?

    I am trying to setup my Mac Mini running OS X Server (Mountain Lion) to be accessed from users at home (for file sharing and Contact Services). Is a VPN the best solution? (Small business setup - privacy/security a concern).
    Hi everyone, and Thanks for the help in advance!
    I am currently setting up a network for my company (small business) and have a few questions. We have a Mac Mini (mid-2012) running Server OS X Mountain Lion, and 5 MBP's (our work computers- all running latest version of Mountain Lion).
    To summarize:
    My goal = Setup a secure way of connecting the MBP's to the server when our personnel are at home (for file sharing).
    I am switching all of the users from local to network (we didn't need the network functionality when we first setup the server, and we are now expanding our use of it). This is going to occur this weekend, as downtime for the server is needed to make the changes.
    After I establish the Open Directory and all of that, I will be setting up Contact Services (to share a master list of contacts with the members of our department) and we already have some Calendar sharing setup.
    The purpose of this is to enable our employees the option of working necessary overtime from home so they can be with their families instead of in the office all the time. It is a noble cause and I want to set this up the best that I can for them.
    This being said... I'm no Mac Genius, and this stuff can get very confusing very fast. I have read a little about VPN's, and am wondering if this is the solution to my problem. We need to establish a SECURE way of connecting to the server from remote locations, enabling us to pull needed files from the server.
    If anybody can offer some advice on this I would really appreciate it. I love Apple products and I have faith that this is as easy as I've been told it is.
    Thank you very much for your time and consideration!

    No, it wasn't difficult at all to setup in OS X Server. I use a free internet domain name from DynDNS.com. I don't know if they still offer free ones anymore. You can not use VPN and 'Back to My Mac' at the same time as they use some or all of the same ports.
    I'm at work and not on my Mac at the moment so this is from memory.
    Within OS X Server, I enabled the VPN Service (default L2TP) and used my free domain name in the VPN Host Name and a Secret passphrase. This put an entry in my Airport Extreme router for VPN (port mapping).
    Within the client Mac, I added a VPN network connnection (System Preferences /Network). I pointed to my free domain name in the Server Address, used my Server account name in the account name. I think there's an Authentication button that I clicked. I entered my Server account password, the Secret passphrase in the Secret field, checked a box to show VPN icon in Menu Bar and exited out of that. Then clicked the Advanced button and checked the box to send all traffic over VPN connection.
    I had VPN authentication issues at first when trying to connect to test out the connection. I just kept trying as I knew I had all the settings correct and it would finally connect after about 3-4 tries. After that, I sometimes have to connect more than once to actually connect to my Server via VPN. But it does work nice. I brought my MBP into work once to test it out and was able to connect to my home Server via VPN and use Screen Sharing and had access to all my shared folders.

  • 2 internal hard drives Mac Pro Tiger Server

    I have a mac pro 10.4.11 server that has 2 internal hard drives. 1 is 232.89 GB which is the main startup drive and the second is 465.76 Gb which I had pre installed for extra storage. My question is when I look in Server Admin under sharing and I click the "all" tab. It displays 2 hard drive icons and when you select either one, they consist of the exact same things. Do I need to format the second drive in a way so it will be recognized in the Server Admin Sharing?? I can install applications to the drive as it is recognized in the normal finder but I can't seem to get Server Admin to know it is there. I was going to use the second drive for mostly applications and storage. The other hard drive I was going to try and keep just for home directories.

    This is the wrong forum for your topic. You should post it in the Mac OS X Server forum.

  • I have a MAC Pro from 2011 currently running MAC OS 10.9.5.  This weekend I cloned the MAC HD drive to a new SSD drive for improved performance.  The clone was completed successfully with no errors.  After the clone completed I successfull restarted my sy

    I have a MAC Pro from 2011 currently running MAC OS 10.9.5.  This weekend I cloned the MAC HD drive to a new SSD drive for improved performance.  The clone was completed successfully with no errors.  After the clone completed I successfully restarted my system using the SSD as the boot device.  I then successfully tested all of my products, including Photoshop CS6 and all of its plug-ins.  I successfully tested the key features that I frequently use.  Today while attempting to launch Photoshop CS6 a message is being displayed indicating that a scratch disk cannot be found.  All drives are available on the system via the Finder and Disk Utility.  I can access all drives including the old MAC HD which is no longer the boot device.  I've even attempted to launch Photoshop from the old device yet the same error persist.  Is there a way to review/edit/change Photoshop preferences if Photoshop doesn't launch?  I've even restarted my system several times to see if that would resolve the issues.  Does anyone have any recommendations for this issue?  Have you previously address this issue? 
    Thank you Gregg Williams

    Boilerplate text:
    Reset Preferences
    http://forums.adobe.com/thread/375776
    1) Close the program and press Ctrl+Alt+Shift/Cmd+Option+Shift during startup (not reversible)
    or
    2) Move the Folder. See:
    http://www.bugge.com/Family-and-friends/Illy/illy.html
    --OB

  • Old Web Server Software on Mac OS X Server 10.4.6?

    I am wondering why my apache that is running is only 1.3.33 accordign to my webmin tool that my friend installed, the php and sql are old too.
    I'm not a unix guru by any means and I want to upgrade these and enable GD etc, but I'm running 4 or more virtual servers by using the server tools and I don't want to break the builtin functionality of the server tools. Is apple going to upgrade this stuff on os x server?

    Mac OS X Server ships with both Apache 1.3.33 and Apache 2.2 (in /opt/apache2).
    You're more than welcome to disable Apache 1.3.x and use 2.2 if you prefer.
    However, the Server Admin GUI will only currently work with Apache 1.3.x, so if you do you'll need to manage your configurations manually.

  • Mac OS X Server 10.0.4 Update

    Hello,
    I've been going through my software and downloading all the updates I can find. I was wondering if any of you might have this in your archives, Apple seems to have "lost" it and my usual haunts have come up empty.
    I've recently bought Mac OS X Server 10.0, and I have some of the other OS X Servers (for the Xserve), it seems finding (just the) updates you need before OS X Server 10.3 is hit or miss.
    In one example I'm trying to find:
    Mac OS X Server 10.0.4 Update: Document and Software
    http://docs.info.apple.com/article.html?artnum=120035
    ( http://download.info.apple.com/MacOSX/062-8318.20010702/0z/10.0.4ServerUpdate.dmg.bin )
    Dumps you at:
    " This URL is no longer used. If you get to this page, please go to:"
    http://www.info.apple.com/export/
    ... do strange loop.
    (My cookies are enabled)
    I know this is old, thats not the point, why is this and for that fact most of the other updates missing?
    I'm not real clear if 10.0 Server is update-able to 10.1 Server with the OS X 10.0-10.1 update CD for the regular OS X to which you may then UD to MacOSXUpdateCombo10.1.5, they mixed it up so you can't tell - or I can't tell.
    Mac OS X Server 10.1: Chart of Available Software Updates:
    http://docs.info.apple.com/article.html?artnum=42741
    See what I mean?
    Even OS X Server 10.0.3 Update would suffice. I'd appreciate you all poking around - I got nothing.
    Mac OS X Server 10.3.x on, stuff is easy to find, Server 10.2.x and earlier is a pain and this is the last time (hopefully) I'll need to do this.
    If anyone with these updates could contact me that would be great or just reply to this post, this server will not be online - just to be clear.
    Any help would be appreciated.
    hylas
    California, USA
    hylas[|at|]operamail[|dot|]com
    Macintoshes   Mac OS X (10.4.6)   System 1.0 - 7.6.1, MacOS 8.0 - 9.2.2, OS X 10.0 - 10.4.x Client and some Servers

    "Which took me about 5 seconds to find, by searching at
    http://www.apple.com/support/downloads/
    for 10.0 server
    and choosing "restrict to downloads"
    I've spent more than five seconds looking dear one.
    Mac OS X (10.0.4) Combined Update Information and Software
    http://docs.info.apple.com/article.html?artnum=75141
    is not:
    Mac OS X Server 10.0.4 Update: Document and Software
    http://docs.info.apple.com/article.html?artnum=120035
    it is required, though.
    Mac OS X Server 10.0 OZ691-3023-A
    Mac OS X Server 10.0 (has 10.0.3 4P13 on it) OZ691-3023-A
    /AppleSupport_Area/Apple_Software_Updates/Mac_OSX/downloads/062-8318.200106027/0z/10.0.4ServerUpdate.dmg.bin
    http://download.info.apple.com/MacOSX/691-3023.20010702/0z/10.0.4ServerUpdate.dmg.bin
    ^ No worky ^
    Title:
    Mac OS X Server 10.0.4
    Description:
    Installing the updated Server Admin on Mac OS X clients After installing the 10.0.4 Server Update, you may update your Mac OS X Server administration clients by copying the Server Admin application to them. Follow these steps to perform the copy: Install 10.0.4 Server Update, then restart. Start Apple File Services if necessary. Copy the Server Admin application from the /Application/Utilities folder to the /Shared Items/Public folder. On your Mac OS X client, install 10.0.4 Update if necessary. Connect to your Mac OS X Server, mount the Public folder. Copy the Server Admin application to your Mac OS X client. Requirements for Mac OS X Server 10.0.4 Update You must have previously installed the Mac OS X Server 10.0.3 software in order to install this update. In addition, this update requires that you install the Mac OS X 10.0.4 Update before proceeding.
    OS X Server 10.0.4 Receipts
    Essentials.pkg
    BSD.pkg
    SoftwareUpdate131.pkg
    10.0.1Update.pkg
    10.0.3Update.pkg
    10.0.2ServerUpdate.pkg
    EssentialServerSoftware.pkg
    MacOS_X_ServerAdmin.pkg
    MacintoshManagerAdmin.pkg
    MacintoshManagerServer.pkg
    QTSS3.pkg
    MinimalSystem.bom
    10.0.2Update.pkg
    10.0.4Update.pkg
    MicrosoftIE5.pkg
    10.0.4ServerUpdate.pkg
    NetBoot Extras: Information and Download
    http://docs.info.apple.com/article.html?artnum=120039
    It's a bit confusing, reread my initial post it's a real mess upgrading to 10.1 too.
    Thanks for trying though,
    Macintoshes   Mac OS X (10.4.6)  

  • Not able to install mac os x server 10.5.4

    Hello,
    I've inherited a MAC g5 from a previous sys admin.
    it had a number of issues so i decided to do a clean install.
    i've set in my os x 10.5.4 server and rebooted that didn't work. when i chose the dvd it just hanged there.
    so i installed a mac pro (came with the g5 ) as i've read in an online how to that described my exact problem. once done i tried installing the server again and same issue happened.
    now i have mac pro on my g5.
    after research it seems that my mac os x server 10.5.4 has another version which is older than the G5. so it cannot be installed.
    i tried using a targeted mode though came into another set of trouble:
    1. tried booting from the dvd using a macbook pro with a fire wire plugged into it.
    result: macbook kept restarting when i chose the mac os x server
    2. tried booting from dvd using an imac.
    result: after choosing the dvd it hangs a bit and then boots normally from hardidisk.
    3. picked an old IMAC and booted from it
    result: it worked, and i installed the mac os x server on one of the HDD in my g5
    once done, i've shut down both, unplugged firewire and then booted the G5
    a grey screen appeared with another hdd in the middle of the screen and it just stayed there.
    Can someone please advise how can i proceed?
    PS: i've contacted the apple reseller, though as our support contract ended they couldn't help.

    The retail disks I've seen in that era were usually black in color. The non-retail disks tended to be gray in color. IIRC, the part number for the 10.5.4 Mac OS X Server Leopard Server retail disk is MB605Z/A.
    If it's not a retail disk, then the contents are usually tailored for a specific Mac box.
    The MacBook Pro would have to be a fairly old model to boot 10.5.4; [here are the Mac Intel minimum OS version requirements (HT1159)|http://support.apple.com/kb/HT1159], and (though there were no MBP PPC boxes AFAIK) [here are the PPC version requirements (HT2191)|http://support.apple.com/kb/HT2191].
    The "issues" that precipitated this reinstallation sequence could well be a disk or processor or memory or other hardware problem with the server, too.

  • How do i install mysql on my mac mini lion server?

    How do i install mysql on my mac mini lion server?

    I have this error log
    May 27 07:06:35 server servermgrd[13454]: -[AccountsRequestHandler(AccountsSystemConfigurationObservation) registerForKeychainEventNotifications]: SecKeychainAddCallback() status: -25297
    May 27 07:06:35 server servermgrd[13454]: servermgr_ipfilter:ipfw config:Notice:Flushed IPv4 rules
    May 27 07:06:35 server servermgrd[13454]: servermgr_ipfilter:ipfw config:Notice:Flushed IPv6 rules
    May 27 07:10:35 server servermgrd[13454]: No requests in 300 seconds, shutting down
    May 27 07:20:29 server ScreensharingAgent[13999]: [CL_INVALID_DEVICE] : OpenCL Error : Failed to create context! Invalid device
    May 27 07:26:03 server login[14203]: USER_PROCESS: 14203 ttys000
    May 27 07:26:42 server SafariDAVClient[14233]: ServerNotifications: Setting delegate to APSD
    May 27 07:26:43 server SafariDAVClient[14233]: Subscription request completed
    May 27 07:27:58 server SafariDAVClient[14284]: ServerNotifications: Setting delegate to APSD
    May 27 07:27:59 server SafariDAVClient[14284]: Subscription request completed
    May 27 07:29:03 server login[14203]: DEAD_PROCESS: 14203 ttys000
    May 27 07:29:09 server login[14331]: USER_PROCESS: 14331 ttys000
    May 27 07:47:30 server com.mysql.mysqld[15000]: 120527 07:47:30 mysqld_safe Logging to '/usr/local/mysql/data/server.martinhedegaard.dk.err'.
    May 27 07:47:30 server com.apple.launchd[1] (0x7f82db634810.anonymous.nohup[15222]): Bug: launchd_core_logic.c:9394 (25693):0
    May 27 07:47:30 server com.apple.launchd[1] (0x7f82db634810.anonymous.nohup[15222]): Switching sessions is not allowed in the system Mach bootstrap.
    May 27 07:47:30 server com.apple.launchd[1] (0x7f82db634810.anonymous.nohup[15222]): _vprocmgr_switch_to_session(): kr = 0x44c
    May 27 07:47:30 server com.apple.launchd[1] (0x7f82dc9015d0.anonymous.nohup[15223]): Bug: launchd_core_logic.c:9394 (25693):0
    May 27 07:47:30 server com.apple.launchd[1] (0x7f82dc9015d0.anonymous.nohup[15223]): Switching sessions is not allowed in the system Mach bootstrap.
    May 27 07:47:30 server com.apple.launchd[1] (0x7f82dc9015d0.anonymous.nohup[15223]): _vprocmgr_switch_to_session(): kr = 0x44c
    May 27 07:47:30 server com.mysql.mysqld[15000]: 120527 07:47:30 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data
    May 27 07:48:31 server Safari[541]: IPCClient: Server port 0 is invalid; looking it up again...
    May 27 09:06:34 server servermgrd[18040]: -[AccountsRequestHandler(AccountsSystemConfigurationObservation) registerForKeychainEventNotifications]: SecKeychainAddCallback() status: -25297
    May 27 09:06:35 server servermgrd[18040]: servermgr_ipfilter:ipfw config:Notice:Flushed IPv4 rules
    May 27 09:06:35 server servermgrd[18040]: servermgr_ipfilter:ipfw config:Notice:Flushed IPv6 rules
    May 27 09:09:01 server ScreensharingAgent[18184]: [CL_INVALID_DEVICE] : OpenCL Error : Failed to create context! Invalid device
    May 27 09:09:08 server SafariDAVClient[18193]: ServerNotifications: Setting delegate to APSD
    May 27 09:09:09 server SafariDAVClient[18193]: Subscription request completed
    May 27 09:10:34 server servermgrd[18040]: No requests in 300 seconds, shutting down
    May 27 09:29:44 server System Preferences[581]: about to perform command
    May 27 09:29:48 server com.mysql.mysqld[15000]: 120527 09:29:48 mysqld_safe mysqld from pid file /usr/local/mysql/data/server.martinhedegaard.dk.pid ended
    May 27 09:29:48 server com.mysql.mysqld[19056]: 120527 09:29:48 mysqld_safe Logging to '/usr/local/mysql/data/server.martinhedegaard.dk.err'.
    May 27 09:29:48 server com.apple.launchd[1] (0x7f82db62da20.anonymous.nohup[19280]): Bug: launchd_core_logic.c:9394 (25693):9
    May 27 09:29:48 server com.apple.launchd[1] (0x7f82db62da20.anonymous.nohup[19280]): Switching sessions is not allowed in the system Mach bootstrap.
    May 27 09:29:48 server com.apple.launchd[1] (0x7f82db62da20.anonymous.nohup[19280]): _vprocmgr_switch_to_session(): kr = 0x44c
    May 27 09:29:48 server com.apple.launchd[1] (0x7f82dc800da0.anonymous.nohup[19281]): Bug: launchd_core_logic.c:9394 (25693):0
    May 27 09:29:48 server com.apple.launchd[1] (0x7f82dc800da0.anonymous.nohup[19281]): Switching sessions is not allowed in the system Mach bootstrap.
    May 27 09:29:48 server com.apple.launchd[1] (0x7f82dc800da0.anonymous.nohup[19281]): _vprocmgr_switch_to_session(): kr = 0x44c
    May 27 09:29:48 server com.mysql.mysqld[19056]: 120527 09:29:48 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data
    May 27 09:29:49 server System Preferences[581]: status= 0
    May 27 09:29:49 server System Preferences[581]: stat /usr/local/mysql/data
    May 27 09:33:54 server login[14331]: DEAD_PROCESS: 14331 ttys000
    May 27 09:34:12 server com.apple.launchd.peruser.501[456] (com.apple.talagent[494]): Exited: Killed: 9
    May 27 09:34:12 server com.apple.launchd.peruser.501[456] ([0x0-0x3a03a].com.apple.AppleSpell[15293]): Exited: Killed: 9
    May 27 09:34:12 server com.apple.launchd.peruser.501[456] (com.apple.mdworker.pool.0[18053]): Exited: Terminated: 15
    May 27 09:34:12 server loginwindow[98]: DEAD_PROCESS: 98 console
    May 27 09:34:12 server com.apple.dock.extra[19467]: Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:34:12 server com.apple.dock.extra[19467]: 2012-05-27 09:34:12.356 com.apple.dock.extra[19467:1707] Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:34:12 server com.apple.dock.extra[19467]: Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:34:12 server com.apple.dock.extra[19467]: 2012-05-27 09:34:12.357 com.apple.dock.extra[19467:1707] Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:34:12 server com.apple.dock.extra[19467]: Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:34:12 server com.apple.dock.extra[19467]: 2012-05-27 09:34:12.357 com.apple.dock.extra[19467:1707] Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:34:12 server com.apple.dock.extra[19467]: Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:34:12 server com.apple.dock.extra[19467]: 2012-05-27 09:34:12.358 com.apple.dock.extra[19467:1707] Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:34:12 server shutdown[19471]: reboot by martinhedegaard:
    May 27 09:34:12 server shutdown[19471]: SHUTDOWN_TIME: 1338104052 753955
    rc.server[ 8 ]: Tuning server for 4 GB (rounded down).
    May 27 09:34:22 localhost bootlog[0]: BOOT_TIME 1338104062 0
    May 27 09:34:33 localhost UserEventAgent[30]: starting CaptiveNetworkSupport as SystemEventAgent built May 25 2011 12:27:35
    May 27 09:34:33 localhost UserEventAgent[30]: CertsKeychainMonitor: configuring
    May 27 09:34:33 localhost UserEventAgent[30]: WirelessAirPortDeviceNameCopy(): no BSD interface name found for object 12551
    May 27 09:34:33 localhost UserEventAgent[30]: CaptiveNetworkSupport:CaptiveSCCopyWiFiDevices:388 WiFi Device Name == NULL
    May 27 09:34:23 localhost com.apple.launchd[1]: *** launchd[1] has started up. ***
    May 27 09:34:32 localhost com.apple.launchd[1] (com.apple.powerd): Unknown value for key POSIXSpawnType: Interactive
    May 27 09:34:32 localhost com.apple.launchd[1] (com.apple.sandboxd): Unknown value for key POSIXSpawnType: Interactive
    May 27 09:34:32 localhost com.apple.launchd[1] (com.apple.xgridd.pcastserver): Bug: launchd_core_logic.c:5193 (25693):2
    May 27 09:34:32 localhost com.apple.launchd[1] (com.apple.xgridd.pcastserver): Path monitoring failed on "/var/pcast/server/xgridd/keepalive": No such file or directory
    May 27 09:34:36 localhost airportd[47]: _processDLILEvent: en1 attached (down)
    May 27 09:34:36 localhost mDNSResponder[31]: mDNSResponder mDNSResponder-320.16 (Mar 17 2012 21:31:16) starting OSXVers 11
    May 27 09:34:36 localhost UserEventAgent[30]: CaptiveNetworkSupport:CreateInterfaceWatchList:2788 WiFi Devices Found.
    May 27 09:34:36 localhost UserEventAgent[30]: CaptiveNetworkSupport:CaptivePublishState:1211 en1 - PreProbe
    May 27 09:34:36 localhost UserEventAgent[30]: CaptiveNetworkSupport:CaptiveSCRebuildCache:81 Failed to get service order
    May 27 09:34:36: --- last message repeated 1 time ---
    May 27 09:34:36 localhost UserEventAgent[30]: CaptiveNetworkSupport:CaptivePublishState:1211 en1 - PreProbe
    May 27 09:34:36 localhost UserEventAgent[30]: CaptiveNetworkSupport:CaptiveSCRebuildCache:81 Failed to get service order
    May 27 09:34:36: --- last message repeated 1 time ---
    May 27 09:34:36 localhost UserEventAgent[30]: CaptiveNetworkSupport:CaptivePublishState:1211 en1 - PreProbe
    May 27 09:34:37 server configd[35]: setting hostname to "server.martinhedegaard.dk"
    May 27 09:34:37 server configd[35]: network configuration changed.
    May 27 09:34:40 server systemkeychain[52]: done file: /var/run/systemkeychaincheck.done
    May 27 09:34:40 server configd[35]: network configuration changed.
    May 27 09:34:40: --- last message repeated 1 time ---
    May 27 09:34:40 server mDNSResponder[31]: D2D_IPC: Loaded
    May 27 09:34:40 server mDNSResponder[31]: D2DInitialize succeeded
    May 27 09:34:40 server com.apple.ucupdate.plist[83]: ucupdate: Checked 1 update, no match found.
    May 27 09:34:40 server com.apple.pfctl[92]: No ALTQ support in kernel
    May 27 09:34:40 server com.apple.pfctl[92]: ALTQ related functions disabled
    HeadlessStartup: Already setup or this is an upgrade so we will not set the password.
    May 27 09:34:40 server emond[108]: SetUpLogs: uid = 0 gid = 0
    May 27 09:34:40 server named[78]: starting BIND 9.7.3-P3 -f
    May 27 09:34:40 server named[78]: built with '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--disable-dependency-tracking' '--prefix=/usr' '--sysconfdir=/private/etc' '--localstatedir=/private/var' '--enable-atomic=no' '--with-openssl=yes' '--with-gssapi=yes' '--enable-symtable=none' 'CFLAGS=-arch x86_64 -arch i386 -g -Os -pipe -gdwarf-2 -D__APPLE_USE_RFC_2292' 'LDFLAGS=-arch x86_64 -arch i386 ' 'CXXFLAGS=-arch x86_64 -arch i386 -g -Os -pipe '
    May 27 09:34:40 server emond[108]: SetUpLogs: opening /Library/Logs/EventMonitor/EventMonitor.error.log
    May 27 09:34:40 server com.apple.SystemStarter[84]: Starting MySQL database server
    May 27 09:34:40 server loginwindow[97]: Login Window Application Started
    May 27 09:34:40 server com.apple.usbmuxd[82]: usbmuxd-268.5 on Jan  5 2012 at 03:34:01, running 64 bit
    May 27 09:34:40 server UserEventAgent[30]: WebUserEventAgent: installed
    May 27 09:34:42 server UserEventAgent[30]: Registered Workstation service - Wellness Guiden Server [3c:07:54:72:75:94]._workstation._tcp.
    May 27 09:34:43 server PasswordService[93]: -[PasswordServerPrefsObject getSearchBase]: Unable to locate search base: -1 Can't contact LDAP server
    May 27 09:34:43 server PasswordService[93]: -[PasswordServerPrefsObject loadXMLData]: Unable to locate passwordserver config record's plist attribute: -1 Can't contact LDAP server
    May 27 09:34:43 server PasswordService[93]: -[PasswordServerPrefsObject getSearchBase]: Unable to locate search base: -1 Can't contact LDAP server
    May 27 09:34:43 server PasswordService[93]: -[PasswordServerPrefsObject saveXMLData]: ldap_modify_ext_s of the passwordserver config record's plist attribute: -1 Can't contact LDAP server
    May 27 09:34:43 server named[78]: command channel listening on 127.0.0.1#54
    May 27 09:34:43 server mds[95]: (Normal) FMW: FMW 0 0
    May 27 09:34:44 server com.mysql.mysqld[117]: 120527 09:34:44 mysqld_safe Logging to '/usr/local/mysql/data/server.martinhedegaard.dk.err'.
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82db403900.anonymous.nohup[359]): Bug: launchd_core_logic.c:9394 (25693):2
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82db403900.anonymous.nohup[359]): Switching sessions is not allowed in the system Mach bootstrap.
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82db403900.anonymous.nohup[359]): _vprocmgr_switch_to_session(): kr = 0x44c
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82db62bfd0.anonymous.nohup[360]): Bug: launchd_core_logic.c:9394 (25693):0
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82db62bfd0.anonymous.nohup[360]): Switching sessions is not allowed in the system Mach bootstrap.
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82db62bfd0.anonymous.nohup[360]): _vprocmgr_switch_to_session(): kr = 0x44c
    May 27 09:34:44 server com.mysql.mysqld[117]: 120527 09:34:44 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82dd0023b0.anonymous.nohup[620]): Bug: launchd_core_logic.c:9394 (25693):0
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82dd0023b0.anonymous.nohup[620]): Switching sessions is not allowed in the system Mach bootstrap.
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82dd0023b0.anonymous.nohup[620]): _vprocmgr_switch_to_session(): kr = 0x44c
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82dd0023b0.anonymous.nohup[621]): Bug: launchd_core_logic.c:9394 (25693):0
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82dd0023b0.anonymous.nohup[621]): Switching sessions is not allowed in the system Mach bootstrap.
    May 27 09:34:44 server com.apple.launchd[1] (0x7f82dd0023b0.anonymous.nohup[621]): _vprocmgr_switch_to_session(): kr = 0x44c
    May 27 09:34:45 server freshclam[79]: Can't query current.cvd.clamav.net
    May 27 09:34:45 server freshclam[79]: Invalid DNS reply. Falling back to HTTP mode.
    May 27 09:34:46 server freshclam[79]: Can't get information about database.clamav.net: nodename nor servname provided, or not known
    May 27 09:34:46 server freshclam[79]: Can't read main.cvd header from database.clamav.net (IP: )
    May 27 09:34:47 server rpcsvchost[660]: sandbox_init: com.apple.msrpc.netlogon.sb succeeded
    May 27 09:34:47 server configd[35]: network configuration changed.
    May 27 09:34:48 server servermgrd[88]: servermgr_accounts: noteDirectorySearchPolicyChanged (reopening nodes)
    May 27 09:34:49 server ntpd[77]: proto: precision = 1.000 usec
    May 27 09:34:50 server loginwindow[97]: **DMPROXY** Found `/System/Library/CoreServices/DMProxy'.
    May 27 09:34:50 server com.apple.launchctl.LoginWindow[673]: com.apple.findmymacmessenger: Already loaded
    May 27 09:34:50 server loginwindow[97]: Login Window Started Security Agent
    May 27 09:34:50 server SecurityAgent[682]: Echo enabled
    May 27 09:34:51 server WindowServer[143]: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
    May 27 09:34:51 server freshclam[79]: Current functionality level = 61, recommended = 63
    May 27 09:34:53 server ScreensharingAgent[695]: [CL_INVALID_DEVICE] : OpenCL Error : Failed to create context! Invalid device
    May 27 09:34:54 server screensharingd[694]: 3891612: (connectAndCheck) Untrusted apps are not allowed to connect to or launch Window Server before login.
    May 27 09:34:54 server screensharingd[694]: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
    May 27 09:35:10 server sandboxd[713] ([712]): xscertd(712) deny job-creation
    May 27 09:35:10 server UserEventAgent[30]: CertsKeychainMonitor: ready to process keychain & timer events
    May 27 09:35:48 server servermgrd[88]: getting service list
    May 27 09:35:49 server servermgrd[88]: servermgr_ipfilter:ipfw config:Notice:Flushed IPv4 rules
    May 27 09:35:49 server servermgrd[88]: servermgr_ipfilter:ipfw config:Notice:Flushed IPv6 rules
    May 27 09:36:08 server SecurityAgent[682]: User info context values set for martinhedegaard
    May 27 09:36:08 server SecurityAgent[682]: Login Window login proceeding
    May 27 09:36:08 server loginwindow[97]: Login Window - Returned from Security Agent
    May 27 09:36:08 server loginwindow[97]: USER_PROCESS: 97 console
    May 27 09:36:08 server com.apple.launchd.peruser.501[703] (com.apple.ReportCrash): Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self
    May 27 09:36:08 server com.apple.launchctl.Aqua[757]: load: option requires an argument -- D
    May 27 09:36:08 server com.apple.launchctl.Aqua[757]: usage: launchctl load [-wF] [-D <user|local|network|system|all>] paths...
    May 27 09:36:09 server com.apple.launchd.peruser.501[703] (com.apple.launchctl.Aqua[757]): Exited with code: 1
    May 27 09:36:09 server ScreensharingAgent[773]: [CL_INVALID_DEVICE] : OpenCL Error : Failed to create context! Invalid device
    May 27 09:36:09 server UserEventAgent[30]: CaptiveNetworkSupport:CNSServerRegisterUserAgent:187 new user agent port: 17183
    May 27 09:36:10 server com.apple.dock.extra[802]: Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:36:10 server com.apple.dock.extra[802]: 2012-05-27 09:36:10.163 com.apple.dock.extra[802:1707] Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:36:10 server com.apple.dock.extra[802]: Could not connect the action buttonPressed: to target of class NSApplication
    May 27 09:36:10 server com.apple.dock.extra[802]: 2012-05-27 09:36:10.164 com.apple.dock.extra[802:1

  • How to share raw partitions on Mac OS X Server ?

    Hello,
    I'm trying to build a RAC Database with 3 nodes. I have created 2 raw partitions for the OCR and CRS Voting Disk on the local hard drive of node 1.
    I read the documentation concerning how to install a RAC Database on Mac OS X Server, but I don't know how to share the 2 raws partitions between my nodes.
    Anyone could explain me how to share those raw partitions accross all nodes ?
    Regards,
    Bob

    Good morning Bob,
    I guess you refer the the linux firewire solution for rac. It would surprize me if that works for the mac since on linux they created special kernel modules for it to be able to run. When connecting 3 servers you would need a firewire switch. From what I have seen sofar, the mac mounts the firewire drives exclusively and the (linux)kernel modifictions change that to shared allowing multiple servers to connect.
    For storage I would definately go for ASM. It makes you choice for storage hardware a bit less critical. Let oracle do what otherwise a highend SAN solution would do. Why are you building the RAC ? If it has a serious goal, get a xserve-RAID. I don't think you can get a better price/performance ratio. What other storage hardware do you have available ? (netapp would be fine ;-))
    regards,
    Ronald
    http://ronr.nl/unix-dba

Maybe you are looking for

  • I have downloaded Elements 13 but it is the 32 bit version. How do I get the 64 bit version

    When downloading Elements 13, how do I get the option to choose between the 32 and 64 bit versions? I am automatically getting the 32 bit version which is no good for my operating system.

  • Unable to open attachments(.pdf file , .eml file ) in iPad or iPhone

    Hi, We are facing one critical issue that unable to open (few attachments ) .pdf or .eml on iPad or iPhone . But same file we could open using  gmail or other account  in a same iPhone or iPad.  Please help me to resolve this. Thanks & Regards, Vinot

  • Problem in Upload for HR Cube

    Hello, I am facing one problem when i am uploading data in HR Cube Qualification (0PAPD_C01). When i am uploading from R3 to BW it is giving 0 records. Also it is giving green signal. But in my R3 extractor, 7,350 records is available. Same connectio

  • Transactional Context

    hi guys Have a quick question on transactional context Question: Will the transactional context be passed on from a LSB mediator to other java components (simple java classes). The LSB is delgating control to managers which are simple java classes. T

  • Help! Just want to share DSL between new iMac & existing Windows laptop

    I have existing laptop running on Windows XP, connected to a DSL modem via ethernet cable. The modem also has an additional USB slot. I want to access the Internet from my new iMac G5, using the same DSL line, but not share anything (files, printer,