Config Issues

Hi guys,
I am having some trouble with this config. All i am looking to do is a simple reverse proxy to this one host. When the page comes up it prompts me to download a bin file.... Probe succeeds and it says its working. I would also like to redirect to /spend What am i missing?
PA-ACE-4700-SLB/Spend-Support# show run
Generating configuration....
crypto chaingroup SPEND-CHAINGROUP
  cert AddTrustExternalCARoot.crt
  cert COMODOHigh-AssuranceSecureServerCA.crt
access-list allow line 8 extended permit ip any any
probe tcp HTTPS_PROBE
  port 443
  interval 5
  passdetect interval 5
  receive 3
  connection term forced
  open 2
probe tcp TCP8005_PROBE
  port 8005
  interval 5
  passdetect interval 5
  receive 3
  connection term forced
  open 2
rserver host Spend
  ip address 10.0.10.22
  inservice
serverfarm host SPEND
  probe HTTPS_PROBE
  rserver Spend 443
    inservice
ssl-proxy service SPEND-SSLPROXY
  key ProdKEYPAIR.PEM
  cert WWW-PROD-CERT.crt
  chaingroup SPEND-CHAINGROUP
class-map type http loadbalance match-any L5
  2 match http url /.*
class-map match-all SPEND-CLASS
  2 match virtual-address 10.0.1.110 tcp eq https
policy-map type loadbalance first-match HTTPS
  class L5
    serverfarm SPEND
policy-map multi-match SPEND-SLB
  class SPEND-CLASS
    loadbalance vip inservice
    loadbalance policy HTTPS
    loadbalance vip icmp-reply active
    nat dynamic 1 vlan 1000
    ssl-proxy server SPEND-SSLPROXY
interface vlan 1000
  ip address 10.0.1.109 255.255.255.0
  access-group input allow
  nat-pool 1 10.0.1.110 10.0.1.110 netmask 255.255.255.255 pat
  service-policy input SPEND-SLB
  no shutdown
ip route 0.0.0.0 0.0.0.0 10.0.1.8
Thanks!
-Andy

Hey Andy what´s up?
Ok, Could you explain a little bit what seems to be the issue which you got or what you want to accomplish here?
You said, you are typing: https://10.0.1.110 and it should show the content of 10.0.10.22 but it is not or you are typing
https://10.0.1.110/spend and you expect the ACE magicly know what to do?
Could you specify a little bit?
If you are trying to do the following:
https://10.0.1.110/spend
then you may try something like:
class-map type http loadbalance match-any spend
  2 match http url /spend
policy-map type loadbalance first-match HTTPS
  class spend
    serverfarm SPEND
  class L5
    serverfarm serverfarm-for-others
Please specify what you are looking for.
Jorge

Similar Messages

  • I can sync bookmarks on my Firfox for android, but folders aren't sync, i can only get bookmarks from bookmarks main folder. Is a bug or a config issue?

    I can sync bookmarks in firefox for android, but only the ones that are on Bookmarks main folder, the folders create below the main folder are not synchronized. Is this a bug or a config issue?
    Thanks

    Thanks Barney, I tried that but all that comes up in Spotlight are the log files that show the file paths! I don't know how Steam works. Are all the files held by Steam on their server perhaps?

  • 851 Router Config Issue

    Hi all,
    Hopefully this will be a nice easy one for you all.
    I have recently configured and installed an 851 router successfully :) I now only have one issue, the damn thing switches itself off after a period of inactivity!
    If I want to use it again I have to issue a reset command then a boot command.
    This takes me to the:
    router>
    prompt. I then have to issue a copy start run command. And then a no shut on each of my interfaces.
    Obviously I would just like the router to stay up and running. But I cant work out how to do it. Im sure that this is just a simple config issue and I would dearly love for you all to solve it!
    If any of you know the answer can you please provide clear an accurate commands as I will copy it parrott fashion into the router.
    Thank you all in advance.
    Stuart

    Hello,
    as spremkumar already pointed out the config register usually is set to 0x2102. You can reconfigure the register by:
    Router#configute terminal
    Router(config)#config-register 0x2102
    Router(config)#end
    Then perform a reload and check whether the config is present after the router finished booting.
    Hope this helps! Please rate all posts.
    Regards, Martin

  • HP LaserJet p1102w with Mac OS X10.6.8 HTML config issue

    Hello, 
    I have been using this printer for a few years now and have moved house a few times and successfully updated the wireless settings on the printer through HTML config. Lately, in printer utilities the HTML config button does not show up where it is meant to.
    I have installed / uninstalled the latest firmware, software drivers, printers and made sure they were platform specific.
    This is really annoying. 
    Is there old software available for download? it was working fine until the recent update - which I did so I could use the eprint features.
    Best regards
    Costas
    Printer: 
    HP LaserJet p1102w, Firmware datacode = 20130213
    Computer:
    Macbook white, late 2008 model: 2.4Ghz Core2Duo, 4G RAM with OS X 10.6.8

    From the name of the printer, it looks like you have it installed through a USB connection. 
    Here is what I would. First go into “System Preferences” and then select either  “Print & Scan” or "Print & Fax".
    Right click (or control + click) on the rectangle listing your printers and then select “Reset Printing System”.  
    NOTE: This will delete all printers. 
    After you have reset the printing system, let's make sure you have the most recent HP driver package installed. 
    You can download it here: http://support.apple.com/downloads/DL907/en_US/HPPrinterDrivers2.14.dmg
    Once you have downloaded the driver package and completed the installation, go into your print settings under System Preferences > Print & Scan. To add the printer, click the plus (+) sign. You should see your printer listed here. If not, click "Add Printer or Scanner." Click the name of your printer and then click "Use:” box.  Make sure that says the name of your printer and not AirPrint. Next make sure that the printer "Kind:" is set to Bonjour or Bonjour Multifunction. Click "Add" down in the bottom right hand corner.
    This will add your printer back using the most recent HP print driver available through Apple. Let me know if this helps resolve your issue or not. If it doesn't, let me know I will see what else I can do.
    Best of luck,
    Kyle
    -------------How do I give Kudos? | How do I mark a post as Solved? --------------------------------------------------------

  • LIRC-0.9.1: Remote not working, scancodes, config issues

    Hi,
    I'm using arch (kernel 3.16.0-2-ARCH #1 SMP PREEMPT x86_64 GNU/Linux), a TechnoTrend USB IR Receiver and my custom remote (not covered by existing configs). I installed lirc and lirc-utils via testing repo (lirc-0.9.1). My problem is that I can access my device, but irw gives me no output at all.
    At first some outputs:
    ir-keytable:
    Found /sys/class/rc/rc0/ (/dev/input/event17) with:
    Driver ttusbir, table rc-tt-1500
    Supported protocols: NEC RC-5 RC-6 JVC SONY SANYO LIRC other
    Enabled protocols: RC-5
    Name: TechnoTrend USB IR Receiver
    bus: 3, vendor/product: 0b48:2003, version: 0x0101
    Repeat delay = 500 ms, repeat period = 125 ms
    output of "ir-keytable -t" for numbers 1-6 on my remote:
    Testing events. Please, press CTRL-C to abort.
    1408117586.815011: event type EV_MSC(0x04): scancode = 0x01
    1408117586.815011: event type EV_SYN(0x00).
    1408117586.934967: event type EV_MSC(0x04): scancode = 0x01
    1408117586.934967: event type EV_SYN(0x00).
    1408117587.702986: event type EV_MSC(0x04): scancode = 0x02
    1408117587.702986: event type EV_SYN(0x00).
    1408117588.366958: event type EV_MSC(0x04): scancode = 0x03
    1408117588.366958: event type EV_SYN(0x00).
    1408117588.486983: event type EV_MSC(0x04): scancode = 0x03
    1408117588.486983: event type EV_SYN(0x00).
    1408117589.094926: event type EV_MSC(0x04): scancode = 0x04
    1408117589.094926: event type EV_SYN(0x00).
    1408117589.214920: event type EV_MSC(0x04): scancode = 0x04
    1408117589.214920: event type EV_SYN(0x00).
    1408117590.926837: event type EV_MSC(0x04): scancode = 0x05
    1408117590.926837: event type EV_SYN(0x00).
    1408117591.046834: event type EV_MSC(0x04): scancode = 0x05
    1408117591.046834: event type EV_SYN(0x00).
    1408117592.446769: event type EV_MSC(0x04): scancode = 0x06
    1408117592.446769: event type EV_SYN(0x00).
    1408117592.566769: event type EV_MSC(0x04): scancode = 0x06
    1408117592.566769: event type EV_SYN(0x00).
    My remote config file looks like this:
    # Please make this file available to others
    # by sending it to <[email protected]>
    # this config file was automatically generated
    # using lirc-0.9.0(devinput) on Thu Aug 7 15:10:35 2014
    # contributed by
    # brand: Test
    # model no. of remote control:
    # devices being controlled by this remote:
    begin remote
    name BlackFlatOne
    bits 16
    eps 30
    aeps 100
    pre_data_bits 16
    pre_data 0x0001
    post_data_bits 32
    post_data 0x00000001
    gap 132799
    toggle_bit 0
    begin codes
    KEY_POWER 0x0c
    KEY_MUTE 0x0a
    KEY_SELECT 0x38
    KEY_Z 0x0f
    KEY_1 0x01
    KEY_2 0x02
    KEY_3 0x03
    KEY_4 0x04
    KEY_5 0x05
    KEY_6 0x06
    KEY_7 0x07
    KEY_8 0x08
    KEY_9 0x09
    KEY_0 0x00
    KEY_TV 0x1e
    KEY_LEFT 0x11
    KEY_RIGHT 0x10
    KEY_UP 0x20
    KEY_DOWN 0x21
    KEY_ENTER 0x0d
    KEY_CHANNELUP 0x12
    KEY_CHANNELDOWN 0x13
    KEY_VOLUMEUP 0x2b
    KEY_VOLUMEDOWN 0x2c
    KEY_STOP 0x0b
    KEY_RECORD 0x1f
    KEY_CAMERA 0x0e
    KEY_ESC 0x29
    end codes
    end remote
    I start lirc manually with
    lircd --driver=devinput --device=/dev/input/by-id/usb-TechnoTrend_AG_TT-USB_Infrared_Device-event-ir BlackFlatOne -n
    After starting lirc, I start irw, but I get no response at all when pressing buttons on my remote.
    I already tried a
    cat /dev/input/by-id/usb-TechnoTrend_AG_TT-USB_Infrared_Device-event-ir
    (lirc and irw not running, of course) and this gives me cryptic symbols when pressing buttons on my remote, so the IR receiver doesn't seem to be the problem.
    I'm wondering if the scancodes in my config are ok for a devinput-device, because the latest "official" lircd.conf.devinput looks like that:
    # generated by devinput.sh
    begin remote
    name devinput
    bits 16
    eps 30
    aeps 100
    pre_data_bits 16
    pre_data 0x0001
    post_data_bits 32
    post_data 0x00000001
    gap 132799
    toggle_bit 0
    begin codes
    KEY_0 11
    KEY_102ND 86
    KEY_1 2
    KEY_2 3
    KEY_3 4
    KEY_4 5
    KEY_5 6
    KEY_6 7
    KEY_7 8
    KEY_8 9
    KEY_9 10
    KEY_A 30
    KEY_AB 0x196
    KEY_ADDRESSBOOK 0x1ad
    KEY_AGAIN 129
    So I'm wondering about the different lengths of the keycodes (e.g. 0x0d vs 0x1ad -> 2 vs 3 digits).
    Can anyone help me out with this issue ?
    Am I missing something ?
    How do I have to format the scancodes/keycodes the correct way for version 0.9.1 ?

    Hi,
    I'm using arch (kernel 3.16.0-2-ARCH #1 SMP PREEMPT x86_64 GNU/Linux), a TechnoTrend USB IR Receiver and my custom remote (not covered by existing configs). I installed lirc and lirc-utils via testing repo (lirc-0.9.1). My problem is that I can access my device, but irw gives me no output at all.
    At first some outputs:
    ir-keytable:
    Found /sys/class/rc/rc0/ (/dev/input/event17) with:
    Driver ttusbir, table rc-tt-1500
    Supported protocols: NEC RC-5 RC-6 JVC SONY SANYO LIRC other
    Enabled protocols: RC-5
    Name: TechnoTrend USB IR Receiver
    bus: 3, vendor/product: 0b48:2003, version: 0x0101
    Repeat delay = 500 ms, repeat period = 125 ms
    output of "ir-keytable -t" for numbers 1-6 on my remote:
    Testing events. Please, press CTRL-C to abort.
    1408117586.815011: event type EV_MSC(0x04): scancode = 0x01
    1408117586.815011: event type EV_SYN(0x00).
    1408117586.934967: event type EV_MSC(0x04): scancode = 0x01
    1408117586.934967: event type EV_SYN(0x00).
    1408117587.702986: event type EV_MSC(0x04): scancode = 0x02
    1408117587.702986: event type EV_SYN(0x00).
    1408117588.366958: event type EV_MSC(0x04): scancode = 0x03
    1408117588.366958: event type EV_SYN(0x00).
    1408117588.486983: event type EV_MSC(0x04): scancode = 0x03
    1408117588.486983: event type EV_SYN(0x00).
    1408117589.094926: event type EV_MSC(0x04): scancode = 0x04
    1408117589.094926: event type EV_SYN(0x00).
    1408117589.214920: event type EV_MSC(0x04): scancode = 0x04
    1408117589.214920: event type EV_SYN(0x00).
    1408117590.926837: event type EV_MSC(0x04): scancode = 0x05
    1408117590.926837: event type EV_SYN(0x00).
    1408117591.046834: event type EV_MSC(0x04): scancode = 0x05
    1408117591.046834: event type EV_SYN(0x00).
    1408117592.446769: event type EV_MSC(0x04): scancode = 0x06
    1408117592.446769: event type EV_SYN(0x00).
    1408117592.566769: event type EV_MSC(0x04): scancode = 0x06
    1408117592.566769: event type EV_SYN(0x00).
    My remote config file looks like this:
    # Please make this file available to others
    # by sending it to <[email protected]>
    # this config file was automatically generated
    # using lirc-0.9.0(devinput) on Thu Aug 7 15:10:35 2014
    # contributed by
    # brand: Test
    # model no. of remote control:
    # devices being controlled by this remote:
    begin remote
    name BlackFlatOne
    bits 16
    eps 30
    aeps 100
    pre_data_bits 16
    pre_data 0x0001
    post_data_bits 32
    post_data 0x00000001
    gap 132799
    toggle_bit 0
    begin codes
    KEY_POWER 0x0c
    KEY_MUTE 0x0a
    KEY_SELECT 0x38
    KEY_Z 0x0f
    KEY_1 0x01
    KEY_2 0x02
    KEY_3 0x03
    KEY_4 0x04
    KEY_5 0x05
    KEY_6 0x06
    KEY_7 0x07
    KEY_8 0x08
    KEY_9 0x09
    KEY_0 0x00
    KEY_TV 0x1e
    KEY_LEFT 0x11
    KEY_RIGHT 0x10
    KEY_UP 0x20
    KEY_DOWN 0x21
    KEY_ENTER 0x0d
    KEY_CHANNELUP 0x12
    KEY_CHANNELDOWN 0x13
    KEY_VOLUMEUP 0x2b
    KEY_VOLUMEDOWN 0x2c
    KEY_STOP 0x0b
    KEY_RECORD 0x1f
    KEY_CAMERA 0x0e
    KEY_ESC 0x29
    end codes
    end remote
    I start lirc manually with
    lircd --driver=devinput --device=/dev/input/by-id/usb-TechnoTrend_AG_TT-USB_Infrared_Device-event-ir BlackFlatOne -n
    After starting lirc, I start irw, but I get no response at all when pressing buttons on my remote.
    I already tried a
    cat /dev/input/by-id/usb-TechnoTrend_AG_TT-USB_Infrared_Device-event-ir
    (lirc and irw not running, of course) and this gives me cryptic symbols when pressing buttons on my remote, so the IR receiver doesn't seem to be the problem.
    I'm wondering if the scancodes in my config are ok for a devinput-device, because the latest "official" lircd.conf.devinput looks like that:
    # generated by devinput.sh
    begin remote
    name devinput
    bits 16
    eps 30
    aeps 100
    pre_data_bits 16
    pre_data 0x0001
    post_data_bits 32
    post_data 0x00000001
    gap 132799
    toggle_bit 0
    begin codes
    KEY_0 11
    KEY_102ND 86
    KEY_1 2
    KEY_2 3
    KEY_3 4
    KEY_4 5
    KEY_5 6
    KEY_6 7
    KEY_7 8
    KEY_8 9
    KEY_9 10
    KEY_A 30
    KEY_AB 0x196
    KEY_ADDRESSBOOK 0x1ad
    KEY_AGAIN 129
    So I'm wondering about the different lengths of the keycodes (e.g. 0x0d vs 0x1ad -> 2 vs 3 digits).
    Can anyone help me out with this issue ?
    Am I missing something ?
    How do I have to format the scancodes/keycodes the correct way for version 0.9.1 ?

  • Ccm.config issue - cluster

    <pre>Hi there,
    XI 3.1 , Linux
    We have a very strange situation.
    We built a cluster for two servers bo1 and bo2 - they had SIA nodes called SIA1 and SIA2 respectively
    A week or two ago, the BO repository became corrupted and we had to re-initalise it
    This meant re-building the cluster. This necessitated the creatiion of a new SIA node for bo2 called SIAII (not my idea!!)
    We did this using cmsdbsetup
    This appeared to work and we appeared to have a working cluster
    We noticed yesterday that a scheduled webi doc created on bo1 that was to run every 15 minutes was intermittently failing - about 3 out of 10 instances failed.
    When we dug deeper, we were able to establish that the webi doc failed when the request was passed to bo2 - indeed it appeared to bring down the wireportserver.exe (both of them)
    We re-checked the cluster via cmsdbsetup and everything looked fine.
    Then we checked the ccm.config for bo1 and bo2 and things look a little strange. I believe a colleague may edited ccm.config incorrectly - there were 2 sets of entries in ccm.config for bo2 - one for SIA2 and another for SIAII. Perhaps the wrong one was removed/edited
    Below is the comparsion of the 2 ccm.config files (bo2 on the left; bo1 on the right)
    Neither have anything ins CLUSTER_NAMESERVER=""  - is this correct
    MYSQLHOSTNAME is incorrect on both
    CMSCLUSTER="no"  ?
    On bo2 the node name is  SIANODENAME="SIA2"
    We looked at the registry entries and we can see entries for the old SIA...
    Real question here is whether the ccm.config is accessed when one member of the cluster passed a report request to the other cluster member - would this be our issue?
    SERVICENAME_AUDIT="BOE120_AUDIT"                                SERVICENAME_AUDIT="BOE120_AUDIT"
    NAMESERVER="bo2"                                              | NAMESERVER="bo1"
    DBTYPE="MySQL"                                                  DBTYPE="MySQL"
    INSTALLTYPE="new"                                               INSTALLTYPE="new"
    REINIT="yes"                                                    REINIT="yes"
    BOBJEVERSION="12.0"                                             BOBJEVERSION="12.0"
    SHUTDOWNPORT="8005"                                             SHUTDOWNPORT="8005"
    REGFILE="/home/BOXI/bobje/data/.bobj"                           REGFILE="/home/BOXI/bobje/data/.bobj"
    DBTYPE_AUDIT="MySQL"                                            DBTYPE_AUDIT="MySQL"
    CLUSTER_NAMESERVER=""                                           CLUSTER_NAMESERVER=""
    CONNECTORPORT="8080"                                            CONNECTORPORT="8080"
    SIAPORTNUMBER="6410"                                            SIAPORTNUMBER="6410"
    BOBJELANG="en"                                                  BOBJELANG="en"
    BOBJELICENSEKEY="XXXX-xxxxxx-xxxxxxxxx-xxxx"                    BOBJELICENSEKEY="XXXX-xxxxxx-xxxxxxxxx-xxxx"
    MYSQLHOSTNAME="127.0.0.1"                                       MYSQLHOSTNAME="127.0.0.1"
    PRODUCTID_NAME="BusinessObjects"                                PRODUCTID_NAME="BusinessObjects"
    PRODUCTID_VER="12.1"                                            PRODUCTID_VER="12.1"
    LOCALNAMESERVER="bo2"                                         | LOCALNAMESERVER="bo1"
    PIDDIR="/home/BOXI/bobje/serverpids"                            PIDDIR="/home/BOXI/bobje/serverpids"
    CMSCLUSTER="no"                                                 CMSCLUSTER="no"
    REDIRECTPORT="8443"                                             REDIRECTPORT="8443"
    SIANODENAME="SIA2"                                            | SIANODENAME="SIA"
    DEFAULT_NAMESERVER="bo2"                                      | DEFAULT_NAMESERVER="bo1"
    INSTALL_DIR="/home/BOXI/bobje/"                                 INSTALL_DIR="/home/BOXI/bobje/"
    BOBJEUSERNAME="toronto1"                                        BOBJEUSERNAME="toronto1"
    CMSNAMESERVER="bo2"                                           | CMSNAMESERVER="bo1"
    DATABASEUID="toronto1"                                          DATABASEUID="toronto1"
    INSTALLMYSQL="yes"                                              INSTALLMYSQL="yes"
    BOBJEDIR="/home/BOXI/bobje/"                                    BOBJEDIR="/home/BOXI/bobje/"
    BOBJEINSTALLLOCAL="system"                                      BOBJEINSTALLLOCAL="system"
    SERVICENAME="BOE120"                                            SERVICENAME="BOE120"
    CMSPORTNUMBER="6400"                                            CMSPORTNUMBER="6400"
    CLUSTERPORTNUMBER="6400"                                        CLUSTERPORTNUMBER="6400"
    SERVICEPORT="3306"                                              SERVICEPORT="3306"
    SERVICEPORT_AUDIT="3306"                                        SERVICEPORT_AUDIT="3306"
    MYSQLHOSTNAME_AUDIT="127.0.0.1"                                 MYSQLHOSTNAME_AUDIT="127.0.0.1"
    SIAIILAUNCH='"/home/BOXI/bobje/enterprise120/generic/bobjrest | SIALAUNCH='"/home/BOXI/bobje/enterprise120/generic/bobjrestar
    </pre>
    Edited by: jemstar on Jun 25, 2009 12:42 PM

    <pre>The logs are attached below - might be a registry related issue??
    ceserver.cpp:968:virtual bool CDZServer::onInitialize(): TraceLog message 1
    2009/06/25 10:40:42.468|>>|E| |16511|1137466256| |||||||||||||||**ERROR:ceserver:invalid entry General\Directories\Config in registry [ceserver.cpp;968]
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 2
    2009/06/25 10:41:40.613|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 3
    2009/06/25 10:41:40.613|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 4
    2009/06/25 10:41:40.850|>>|E| |16511|1199270800| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 5
    2009/06/25 10:41:40.850|>>|E| |16511|1199270800| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 6
    2009/06/25 10:47:06.844|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 7
    2009/06/25 10:47:06.844|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 8
    2009/06/25 10:47:39.350|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 9
    2009/06/25 10:47:39.350|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 10
    2009/06/25 10:48:30.154|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 11
    2009/06/25 10:48:30.154|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 12
    2009/06/25 10:51:39.548|>>|E| |16511|1176263568| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 13
    2009/06/25 10:51:39.548|>>|E| |16511|1176263568| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 14
    2009/06/25 10:54:22.550|>>|E| |16511|1198218128| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 15
    2009/06/25 10:54:22.550|>>|E| |16511|1198218128| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 16
    2009/06/25 10:55:55.728|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 17
    2009/06/25 10:55:55.728|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 18
    2009/06/25 10:56:44.085|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 19
    2009/06/25 10:56:44.085|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 20
    2009/06/25 10:59:11.076|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 21
    2009/06/25 10:59:11.076|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 22
    2009/06/25 11:01:11.492|>>|E| |16511|1199270800| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 23
    2009/06/25 11:01:11.492|>>|E| |16511|1199270800| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 24
    2009/06/25 11:06:19.005|>>|E| |16511|1176263568| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 25
    2009/06/25 11:06:19.005|>>|E| |16511|1176263568| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 26
    2009/06/25 11:11:12.031|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 27
    2009/06/25 11:11:12.031|>>|E| |16511|1170385808| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    kc3xmlGenericParser.cpp:389:bool Cube::XmlTools::ValueTypedConstant::Validate(const Cube::XmlTools::ic3TokenTranslator*): TraceLog message 28
    2009/06/25 11:14:01.242|>>|E| |16511|1170385808| |||||||||||||||**ERROR:C3_GenericParser:ValueTypedConstant::Validate - Client - Invalid value : B95ED5004B624ADF927180432D8E2018 [kc3xmlGenericParser.cpp;389]
    kc3cdbdataprovider.cpp:3641:virtual BOResult cdbDataProvider::SetQuerySpec(const ibo_ptr<iboUnknown>&): TraceLog message 29
    2009/06/25 11:14:01.250|>>|E| |16511|1170385808| |||||||||||||||**ERROR:C3_Dataprovider:QuerySpec Validate failed ! [kc3cdbdataprovider.cpp;3641]
    kdgDocument.cpp:10587:void dgDocument::Check(bool, const char*, bool) const: TraceLog message 30
    2009/06/25 11:14:01.250|>>|E| |16511|1170385808| |||||||||||||||**ERROR:dgDocument:An internal error occured while dgDocument is calling pDataProvider->SetQuerySpec(pQuerySpec) [kdgDocument.cpp;10587]
    kdgDocumentEx.cpp:1589:virtual BOResult dgDocument::SetQueryMDP(const bo_wstring&, const ibo_ptr<iboUnknown>&, std::ostream&, std::ostream*): TraceLog message 31
    2009/06/25 11:14:01.251|>=|E|X|16511|1170385808| |||||||||||||||Uncaught Exception in SilentScope: dgDocumentEx:SetQueryMDP: 0.009
    kdgDocument.cpp:4342:BOResult dgDocument::SetQueryMDP(const dgCommandParser::DPCOMMAND&, std::ostream&): TraceLog message 32
    2009/06/25 11:14:01.251|>=|E|X|16511|1170385808| |||||||||||||||Uncaught Exception in SilentScope: dgDocument:SetQueryMDP: 0.009
    kdgDocument.cpp:4020:void dgDocument::UpdateQueryMDP(const dgCommandParser::DPCOMMAND&, std::ostream&): TraceLog message 33
    2009/06/25 11:14:01.251|>=|E|X|16511|1170385808| |||||||||||||||Uncaught Exception in SilentScope: dgDocument:UpdateQueryMDP: 0.009
    kdgDocument.cpp:1649:virtual BOResult dgDocument::ProcessDPCommands(std::istream&, bool, std::ostream&): TraceLog message 34
    2009/06/25 11:14:01.251|>=|E|X|16511|1170385808| |||||||||||||||Uncaught Exception in SilentScope: dgDocument:ProcessDPCommands: 0.01
    SystemHelpers.cpp:532:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 35
    2009/06/25 11:32:27.546|>>|E| |16511|1199270800| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:532: unable to resolve the USER_DOCUMENTS variable
    SystemHelpers.cpp:540:static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&): TraceLog message 36
    2009/06/25 11:32:27.547|>>|E| |16511|1199270800| |||||||||||||||in static bo_utf8string Helpers::Registry::expandUserDocumentDir(bo_utf8string&) at SystemHelpers.cpp:540: unable to resolve the USER_PROFILE_APP_DIR variable
    </pre>

  • JMS Adapter Config issues with Plan.xml

    Hi All,
    I'm learning how to configure JMS Resources in WLS to use within a JMS adapter in my application. My approach so far has been :
    1. Configure Outbound Connection in JMS Adapter : eis/wls/Queue. I used the weblogic.jms.XAConnectionFactory as the Connection Factory.
    2. Create Queue within SOAJMSModule : jms/MyQueue and target - soa managed server.
    Updated the JMSAdapter.rar deployment and restarted the SOA server as well as the JMS module.
    3. Create JMS Adapter within JDeveloper to use jms/MyQueue as the destination and eis/wls/Queue as the JNDI source.
    On deployment and running, I see this following error. Apologies it is a bit difficult to trawl through. I did have a look in the Plan.xml and it definitely has an entry for this Adapter and the jndi-name. Any other approach?
    Oracle.sysman.emSDK.webservices.wsdlapi.SoapTestException: Exception occured when binding was invoked. Exception occured during invocation of JCA binding: "JCA Binding execute of Reference operation 'PostException' failed due to: JCA Binding Component connection issue. JCA Binding Component is unable to create an outbound JCA (CCI) connection. ExceptionManagement:JMSPostException [ PostException_ptt::PostException(body) ] : The JCA Binding Component was unable to establish an outbound JCA CCI connection due to the following issue: BINDING.JCA-12510 JCA Resource Adapter location error. Unable to locate the JCA Resource Adapter via .jca binding file element <connection-factory/> The JCA Binding Component is unable to startup the Resource Adapter specified in the <connection-factory/> element: location='eis/wls/Queue'. The reason for this is most likely that either 1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic Application server or 2) the '<jndi-name>' element in weblogic-ra.xml has not been set to eis/wls/Queue. In the last case you will have to add a new WebLogic JCA connection factory (deploy a RAR). Please correct this and then restart the Application Server Please make sure that the JCA connection factory and any dependent connection factories have been configured with a sufficient limit for max connections. Please also make sure that the physical connection to the backend EIS is available and the backend itself is accepting connections. ". The invoked JCA adapter raised a resource exception. Please examine the above error message carefully to determine a resolution. at oracle.sysman.emas.model.wsmgt.WSTestModel.invokeOperation(WSTestModel.java:575) at oracle.sysman.emas.view.wsmgt.WSView.invokeOperation(WSView.java:381) at oracle.sysman.emas.view.wsmgt.WSView.invokeOperation(WSView.java:298) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at com.sun.el.parser.AstValue.invoke(Unknown Source) at com.sun.el.MethodExpressionImpl.invoke(Unknown Source) at org.apache.myfaces.trinidadinternal.taglib.util.MethodExpressionMethodBinding.invoke(MethodExpressionMethodBinding.java:53) at org.apache.myfaces.trinidad.component.UIXComponentBase.broadcastToMethodBinding(UIXComponentBase.java:1256) at org.apache.myfaces.trinidad.component.UIXCommand.broadcast(UIXCommand.java:183) at oracle.adf.view.rich.component.fragment.ContextSwitchingComponent$1.run(ContextSwitchingComponent.java:92) at oracle.adf.view.rich.component.fragment.ContextSwitchingComponent._processPhase(ContextSwitchingComponent.java:361) at oracle.adf.view.rich.component.fragment.ContextSwitchingComponent.broadcast(ContextSwitchingComponent.java:96) at oracle.adf.view.rich.component.fragment.UIXInclude.broadcast(UIXInclude.java:102) at oracle.adf.view.rich.component.fragment.ContextSwitchingComponent$1.run(ContextSwitchingComponent.java:92) at oracle.adf.view.rich.component.fragment.ContextSwitchingComponent._processPhase(ContextSwitchingComponent.java:361) at oracle.adf.view.rich.component.fragment.ContextSwitchingComponent.broadcast(ContextSwitchingComponent.java:96) at oracle.adf.view.rich.component.fragment.UIXInclude.broadcast(UIXInclude.java:96) at javax.faces.component.UIViewRoot.broadcastEvents(UIViewRoot.java:475) at javax.faces.component.UIViewRoot.processApplication(UIViewRoot.java:756) at oracle.adfinternal.view.faces.lifecycle.LifecycleImpl._invokeApplication(LifecycleImpl.java:765) at oracle.adfinternal.view.faces.lifecycle.LifecycleImpl._executePhase(LifecycleImpl.java:305) at oracle.adfinternal.view.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:185) at javax.faces.webapp.FacesServlet.service(FacesServlet.java:265) at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227) at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125) at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:300) at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.help.web.rich.OHWFilter.doFilter(Unknown Source) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.sysman.emSDK.license.LicenseFilter.doFilter(LicenseFilter.java:101) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.adf.model.servlet.ADFBindingFilter.doFilter(ADFBindingFilter.java:205) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.adfinternal.view.faces.webapp.rich.RegistrationFilter.doFilter(RegistrationFilter.java:106) at org.apache.myfaces.trinidadinternal.webapp.TrinidadFilterImpl$FilterListChain.doFilter(TrinidadFilterImpl.java:446) at oracle.adfinternal.view.faces.activedata.AdsFilter.doFilter(AdsFilter.java:60) at org.apache.myfaces.trinidadinternal.webapp.TrinidadFilterImpl$FilterListChain.doFilter(TrinidadFilterImpl.java:446) at org.apache.myfaces.trinidadinternal.webapp.TrinidadFilterImpl._doFilterImpl(TrinidadFilterImpl.java:271) at org.apache.myfaces.trinidadinternal.webapp.TrinidadFilterImpl.doFilter(TrinidadFilterImpl.java:177) at org.apache.myfaces.trinidad.webapp.TrinidadFilter.doFilter(TrinidadFilter.java:92) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.security.wls.filter.SSOSessionSynchronizationFilter.doFilter(SSOSessionSynchronizationFilter.java:276) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.sysman.emas.fwk.MASConnectionFilter.doFilter(MASConnectionFilter.java:41) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.adf.library.webapp.LibraryFilter.doFilter(LibraryFilter.java:175) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.sysman.eml.app.AuditServletFilter.doFilter(AuditServletFilter.java:179) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.sysman.eml.app.EMRepLoginFilter.doFilter(EMRepLoginFilter.java:203) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.sysman.core.model.targetauth.EMLangPrefFilter.doFilter(EMLangPrefFilter.java:158) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.sysman.core.app.perf.PerfFilter.doFilter(PerfFilter.java:141) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.sysman.eml.app.ContextInitFilter.doFilter(ContextInitFilter.java:542) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.security.jps.ee.http.JpsAbsFilter$1.run(JpsAbsFilter.java:111) at java.security.AccessController.doPrivileged(Native Method) at oracle.security.jps.util.JpsSubject.doAsPrivileged(JpsSubject.java:313) at oracle.security.jps.ee.util.JpsPlatformUtil.runJaasMode(JpsPlatformUtil.java:413) at oracle.security.jps.ee.http.JpsAbsFilter.runJaasMode(JpsAbsFilter.java:94) at oracle.security.jps.ee.http.JpsAbsFilter.doFilter(JpsAbsFilter.java:161) at oracle.security.jps.ee.http.JpsFilter.doFilter(JpsFilter.java:71) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at oracle.dms.servlet.DMSServletFilter.doFilter(DMSServletFilter.java:136) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at weblogic.servlet.internal.RequestEventsFilter.doFilter(RequestEventsFilter.java:27) at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56) at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(Unknown Source) at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(Unknown Source) at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321) at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120) at weblogic.servlet.internal.WebAppServletContext.securedExecute(Unknown Source) at weblogic.servlet.internal.WebAppServletContext.execute(Unknown Source) at weblogic.servlet.internal.ServletRequestImpl.run(Unknown Source) at weblogic.work.ExecuteThread.execute(ExecuteThread.java:207) at weblogic.work.ExecuteThread.run(ExecuteThread.java:176) Caused by: oracle.sysman.emSDK.webservices.wsdlapi.SoapTestException: Exception occured when binding was invoked. Exception occured during invocation of JCA binding: "JCA Binding execute of Reference operation 'PostException' failed due to: JCA Binding Component connection issue. JCA Binding Component is unable to create an outbound JCA (CCI) connection. ExceptionManagement:JMSPostException [ PostException_ptt::PostException(body) ] : The JCA Binding Component was unable to establish an outbound JCA CCI connection due to the following issue: BINDING.JCA-12510 JCA Resource Adapter location error. Unable to locate the JCA Resource Adapter via .jca binding file element <connection-factory/> The JCA Binding Component is unable to startup the Resource Adapter specified in the <connection-factory/> element: location='eis/wls/Queue'. The reason for this is most likely that either 1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic Application server or 2) the '<jndi-name>' element in weblogic-ra.xml has not been set to eis/wls/Queue. In the last case you will have to add a new WebLogic JCA connection factory (deploy a RAR). Please correct this and then restart the Application Server Please make sure that the JCA connection factory and any dependent connection factories have been configured with a sufficient limit for max connections. Please also make sure that the physical connection to the backend EIS is available and the backend itself is accepting connections. ". The invoked JCA adapter raised a resource exception. Please examine the above error message carefully to determine a resolution. at oracle.sysman.emSDK.webservices.wsdlapi.dispatch.DispatchUtil.invoke(DispatchUtil.java:260) at oracle.sysman.emSDK.webservices.wsdlparser.OperationInfoImpl.invokeWithDispatch(OperationInfoImpl.java:992) at oracle.sysman.emas.model.wsmgt.PortName.invokeOperation(PortName.java:729) at oracle.sysman.emas.model.wsmgt.WSTestModel.invokeOperation(WSTestModel.java:569) ... 81 more Caused by: javax.xml.ws.soap.SOAPFaultException: Exception occured when binding was invoked. Exception occured during invocation of JCA binding: "JCA Binding execute of Reference operation 'PostException' failed due to: JCA Binding Component connection issue. JCA Binding Component is unable to create an outbound JCA (CCI) connection. ExceptionManagement:JMSPostException [ PostException_ptt::PostException(body) ] : The JCA Binding Component was unable to establish an outbound JCA CCI connection due to the following issue: BINDING.JCA-12510 JCA Resource Adapter location error. Unable to locate the JCA Resource Adapter via .jca binding file element <connection-factory/> The JCA Binding Component is unable to startup the Resource Adapter specified in the <connection-factory/> element: location='eis/wls/Queue'. The reason for this is most likely that either 1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic Application server or 2) the '<jndi-name>' element in weblogic-ra.xml has not been set to eis/wls/Queue. In the last case you will have to add a new WebLogic JCA connection factory (deploy a RAR). Please correct this and then restart the Application Server Please make sure that the JCA connection factory and any dependent connection factories have been configured with a sufficient limit for max connections. Please also make sure that the physical connection to the backend EIS is available and the backend itself is accepting connections. ". The invoked JCA adapter raised a resource exception. Please examine the above error message carefully to determine a resolution. at oracle.j2ee.ws.client.jaxws.DispatchImpl.throwJAXWSSoapFaultException(DispatchImpl.java:1012) at oracle.j2ee.ws.client.jaxws.DispatchImpl.invoke(DispatchImpl.java:803) at oracle.j2ee.ws.client.jaxws.OracleDispatchImpl.synchronousInvocationWithRetry(OracleDispatchImpl.java:235) at oracle.j2ee.ws.client.jaxws.OracleDispatchImpl.invoke(OracleDispatchImpl.java:106) at oracle.sysman.emSDK.webservices.wsdlapi.dispatch.DispatchUtil.invoke(DispatchUtil.java:256) ... 84 more
    The deployment plan reads as follows :
    <deployment-plan xmlns="http://xmlns.oracle.com/weblogic/deployment-plan" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://xmlns.oracle.com/weblogic/deployment-plan http://xmlns.oracle.com/weblogic/deployment-plan/1.0/deployment-plan.xsd" global-variables="false">
    <application-name>connectors</application-name>
    <variable-definition>
    <variable>
    <name>ConnectionInstance_eis/wls/Queue_JNDIName_13401799388390</name>
    <value>eis/wls/Queue</value>
    </variable>
    <variable>
    <name>ConfigProperty_ConnectionFactoryLocation_Value_13401801874110</name>
    <value>weblogic.jms.XAConnectionFactory</value>
    </variable>
    </variable-definition>
    <module-override>
    <module-name>JmsAdapter.rar</module-name>
    <module-type>rar</module-type>
    <module-descriptor external="false">
    <root-element>weblogic-connector</root-element>
    <uri>META-INF/weblogic-ra.xml</uri>
    <variable-assignment>
    <name>ConnectionInstance_eis/wls/Queue_JNDIName_13401799388390</name>
    <xpath>/weblogic-connector/outbound-resource-adapter/connection-definition-group/[connection-factory-interface="oracle.tip.adapter.jms.IJmsConnectionFactory"]/connection-instance/[jndi-name="eis/wls/Queue"]/jndi-name</xpath>
    <origin>planbased</origin>
    </variable-assignment>
    <variable-assignment>
    <name>ConfigProperty_ConnectionFactoryLocation_Value_13401801874110</name>
    <xpath>/weblogic-connector/outbound-resource-adapter/connection-definition-group/[connection-factory-interface="oracle.tip.adapter.jms.IJmsConnectionFactory"]/connection-instance/[jndi-name="eis/wls/Queue"]/connection-properties/properties/property/[name="ConnectionFactoryLocation"]/value</xpath>
    </variable-assignment>
    </module-descriptor>
    <module-descriptor external="false">
    <root-element>connector</root-element>
    <uri>META-INF/ra.xml</uri>
    </module-descriptor>
    <module-descriptor external="true">
    <root-element>wldf-resource</root-element>
    <uri>META-INF/weblogic-diagnostics.xml</uri>
    </module-descriptor>
    </module-override>
    <config-root>E:\oracle\product\middleware\11.1.1\soa_11.1\soa\connectors\plan</config-root>
    </deployment-plan>
    Thanks
    JB
    Edited by: 939260 on Jun 20, 2012 5:13 AM

    Hi JB,
    Please follow the below steps from beginning...
    1. Create the JMS Server in the Admin Console, the target server for the same should be the soa server
    2. create new JMS Module.
    3. Create new Connection factory in resources, give your JNDI names, the target servers should be the admin and the soa.
    4. create new queue, give the JNDI names, the target server should be the JMS Server which you have created in the step 1 above.
    5. Now go to deployments, slect the JMS adapter, click update, and say redeploy with the location of JMS-plan.xml given below...
    6. Now inside the composite while configuring the JMS adapter, select the queue which you have created above.
    If you have followed the abpve steps correctly, you should not face any problem.
    Hope this helps,
    N

  • OIF+OAM: install/config  issues

    This post is long. Hoping that at least one of the issues is seen by someone or someone has insights before we open SR(s) with Oracle.
    We have a working OAM/OVD 11.1.1.5 installation (done according to the EDG at http://docs.oracle.com/cd/E21764_01/core.1111/e12035/toc.htm).
    We started an evaluation of OIF and ran into some issues grouped under Install and Config categories.
    h2. Install issues:
    We installed it per chapter 16 of that EDG and and all the steps went OK except step 16.7 (http://docs.oracle.com/cd/E21764_01/core.1111/e12035/oif.htm#BAJCJHBG).The config properties userldaphaenabled, fedldaphaenabled are getting set via WLST but don't appear to be persisted anywhere. On a restart they are false again. Are they supposed to be saved to config.xml of the IDMDomain? Can I try adding them manually like this as child elements under each of the wls_oif managed servers?
    <datastore>
    <userldaphaenabled>true</userldaphaenabled>
    <fedldaphaenabled>true</fedldaphaenabled>
    </datastore>
    If those settings were properly set what is it supposed to do? I can see that config.xml, cots.xml files are stored as blobs in one of the OIF db tables. Will the above setting move them from DB to LDAP?
    h2. Config/Runtime Issues:
    We proceeded with configuration because the /sp/metadata and /idp/metadata test URLs are working fine via the VIP address. we used this manual to do the integration.
    http://docs.oracle.com/cd/E21764_01/doc.1111/e15740/oif.htm#CACJDDGE. In section 4.3.1.6 (Configure Oracle Identity Federation in SP Mode) of this document it says to configure Oracle SSO. We only have OAM and not osso. We went ahead and configured the second tab (OAM) in the screen capture in that section as well (is there any documentation on how to configure that tab?)
    In SP mode (section 4.3) , testing of a resource protected with OIFScheme in OAM is not successful. It does not show any OIF login screen. Instead it takes the user to through these URLs:
         1.     https://sso.company.com/test-app/
         2.     https://sso.company.com/fed/user/sposso  
         3.     https://sso.company.com/fed/user/authnoam?refid=id-tB20kXzmHjpn6MUSdOr7qbmd2OU-
         4.     https://sso.company.com/fed/sp/art20?SAMLart=AAQAAbV1ElKBtte9uuhKoeo4h%2FMufCdY2wDlDIM2T9dL%2BvhsvtfUrwCuZg8%3D&RelayState=id-JPh8MY05pAZRckl4yOc2J4-80GI-
    and then shows this error in the browser:
    Error 401--Unauthorized
    From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
    10.4.2 401 Unauthorized
    The request requires user authentication. The response MUST include a WWW-Authenticate header field (section 14.46) containing a challenge applicable to the requested resource. The client MAY repeat the request with a suitable Authorization header field (section 14.8). If the request already included Authorization credentials, then the 401 response indicates that authorization has been refused for those credentials. If the 401 response contains the same challenge as the prior response, and the user agent has already attempted authentication at least once, then the user SHOULD be presented the entity that was given in the response, since that entity MAY include relevant diagnostic information. HTTP access authentication is explained in section 11.
    The following errors are seen in the WLS_OIF1 (we turned off WLS_OIF2 during this test) managed server logs:
    <Mar 10, 2012 10:58:37 AM PST> <Error> <oracle.security.fed.eventhandler.authn.engines.oam.OAMAuthnEventHandler> <FED-18068> <Authentication failed: WebGate did not authenticate the user>
    <Mar 10, 2012 10:58:37 AM PST> <Emergency> <oracle.security.fed.model.config.Configuration> <FED-10174> <Property was not found: httpheaderattrcollector.>
    <Mar 10, 2012 10:59:27 AM PST> <Warning> <oracle.security.fed.http.handlers.authn.LoginRequestHandler> <FED-18051> <Authentication instant was not sent from the authentication engine.>
    <Mar 10, 2012 10:59:37 AM PST> <Error> <oracle.security.fed.util.ssl.KeystoreUtil> <FED-18080> <Could not retrieve key from the key store. Please verify that the key password is equal to the key store
    < this error is followed by an exception shown below>
    <Mar 10, 2012 10:59:39 AM PST> <Error> <oracle.security.fed.eventhandler.authn.engines.osso.OssoFinishSPSSOEventHandler> <FED-15134> <The service providercould not map the identity provider response to a user>
    FED-18080 exception:
    java.security.UnrecoverableKeyException: Cannot recover key
         at sun.security.provider.KeyProtector.recover(KeyProtector.java:311)
         at sun.security.provider.JavaKeyStore.engineGetKey(JavaKeyStore.java:121)
         at sun.security.provider.JavaKeyStore$JKS.engineGetKey(JavaKeyStore.java:38)
         at java.security.KeyStore.getKey(KeyStore.java:763)
         at com.sun.net.ssl.internal.ssl.SunX509KeyManagerImpl.<init>(SunX509KeyManagerImpl.java:113)
         at com.sun.net.ssl.internal.ssl.KeyManagerFactoryImpl$SunX509.engineInit(KeyManagerFactoryImpl.java:48)
         at javax.net.ssl.KeyManagerFactory.init(KeyManagerFactory.java:239)
         at oracle.security.fed.util.ssl.KeystoreUtil.createKeyManagers(Unknown Source)
         at oracle.security.fed.util.soap.OIFSSLProtocolSocketFactory.createSSLContext(Unknown Source)
         at oracle.security.fed.util.soap.OIFSSLProtocolSocketFactory.getSSLContext(Unknown Source)
         at oracle.security.fed.util.soap.OIFSSLProtocolSocketFactory.createSocket(Unknown Source)
         at oracle.security.fed.util.soap.OIFSSLProtocolSocketFactory.createSocket(Unknown Source)
         at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
         at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
         at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
         at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
         at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
         at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
         at oracle.security.fed.util.soap.SimpleSoapSender.sendMessage(Unknown Source)
         at oracle.security.fed.http.flow.profiles.sp.SendSoapRequestSSOResponseHandler.perform(Unknown Source)
         at oracle.security.fed.controller.ApplicationController.processServletRequest(Unknown Source)
         at oracle.security.fed.controller.web.servlet.FederationServlet.doGet(Unknown Source)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:821)
         at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)
         at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
         at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:300)
         at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:27)
         at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:57)
         at oracle.security.jps.ee.http.JpsAbsFilter$1.run(JpsAbsFilter.java:111)
         at oracle.security.jps.util.JpsSubject.doAsPrivileged(JpsSubject.java:313)
         at oracle.security.jps.ee.util.JpsPlatformUtil.runJaasMode(JpsPlatformUtil.java:413)
         at oracle.security.jps.ee.http.JpsAbsFilter.runJaasMode(JpsAbsFilter.java:94)
         at oracle.security.jps.ee.http.JpsAbsFilter.doFilter(JpsAbsFilter.java:161)
         at oracle.security.jps.ee.http.JpsFilter.doFilter(JpsFilter.java:71)
         at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:57)
         at oracle.dms.servlet.DMSServletFilter.doFilter(DMSServletFilter.java:136)
         at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:57)
         at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3715)
         at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3681)
         at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
         at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
         at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2277)
         at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2183)
         at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1454)
         at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
         at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)
    A minor other problem seems to be with adcri:
    Cause: DFW-40112: There was an error executing adrci commands; the following errors have been found "Cannot run program "/app/iam/middleware/wlserver_10.3/server/adr/adrci": java.io.IOException: error=12, Cannot allocate memory"
    Action: Ensure that command line tool "adrci" can be executed from the command line.
    We can run the adcri tool from command line using the same LD_LIBRARY_PATH as used by the wls_oif1 server. Why is it trying to run it and failing and what is it trying to do? Can we turn it off?

    I reinstalled the suite. This time, during the Policy Manager install I left the "Root Directory for Policy Domains" (step/page 7-12) at the default, which was "/". The GUI now works correctly.
    On the previous install I changed the path to /AccessManagerPolicy -- it wasn't clear to me what the installer meant by 'root directory'. I did try to get /AccessManagerPolicy to work by creating a directory under my web root to match, but I still had issues with the Policy Domain -- the no policy domains would match. So, it looks like this parameter should never be changed in the installer.
    Aaron.

  • 871 Config issues

    Ok I dont know if its just staring at me ridiculing me but I am feeling like an idiot here... I have an 871 and all I need to do is some basic rules..
    Here is the config I am  having the issue with...
    I need these statics:
    .227 opened and forwarded to these  ports:
    10.0.0.240 80 tcp
    10.0.0.241 81 tcp
    10.0.0.242 82 tcp
    10.0.0.243 83 tcp
    10.0.0.244 84 tcp
    10.0.0.9 3389 tcp
    then .228 forwarded and allports opened to 10.0.0.15
    Right now its working for the .228 but  the .227 is blocking everything.. If I remove the lines for the 10.0.0.15  *.*.*.228 then everything works for the .227 statics and  ports..
    What is wrong here???
    s run
    Building configuration...
    Current configuration : 4747 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service sequence-numbers
    hostname ******
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    no aaa new-model
    resource policy
    clock timezone MST -7
    ip cef
    ip name-server *.*.*.65
    ip name-server *.*.*.65
    ip inspect log drop-pkt
    ip inspect name SDM_LOW cuseeme
    ip inspect name SDM_LOW dns
    ip inspect name SDM_LOW ftp
    ip inspect name SDM_LOW h323
    ip inspect name SDM_LOW https
    ip inspect name SDM_LOW icmp
    ip inspect name SDM_LOW imap
    ip inspect name SDM_LOW pop3
    ip inspect name SDM_LOW netshow
    ip inspect name SDM_LOW rcmd
    ip inspect name SDM_LOW realaudio
    ip inspect name SDM_LOW rtsp
    ip inspect name SDM_LOW esmtp
    ip inspect name SDM_LOW sqlnet
    ip inspect name SDM_LOW streamworks
    ip inspect name SDM_LOW tftp
    ip inspect name SDM_LOW tcp router-traffic
    ip inspect name SDM_LOW udp router-traffic
    ip inspect name SDM_LOW vdolive
    crypto pki trustpoint TP-self-signed-974215006
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-974215006
    revocation-check none
    rsakeypair TP-self-signed-974215006
    crypto pki certificate chain TP-self-signed-974215006
    certificate self-signed 01
      30820242 308201AB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 39373432 31353030 36301E17 0D313330 31303231 35333430
      315A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
      532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3937 34323135
      30303630 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
      CE70D924 A69C5408 AF2DC7DF CD6C4FB4 6FF8B3A7 04380A8B AC07B63F DF47B76C
      9269256B 2D166D76 DFEEB4A1 A7F3CD14 87018C5E 00957EE5 233F76EE 8D0EB13E
      D33FE972 77661DF2 B2BBC711 E09CF82F 7FC907DF 5591C326 CF80D599 09017B23
      AB6F3589 A983AC80 2C92D62D E15FF75B 14241C9B 394BED17 69F2BE7F 69BB21EF
      02030100 01A36C30 6A300F06 03551D13 0101FF04 05300301 01FF3017 0603551D
      11041030 0E820C52 69766965 72615F6D 65736130 1F060355 1D230418 30168014
      8F9D3891 FB866320 C9C2FA5B 7AEE8A53 91F495DD 301D0603 551D0E04 1604148F
      9D3891FB 866320C9 C2FA5B7A EE8A5391 F495DD30 0D06092A 864886F7 0D010104
      05000381 81005F45 DD5BBAE3 960E8930 1C88ACEC 4D190FEC C8C6FA71 48FB8CB8
      969BD344 1FC0E8C6 98C4ED1D B559A772 1A3ED3D9 1C75D143 BE642414 B049118C
      858422D5 E84617E9 018B1B66 341E928D EAE0E568 923424C4 BF31DFFF E7E5A490
      B24D2DBC CE5DC6FF 306EC1C2 BD4DDC04 4AE70B0B 5CFE9426 21B5F83E CA6D28E0
      3B93DCA9 015E
      quit
    username****** privilege 15 secret 5 34yweth2453723475
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    description $FW_OUTSIDE$
    ip address *.*.*.226 255.255.255.248
    ip access-group 101 in
    ip verify unicast reverse-path
    ip nat outside
    ip inspect SDM_LOW out
    ip virtual-reassembly
    duplex auto
    speed auto
    interface Vlan1
    description $FW_INSIDE$
    ip address 10.0.0.1 255.255.255.0
    ip access-group 100 in
    ip nat inside
    ip virtual-reassembly
    ip route 0.0.0.0 0.0.0.0 *.*.*.225
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    ip nat pool outside_ip_pool *.*.*.227 *.*.*.230 netmask 255.255.255.24                8
    ip nat inside source list 1 interface FastEthernet4 overload
    ip nat inside source static tcp 10.0.0.240 80 *.*.*.227 80 extendable
    ip nat inside source static tcp 10.0.0.241 81 *.*.*.227 81 extendable
    ip nat inside source static tcp 10.0.0.242 82 *.*.*.227 82 extendable
    ip nat inside source static tcp 10.0.0.243 83 *.*.*.227 83 extendable
    ip nat inside source static tcp 10.0.0.244 84 *.*.*.227 84 extendable
    ip nat inside source static tcp 10.0.0.9 3389 *.*.*.227 3389 extendable
    ip nat inside source static 10.0.0.15 *.*.*.228
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.0.0.0 0.0.0.255
    access-list 100 remark auto generated by SDM firewall configuration##NO_ACES_4##
    access-list 100 remark SDM_ACL Category=1
    access-list 100 deny   ip *.*.*.224 0.0.0.7 any
    access-list 100 deny   ip host 255.255.255.255 any
    access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 101 permit ip any host *.*.*.228
    control-plane
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    scheduler max-task-time 5000
    webvpn context Default_context
    ssl authenticate verify all
    no inservice
    end

    Hi,
    I'm not really familiar with the Router Firewalls but I'd just point out what caught my eye (even though there might not be anything wrong about them)
    You have ACL 101 attached to outside interface and it only allow traffic to .228
    You have some outside_ip_pool configuration line that includes the IPs you're going to use for both Static NAT and Port Forward. Shouldnt you leave the .227 and .228 out of the Pool range?
    - Jouni

  • Apache2 config issue with CFMX8 on Ubuntu

    hi there -
    I have a new Ubuntu laptop I purchased from Zareason, (great
    deal, nice people). They were cool to install CFMX8 developer
    version on my laptop before shipping.
    My issue is this:
    The cfadmin works fine, so I know CF is at least up and
    running, and connected to the web server thru port 8500.
    so,
    http://localhost:8500/CFIDE/administrator/
    works just dandy.
    http://localhost/test.cfm
    (with some simple code) outputs to the browser the literal code
    The problem I have is that when I put a simple test .cfm page
    in my documentroot for apache (mine is /var/www), the CF code
    outputs straight to the browser. I know that SOME scripts execute
    from this directory, since I can run PHP scripts.
    Most of my config options for Apache2 seem to be in the
    /etc/apache2/apache2.conf and /etc/apache2/sites-available/default.
    I cant for the life of me figure out how to get a simple
    script to run from this dir. I've looked at permissions,
    configurations, etc and have come up empty.
    any ideas folks? Thanks in advance.
    hogan

    Well found the issue. Adapter config needs to have a parent config tag. It was missing in my case.
    <?xml version="1.0" ?>
    *<config>*
    <adapter type="scs" default="true" name="myadapter">
    <config>
    <property name="port">4444</property>
    <property name="host">161.222.84.128</property>
    <property name="type">socket</property>
    </config>
    <beans template="classpath:/META-INF/resources/adapter/adapter-services-scs.jxml"/>
    </adapter>
    *</config>*

  • MAB Config Issue

    with acs 4.2 installed in my network,   PEAP, EAP-TLS, md5... authentications work normally.  But Mac-Based-Authentication   doesnt work at all.  i tested every thing but no luck .
    This is what i have setup on Swith for MAB:
    aaa new-model
    aaa authentication login default none
    aaa authentication dot1x default group radius
    radius-server host 192.168.2.16 auth-port 1645 acct-port 1646 key cisco
    dot1x system-auth-control
    interface FastEthernet0/1
    switchport mode access
    dot1x pae authenticator
    dot1x port-control auto
    dot1x mac-auth-bypass
    On ACS server, i created Netword-Profile for MAB, i added those Agentless hosts mac-adds,   Even i created User-Name&password by those Agentless hosts mac-adds on acs,   ..... still nothing seems to be working.   i have selected ACS_Internal-Database for mac authentication.
    On ACS while i check the   Failed-attempt log, nothing is logged there.  i dont know where is the issue.
    Please tell me where im wrong on my config?

    Under your interface type: mab
    Sent from Cisco Technical Support iPad App

  • No soa_server1 ???? Oracle SOA Suite 11g config issue on WIN 7 64 bit

    Hello guys.
    Happy new year. Here is the first Oracle SOA Suite 11g issue I met in this new decade:
    While I tried to install Oracle SOA Suite 11g on my new win 7 home Premium, after all installation done, I found there was no "soa_server1" under new created domain(path C:\Oracle\Middleware\user_projects\domains\base_domain\servers) with just Admin server only - i have done similar install/config on win vista 32bit before everything was fine. I found following lines in the log(C:\Oracle\Middleware\logs\wlsconfig_20110102233019.log):
    2011-01-02 23:31:52,986 INFO [Thread-14] com.oracle.cie.domain.script.ScriptExecutor - warn: set obj26 attribute Targets to "AdminServer"
    2011-01-02 23:31:52,986 WARN [Thread-14] com.oracle.cie.domain.script.ScriptExecutor - warn: set obj26 attribute Targets to "AdminServer"
    com.oracle.cie.domain.script.ScriptException: Unable to find attribute Targets
         at com.oracle.cie.domain.script.ScriptExecutor.setAttrValue(ScriptExecutor.java:3589)
         at com.oracle.cie.domain.script.ScriptExecutor.setValue(ScriptExecutor.java:1331)
         at com.oracle.cie.domain.script.jython.ScriptInvocationHandler.set(ScriptInvocationHandler.java:210)
         at com.oracle.cie.domain.script.jython.ScriptInvocationHandler.invoke(ScriptInvocationHandler.java:103)
         at $Proxy12.setTargets(Unknown Source)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:597)
         at com.oracle.cie.domain.script.jython.WLScriptContext.set(WLScriptContext.java:1298)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:597)
         at org.python.core.PyReflectedFunction.__call__(Unknown Source)
         at org.python.core.PyMethod.__call__(Unknown Source)
         at org.python.core.PyObject.__call__(Unknown Source)
         at org.python.core.PyInstance.invoke(Unknown Source)
         at org.python.pycode._pyx61.set$5(<iostream>:45)
         at org.python.pycode._pyx61.call_function(<iostream>)
         at org.python.core.PyTableCode.call(Unknown Source)
         at org.python.core.PyTableCode.call(Unknown Source)
         at org.python.core.PyFunction.__call__(Unknown Source)
         at wls_webservice_fixup_utils$py.verifyWseeWorkManager$11(C:\Oracle\Middleware\user_projects\domains\domain2\wls_webservice_fixup_utils.py:359)
         at wls_webservice_fixup_utils$py.call_function(C:\Oracle\Middleware\user_projects\domains\domain2\wls_webservice_fixup_utils.py)
         at org.python.core.PyTableCode.call(Unknown Source)
         at org.python.core.PyTableCode.call(Unknown Source)
         at org.python.core.PyFunction.__call__(Unknown Source)
         at wls_webservice_fixup_utils$py.doWseeFixup$1(C:\Oracle\Middleware\user_projects\domains\domain2\wls_webservice_fixup_utils.py:18)
         at wls_webservice_fixup_utils$py.call_function(C:\Oracle\Middleware\user_projects\domains\domain2\wls_webservice_fixup_utils.py)
         at org.python.core.PyTableCode.call(Unknown Source)
         at org.python.core.PyTableCode.call(Unknown Source)
         at org.python.core.PyFunction.__call__(Unknown Source)
         at org.python.core.PyObject.invoke(Unknown Source)
         at org.python.pycode._pyx64.f$0(<iostream>:11)
         at org.python.pycode._pyx64.call_function(<iostream>)
         at org.python.core.PyTableCode.call(Unknown Source)
         at org.python.core.PyCode.call(Unknown Source)
         at org.python.core.Py.runCode(Unknown Source)
         at org.python.util.PythonInterpreter.execfile(Unknown Source)
         at org.python.util.PythonInterpreter.execfile(Unknown Source)
         at com.oracle.cie.domain.script.ScriptHelper.executeEmbeddedTemplateScript(ScriptHelper.java:1571)
         at com.oracle.cie.domain.DomainChecker.executeEmbeddedScript(DomainChecker.java:1322)
         at com.oracle.cie.domain.DomainChecker.runCustomWLSTScript(DomainChecker.java:1305)
         at com.oracle.cie.domain.DomainChecker.preprocessOutput(DomainChecker.java:143)
         at com.oracle.cie.domain.DomainGenerator.generate(DomainGenerator.java:269)
         at com.oracle.cie.wizard.domain.gui.tasks.DomainCreationGUITask$1.run(DomainCreationGUITask.java:216)
    2011-01-02 23:31:52,986 INFO [Thread-14] com.oracle.cie.domain.script.ScriptExecutor - set obj26 attribute Target to "AdminServer"
    2011-01-02 23:31:53,002 INFO [Thread-14] com.oracle.cie.domain.script.ScriptExecutor - succeed: set obj26 attribute Target to "AdminServer"
    2011-01-02 23:31:53,002 WARN [Thread-14] com.oracle.cie.domain.aspect.XBeanConfigAspect - Unable to locate property:Name on type:class com.oracle.cie.domain.xml.configxb.weblogic.x90.impl.WeblogicJmsTypeImpl
    2011-01-02 23:31:53,345 WARN [Thread-14] com.oracle.cie.domain.aspect.XBeanConfigAspect - Unable to locate property:CredentialEncrypted on type:class com.oracle.cie.domain.xml.configxb.impl.DefaultAuthenticatorTypeImpl
    2011-01-02 23:31:53,345 WARN [Thread-14] com.oracle.cie.domain.aspect.XBeanConfigAspect - Unable to locate property:CredentialEncrypted on type:class com.oracle.cie.domain.xml.configxb.impl.DefaultIdentityAsserterTypeImpl
    Dose anyone have some suggestions for solving this? Thanks first.............
    Cliff

    Can you cross check your steps again against the steps mentioned here -
    http://anuj-dwivedi.blogspot.com/2010/10/installing-oracle-soa-and-bpm-111130.html
    Regards,
    Anuj

  • CSM Bridged mode config issue

    I currently have a CSM that is load balancing two web servers.  Everything working great.  I have two new web servers that are being used for a different system so I basically copied the old config, changed the names of the vservers, serverfarms and policies and expected the same result as the first.
    What is happening is that when I ping the VIP, it gets redirected to one of the reals but then the real responds back instead of the VIP.
    Not sure why that is happening.

    Sean,
    When you said "Typically, the rservers would use the same gateway you have configured on the client VLAN.  The important thing to make sure of, is that you must make sure that the ONLY for these rservers to reach their gateway is through the CSM that is bridging the servers' VLAN to that client VLAN."
    Now I assume you meant to say "Typically, the rservers would use the same gateway you have configured on the client VLAN.  The important thing to make sure of, is that you must make sure that the ONLY way for these rservers to reach their gateway is through the CSM that is bridging the servers' VLAN to that client VLAN.
    Well, I have a working bridging configuration for a different system and I have found that the real servers in my server vlan do have the client vlan IP address... But the server vlan is in fact a layer 2 vlan, it does not have it's own gateway so it has no other way out other than through the CSM and to the client vlan gateway, just as you said.
    What I have found is that the server vlan for my new set up actually has its own gateway.  Because of other servers in this vlan I cannot do away with it.  So, I looked at an ealier post where you stated" If the adding source-NAT resolves the issue, then you know that asymmetric routing was your problem.  One solution would be to leave the source-NAT config in permanently.  The other would be to set the default gateway of your new servers to the CSM interface, and another would be to use policy-based routing."
    The two solutions I am interested in is the client nat and the setting of the default gateway of the new servers to the CSM interface.  Exaclty what interface are you referring?  Are you referring to the IP address that bridges the client and server vlan together?
    Regarding your client nat example, you mentioned that the client nat address is owned by the CSM, but in your example config I did not see that IP address at all so I am a little confused as to how the csm owns this IP.
    I really appreciate your responses!

  • IPhone Config Issue with Cox

    sigh Where do I begin? I know I'm not the first to post, but I do not see an answer yet.
    I configured my iPhone last night and have Cox as my ISP. I also have WiFi at my house. Ultimately, I cannot get email to function properly on the iPhone - mostly with sent items. On WiFi, the icon simply spins and never sends. I initially received failure errors until I configured the SMTP for Cox on the iPhone.
    I researched and found some options. The easiest/best was the mail assitant at this address: http://www.apple.com/support/iphone/mailhelper/
    However, when on WiFi, the device throws the items into the Outbox and simply doesn't send. I was able to shut off the WiFi connection, which forced it to Edge, and it attempted to send (albeit very slowly). After configuring for cwmx.com for SMTP, it worked a few times - again, very slowly.
    I was able to receive emails, but the send function failed more often than not. I couldn't duplicate the sending of emails again after those two. I'm aware of port 25 being blocked by Cox and, yes, I configured SMTP properly for Cox with the username and password entered in.
    The only solution I can see is to turn on WiFi when I'm in a hot spot or in my home only to use Safari or YouTube (Internet connectivity), but otherwise shut off the WiFi when I'm out of the house - thus forcing it to Edge for email. I don't want to set up a different email address (hotmail, gmail, etc.) - everyone knows my Cox address - I simply want to get this to work effectively with Cox's email servers.
    Thoughts? What am I missing?!?

    Nathan ~ I haven't read your link yet, but I will. I'll use it equally at home and out and about. I have it currently config'd for cwmx.com and have wireless of while using Edge.
    A little confused - You first stated, "When you are on WiFi at home, you will need to disable WiFi in order to send..." but then stated, "If you expect it to be mostly at home, configure it with the outgoing mail server you have on your computer." If I turn off the WiFi, it'll kick over to Edge to send - I understand that. But if I configure for the same settings for SMTP through Cox, it would, in effect, try to use Cox while at home on WiFi. The latter I cannot get to work - that's part of my issue. It just churns and churns with no sent messages.
    Too bad there's not a ProxyPal type of icon on the desktop that would, by simply touching it, toggle from WiFi to Edge. ProxyPal works on my laptop for proxy settings much the same way - it just simplifies things.
    ~~~~~~~~~~~~
    PC2K07 ~ This made me chuckle - "...switched back to edge quick to send…" It's not quick for me by any means. Painfully slow with full bars on Edge. I do some business through my current email account and want to keep this as simple as I can. As a result, I'd really, REALLY prefer not to set up an additional email account - even if it's used for forwarding emails.
    ~~~~~~~~~~~~
    TH3 ~ I tried the web access for Cox. Although it works, it's not truly effective. I'd much prefer the mail client through the standard icons.
    Thanks, all.

  • CME 7.1 / CUE 3.1 - Fax Onramp - Bug or Config Issue?

    I have searched long and hard for the correct way to do this but I can't find the information I think I need. I want to setup a dedicated incoming fax number (fax onramp) to accept a fax from the PSTN network (a traditional fax machine) and have it email to a dedicated email address. In other words, FAX Machine dials 1234561280, which receives the fax and then emails it to a local Exchange server ([email protected]). (NOTE: I could also live with it going to a single CUE mailbox too.)
    I am running CME 7.1 and CUE 3.1.1.
    So in doing research, I found several articles on using a TCL script you can download for fax onramp (and offramp) for an IOS gateway. I went down that route and finally had it answering the phone with a fax tone (config below) but it would reboot the router as soon as I hung up. (Never tried an actual fax since this was unacceptable regardless if it took the fax).
    This was frustrating so more research. I was thinking the issue was the fact that the script was fairly old. So then I notice documents (and I had noted the fields when configuring users in CUE) that CUE 3.1 supported faxes. So then I wondered if I was using the wrong method.
    I searched Cisco's web site and found nothing useful. Then I ran across this post on this forum that seemed to support my assumption that maybe I did not need that old TCL script on more recent IOS/CME/CUE solutions.
    POST:
    http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=General&topicID=.ee6c82b&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cc048f5
    SPECIFIC REPLY:
    Replied by: tnorrell - CSE, CISCO SYSTEMS - May 11, 2008, 9:30am PST
    The link in the previous post deals with haveing an application detect fax tone, but it does not function very well as an AA. The caller calls in, waits N number of seconds while a voice says something like "press 1 if this is a voice call, 2 if fax...". If the caller presses to, or the script hears fax tone, the script knows how to negotiate the fax. However, it wants to do it with t.37 (or store and forward). Meaning the email will be sent via email to the address listed in the script.
    CUE 3.1 has the ability to do store and forward. it's built into the code, and doesn't require the IOS tcl script noted in the previous paragraph. It's a great way to receive faxes.
    http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel3_1/administration/guide/voicemail/fxgatewy.html
    But when I followed the link shown here, it too uses the TCL script.
    So I guess my question is:
    1) Is there a way to do this without the TCL script?
    2) If I need the TCL script, is there something I have configured wrong that is causing the problem or is there a bug in the script?
    ANY HELP WOULD BE APPRECIATED!!!!

    HERE IS MY SETUP
    ==============================
    1) Running the following code on 2851.
    Cisco IOS Software C2800NM-SPSERVICESK9-M Version 12.4(22)YB
    Cisco Unity Express Version 3.1 - Installer (Installer application) 3.1.1.0
    2) Uploaded latest script to FLASH.
    r1-rtr-voip#dir keep
    Directory of flash:/keep/
    274 -rw- 12262 Mar 15 2009 22:16:24 -05:00 app_faxmail_onramp.2.0.1.3.tcl
    3) Setup the following Config:
    voice service voip
    allow-connections h323 to sip
    allow-connections sip to h323
    h323
    call start slow
    voice translation-rule 1280
    rule 1 /^1234561280$/ /1234561280/
    rule 14 /^\(.......\)$/ /210/
    rule 15 /^\(..........\)$/ /210/
    voice translation-profile 123456128X-Inbound
    translate calling 200
    translate called 1280
    fax interface-type fax-mail
    mta send server 10.1.120.10 port 25
    mta send postmaster [email protected]
    mta send mail-from hostname exchange.domain.local
    mta send mail-from username unity
    application
    service faxtoemail flash:/keep/app_faxmail_onramp.2.0.1.3.tcl
    interface Integrated-Service-Engine1/0
    description Unity Express (NME)
    ip unnumbered GigabitEthernet0/0.120
    service-module ip address 10.1.120.20 255.255.255.0
    !Application: CUE Running on NME
    service-module ip default-gateway 10.1.120.1
    no keepalive
    ccm-manager fax protocol cisco
    mgcp fax t38 ecm
    dial-peer voice 1000 pots
    description FAX to Email - Part 1
    service faxtoemail
    incoming called-number 1234561280
    direct-inward-dial
    dial-peer voice 1001 mmoip
    description FAX to Email - Part 2
    service fax_on_vfc_onramp_app out-bound
    destination-pattern 1234561280
    information-type fax
    session target mailto:[email protected]
    dial-peer voice 1280 pots
    description Incoming PRI (123456128X)
    translation-profile incoming 123456128X-Inbound
    incoming called-number 123456128.
    direct-inward-dial
    port 0/0/0:23

Maybe you are looking for

  • Display account balances for vendor PO's and GRPO's

    In the BP Master, there is a display for customers of the account balance, open orders, deliveries, and opportunities.  But for vendors there is only an account balance.  There should be a similar display for open PO's and GRPO's.

  • How do you get your iPhone 5 out of recovery mode without restoring it?

    I plugged in my phone and tried to update it to iOS 7.1.1 but something happened and it told me to plug my phone into itunes and restore it. I have an iPhone 5, it's not jail broken. I haven't gotten the chance to backup on phone on my new laptop yet

  • IPhoto won't open photos from thumbnails.

    Hi - Some weeks ago, my older version of iPhoto stopped opening photos from the thumbnails.  You click on thumbnail and nothing happens, no black screen, no beach ball, no error messages - just as though you haven't clicked on it at all.  So reading

  • How to create selections-screens to display PO using module pool program

    All, I'm new to module pool programming. Can any one please provide me where to create selections screens to display existing purchase orders using the below selection criteria in thr module pool program., SELECT-OPTIONS : S_LIFNR FOR EKKO-LIFNR,    

  • I Mac does not. start

    Hi, i Mac Will not. Start up. Pse. Any suggestions?