Continue Statement in export map

Hey all,
  I need a definative answer on why the following is not working:
ip prefix-list Management seq 5 192.168.0.0/16 le 32
route-map Exp-Map permit 5
description Management Nets to Management Provider 1
match ip address prefix-list Management
set extcommunity rt  1:1 additive
continue
route-map Exp-Map permit 10
description Management Nets to Management Provider 2
match ip address prefix-list Management
set extcommunity rt  2:2 additive
continue
ip vrf Customer
rd 3:3
export-map Exp-Map
route-target both 3:3
PE1#show ip bgp vpnv4 all  192.168.1.1/32
BGP routing table entry for 3:3:192.168.1.1/32, version 22
Paths: (1 available, best #1, no table)
Flag: 0xA20
  Advertised to update-groups:
     1        
  64774, (Received from a RR-client)
    10.98.98.98 (metric 30) from 10.98.98.98 (10.98.98.98)
      Origin IGP, metric 0, localpref 400, valid, internal, best
      Extended Community: RT:1:1 RT:3:3
      mpls labels in/out nolabel/33
As you can see, it is though the continue statement is not working.
I want to be able to use varying communities to allocate an RT.
If the continue statement does not work, then I would need to allocate a community based on every permutation possible, which is allot.
Cheers
Adam

Hi Adam,
The "continue" keyword in a route-map forces the router to look at the next route-map sequence instead of stopping in the event of a match, as per normal route-map operation.
In your example, you are making a match in sequence 10, the continue keyord will kick in and sequence 20 will be looked at, however, since you are matching on the same sequence of that prefix-list, the extra extcommunity will not be applied that you have requested in sequence 20.
To get around this and acheive what you are trying to do, you can add both RT's to your route-map in sequence 10:
Configured on PE1:
ip prefix-list TEST_LOOPS seq 5 permit 25.25.25.25/32
route-map EXP_MAP permit 10
match ip address prefix-list TEST_LOOPS
set extcommunity rt  25:25 35:35 additive
ip vrf CUST_A
rd 1010:1
export map EXP_MAP
route-target export 1010:79
route-target import 2020:79
Output from PE2:
AS2020_PE#sh ip bgp vpnv4 all 25.25.25.25
BGP routing table entry for 1010:1:25.25.25.25/32, version 30
Paths: (1 available, best #1, no table)
  Not advertised to any peer
  1010
    6.6.6.6 (metric 20) from 6.6.6.6 (6.6.6.6)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Community: 250:1
      Extended Community: RT:25:25 RT:35:35 RT:1010:79
        OSPF DOMAIN ID:0x0005:0x000000640200 OSPF RT:0.0.0.0:5:1
        OSPF ROUTER ID:1.1.1.1:1281,
      mpls labels in/out nolabel/19
As you can see, the router assigns the two RTs to that 1 prefix you are matching on.
If you are going to be adding more sequences to that same prefix-list, then yes you the "continue" keywork would work fine as the next route-map sequence would be matching on the next prefix-list sequence where it hits a match:
Configured on PE1:
ip prefix-list TEST_LOOPS seq 5 permit 25.25.25.25/32
ip prefix-list TEST_LOOPS seq 10 permit 35.35.35.35/32     
route-map EXP_MAP permit 10
match ip address prefix-list TEST_LOOPS
set extcommunity rt  25:25 additive
continue
route-map EXP_MAP permit 20
match ip address prefix-list TEST_LOOPS
set extcommunity rt  35:35 additive
  continue
Output from PE2:
AS2020_PE#sh ip bgp vpnv4 all 25.25.25.25
BGP routing table entry for 1010:1:25.25.25.25/32, version 22
Paths: (1 available, best #1, no table)
  Not advertised to any peer
  1010
    6.6.6.6 (metric 20) from 6.6.6.6 (6.6.6.6)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Community: 250:1
      Extended Community: RT:25:25 RT:1010:79
        OSPF DOMAIN ID:0x0005:0x000000640200 OSPF RT:0.0.0.0:5:1
        OSPF ROUTER ID:1.1.1.1:1281,
      mpls labels in/out nolabel/19
AS2020_PE#
AS2020_PE#sh ip bgp vpnv4 all 35.35.35.35
BGP routing table entry for 1010:1:35.35.35.35/32, version 24
Paths: (1 available, best #1, no table)
  Not advertised to any peer
  1010
    6.6.6.6 (metric 20) from 6.6.6.6 (6.6.6.6)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Community: 250:1
      Extended Community: RT:35:35 RT:1010:79
        OSPF DOMAIN ID:0x0005:0x000000640200 OSPF RT:0.0.0.0:5:1
        OSPF ROUTER ID:1.1.1.1:1281,
      mpls labels in/out nolabel/18
AS2020_PE#
HTH
Joe.

Similar Messages

  • Export map on a vrf

    With the following config, does it export only the 10.2.3.3/32 route with
    the 114.3.1.1:4 RT set ? Or does all routes from the vrf get exported
    (because there is no set extcommunity statement below the
    route-map) ?? My intention is to export only that route from the vrf..
    ip vrf bv_1.135_fe.0.0.112-Hub
    rd 135:5
    export map bv_1.135_fe.0.0.112
    route-target export 114.3.1.1:4
    route-target import 114.3.1.1:5
    route-map bv_1.135_fe.0.0.112 permit 1
    match ip address prefix-list bv_EVpn1-bv_1.135_fe.0.0.112-Hub
    ip prefix-list bv_EVpn1-bv_1.135_fe.0.0.112-Hub seq 1 permit 10.2.3.3/32
    Thanks !
    /bala

    Martin-
    The intent is this: the VRF hosts a management site and our customer wants to export only specific routes from the management hub site to the spokes....enough for them to get to the mgmt site. We had cupla options - using ACLs vs prefix-list and chose the prefix list per customer request due to perf reasons (see my last post).
    I;m curious to know how you'd control this via redistribution. So under my PE-CE redistribution to my mgmt site, I'd then have to throw away 'other routes' ? I'd end up using route-map there too right ? it'd just be a different place (instead of "export map" under my "ip vrf" then it'd be under say my "router bgp" ??)
    Thanks !
    /bala

  • Getting error in continue statement

    Hi All,
    When i am writing the following code in java then i am getting syntex error in continue statement...
    Kindly tell me whyi am getting this one...
    package com.fidelity.ereview.utils;
    import java.io.*;
    * @author 197881
    public class Sunita {
          * @param args
         public static void main(String[] args) throws IOException {
              test: System.out
                        .print("Enter The Report Name to Generate(DataValidationReport/ErrorReport/ComparisionReport) : ");
              BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
              String reportName = br.readLine();
              if (reportName.equalsIgnoreCase("DataValidationReport")
                        || reportName.equalsIgnoreCase("ErrorReport")) {
                   FileWriter f0 = new FileWriter("D:/TCS/" + reportName + "");
              } else {
                   System.out.println("Please Enter Correct Report Name");
                   continue test;
    }

    You need to be in some "loop" to use that:
    public static void main(String[] args) {
    test:
        while(true) {
            if (something) {
                continue test;
    }But I wouldn't advise it.

  • Decode statement in a mapping involve Source Text File & Table.

    Hi All,
    Oracle 9i Warehouse Builder Client: 9.2.0.4.0
    Oracle 9i Warehouse Builder Repository: 9.2.0.2.0
    Oracle9i Enterprise Edition Release 9.2.0.5.0 - 64bit Production
    Does OWB allow to use Decode statement in a mapping involves Source Text File and Oracle Table.
    My understanding is it's not possible, since OWB makes use of Sqlloader. For this work arround could be make use of External Table instead of Text Flat File.
    However I came across an old posting (June-2003) which says that this feature is available OWB 9.2.
    Following is the url:
    IF THEN LOGIC from Flat File to Table
    Can someone please confirm this?
    Thanks in Advance.
    Regards,
    Vidyanand

    Hi all,
    If you want to validate correctly this mapping you must to :
    1. Right click on the mapping, then Configure
    2. Right click on Sql Loader Data Files, then Create
    3. Verify that the location name is correct and complete the Data File Name
    4. OK
    The validation is now OK.
    I hope it will be help you
    Best Regards
    Samy

  • How to Import exported mapping in SAP XI

    Hello
    I have a exported mapping from Integration repository file with .xim extension. How we can can import it another XI server.
    Thanks
    Chaitanya

    Hi,
    If u import any objects then ur file be .tpz extension. I m surprised how ur file extension is .xim extension.
    have u followed the same process which is mentioned below:
    1) tools->export->select->FTP/CMS-> selct whole SWCV,individual objects,namespace and finish.
    after whole process it will give the .tpz file name u need to take the file from that FTp server and u need to follow the reverse process in IR.
    Import:
    tools->import->ans go on.
    Refer the link for process.
    http://help.sap.com/saphelp_nw04/helpdata/en/a8/5e56006c17e748a68bb3843ed5aab8/frameset.htm
    Thnx
    Chirag

  • Export map to Excel dates issue

    Hi,
    I created an export map exporting several dates fields.
    the problem is that the format is not the same:
    Finish date format was: dd-mm-yy
    Finish1 date format was: mm-dd-yy
    in MSP itself I see both formats the same (dd-mm-yy)
    Please help.
    Thank you, Yuval

    Yuval,
    The version number your show for Project looks like it is not updated with SP2 and it should be. Although the version number you show for Office looks like it may be updated with SP2, you need to check. In both Project and Excel, go to File/Help. On the
    right side of the screen under find "additional version and copyright information". Click on that. If you do not see SP2 listed as part of the version number, then that application is not updated. All updates can be downloaded from: http://technet.microsoft.com/en-us/office/ee748587.
    Until you can verify that everything is updated it is pointless to guess about a problem.
    After verifying that both Project and Excel are fully updated, try exporting a new Project file into a new Excel file. Does the problem still occur?
    John

  • Vpnv4 prefix dynamic update on export-map changes

    Hi guys,
    I have a 76k running 12.2(33)SRE9a with this vrf configuration:
    ip vrf B
    rd 2:2
    export map RM-R3
    route-target import 2:2
    route-map RM-R3 permit 10
    match ip address prefix-list PL-R3
    set extcommunity rt 4:4  2:2  additive
    route-map RM-R3 permit 15
    set extcommunity rt 2:2
    ip prefix-list PL-R3 seq 5 permit 172.3.3.3/32
    ip prefix-list PL-R3 seq 10 permit 172.33.33.33/32
    So I expect that prefixes matching prefix-list PR-R3 will have route-target 2:2 4:4, and all other prefixes will have route-target 2:2.
    The question is: What happens if I remove this line of the prefix list?
    no ip prefix-list PL-R3 seq 10 permit 172.33.33.33/32
    Will there be any dynamic update? Do I have to clear bgp or ip routing table?
    Thanks!
    Diego.

    Hi Diego,
    I checked in IOU with SRE9a image and observed that there is no dynamic update and we need to do "clear ip bgp <as> soft out from CE side.
    Topology
    R1--ebgp--[vrf CUST-A] R3----vpnv4 ibgp -----R4
    ip vrf CUST-A
     rd 300:1
     export map RM-R3
     route-target export 300:1
     route-target import 300:1
    R3#show route-map RM-R3
    route-map RM-R3, permit, sequence 10
      Match clauses:
        ip address prefix-lists: PL-R3 
      Set clauses:
        extended community RT:300:1 RT:300:2 additive
      Policy routing matches: 0 packets, 0 bytes
    route-map RM-R3, permit, sequence 15
      Match clauses:
      Set clauses:
        extended community RT:300:2
      Policy routing matches: 0 packets, 0 bytes
    R3#show ip prefix  PL-R3
    ip prefix-list PL-R3: 1 entries
       seq 5 permit 172.16.17.0/24
       seq 10 permit 172.16.19.0/24
    R3#
    R4#show ip b vpnv4 all 172.16.19.0/24
    BGP routing table entry for 300:1:172.16.19.0/24, version 34
    Paths: (1 available, best #1, table CUST-A)
      Not advertised to any peer
      100
        3.3.3.3 (metric 11) from 3.3.3.3 (3.3.3.3)
          Origin IGP, metric 0, localpref 100, valid, internal, best
          Extended Community: RT:300:1 RT:300:2
          mpls labels in/out nolabel/36
    R4#
    R3(config)#no ip prefix-list PL-R3 seq 10 permit 172.16.19.0/24
    R3(config)#end
    after 10 min
    R4#show ip b vpnv4 all 172.16.19.0/24
    BGP routing table entry for 300:1:172.16.19.0/24, version 34
    Paths: (1 available, best #1, table CUST-A)
      Not advertised to any peer
      100
        3.3.3.3 (metric 11) from 3.3.3.3 (3.3.3.3)
          Origin IGP, metric 0, localpref 100, valid, internal, best
          Extended Community: RT:300:1 RT:300:2
          mpls labels in/out nolabel/36
    R4#
    R1#clear ip bgp 300 soft out
    R1#
    R4#show ip b vpnv4 all 172.16.19.0/24
    BGP routing table entry for 300:1:172.16.19.0/24, version 50
    Paths: (1 available, best #1, table CUST-A)
      Not advertised to any peer
      100
        3.3.3.3 (metric 11) from 3.3.3.3 (3.3.3.3)
          Origin IGP, metric 0, localpref 100, valid, internal, best
          Extended Community: RT:300:2
          mpls labels in/out nolabel/36
    R4#
    I hope it helps

  • Export maps from PI 1.3

    Is it possible to do an export of a map that is already in PI ? If so, can you relay the details?

    Hi Ben,
    It is possible to export the maps from PI.
    In classic view of PI go to
    Monitor >                Site Maps then from the drop down click on export maps.
    Thanks,
    Roopesh

  • My finder app is in a continuous state of crashing

    My finder app is in a continuous state of crashing and relaunching every 2 seconds or so, I can't open finder or time machine or my trash, as well as all of my desktop items are gone, I can still access the internet, but nothing online has helped me. If anybody has any solutions I would be extremely thankful. I'm using 10.6.8 . I have tried using terminal, or relaunching finder, nothing will work.

    You may be able to start up in SafeBoot and then read the Log files in the system profiler area, to see what kinds of oddities may appear or if there is some kind of kernel panic, etc going on. And while there in a booted state with limited OS X sections off by default, you may be able to see such basics as if the computer's hard disk drive is getting full, or if Disk Utility gives you any error messages when you Check Disk, and while there, note free vs used capacities, status of RAM (including VM as it uses drive space as RAM.)
    In the trouble and or crash logs, and basic running logs, Console is also a place to look, but there are very many; so this may be something to get into when or if someone who knows how to read the log file language sees your post and expresses a willingness to help decode them.
    If you have a backup, you may have to see about using 'secure erase' from the booted installer DVD or if your computer has no optical drive but has a recovery partition, see about using that system's Utilities to access Disk Utility, and then choose the Erase selection. And that would wipe the drive, and overwrite zeros on the old data; failed sectors may be tagged and avoided, or repaired, in so doing the drive would be clearer. Unless the hard disk drive is failing.
    There is a chance there may be something haywire, even corrupt/bad hard drive or bad RAM may act up, but Finder should not crash. There are related issues and ideas here, but in a later OS X version: https://discussions.apple.com/message/22273053#22273053
    Did you upgrade from an older system than 10.6(.8) or did that computer ship with the version installed? Some people upgrade over an older system and that effectively can carry a problem forward without resolving it. {edited}
    Good luck & happy computing!

  • Can anyone help me understand "Continue Statements"?

    Hi,
    I was wondering if anyone could help me understand continue statements. I've been studying the java tutorials this weekend but can not get my head around the following explanation: (My thoughts are at the end of this message and it might be easiest to read them first!)
    "The continue statement skips the current iteration of a for, while , or do-while loop. The unlabeled form skips to the end of the innermost loop's body and evaluates the boolean expression that controls the loop. The following program, ContinueDemo , steps through a String, counting the occurences of the letter "p". If the current character is not a p, the continue statement skips the rest of the loop and proceeds to the next character. If it is a "p", the program increments the letter count.
    {code}class ContinueDemo {
    public static void main(String[] args) {
    String searchMe = "peter piper picked a peck of pickled peppers";
    int max = searchMe.length();
    int numPs = 0;
    for (int i = 0; i < max; i++) {
    //interested only in p's
    if (searchMe.charAt(i) != 'p')
    continue;
    //process p's
    numPs++;
    System.out.println("Found " + numPs + " p's in the string.");
    }{code}
    Here is the output of this program:
    Found 9 p's in the string.
    To see this effect more clearly, try removing the continue statement and recompiling. When you run the program again, the count will be wrong, saying that it found 35 p's instead of 9.
    A labeled continue statement skips the current iteration of an outer loop marked with the given label. The following example program, ContinueWithLabelDemo, uses nested loops to search for a substring within another string. Two nested loops are required: one to iterate over the substring and one to iterate over the string being searched. The following program, ContinueWithLabelDemo, uses the labeled form of continue to skip an iteration in the outer loop.
    {code}class ContinueWithLabelDemo {
    public static void main(String[] args) {
    String searchMe = "Look for a substring in me";
    String substring = "sub";
    boolean foundIt = false;
    int max = searchMe.length() - substring.length();
    test:
    for (int i = 0; i <= max; i++) {
    int n = substring.length();
    int j = i;
    int k = 0;
    while (n-- != 0) {
    if (searchMe.charAt(j++)
    != substring.charAt(k++)) {
    continue test;
    foundIt = true;
    break test;
    System.out.println(foundIt ? "Found it" :
    "Didn't find it");
    }{code}
    Here is the output from this program.
    Found it"
    Here are Woodie's thoughts........................................
    1) With the first program I don't understand how the program counts the number of "p's". Like for example how it stores the number of "p's". Shouldn't it say:
    if (searchMe.charAt(i) = 'p') then store it in some sort of containers??? 2) With the second program, I don't understand the test section. For example: Why does it have --? why does it have != after while and why does it have != after if?
    while (n-- != 0)
                    if (searchMe.charAt(j++) != substring.charAt(k++))
                        continue test;
                foundIt = true;
                     break test;Edited by: woodie_woodpeck on Nov 23, 2008 3:29 AM

    Woodie, I think they're just silly "theoretical" examples... ergo don't worry too much not understanding them, coz they don't actually make a lot of sense... as you've allready pointed out there are other "more normal" control structures which achieve the same thing, and which in this case (in my humble opinion) would make for clearer, more concise, more maintainable code.
    All you need to know about continue is "it means go back to the top of the loop"... If you're not comfortable using "continue" then don't.
    There's more than one way to do it.
      public static void main(String[] args) {
        try {
          final String s = "peter piper picked a peck of pickled peppers";
          int count = 0;
          for ( char c : s.toStringArray() ) {
            if (c=='p') count++;
          System.out.println("There are "+count+ " p's in '"+s+"'");
        } catch (Exception e) {
          e.printStackTrace();
      }Having said all that... I did use continue in anger the other day... I was reading Geometries from a shape file... the reader was throwing an ArrayIndexOutOfBoundsException given an "empty Feature" (ie a feature with the geospatial presence)... All I did was catch the exception and continue trying to read the new feature... the alternative would have been to rewrite the control logic of the whole reader loop... quick, simple effective... but I don't routinely build continue statements into new code... just a matter of personal taste.
    Cheers. Keith.

  • Using the continue statement with an Iterator

    Hi everyone, got a problem; I am trying to use a continue statement to return to the start of a for loop. I am using an iterator in the for loop, not a conventional incremental/decremental counter. What is happening is that I am getting a NullPointerException because i.hasNext() is returning false. I know however, that there are subsequent records in the hashmap. Has anyone encountered this problem before? or has anyone tried to use continue with iterators? any help would be greatly appreciated!
    example of my code - This is important bit of loop:
    for (Iterator i = newCards.iterator(); i.hasNext();)
    accountID = (String) i.next();
    code where i do the continue:
    if (clientFlat.length() > 10)
    if (i.hasNext())
    System.out.println("i.hasnext has returned true and is about to continue");
    errorFlag = 2;
    continue;
    clientFlat is > 10, so it tests the i.hasNext condition. This is the problem, it returns false when it should be true.
    can anyone help? thanx

    Hi guys, can you help me...
    See my script... why the levelTemp value is different and yah, you right, the value inside iterator always some, but it is not equal with levelTemp before iteration..
    see this...
    public LinkedList getRecursiveChild() throws ClassNotFoundException, SQLException, Exception {
              LinkedList recursiveChildList,a;
              recursiveChildList = new LinkedList();
              String parent_id="";
              Iterator iterChild;
              int i=0;
              int levelTemp=0;
              DbTreeMembership dbTreeMembershipChild, dbTreeMembershipChildIterator;
              // query level 1, all downline of memberId;
              myDbBean.connect();
    mySQL = "SELECT * FROM membership WHERE parent_id='"+this.memberId+"'";
    myResultSet=myDbBean.execSQL(mySQL);
         while (myResultSet.next())
                   // query next level
                   // write all result to the list
                   parent_id = myResultSet.getString("membership_code");
                   // add to List
                   dbTreeMembershipChild = new DbTreeMembership( parent_id );
                   dbTreeMembershipChild.setLevel(level);
                   recursiveChildList.add( dbTreeMembershipChild );
                   // query level 2, if level 2 >= 1, add to list
                   // recursive procedure
                   DbTreeWalker dbTreeWalkerChild = new DbTreeWalker(dbTreeMembershipChild.getMemberId(), dbTreeMembershipChild.getLevel() + 1, this.recursiveList);
                   levelTemp=dbTreeMembershipChild.getLevel() +1;
                   System.out.println("leveltemp1:"+levelTemp);
                   a = dbTreeWalkerChild.getRecursiveChild();
                   iterChild = a.iterator();
                   // add child to LinkedList
                   while (iterChild.hasNext()) {
                        DbTreeMembership entry = (DbTreeMembership)iterChild .next();
                        dbTreeMembershipChildIterator = new DbTreeMembership( entry.getMemberId());
                        dbTreeMembershipChildIterator.setLevel(levelTemp);
                        System.out.println("leveltemp2:"+levelTemp);
                        recursiveChildList.add(dbTreeMembershipChildIterator);
              i++;
              recursiveChildCount=i;
              return      recursiveChildList;
         }

  • Inter-VPN routing with export map for host routes

    Hi,
    I am trying to export host routes from a connected network from one VRF to multiple other VRFs. This is to allow the leaking specific host routes for management purposes. However, I suspect that the /32 host route(s) actually need to be present in the management VRF so the RTs are added accordingly, rather than just specified in the match clause of the MGMT VRF export map.
    Ideally here, I only want to export 10.111.111.254/32 from the connected network 10.111.111.0/24 in the MGMT VRF. The only way around this I can see it to move 10.111.111.0/24 behind another device, and add specific host route(s) within the MGMT VRF for the 10.111.111.X/32 host routes (which are redistributed into the MGMT VRF), using the additional device as the next-hop.
    ip vrf MGMT
    rd 1:1
    export map MGMT-EXPORT-MAP
    route-target export 1:1
    route-target import 1:1
    route-target import 1:1001
    ip vrf CUST-B
    rd 1:2
    export map CUSTOMERS-EXPORT-MAP
    route-target export 1:2
    route-target import 1:2
    route-target import 1:1000
    interface FastEthernet0/0.100
    encapsulation dot1Q 100
    ip vrf forwarding MGMT
    ip address 10.111.111.1 255.255.255.0
    interface FastEthernet0/0.200
    encapsulation dot1Q 101
    ip vrf forwarding CUST-B
    ip address 10.96.2.1 255.255.254.0
    router bgp 65000
    bgp router-id 1.1.1.1
    no bgp default ipv4-unicast
    bgp log-neighbor-changes
    address-family ipv4 vrf CUST-B
      redistribute connected
      no synchronization
    exit-address-family
    address-family ipv4 vrf MGMT
      redistribute connected
      no synchronization
    exit-address-family
    ip prefix-list CUSTOMERS seq 5 permit 10.96.2.0/23
    ip prefix-list ONPREMISE seq 5 permit 10.111.111.0/24
    ip prefix-list ONPREMISE seq 10 permit 10.111.111.254/32
    route-map CUSTOMERS-EXPORT-MAP permit 10
    match ip address prefix-list CUSTOMERS
    set extcommunity rt  1:1001 additive
    route-map MGMT-EXPORT-MAP permit 10
    match ip address prefix-list ONPREMISE
    set extcommunity rt  1:1000 additive
    Cheers,
    Matt

    Hi Matt
    Yes the X/32 routes needs to be present in the VRF Routing-Table and if they are to be learnt statically then the MP-iBGP config for that particular VRF address-family has to redistribute static routes as well.
    Regards
    Varma

  • Use XSD referencing other XSDs with include statement in Message mapping

    Hello,
    I have an XSD with include statements having reference to other 4 XSDs.One XSD out of these 4,one references one more XSD
    I referred to the thread on this :
    refrencing 1 xsd to another   https://forums.sdn.sap.com/post!default.jspa?forumID=44#
    I have created 6 External Definitions one for each XSD
    Referring to the following statement in this thread:
    In XI 3.0, there is a tab there called External References. You will see there a Source and a Name. When you click the Name, click Copy Object. Then you open the target object and paste it under the Source located just before the tabs.
    The Name you see in the External References are the ones that are declared as include or import in the XSD.
    I can see included XSD names in Source column under External References tab in External definition for main XSD.
    But Name column is always blank and these columns are not editable.Also,copy doesn't work.
    We have XSD names in include statements,but I wonder when I create External definitions out of these XSDs ,how would my main External definition know,which other External definitions are referenced?
    If I use the External definition with main XSD as target structure in my mapping,I can only see the fields from this XSD and not the fields from the included XSDs.But I need to map these fields as well.
    Can anybody please let me know how can I get a complete XSD as target structure in my mapping?
    Thanks for your help.
    Regards,
    Shweta

    Plz close other duplicate threads for the same issue first..
    Regards,
    Sarvesh

  • Case statement in OWB mapping

    I am trying to use a case statement in an OWB mapping. I am attempting to use it in expression builder within a filter object. Each time I try to validate the expression in the expression builder I get an error:
    Line 4, Col 6:
    PL/SQL: ORA-00920: invalid relational operator
    Below is the code used in the expression builder window:
    CASE A.ATTRIBUTE_NAME
    WHEN 'CA COMPLETION DATE' THEN RTRIM(A.C_CODE_VALUE)
    ELSE NULL
    END
    Any help with what is happening would be appreciated.
    Thank you.
    Matt

    Thank you both for you help. I initially tried to use the expression operator but was confused since the expression builder in the expression operator has the drop down list with the available SQL clauses greyed out. In the OWB documentation it states that the drop down will contain SQL clauses that are appropriate for that expression type so when I saw it was greyed out I assumed that those clauses where not valid for this operator. Sure enough though when I pasted in my Case statement it verified correctly.
    Thanks again,
    Matt

  • Generate SQL Insert Statement using EXPORTED dmp file

    Dear DBAs,
    Kindly inform me that is it possible to generate SQL script file using the exported file dmp,
    I am looking for some option in import utility that generates script without import any rows in the database
    Secondly is there any other way to check the validity of exported dmp file data validity without importing it back into the database.
    Regards,
    Asif

    Hi Satish,
    Yes you are correct the insert into statements won't be avaliable using either the indexfile or the show parameter.I had given these two options as per his 1st post requirement where he had mentioned
    >
    it possible to generate SQL script file using the exported file dmp,I am looking for some option in import utility that generates script without import any rows in the database
    >
    So, i thought he needed to see whats all objects are in the .dmp
    Apologies for my 2nd post.
    Anand

Maybe you are looking for

  • Carry out repairs in non-original....

    I am trying to update a few programs that are z programs but I get the follow message each time I go into edit mode: 'Carry out repairs in non-original systems only if they are urgent'. Is there a way for me to get rid of this message?  I can't figur

  • Customer TDS Exemption - Amount & Percentage

    In the withholding tax tab of the customer master, there is no provision to maintain exemption amount and percentage unlike in vendor master. Pls advise. Ravi Mobile 9849393564

  • Execute immideate Create spatial index

    I can't create spatial index in package when use execute immideate declare l_res varchar2(500); begin l_res := 'CREATE INDEX INDXSDO1_elements ON (GEOMETRY) INDEXTYPE IS MDSYS.SPATIAL_INDEX'; execute immediate l_res; end; i get an exception: ORA-2985

  • What Adobe Presenter 8 Licence option is best?

    Our association would like to hire freelance content experts to develop short narrated ppt presentations (hopefully in adobe presenter) that we could then publish to the web. However, not all our authors will necessarily have this software. Is there

  • Unable to Import metadata into RPD

    Hi, I have installed OBIEE 111.1.1.6 on the sever and OBIEe client tools on my local desktop. now when i am trying to import metadata into my rpd by connecting to database it shows me the error "Unable to connect" can you please let me know if i am m