Design Studio BW SSO User not authorized

Hi all,
I have problem with BW SSO integration on Design Studio. We developed dashboards on top of BW. We have users and they are only authorized to see the data for their own companies and plants. To achieve that, we created OLAP connections with SSO enabled and we have BO/BW integration. The queries work fine in Analysis OLAP.
However, we are having problems with Design Studio. Here is the problem.
1. Create a dashboard lets say with a combo box and a chart.
2. Populate the combo box with the script below:
DROPDOWN_1.setItems(DS_1.getMemberList("0COMP_CODE", MemberPresentation.INTERNAL_KEY, MemberDisplay.TEXT, 20, "ALL"));
3. In combo box, wirte the code below to filter values on chart:
DS_1.setFilter("0PLANT__0COMP_CODE", DROPDOWN_1.getSelectedValue());
4. Save it on the platform.
5. Open the dashboard on the platform with SAP user
6. By default, in combo box, "ALL" value will be selected. If the user has only authorized to see only 1 or 2 companies, then the chart give "User is not authorized" error message.
7. Select a company from combo box, the chart shows values of the selected company.
8. If the user wants to see the total of the companies authorized to see, then the chart doesn't show but the error message.
Another issue is that each company has plants. If the user wants to seel the data for all plants then he receives the "not authorized" error.
The user should be able the select "ALL" and be able to see the total of companies or plants authorized to see.
If "ALL" is selected for a company:
If a single company selected and ALL plants are selected:
If a single company and a single plant is selected:
BTW, the authorization works fine in BW and with Analysis OLAP tools. The user can see the total of the companies authorized to see.
Thanks for your help in advance.

Hi Zahid - this application has more than one query, correct?
can you try if the authorization issue is occuring also when you have one query only per applications?
Reason I ask is, when using design studio, all queries are executed with merged variables and then I belive the authorisation context is different. I assume you have some special customer exit in the system for the authorisation check - and in case of design studio this can get into a point where the constellation is not authorized.
In such cases you would need to run authorisation trace (I would need to search the transaction).
Regards, Karol

Similar Messages

  • " User not authorized" error while deploying webdynpro application on WAS

    I am getting following error while deploying dyn pro application on WAS
    Error
    May 17, 2005 6:37:21 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] ERROR:
    [002]Deployment aborted
    Settings
    SDM host : DYNPRO
    SDM port : 50018
    URL to deploy : file:/C:/DOCUME1/720359/LOCALS1/Temp/temp50603PVTOSAP.ear
    Result
    => deployment aborted : file:/C:/DOCUME1/720359/LOCALS1/Temp/temp50603PVTOSAP.ear
    Aborted: development component 'PVTOSAP'/'local'/'LOKAL'/'0.2005.05.17.18.37.08':
    Caught exception while checking the login credentials for SAP J2EE Engine. Check whether the SAP J2EE Engine is up and running.
    com.sap.engine.deploy.manager.DeployManagerException: ERROR: Cannot connect to Host: [DYNPRO] with user name: [J2EE_ADMIN]                     Check your login information.                     Exception is: com.sap.engine.services.jndi.persistent.exceptions.NamingException: Exception while trying to get InitialContext. [Root exception is com.sap.engine.services.security.exceptions.BaseLoginException: User not authorized.]
    (message ID: com.sap.sdm.serverext.servertype.inqmy.extern.EngineApplOnlineDeployerImpl.checkLoginCredentials.DMEXC)
    Deployment exception : The deployment of at least one item aborted
    Additional Log :
    May 17, 2005 6:37:21 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] INFO:
    [002]Additional log information about the deployment
    <!LOGHEADER[START]/>
    <!HELP[Manual modification of the header may cause parsing problem!]/>
    <!LOGGINGVERSION[1.5.3.7162 - 630_SP]/>
    <!NAME[D:\usr\sap\DYN\DVEBMGS00\SDM\program\log\sdmcl20050517131312.log]/>
    <!PATTERN[sdmcl20050517131312.log]/>
    <!FORMATTER[com.sap.tc.logging.TraceFormatter(%24d %s: %m)]/>
    <!ENCODING[Cp1252]/>
    <!LOGHEADER[END]/>
    May 17, 2005 6:43:12 PM  Info: -
    Starting deployment -
    May 17, 2005 6:43:12 PM  Info: Loading selected archives...
    May 17, 2005 6:43:12 PM  Info: Loading archive 'D:\usr\sap\DYN\DVEBMGS00\SDM\program\temp\temp50603PVTOSAP.ear'
    May 17, 2005 6:43:14 PM  Info: Selected archives successfully loaded.
    May 17, 2005 6:43:14 PM  Info: Actions per selected component:
    May 17, 2005 6:43:14 PM  Info: Update: Selected development component 'PVTOSAP'/'local'/'LOKAL'/'0.2005.05.17.18.37.08' updates currently deployed development component 'PVTOSAP'/'local'/'LOKAL'/'0.2005.05.17.09.04.27'.
    May 17, 2005 6:43:15 PM  Info: Error handling strategy: OnErrorStop
    May 17, 2005 6:43:15 PM  Info: Update strategy: UpdateAllVersions
    May 17, 2005 6:43:15 PM  Info: Starting: Update: Selected development component 'PVTOSAP'/'local'/'LOKAL'/'0.2005.05.17.18.37.08' updates currently deployed development component 'PVTOSAP'/'local'/'LOKAL'/'0.2005.05.17.09.04.27'.
    May 17, 2005 6:43:15 PM  Info: SDA to be deployed: D:\usr\sap\DYN\DVEBMGS00\SDM\root\origin\local\PVtoSAP\LOKAL\0.2005.05.17.18.37.08\temp50603PVTOSAP.ear
    May 17, 2005 6:43:15 PM  Info: Software type of SDA: J2EE
    May 17, 2005 6:43:15 PM  Info: ***** Begin of SAP J2EE Engine Deployment (J2EE Application) *****
    May 17, 2005 6:43:15 PM  Info: ***** End of SAP J2EE Engine Deployment (J2EE Application) *****
    May 17, 2005 6:43:15 PM  Error: Aborted: development component 'PVTOSAP'/'local'/'LOKAL'/'0.2005.05.17.18.37.08':
    Caught exception while checking the login credentials for SAP J2EE Engine. Check whether the SAP J2EE Engine is up and running.
    com.sap.engine.deploy.manager.DeployManagerException: ERROR: Cannot connect to Host: [DYNPRO] with user name: [J2EE_ADMIN]
                        Check your login information.
                        Exception is:
    com.sap.engine.services.jndi.persistent.exceptions.NamingException: Exception while trying to get InitialContext. [Root exception is com.sap.engine.services.security.exceptions.BaseLoginException: User not authorized.]
    (message ID: com.sap.sdm.serverext.servertype.inqmy.extern.EngineApplOnlineDeployerImpl.checkLoginCredentials.DMEXC)
    May 17, 2005 6:43:17 PM  Error: -
    At least one of the Deployments failed -

    Hi Abhijeet,
    1. Execute the remoteGUI
    <<Installed drive>>:\usr\sap\J2E\JC00\SDM\program\RemoteGui.bat
    2. Click the "Connect to SDM server" (Menu "SDM GUI --> Login")
    3. Give the hostname (DYNPRO) and port (50018)
    4. Enter the password and click login.
    Check whether you are able to login or not. If you are not able to login through the RemoteGUI, then the password might be wrong. Check the password.
    Regards,
    Santhosh.C

  • AnyConnect error " User not authorized for AnyConnect Client access, contact your administrator"

    Hi everyone,
    it's probably just me but I have tried real hard to get a simple AnyConnect setup working in a lab environment on my ASA 5505 at home, without luck. When I connect with the AnyConnect client I get the error message "User not authorized for AnyConnect Client access, contact your administrator". I have searched for this error and tried some of the few solutions out there, but to no avail. I also updated the ASA from 8.4.4(1) to 9.1(1) and ASDM from 6.4(9) to 7.1(1) but still the same problem. The setup of the ASA is straight forward, directly connected to the Internet with a 10.0.1.0 / 24 subnet on the inside and an address pool of 10.0.2.0 / 24 to assign to the VPN clients. Please note that due to ISP restrictions, I'm using port 44455 instead of 443. I had AnyConnect working with the SSL portal, but IKEv2 IPsec is giving me a headache. I have stripped down certificate authentication which I had running before just to eliminate this as a potential cause of the issue. When running debugging, I do not get any error messages - the handshake completes successfully and the local authentication works fine as well.
    Please find the current config and debugging output below. I appreciate any pointers as to what might be wrong here.
    : Saved
    ASA Version 9.1(1)
    hostname ASA
    domain-name ingo.local
    enable password ... encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd ... encrypted
    names
    name 10.0.1.0 LAN-10-0-1-x
    dns-guard
    ip local pool VPNPool 10.0.2.1-10.0.2.10 mask 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif Internal
    security-level 100
    ip address 10.0.1.254 255.255.255.0
    interface Vlan2
    nameif External
    security-level 0
    ip address dhcp setroute
    regex BlockFacebook "facebook.com"
    banner login This is a monitored system. Unauthorized access is prohibited.
    boot system disk0:/asa911-k8.bin
    ftp mode passive
    clock timezone PST -8
    clock summer-time PDT recurring
    dns domain-lookup Internal
    dns domain-lookup External
    dns server-group DefaultDNS
    name-server 10.0.1.11
    name-server 75.153.176.1
    name-server 75.153.176.9
    domain-name ingo.local
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network LAN-10-0-1-x
    subnet 10.0.1.0 255.255.255.0
    object network Company-IP1
    host xxx.xxx.xxx.xxx
    object network Company-IP2
    host xxx.xxx.xxx.xxx
    object network HYPER-V-DUAL-IP
    range 10.0.1.1 10.0.1.2
    object network LAN-10-0-1-X
    access-list 100 extended permit tcp any4 object HYPER-V-DUAL-IP eq 3389 inactive
    access-list 100 extended permit tcp object Company-IP1 object HYPER-V-DUAL-IP eq 3389
    access-list 100 extended permit tcp object Company-IP2 object HYPER-V-DUAL-IP eq 3389 
    tcp-map Normalizer
      check-retransmission
      checksum-verification
    no pager
    logging enable
    logging timestamp
    logging list Threats message 106023
    logging list Threats message 106100
    logging list Threats message 106015
    logging list Threats message 106021
    logging list Threats message 401004
    logging buffered errors
    logging trap Threats
    logging asdm debugging
    logging device-id hostname
    logging host Internal 10.0.1.11 format emblem
    logging ftp-bufferwrap
    logging ftp-server 10.0.1.11 / asa *****
    logging permit-hostdown
    mtu Internal 1500
    mtu External 1500
    ip verify reverse-path interface Internal
    ip verify reverse-path interface External
    icmp unreachable rate-limit 1 burst-size 1
    icmp deny any echo External
    asdm image disk0:/asdm-711.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (Internal,External) dynamic interface
    object network LAN-10-0-1-x
    nat (Internal,External) dynamic interface
    object network HYPER-V-DUAL-IP
    nat (Internal,External) static interface service tcp 3389 3389
    access-group 100 in interface External
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server radius protocol radius
    aaa-server radius (Internal) host 10.0.1.11
    key *****
    radius-common-pw *****
    user-identity default-domain LOCAL
    aaa authentication ssh console radius LOCAL
    http server enable
    http LAN-10-0-1-x 255.255.255.0 Internal
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto ipsec security-association pmtu-aging infinite
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map External_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map External_map interface External
    crypto ca trustpoint srv01_trustpoint
    enrollment terminal
    crl configure
    crypto ca trustpoint asa_cert_trustpoint
    keypair asa_cert_trustpoint
    crl configure
    crypto ca trustpoint LOCAL-CA-SERVER
    keypair LOCAL-CA-SERVER
    crl configure
    crypto ca trustpool policy
    crypto ca server
    cdp-url http://.../+CSCOCA+/asa_ca.crl:44435
    issuer-name CN=...
    database path disk0:/LOCAL_CA_SERVER/
    smtp from-address ...
    publish-crl External 44436
    crypto ca certificate chain srv01_trustpoint
    certificate <output omitted>
      quit
    crypto ca certificate chain asa_cert_trustpoint
    certificate <output omitted>
      quit
    crypto ca certificate chain LOCAL-CA-SERVER
    certificate <output omitted>
      quit
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable External client-services port 44455
    crypto ikev2 remote-access trustpoint asa_cert_trustpoint
    telnet timeout 5
    ssh LAN-10-0-1-x 255.255.255.0 Internal
    ssh xxx.xxx.xxx.xxx 255.255.255.255 External
    ssh xxx.xxx.xxx.xxx 255.255.255.255 External
    ssh timeout 5
    ssh version 2
    console timeout 0
    no vpn-addr-assign aaa
    no ipv6-vpn-addr-assign aaa
    no ipv6-vpn-addr-assign local
    dhcpd dns 75.153.176.9 75.153.176.1
    dhcpd domain ingo.local
    dhcpd option 3 ip 10.0.1.254
    dhcpd address 10.0.1.50-10.0.1.81 Internal
    dhcpd enable Internal
    threat-detection basic-threat
    threat-detection scanning-threat shun except ip-address LAN-10-0-1-x 255.255.255.0
    threat-detection statistics access-list
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    dynamic-filter use-database
    dynamic-filter enable interface Internal
    dynamic-filter enable interface External
    dynamic-filter drop blacklist interface Internal
    dynamic-filter drop blacklist interface External
    ntp server 128.233.3.101 source External
    ntp server 128.233.3.100 source External prefer
    ntp server 204.152.184.72 source External
    ntp server 192.6.38.127 source External
    ssl encryption aes256-sha1 aes128-sha1 3des-sha1
    ssl trust-point asa_cert_trustpoint External
    webvpn
    port 44433
    enable External
    dtls port 44433
    anyconnect image disk0:/anyconnect-win-3.1.02026-k9.pkg 1
    anyconnect profiles profile1 disk0:/profile1.xml
    anyconnect enable
    smart-tunnel list SmartTunnelList1 mstsc mstsc.exe platform windows
    smart-tunnel list SmartTunnelList1 putty putty.exe platform windows
    group-policy DfltGrpPolicy attributes
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec ssl-client ssl-clientless
    webvpn
      anyconnect profiles value profile1 type user
    username write.ingo password ... encrypted
    username ingo password ... encrypted privilege 15
    username tom.tucker password ... encrypted
    class-map TCP
    match port tcp range 1 65535
    class-map type regex match-any BlockFacebook
    match regex BlockFacebook
    class-map type inspect http match-all BlockDomains
    match request header host regex class BlockFacebook
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 1500
      id-randomization
    policy-map TCP
    class TCP
      set connection conn-max 1000 embryonic-conn-max 1000 per-client-max 250 per-client-embryonic-max 250
      set connection timeout dcd
      set connection advanced-options Normalizer
      set connection decrement-ttl
    policy-map type inspect http HTTP
    parameters
      protocol-violation action drop-connection log
    class BlockDomains
    policy-map global_policy
    class inspection_default
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect dns preset_dns_map dynamic-filter-snoop
      inspect http HTTP
    service-policy global_policy global
    service-policy TCP interface External
    smtp-server 199.185.220.249
    privilege cmd level 3 mode exec command perfmon
    privilege cmd level 3 mode exec command ping
    privilege cmd level 3 mode exec command who
    privilege cmd level 3 mode exec command logging
    privilege cmd level 3 mode exec command failover
    privilege cmd level 3 mode exec command vpn-sessiondb
    privilege cmd level 3 mode exec command packet-tracer
    privilege show level 5 mode exec command import
    privilege show level 5 mode exec command running-config
    privilege show level 3 mode exec command reload
    privilege show level 3 mode exec command mode
    privilege show level 3 mode exec command firewall
    privilege show level 3 mode exec command asp
    privilege show level 3 mode exec command cpu
    privilege show level 3 mode exec command interface
    privilege show level 3 mode exec command clock
    privilege show level 3 mode exec command dns-hosts
    privilege show level 3 mode exec command access-list
    privilege show level 3 mode exec command logging
    privilege show level 3 mode exec command vlan
    privilege show level 3 mode exec command ip
    privilege show level 3 mode exec command failover
    privilege show level 3 mode exec command asdm
    privilege show level 3 mode exec command arp
    privilege show level 3 mode exec command ipv6
    privilege show level 3 mode exec command route
    privilege show level 3 mode exec command ospf
    privilege show level 3 mode exec command aaa-server
    privilege show level 3 mode exec command aaa
    privilege show level 3 mode exec command eigrp
    privilege show level 3 mode exec command crypto
    privilege show level 3 mode exec command ssh
    privilege show level 3 mode exec command vpn-sessiondb
    privilege show level 3 mode exec command vpnclient
    privilege show level 3 mode exec command vpn
    privilege show level 3 mode exec command dhcpd
    privilege show level 3 mode exec command blocks
    privilege show level 3 mode exec command wccp
    privilege show level 3 mode exec command dynamic-filter
    privilege show level 3 mode exec command webvpn
    privilege show level 3 mode exec command service-policy
    privilege show level 3 mode exec command module
    privilege show level 3 mode exec command uauth
    privilege show level 3 mode exec command compression
    privilege show level 3 mode configure command interface
    privilege show level 3 mode configure command clock
    privilege show level 3 mode configure command access-list
    privilege show level 3 mode configure command logging
    privilege show level 3 mode configure command ip
    privilege show level 3 mode configure command failover
    privilege show level 5 mode configure command asdm
    privilege show level 3 mode configure command arp
    privilege show level 3 mode configure command route
    privilege show level 3 mode configure command aaa-server
    privilege show level 3 mode configure command aaa
    privilege show level 3 mode configure command crypto
    privilege show level 3 mode configure command ssh
    privilege show level 3 mode configure command dhcpd
    privilege show level 5 mode configure command privilege
    privilege clear level 3 mode exec command dns-hosts
    privilege clear level 3 mode exec command logging
    privilege clear level 3 mode exec command arp
    privilege clear level 3 mode exec command aaa-server
    privilege clear level 3 mode exec command crypto
    privilege clear level 3 mode exec command dynamic-filter
    privilege cmd level 3 mode configure command failover
    privilege clear level 3 mode configure command logging
    privilege clear level 3 mode configure command arp
    privilege clear level 3 mode configure command crypto
    privilege clear level 3 mode configure command aaa-server
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:41a021a28f73c647a2f550ba932bed1a
    : end
    Many thanks,
    Ingo

    Hi Jose,
    here is what I got now:
    ASA(config)# sh run | begin tunnel-group
    tunnel-group DefaultWEBVPNGroup general-attributes
    address-pool VPNPool
    authorization-required
    and DAP debugging still the same:
    ASA(config)# DAP_TRACE: DAP_open: CDC45080
    DAP_TRACE: Username: tom.tucker, aaa.cisco.grouppolicy = DfltGrpPolicy
    DAP_TRACE: Username: tom.tucker, aaa.cisco.username = tom.tucker
    DAP_TRACE: Username: tom.tucker, aaa.cisco.username1 = tom.tucker
    DAP_TRACE: Username: tom.tucker, aaa.cisco.username2 =
    DAP_TRACE: Username: tom.tucker, aaa.cisco.tunnelgroup = DefaultWEBVPNGroup
    DAP_TRACE: Username: tom.tucker, DAP_add_SCEP: scep required = [FALSE]
    DAP_TRACE: Username: tom.tucker, DAP_add_AC:
    endpoint.anyconnect.clientversion="3.1.02026";
    endpoint.anyconnect.platform="win";
    DAP_TRACE: Username: tom.tucker, dap_aggregate_attr: rec_count = 1
    DAP_TRACE: Username: tom.tucker, Selected DAPs: DfltAccessPolicy
    DAP_TRACE: Username: tom.tucker, DAP_close: CDC45080
    Unfortunately, it still doesn't work. Hmmm.. maybe a wipe of the config and starting from scratch can help?
    Thanks,
    Ingo

  • User not authorized for message processing

    Hi,
    I have a SM59 connection from SAP PI --> SAP R3.
    Targethost sapr3T.mydomain.
    Path prefix: /sap/xi/engine?type=entry
    Process: From PI send a message to R3 (scenarie is a Server Proxy...)
    User: PIPROXY has  Role SAP_XI_APPL_SERV_USER
    This is not enought I get error "User not authorized for message processing" when trying the connection from my  PI server. (I tried with SAP_ALL and then it works)
    What would be the right user role for this operation ?
    Br,
    Martin

    Hi all,
    I have the same problem in a XI -> BW scenario (Abap proxy).
    I get error "User not authorized for message processing" when try to send message from PI to BW.
    (I tried with SAP_ALL and then it works)
    User: PI1REMOTE has Role SAP_XI_APPL_SERV_USER and SAP_XI_IS_SERV_USER
    What would be the right user role for this operation ?
    Thanks
    Daniele

  • RSDRC / FORM AUTHORITY_CHECK USER NOT AUTHORIZED

    Hi Gurus,
    I am working on 3.5 version. Got the following error messages while trying to retrieve data from Cube.
    RSDRC / FORM AUTHORITY_CHECK USER NOT AUTHORIZED
    RSDRC / FUNC RSDRC_BASIC_CUBE_DATA_GET ERROR IN RSDRC_
    RSDRC / FORM DATA_GET ERROR IN RSDRC_BASIC_CUBE_DATA_GE
    Data cannot be seen in the report too.
    However, PSA displays the data. The request is also green.
    This is related to authorizations. Can anybody help?
    Points assured.
    Thanks.

    Run Su53 and check the authorization for the user that is getting this error.
    Also, check for all the obejcts in the cube, whether any of them are marked "authorization relevant". If so and if you have authorization objects created on them, and have a variable on that characteristic and if values are maintained for that variable, make sure the user who is getting this error has value in that variable.
    Ravi Thothadri

  • Watch ESPN - User not authorized error

    I'm a U-200 subscriber, I get all of the ESPN channels on u-verse.  I recently moved to Kansas City from Chicago, and since the move I haven't been able to access Watch ESPN online.  I've tried from my laptop, phone and two different tablets.  I just get the User Not Authorized error.  Does anyone know how to fix this?  I don't have time to spend an hour on hold waiting for tech support.

    I'm a U-200 subscriber, I get all of the ESPN channels on u-verse, and also BTN, NBCSN, etc..  I recently upgraded from Internet U-verse only to U-200 and Internet, switching from DirecTV.  Unfortunately, when I try to use TV network apps on my iPhone and iPad (like ABC, Watch ESPN, NBC Sports Live Extra, Fox, BTN2Go, etc), after selecting ATT  U-verse as my participating TV provider and entering my U-verse credentials, I just get the User Not Authorized error from every single app.  Does anyone know how to fix this?  I don't have time to spend an hour on hold waiting for tech support, and I am about to switch back to another provider after only three days with U-verse. Examples of errors: NBC Sports Live Extra: "We're Sorry it looks like you're not a subscriber to this channel. Please contact you're provider."ABC: "Error code:400-1. Unfortunately, you cannot access this content. Please contact your TV provider for further assistance."BTN2Go: "User is not authroized to this content."Watch ESPN: "Unable to play video. You are not authorized to play this content. Please contact your provider." Can someone please help??? Talked with two techs who have basically thrown up their hands saying they cannot help. Update on 6/9: So I sent a PM to ATTU-verseCare and quickly got a response from SadathCS. He called me and noticed that when I upgraded from Internet Only Uverse, the database they use to authenticate TV subs on these apps was not properly synched after my upgrade to the TV/Internet account bundle.  He forced the sync and it is now working. Thanks SadathCS! issue solved.

  • Internal Error - User not authorized to use the gross profit module

    We have a client who has a limited logistics license and just recently moved to 8.8.  in the past he could deliver directly from a pick list but now he is getting an error "User not authorized to use the gross profit module".  Is this something related to an authorization setting?  Before the move this task was not an issue.  Please advise.
    Thank you.
    Rene

    Hi Gordon, one of our user just experienced the same problem in sales order.
    In Form Settings he ticked "Display BP Catalog Number", and while he entered the catalog number he got the same error message.
    I'm not sure what this has to do with the gross profit base method...maybe the fields "Gross profit" and "Gross profit base price"?   Don't know where to set them up.
    Thanks.

  • System error - User not authorized to access requested Info Object!

    Hi, Experts,
    I have a user ID begin with S***, but when I click some links, the following message shows:
    "System error - User not authorized to access requested Info Object!"
    How could I have authorization to see these links?
    Thanks!
    Lorrie

    Hi Lorrie,
    If you are a superuser, you should not get this error.
    If not, you can not change any autohorizations.
    Check it out.  For your job, you have to be a super user.
    Thanks,
    Gordon

  • System error: RSDRC / FORM AUTHORITY_CHECK USER NOT AUTHORIZED 0SAL_DS01 0S

    Hello
    I have a big problem, I a have active the ODS 0SAL_DS01 with the update rule 0CRM_SALES_ACT_1.
    I have upload the data without problem.
    When I want to see the data I have this message :
    Your user master record is not sufficiently maintained for object Sales Org
    System error: RSDRC / FORM AUTHORITY_CHECK USER NOT AUTHORIZED 0SAL_DS01 0SAL_DS01
    Can someone help me please?
    Regards.
    Farchid

    Hi Farchid,
    You need auth for the SalesOrg Auth object that is securing this ODS. In RSSM, you can enter 0SAL_DS01 in the check for InfoProvider box and then click display. You should see a check mark against this auth object for SalesOrg. Makre sure that you have the related role assigned to your ID.
    Hope this helps...

  • User "not authorized" but should be

    Greetings,
    I am administrator to a licensed Breeze operation at the
    University of St. Francis. I have a user, an instructor, who has an
    account and has priveleges for content, meeting hosting, and
    training. The user downloaded the Breeze Presenter.exe plug-in to
    his home computer, and installed it but gets a "not authorized"
    message when he tries to publish. He says
    "I tried to publish a presentation from home and I got a
    message saying I do not have authorization.
    This is quite frustrating. How can I not have the authority?
    Why is this message appearing?"
    If someone could shed some light on this, I will be most
    appreciative,
    Glen Gummess
    Instructional Designer
    University of St. Francis

    Hi Krishnan,
    I have added this A_B in the analysis auth and maintained hierarchy authorizations for A_B. In hierarchy D , user should see only D2,D5,D6 among D1 to D10. Hence I have given the following parameters.
    _Definition of hierarchy authorization:_
    Hierarchy : D
    Nodes: D2,D5 andD6
    Type of authorization: 0 (only the selected nodes)
    Hierarchy level: 0
    Validity range: 2 ( Name identical)
    can you pls. tell me that above paramters are correct or not..
    still I am getting user is not aouthorized after maintaining all these.
    regards
    ameer

  • Error while creating user - not authorized to assign profiles or roles

    I have configured CUA according to the help.sap.com instructions.  I am getting this error (in TCODE SCUL)..
    +You are not authorized to assign profiles
    Message no. 01589
    You are not authorized to assign profiles to users or to cancel the authorization.+
    I can create the user, change the address data, and initial password.
    I get errors on assigning to a group, parameters, or the role and profiles. 
    We are on NW Mobile 7.1 (ABAP stack only) SP05.
    I've read Note "492589 - CUA:  Minimum authorizations for communications users."
    It mentions SP07.  Is this not compatible?

    > Run SU53 (immediately after you receive the error message) and check which authorizations that failed. You probably miss S_USER_PRO with activity 01 or 02 from your own roles.
    I think that will not work in his situation. The errors show up in SCUL so they may come from one or more of the CUA children. Running SU53 in the CUA master will (if that is the case) not provide the necessary info.

  • User not authorized for particular Transaction.

    While running a Custom Transaction I m getting error that user is not authorized for that transaction.
    how to solve this?

    Hi,
    Try using FM C160_TRANSACTION_CALL. Let's see if this works.
    OR
    Create a custom program that calls your custom transaction code.
    Hope this helps.
    Benedict

  • Weblogic user not authorized to use announcements

    Hi
    I have recently installed Webcenter on Windows and am working with Spaces at this point. For some reason I cannot use announcements and discussions. My Spaces home page has the following under the announcement banner:
    User is not authorized.
    Also when I navigate to administration > configuration > services > discussions I get the following error:
    failure to authenticate the user weblogic, due to: Unexpected error occurred, due to : oracle.j2ee.ws.client.jaxws.JRFSOAPFaultException: Client received SOAP Fault from server : SOAP must understand error. Server could not understand one or more SOAP headers : {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security
    Everything else seems to be working ok, such as content server, documents etc. I have followed the admin guide regarding the jive set up file and can also connect and see the embedded LDAP server ok using an LDAP browser and connect to the discussions server directly. I have also created a connection to the discussion server which tests ok using the em farm, so everything suggests it should be working ok. To confirm I am using the embedded LDAP server on the WLS admin server, delivered as part of the Webcenter download and I have configured 2 machines on one box with the Admin Server, WC_Spaces and WC_Collaboration all being on the same machine (WC_Host).Can someone please suggest what else I may need to do?
    Cheers
    Stacy

    Hi Stacy,
    You probably want to get help for this in the right forum which is WebCenter Portal (https://forums.oracle.com/community/developer/english/fusion_middleware/webcenter/webcenter_portal)
    This seems like a config issue. Try the following to resolve the issue. It is from KM Article https://support.oracle.com/epmos/faces/DocContentDisplay?id=1541024.1
    Ensure that the WC_Spaces and WC_Collaboration managed servers are running.
    Run the following WLST command to attach an OWSM policy on the Spaces Web service endpoint:attachWebServicePolicy(application='webcenter', moduleName='webcenter', moduleType='web', serviceName='SpacesWebService',subjectName='SpacesWebServiceSoapHttpPort', policyURI='oracle/wss11_saml_token_with_message_protection_service_policy')
    Run the following WLST command to attach an OWSM policy on the Discussions Web service endpoint:attachWebServicePolicy(application='owc_discussions', moduleName='owc_discussions', moduleType='web', serviceName='OWCDiscussionsServiceAuthenticated',subjectName='OWCDiscussionsServiceAuthenticated', policyURI='oracle/wss10_saml_token_service_policy')
    Restart the WC_Spaces and WC_Collaboration managed servers.

  • Web content, user not authorized, credential error

    I'm trying to do a query from the web, and am running into a "The user was not authorized" error, "The credentials provided for the Web source, are invalid. Please update the credentials..."
    I can use MSIE to access the exact same URL with the exact same credentials, using "Basic" web authentication, and it works fine.
    Even more strangely, looking through my web server logs, apparently Power Query successfully authenticates the first time, but then it repeats the request (perhaps looking at additional tables in the output?) and then fails to authorize.
    And, if I intentionally typo the end of the URL, I get a '404 not found', which you can only get if you successfully authorize!
    The following lines are from the web server access log, only showing testing instances from Power Query.
    First the intentional typo:
    [13146] aaa.bbb.ccc.ddd- ed [11/Sep/2014:16:03:12 -0500] "GET /cgi-bin/XXXXXXXz HTTP/1.1" 404 320
    [13146] aaa.bbb.ccc.ddd - ed [11/Sep/2014:16:03:13 -0500] "GET /cgi-bin/XXXXXXXz HTTP/1.1" 404 320
    The " - ed" shows that I successfully authenticated.
    Then, with the correct spelling of the end of the URL:
    [12617] aaa.bbb.ccc.ddd - ed [11/Sep/2014:16:03:51 -0500] "GET /cgi-bin/XXXXXXXX HTTP/1.1" 200 4007
    [13156] aaa.bbb.ccc.ddd - - [11/Sep/2014:16:03:52 -0500] "GET /cgi-bin/XXXXXXXX HTTP/1.1" 401 479
    [13146] aaa.bbb.ccc.ddd - ed [11/Sep/2014:16:03:53 -0500] "GET /cgi-bin/XXXXXXXX HTTP/1.1" 200 4007
    For some reason, Power Query sends the request 3 times. The first and third times successfully authenticate (" - ed", and a "200" response code). But the second time fails to authenticate, and apparently, that's all that Power Query cares
    about, since I get a "The user was not authorized" error.
    Any ideas? I tried enabling tracing, but I can't discern anything useful in the log file.
    Thanks,
    Ed

    You can use "send a frown" from inside the addin to report this as a bug. However, I think this is a known issue. We have to load the web page into IE in order to get the DOM, and I think we don't have any way to set the credential for IE.

  • Having the tab to be not visible for users not authorized to access it

    Hello,
    I've set up an authorization scheme to certain tabs. However, users who are not allowed to access them still have the tabs visible to them. When they click on the tab, they are redirected to a page that contains the error message that they are not authorize to view the page. Is there a way of not making the tabs available at all to those who are not authorize to use it? thanks

    Have you set the same authorization scheme to the tab as you set to the page which is started by the tab?
    If so, you should not see the tab.
    Fred.

Maybe you are looking for

  • My ipod is recognized by windows but not itunes

    Ok, I had trouble with my 4gb black nano when I had to install it, i used TrevorQ's tip and it worked. Now I need to update some songs on my ipod and it wont recognize it now 6.05.20 Itunes 2006-03-23 Ipod Updater I cant end the "IpodService.exe" pro

  • Problem to read and write files on hdd out of html with an Applet ????

    hi there, i wrote an applet for loading a file from HDD or saving data out of a cookie in a file on a hdd. when i compile the class there are warnings about "unchecked method invocation" and "unchecked conversion". what did i do wrong? i think it's a

  • Change No & BOM

    Hi PP Gurus, I am using change numbers for BOM. My requirement is while changing BOM system should ask the reason or some description where I can enter the reason. How this is possible? Also User should not change the quantity is subcontracting Purch

  • Srm 70 BRF deadline monitoring BUS2201

    Dear SDN-ers, We are using SRM70 process controlled workflow. In my project we would like to use deadline monitoring on PO approval workitems. When we check the customising for deadline for events Business object BUS2201 does not contain any usable e

  • Limiting the time when Sales Orders can be confirmed on the same day

    Hello Gurus. The business has a requirement where they want to limit the time of the day when they can confirm sales orders on the same day. So, when they receive a sales order, they want that if the order is received after a certain time (e.g. 14:00