Error connection using JCO.Client

Hello all,
I got the following problem <b>"Error connection using JCO.Client"</b> and don't know what's wrong. All connections works at the content administration when I test the connection.
Can anyone help me please?
Best regards
Petra

Hi,
I almost tested the JCO connection with the 'test' button successfully at the content administrator. I tested again and it still works. And I have a stand alone webdynpro application (no portal).
Now I got the following error message after completing the coding with 'e.printStackTrace().'.
<i>
"Error connection using JCO.Client:null"
"[Ljava.lang.StackTraceElement:@60db08"
"Could not create JCOClientConnection for logical System:WD_MODELDATA_DEST - Model: class impersonalaccout.intro.model.Z_Fh0002_Datenverwaltung.Please assure that you have configured the RFC connections and/or logical System"
"com.sap.tc.webdynpro.modelimpl.dynamicrfc.WDDynamicRFCException:Error connection using JCO.Client:null"
"com.sap.tc.webdynpro.modelimpl.dynamicrfc.WDDynamicRFCException: Could not create JCOClientConnection for logical System: WD_MODELDATA_DEST - Model:class impersonalaccout.intro.model.Z_Fh0002_Datenveraltung.Please ***"</i>
Can anyone explaine me what's wrong?
Bye
Petra

Similar Messages

  • Error connecting using JCO.Client: null

    Hi,
    I created a WD app which uses  the RFC FM.  I followed How-To-build-webdynpro.pdf document to create the WD and trying to deploy and run, I see the view page but when I trigger the action via button UI element I get following error as exception in the try catch block of execute method
    In the NWA I see
    Could not create JCOClientConnection for logical System: 'WD_MODELDATA_DEST' - Model
    An exception has occurred: Erorr accessing cache [region]='XCM_SESSION_SCOPE'.
    [EXCEPTION]
    com.sap.isa.core.cache.Cache$Exception: Cannot return access for region 'XCM_SESSION_SCOPE'. Cache is not ready
    I'm using following existing JCO definition by configuring them with correct parameters.  Tested them successfully
    WD_RFC_METADATA_DEST
    WD_MODELDATA_DEST
    What am I missing?  In SM04 tcode I see 2 connections are opened with 2 Megabyte not released for a long time.  I think if connections are released correctly it should drop to 1 megabyte.  Is there anything that I need to do just after execute method as shown below (I have replaced function module with <FM> in below code)
    try {
             wdContext.node<FM>_Input().current<FM>_Get_InputElement().modelObject().execute();
         } catch(Exception exception) {
              msgMgr.reportException(exception.getLocalizedMessage(), false);
          wdContext.nodeOutput().invalidate();
          msgMgr.reportSuccess("Success");
    The error is in the catch block which is displayed on the view page.
    Thanks
    Praveen
    I modified the above code and put in finally block to close the connections as follows, please let me know if this is OK.  I still get error message as "Error connecting using JCO.Client: null" but no additional connections in the SM04 after adding finally block.
    try {
             wdContext.node<FM>_Input().current<FM>_Get_InputElement().modelObject().execute();
         } catch(Exception exception) {
              msgMgr.reportException(exception.getLocalizedMessage(), false);
         }finally {
              // disconnect the connection
              wdContext.<FM>_Get_InputElement().modelObject().modelInstance().disconnectIfAlive();     
    Edited by: Praveen11 on Oct 5, 2009 9:06 AM

    Thanks Satish.
    The issue is resolved.  I think it was to do with permission, as I was running directly from NWDS deploy and run the session didn't have proper authorisation or something that was causing this error.
    When I copy pasted the URL in the correct browser session window I got no error and function module was successfully executed.   However the issue now is that values are not showing up in the view may be to do with mapping context or model  I'll review and post back as different thread.
    Thanks
    Praveen

  • Error connection using  JCO.Client :null

    Hi,
    I have small doubt in JCO connection, can any one help me.
    In WebDynpro  application some time we are getting exception like Error connection using JCO.client : null.
    Connection :200 we are maintained in JCO configuration.
    If I call one RFC useing JCO it will created a session or connection to ECC server, because we are getting exception in server too many sessions to ECC server.  
    Write now we are not using any code to close the connection like.
    SaveModel svModel = (SaveModel)WDModelFactory.getModelInstance(SaveModel.class);
    svModel.disconnectIfAlive();
    If we use the above code it will close the connection or sessions.
    Is it recommended to write the code in every RFC calls or  in final block of all RFC calls ?
    Regards,
    Satya.

    Hi Satya
    /message/1944647#1944647 [original link is broken]
    /message/8499#8499 [original link is broken]
    Please go through this link.Hope it will be helpful for you
    Regards
    Ruturaj

  • WDDynamicRFCExecuteException: Error connecting using JCO.Client: null

    Hi
    This is a common problem,I have seen many threads , but following them did not solve my problem.
    I have the JCOs tested successful from WD Admin. When I create a sample WDJ application with RFC model and deploy it to the server, I get
    Exception:com.sap.tc.webdynpro.modelimpl.dynamicrfc.WDDynamicRFCExecution: Error connecting using JCO.Client: null.
    I have checked my binding , I have only one input parameter and the code is
          wdComponentAPI.getMessageManager().reportSuccess("Inside wdInit in Component ctrller");
          Z_Plm44_Obsoleteimpactanalysis_Input input = new Z_Plm44_Obsoleteimpactanalysis_Input();
         wdContext.nodeZ_Plm_Input().bind(input);
         wdContext.createZ_Plm_InputElement(input).setV_Type(wdContext.currentZ_Plm_InputElement().getV_Type());
    Also I have implemented closing the connection
    disconnectifalive
    I contacted the basis team... they tell me that everything is fine from their end. they have tried increasing the JCO connection pools.
    Thanks for your help in advance
    Karthika

    Hi Karthika
    Check this pdf and try to catch WDDynamicRFCExecution in catch block.
    Please put your code in try catch and also import com.sap.tc.webdynpro.modelimpl.dynamicrfc.WDDynamicRFCExecution in your code;
    http://www.sappro.com/downloads/WebDynproJava.pdf
    Re: User has no RFC authorization for function group.
    Hope this will help you.
    thanks
    Arun Jaiswal

  • Error in Connecting to BAPI (Error connecting using JCO.Client: null)

    Hi,
        I am trying to connect to a BAPI to extract data. However, I am getting this error
        Error connecting using JCO.Client: null
        Pls explain the meaning of the error and solution to the problem
    TIA
    Himanshu

    Hi,
    This means you are getting error while executing your model. its not able to use the JCO's.
    as I asked previously check your JCO status... its up and running????
    Here are some threads having same problem
    URGENT :Error connecting using JCO.Client: null
    Model and MetaData configarations  in JCO Connection
    Exception while executing
    PradeeP
    Edited by: pradeep bondla on Jul 31, 2008 11:53 AM

  • Error connecting using JCO.Client: null in xRPM in EP

    Hi Friends,
    I am getting the following error in xRPM through EP
    "Error connecting using JCO.Client: null"
    I can't enter xRPM, but I can enter other Business packages iViews.
    The problem is intermittant and user specific.
    Can you pls provide any input on this ?
    thanks in advance and warm regards
    Purnendu

    Hi Flavio,
    Thanks for your reply.
    The user is created both in the backend as well as in portal.
    The roles are also ok.
    The error I am getting only while accessing xRPM iViews.
    If I restart the instance the error is removed. But it reappears again may be after few days.
    This error is intermittant.
    May be it is related to the Maximum Number of JCo connections in the WebDynpro configuration.
    But I don't have much idea on that.
    Can you pls provide any help on this.
    Warm regards
    Purnendu

  • Error connecting using RemoteObject

    I've developed a simple flex app for listing data in a grid,
    which works just fine locally when the remoteobject call is made to
    the cfc. However, once the file was moved to a testing server, I
    receive the following error when the object call fires off:
    [RPC Fault faultString="Send failed"
    faultCode="Client.Error.MessageSend"
    faultDetail="Channel.Connect.Failed error
    NetConnection.Call.BadVersion: : url:
    http://www.website.edu/flex2gateway/
    The site does have a firewall in place, but the call to the
    page is being made from a pc inside the network. Are there any
    specific cf config files that need modified to allow the AMF
    message to get through?
    Thanks!

    Hi
    1.May be JCO's are not configured properly.Check your JCO's are up and running by pinging it in ContentAdmin->WebDynpro.
    2. its a simple problem of connection pooling. In your JCO connection settings change the maximum connections to 200. It will work.it  is good After you execute the Model please release the connection. The reason you are getting this JCO Client null is because the connection is not getting released.
    When you say the following code
    wdContext.current<BAPI_INPUT>.modelObject().execute();
    //Get the reference to the model and release the connection
    If your Model name is say "MO_Mymodel"  then
    MO_Mymodel model = (MO_Mymodel) WDModelFactory.getModelInstance(MO_Mymodel.class);
    model.disconnectIfAlive();
    This should release your connections. Also ensure you release the connections even if there is a exception :).
    Please refer the below forum also:
    Error connection using  JCO.Client :null
    JCO.Client: null
    com.sap.mw.jco.JCO$Exception: (102) JCO_ERROR_COMMUNICATION: JCO.Client not
    Thanks
    susmita

  • Jco: Error Connecting using sapgw04

    Hi,
    I have a problem using Jco to connect to a SAP-System.
    I'm trying to connect to SAP using the following configuartions:
         sysnr:           04
         GWServ:      sapgw00
         GWHost:      XXX.YYY.com
         ASHost:      XXX.YYY.com
    The code to create a repository for this configuration is:
         JCO.addClientPool(poolname, maxpoolsize, "538", "username", "password", "DE",
                   "XXX.YYY.com", "04", "XXX.YYY.com", "sapgw00");
    When I use this pool to get a function I get an Exception:
    com.sap.mw.jco.JCO$Exception: (123) JCO_ERROR_FUNCTION_NOT_FOUND: Server repository could not create function template '[FUNCTIONNAME]'
    caused by: com.sap.mw.jco.JCO$Exception: (102) RFC_ERROR_COMMUNICATION: Connect from SAP gateway to RFC server failed
    Connect_PM 
         GWHOST=XXX.YYY.com , GWSERV=sapgw00, ASHOST=XXX.YYY.com , SYSNR=04
    LOCATION   
         SAP-Gateway on host h33e / sapgw00
    ERROR       partner not reached
         (host XXX.YYY.com , service <b>sapgw04</b>)
    The strange thing is the sapgw04 in the error-message.
    Somehow JCO wants to use sapgw04 to connect to the RFC-Server. Is this an error in the SAP-Configuration or do I have to change the configuration of Jco?
    How can I tell Jco not to use sapgw04 but sapgw00?
    Any help would be appreciated!
    Thanks
    Torsten

    Hi Torsten,
    please check how you log on to your system.  You are giving a system number 04, which corresponds to sapgw04.  I'm not sure why the method needs all the information, seems to be duplicate to me (please comment if I'm wrong); it should be sufficient to use:
    addClientPool(String key,
       int max_connections,
       String client,
       String user,
       String passwd,
       String lang,
       String ashost,
       String sysnr)
    If you don't want to use sapgw04, just specify "00" for the sysnr.
    Hope this helps, harald

  • Error connecting using OCI8

    I am getting an error when attempting to connect to a Oracle 9i r2 database using OCI8. When I connect using the thin driver all works fine. Are different drivers or installation procedures needed to use OCI8? I am working with BLOB's and wanted to use OCI because I understand it is more efficient than the thin driver for this data type.
    The two url's which are used are listed below:
    dbUrl1 "jdbc:oracle:oci8:@svr:1521:orcl"
    Fails with the following error: 500 Internal Server Error : java.lang.NoSuchFieldError: oracle.jdbc.oci8.OCIEnv.envCharSetId
    dbUrl2 "jdbc:oracle:thin:@svr:1521:orcl"
    Works fine.
    Any help is much appreciated.
    Thanks in advance.
    Wayne

    I solved the problem too.Just replace classes12.zip &
    classes12.jar from orahome/jdbc/lib to
    jdevhome/jdbc/lib.
    Oracle version 9i release 2
    JDeveloper 9i release 2there some details on metalink saying you cannot connect to 9.2 with 9.2 client in path. they say you must install 9.0 client and put it in your path and point your project at those libraries.
    I have tried everything and can't get anything to work.
    For awhile I had it so that I could create a connection in jdeveloper, but if my application tried to create its own connection, and not use the predefined one from jdeveloper, I ran into the same error again, even though the same jdbc url connection tested successfully in jdeveloper.
    I have been downloading drivers, modifying jdev.conf, and such for a couple days now, all to try and get an oci connection to work.
    i am using jdev r3 and 9i r2 now, gave up on r2, was hoping it would work in r3.

  • Cannot connect using VPN client

    Hi, I have a problem configuring my CISCO ASA 5515-x for VPN client. I succesfully configure AnyConnect and SSL VPN but when client using VPN Client software, they cannot establish the VPN connection. This is my configuration and attached is the error occured when connecting to the firewall. Can anyone help me solve this problem?
    : Saved
    ASA Version 9.1(1)
    hostname ciscoasa
    domain-name g
    ip local pool vpn_client 192.168.2.200-192.168.2.254 mask 255.255.255.0
    ip local pool vpn_250 192.168.3.1-192.168.3.254 mask 255.255.255.0
    interface GigabitEthernet0/0
    nameif DIGI
    security-level 0
    ip address 210.48.*.* 255.255.255.0
    interface GigabitEthernet0/1
    nameif LAN
    security-level 0
    ip address 192.168.2.5 255.255.255.0
    interface GigabitEthernet0/2
    nameif Pone
    security-level 0
    ip address dhcp setroute
    interface GigabitEthernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/4
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/5
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    management-only
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    ftp mode passive
    clock timezone MYT 8
    dns domain-lookup DIGI
    dns server-group DefaultDNS
    name-server 8.8.8.8
    domain-name g
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network NETWORK_OBJ_113.20.*.*_24
    subnet 113.20.*.* 255.255.255.0
    object network NETWORK_OBJ_210.48.*.*_24
    subnet 210.48.*.* 255.255.255.0
    object network CsHiew
    host 192.168.2.9
    object network ERPServer
    host 192.168.2.2
    object network Giap
    host 192.168.2.126
    object network Jennifer
    host 192.168.2.31
    object network KCTan
    host 192.168.2.130
    object network KCTan-NB
    host 192.168.2.77
    object network MailServer
    host 192.168.2.6
    object network YHKhoo
    host 192.168.2.172
    object network Aslina
    host 192.168.2.59
    object network Law
    host 192.168.2.38
    object network Nurul
    host 192.168.2.127
    object network Laylee
    host 192.168.2.17
    object network Ms_Pan
    host 192.168.2.188
    object network Peck_Ling
    host 192.168.2.248
    object network Pok_Leng
    host 192.168.2.36
    object network UBS
    host 192.168.2.21
    object network Ainie
    host 192.168.2.11
    object network Angie
    host 192.168.2.116
    object network Carol
    host 192.168.2.106
    object network ChunKit
    host 192.168.2.72
    object network KKPoong
    host 192.168.2.121
    object network Ben
    host 192.168.2.147
    object network Eva
    host 192.168.2.37
    object network Jacklyn
    host 192.168.2.135
    object network Siew_Peng
    host 192.168.2.149
    object network Suki
    host 192.168.2.61
    object network Yeow
    host 192.168.2.50
    object network Danny
    host 192.168.2.40
    object network Frankie
    host 192.168.2.101
    object network Jamal
    host 192.168.2.114
    object network OcLim
    host 192.168.2.177
    object network Charles
    host 192.168.2.210
    object network Ho
    host 192.168.2.81
    object network YLChow
    host 192.168.2.68
    object network Low
    host 192.168.2.58
    object network Sfgan
    host 192.168.2.15
    object network Joey
    host 192.168.2.75
    object network Rizal
    host 192.168.2.79
    object network 190
    host 192.168.2.190
    object network 191
    host 192.168.2.191
    object network 192
    host 192.168.2.192
    object network 193
    host 192.168.2.193
    object network 194
    host 192.168.2.194
    object network 199
    host 192.168.2.199
    object network 201
    host 192.168.2.201
    object network 203
    host 192.168.2.203
    object network 204
    host 192.168.2.204
    object network 205
    host 192.168.2.205
    object network CNC214
    host 192.168.2.214
    object network Liyana
    host 192.168.2.16
    object network Aipin
    host 192.168.2.22
    object network Annie
    host 192.168.2.140
    object network Ikah
    host 192.168.2.54
    object network Sue
    host 192.168.2.113
    object network Zaidah
    host 192.168.2.32
    object network CKWong
    host 192.168.2.33
    object network KhooSC
    host 192.168.2.47
    object network Neexon-PC
    host 192.168.2.179
    object network Neexon_NB
    host 192.168.2.102
    object network kc
    host 192.168.2.130
    object network P1
    subnet 192.168.2.0 255.255.255.0
    object network NETWORK_OBJ_192.168.2.0_24
    subnet 192.168.2.0 255.255.255.0
    object network NETWORK_OBJ_192.168.2.192_26
    subnet 192.168.2.192 255.255.255.192
    object network NETWORK_OBJ_192.168.10.192_26
    subnet 192.168.10.192 255.255.255.192
    object network VPN
    subnet 192.68.3.0 255.255.255.0
    object network NETWORK_OBJ_192.168.3.0_24
    subnet 192.168.3.0 255.255.255.0
    object-group network HPTM_DIGI
    network-object object CsHiew
    network-object object ERPServer
    network-object object Giap
    network-object object Jennifer
    network-object object KCTan
    network-object object KCTan-NB
    network-object object MailServer
    network-object object YHKhoo
    object-group network Inventory
    network-object object Aslina
    network-object object Law
    network-object object Nurul
    object-group network Account
    network-object object Laylee
    network-object object Ms_Pan
    network-object object Peck_Ling
    network-object object Pok_Leng
    network-object object UBS
    object-group network HR
    network-object object Ainie
    network-object object Angie
    object-group network Heeroz
    network-object object Carol
    network-object object ChunKit
    network-object object KKPoong
    object-group network Sales
    network-object object Ben
    network-object object Eva
    network-object object Jacklyn
    network-object object Siew_Peng
    network-object object Suki
    network-object object Yeow
    object-group network Production
    network-object object Danny
    network-object object Frankie
    network-object object Jamal
    network-object object OcLim
    object-group network Engineering
    network-object object Charles
    network-object object Ho
    network-object object YLChow
    network-object object Joey
    network-object object Rizal
    object-group network Purchasing
    network-object object Low
    network-object object Sfgan
    object-group network Wireless
    network-object object 190
    network-object object 191
    network-object object 192
    network-object object 193
    network-object object 194
    network-object object 199
    network-object object 201
    network-object object 203
    network-object object 204
    network-object object 205
    object-group network IT
    network-object object CNC214
    network-object object Liyana
    object-group network Skype
    network-object object Aipin
    network-object object Annie
    network-object object Ikah
    network-object object Sue
    network-object object Zaidah
    object-group network HPTM-P1
    network-object object CKWong
    network-object object KhooSC
    network-object object Neexon-PC
    network-object object Neexon_NB
    object-group service DM_INLINE_SERVICE_1
    service-object tcp-udp destination eq www
    service-object tcp destination eq https
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group service DM_INLINE_SERVICE_2
    service-object tcp-udp destination eq www
    service-object tcp destination eq https
    access-list DIGI_access_in extended permit ip any any
    access-list DIGI_access_in extended permit icmp any any echo
    access-list LAN_access_in extended deny object-group DM_INLINE_SERVICE_2 object-group Skype any
    access-list LAN_access_in extended deny object-group DM_INLINE_SERVICE_1 object 205 any
    access-list LAN_access_in extended permit ip any any
    access-list DIGI_cryptomap extended permit ip object VPN 113.20.*.* 255.255.255.0
    access-list Pq_access_in extended permit ip any any
    access-list splittun-vpngroup1 extended permit ip 192.168.2.0 255.255.255.0 192.168.3.0 255.255.255.0
    access-list nonat extended permit ip 192.168.2.0 255.255.255.0 192.168.3.0 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    logging recipient-address aaa@***.com level errors
    mtu DIGI 1500
    mtu LAN 1500
    mtu Pone 1500
    mtu management 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-711(1).bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    nat (DIGI,LAN) source static any interface
    nat (Pone,LAN) source static any interface
    nat (DIGI,DIGI) source static NETWORK_OBJ_210.48.*.*_24 NETWORK_OBJ_210.48.*.*_24 destination static NETWORK_OBJ_113.20.*.*_24 NETWORK_OBJ_113.20.*.*_24 no-proxy-arp route-lookup
    nat (LAN,DIGI) source static NETWORK_OBJ_192.168.2.0_24 NETWORK_OBJ_192.168.2.0_24 destination static NETWORK_OBJ_192.168.2.192_26 NETWORK_OBJ_192.168.2.192_26 no-proxy-arp route-lookup
    nat (LAN,DIGI) source static NETWORK_OBJ_192.168.2.0_24 NETWORK_OBJ_192.168.2.0_24 destination static NETWORK_OBJ_192.168.10.192_26 NETWORK_OBJ_192.168.10.192_26 no-proxy-arp route-lookup
    nat (LAN,any) source static any any destination static VPN VPN
    nat (LAN,DIGI) source static any any destination static NETWORK_OBJ_192.168.3.0_24 NETWORK_OBJ_192.168.3.0_24 no-proxy-arp route-lookup
    nat (LAN,DIGI) source static NETWORK_OBJ_192.168.2.0_24 NETWORK_OBJ_192.168.2.0_24 destination static NETWORK_OBJ_192.168.3.0_24 NETWORK_OBJ_192.168.3.0_24 no-proxy-arp route-lookup
    object network VPN
    nat (any,DIGI) dynamic interface
    nat (LAN,Pone) after-auto source dynamic any interface dns
    nat (LAN,DIGI) after-auto source dynamic any interface dns
    access-group DIGI_access_in in interface DIGI
    access-group LAN_access_in in interface LAN
    access-group Pq_access_in in interface Pone
    route Pone 0.0.0.0 0.0.0.0 10.1.*.* 2
    route DIGI 0.0.0.0 0.0.0.0 210.48..*.* 3
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 192.168.2.0 255.255.255.0 LAN
    http 0.0.0.0 0.0.0.0 DIGI
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto ipsec security-association pmtu-aging infinite
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto dynamic-map DIGI_access_in 20 set ikev1 transform-set ESP-3DES-SHA
    crypto map DIGI_map 65535 ipsec-isakmp dynamic DIGI_access_in
    crypto map DIGI_map interface DIGI
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    fqdn sslvpn.cisco.com
    subject-name CN=sslvpn.cisco.com
    keypair hpmtkeypair
    crl configure
    crypto ca trustpool policy
    crypto ca certificate chain ASDM_TrustPoint0
    certificate ed15c051
        308201ef 30820158 a0030201 020204ed 15c05130 0d06092a 864886f7 0d010105
        0500303c 31193017 06035504 03131073 736c7670 6e2e6369 73636f2e 636f6d31
        1f301d06 092a8648 86f70d01 09021610 73736c76 706e2e63 6973636f 2e636f6d
        301e170d 31333036 32313038 30343438 5a170d32 33303631 39303830 3434385a
        303c3119 30170603 55040313 1073736c 76706e2e 63697363 6f2e636f 6d311f30
        1d06092a 864886f7 0d010902 16107373 6c76706e 2e636973 636f2e63 6f6d3081
        9f300d06 092a8648 86f70d01 01010500 03818d00 30818902 818100a9 7715ca9e
        4d63204e 66e6517b 9a560be8 188603cc 90bb39a7 c61ef0d8 cd74bf19 8ec33146
        5176547f f43615a2 b8917a03 3a5a9dd6 e087a78a 74bf3a8e 6d7cfad2 0678253d
        b03a677a 52e9ebc0 8e044353 e9fe2055 3cafafa3 3ec74ef9 45eaf8d6 8e554879
        db9bf2fb ebcdb5c3 011bf61f 8c139ed1 a00d300a 8fe4784f 173c7702 03010001
        300d0609 2a864886 f70d0101 05050003 81810046 d32b20a6 a1efb0b5 29c7ed00
        11c0ce87 c58228c9 aae96197 eb275f9a f9da57a1 fc895faf 09a24c0c af43772b
        2818ec29 0a56eb33 c0e56696 dd1fa3bb 151ee0e4 18d27366 92177a31 b2f7842b
        4f5145b9 942fbc49 c785f925 3a909c17 2593efcc 2e410b5c d3026fe1 f48d93c1
        744333e2 c377e5d3 62eebb63 abca4109 d57bb0
      quit
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable DIGI client-services port 443
    crypto ikev2 remote-access trustpoint ASDM_TrustPoint0
    crypto ikev1 enable DIGI
    crypto ikev1 policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    track 1 rtr 123 reachability
    telnet 192.168.1.0 255.255.255.0 management
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 DIGI
    ssh timeout 5
    console timeout 0
    vpn-sessiondb max-other-vpn-limit 250
    vpn-sessiondb max-anyconnect-premium-or-essentials-limit 2
    vpn load-balancing
    interface lbpublic DIGI
    interface lbprivate DIGI
    dhcp-client client-id interface Pone
    dhcpd address 192.168.2.10-192.168.2.150 LAN
    dhcpd dns 210.48.*.* 210.48.*.* interface LAN
    dhcpd enable LAN
    dhcpd address 192.168.1.2-192.168.1.254 management
    dhcpd enable management
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    ssl trust-point ASDM_TrustPoint0 DIGI
    webvpn
    enable DIGI
    anyconnect image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
    anyconnect profiles anyhpmt_client_profile disk0:/anyhpmt_client_profile.xml
    anyconnect enable
    tunnel-group-list enable
    tunnel-group-preference group-url
    group-policy sslpolicy internal
    group-policy sslpolicy attributes
    vpn-tunnel-protocol ssl-clientless
    webvpn
      url-list none
    group-policy GroupPolicy_anyhpmt internal
    group-policy GroupPolicy_anyhpmt attributes
    wins-server none
    dns-server value 8.8.8.8
    vpn-tunnel-protocol ikev2 ssl-client ssl-clientless
    default-domain value g
    webvpn
      anyconnect profiles value anyhpmt_client_profile type user
    group-policy vpngroup1 internal
    group-policy vpngroup1 attributes
    dns-server value 8.8.8.8
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value splittun-vpngroup1
    default-domain value g
    address-pools value vpn_250
    group-policy newvpn internal
    group-policy newvpn attributes
    dns-server value 8.8.8.8
    vpn-tunnel-protocol ikev1 l2tp-ipsec
    default-domain value g
    username cshiew password KK1oQOhoxfwWvya4 encrypted
    username cshiew attributes
    webvpn
      anyconnect keep-installer installed
      anyconnect ask none default anyconnect
    username newuser password GJrqM3H2KqQZv/MI encrypted privilege 1
    tunnel-group vpngroup1 type remote-access
    tunnel-group vpngroup1 general-attributes
    address-pool vpn_250
    default-group-policy vpngroup1
    tunnel-group vpngroup1 webvpn-attributes
    group-alias vpngroup1 enable
    tunnel-group vpngroup1 ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group sslhpmt type remote-access
    tunnel-group sslhpmt general-attributes
    default-group-policy sslpolicy
    tunnel-group sslhpmt webvpn-attributes
    group-alias sslhpmt enable
    tunnel-group anyhpmt type remote-access
    tunnel-group anyhpmt general-attributes
    address-pool vpn_client
    default-group-policy GroupPolicy_anyhpmt
    tunnel-group anyhpmt webvpn-attributes
    group-alias anyhpmt enable
    tunnel-group-map default-group vpngroup1
    class-map global-class
    match any
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
    class global-class
      cxsc fail-open
    class class-default
      user-statistics accounting
    policy-map global-policy
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    hpm topN enable
    Cryptochecksum:7a5ee8ff016e63420802423269da864b
    : end

    Hi,
    Safwan Hashan napisano:i dont know which output you referring but this is output from the VPN client.
    We need more information.
    I expect debug output from the ASA.
    To enable debugging and syslog messages, perform the following CLI steps:
    1.
    ASA#configure terminal
    ASA(config)# debug crypto ikev1 127
    ASA(config)# debug crypto ipsec 127
    Enable debuging messages for IKEv1 and IPSec.
    2.
    ASA(config)# logging monitor debug
    Sets syslog messages to be sent to Telnet or SSH sessions.
    Note: You can alternately use the logging buffer debug command to send log messages to a buffer, and then view them later using the show logging command.
    3.
    ASA(config)# terminal monitor
    Sends the syslog messages to a Telnet or SSH session.
    4.
    ASA(config)# logging on
    Enables syslog message generation.
    NOTE: This you have enabled.
    Cleanup CLI
    ASA(config)# no debug crypto ikev1
    ASA(config)# no debug crypto ipsec
    ASA(config)# no logging monitor debug
    ASA(config)# no terminal monitor
    More information: Sensible Debugging and Logging
    I have one suggestion. Change and try.
    group-policy vpngroup1 internal
    group-policy vpngroup1 attributes
    no vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec
    vpn-tunnel-protocol ikev1
    Best regards,
    MB
    Please rate all helpful posts. Thx

  • How to create multi connections using JCO in different application servers

    Hi all,
    I want to connect to sap using jco from different servers at the same time.
    There are 3 Jave application servers now. But I can only connect the sap servers using ONE server ( random ) at same time. It means when one server connect to sap , the other 2 servers CANNOT connect to sap.
    Anyone konw what wrong?
    Thanks in advance.
    Ned

    ......

  • -t2cGetCharSet error when using thick client with 1.0.0.15.57

    I think I have found a bug in 1.0.0.15 related to accessing a database using the thick client. I have tested this with 1.0.0.14 release of SQLDeveloper and that version DOES work OK.
    Simply put, I try connecting to a database using the 10g Client on Windows XP and I get "Failure: -t2cGetCharSet" error when running 1.0.0.15.57. I must use 10g thick client so that I can use encyption between the client and the database. 9i thick client doesn't work between Windows and Linux when using encryption. Also, instant client isn't an option; it doesn't support Advanced Security Option (encryption).
    I DID test without encryption enabled to eliminate that as a possible cause and the results were the same.
    If need be, I could back down to 1.0.0.14, but I would prefer not to.

    See:
    Re: TNS Connection Issues
    Raptor does not find My tnsnames
    If don't to solve your problem, let us to know.

  • Error while using oracle client

    I agree to all what you have written .But as you said we often have client server co-existing on the same hardware platform and also i have additionally installed an oracle client .I agree that the TCP connections is via Net8 (Sql*Net) /ODBC etc. But my question is i want to connect to both my XE server and my other database servers (Production) using a single client (since m having 2 clients , one that came along with the XE database and the other which i have explicitly installed) ,I get the following error
    SP2-0667: Message file sp1<lang>.msb not found
    SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory .Despite setting the path and ORACLE_HOME environment variables , the error persists.

    Windows host? Which version, xp? Which "2nd client" version, instant client?
    Double check the environment variables and %PATH%. Try changing directory to the particular client .../bin directory and run sqlplus from there, the client program you want may not be the client program you're getting.
    %ORACLE_HOME% also needs to be pre-pended to %PATH%, with that second client it might be helpful to set up a .bat file with proper settings. Saves having to retype stuff which will also be typo-prone, i.e. in ct2.bat:
    set ORACLE_HOME=C:\ora\<folder\path>
    set PATH=%ORACLE_HOME%;%PATH%

  • Error after using Test Client (HomeFactory Problem)

    All,
    I am a newbie with websphere and I try to develop a sample EJB app.
    My attempts to test my method of my stateless Session bean were not successful.
    I got the following messaage:
    [18.07.05 00:02:51:752 CEST] 31c7edd5 WebGroup I SRVE0180I: [bpesoapclient] [bpesoapclient] [Servlet.LOG]: InvokerServlet: init
    [18.07.05 00:02:52:003 CEST] 31c7edd5 ApplicationMg A WSVR0221I: Die Anwendung wurde gestartet: BPERemoteDeploy
    [18.07.05 00:02:52:023 CEST] 31c7edd5 ApplicationMg A WSVR0200I: Die Anwendung wird gestartet: query
    [18.07.05 00:02:52:083 CEST] 31c7edd5 EJBContainerI I WSVR0207I: Der Start des EJB-JAR wird vorbereitet: querybean.jar
    [18.07.05 00:02:52:333 CEST] 31c7edd5 EJBContainerI I WSVR0037I: EJB-JAR-Datei wird gestartet: querybean.jar
    [18.07.05 00:02:52:524 CEST] 31c7edd5 ApplicationMg A WSVR0221I: Die Anwendung wurde gestartet: query
    [18.07.05 00:02:52:534 CEST] 31c7edd5 ApplicationMg A WSVR0200I: Die Anwendung wird gestartet: TestDmProjectEAR
    [18.07.05 00:02:52:644 CEST] 31c7edd5 EJBContainerI I WSVR0207I: Der Start des EJB-JAR wird vorbereitet: TestDmProject.jar
    [18.07.05 00:02:57:671 CEST] 31c7edd5 EJBContainerI I WSVR0037I: EJB-JAR-Datei wird gestartet: TestDmProject.jar
    [18.07.05 00:03:01:266 CEST] 31c7edd5 ApplicationMg A WSVR0221I: Die Anwendung wurde gestartet: TestDmProjectEAR
    [18.07.05 00:03:01:496 CEST] 31c7edd5 StaffServiceI I STFF0032I: Der Staff Service wurde ordnungsgem&#33913; gestartet.
    [18.07.05 00:03:02:899 CEST] 31c7edd5 HttpTransport A SRVE0171I: Der Transport http ist empfangsbereit an Port 9.080.
    [18.07.05 00:03:06:003 CEST] 31c7edd5 HttpTransport A SRVE0171I: Der Transport https ist empfangsbereit an Port 9.443.
    [18.07.05 00:03:06:043 CEST] 31c7edd5 SchedulerServ I SCHD0031I: Der Scheduler Service wird gestartet.
    [18.07.05 00:03:12:733 CEST] 31c7edd5 SchedulerServ I SCHD0032I: Die Scheduler-Instanz BPEScheduler wird gestartet.
    [18.07.05 00:03:17:309 CEST] 31c7edd5 SchedulerDaem I SCHD0038I: Der Scheduler-D&#33282;on f&#12539; die Instanz BPEScheduler wurde gestartet.
    [18.07.05 00:03:17:500 CEST] 31c7edd5 SchedulerServ I SCHD0033I: Die Scheduler-Instanz BPEScheduler wurde gestartet.
    [18.07.05 00:03:17:520 CEST] 31c7edd5 SchedulerServ I SCHD0001I: Der Scheduler Service wurde gestartet.
    [18.07.05 00:03:19:012 CEST] 31c7edd5 RMIConnectorC A ADMC0026I: Der RMI-Connector ist an Port 2809 verf&#12539;bar.
    [18.07.05 00:03:19:542 CEST] 31c7edd5 WsServer A WSVR0001I: Der Server server1 ist f&#12539; e-business bereit.
    [18.07.05 00:03:27:013 CEST] 46da2dd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: jndiLookupServlet: init
    [18.07.05 00:03:29:517 CEST] 46da2dd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: /index.jsp: init
    [18.07.05 00:03:29:827 CEST] 46da2dd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: /html/ejbPage/ejbFrame.jsp: init
    [18.07.05 00:03:29:837 CEST] 4d94edd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: /html/toolbar/global_nav.jsp: init
    [18.07.05 00:03:30:458 CEST] 46da2dd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: /html/ejbPage/referencePage.jsp: init
    [18.07.05 00:03:30:468 CEST] 4d94edd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: /html/ejbPage/parameterPage.jsp: init
    [18.07.05 00:03:30:939 CEST] 46da2dd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: /html/toolbar/toolbar.jsp: init
    [18.07.05 00:03:30:959 CEST] 4d94edd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: /html/ejbPage/reference.jsp: init
    [18.07.05 00:03:31:520 CEST] 46da2dd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: /html/ejbPage/parameter.jsp: init
    [18.07.05 00:03:36:457 CEST] 4d94edd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: treeExpansionServlet: init
    [18.07.05 00:03:39:932 CEST] 4d94edd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: selectMemberServlet: init
    [18.07.05 00:03:42:145 CEST] 46da2dd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: invokeServlet: init
    [18.07.05 00:03:44:388 CEST] 4d94edd7 WebGroup I SRVE0180I: [IBM Universal Test Client] [UTC] [Servlet.LOG]: addObjectServlet: init
    [18.07.05 00:03:55:504 CEST] 46da2dd7 SystemOut O class=class com.mbusa.TestDm._EJSRemoteCMPStatusHome_ce727769_Stub
    [18.07.05 00:03:55:504 CEST] 46da2dd7 SystemOut O ejbRef ejb/com/mbusa/TestDm/StatusHome is a remote reference.
    [18.07.05 00:03:56:105 CEST] 46da2dd7 ExceptionUtil E CNTR0019E: Bei der Verarbeitung der Methode "setStatus" ist eine nicht auf die Anwendung zur&#12539;kzuf&#12539;rende Ausnahme eingetreten. Ausnahmedaten: com.ibm.ejs.container.CreateFailureException: ; nested exception is:
         java.lang.reflect.InvocationTargetException
         at com.ibm.ejs.container.StatelessBeanO.<init>(StatelessBeanO.java:151)
         at com.ibm.ejs.container.CMStatelessBeanO.<init>(CMStatelessBeanO.java:53)
         at com.ibm.ejs.container.CMStatelessBeanOFactory.create(CMStatelessBeanOFactory.java:40)
         at com.ibm.ejs.container.EJSHome.createBeanO(EJSHome.java:668)
         at com.ibm.ejs.container.EJSHome.createBeanO(EJSHome.java:755)
         at com.ibm.ejs.container.activator.UncachedActivationStrategy.atActivate(UncachedActivationStrategy.java:78)
         at com.ibm.ejs.container.activator.Activator.activateBean(Activator.java:516)
         at com.ibm.ejs.container.EJSContainer.preInvoke_internal(EJSContainer.java:2762)
         at com.ibm.ejs.container.EJSContainer.preInvoke(EJSContainer.java:2487)
         at com.ibm.ejs.container.EJSContainer.preInvoke(EJSContainer.java:2472)
         at com.mbusa.TestDm.EJSRemoteStatelessTestDmSession_3f7076e7.setStatus(EJSRemoteStatelessTestDmSession_3f7076e7.java:34)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)
         at java.lang.reflect.Method.invoke(Method.java:391)
         at com.ibm.rmi.util.ProxyUtil$4.run(ProxyUtil.java:726)
         at java.security.AccessController.doPrivileged1(Native Method)
         at java.security.AccessController.doPrivileged(AccessController.java:351)
         at com.ibm.rmi.util.ProxyUtil.invokeWithClassLoaders(ProxyUtil.java:724)
         at com.ibm.CORBA.iiop.ClientDelegate.invoke(ClientDelegate.java:1121)
         at $Proxy5.setStatus(Unknown Source)
         at com.mbusa.TestDm._TestDmSession_Stub.setStatus(_TestDmSession_Stub.java:266)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)
         at java.lang.reflect.Method.invoke(Method.java:391)
         at com.ibm.etools.utc.model.ReflectionMethodModel.invoke(ReflectionMethodModel.java:68)
         at com.ibm.etools.utc.servlet.InvokeServlet.invoke(InvokeServlet.java:110)
         at com.ibm.etools.utc.servlet.InvokeServlet.doPost(InvokeServlet.java:366)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
         at com.ibm.ws.webcontainer.servlet.StrictServletInstance.doService(StrictServletInstance.java:110)
         at com.ibm.ws.webcontainer.servlet.StrictLifecycleServlet._service(StrictLifecycleServlet.java:174)
         at com.ibm.ws.webcontainer.servlet.IdleServletState.service(StrictLifecycleServlet.java:313)
         at com.ibm.ws.webcontainer.servlet.StrictLifecycleServlet.service(StrictLifecycleServlet.java:116)
         at com.ibm.ws.webcontainer.servlet.ServletInstance.service(ServletInstance.java:283)
         at com.ibm.ws.webcontainer.servlet.ValidServletReferenceState.dispatch(ValidServletReferenceState.java:42)
         at com.ibm.ws.webcontainer.servlet.ServletInstanceReference.dispatch(ServletInstanceReference.java:40)
         at com.ibm.ws.webcontainer.webapp.WebAppRequestDispatcher.handleWebAppDispatch(WebAppRequestDispatcher.java:1019)
         at com.ibm.ws.webcontainer.webapp.WebAppRequestDispatcher.dispatch(WebAppRequestDispatcher.java:592)
         at com.ibm.ws.webcontainer.webapp.WebAppRequestDispatcher.forward(WebAppRequestDispatcher.java:204)
         at com.ibm.ws.webcontainer.srt.WebAppInvoker.doForward(WebAppInvoker.java:125)
         at com.ibm.ws.webcontainer.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:286)
         at com.ibm.ws.webcontainer.cache.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:71)
         at com.ibm.ws.webcontainer.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:182)
         at com.ibm.ws.webcontainer.oselistener.OSEListenerDispatcher.service(OSEListener.java:334)
         at com.ibm.ws.webcontainer.http.HttpConnection.handleRequest(HttpConnection.java:56)
         at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:615)
         at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:439)
         at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:912)
    Caused by: java.lang.reflect.InvocationTargetException
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)
         at java.lang.reflect.Method.invoke(Method.java:391)
         at com.ibm.ejs.container.StatelessBeanO.<init>(StatelessBeanO.java:144)
         ... 51 more
    Caused by: java.lang.ClassCastException: com.mbusa.TestDm._EJSRemoteCMPStatusHome_ce727769_Stub
         at com.mbusa.TestDm.TestDmSessionBean.getHomes(TestDmSessionBean.java:71)
         at com.mbusa.TestDm.TestDmSessionBean.ejbCreate(TestDmSessionBean.java:39)
         ... 57 more
    The code looks as follows:
    package com.mbusa.vrm;
    * Bean implementation class for Enterprise Bean: VrmSession
    import javax.ejb.*;
    import javax.naming.*;
    import java.rmi.RemoteException;
    import java.sql.Date;
    import com.test.dm.homeFactory.*;
    public class TestDmSessionBean implements javax.ejb.SessionBean {
         private javax.ejb.SessionContext mySessionCtx;
         protected StatusLocalHome statusHome = null;
              * getSessionContext
              public javax.ejb.SessionContext getSessionContext() {
                   return mySessionCtx;
              * setSessionContext
              public void setSessionContext(javax.ejb.SessionContext ctx) {
                   mySessionCtx = ctx;
              * ejbCreate
              public void ejbCreate() throws javax.ejb.CreateException {
                   getHomes();
              * ejbActivate
              public void ejbActivate() {
                   getHomes();
              * ejbPassivate
              public void ejbPassivate() {
                   statusHome = null;
              * ejbRemove
              public void ejbRemove() {
              protected void getHomes() {
                   try {
                        statusHome = (StatusLocalHome) HomeFactory.singleton().getHome("ejb/com/test/dm/StatusHome");
                   } catch (NamingException ex) {
                        ex.printStackTrace();
                        throw new EJBException("Error looking up homes: "+ex.getMessage());
         public void setStatus(int statusId, String description) throws FinderException, CreateException {
              try {
                   StatusLocal status = statusHome.create(statusId);
                   status.setDescription(description);
              } catch (EJBException ex) {
                   throw new EJBException("Status setStatus failed for "+ statusId);
         public String getStatusDEscription(int statusId) throws FinderException, CreateException {
              try {
                   StatusLocal status = statusHome.findByPrimaryKey(new StatusKey(statusId));
                   return status.getDescription();
              } catch (EJBException ex) {
                   throw new EJBException("Status setStatus failed for "+ statusId);
    I appreciate any help!!!
    Cheers
    Greg

    Hi,
    I am using the Universal test client to test my methods.
    Thank you very much for your help!!!
    Greg

  • Error connecting JCO.Client

    Hello!
    I've got a little problem with Adaptive RFC calls: After exactly 10 times executing my call I always get the following Exception:
    com.sap.tc.webdynpro.modelimpl.dynamicrfc.WDDynamicRFCExecuteException: Error connecting using JCO.Client: null
    Has anybody by any chance got an idea why or how to handle this problem?
    Thank you very much in advance!
    Best Regards

    Hi
      Well its a simple problem of connection pooling. In your JCO connection settings change the maximum connections to 200. It will work.
    well what i would advice is that After you execute the Model please release the connection. The reason you are getting this JCO Client null is because the  connection is not getting released.
    When you say the following code
    wdContext.current<BAPI_INPUT>.modelObject().execute();
    //Get the reference to the model and release the connection
    If your Model name is say "MO_Mymodel"
    then
    MO_Mymodel model = (MO_Mymodel) WDModelFactory.getModelInstance(MO_Mymodel.class);
    model.disconnectIfAlive();
    This should release your connections. Also ensure you release the connections even if there is a exception :).
    Hope that helps you.
    regards
    ravi

Maybe you are looking for