Error message: itunes library .itl cannot be read because  it was created by a newer version.  I downloaded and in stalled the latest version of itunes and it did not help.  What now?

error message: itunes library .itl cannot be read because  it was created by a newer version.  I downloaded and in stalled the latest version of itunes and it did not help.  What now?

Perhaps check to see if you're accidentally running two different versions of iTunes. There's some information on troubleshooting that in the Opening iTunes section of the following document:
Troubleshooting iTunes installation on Mac OS X

Similar Messages

Maybe you are looking for