Help with expiring client scope

Hi,
I have a website that uses the client scope for its shopping cart. Im having a problem with expiring the client scope. What happens is when I make changes to the site that effect cookies, people who havce old cookies or client on there system get an error message and I for the life of me cannont figuer out a way to have the scope say expire when they leave the page or close the browser.
THanks for any help.
Mike.

Well, the web being stateless, it's not easy to auto-logout if a person just 'leaves' your website - the server just doesn't know they've gone.  If they actually 'log out'  you 'could' clear all their cookies using the cookie scope, but other than that maybe set a short expire on the client scope so that if a person does leave your site it won't be long before they time out and have to get new client vars next time.
By the way, the client scope is not encouraged by Adobe (or so I seem to remember in the past).  Is there any reason you need to use it?  Would the session scope be more suited?  I KNOW it's faster, but not persistent unless you serialise the session scope via wddx (which you can do - emulating client scope when needed).

Similar Messages

  • Help with expiring Default certificate

    I need some help, I'm not sure how to go about reactivating or extending this certificate... I am getting this message:
    +The following certificate is about to expire on your server, (servername):+
    + +
    + Name: Default+
    + Expiration Date: 2009-12-16 18:34:33 -0500+
    My question is, do I delete this Default cert and make a new one called the same name, or...?
    Thanks in advance.
    Message was edited by: ekal

    Hi,
    You can’t “edit” the existing cert anymore.
    You have to delete your expired (or soon to expire) cert if the new cert will be for the same host name, which is likely else you’ll get an error about it already existing in the chain. Just go to the certificate window, press the + and select “create a certificate identity”. Use the fully qualified domain name that matches the service or purpose of the cert and host. This will create a new self signed cert that is good for one year by default. If you want to create a cert with a different expiration date (more than 365 days), you must check the box to override defaults or something alone those lines when you’re creating the cert. That part is pretty self explanatory.
    I’m not sure if clients will have to “trust” the “new” self signed cert each time you do this. I don’t have time to test that as I was just looking at this during a meeting :P Not sure if you have to “repoint” your services to the new cert either but that’s fairly trivial even if you must do so. I assume you don’t have to though as long as the cert name remained the same and continues to match.

  • Help with Company/Client organization program!

    Hey guys. I've been working on this project for a while, but since my java skills are not so great, i've been having some difficulty. I was hoping someone could look at the code I had and give me some advice, help and directions.
    In the program, the user should be able to create Companies and Clients, as well as their attributes, and save them to two separate Random Access Files ("companies.dat" and "contacts.dat"). The user should then also be able to read back, edit and delete a company or client if they so wish. Each company or client is assigned a Level Of Interest, which I want to take and put into an array, which can later be sorted and viewed in order of increasing interest. I'm not entirely sure of how to go about achieving this, however.
    NOTE: The IBIO class was put together by one of my professors to help make i/o easier.
    I am also unsure of how to go about deleting, searching and editing the data that is written to the RAF. I hope someone can give me some pointers here. I'll post my code, take a look.

    import java.io.*;
    public class CreateCompany {
         private final int MAX = 20;
         private final int RECORD_LENGTH = 230;
         private final String FILE_NAME = "companies.dat";
         private Company[] myCompanies = new Company[MAX];
         public static void initOrganizer(){
              new CreateCompany();
         public CreateCompany(){
              initArray();
              inputCompanies();
              saveCompany();
              initArray();
              readCompanies();
              displayCompanies();
         public void initArray() {
              for (int i = 0; i < MAX; i++) {
                   myCompanies[i] = new Company(0, "", "", "", "", "", "", "", "", 0, 0, 0);
         public void inputCompanies() {
              int rec = 0;
              for (;;) {
                   int id = IBIO.inputInt("ID: ");
                   if (id == 0) {
                        System.out.println("Bye.");
                   if (id != 0){
                   System.out.println("If you wish to exit at any point, enter '0'");
                   System.out.println("");
                   String CompanyName = IBIO.input("Company Name: ");
                   String Adress = IBIO.input("Adress: ");
                   String Country = IBIO.input("Country: ");
                   String State = IBIO.input("State: ");
                   String City = IBIO.input("City: ");
                   String PostalCode = IBIO.input("Postal Code: ");
                   String WebsiteURL = IBIO.input("Website URL: ");
                   String CompanyStatus = IBIO.input("Company Status: ");
                   String LevelOfInterest = IBIO.input("What is the level of interest in this company: ");
                   String DateOfCreation = IBIO.input("When was this Company created: ");
                   String RenewalDate = IBIO.input("When should the contract with this company be renewed: ");
                   myCompanies[rec] = new Company(0, CompanyName, Adress, Country, State, City, PostalCode, WebsiteURL, CompanyStatus, 0, 0, 0);
                   rec++;
         public void saveCompany() {
              try {
                   RandomAccessFile rf = new RandomAccessFile(FILE_NAME, "rw");
                   for (int i = 0; i < MAX; i++) {
                        String name = myCompanies.getCompanyName();
                        if (name.length() > 40)
                             name = name.substring(0, 40);
                        long pos = i * RECORD_LENGTH;
                        rf.seek(pos);
                        rf.writeInt(myCompanies[i].getIDKey());
                        rf.writeUTF(name);
                        rf.writeUTF(myCompanies[i].getAdress());
                        rf.writeUTF(myCompanies[i].getCountry());
                        rf.writeUTF(myCompanies[i].getState());
                        rf.writeUTF(myCompanies[i].getCity());
                        rf.writeUTF(myCompanies[i].getPostalCode());
                        rf.writeUTF(myCompanies[i].getWebsiteURL());
                        rf.writeUTF(myCompanies[i].getCompanyStatus());
                        rf.writeInt(myCompanies[i].getLevelOfInterest());
                        rf.writeInt(myCompanies[i].getDateOfCreation());
                        rf.writeInt(myCompanies[i].getRenewalDate());
                   rf.close();
              } catch (IOException ex) {
                   System.out.println(ex.toString());
         public void readCompanies() {
              try {
                   RandomAccessFile rf = new RandomAccessFile(FILE_NAME, "rw");
                   for (int i = 0; i < MAX; i++) {
                        rf.seek(i * RECORD_LENGTH);
                        int IDKey = rf.readInt();
                        String CompanyName = rf.readUTF();
                        String Adress = rf.readUTF();
                        String Country = rf.readUTF();
                        String State = rf.readUTF();
                        String City = rf.readUTF();
                        String PostalCode = rf.readUTF();
                        String WebsiteURL = rf.readUTF();
                        String CompanyStatus = rf.readUTF();
                        int LevelOfInterest = rf.readInt();
                        int DateOfCreation = rf.readInt();
                        int RenewalDate = rf.readInt();
                        myCompanies[i] = new Company(IDKey, CompanyName, Adress, Country, State, City, PostalCode, WebsiteURL, CompanyStatus, 0, 0, 0);
                   rf.close();
              } catch (IOException ex) {
                   System.out.println(ex.toString());
         public void displayCompanies() {
              for (int i = 0; i < MAX; i++) {
                   if (myCompanies[i].getIDKey() != 0)
                        System.out.println(myCompanies[i]);

  • Help With EJB Client

    I have successfully gotten my client to run when I use the appclient with the reference implementation. When I try to run my simple client outside of appclient I get the following error.
    Exception: javax.naming.NameNotFoundException [Root exception is org.omg.CosNaming.NamingContextPackage.NotFound: I
    DL:omg.org/CosNaming/NamingContext/NotFound:1.0]
    I have my client.jar which is returned from the deploy tool, I have the j2ee.jar in my classpath, and I have my jndi name set up as ejb/Hello in the server. My code to access this is such:
    public static void main(String[] args)
    try
    System.out.println("Adding properties");
    Properties env = new Properties();
    env.put(Context.INITIAL_CONTEXT_FACTORY, "com.sun.jndi.cosnaming.CNCtxFactory");
    env.put(Context.PROVIDER_URL, "iiop://MyHost:3700");
    Context initial = new InitialContext(env);
    System.out.println("Got initial context!");
    Object o = initial.lookup("java:comp/env/ejb/Hello");
    System.out.println("got object from lookup");
    HelloHome home = (HelloHome)PortableRemoteObject.narrow(o, com.tosht.ejb.HelloHome.class);
    System.out.println("got home object back and did remote narrow cast");
    Hello h = home.create();
    System.out.println("got component interface");
    System.out.println(h.sayHello());
    System.out.println("called business method on component interface");
    catch(Exception ex)
    System.out.println("Exception: " + ex.toString());
    I am sure this is a jndi issue, but in the deploy tool my applications jndi name for my component is ejb/Hello just as it is in code?
    Any help would be greatly appreciated!!!!!

    Hi Tim,
    Couple things I can think of. 1) Are you sure that the ejb application deployed correctly? ejb/Hello does look like the right global JNDI name given the sun-ejb-jar.xml, so one explanation is that the ejb is not found because it wasn't deployed at all or wasn't deployed successfully. 2) It's worth double-checking that you have the correct client code compiled and found at runtime. Is it possible there is still the old version of the client main class that is looking up java:comp/env/ejb/Hello?
    One final suggestion is to print the exception.printStackTrace() rather than exception.toString(). There is often very valuable information about the exception that is not printed out as part of toString().
    --ken                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

  • Help with java client

    Hi all.
    I just can't seem to get it right.I have a web service running and I generate a WSDL file.I can't seem to get it right to write a simple java client to read from it.
    Please help anyone

    http://196.36.57.202:1972/csp/samples/SOAP.Demo.cls?wsdl is wher my wsdl file is.
    This is what i have
    import java.io.*;
    import java.util.*;
    import java.net.*;
    import org.w3c.dom.*;
    import org.apache.soap.util.xml.*;
    import org.apache.soap.*;
    import org.apache.soap.encoding.*;
    import org.apache.soap.encoding.soapenc.*;
    import org.apache.soap.rpc.*;
    import org.apache.soap.transport.http.SOAPHTTPConnection;
    public class testSoap
    public static void main(String[] args) throws Exception
    URL url = new URL ("http://196.36.57.202:1972/csp/samples/SOAP.Demo.cls");
    SOAPMappingRegistry smr = new SOAPMappingRegistry ();
    StringDeserializer sd = new StringDeserializer ();
    smr.mapTypes (Constants.NS_URI_SOAP_ENC, new QName ("", "Result"), null, null, sd);
    // create the transport and set parameters
    SOAPHTTPConnection st = new SOAPHTTPConnection();
    // build the call.
    Call call = new Call ();
    call.setSOAPTransport(st);
    call.setSOAPMappingRegistry (smr);
    call.setTargetObjectURI ("http://tempuri.org/message/");
    call.setMethodName("FindPereson");
    call.setEncodingStyleURI ("http://schemas.xmlsoap.org/soap/encoding/");
    //Vector params = new Vector();
    //params.addElement(new Parameter("NumberOne", Double.class, "10", null));
    //params.addElement(new Parameter("NumberTwo", Double.class, "25", null));
    //call.setParams(params);
    Response resp = null;
    try
    resp = call.invoke (url, "http://196.36.57.202:1972/csp/samples/SOAP.Demo.cls");
    catch (SOAPException e)
    System.err.println("Caught SOAPException (" + e.getFaultCode () + "): " + e.getMessage ());
    return;
    // check response
    if (resp != null && !resp.generatedFault())
    Parameter ret = resp.getReturnValue();
    Object value = ret.getValue();
    System.out.println ("Answer--> " + value);
    else
    Fault fault = resp.getFault ();
    System.err.println ("Generated fault: ");
    System.out.println (" Fault Code = " + fault.getFaultCode());
    System.out.println (" Fault String = " + fault.getFaultString());
    I get a document root element missing

  • Help with sql client.

    I finished my application in visual studio 2013, i used my sql database, i shared the application in the network and i need users to use in different machines from one computer, when i try running it i get this error:
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    ************** Exception Text **************
    System.Data.SqlClient.SqlException (0x80131904): The file "\\RYZA-PC\Debug\Database\LMS-Db.mdf" is on a network path that is not supported for database files.
    An attempt to attach an auto-named database for file \\RYZA-PC\Debug\Database\LMS-Db.mdf failed. A database with the same name exists, or specified file cannot be opened, or it is located on UNC share.
       at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection)
       at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection)
       at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection)
       at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
       at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
       at System.Data.SqlClient.SqlConnection.TryOpenInner(TaskCompletionSource`1 retry)
       at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource`1 retry)
       at System.Data.SqlClient.SqlConnection.Open()
       at System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior)
       at System.Data.Common.DbDataAdapter.Fill(DataTable[] dataTables, Int32 startRecord, Int32 maxRecords, IDbCommand command, CommandBehavior behavior)
       at System.Data.Common.DbDataAdapter.Fill(DataTable dataTable)
       at New_Dawn._LMS_DbDataSetTableAdapters.StudentsBooksBorrowHistoryTableAdapter.Fill(StudentsBooksBorrowHistoryDataTable dataTable) in C:\Users\Ryza\Dropbox\New Dawn\New Dawn\Database\_LMS_DbDataSet.Designer.vb:line 12788
       at New_Dawn.StudentsIssueForm.StudentsIssueForm_Load(Object sender, EventArgs e) in C:\Users\Ryza\Dropbox\New Dawn\New Dawn\GUI\Circulation\Students\StudentsIssueForm.vb:line 22
       at System.Windows.Forms.Form.OnLoad(EventArgs e)
       at System.Windows.Forms.Form.OnCreateControl()
       at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
       at System.Windows.Forms.Control.CreateControl()
       at System.Windows.Forms.Control.WmShowWindow(Message& m)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
       at System.Windows.Forms.ContainerControl.WndProc(Message& m)
       at System.Windows.Forms.Form.WmShowWindow(Message& m)
       at System.Windows.Forms.Form.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    ClientConnectionId:06665186-49a7-4ca2-8dbb-240e2dc66013
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18444 built by: FX451RTMGDR
        CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    New Dawn
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.0.0
        CodeBase: file://RYZA-PC/Debug/New%20Dawn.exe
    Microsoft.VisualBasic
        Assembly Version: 10.0.0.0
        Win32 Version: 11.0.50938.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    System
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    System.Core
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    System.Windows.Forms
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    System.Drawing
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    System.Configuration
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    System.Xml
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
    System.Runtime.Remoting
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    System.Data
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
    System.Data.DataSetExtensions
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Data.DataSetExtensions/v4.0_4.0.0.0__b77a5c561934e089/System.Data.DataSetExtensions.dll
    System.Numerics
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
    System.Transactions
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
    System.EnterpriseServices
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
    Accessibility
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    For example:
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    Please help. RYZA-PC is the main computer. the application is running.

     i need users to use in different machines from one computer, when i try running it i get this error:
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    ************** Exception Text **************
    System.Data.SqlClient.SqlException (0x80131904): The file "\\RYZA-PC\Debug\Database\LMS-Db.mdf"
    is on a network path that is not supported for database files.
    As the error message already says, hosting a database file on a NAS / network share is not supported; you can't get this scenario working.
    Why don't you locate the database on a local drive, attach it to SQL Server  and allow remote access to SQL Server for the users instead?
    Olaf Helper
    [ Blog] [ Xing] [ MVP]

  • Need help with server / client data

    i have a java server that sends strings to a client
    when i use telnet it works fine
    but with a java client it only recieves one line and then disconects
    any ideas?

    post the client and the server code plz

  • (beginner) Need help with a client [Beginner]

    Hi, i'm danny and i'm following tutorials and lessons, and i created my own server and i tried to make my own webclient. My Teacher send me a webclient and he said that i only have to change the ip adress into mines (runescapeworld143.zapto.org) and compile it. The whole problem is now my teacher is on holiday and i called him if he would help me he said that i must ask it to the forums of oracle, so here is my question.
    Ok the source is here if you wanna download it [http://updatedannyskape.webs.com/client.jar.src.zip]
    My teacher say's that the current ip = 188.165.201.65:port43594
    and you have to change it in you're ip adress (runescapeworld143.zapto.org)
    but the problem is now i searched the whole document for 188.165.201.65 but i can't find it, can somebody help me out where i can find this?
    I also tried to compile the source but there are over the 100 errors
    Maybe this is because i created my own compiler ?
    I don't know but here is the compiler code
    @echo off
    cd .
    "C:\Program Files\Java\jdk1.6.0_20\bin\javac.exe" -sourcepath scr/*.java
    pause[Compiler error picture|http://updatedannyskape.webs.com/error.png]
    I hope you are able to help me, Already thanks !
    Edited by: Codenowy on Aug 18, 2010 1:21 PM
    Edited by: Codenowy on Aug 18, 2010 1:22 PM

    Open your file in QuickTime Player then press command & J keys to access the Properties window.
    Click on *Video Track* then *Other Settings*.
    Actvate the checkbox next to *Cache (hint)*.

  • Please need help with OWB client

    Hi All
    I have a problem where i can get into the OWB client but i cannot use the deployment manager, when i click on the deployment manager i get a blank pop up window, so now i want to uninstall and reinstall the OWB Client. I have a universal installer do i have to go through the universal installer to uninstall the OWB Client and reinstall it or is there any other way? It would be of great help if any one of you can post the procedure and the steps to follow.
    Thanks

    Which platform and OWB version is it? Can anyone else open the deployment manager for this repository on their systems?
    To reinstall you have to uninstall using the Oracle Universal Installer, or just install another image in a different home.
    Cheers
    David

  • Need help with HTTPS Client/Server

    Hi i really dont know much about this topic and i was wondering if any 1 knows where to find a good example program to set up a
    HTTPS Server/Client or at least how to implemnt a HTTPS Client.
    thanks in advance

    URL.openConnection works fine as a client. You don't have to do anything other than specify the protocol as https.
    I don't know what you are looking for in terms of server. Are you trying to write your own server? Which part do you not know? The HTTP part or the S part?

  • Need help in configuring Client to Site IPSec VPN with Hairpinning on Cisco ASA5510 8.2(1)

    Need urgent help in configuring Client to Site IPSec VPN with Hairpinning on Cisco ASA5510 - 8.2(1).
    The following is the Layout:
    There are two Leased Lines for Internet access - 1.1.1.1 & 2.2.2.2, the latter being the Standard Default route, the former one is for backup.
    I have been able to configure  Client to Site IPSec VPN
    1) With access from Outside to only the Internal Network (172.16.0.0/24) behind the asa
    2) With Split tunnel with simultaneous assess to internal LAN and Outside Internet.
    But I have not been able to make tradiotional Hairpinng model work in this scenario.
    I followed every possible sugestions made in this regard in many Discussion Topics but still no luck. Can someone please help me out here???
    Following is the Running-Conf with Normal Client to Site IPSec VPN configured with No internat Access:
    LIMITATION: Can't Boot into any other ios image for some unavoidable reason, must use 8.2(1)
    running-conf  --- Working  normal Client to Site VPN without internet access/split tunnel
    ASA Version 8.2(1)
    hostname ciscoasa
    domain-name cisco.campus.com
    enable password xxxxxxxxxxxxxx encrypted
    passwd xxxxxxxxxxxxxx encrypted
    names
    interface GigabitEthernet0/0
    nameif internet1-outside
    security-level 0
    ip address 1.1.1.1 255.255.255.240
    interface GigabitEthernet0/1
    nameif internet2-outside
    security-level 0
    ip address 2.2.2.2 255.255.255.224
    interface GigabitEthernet0/2
    nameif dmz-interface
    security-level 0
    ip address 10.0.1.1 255.255.255.0
    interface GigabitEthernet0/3
    nameif campus-lan
    security-level 0
    ip address 172.16.0.1 255.255.0.0
    interface Management0/0
    nameif CSC-MGMT
    security-level 100
    ip address 10.0.0.4 255.255.255.0
    boot system disk0:/asa821-k8.bin
    boot system disk0:/asa843-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name cisco.campus.com
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group network cmps-lan
    object-group network csc-ip
    object-group network www-inside
    object-group network www-outside
    object-group service tcp-80
    object-group service udp-53
    object-group service https
    object-group service pop3
    object-group service smtp
    object-group service tcp80
    object-group service http-s
    object-group service pop3-110
    object-group service smtp25
    object-group service udp53
    object-group service ssh
    object-group service tcp-port
    object-group service udp-port
    object-group service ftp
    object-group service ftp-data
    object-group network csc1-ip
    object-group service all-tcp-udp
    access-list INTERNET1-IN extended permit ip host 1.2.2.2 host 2.2.2.3
    access-list CSC-OUT extended permit ip host 10.0.0.5 any
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq www
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq https
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq ssh
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq ftp
    access-list CAMPUS-LAN extended permit udp 172.16.0.0 255.255.0.0 any eq domain
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq smtp
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq pop3
    access-list CAMPUS-LAN extended permit ip any any
    access-list csc-acl remark scan web and mail traffic
    access-list csc-acl extended permit tcp any any eq smtp
    access-list csc-acl extended permit tcp any any eq pop3
    access-list csc-acl remark scan web and mail traffic
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq 993
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq imap4
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq 465
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq www
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq https
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq smtp
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq pop3
    access-list INTERNET2-IN extended permit ip any host 1.1.1.2
    access-list nonat extended permit ip 172.16.0.0 255.255.0.0 172.16.0.0 255.255.0.0
    access-list DNS-inspect extended permit tcp any any eq domain
    access-list DNS-inspect extended permit udp any any eq domain
    access-list capin extended permit ip host 172.16.1.234 any
    access-list capin extended permit ip host 172.16.1.52 any
    access-list capin extended permit ip any host 172.16.1.52
    access-list capin extended permit ip host 172.16.0.82 host 172.16.0.61
    access-list capin extended permit ip host 172.16.0.61 host 172.16.0.82
    access-list capout extended permit ip host 2.2.2.2 any
    access-list capout extended permit ip any host 2.2.2.2
    access-list campus-lan_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 192.168.150.0 255.255.255.0
    pager lines 24
    logging enable
    logging buffered debugging
    logging asdm informational
    mtu internet1-outside 1500
    mtu internet2-outside 1500
    mtu dmz-interface 1500
    mtu campus-lan 1500
    mtu CSC-MGMT 1500
    ip local pool vpnpool1 192.168.150.2-192.168.150.250 mask 255.255.255.0
    ip verify reverse-path interface internet2-outside
    ip verify reverse-path interface dmz-interface
    ip verify reverse-path interface campus-lan
    ip verify reverse-path interface CSC-MGMT
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-621.bin
    no asdm history enable
    arp timeout 14400
    global (internet1-outside) 1 interface
    global (internet2-outside) 1 interface
    nat (campus-lan) 0 access-list campus-lan_nat0_outbound
    nat (campus-lan) 1 0.0.0.0 0.0.0.0
    nat (CSC-MGMT) 1 10.0.0.5 255.255.255.255
    static (CSC-MGMT,internet2-outside) 2.2.2.3 10.0.0.5 netmask 255.255.255.255
    access-group INTERNET2-IN in interface internet1-outside
    access-group INTERNET1-IN in interface internet2-outside
    access-group CAMPUS-LAN in interface campus-lan
    access-group CSC-OUT in interface CSC-MGMT
    route internet2-outside 0.0.0.0 0.0.0.0 2.2.2.5 1
    route internet1-outside 0.0.0.0 0.0.0.0 1.1.1.5 2
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    aaa authentication enable console LOCAL
    http server enable
    http 10.0.0.2 255.255.255.255 CSC-MGMT
    http 10.0.0.8 255.255.255.255 CSC-MGMT
    http 1.2.2.2 255.255.255.255 internet2-outside
    http 1.2.2.2 255.255.255.255 internet1-outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map internet2-outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map internet2-outside_map interface internet2-outside
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca xyzxyzxyzyxzxyzxyzxyzxxyzyxzyxzy
            a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as
      quit
    crypto isakmp enable internet2-outside
    crypto isakmp policy 10
    authentication pre-share
    encryption aes
    hash md5
    group 2
    lifetime 86400
    telnet 10.0.0.2 255.255.255.255 CSC-MGMT
    telnet 10.0.0.8 255.255.255.255 CSC-MGMT
    telnet timeout 5
    ssh 1.2.3.3 255.255.255.240 internet1-outside
    ssh 1.2.2.2 255.255.255.255 internet1-outside
    ssh 1.2.2.2 255.255.255.255 internet2-outside
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy VPN_TG_1 internal
    group-policy VPN_TG_1 attributes
    vpn-tunnel-protocol IPSec
    username ssochelpdesk password xxxxxxxxxxxxxx encrypted privilege 15
    username administrator password xxxxxxxxxxxxxx encrypted privilege 15
    username vpnuser1 password xxxxxxxxxxxxxx encrypted privilege 0
    username vpnuser1 attributes
    vpn-group-policy VPN_TG_1
    tunnel-group VPN_TG_1 type remote-access
    tunnel-group VPN_TG_1 general-attributes
    address-pool vpnpool1
    default-group-policy VPN_TG_1
    tunnel-group VPN_TG_1 ipsec-attributes
    pre-shared-key *
    class-map cmap-DNS
    match access-list DNS-inspect
    class-map csc-class
    match access-list csc-acl
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class csc-class
      csc fail-open
    class cmap-DNS
      inspect dns preset_dns_map
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum: y0y0y0y0y0y0y0y0y0y0y0y0y0y
    : end
    Neither Adding dynamic NAT for 192.168.150.0/24 on outside interface works, nor does the sysopt connection permit-vpn works
    Please tell what needs to be done here, to hairpin all the traffic to internet comming from VPN Clients.
    That is I need clients conected via VPN tunnel, when connected to internet, should have their IP's NAT'ted  against the internet2-outside interface address 2.2.2.2, as it happens for the Campus Clients (172.16.0.0/16)
    I'm not much conversant with everything involved in here, therefore please be elaborative in your replies. Please let me know if you need any more information regarding this setup to answer my query.
    Thanks & Regards
    maxs

    Hi Jouni,
    Thanks again for your help, got it working. Actually the problem was ASA needed some time after configuring to work properly ( ?????? ). I configured and tested several times within a short period, during the day and was not working initially, GUI packet tracer was showing some problems (IPSEC Spoof detected) and also there was this left out dns. Its working fine now.
    But my problem is not solved fully here.
    Does hairpinning model allow access to the campus LAN behind ASA also?. Coz the setup is working now as i needed, and I can access Internet with the NAT'ed ip address (outside-interface). So far so good. But now I cannot access the Campus LAN behind the asa.
    Here the packet tracer output for the traffic:
    packet-tracer output
    asa# packet-tracer input internet2-outside tcp 192.168.150.1 56482 172.16.1.249 22
    Phase: 1
    Type: ACCESS-LIST
    Subtype:
    Result: ALLOW
    Config:
    Implicit Rule
    Additional Information:
    MAC Access list
    Phase: 2
    Type: FLOW-LOOKUP
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Found no matching flow, creating a new flow
    Phase: 3
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   172.16.0.0      255.255.0.0     campus-lan
    Phase: 4
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.150.1   255.255.255.255 internet2-outside
    Phase: 5
    Type: ACCESS-LIST
    Subtype: log
    Result: ALLOW
    Config:
    access-group internnet1-in in interface internet2-outside
    access-list internnet1-in extended permit ip 192.168.150.0 255.255.255.0 any
    Additional Information:
    Phase: 6
    Type: IP-OPTIONS
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 7
    Type: CP-PUNT
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 8
    Type: VPN
    Subtype: ipsec-tunnel-flow
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 9
    Type: NAT-EXEMPT
    Subtype: rpf-check
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 10
    Type: NAT
    Subtype:     
    Result: DROP
    Config:
    nat (internet2-outside) 1 192.168.150.0 255.255.255.0
      match ip internet2-outside 192.168.150.0 255.255.255.0 campus-lan any
        dynamic translation to pool 1 (No matching global)
        translate_hits = 14, untranslate_hits = 0
    Additional Information:
    Result:
    input-interface: internet2-outside
    input-status: up
    input-line-status: up
    output-interface: internet2-outside
    output-status: up
    output-line-status: up
    Action: drop
    Drop-reason: (acl-drop) Flow is denied by configured rule
    The problem here as you can see is the Rule for dynamic nat that I added to make hairpin work at first place
    dynamic nat
    asa(config)#nat (internet2-outside) 1 192.168.150.0 255.255.255.0
    Is it possible to access both
    1)LAN behind ASA
    2)INTERNET via HAIRPINNING  
    simultaneously via a single tunnel-group?
    If it can be done, how do I do it. What changes do I need to make here to get simultaneous access to my LAN also?
    Thanks & Regards
    Abhijit

  • FormsCentral retiring in July???!!!  Are you freaking kidding me?  My clients use this feature all the time.  What do you suggest I do now?  What service do I go with that is comparable to it?  I need help with this asap!

    FormsCentral retiring in July???!!!  Are you freaking kidding me?  My clients use this feature all the time.  What do you suggest I do now?  What service do I go with that is comparable to it?  I need help with this asap!

    I would suggest checking out http://www.logiforms.com. They have really good PDF support for both hosted PDF's and generating PDFs. You can:
    populate PDF forms from a web form submission
    Merge multiple PDF's together using conditional logic
    Include uploaded images in the generated PDF
    Get Electronic signatures on PDF's
    Use conditional logic when creating PDF's
    Convert HTML to PDF. You design in HTML and CSS and use form field wildcards and generate the PDF
    More of the PDF features are explained here:
    PDF Form Creator | PDF Form Maker | V3.Logiforms.com
    They are also offering a 25% discount to anyone coming from Forms Central...

  • HT2492 When I try to update Adobe Flash Player I'm prompted to quit Safari and Dashboard Client. I quit Safari but I don' know how to quit Dashboard Client. Can anyone help with this challenge?

    When I try to update Adobe Flash Player I'm prompted to quit Safari and Dashboard Client. I quit Safari but I don' know how to quit Dashboard Client. Can anyone help with this challenge?

    Carolyn,
    Thank you. It worked
    Angus.

  • Help with configuring AP-1240AG as local authenticator for EAP-FAST client

    Hi,
    I am trying to configure an AP-1240AG as a local authenticator for a Windows XP client with no success. Here is a part of the AP configuration:
    dot11 lab_test
       authentication open eap eap_methods
       authentication network-eap eap_methods
       guest-mode
       infrastructure-ssid
    radius-server local
      eapfast authority id 0102030405060708090A0B0C0D0E0F10
      eapfast authority info lab
      eapfast server-key primary 7 211C7F85F2A6056FB6DC70BE66090DE351
      user georges nthash 7 115C41544E4A535E2072797D096466723124425253707D0901755A5B3A370F7A05
    Here is the Windows XP client configuration:
    Authentication: Open
    Encrpytion WEP
    Disable Cisco ccxV4 improvements
    username: georges
    password: georges
    Results: The show radius local-server statistics does not show any activity for the user georges and the debug messages are showing the following:
    *Mar  4 01:15:58.887: %DOT11-7-AUTH_FAILED: Station 0016.6f68.b13b Authentication failed
    *Mar  4 01:16:28.914: %DOT11-7-AUTH_FAILED: Station 0016.6f68.b13b Authentication failed
    *Mar  4 01:16:56.700: RADIUS/ENCODE(00001F5C):Orig. component type = DOT11
    *Mar  4 01:16:56.701: RADIUS:  AAA Unsupported Attr: ssid              [263] 19
    *Mar  4 01:16:56.701: RADIUS:    [lab_test]
    *Mar  4 01:16:56.701: RADIUS:   65                                               [e]
    *Mar  4 01:16:56.701: RADIUS:  AAA Unsupported Attr: interface         [156] 4
    *Mar  4 01:16:56.701: RADIUS:   38 32                                            [82]
    *Mar  4 01:16:56.701: RADIUS(00001F5C): Storing nasport 8275 in rad_db
    *Mar  4 01:16:56.702: RADIUS(00001F5C): Config NAS IP: 10.5.104.22
    *Mar  4 01:16:56.702: RADIUS/ENCODE(00001F5C): acct_session_id: 8026
    *Mar  4 01:16:56.702: RADIUS(00001F5C): sending
    *Mar  4 01:16:56.702: RADIUS/DECODE: parse response no app start; FAIL
    *Mar  4 01:16:56.702: RADIUS/DECODE: parse response; FAIL
    It seems that the radius packet that the AP receive is not what is expected. Do not know if the problem is with the client or with the AP configuration. Try many things but running out of ideas. Any suggestions would be welcome
    Thanks

    Hi Stephen,
    I do not want to create a workgroup bridge, just want to have the wireless radio bridge with the Ethernet port. I will remove the infrastructure command.
    Thanks for your help
    Stephane
    Here is the complete configuration:
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Lab
    ip subnet-zero
    aaa new-model
    aaa group server radius rad_eap
    aaa group server radius rad_mac
    aaa group server radius rad_admin
    aaa group server tacacs+ tac_admin
    aaa group server radius rad_pmip
    aaa group server radius dummy
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authorization exec default local
    aaa accounting network acct_methods start-stop group rad_acct
    aaa session-id common
    dot11 lab_test
       authentication open eap eap_methods
       authentication network-eap eap_methods
       guest-mode
       infrastructure-ssid
    power inline negotiation prestandard source
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    ssid lab_test
    traffic-metrics aggregate-report
    speed basic-54.0
    no power client local
    channel 2462
    station-role root
    antenna receive right
    antenna transmit right
    no dot11 extension aironet
    bridge-group 1
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio1
    no ip address
    no ip route-cache
    shutdown
    dfs band 3 block
      speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
    channel dfs
    station-role root
    no dot11 extension aironet
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    hold-queue 160 in
    interface BVI1
    ip address 10.5.104.22 255.255.255.0
    ip default-gateway 10.5.104.254
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip radius source-interface BVI1
    radius-server local
      eapfast authority id 000102030405060708090A0B0C0D0E0F
      eapfast authority info LAB
      eapfast server-key primary 7 C7AC67E296DF3437EB018F73BE00D822B8
      user georges nthash 7 14424A5A555C72790070616C03445446212202080A75705F513942017A76057007
    control-plane
    bridge 1 route ip
    line con 0
    line vty 0 4
    end

  • Help Needed With Basic Client/Server App

    I was wondering if anyone can help with a simple blackjack client/server application i've been writting (basically its a moddified chat application). The problem i'm having seems to lie within the connection management i've written.
    What i'm trying to get is that only 4 players can connect at one time and that each player takes a turn (which i've implemented using threads) to play their hand (as you would if you were playing it for real). The problem is that it will allow the players to connect, but oddly enough, it will not allow a new transaction to be created (i.e. allow a player to take their turn) until 2 players have connected.
    Even when it does create the transaction, after taking input from the client once, the server seems to stop doing anything without any error message of any kind.
    Its really annoyed me now, so you guys are my last hope!
    The code can be found in full here:
    Client Application: http://stuweb3.cmp.uea.ac.uk/~y0241725/WinEchoClient.java
    Server Application: http://stuweb3.cmp.uea.ac.uk/~y0241725/ThreadServer.java
    Card Class: http://stuweb3.cmp.uea.ac.uk/~y0241725/Card.java
    Deck Class: http://stuweb3.cmp.uea.ac.uk/~y0241725/Deck.java
    Please feel free to play around with this code as much as you feel necessary!

    (one last bump back up the forum before i give up on this completely)

Maybe you are looking for

  • G62 can't find drivers for USB mouse

    For some reason I can't get my wired mouse OP-35D to work with Windows 7. When I plug it in ti the USBslot the PC can identify that its a USB mouse but can't find any drivers. I've downloded drivers from the manufacturers homepage but it's still not

  • Issue with printing of multiple text elements in main window

    Hi experts, I have developed a sales order form in SAP script. I hv got two text elements in the main window. n i m calling these two text elements by using two write form functions in d print program. The first text element is gettin called n d rele

  • How can I get the frame option that diffuses the edges of a picture in pages 5.2

    I recently updated to Pages 5.2 and have discovered that my favorite and most used framing option is no longer a choice.  How can I get the frame option that allowed you to diffuse the edges to soften a picture edges on 5.2? 

  • ITunes radio has no sound

    I have iTunes on the Mac at my work. I've been using the radio thing on it for about 9 years and suddenly it quit. The screen makes it look as if it's playing but I hear nothing. Tried new earphones but still hear nothing. Now what?

  • Where to place crossdomain.xml

    Hi experts, I am trying to connect from a flex application to a webservice on the Web AS. If I deploy local or run the application on the same domain as the webservice everything works fine, but not on another domain, so I think it could be fixed wit