How do I load balance TFTP between two servers and a client on the same subnet?

Hi,
I have trawled through several documents and tried umpteen different configs, all to no avail. I have a PXE boot client trying to access a boot file via TFTP from a couple of TFTP servers on the same VLAN/subnet. For HA purposes I want to load balance the two TFTP servers.
Config is currently;
=====
probe icmp ICMP_PROBE
  description icmp probe for default gateway tracking
  interval 5
  passdetect interval 15
rserver host server1
  description Server1
  ip address 10.0.0.1
  inservice
rserver host server2
  description Server 2
  ip address 10.0.0.2
  inservice
serverfarm host serverfarm_01
  description servers used
  probe ICMP_PROBE
  rserver server1
    inservice
  rserver server2
    inservice
class-map match-all L4_VIP_TFTP
  10 match virtual-address 10.0.0.10 udp eq 69
policy-map type loadbalance first-match L7_TFTP
  class class-default
    serverfarm serverfarm_01
policy-map multi-match L4_LB_VIP_POLICY
  class L4_VIP_TFTP
    loadbalance vip inservice
    loadbalance policy L7_TFTP
    loadbalance vip icmp-reply active
nat dynamic 1 vlan 200
interface vlan 200
  ip address 10.0.0.250 255.255.255.0
  nat-pool 1 10.0.0.241 10.0.0.243 netmask 255.255.255.255 pat
  service-policy input L4_LB_VIP_POLICY
  no shutdown
ip route 0.0.0.0 0.0.0.0 10.0.0.254
=====
I have read the doco by Ivan Kovacevic amongst many others but as my clients and servers are on the same subnet, the config doesnt work.
Can anybody point me in the right direction please. The devices are ACE 4710 running A3(2.3).
Thanks

Try using the following configuration:
Note: Please make sure to configure also a udp probe to probe udp port 69, in case the application is down.
You need to configure a management policy on the interface when using a UDP probe.
That is because, when port 69 on the server will be unreachable, the server will send an ICMP unreachable.
ACE will consider a udp probe as "failed" only when it sees ICMP unreachable.
Without a management policy-map, the ICMP unreachable message will be dropped.
Also, add an ICMP probe to the rserver because udp probe will not be enough when the physical interface will be down.
That is because UDP is a connection-less protocol. To consider a UDP probe successfull, ACE need to see NO answer from the server in respose to the probe.
The ACE will not see any answer from the server when the interface is down and thus, will consider the probe as "sucessful".
With ICMP probe attached to the rserver, you also test the reachability of the server and not only the UDP port.
Here is the configuration (of course, you can chage the names of the of the objects to the name you are using if you want) :
access-list ALL line 10 extended permit ip any any
probe udp TFTP
  port 69
  interval 5
  passdetect interval 15
probe icmp ICMP_PROBE
  interval 5
  passdetect interval 15
rserver host TFTP_1
  ip address 10.0.0.1
  probe TFTP
  probe ICMP_PROBE
  inservice
rserver host TFTP_2
  ip address 10.0.0.2
  probe TFTP
  probe ICMP_PROBE
  inservice
serverfarm host TFTP-SFARM
  rserver TFTP_1
    inservice
  rserver TFTP_2
    inservice
sticky ip-netmask 255.255.255.255 address source TFTP-STICKY
  timeout 10
  replicate sticky
  serverfarm TFTP-SFARM
class-map type management match-any MANAGE
  2 match protocol icmp any
class-map match-all NAT
  2 match virtual-address 0.0.0.0 0.0.0.0 udp any
class-map match-all TFTP
  2 match virtual-address 10.0.0.10 udp eq 69
policy-map type management first-match MANAGE
  class MANAGE
    permit
policy-map type loadbalance first-match ROUTE
  class class-default
    forward
policy-map type loadbalance first-match TFTP-POL
  class class-default
    sticky-serverfarm TFTP-STICKY
policy-map multi-match TFTP-MULTI
  class TFTP
    loadbalance vip inservice
    loadbalance policy TFTP-POL
    nat dynamic 1 vlan 212
  class NAT
    loadbalance vip inservice
    loadbalance policy ROUTE
    nat dynamic 2 vlan 212
interface vlan 212
  ip address 10.0.0.250 255.255.255.0
  no normalization
  access-group input ALL
  nat-pool 1 10.0.0.241 10.0.0.243 netmask 255.255.255.0 pat
  nat-pool 2 10.0.0.10 10.0.0.10 netmask 255.255.255.0 pat
  service-policy input TFTP-MULTI
  service-policy input MANAGE
  no shutdown
Let me know how it goes.
Good luck!

Similar Messages

  • I have two Macs and I am using the same Apple ID on both.  All of my info, history etc is showing up on both.  How do I turn this off?

    I have two Macs and I am using the same Apple ID on both.  All of my info, history etc is showing up on both.  How do I turn this off?

    You likely have iCloud turned on in at least Safari. If you don't want Safari to sync between these devices turn one of them off. System Preferences - iCloud - Safari (uncheck the box)

  • How Do I Share My Database Between More Than One User Account on the Same Mac?

    How Do I Share My Database Between More Than One User Account on the Same Mac?

    How to use multiple iPhone, iPad, or iPod devices with one computer. The only way is for you to have a separate user account to log into on that computer.

  • How do I create a graph with two different y-axis variables with the same x-axis (therefor having two curves)?, How do I create a graph with two different y-axis variables with the same x-axis (therefor having two curves)?

    How do I create a graph with two different y-axis variables with the same x-axis (therefor having two curves)?, How do I create a graph with two different y-axis variables with the same x-axis (therefor having two curves)?

    Hi Libby,
    Select all three columns of data. All three must be 'regular' columns, not Header columns, and the X values must be in the leftmost column.
    Click the Charts button and choose the Scatter chart.
    The resulting chart will initially show only the first and second columns of data, and the selection will have been reduced to show this.
    Click the gear icon at the top left of the selection and choose Share X Values.
    You should see a result similar to this:
    Notes:
    The values on my sample table contain a random element, so they have changed from thhe first image to the second.
    The chart is as created by Numbers, with two edits:
    Data points have been connected with curves, using the Chart nspector.
    The curves were selected and their stroke increased to 2pts, using the stroke formating button in the format bar.
    Regards,
    Barry

  • SCVMM 2012 R2 – two iSCSI network interfaces connected to the same subnet

    I would like to configure two networks in SCVMM 2012 R2 which will be used by VMs to connect to iSCSI SAN. Both of these networks should be connected to the same subnet (192.168.100.0/24) because they will connect VMs to Dell EqualLogic using iSCSI MPIO.
    Those networks should be available on all Windows Server 2012 R2 Hyper-V cluster nodes.
    When I try to create two logical networks in SCVMM with the same subnet, I receive error (Unable to assign the subnet 192.168.100.0/24 because it overlaps with an existing subnet)
    How should I configure networking in SCVMM to allow one virtual machine to connect to the same subnet using two network interfaces?

    "How should I configure networking in SCVMM to allow one virtual machine to connect to the same subnet using two network interfaces?"
    You can achieve this by simply adding multiple vNICs to a VM - connected to the same VM Network. 
    -kn
    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )

  • If you registrate one Apple ID for each iPhone/iPad, you'll get 5GB on iCloud for each Apple ID, right? I have two iPhones and one iPad  with the same Apple ID, why can't I get 5 GB fo each of them?

    If you registrate one Apple ID for each iPhone/iPad, you'll get 5GB on iCloud for each Apple ID, right? I have two iPhones and one iPad  with the same Apple ID, why can't I get 5 GB fo each of them?

    Actually, everyone missed one point, when a device is priced, the cost of icloud storage space for that device is also included in it that is why they are able to give you 5gb each for each user ID, in nutshell there is nothing free coming with apple device purchase, it is paid for.  What they are trying by giving only 5gb per user ID irrespective of the number of devices used is pure broadlight looting, they take money from you when you buy each device and give you nothing, This is a case of goods and services bought but not fully deliverd ie apple can be suied for discreminatory treatment towards it's users. I wonder why no one tried this yet in America where everyone sue everyone for petty things..... there is no one to take up this issue? . if tim got any love for the guys who shell out money for the devices his company makes, he should be implimenting this as priority before someone wake up from sleep and sue him.

  • In Pages 5.2.2: How do you go from 1 column to 2 and keep them on the same page?

    In Pages 5.2.2: How do you go from 1 column to 2 and keep them on the same page?

    Sorry, I tried to say your answer solved my question, but I guess I told it that my response to you solved it. Now that I liked it, the solved option doesn't appear.

  • Difference between local amount and document amount in the same currency

    Dear All,
    Why different between local amount and document amount with the same currency in some FI document line items? Both currency is 'TWD' and update currecy(BSEG-PSWSL) is 'USD'.
    What is the purpose of update currency(BSEG-PSWSL) and update amount(BSEG-PSWBT) ?
    Does update curreny cause the difference mentioned above?
    Thanks all in advance.
    Best regards,
    SAP user

    Dear Sir,
    Thanks for your kindly response!
    These fields of the FI document header are following:
    Local currency 1(BKPF-HWAER) : TWD
    Local currency 2(BKPF-HWAE2) : null
    Local currency 3(BKPF-HWAE3) : null
    Document currency (BKPF-WAERS) : TWD
    Transcation currency means which field ?
    Transaction code (BKPF-TCODE) : FB1S
    The line items as following :
    Itm PK Account    Account  short text   Amount
    1   40   21302500  A/E-Maintenance     1,119,350
    2   50   21302500  A/E-Maintenance     1,119,350-
    Amount in document currency is 1,119,350(TWD) but amount in local currency is 1,087,998(TWD).
    The line item's additional data :
    Amount for Updating in General Ledger : 33,894.02(USD)
    Thanks a lot !!
    Best regards,
    SAP user

  • How to access a Network Share between two servers in same data centre

    I have two dedicated servers (both Windows 2012 Server) hosted in a data centre somewhere.   I want to share a folder on one server with the other server, but it's obviously not as straight forward as one might think.  My servers are called "Maximus"
    and "Apprentice".
    On Maximus I shared a folder by right clicking on it and choosing "Share with... / Specific People", I then typed in the name of a local user account which also exists on Apprentice with the same name and password.  (so each server has a local
    user account with the same name and password).
    So then on Apprentice, I was hoping I could access the share (while being logged in as this user with whom the folder was shared) by simply typing  "\\ipaddress\sharename" into the address bar in file explorer.  Unfortunately it comes
    back with "Windows can not access [ip address]".
    Now, I do have a website setup on the IP address for Maximus.  This is actually the reason I want to create this share.  I need the second server for load balancing and need to share IIS config as well as the website itself.  (So I will need
    two shares eventually, but for now I'm just trying to get one to work).  I don't know if the fact that the ip address is pointing to the website is causing me problems here or if it's something else.
    Are there any network gurus out there who can tell me what the issue is and how to resolve it?

    I can ping both servers in either direction, but I believe I may have found the problem.  Apparently my host is blocking port 445 which Windows wants to use to connect to the share and they will not unblock it.
    Is there a way to connect to the share through a different port?  
    To my knowledge, you cannot change the port. However, you can try disabling your security software for testing. If this fixes the problem then you need to adjust your security software configuration so that traffic on this port is not blocked or filtered.
    This posting is provided AS IS with no warranties or guarantees , and confers no rights.
    Ahmed MALEK
    My Website Link
    My Linkedin Profile
    My MVP Profile

  • How can I easily manage different libraries of music between my iPad and my iPhone from the same computer?

    My 32 GB iPad stores much more data than my 16 GB iPhone... clearly. But I want to be able to easily sync these two seperate devices with two different sets of music from my iTunes. As it stands now, my iPad will always have the same amount of music as my iPhone because my iPhone is maxed out and the two devices are synced on the same computer from the same library. Do you understand where I'm coming from? Let me know if you need clarification.
    I want to be able to have my iPhone filled with individual songs, whereas my iPad would have the full albums. There doesn't seem to be an efficient way to do this with one computer. Any suggestions would be great. Thanks.

    It can be done very easily actually. I do it with three different iDevices.
    Connect the iDevice to your PC and launch iTunes. Select the iDevice from the left sidebar of the iTunes window. Then click on the Music Tab. Select only the music that you want on that particular iDevice and then sync the device with those selections.
    Do the same thing with the other iDevice. When you sync with iTunes the next time, iTunes will remember the music that was synced to that device.
    Make sure that you uncheck Sync Entire Music Library and check Sync Selected playlists, albums, etc and then select all of the music for each device.
    When you make changes to the current configuartion on the iPad - you will have to click on Apply in the lower right corner of the iTunes window.

  • Ichat av between macbook pro and a macbook with the same .Mac acct.

    Hello everyone:
    How can I chat AV (isight) between my macbook pro and my son's macbook using the same .mac account or is there any other way to see each other on the computer and chat. I'm in Dallas he's in Miami. Thank you guys

    One of you can get a free trial .Mac account (it will still work in iChat after it expires) or get a free AIM account:
    <https://reg.my.screenname.aol.com/cqr/registration/initRegistration.psp?mcState=initialized&seamless=n&createSn=1& sitedomain=www.aim.com&siteState=http%3A//www.aim.com/getaim/congratsd2.adp&triedAimAuth=y&promo=380464&mcAuth=%2FBcAG0VsjuwAAPdfAo233EVs jygIrleg1RkQxBwAAA%3D%3D>

  • How do I listen to music on my iMac and Bose Soundlink at the same time???

    I just bought a Bose Soundlink Color. However I can only listen to either the iMac or the soundlink. Not both at the same time. Can you do this and if you can how do I fix it. Thanks for any help.

    Welcome to the Apple Community.
    Use the multiple speakers option from the AirPlay menu.

  • How to have creative p5800 in 5.1 mode and a microphone at the same t

    Hello everybody,
    pls, can somebody advise, how can i use my creative p5800 in 5. mode and at the same time to have microphone working properly.
    for the moment i have installed my creative as stereo speakers and the mic is plugged?into the sound card, which is not very conviniet, because my rear speakers are not working.
    i would be very greatful if somebody can help me.
    0x in advance

    I'm not really sure what you mean.
    Which soundcard do you have exactly? If it's one of ours, you should be able to use the outputs on the back to connect your speakers (and set the speaker selection to 5.) and connect the microphone. As long as the microphone is set up correctly in the mixer, and is selected as the recording source, then it should work fine.
    Cat

  • Two Versions of essbase client in the same pc

    Can we have two different versions of the Essbase client installed in the same PC?

    Yes, but not running concurrently.. What I have done in the past is to:1. Setup the first version in a directory, say "C:\Hyperion\Essbase" and have the ARBORPATH statement setup to point to this directory, etc..2. Rename the Hyperion directory (ex. "Hyperion.6.2"3. Install th new version to "C:\Hyperion\Essbase".To switch versions, rename the Hyperion directories as necessary (ex. "Hyperion.6.5.3"), then rename the first directory to "Hyperion".I don't know if Hyperion supports this method.Tim TowApplied OLAP, Inc

  • I'd like to sync two videos and edit them at the same time, possible?

    I've recently recorded a conference speaker with a camera and a screen capture of his slides I'd like to import the two video files and sync them together (they received the same audio feed) then perform very basic edits of removing any intro before the speaker and the q&amp;a after his talk. Any tips on making this as easy as possible would be greatly appreciated. I need to have a copy of each video (headshot and screen capture) that is the same length.

    Here is the user manual about creating and editing Multicam clips.
    http://help.apple.com/finalcutpro/mac/10.1/#ver23c76439
    macProVideo.com and Ripple Training have the best online training available.
    http://www.macprovideo.com/finalcut
    http://www.rippletraining.com/categories/apple-pro-apps-tutorials/final-cut-pro- x-tutorials.html
    The "Apple Pro Training Series: Final Cut Pro X 10.1, Professoinal Post Production" book is what we use to teach Apple authorized training, and is really quite good.  It is step-by-step, hands-on training you can't beat.
    http://www.peachpit.com/store/apple-pro-training-series-final-cut-pro-x-10.1-pro fessional-9780321949561
    I've found the Lynda.com FCPX training to be lacking, and it is not kept up to date very well.

Maybe you are looking for