I am trying to install Xmarks on Firefox 12 but get "Xmarks could not be installed because Firefox cannot modify the necessary file." Already reinstalled FF.

Noticed that my wife's laptop (same make and model as mine) appeared different and had no "Reload" icon. Ran FF in Safe Mode and disabled all add-ons and reset toolbars and controls. When that resolved the problem, I made the changes and restarted. Was able to re-install all the other add-ons (WOT, Adblock, No Script, All-in One-Sidebar, Colorful tabs, and IE tab) without any problem. Tried installing Xmarks thru FF and directly from xmarks.com without any luck.

Hi cor-el,
'''''FINALLY!!''''' When I deleted all the "extension" suggestions you made (along with .rdf that was in KB) and it did not work, I tried to uninstall via CCleaner (without success) and then via the Control Panel (again, without success) and then through the FF "uninstall\helper.exe" - still without success. Had to delete each file one at a time until I got to the corrupt file at the end of the Application Data tree (extensions - chrome - locale - "vi"). Getting rid of that file took some doing, but once accomplished the uninstall was finished. In the process.
Thanks again for the guidance as the problem was a corrupt file in extensions. Too bad it could not be corrected with the easier/faster deletions you suggested.
Will wait before installing FF 13 as the machine is running much faster now and want to give it time to make sure it was FF causing it to be so slow. Have to echo what some others have said about disliking ANY program that does not allow for it to be uninstalled.

Similar Messages

  • When attempting to install add-ons, Firefox generates a message saying it is unable to install add-on because Firefox cannot modify the necessary file. To what file is this referring, and how do I fix this problem?

    When I download an add-on such as Colorful Tabs and start the installation process, I receive a message that Firefox cannot install the add-on because it cannot modify the necessary file. To what file is this referring?

    That is usually caused by Firefox not unpacking the extension.
    You can try to set the Boolean pref <b>extensions.alwaysUnpack</b> to <i>true</i> on the <b>about:config</b> page.
    To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br />
    If you see a warning then you can confirm that you want to access that page.<br />
    *Use the Filter bar at to top of the about:config page to locate a preference more easily.
    *Preferences that have been modified show as bold (user set).
    *Preferences can be reset to the default via the right-click context menu if they are user set
    *Preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean)

  • Firefox crashes whenever i want to install any addon or download any file. Some times i am receiving error while downloading any file like "could not be saved, because you cannot change the contents of that folder"

    I am the user of latest firefox 3.6.6 browser. I am getting problems of frequent crashes whenever i tries to install any addon. The crashes also occures whenever i want to download any file.
    I am also receiving errors while downloading any file like:
    "C:\Users\****\AppData\Local\Temp\******.001.part could not be saved, because you cannot change the contents of that folder.
    Change the folder properties and try again, or try saving in a different location. I already changed it many many times but still the same problem."
    Adobe flash palyer is also giving problems of not responding. I am using updated version of it already. Java is also updated.
    I already uninstalled firefox compeletly and re installed it many many times but still the same problem. I also scanned my computer with avira and malware bytes' Anti malware and got no dection. Please ractify this problem ASAP lest my profession will suffer.
    == Crash ID(s) ==
    b7f518f2-8d86-41ca-8bab-aee632100709; 1d790e10-d8eb-4904-98c9-94bc62100708; f042d319-b9f8-42ed-a8cb-57c7d2100708

    Please help.
    It is getting worse
    Adobe flash player is crashing. I already uninstalled and re installed the latest ver. Also it is hanging randomly.
    Please help.

  • Add-on could not be installed because Firefox cannot modify the necessary file.

    I see that for the issue:
    <Add-on> could not be installed because Firefox cannot modify the necessary file.
    The usual fixes include:
    - ensuring that xpinstall.enabled is set to true
    - ensuring that extensions.alwaysUnpack is set to true
    What might be the non-usual fixes as I have set both to true and I still get the message above.
    I have tried installing the <add-on> after I have set the values to true, then again after restarting my browser, then again after restarting my computer and finally tried creating a new profile and repeated each of the steps after setting the 2 preferences to true.

    Can you at least update to the latest Firefox 10.0.10 ESR version?
    Firefox 10.0.x ESR:
    *http://www.mozilla.org/en-US/firefox/organizations/all.html
    So a new profile with no other extensions didn't work as well?
    *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
    *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues
    Which extension is causing this problem or can't you install any extensions at all?
    *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions
    *https://support.mozilla.org/kb/Unable+to+install+add-ons

  • When firefox trys to auto update, or I manually download the new version, or some but not all downloads off of the web, I get this error message. C:\Users\John\AppData\Local\Temp could not be saved, because you cannot change the contents of that folder.

    First off, when firefox trys to auto update, it fails. It tells me to try and download the new version from mozilla's site. When I try to download the new version I get this: (C:\Users\John\AppData\Local\Temp could not be saved, because you cannot change the contents of that folder.)
    This is the same message I have been getting when I try to download other things off the net. (When I use other browsers to download I dont have this problem)

    Please help.
    It is getting worse
    Adobe flash player is crashing. I already uninstalled and re installed the latest ver. Also it is hanging randomly.
    Please help.

  • Lightning will not install because Thunderbird cannot modify the needed file

    Am using OpenSUSE with a shared .default file for Linux and Mint, where it works. Originally the file loaded but the calendat was unresponsive. Removed and tried to reinstall and now get the above message.
    What file does it need and how do I get it to be modifiable while using a common .default file?

    Check the file ownership, i.e. the user id which owns the file. There is a numeric value behind a user name. My best guess is that the numeric user ids are different for your OpenSUSE and Ubuntu installations.
    Start in the extensions directory for Lightning of your Thunderbird profile. This should be something like:
    /home/<user id>/.thunderbird/<profile name>/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}

  • I am trying to install xmarks on Firefox 4 but it tells me Firefox cannot modify the needed file.

    I just upgraded to Firefox 4 and am trying to install xmarks for the first time, but Firefox says it cannot modify the needed file.

    What is the exact error message?

  • I am unable to install "Springpad extension" It states "could not be installed because Firefox cannot modify the needed file"

    I have just installed Firefox 4.0. I cannot install the extension called Springpad extension, found here: https://addons.mozilla.org/en-US/firefox/addon/springpad/
    I click add to Firefox, it downloads, prompts me that the author is not verified and I click 'Install Now'. It then says "Springpad extension could not be installed because Firefox cannot modify the needed file". What am I missing here?

    Unable to get Springpad Browser Extension to show up on my browser even though it is with-in my existing add-ons. I was having problems with the Springpad Browser Extension so I thought I would uninstall it and reinstall it but that hasn't worked. So I would like to know how to get it back so I can use it. When I go to the help button and click add-ons to search for Springpad, it does not come up in the results. So I tried using the link on my Springpad homepage website, but it didn't work. Then I searched Firefox support and found this post and tried installing it using the link here. It shows up now in my list of existing add-ons, but when I enabled it, it did not show up on my browser as a clickable icon I can use to spring a web-site. I'm stuck now!
    However, the reason for uninstalling it is there is no longer a"back arrow, the + sign, home, or scissors" at the top of the Springpad Browser Extension for Firefox? I have to log out and back in in order to get back to my notebooks because I am unable to get to them without a home button or a back button...and now I can't just click the scissors to spring a web-page. How are we supposed to spring a web-page now?
    Disappointed,
    Angela

  • [Add-on] could not be installed because firefox cannot modify the needed file

    I've tried both Zotero & Firefox forums with no success:
    Zotero could not be installed because Firefox cannot modify the needed file.
    I've deleted my cache, restarted firefox and computer, tried in various versions of Firefox (currently 8.0 which the add-on store says is compatible). I'm running brand new Mac with Windows for Mac 2011, have tried downloading in Safari & dropping into Firefox, from the Firefox add-ons and directly from the site. The add-ons says - unable to install & both the other methods list the above error (cannot modify the needed file).
    Thanks in advance.

    This can be a problem with the file(s) that store the extensions registry.
    Delete the files extensions.* (extensions.sqlite, extensions.ini, extensions.cache, extensions.rdf) and compatibility.ini in the Firefox [[Profiles|profile folder]] to reset the extensions registry.<br />
    New files will be created when required.
    See "Corrupt extension files":
    * http://kb.mozillazine.org/Unable_to_install_themes_or_extensions
    * Help > Troubleshooting Information > Profile Directory: Open Containing Folder
    If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is an update.

  • Error: "FT DeepDark 11.3.1 could not be installed because Firefox cannot modify the needed file." What does this mean?

    In an earlier version (Firefox v.31) on this, and (presently) on two other PC's, I was/am able to run add-on FT DeepDark 11.3.1 without any problems. It was only recently - after updating to v.32.0.3 on this PC that this situation started. The PC in question is a Dell Dimension 8400 Intel P4 running Windows 7, though I'm thinking it may have something to do with the newer version of Firefox. Could anyone help me with this? I like this add-on because it is easier in my eyes when browsing the internet. Thanks
    PS: Attempted to install the troubleshooter, and again I received a similar error: "Troubleshooter could not be installed because Firefox cannot modify the needed file."

    This error has been reported before in this bug:
    https://bugzilla.mozilla.org/show_bug.cgi?id=730040#c21
    Please read that bug I linked you to and let me know if the last comment in the bug solves your problem. Apparently the problem is about the addon .xpi file being read-only. Try right-clicking it, going to Properties and unchecking the "Read-only" attribute box at the bottom of the dialog. Click Apply, then OK.

  • When going through the download process with social monkee and getting to the point of adding it to firefox I get the following message: 'Social Monkee could not be installed because firefox cannot modify the needed file'. How can this be fixed?

    When going through the download process with social monkee and getting to the point of adding it to firefox I get the following message: 'Social Monkee could not be installed because firefox cannot modify the needed file'. How can this be fixed?

    That is usually caused by a missing unpack directive (&lt;em:unpack&gt;true&lt;/em:unpack&gt;) in the file install.rdf of that extension.
    See https://developer.mozilla.org/En/Updating_extensions_for_Firefox_4.0#XPI_unpacking
    -----

  • Cannot install "plugin/extension name" because Firefox cannot modify the needed file. This is happening for any and every kind of plugin theme you could think of. This started when I upgraded to Firefox 11 just now.

    I just upgraded to Firefox 11.0 (unwillingly) and I get the following whenever I try to install ANYTHING at all. Themes, add-ons...it doesn't matter, the result is the same.
    "Cannot install "plugin name here" because Firefox cannot modify the needed file.
    If the fix requires installing a plugin...well, that's not going to work obviously.
    Anybody know how to fix this?

    You shouldn't see such an error.<br />
    That error usually indicates that an extension or dictionary needs to be unpacked to make it work.
    Firefox 4 and later no longer unpacks an extension automatically, but renames the XPI file to the ID of the extension and copies that file to the extensions folder in the Firefox Profile Folder.
    If an extension needs to be unpacked then there should be an unpack directive (<nowiki><em:unpack>true</em:unpack></nowiki>) in the install.rdf file of that extension
    You can try to set the Boolean pref <b>extensions.alwaysUnpack</b> to <i>true</i> on the <b>about:config</b> page.
    *http://kb.mozillazine.org/about:config
    * https://developer.mozilla.org/En/Updating_extensions_for_Firefox_4.0#XPI_unpacking

  • I cannt install erail.in. note is"erail pluginfor firefox could not be installed because firefox cannot modify the needed file". what should i do now

    when i go to www.erail.net for train details. message as"click here to install plugin" displayed and clicked for install then the message "erail plugin for firefox could not be installed because firefox cannot modify the needed file"
    so, further what should i do
    regards. madhu

    You usually get this error if you try to install an extension that needs to be unpacked to work properly.<br />
    Current Firefox version do not unpack an extension automatically, but rename the xpi file to the extension's GUID.
    An extension that needs to be unpacked should have an unpack flag in its install.rdf file
    <pre><nowiki><em:unpack>true</em:unpack></nowiki></pre>
    *https://developer.mozilla.org/En/Updating_extensions_for_Firefox_4.0#XPI_unpacking
    You can try to set the extensions.alwaysUnpack pref to true on the <b>about:config</b> page.
    The extension seems to install, but I haven't tested if it works.
    *https://addons.mozilla.org/firefox/addon/erail-plugin-for-firefox/

  • I can not download the new version of Firefox. I keep getting a message that says "Firefox 5.0.1dmg could not be opened, because an unknown error occurred" HOW do I fix this?

    Every time I try to download the new version it just says I can not download the new version of Firefox. I keep getting a message that says "Firefox 5.0.1dmg could not be opened, because an unknown error occurred - Try saving to disk first and then opening the file"

    If you have problems with updating or with the permissions then easiest is to download the full version and trash the currently installed version to do a clean install of the new version.
    Download a new copy of the Firefox program and save the DMG file to the desktop
    * Firefox 5.0.x: http://www.mozilla.com/en-US/firefox/all.html
    * Trash the current Firefox application to do a clean (re-)install
    * Install the new version that you have downloaded
    Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data.
    * http://kb.mozillazine.org/Profile_folder_-_Firefox

  • Firefox cannot modify the needed file. I get this message when I try to add a theme. I am using Linux Mint 14.

    I am currently using Linux Mint 14 with Firefox 21. I am trying to add new themes and add ons, but I keep getting the message "firefox cannot modify the needed file in linux". How can I correct this?
    Thanks

    Click the Firefox button at the top left, then click the ''Help'' menu and select ''Troubleshooting Information'' from the submenu. If you don't have a Firefox button, click the Help menu at the top and select ''Troubleshooting Information'' from the menu. Go to Open Profile Directory (or something similar) and delete a file named user.js

Maybe you are looking for

  • Control file for United States Geometry

    Has anyone built a control file to load all of the United States? I have tried dumping all of the STATES GEOM data out of the Demo, but to clean it up and use it in a control file to load it into a new table I need to dump it into Excel. Excel hits i

  • How to disable auto header and footer from firefox desktop Application

    I build a Firefox desktop application for my company. i need to print some page from that application using JS window.print(). It Works Perfectly in my application. But the problem is when it printing my document it prints a header and a footer autom

  • SQL Query for max values!!

    Hi to all, I have four tables Tbl_one Tbl_two Tbl_three Tbl_four the relation between these tables is Tbl_one.SEQ = Tbl_two.SEQ) and tbl_two.case_SEQ = Tbl_four.SEQ AND Tbl_two.ORDER_SEQ = tbl_three.SEQ)) I want a query like this Select tbl_one.com_n

  • Mailbox move question

    Hi all, I want to move user's mailboxes from one post office to another but I don't want them to try and log in while doing this either. I want to check "disable logins" in the Groupwise properties of the user as this will not allow them to log into

  • XPath for Java

    Hi all, I have an xml and i would like to do some query to the xml. Is there any XPath API that i can use in java ? Currently using 1.4.2 Is there any other recommendations? Thanks