I have MAC OSX 10.5.8 and need to install adobe illustrator. I checked the compatibility and found that CS5 will work.Can any one help where i can find it. The trail version is fine with me.

I have MAC OSX 10.5.8 and need to install adobe illustrator. I checked the compatibility and found that CS5 will work.Can any one help where i can find it. The trail version is fine with me as i just have to use it for couple of days till i get my mac book back from service. Can any one help me on this.

You are welcome, ameronweb.
To elaborate a bit, you may come across offers of a new/unopened/unregistered version, which is the simplest case (you would need a guarantee). Other cases require much detailed information (and a guarantee).
If upgrading to 10.6.8 or higher is an option, you could use CS6.

Similar Messages

Maybe you are looking for

  • Creating an illustrator file from an indesign file

    Is there any way of exporting or turning an indesign file into an illustrator file. Not by exporting as a PDF or an EPS and then opening that in illustrator. I mean that in one step (through a third party plug-in in indesign maybe) an indesign file c

  • Importing Photos function no longer working

    I'm currently on the trial run of Adobe Story. Is there a limit as to how photos can be imported into a multi-column AV format. I've added 59 photos to my script and I don't know why I can't upload anymore photos into the system. I tried deleting a l

  • Takes Several Minutes to Start-up

    I rarely shut-down or restart my computer, but the battery was out of juice yesterday and the computer automatically shut-down. When I plugged the G4 in this morning and turned the computer on, it took 12 minutes for the computer to start-up. 3-4 min

  • I don't want to upgrade to 5.0 until my anti-virus software plug-n is compatible. How can I stop Firefox bugging me to upgrade every two days?

    The nag screen to make me update is coming up every two days when I click 'ask me later'. This is not 'later' in my book, it is going to take longer than two says for my av supplier to update their plug-in, I'll bet. Ok, I know in the grand scheme of

  • Urgent help ---   WAN boot installation error

    Hi I m trying to do wanboot on t2000 server after giving boot net - install i m getting this error , any thought , the wanboot server is fine I m able to install for other sever ++++++++++++++++++error messages ++++++++++++++++++ Rebooting with comma