Impossible to connect to an ssh server with Mysecureshell

Hi,
I have a SSH server (openssh) with MySecureShell and fail2ban installed.
When I try to connect as an user whose shell is MySecureShell, I got "permission denied" (in terminal) or "critical error, impossible to connect" in filezilla. As soon as I replace /bin/MySecureShell by /bin/bash in /etc/passwd, I am able to connect. When I desactivate fail2ban, nothing changes. The problem is thus likely to come from MySecureShell.
I append my /etc/ssh/sshd_config:
# $OpenBSD: sshd_config,v 1.89 2013/02/06 00:20:42 dtucker Exp $
# This is the sshd server system-wide configuration file. See
# sshd_config(5) for more information.
# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin
# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented. Uncommented options override the
# default value.
#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::
# The default requires explicit activation of protocol 1
#Protocol 2
# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 1024
# Logging
# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO
# Authentication:
#LoginGraceTime 2m
PermitRootLogin no
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10
#RSAAuthentication yes
#PubkeyAuthentication yes
# The default is to check both .ssh/authorized_keys and .ssh/authorized_keys2
# but this is overridden so installations will only check .ssh/authorized_keys
AuthorizedKeysFile .ssh/authorized_keys
#AuthorizedPrincipalsFile none
#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody
# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes
# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no
# Change to no to disable s/key passwords
ChallengeResponseAuthentication no
# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no
# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes
# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication. Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes
#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
PrintMotd no # pam does that
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
UsePrivilegeSeparation sandbox # Default for new installations.
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none
# no default banner path
#Banner none
# override default of no subsystems
Subsystem sftp /usr/lib/ssh/sftp-server
# Example of overriding settings on a per-user basis
#Match User anoncvs
# X11Forwarding no
# AllowTcpForwarding no
# ForceCommand cvs server
and my /etc/ssh/sftp_config:
## MySecureShell Configuration File ##
#Default rules for everybody
<Default>
GlobalDownload 0 #total speed download for all clients
# o -> bytes k -> kilo bytes m -> mega bytes
GlobalUpload 0 #total speed download for all clients (0 for unlimited)
Download 0 #limit speed download for each connection
Upload 0 #unlimit speed upload for each connection
StayAtHome true #limit client to his home
VirtualChroot true #fake a chroot to the home account
LimitConnection 10 #max connection for the server sftp
LimitConnectionByUser 10 #max connection for the account
LimitConnectionByIP 10 #max connection by ip for the account
Home /home/$USER #overrite home of the user but if you want you can use
# environment variable (ie: Home /home/$USER)
IdleTimeOut 5m #(in second) deconnect client is idle too long time
ResolveIP true #resolve ip to dns
# IgnoreHidden true #treat all hidden files as if they don't exist
# DirFakeUser true #Hide real file/directory owner (just change displayed permissions)
# DirFakeGroup true #Hide real file/directory group (just change displayed permissions)
# DirFakeMode 0400 #Hide real file/directory rights (just change displayed permissions)
#Add execution right for directory if read right is set
HideNoAccess true #Hide file/directory which user has no access
# MaxOpenFilesForUser 20 #limit user to open x files on same time
# MaxWriteFilesForUser 10 #limit user to x upload on same time
# MaxReadFilesForUser 10 #limit user to x download on same time
DefaultRights 0666 0777 #Set default rights for new file and new directory
# MinimumRights 0400 0700 #Set minimum rights for files and dirs
ShowLinksAsLinks false #show links as their destinations
# ConnectionMaxLife 1d #limits connection lifetime to 1 day
# Charset "ISO-8859-15" #set charset of computer
</Default>
#Rules only for group ftp
#<Group ftp>
# Download 25 k/s
# LogFile /var/log/sftp-server_ftp.log #Change logfile
# ExpireDate "2007-02-28 18:31:01"
#</Group>
#<Group sftp_administrator>
# IsAdmin true #can admin the server
# VirtualChroot false #you must disable chroot to have a full support of admin
# StayAtHome true
# IdleTimeOut 0
#</Group>
#<Group old_client>
# SftpProtocol 3 #force protocol SFTP
# DisableAccount true #disable account
#</Group>
#Rules only for group ftpnolimit
#<Group ftpnolimit>
# Download 0 #0 = unlimited
# IdleTimeOut 0 #no timeout
# DirFakeUser false #show real user on file/directory
# DirFakeGroup false #show real group on file/directory
# DirFakeMode 0 #show real rights on file/directory
# MaxReadFilesForUser 0 #0 = unlimited but still have the restriction MaxOpenFilesForUser
#</Group>
#<IpRange 192.168.0.1-192.168.0.5>
# ByPassGlobalDownload true #bypass GlobalDownload restriction
# ByPassGlobalUpload true #bypass GlobalUpload restriction
# Download 0
# DisableAccount false #enable account
# IdleTimeOut 0 #disable timeout
# LimitConnectionByIP 0 #no limit
#</IpRange>
#<Group trusted_users>
# Shell /bin/tcsh #give a shell access to TRUSTED clients !!!
#</Group>
#<VirtualHost *:22>
# DirFakeUser false #show real user on file/directory
# DirFakeGroup false #show real group on file/directory
# DirFakeMode 0 #show real rights on file/directory
# HideNoAccess false
# IgnoreHidden false
#</VirtualHost>
#Include /etc/my_sftp_config_file #include this valid configuration file
My installation is up to date.
Please let me know if you need supplementary info.
Last edited by Vincent D (2013-04-15 09:54:06)

Vincent D wrote:
Gat wrote:I'm getting the same error, but without using MySecureShell. The problem occurs with any script being placed in user's home directory and specified in /etc/passwd instead of /bin/bash. It's possible for a user to log in to bash and then run the script, so it doesn't seem to be a file permission problem.
Do you also get the "permission denied"?
My workaround is to purely remove MySecureShell, but this is not very safe.
Yes I'm also getting a permission denied error. I guess this might be something we need to set in PAM config, but I wasn't able to find it.

Similar Messages

  • How do I connect to a terminal server with my mac book pro

    How do I connect to a terminal server with my mac book pro

    Use the Remote Desktop icon on the tray and make sure to use the Fully Qualified Domain Name (FQDN) on the 'name of server' field.  If that does not work then use the IP address to connect.

  • My email account in Mail.app is IMAP, but when I delete emails, they don't delete from other devices connected to the mail server with IMAP. Deleted mail on other devices delete as normal from the server and thus from other devices as normal.

    MacBook Pro, late 2011 version. Up to date Mountain Lion.
    My email account in the Mail.app is set up as IMAP, but when I delete emails in the Mac Mail App, they are not deleted from the mail clients of the other devices that are connected to the mail server with IMAP. IMAP works perfectly between Windows Outlook 2010, iPad Mail App and Android default mail client. Deleted messages behave correctly, as in delete from one device and the mail is deleted from all devices.
    Having just tested in reverse order on the Mac; emails deleted from the email client on Windows, iPad and Android are not deleted in the Mac Mail App.  It appears that the account is behaving like POP rather than IMAP.
    Any advice on how to have IMAP work correctly on the MacBook Pro Mail.app?
    Thank you.

    Hi Csound1, thanks. The email host is 1and1.co.uk, however, i am going to fess up and make myself look like a plonker now -
    the email account in question was set up in Outlook as POP - stupid, stupid, stupid me, wasted an afternoon on this!  I have now changed the Outlook account to IMAP and Mail.app works perfectly - and looks much nicer than Outlook did.  Im in the middle of converting from Windows to a Mac, and still finding my way around the Mac
    The lesson learned, never assume - always double  check!  All my other email addresses with 1and1 are all imap, except this one, and it happened to be the first one I set up in the Mail.app. (bows head in disgrace!)
    Thank you anyway for attempting to help me!
    Cheers

  • Connect to a data server with topology manager

    Hi! I am new to ODI...
    I've created a master and work repository. Now I'm in topology manager to create a data server from Physical Architecture. I succeed in connecting to this data server with "Oracle Toad" using a service name...so I select JDBC driver and then I insert jdbc:oracle:oci8:@&lt;tns_alias&gt; (with the right service name).
    Then it give me the message that it can connect to the data server, but when i click ok, it says me:
    {color:#ff0000}java.lang.UnsatisfiedLinkError: no ocijdbc10 in java.library.path
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at oracle.jdbc.driver.T2CConnection.loadNativeLibrary(T2CConnection.java:3013)
    at oracle.jdbc.driver.T2CConnection.logon(T2CConnection.java:228)
    at oracle.jdbc.driver.PhysicalConnection.&lt;init&gt;(PhysicalConnection.java:361)
    at oracle.jdbc.driver.T2CConnection.&lt;init&gt;(T2CConnection.java:142)
    at oracle.jdbc.driver.T2CDriverExtension.getConnection(T2CDriverExtension.java:79)
    at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:595)
    at com.sunopsis.sql.SnpsConnection.u(SnpsConnection.java)
    at com.sunopsis.sql.SnpsConnection.a(SnpsConnection.java)
    at com.sunopsis.sql.SnpsConnection.testConnection(SnpsConnection.java)
    at com.sunopsis.sql.SnpsConnection.testConnection(SnpsConnection.java)
    at com.sunopsis.graphical.frame.b.jz.dP(jz.java)
    at com.sunopsis.graphical.frame.b.jz.bD(jz.java)
    at com.sunopsis.graphical.frame.bo.bz(bo.java)
    at com.sunopsis.graphical.frame.b.jz.em(jz.java)
    at com.sunopsis.graphical.frame.b.jz.&lt;init&gt;(jz.java)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at com.sunopsis.graphical.frame.bb.b(bb.java)
    at com.sunopsis.graphical.tools.utils.swingworker.v.call(v.java)
    at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
    at com.sunopsis.graphical.tools.utils.swingworker.l.run(l.java)
    at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
    at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
    at java.lang.Thread.run(Unknown Source)
    {color}
    My environment variable for Oracle are:
    C:\oracle\ora92\bin;C:\Programmi\Oracle\jre\1.3.1\bin;
    I succeed in connecting with OCI using Toad...why can't I connect with ODI? Need I to install another component? (and which?)
    Sorry for my english...please help me! thanks....
    Alessia
    Edited by: user1762560 on 26-feb-2009 9.06

    jdbc:oracle:oci8:@tns_alias
    it doesn't contain the sign '< ' or '>'

  • Can not connect to a remote SSH server with my mac

    Ok have tried 4 different applications, fetch , captain ftp, terminal, etc.
    I am trying and connect to a friends ssh server to upload some file logs. I have the correct login/password, have tried both protocol 1 and 2. Port 22 is correct. I keep getting the error message
    User logging error - captain ftp
    SFTP connection to ..... could not be opened becasue the connection to the SFTP server could not be established or was lost - Fetch
    sshexchangeidentification: Connection closed by remote host - Ternminal
    We have tested it using Telnet and other programs on a PC and all is well.
    When i try and connect he receives the message
    Refused connect from cpe-"ip address"(ip address)
    policy: HostKey/etc/ssh/sshhost_rsakey
    Do i have a setting somewhere i am missing.

    1st, is the server behind a home router? Has port 22 been "Port Forwarded" from the internet side to the server's side of the router?
    2nd, from a Terminal session use the command:
    ssh -v -v -v [email protected]
    The -v -v -v triplets will give you a wealth of ssh connection information. If you read through this carefully you may find the root cause of your problems (assuming the 1st step above doesn't yield results).
    Another thing to consider, is that ssh will not make a connection to an account that it does not consider to be reasonably secure. This means that the home directory of the account and specific key subdirectories must have proper ownership and permissions, or ssh will not connect. The specific ownership and permissions needed and the files and directories checked are spelled out in the ssh man page
    man ssh

  • Can not connect to Cerberus FTP Server with PASV

    I setup a FTP Server and i can connect from the inside fine but from the outside i can not connect in passive mode. I can in regular ftp or ssh.
    Here is the log from filezilla
    Status:          Resolving address of domain.com
    Status:          Connecting to ExternalIP:990...
    Status:          Connection established, initializing TLS...
    Status:          Verifying certificate...
    Status:          TLS/SSL connection established, waiting for welcome message...
    Response:          220-220-Welcome to Cerberus FTP Server
    Response:          220 220 Created by Cerberus, LLC
    Command:          USER test
    Response:          331 User test, password please
    Command:          PASS ***********
    Response:          230 Password Ok, User logged in
    Command:          CLNT FileZilla
    Response:          200 Command okay
    Command:          OPTS UTF8 ON
    Response:          220 UTF8 support on
    Command:          PBSZ 0
    Response:          200 PBSZ=0
    Command:          PROT P
    Response:          200 PROT P OK, data channel will be secured
    Status:          Connected
    Status:          Retrieving directory listing...
    Command:          PWD
    Response:          257 "/" is the current directory
    Command:          TYPE I
    Response:          200 Type Binary
    Command:          PASV
    Response:          227 Entering Passive Mode (external IP,195,83)
    Command:          MLSD
    Error:          Connection timed out
    Error:          Failed to retrieve directory listing
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.0(4)
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.10.10 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group att
    ip address pppoe setroute
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service FTP_PASV_Ports tcp
    description Passive Ports
    port-object range 35000 35999
    object-group service FTPS tcp
    description FTPS
    port-object eq 990
    access-list outside_access_in extended permit tcp any any object-group RDP
    access-list outside_access_in extended permit icmp any any
    access-list outside_access_in extended permit tcp any any eq ftp
    access-list outside_access_in extended permit tcp any any eq telnet
    access-list outside_access_in extended permit tcp any any eq smtp
    access-list outside_access_in extended permit tcp any any eq www
    access-list outside_access_in extended permit tcp any any eq pop3
    access-list outside_access_in extended permit tcp any any eq https
    access-list outside_access_in remark passive FTP port range
    access-list outside_access_in extended permit tcp any host server object-group FTP_PASV_Ports
    access-list outside_access_in extended permit tcp any any eq ssh
    access-list outside_access_in extended permit tcp any any object-group FTPS
    access-list outside_access_in extended permit tcp any any eq ftp-data
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1492
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-621.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface www server www netmask 255.255.255.255
    static (inside,outside) tcp interface https server https netmask 255.255.255.255
    static (inside,outside) tcp interface smtp server smtp netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 server 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface pop3 server pop3 netmask 255.255.255.255
    static (inside,outside) tcp interface ftp server ftp netmask 255.255.255.255
    static (inside,outside) tcp interface ssh server ssh netmask 255.255.255.255
    static (inside,outside) tcp interface 990 server 990 netmask 255.255.255.255
    static (inside,outside) tcp interface ftp-data server ftp-data netmask 255.255.255.255
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.10.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 5
    ssh 192.168.10.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    vpdn group att request dialout pppoe
    vpdn group att localname @static.sbcglobal.net
    vpdn group att ppp authentication pap
    vpdn username @static.sbcglobal.net password *********
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    username admin password rcuFiQnIXLd encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:ecb5356a2f5e680b
    : end
    I am programing the router with ASDM so if you could tell me what i need to do from the GUI to fix this.

    Dan,
    Looking at the output,
    Status:          Resolving address of domain.com
    Status:          Connecting to ExternalIP:990...
    Status:          Connection established, initializing TLS...
    Status:          Verifying certificate...
    Status:          TLS/SSL connection established, waiting for welcome message...
    This looks like FTPS which is not supported on the ASA. You can workaround it by trying to connect using Active mode from the outside instead of PSV.
    You can find more info here:
    https://supportforums.cisco.com/docs/DOC-23206
    Mike

  • Trouble connecting to MS Exchange server with IMAP

    I've been trying to setup Apple mail to talk with the Exchange server at work.
    I've had no luck after many attempts.
    Mac Mini, Intel Core Duo
    OS X 10.4.5
    Mail 2.0.6
    I can connect to the mail server using Safari via Outlook Web Access fine, so my account information must be good...
    The sys admin at work, though not Mac savvy, said to use IMAP.
    A few other Mac users at work have gotten this to work from their homes with no hassles but non of their suggestions have helped.
    The account parameters are:
    General Information
    Account Type: IMAP
    Account Description: IMAP Account
    Fill Name: First-name Last-name
    Email Address: <user>@<domain>.com
    Incoming Mail Server
    Incoming Mail Server: mail.<domain>.com
    User Name: <windows-domainname>\user
    Password: <password>
    After this window I click Continue and wait ....
    Eventually Mail times out with the message:
    The IMAP server mail.<domain>.com is not responding ...
    Can someone help ...
    Some related questions:
    Do I need have the VPN to work established for Mail to work ?
    I've tried it both ways and they both fail.
    How do I get additional debug/log information out of mail ?
    What is the difference between an Exchange account and an IMAP account ?

    Try enabling a secure connection to the IMAP-server in account setup (which also should change the port to be used).
    Try using the servername found in the WebAccess URL (http://servername/exchange) instead of mail.<domain>.com if it is different.
    Try using user@windows-domainname instead of windows-domainname\user.
    If this all does not help, be sure to enable your AD-account for IMAP-access. This is a per account configuration. Just installing the IMAP-connector on the Exchange-server does not grant IMAP-access to everybody.

  • Can not connect to ther admin server with t3s in the WLST

    Hi,
    Our server face a strange problem.
    We want to add SSL to our server, and I have set the SSL linsten port enabled, an we can access the admin console with https protocol and SSL listen port.
    Then I want to manage the server with
    ##start WLST with DemoTrust enable
    java -Dweblogic.security.SSL.ignoreHostnameVerification=true -Dweblogic.security.TrustKeyStore=DemoTrust weblogic.WLST
    ##connect
    If I use
    connect('system','testAdmin','t3://xxxx:10001')
    ##this can connect successful.
    If I use
    connect('system','testAdmin','t3s://xxxx:10002')
    It will cause an error
    WLSTException: Error occured while performing connect : Error getting the initial context. There is no server running at t3s://xxxx:10002 Use dumpStack() to view the full stacktrace
    I both enabled plain and SSL listen port and I can access the admin console with http and https without problem. But why I just can not use t3s to connect the server in the WLST? Is there any setting related this? Please advise, thanks.
    Here is the dumpStack()
    javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3s://xxxx:10002: Destination unreachable; nested exception is:
            java.io.IOException: Stream closed.; No available router to destination]
    at weblogic.jndi.internal.ExceptionTranslator.toNamingException(ExceptionTranslator.java:40)
    at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLInitialContextFactoryDelegate.java:783)
    at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:365)
    at weblogic.jndi.Environment.getContext(Environment.java:315)
    at weblogic.jndi.Environment.getContext(Environment.java:285)
    at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:117)
    at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:667)
    at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288)
    at javax.naming.InitialContext.init(InitialContext.java:223)
    at javax.naming.InitialContext.<init>(InitialContext.java:197)
    at weblogic.management.scripting.WLSTHelper.populateInitialContext(WLSTHelper.java:512)
    at weblogic.management.scripting.WLSTHelper.initDeprecatedConnection(WLSTHelper.java:565)
    at weblogic.management.scripting.WLSTHelper.initConnections(WLSTHelper.java:305)
    at weblogic.management.scripting.WLSTHelper.connect(WLSTHelper.java:203)
    at weblogic.management.scripting.WLScriptContext.connect(WLScriptContext.java:60)
    at weblogic.management.scripting.utils.WLSTUtil.initializeOnlineWLST(WLSTUtil.java:125)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.python.core.PyReflectedFunction.__call__(PyReflectedFunction.java:160)
    at org.python.core.PyMethod.__call__(PyMethod.java:96)
    at org.python.core.PyObject.__call__(PyObject.java:248)
    at org.python.core.PyObject.invoke(PyObject.java:2016)
    at org.python.pycode._pyx4.connect$1(<iostream>:16)
    at org.python.pycode._pyx4.call_function(<iostream>)
    at org.python.core.PyTableCode.call(PyTableCode.java:208)
    at org.python.core.PyTableCode.call(PyTableCode.java:404)
    at org.python.core.PyTableCode.call(PyTableCode.java:287)
    at org.python.core.PyFunction.__call__(PyFunction.java:179)
    at org.python.pycode._pyx15.f$0(<console>:1)
    at org.python.pycode._pyx15.call_function(<console>)
    at org.python.core.PyTableCode.call(PyTableCode.java:208)
    at org.python.core.PyCode.call(PyCode.java:14)
    at org.python.core.Py.runCode(Py.java:1135)
    at org.python.core.Py.exec(Py.java:1157)
    at org.python.util.PythonInterpreter.exec(PythonInterpreter.java:148)
    at org.python.util.InteractiveInterpreter.runcode(InteractiveInterpreter.java:89)
    at org.python.util.InteractiveInterpreter.runsource(InteractiveInterpreter.java:70)
    at org.python.util.InteractiveInterpreter.runsource(InteractiveInterpreter.java:44)
    at weblogic.management.scripting.WLST.main(WLST.java:178)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at weblogic.WLST.main(WLST.java:29)
    Caused by: java.net.ConnectException: t3s://xxxx:10002: Destination unreachable; nested exception is:
    java.io.IOException: Stream closed.; No available router to destination
    at weblogic.rjvm.RJVMFinder.findOrCreate(RJVMFinder.java:203)
    at weblogic.rjvm.ServerURL.findOrCreateRJVM(ServerURL.java:153)
    at weblogic.jndi.WLInitialContextFactoryDelegate$1.run(WLInitialContextFactoryDelegate.java:344)
    at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
    at weblogic.security.service.SecurityManager.runAs(Unknown Source)
    at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:339)
    ... 43 more
    Caused by: java.rmi.ConnectException: Destination unreachable; nested exception is:
    java.io.IOException: Stream closed.; No available router to destination
    at weblogic.rjvm.ConnectionManager.bootstrap(ConnectionManager.java:464)
    at weblogic.rjvm.ConnectionManager.bootstrap(ConnectionManager.java:315)
    at weblogic.rjvm.RJVMManager.findOrCreateRemoteInternal(RJVMManager.java:251)
    at weblogic.rjvm.RJVMManager.findOrCreate(RJVMManager.java:194)
    at weblogic.rjvm.RJVMFinder.findOrCreateRemoteServer(RJVMFinder.java:225)
    at weblogic.rjvm.RJVMFinder.findOrCreate(RJVMFinder.java:188)
    ... 48 more
    Edited by: Kaos on Feb 25, 2010 12:06 AM

    Jai/Faisal,
    One strange thing i observe, i tried connecting to admin server through WLST, it works for first time and again it gave me the error next (Connecting alternatively).
    the error message which i am getting:
    This Exception occurred at Thu Jun 10 08:19:39 CDT 2010.
    javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3s://mo8xdwls0018.bankofamerica.com:8933: Destination unreachable; nested exception is:
            java.io.IOException: Stream closed.; No available router to destination]
    at weblogic.jndi.internal.ExceptionTranslator.toNamingException(ExceptionTranslator.java:40)
    at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLInitialContextFactoryDelegate.java:783)
    at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:365)
    at weblogic.jndi.Environment.getContext(Environment.java:315)
    at weblogic.jndi.Environment.getContext(Environment.java:285)
    at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:117)
    at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:667)
    at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288)
    at javax.naming.InitialContext.init(InitialContext.java:223)
    at javax.naming.InitialContext.<init>(InitialContext.java:197)
    at weblogic.management.scripting.WLSTHelper.populateInitialContext(WLSTHelper.java:512)
    at weblogic.management.scripting.WLSTHelper.initDeprecatedConnection(WLSTHelper.java:565)
    at weblogic.management.scripting.WLSTHelper.initConnections(WLSTHelper.java:305)
    at weblogic.management.scripting.WLSTHelper.connect(WLSTHelper.java:203)
    at weblogic.management.scripting.WLScriptContext.connect(WLScriptContext.java:60)
    at weblogic.management.scripting.utils.WLSTUtil.initializeOnlineWLST(WLSTUtil.java:125)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.python.core.PyReflectedFunction.__call__(PyReflectedFunction.java:160)
    at org.python.core.PyMethod.__call__(PyMethod.java:96)
    we are connecting to t3s://mo8xdwls0018.bankofamerica.com:8933.
    Any help would be appreciated.
    -Vishal Iyer

  • Ssh server with keys for authentication?

    Anyone have a link to doco or tutorial that covers how to setup an ssh server running on your Mac (latest version OSX) such that:
    * assumption - port forward ssh port on your home gateway to your Mac
    * keys established (for better security) - i.e. need to have the key available on your external PC when wanting to ssh back to home
    * custom ssh port
    * only access ssh requires for logon from predefined external IP addresses (or perhaps this is something you'll setup on your home internet gateway/router along with port forwarding)

    hi kbwrecker,
    as i know, sharepoint will as well follow the diagram that you posted before, additional article
    https://technet.microsoft.com/en-us/library/cc262350(v=office.15).aspx#plansaml
    i checked with our ADFS engineer, the certificate is to sign the token, so, it should not have any relation directly to each of the realm.
    i am not quite sure on how this ADFS and token signing, will work that deep, as from sharepoint side, we may need only the certificate that is valid, and update them to our environment, to make it work.
    for more details regarding this issue, you may try to open a thread as well in the ADFS thread for this.
    based on the additional article, your design may able to work, but we encourage you to seek more deep answer in ADFS forum thread
    https://technet.microsoft.com/en-us/windowsserver/dd448613.aspx
    Regards,
    Aries
    Microsoft Online Community Support
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

  • How to connect Crystal Report 2008 server with SAP BI/BW server

    Hi ,
    I have downloaded the 60 Days trial version of  "Crystal Report 2008 Server' from sap site to my machine. Now i would like to connect this Crystal server with SAP BI and want to use the data of BI Bex queries and Infoproviders.
    Can you please guide me how to connect them?
    Aslo how can i get the free trial version of Intergration kit ..here please provide me the entire full path of site(to download the Integration Kit).....
    Any inputs would be appreciated!!
    Regards,
    Naween

    Hi Michelle,
    Older versions of CR would allow you to run CR from a network share point but you still had to have a license for each user. Current versions of CR do not allow you to do this any more, possibly using a Citrix or Terminal Server would allow this but you still need a license for each user. Older versions had a Network install option.
    And as suggested exporting to PDF or some other format is fine for end users viewing your output. They are not using CR but Adobe Reader or Word etc. to view the reports, they just can't use the Designer to view the reports.
    Hope this is clear now?
    Thank you
    Don

  • Connection to a Unix-Server with Java

    Hi!
    I've got a little problem! I must write a java programm that connects to a unix-server! The programm should connect to the server and writes a command like "ls"! How can I do this? Can someone help me?
    Thanks Flyer2004

    Hi,
    something to help you with your assignment.
    The code below will connect to a server on a port.
    public void run() {
    try
    Socket socket = new Socket( "abc.com" , 13312 );
    System.out.println( "Connected to the server" );
    PrintWriter pw = new PrintWriter( socket.getOutputStream(), true );
    BufferedReader stdIn = new BufferedReader( new InputStreamReader(System.in) );
    BufferedReader in = new BufferedReader( new InputStreamReader( socket.getInputStream() ) );
    String userInput;
    while ( (userInput = stdIn.readLine()) != null ) {
    pw.println( userInput );
    System.out.println("echo: " + in.readLine() );
    catch ( Exception ex )
    ex.printStackTrace();     
    you can use this code to connect to a port.
    now comes the server part.....
    ServerSocket serverSocket = new ServerSocket( 7777 );
    FileInputStream fis = new FileInputStream( "test.dat" );
    Socket socket = serverSocket.accept();
    OutputStream os = socket.getOutputStream();
    byte[] buffer = new byte[1024];
    int bytes = 0 ;
    int i = 0 ;
    while( ( bytes = fis.read( buffer ) ) != -1 ) {
    os.write( buffer, 0, bytes );
    os.flush();
    i++ ;
    System.out.println( "bytes sent : " + i + " KB " ) ;
    os.close();
    fis.close();
    The code above post's the file back...
    in your case you want the output of your command so use "Runtime.runexec" and run your command on the server..
    use the above code and replace the file downloading part with your code....
    send back the output of the same to the client...
    just in case ...
    if you want to do any random commands... you need to let your server knwo that and the code for that needs to be persent on the system.
    by the way this is pure vanilla and it needs to be modified a lot.
    Regards,
    myraid

  • Want to connect to client's server with ARD, and run ARD on the server.

    Hi, I have Apple Remote Desktop and use it to monitor, update and service clients servers. I also have client's buy ARD to use internally to access, update and maintain computers on the network.
    When I try to access/sign-in to a server with ARD, when it's running ARD, it will not connect.
    What is the proper way to ARD into a server and still be able to run ARD on the server to connect with and work on other computers on the local network?
    Thanks in advance.

    On the client server install of ARD, open ARD, select preferences, select security tab, and make sure "allow control of this computer when ARD is running" is selected.

  • Cann't connect to nokia map server with nokia suit...

    this is very seriously problem,because i have problem to connect to map server,a view minute download, it seem have speed 2,4 mbps, but it stop and say, "you work in ofline mode". Any body can help me for solve this problem???

    Need to know what device you are using here as in a last resort you could always download map data as compressed .zip, decompress it and install manually. It sounds as if you have a very poor internet connection and it is timing out.
    Happy to have helped forum in a small way with a Support Ratio = 37.0

  • How to connect a remote Oracle Server with its IP

    is it possible to connect Oracle SerVer in VC
    I have used Microsoft ODBC driver for oracle and Oracle odbc driver to test in VC++6.0,
    but SQLDriverConnect, OCI methods failed.

    with VC++ an odbc driver for oracle is also installed with which u can connect to oracle db all u need to know is the database SID or oracle server name
    try doing this it will work hopefully
    regards

  • Connecting to MS SQL Server with JTDS DBC Driver version 11.1.58.17

    The version 1.5.4 supposed to allow you to connect to SQL Servers (JTDS DBC Driver version 11.1.58.17) but in fact you cannot. That is, even to SQL Express2005.
    The earlier JTDS could in fact supported connecting to SQL Server 2005 as well as SQL Express as I wrote in my earlier article,
    http://www.packtpub.com/article/oracle-sql-developer-tool-1.5-sql-server-2005
    The new driver does not enable the connection with similar syntax while connecting to SQL Server 2005. Is it a problem with the driver?

    Thanks a lot.
    That appears to be a good link. Why does this process have to be so convoluted? First of all the user is directed to something that is not going to work (I mean the Oracle's JTDS 11.1.58.17 stuff) and to use Source Forge you need to do further work. Does not make sense from the usability point of view, does it?
    Anyway is SQL Server 2008 is supported in this version?

Maybe you are looking for

  • Purchase price vaiance of certain materials to Separate GL account

    Hi, Is it possible to allocate purchase price variance of only certain materials to a separate GL account? If so, what configuration needs to be done. Thanks for your help. Ram

  • Formatting and alignment issues in Crystal Reports when exported to PDF

    Hi Experts, When we export the crystal reports 2013 reports to PDF we are facing issues with formatting and alignment. The columns are overlapping and also for some column's data, we are able to see only some parts of text when exported to PDF. Data

  • Commas in speed dials

    Good morning experts - We are on Call Manager 10.5 and I am trying to use commas in a speed dial for our long distance calls. We have authorization codes set up through our long distance vendor (not auth codes in Call Manager) so that after a long di

  • IPOD Video converting

    Problem with NERO RECODE 2: I have Nero Recode 2 and i try to convert a dvd. I only can convert with the Profil"PSP" for the Playstation Why it´s not possible to us another profil? thanks for your help rene´

  • Updating to 4.2.8: Error 3194 iTunes

    Error 3194: Resolve error 3194 by updating to the latest version of iTunes. "This device is not eligible for the requested build" in the updater logs confirms this is the root of the issue. For more Error 3194 steps see: This device is not eligible f