JAAS client access instead of JNDI

Hi,
I'm exploring using the JAAS client access instead of JNDI access on WL7.
The Docs say I have to write a LoginModule. However, the following
appears to work too (and of course, I'm not using a LoginModule):
     Environment env = new Environment();
          env.setProviderUrl(url);
          env.setSecurityPrincipal(username);
          env.setSecurityCredentials(password);
          Subject sub = new Subject();
          Authenticate.authenticate(env,sub);
          System.err.println("SUBJECT IS " + sub.toString());
          SampleAction sampleAction = new SampleAction(url);
          Security.runAs(sub, sampleAction);
The LoginModule approach just appears to be a convoluted way of doing
the same thing, so why do I need it?
Also, the WebLogic examples do all sorts of strange things in their
example LoginModule, like their commit does this:
final PasswordCredential passwordCred = new
PasswordCredential(username, password);
AccessController.doPrivileged(new PrivilegedAction() {
public java.lang.Object run() {
subject.getPrivateCredentials().add(passwordCred);
return null;
(see http://edocs.bea.com/wls/docs70/security/fat_client.html#1029441)
Surely this is not necessary - cos the actuall login call to
Authenticate.authenticate would have populated the subject properly.
Any ideas? TIA.
Q

You may want to read "Small Footprint Client Options for BEA WebLogic Server"
paper (http://dev2dev.bea.com/resourcelibrary/whitepapers.jsp?highlight=whitepapers)
Madhu <[email protected]> wrote:
infact for a remote client to access the EJB, what are the necessary jar/files
needed apart from the myejb.jar.
Do we need to copy the complete weblogic.jar and weblogic/classes folder?
"Madhu" <[email protected]> wrote:
Even i have the same problem. I had to copy the weblogic.jar, and all
the weblogic/classes
folder to the client machine.
I am thinking that this is a wrong process, and the jndi.jar is sufficient
enough
to make a lookup of home objects.
I would appreciate If anyone has any solution other than copying the
complete
40M bytes.
-Madhu
Dimitri

Similar Messages

  • [Fwd: Client accessing MBeanHome for more than one domain receives SecurityException]

    Fwd'ing to security newsgroup
    -------- Original Message --------
    Subject: Client accessing MBeanHome for more than one domain receives
    SecurityException
    Date: 4 Mar 2004 07:27:33 -0800
    From: Dinesh Bhat <[email protected]>
    Reply-To: Dinesh Bhat <[email protected]>
    Organization: BEA NEWS SITE
    Newsgroups: weblogic.developer.interest.management
    Hi,
    When a client accesses MBeans of more than one domains (Weblogic 8.1)
    that have
    different passwords, it receives a SecurityException. This occurs when
    the MBeanHome
    for each domain is looked up at initialization and reused for each
    request ( to
    access MBeans ). The security exception does not occur if the MBeanHome
    for each
    domain is looked up for each request. On initial review, this behavoir
    seems inconsistent.
    Looking up the MBeanHome for each request may introduce a significant
    overhead.
    I am not sure if concurrent lookups would also cause the same problem.
    I have read on another post that we can work around this problem by
    establishing
    a trust relationship between the servers, but this may not be feasible
    when one
    is monitoring a lot of servers and the overhead of configuration may be
    an issue.
    I have attached code that can reproduce the problem.
    Please advise on the correct approach.
    Thanks
    Dinesh Bhat
    Panacya Inc.
    import java.util.ArrayList;
    import java.util.Set;
    import java.util.HashMap;
    import java.util.Iterator;
    import java.util.Hashtable;
    import javax.management.MBeanServer;
    import javax.naming.Context;
    import weblogic.jndi.Environment;
    import weblogic.management.MBeanHome;
    * This class reproduces the Security Exception that is caused when a client tries to access
    * MBeans of more than one domain with different weblogic passwords. Here is the stacktrace of the
    * exception
    * java.lang.SecurityException: [Security:090398]Invalid Subject: principals=[weblogic, Administrators]
         at weblogic.rjvm.BasicOutboundRequest.sendReceive(BasicOutboundRequest.java:108)
         at weblogic.rmi.internal.BasicRemoteRef.invoke(BasicRemoteRef.java:138)
         at weblogic.management.internal.AdminMBeanHomeImpl_811_WLStub.getDomainName(Unknown Source)
         at WLSecurityTest.getWeblogicInfo(WLSecurityTest.java:140)
         at WLSecurityTest.runTest(WLSecurityTest.java:75)
         at WLSecurityTest.<init>(WLSecurityTest.java:66)
         at WLSecurityTest.main(WLSecurityTest.java:51)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:324)
         at com.intellij.rt.execution.application.AppMain.main(Unknown Source)
    Caused by: java.lang.SecurityException: [Security:090398]Invalid Subject: principals=[weblogic, Administrators]
         at weblogic.security.service.SecurityServiceManager.seal(SecurityServiceManager.java:682)
         at weblogic.rjvm.MsgAbbrevInputStream.getSubject(MsgAbbrevInputStream.java:181)
         at weblogic.rmi.internal.BasicServerRef.acceptRequest(BasicServerRef.java:814)
         at weblogic.rmi.internal.BasicServerRef.dispatch(BasicServerRef.java:299)
         at weblogic.rjvm.RJVMImpl.dispatchRequest(RJVMImpl.java:920)
         at weblogic.rjvm.RJVMImpl.dispatch(RJVMImpl.java:841)
         at weblogic.rjvm.ConnectionManagerServer.handleRJVM(ConnectionManagerServer.java:222)
         at weblogic.rjvm.ConnectionManager.dispatch(ConnectionManager.java:794)
         at weblogic.rjvm.t3.T3JVMConnection.dispatch(T3JVMConnection.java:570)
         at weblogic.socket.NTSocketMuxer.processSockets(NTSocketMuxer.java:105)
         at weblogic.socket.SocketReaderRequest.execute(SocketReaderRequest.java:32)
         at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:197)
         at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:170)
    * Note: the exception is caused only when the MBeanHome for each domain is cached and used for subsequent
    * transactions. The exception does not occur if the MBeanHome for each domain is looked up for each transaction. This
    * would significant overhead in practice. Also the transactions across the various domains occurs serially, hence
    * the effect of concurrent lookups has to be tested.
    * Usage:
    * This class has been tested with weblogic 8.1
    * The class needs weblogic.jar in its classpath
    * One can specify the weblogic details as System properties. The properties need to be specified in
    * the following format:
    * wls.host.n, wls.userId.n, wls.password.n where n is the weblogix instance number. Also specify
    * the boolean system property reconnect.each.iteration to toggle between reconnecting or not reconnecting
    * for each iteration. When not reconnecting for each iteration, the MBeanHome is reused and the Security Exception
    * occurs.
    * Following is the example of system properties
    * -Dwls.host.0=localhost:7001 -Dwls.userId.0=weblogic -Dwls.password.0=weblogic
    * -Dwls.host.1=localhost:7011 -Dwls.userId.1=weblogic -Dwls.password.1=weblogic1
    * -Dwls.host.2=localhost:7021 -Dwls.userId.2=weblogic -Dwls.password.2=weblogic2
    * -Dreconnect.each.iteration=false
    public class WLSecurityTest
    ArrayList wlsDetailsList = new ArrayList();
    HashMap connectionMap = new HashMap();
    public static void main(String[] args)
    try
    WLSecurityTest wlSecurityTest = new WLSecurityTest();
    catch (Exception e)
    e.printStackTrace();
    * Constructor
    * @throws Exception
    public WLSecurityTest() throws Exception
    int noOfTries = 10;
    getWLSDetails();
    for( int i=0; i <= noOfTries; i++)
    runTest();
    * Runs the test
    private void runTest()
    for (int i = 0; i < wlsDetailsList.size(); i++)
    WLSDetails wlsDetails = (WLSDetails) wlsDetailsList.get(i);
    getWeblogicInfo(wlsDetails);
    * Get Weblogic details from System properties
    * @throws Exception
    private void getWLSDetails() throws Exception
    wlsDetailsList = new ArrayList();
    String hostKeyTmpl = "wls.host";
    String userIdKeyTmpl = "wls.userId";
    String passwordKeyTmpl = "wls.password";
    boolean done = false;
    for (int i = 0; !done; i++)
    WLSDetails wlsDetails = new WLSDetails();
    String hostKey = hostKeyTmpl + "." + Integer.toString(i);
    String userIdKey = userIdKeyTmpl + "." + Integer.toString(i);
    String passwordKey = passwordKeyTmpl + "." + Integer.toString(i);
    wlsDetails.hostName = System.getProperty(hostKey);
    done = (wlsDetails.hostName == null) || (wlsDetails.hostName.length() == 0);
    if (!done)
    wlsDetails.userId = System.getProperty(userIdKey);
    wlsDetails.password = System.getProperty(passwordKey);
    connect(wlsDetails);
    wlsDetailsList.add(wlsDetails);
    * Lookup the MBeanHome for the specified weblogic server
    * @param wlsDetails
    * @throws Exception
    public synchronized void connect(WLSecurityTest.WLSDetails wlsDetails) throws Exception
    Context ctx = null;
    MBeanHome mbHomeLocal = null;
    try
    Environment env = new Environment();
    env.setProviderUrl("t3://" + wlsDetails.hostName);
    env.setSecurityPrincipal(wlsDetails.userId);
    env.setSecurityCredentials(wlsDetails.password);
    Hashtable hashtable = env.getProperties();
    System.out.println(hashtable.toString());
    ctx = env.getInitialContext();
    wlsDetails._mBeanHome = (MBeanHome) ctx.lookup(MBeanHome.ADMIN_JNDI_NAME);
    catch (Exception e)
    e.printStackTrace();
    * Gets weblogic information using MBeans
    * @param wlsDetails
    public synchronized void getWeblogicInfo(WLSDetails wlsDetails)
    try
    boolean reconnectEachIteration =
    Boolean.getBoolean("reconnect.each.iteration");
    if( (reconnectEachIteration) || ((wlsDetails._mBeanHome == null) && (!reconnectEachIteration) ))
    connect(wlsDetails);
    MBeanHome mbHomeLocal = wlsDetails._mBeanHome;
    String domainName = mbHomeLocal.getDomainName();
    Set allMBeans = mbHomeLocal.getAllMBeans();
    System.out.println("Size: " + allMBeans.size());
    Set clusterMBeans = mbHomeLocal.getMBeansByType("Cluster", domainName);
    System.out.println(clusterMBeans);
    MBeanServer mBeanServer = mbHomeLocal.getMBeanServer();
    catch (Exception ex)
    ex.printStackTrace();
    * Class that holds weblogic server details
    class WLSDetails
    String hostName = "";
    String userId = "";
    String password = "";
    MBeanHome _mBeanHome = null;

    If Server version is 61.
    Make user "system" password of all weblogic servers same.
    If Server version above 61(70,81)
    In the Security Advanced Settings un check generated credential and specify a common credentail for all the weblogic servers(domains).

  • AnyConnect error " User not authorized for AnyConnect Client access, contact your administrator"

    Hi everyone,
    it's probably just me but I have tried real hard to get a simple AnyConnect setup working in a lab environment on my ASA 5505 at home, without luck. When I connect with the AnyConnect client I get the error message "User not authorized for AnyConnect Client access, contact your administrator". I have searched for this error and tried some of the few solutions out there, but to no avail. I also updated the ASA from 8.4.4(1) to 9.1(1) and ASDM from 6.4(9) to 7.1(1) but still the same problem. The setup of the ASA is straight forward, directly connected to the Internet with a 10.0.1.0 / 24 subnet on the inside and an address pool of 10.0.2.0 / 24 to assign to the VPN clients. Please note that due to ISP restrictions, I'm using port 44455 instead of 443. I had AnyConnect working with the SSL portal, but IKEv2 IPsec is giving me a headache. I have stripped down certificate authentication which I had running before just to eliminate this as a potential cause of the issue. When running debugging, I do not get any error messages - the handshake completes successfully and the local authentication works fine as well.
    Please find the current config and debugging output below. I appreciate any pointers as to what might be wrong here.
    : Saved
    ASA Version 9.1(1)
    hostname ASA
    domain-name ingo.local
    enable password ... encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd ... encrypted
    names
    name 10.0.1.0 LAN-10-0-1-x
    dns-guard
    ip local pool VPNPool 10.0.2.1-10.0.2.10 mask 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif Internal
    security-level 100
    ip address 10.0.1.254 255.255.255.0
    interface Vlan2
    nameif External
    security-level 0
    ip address dhcp setroute
    regex BlockFacebook "facebook.com"
    banner login This is a monitored system. Unauthorized access is prohibited.
    boot system disk0:/asa911-k8.bin
    ftp mode passive
    clock timezone PST -8
    clock summer-time PDT recurring
    dns domain-lookup Internal
    dns domain-lookup External
    dns server-group DefaultDNS
    name-server 10.0.1.11
    name-server 75.153.176.1
    name-server 75.153.176.9
    domain-name ingo.local
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network LAN-10-0-1-x
    subnet 10.0.1.0 255.255.255.0
    object network Company-IP1
    host xxx.xxx.xxx.xxx
    object network Company-IP2
    host xxx.xxx.xxx.xxx
    object network HYPER-V-DUAL-IP
    range 10.0.1.1 10.0.1.2
    object network LAN-10-0-1-X
    access-list 100 extended permit tcp any4 object HYPER-V-DUAL-IP eq 3389 inactive
    access-list 100 extended permit tcp object Company-IP1 object HYPER-V-DUAL-IP eq 3389
    access-list 100 extended permit tcp object Company-IP2 object HYPER-V-DUAL-IP eq 3389 
    tcp-map Normalizer
      check-retransmission
      checksum-verification
    no pager
    logging enable
    logging timestamp
    logging list Threats message 106023
    logging list Threats message 106100
    logging list Threats message 106015
    logging list Threats message 106021
    logging list Threats message 401004
    logging buffered errors
    logging trap Threats
    logging asdm debugging
    logging device-id hostname
    logging host Internal 10.0.1.11 format emblem
    logging ftp-bufferwrap
    logging ftp-server 10.0.1.11 / asa *****
    logging permit-hostdown
    mtu Internal 1500
    mtu External 1500
    ip verify reverse-path interface Internal
    ip verify reverse-path interface External
    icmp unreachable rate-limit 1 burst-size 1
    icmp deny any echo External
    asdm image disk0:/asdm-711.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (Internal,External) dynamic interface
    object network LAN-10-0-1-x
    nat (Internal,External) dynamic interface
    object network HYPER-V-DUAL-IP
    nat (Internal,External) static interface service tcp 3389 3389
    access-group 100 in interface External
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server radius protocol radius
    aaa-server radius (Internal) host 10.0.1.11
    key *****
    radius-common-pw *****
    user-identity default-domain LOCAL
    aaa authentication ssh console radius LOCAL
    http server enable
    http LAN-10-0-1-x 255.255.255.0 Internal
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto ipsec security-association pmtu-aging infinite
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map External_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map External_map interface External
    crypto ca trustpoint srv01_trustpoint
    enrollment terminal
    crl configure
    crypto ca trustpoint asa_cert_trustpoint
    keypair asa_cert_trustpoint
    crl configure
    crypto ca trustpoint LOCAL-CA-SERVER
    keypair LOCAL-CA-SERVER
    crl configure
    crypto ca trustpool policy
    crypto ca server
    cdp-url http://.../+CSCOCA+/asa_ca.crl:44435
    issuer-name CN=...
    database path disk0:/LOCAL_CA_SERVER/
    smtp from-address ...
    publish-crl External 44436
    crypto ca certificate chain srv01_trustpoint
    certificate <output omitted>
      quit
    crypto ca certificate chain asa_cert_trustpoint
    certificate <output omitted>
      quit
    crypto ca certificate chain LOCAL-CA-SERVER
    certificate <output omitted>
      quit
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable External client-services port 44455
    crypto ikev2 remote-access trustpoint asa_cert_trustpoint
    telnet timeout 5
    ssh LAN-10-0-1-x 255.255.255.0 Internal
    ssh xxx.xxx.xxx.xxx 255.255.255.255 External
    ssh xxx.xxx.xxx.xxx 255.255.255.255 External
    ssh timeout 5
    ssh version 2
    console timeout 0
    no vpn-addr-assign aaa
    no ipv6-vpn-addr-assign aaa
    no ipv6-vpn-addr-assign local
    dhcpd dns 75.153.176.9 75.153.176.1
    dhcpd domain ingo.local
    dhcpd option 3 ip 10.0.1.254
    dhcpd address 10.0.1.50-10.0.1.81 Internal
    dhcpd enable Internal
    threat-detection basic-threat
    threat-detection scanning-threat shun except ip-address LAN-10-0-1-x 255.255.255.0
    threat-detection statistics access-list
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    dynamic-filter use-database
    dynamic-filter enable interface Internal
    dynamic-filter enable interface External
    dynamic-filter drop blacklist interface Internal
    dynamic-filter drop blacklist interface External
    ntp server 128.233.3.101 source External
    ntp server 128.233.3.100 source External prefer
    ntp server 204.152.184.72 source External
    ntp server 192.6.38.127 source External
    ssl encryption aes256-sha1 aes128-sha1 3des-sha1
    ssl trust-point asa_cert_trustpoint External
    webvpn
    port 44433
    enable External
    dtls port 44433
    anyconnect image disk0:/anyconnect-win-3.1.02026-k9.pkg 1
    anyconnect profiles profile1 disk0:/profile1.xml
    anyconnect enable
    smart-tunnel list SmartTunnelList1 mstsc mstsc.exe platform windows
    smart-tunnel list SmartTunnelList1 putty putty.exe platform windows
    group-policy DfltGrpPolicy attributes
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec ssl-client ssl-clientless
    webvpn
      anyconnect profiles value profile1 type user
    username write.ingo password ... encrypted
    username ingo password ... encrypted privilege 15
    username tom.tucker password ... encrypted
    class-map TCP
    match port tcp range 1 65535
    class-map type regex match-any BlockFacebook
    match regex BlockFacebook
    class-map type inspect http match-all BlockDomains
    match request header host regex class BlockFacebook
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 1500
      id-randomization
    policy-map TCP
    class TCP
      set connection conn-max 1000 embryonic-conn-max 1000 per-client-max 250 per-client-embryonic-max 250
      set connection timeout dcd
      set connection advanced-options Normalizer
      set connection decrement-ttl
    policy-map type inspect http HTTP
    parameters
      protocol-violation action drop-connection log
    class BlockDomains
    policy-map global_policy
    class inspection_default
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect dns preset_dns_map dynamic-filter-snoop
      inspect http HTTP
    service-policy global_policy global
    service-policy TCP interface External
    smtp-server 199.185.220.249
    privilege cmd level 3 mode exec command perfmon
    privilege cmd level 3 mode exec command ping
    privilege cmd level 3 mode exec command who
    privilege cmd level 3 mode exec command logging
    privilege cmd level 3 mode exec command failover
    privilege cmd level 3 mode exec command vpn-sessiondb
    privilege cmd level 3 mode exec command packet-tracer
    privilege show level 5 mode exec command import
    privilege show level 5 mode exec command running-config
    privilege show level 3 mode exec command reload
    privilege show level 3 mode exec command mode
    privilege show level 3 mode exec command firewall
    privilege show level 3 mode exec command asp
    privilege show level 3 mode exec command cpu
    privilege show level 3 mode exec command interface
    privilege show level 3 mode exec command clock
    privilege show level 3 mode exec command dns-hosts
    privilege show level 3 mode exec command access-list
    privilege show level 3 mode exec command logging
    privilege show level 3 mode exec command vlan
    privilege show level 3 mode exec command ip
    privilege show level 3 mode exec command failover
    privilege show level 3 mode exec command asdm
    privilege show level 3 mode exec command arp
    privilege show level 3 mode exec command ipv6
    privilege show level 3 mode exec command route
    privilege show level 3 mode exec command ospf
    privilege show level 3 mode exec command aaa-server
    privilege show level 3 mode exec command aaa
    privilege show level 3 mode exec command eigrp
    privilege show level 3 mode exec command crypto
    privilege show level 3 mode exec command ssh
    privilege show level 3 mode exec command vpn-sessiondb
    privilege show level 3 mode exec command vpnclient
    privilege show level 3 mode exec command vpn
    privilege show level 3 mode exec command dhcpd
    privilege show level 3 mode exec command blocks
    privilege show level 3 mode exec command wccp
    privilege show level 3 mode exec command dynamic-filter
    privilege show level 3 mode exec command webvpn
    privilege show level 3 mode exec command service-policy
    privilege show level 3 mode exec command module
    privilege show level 3 mode exec command uauth
    privilege show level 3 mode exec command compression
    privilege show level 3 mode configure command interface
    privilege show level 3 mode configure command clock
    privilege show level 3 mode configure command access-list
    privilege show level 3 mode configure command logging
    privilege show level 3 mode configure command ip
    privilege show level 3 mode configure command failover
    privilege show level 5 mode configure command asdm
    privilege show level 3 mode configure command arp
    privilege show level 3 mode configure command route
    privilege show level 3 mode configure command aaa-server
    privilege show level 3 mode configure command aaa
    privilege show level 3 mode configure command crypto
    privilege show level 3 mode configure command ssh
    privilege show level 3 mode configure command dhcpd
    privilege show level 5 mode configure command privilege
    privilege clear level 3 mode exec command dns-hosts
    privilege clear level 3 mode exec command logging
    privilege clear level 3 mode exec command arp
    privilege clear level 3 mode exec command aaa-server
    privilege clear level 3 mode exec command crypto
    privilege clear level 3 mode exec command dynamic-filter
    privilege cmd level 3 mode configure command failover
    privilege clear level 3 mode configure command logging
    privilege clear level 3 mode configure command arp
    privilege clear level 3 mode configure command crypto
    privilege clear level 3 mode configure command aaa-server
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:41a021a28f73c647a2f550ba932bed1a
    : end
    Many thanks,
    Ingo

    Hi Jose,
    here is what I got now:
    ASA(config)# sh run | begin tunnel-group
    tunnel-group DefaultWEBVPNGroup general-attributes
    address-pool VPNPool
    authorization-required
    and DAP debugging still the same:
    ASA(config)# DAP_TRACE: DAP_open: CDC45080
    DAP_TRACE: Username: tom.tucker, aaa.cisco.grouppolicy = DfltGrpPolicy
    DAP_TRACE: Username: tom.tucker, aaa.cisco.username = tom.tucker
    DAP_TRACE: Username: tom.tucker, aaa.cisco.username1 = tom.tucker
    DAP_TRACE: Username: tom.tucker, aaa.cisco.username2 =
    DAP_TRACE: Username: tom.tucker, aaa.cisco.tunnelgroup = DefaultWEBVPNGroup
    DAP_TRACE: Username: tom.tucker, DAP_add_SCEP: scep required = [FALSE]
    DAP_TRACE: Username: tom.tucker, DAP_add_AC:
    endpoint.anyconnect.clientversion="3.1.02026";
    endpoint.anyconnect.platform="win";
    DAP_TRACE: Username: tom.tucker, dap_aggregate_attr: rec_count = 1
    DAP_TRACE: Username: tom.tucker, Selected DAPs: DfltAccessPolicy
    DAP_TRACE: Username: tom.tucker, DAP_close: CDC45080
    Unfortunately, it still doesn't work. Hmmm.. maybe a wipe of the config and starting from scratch can help?
    Thanks,
    Ingo

  • Access ADSI through JNDI ?

    Hi All,
    Im a newbie to JNDI. Could you please answer to my following query:
    I wanted to access the ADSI (Microsoft's Active Directory Services Interface) with the client java code.
    I am aware that we can do this by using JNDI since a service provider is
    availaible for NDS and LDAP.
    So my question can I access Microsoft's ADSI using
    JNDI? If so how? (I mean where is the service provider availaible for
    ADSI and how does JNDI interact with COM interfaces of ADSI). If not, is there any other way I can access the ADSI using java code (I know that JIntegra has some software to do this).
    Many thanks in advance.

    JNDI is similar to ADSI in that it provides a set of interfaces and directory service providers.
    You can access Active Directory directly using JNDI via the LDAP protocol. Here is a list of some of the posts I have submitted.
    JNDI, Active Directory and Authentication (Part 1) (Kerberos)
    http://forum.java.sun.com/thread.jspa?threadID=579829&tstart=300
    JNDI, Active Directory & Authentication (part 2) (SSL)
    http://forum.java.sun.com/thread.jspa?threadID=581425&tstart=50
    JNDI, Active Directory & Authentication (part 3) (Digest-MD5)
    http://forum.java.sun.com/thread.jspa?threadID=581868&tstart=150
    JNDI, Active Directory & Authentication (part 4) (SASL EXTERNAL)
    http://forum.java.sun.com/thread.jspa?threadID=641047&tstart=0
    JNDI, Active Directory, Paging and Range Retrieval
    http://forum.java.sun.com/thread.jspa?threadID=578347&tstart=0
    JNDI, Active Directory, Referrals and Global Catalog
    http://forum.java.sun.com/thread.jspa?threadID=603815&tstart=15
    JNDI, Active Directory (Creating new users & demystifying userAccountControl)
    http://forum.java.sun.com/thread.jspa?threadID=582103&tstart=15
    JNDI, Active Directory & Changing Passwords
    http://forum.java.sun.com/thread.jspa?threadID=592611&tstart=50
    JNDI, Active Directory and Group Memberships
    http://forum.java.sun.com/thread.jspa?threadID=581444&tstart=150
    JNDI, Active Directory and objectGUID's
    http://forum.java.sun.com/thread.jspa?threadID=585034&tstart=150
    JNDI, Active Directory and SID's (Security Identifiers)
    http://forum.java.sun.com/thread.jspa?threadID=585031&tstart=150
    JNDI, Active Directory and Error codes
    http://forum.java.sun.com/thread.jspa?threadID=578674&tstart=200
    JNDI, Active Directory and Server Side Sorting
    http://forum.java.sun.com/thread.jspa?threadID=628857&tstart=0
    JNDI, Active Directory & Persistent Searches (part 1)
    http://forum.java.sun.com/thread.jspa?threadID=578338&tstart=200
    JNDI, Active Directory and Persistent Searches (part 2)
    http://forum.java.sun.com/thread.jspa?threadID=578342&tstart=200
    Sample code demonstrating a search for disabled accounts.
    http://forum.java.sun.com/thread.jspa?threadID=588430&messageID=3045217
    JNDI, Active Directory and User Account status (account expired, locked)
    http://forum.java.sun.com/thread.jspa?threadID=716240&tstart=0
    JNDI, Active Directory and Authentication (part 5, LDAP Fastbinds)
    http://forum.java.sun.com/thread.jspa?threadID=726601&tstart=0
    If you need to access ADSI via JNDI (perhaps for some of the ADSI specific features), then other posts on this forum have suggested http://j-integra.intrinsyc.com/

  • Copying Client 001 instead of 000

    Hi Experts,
    Just a query, we've installed srm 7.0 ehp1 and after finishing the post processing i've noticed that we've copied client 001 to the new client (sandbox client - 251) instead of 000. is there any drawback or consequence of doing that? the thing is we have already configured SRM-ECC integration (SRM 251 and ECC 251).
    Is there any harm? because reviewing the client 001 - it is copy of master client 000.. but based on the document -
    5.16Performing the Client Copy
    SAPinst creates three ABAP clients during the installation, client 000, client 001, and client 066.
    Client 000 is the SAP reference client for ABAP.
    Use client 000 as source client for the client copy.
    please help me analyze and explain if there will be a drawback about copying client 001 instead of client 000. should i delete the existing client251 and create a new client251 copied from client 000 and repeat the SRM - ECC integration?
    Thank you.
    Regards,
    Tony
    Edited by: Tony on Aug 8, 2011 1:13 PM

    >
    Razia Cassim wrote:
    > Hi, thanks for your input,  I created all the required users and made the change in the
    >
    > When i try to access the portal I can get into the potal but when I goto
    >
    > http://ttaf-sap-bwp.ttaf.co.za:8000/ijr/portal ->
    >
    > SYSTEM ADMINISTRATION -> SYSTEM CONFIGURATION -> UME CONFIGURATION ->
    >
    > I get the following error message :  You are not authorized to use the UME config editor
    >
    Does your user have the required authorizations? Is it part of the SAP_J2EE_ADMIN group? Is the user assigned to a role that contains UME.Manage_All?
    >
    Razia Cassim wrote:
    Then when I try to goto
    >
    > http://ttaf-sap-bwp.ttaf.co.za:8000/index.html -> SAP NETWEAVER ADMINISTRATOR
    >
    > i get the following error message : SYSTEM LANDSCAPE DIRECTORY IS NOT ACCESSIBLE
    >                                                   SELECT SYSTEMS BEFORE PROCEEDING
    >
    > Please advise how I can overcome this problem
    >
    > You assistance is most highly appreciated,
    >
    > Razia
    As far as the SLD goes, I am no expert. I suggest you take a look at the SLD documentaion:
    http://help.sap.com/saphelp_nw70/helpdata/EN/31/f0ff69551e4f259fdad799a229363e/frameset.htm
    -Michael
    Edited by: Michael Shea on Mar 5, 2008 3:40 PM
    fixed quote tags

  • Exchange 2013 - Client Access Servers - Disk Space C:\ Running Low Space

    Currently having an issue with both of our client access servers with exchange 2013.
    The issue is that the C:\ drive will run low on disk space on one of the cas server and the other one will be fine.  We have cleaned up all the logs etc to free space on the cas server that is running low on space but its not sufficient enough
    as it keeps on running low on space, then what we do the free up the space is to reboot the cas server that runs low on space, and it free the space up after it has been restarted, then the other cas server starts running low on space.
    has anyone seen this before?

    Hi,
    If it is possible, I suggest re-installing Exchange Server on another path instead of C:\.
    Thanks
    Mavis
    Mavis Huang
    TechNet Community Support

  • Exchange 2013 - Client Access - Wrong Servername

    Hi,
    i have 4 exchange servers running, 2x Client Access, 2x MAilbox with DAG.
    i configured the external URL on all virtual directories and outlook anywhere to cas.contoso.com
    the internal url is cas01.contoso.com and cas02.contoso.com.
    All Clients connect from outside the company, so the internal url doesn't matter.
    When i client connects from outside, it's very slow. I saw on the firewall, that outlook is trying to connect to cas01 or cas02.contoso.com and then gives up and go to cas.contoso.com which is right.
    how can i check, why outlook is trying to access the servers instead of the alias cas.contoso.com ?
    cas.contoso.com points to KEMP Load balancers which distribute the load to the two Client access servers.

    hi,
    we have no internal traffic, all clients connects from external sources.
    anyway, i changed all URL's to the external URL now, for OWA, ECP, EWS and Outlook Anywhere.
    I created a new outlook profile and it still tries the internal URL first.
    BTW: the internal URL is also a public IP address but firewalled POrt 443, only the cas.contoso.com IP is open on 443.
    So the internal Hostnames are DNS resolvable on the internet? If so, that is not what you want to do. Make only the external Host name resolvable.
    Twitter!:
    Please Note: My Posts are provided “AS IS” without warranty of any kind, either expressed or implied.
    Well, the hole system is resolvable on the Internet, i can switch them to https://localhost/... 
    but in my case, i switched everything from cas01 or cas02 to cas and outlook still shows up with
    cas01.contoso.com  connecting....
    cas.contoso.com conneted...
    where does this client get cas01.contoso.com from ?!

  • Installation of Client Access role fails on Windows Server 2008 R2 (Execution of: "$error.Clear(); Install-ExchangeCertificate -services "IIS, POP, IMAP")

    Hello
    I am trying to install Exchange Server 2010 beta 1 onto a Windows Server 2008 R2 (build 7000) machine which has also been set up as a domain controller.
    However when attempting to install the Client Access role, setup fails with the error below.
    Does anyone know of a way to get around this please?
    I have already searched for this error and not found any similar threads.
    Also every time I press the code button on this forum it crashes the browser and I keep losing the message! (IE8 from within Server R2). Also the message box is very small, will not expand and keeps jumping to the top.
    Thanks
    Robin
    [code]
    Summary: 4 item(s). 1 succeeded, 1 failed.
    Elapsed time: 00:00:01
    Preparing Setup
    Completed
    Elapsed Time: 00:00:00
    Client Access Role
    Failed
    Error:
    The execution of: "$error.Clear(); Install-ExchangeCertificate -services "IIS, POP, IMAP" -DomainController $RoleDomainController", generated the following error: "Could not grant Network Service access to the certificate with thumbprint 2F320F5D5B5C6873E54C8AB57F604D8AFA31D18C because a cryptographic exception was thrown.".
    Could not grant Network Service access to the certificate with thumbprint 2F320F5D5B5C6873E54C8AB57F604D8AFA31D18C because a cryptographic exception was thrown.
    Access is denied.
    Elapsed Time: 00:00:01
    Mailbox Role
    Cancelled
    Finalizing Setup
    Cancelled
    [/code]
    Robin Wilson

    Hello
    Thanks for all the replies.
    I have since wiped the system and installed everything again and it all worked this time so not sure what was wrong last time. I did try to uninstall all Exchange components and then uninstall IIS and Application server, reboot and re-install but I received the same error still when it came to installing the client access role.
    Walter: I just attempted the standard installation which should have used the default self-signed certificate. Everything was a fresh install done at the same time on a freshly formatted PC.
    For info last time when it failed to work:
    - Installed Windows Server 2008 R2
    - Installed Domain Controller role using dcpromo. I set the forest and domain as Windows Server 2008 R2
    - Added a forest trust between main domain and test Exchange domain (set up as ex2010.local)
    - Installed IIS and Application Server role
    - Installed Hyper-v role
    - Installed Desktop Experience feature
    - Installed Exchange and recieved the error
    When it worked I set up the forest and domain in Windows Server 2008 mode (i.e. not R2), installed Exchange first and then set up the forest trust and then Hyper-v. It did say it failed to configure dns which was probably because it started trying to do automatic updates half way through the dcpromo! DNS seems to work ok though.
    I did notice this time that Hyper-v gave a warning about the virtual network adapter not being set up correctly and the local network did not work correctly although I could access the internet. Not sure if this could have been related to the cause of the problem previously. For now I have disabled the virtual network until I get time to try and get it working and so the mail will work in the meantime.
    I also noticed that Hyper-v added an extra 443 ssl binding to the default website so as it had 2 bindings on port 443 it refused to start. After deleting one it worked.
    I decided to install Exchange onto a domain controller as it is only a test and I wouldn't do it in a live environment. I am also short of test machines! It didn't give me any warnings about this actually, I think previous versions warn you that it is not recommended.
    Andreas and Chinthaka: I did not know about the requirement to run the domain at 2003 mode. The main domain is running in 2008 mode with Exchange 2007 so I assume this is just a temporary beta related requirement. It does seem to be working (second attempt) so far in a 2008 mode domain although I haven't had a chance to fully test it yet.
    Thanks
    Robin
    P.S. Sorry it's taken me a while to reply!
    Robin Wilson

  • EMC Crash when i try to - reset client access virtual directory

    Hi All,
    I have one exchagne server 2010 sp3 rollup 7 installed on server 2012R2 Std.
    When i try to reset client access virtual directory the MMC is crashing.
    In the event viewer i can find 3 error after to crash:
    1.
    The program mmc.exe version 6.3.9600.17415 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
     Process ID: 2360
     Start Time: 01d04e7b531a4a0d
     Termination Time: 4294967295
     Application Path: C:\Windows\system32\mmc.exe
     Report Id: 69db84d3-ba91-11e4-80c3-0050569b5787
     Faulting package full name: 
     Faulting package-relative application ID: 
    2. 
    Application: mmc.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.Reflection.TargetInvocationException
    Stack:
       at Microsoft.ManagementConsole.Executive.MmcThreadMessageWindow.OnThreadException(Exception e)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
       at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
       at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
       at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
       at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
       at Microsoft.ManagementConsole.Internal.SnapInMessagePumpProxy.Microsoft.ManagementConsole.Internal.ISnapInMessagePumpProxy.Run()
       at Microsoft.ManagementConsole.Executive.SnapInThread.OnThreadStart()
       at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
       at System.Threading.ThreadHelper.ThreadStart()
    3.
    Faulting application name: mmc.exe, version: 6.3.9600.17415, time stamp: 0x54504e26
    Faulting module name: KERNELBASE.dll, version: 6.3.9600.17415, time stamp: 0x54505737
    Exception code: 0xe0434352
    Fault offset: 0x0000000000008b9c
    Faulting process id: 0x2014
    Faulting application start time: 0x01d04e9e432feaef
    Faulting application path: C:\Windows\system32\mmc.exe
    Faulting module path: C:\Windows\system32\KERNELBASE.dll
    Report Id: b8276755-ba91-11e4-80c3-0050569b5787
    Faulting package full name: 
    Faulting package-relative application ID: 
    When i try to preform the task from EMC that installed on my PC (Win 7 SP1 x64) everything works fine
    Thank you.

    Hi Eliran,
    Thank you for your question.
    Are there any update recently?
    We could refer to the following steps to troubleshoot:
    1)disable A/V
    2) Run: DISM.exe /Online /Cleanup-image /Restorehealth
    http://support.microsoft.com/kb/947821/en-gb
    3) follow http://support.microsoft.com/kb/929833/en-gb to upload %WinDir%\Logs\CBS\CBS.log
    4) disable snap-ins exept DNS-snapin
    5) run SDP
    6) enable A/V
    We could also re-install .Net 4.0 to check if the issue persist by the following link:
    http://www.microsoft.com/en-us/download/details.aspx?id=17718  
    If the issue persist, we could install Exchange 2010 SP3 CU8 by the following link:
    http://www.microsoft.com/en-us/download/details.aspx?id=45225
    If there are any questions regarding this issue, please be free to let me know.
    Best Regard,
    Jim

  • How do I find the MAC address of a CLIENT ACCESS POINT created from the FILE SERVICES ROLE

    I have several Client Access Points created within the clustered File Services Role.  The only way I seem to be able to determine the MAC address of each of these, is by visiting the DHCP server.
    Does anyone know if there is a way of reporting on this from the server (active node) itself?  I have tried ipconfig all, checked the properties of the CAP in the FCS console etc.
    Many thanks.
    Kathleen Hayhurst Senior IT Support Analyst

    Hi,
    As far as I know there have no original option for query all the CAP MAC address, may you can create a PowerShell command then filter the configuration result, you can ask
    in PowerShell forum for the further help.
    More information:
    PowerShell forum:
    http://social.technet.microsoft.com/Forums/en-US/bf0e249b-a9f3-4bef-a536-c210b3f09340/powershell-script-to-alert-on-failed-system-state-backups?forum=winserverpowershell
    The related KB:
    Failover Clusters Cmdlets in Windows PowerShell
    http://technet.microsoft.com/en-us/library/hh847239.aspx
    The related article:
    PowerShell for Failover Clustering: Frequently Asked Questions &amp; Enabling CSV
    http://blogs.msdn.com/b/clustering/archive/2009/05/23/9636665.aspx
    Hope this helps.
    We
    are trying to better understand customer views on social support experience, so your participation in this
    interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

  • RV042 VPN Client Access not able to connect two users at same time

    I have a RV042 and have set it up for VPN Client access using the QuickVPN client to connect my remote users. I discovered today that I cannot have two users connect in at the same time. Both users are in the same remote office. They can connect individually with no problem but if one is connected and the other tries connect also the second user gets a message the gateway is not responding. They are both running WinXPPRo SP3. Any help is greatly appreciated.

    Were your QuickVPN clients behind a firewall router of some sort? For multiple QuickVPN clients to be able to connect to the remote RV042 at the same time, the local firewall router must have VPN Passthrough correctly implemented. You could try using a RV042 as the firewall router for your QuickVPN clients and you should be able to maintain 2 tunnels at the same time to the remote RV042.

  • REMOTE DESKTOP SERVICES CLIENT ACCESS LICENSES FOR MICROSOFT WINDOWS SERVER 2012 STANDARD AND DATACENTER

    I am using a window 7 professional  service pack 1 and I purchase REMOTE DESKTOP SERVICES CLIENT ACCESS LICENSES FOR MICROSOFT WINDOWS SERVER 2012 STANDARD AND DATACENTER. but  the seller did not send me any installation CD or instruction
    on how to use it.
     Please how can I use it on my window 7 professional  service pack 1.
    Thank you.

    Though Bill is absolutely correct for most CALs, Remote Desktop Services does have its own special licensing server.  I haven't installed one on 2012, yet, but here is a step-by-step guide for 2008. 
    http://technet.microsoft.com/en-us/library/dd983943(v=ws.10).aspx
    Here is a lab guide for 2012 -
    http://technet.microsoft.com/en-us/library/jj134160.aspx
    But, the explanation of your environment begs the question - what are you trying to do?  You say you have a desktop OS and you are talking about Windows Server products.  In that light, your question does not make a lot of sense.
    . : | : . : | : . tim

  • No new mail notification in Outlook - CAS Exchange RPC Client Access problem

    Hi, we're facing this problem:
    Users start complaining they suddenly don’t receive new mail notifications in Outlook (2010/2013)  anymore
    Inbox does not show the new mail either
    When the user changes folders in outlook, the new mail does show in the Inbox folder
    Restarting Outlook shows the new mail as well.
    The same new e-mail arrives instantly (with notifications) in Owa and on mobile devices
    Sometimes the new mail notification pops up after a longer period of time (from 30 seconds to 10 minutes). But more often not at all.
    This issue seems to occur at random. We’ve been problem free for a week, and sometimes it comes back three times a day.
    Clients running Outlook 2010, 2013 cached or online, on site and off site. So it seems server related, not client.
    It was seen first around January 8th. We did not make any changes around that time that we can link to this problem.
    Only one CAS server (EXCH1-RTD) shows this issue. CAS servers on other sites are ok
    EXCH1-RTD has CAS and HUB transport roles. The same site has two mailbox only servers. EXCH2-RTD (mailbox server for normal mailboxes). And EXCH3-RTD (mailbox server for archive mailboxes)
    No entries in the event logs that seems to be related
    As the problem only occurs with Outlook clients, I suspected RPC issues. We cannot gracefully stop the “Microsoft Exchange RPC Client Access” service on EXCH1-RTD  while the issue occurs. We
    can only kill the process and restart the service, solving the issue instantly.
    What we’ve tried until now:
    Updated all Exchange servers from Exchange 2010 SP3 RU6 to RU8-v2 (server OS=W2K8R2)
    Updated all Exchange servers  to latest critical Windows updates
    Recalculated requirements using MS Sizing tool.  Upgraded EXCH1-RTD  VM from 8GB and 2 vCPU (1 core/cpu) to 16GB
    and 4vCPU (1 core/cpu)
    Ran various perfmon counters and compared them with other Exchange servers, not finding any obvious anomalies.
    Any ideas would be greatly appreciated!
    Ron

    Hi Ron,
    From your description, OWA works well, the issue is related to Outlook side. In your case, I recommend you use Outlook safe mode to determine whether the issue is related to add-ins. If the issue persists, you can create a new profile to check the result.
    Hope this can be helpful to you.
    Best regards,
    Amy Wang
    TechNet Community Support

  • How to scroll up and down in IBM client access using windows 7 on mac running bootcamp

    How to scrool up and down in Client Access 5250 (AS/400 emulator) using windows 7 on Mac running boot camp. The key board does not function within the client access 5250 session?

    You can also share a printer between the Mac/PC as well as files and mounted Volumes, see the Tiger articles here
    http://www.ifelix.co.uk/tech/
    You may want to use Bonjour for Windows on your PC
    http://www.apple.com/macosx/features/bonjour/
    Then there are VNC clients for Mac/PC that also allow you to actually control the other machine, if they aren't in the same room and you just need to check something quick that can be handy, it's kind of slow though for regular use.
    The main benefit of partitioning is being able to have different versions of bootable OS on them. You can try out Leopard on a new partition, while keeping your Tiger partition intact, you can have a XP/Vista partition for parallels or BootCamp, etc... other than that drives are pretty much fast enough, having smaller partitions probably won't realize any significant speed ups over searching the whole large drive.

  • No client access on DAG switchover - Single site

    Let’s summarize my environment:
    I have 3 Exchange 2013 SP1 (cu4) server in one site. CAS01, only have cas role and MBX01&MBX02 have only mailbox. Both mailbox are in a DAG (DAG01).
    The server mounting my database is MBX02. Whenever a switchover to MBX01 occur (or when I force it whith Move-ActiveMailboxDatabase –server MBX02 -ActivateOnServer MBX01), all my client get disconnected so no more outlook, active sync
    and even owa. As soon as I roll them back on MBX02, everything returns to normal. However, every single email delivered while the DAG was mounted on MBX01 are getting delivered to the mailbox server so dag is working properly for the mail flow, minus the client
    access HA.
    Now I know that on Exchange 2010 and the issue could have been with the value of –rpcclientaccessserver on my database, but this value is not used anymore on 2013.
    Any ideas?
    Thanks

    Hi  S.Nithyanandham
    1. No my servers are working pretty fine is I create a non dag DB on MBX01, Client access and mail flow is fine. Turning off both Windows firewall didn’t
    change anything
    2.
    Server Check                Result Error
    MBX01  ClusterService       Passed
    MBX01  ReplayService        Passed
    MBX01  ActiveManager        Passed
    MBX01  TasksRpcListener     Passed
    MBX01  TcpListener          Passed
    MBX01  ServerLocatorService Passed
    MBX01  DagMembersUp         Passed
    MBX01  ClusterNetwork       Passed
    MBX01  QuorumGroup          Passed
    MBX01  FileShareQuorum      Passed
    MBX01  DatabaseRedundancy   Passed
    MBX01  DatabaseAvailability Passed
    Server Check                Result Error
    MBX02  ClusterService       Passed
    MBX02  ReplayService        Passed
    MBX02  ActiveManager        Passed
    MBX02  TasksRpcListener     Passed
    MBX02  TcpListener          Passed
    MBX02  ServerLocatorService Passed
    MBX02  DagMembersUp         Passed
    MBX02  ClusterNetwork       Passed
    MBX02  QuorumGroup          Passed
    MBX02  FileShareQuorum      Passed
    MBX02  DatabaseRedundancy   Passed
    MBX02  DatabaseAvailability Passed
    MBX02  DBCopySuspended      Passed
    MBX02  DBCopyFailed         Passed
    MBX02  DBInitializing       Passed
    MBX02  DBDisconnected       Passed
    MBX02  DBLogCopyKeepingUp   Passed
    MBX02  DBLogReplayKeepingUp Passed
    3. I’ve double check that  and recreated the dag binding multiple time with no luck.
    4. yes they are
    [PS] C:\Windows\system32>get-mailboxdatabasecopystatus | ft -au
    Name      Status  CopyQueueLength ReplayQueueLength LastInspectedLogTime ContentIndexState
    DB1\MBX01 Mounted 0               0                                     
    Healthy
    DB2\MBX01 Mounted 0               0                               
          Healthy
    DB3\MBX01 Mounted 0               0                                     
    Healthy
    DB4\MBX01 Mounted 0               0                                     
    Healthy
    [PS] C:\Windows\system32>get-mailboxdatabasecopystatus -server mbx02 | ft -au
    Name      Status  CopyQueueLength ReplayQueueLength LastInspectedLogTime ContentIndexState
    DB1\MBX02 Healthy 0               0                 2015-01-12 19:57:58  Healthy
    DB2\MBX02 Healthy 0               0                 2015-01-12 19:58:10  Healthy
    DB3\MBX02 Healthy 0               0                 2015-01-12 19:58:07  Healthy
    DB4\MBX02 Healthy 0               0                 2015-01-12 20:00:23  Healthy
    5. None except those related to the failover if I bring MBX02 down
    6. File share is fine and acessible.
    Then please explain me what you are trying to say on the below mentioned line?
    When I have a failover and database are mounted and healthy I can’t connect trougth any devices but email sent to my organization are devilered in databases correctly. I can see them with Get-MessageTrackingLog. In addition, my Wtachguard
    in front of my cas is not reporting any bounce or error, everything is delivred and queue is empty inside it.
    A big Thank you for your help
    Alex
    Alexandre Contant

Maybe you are looking for

  • Sql query is taking more time

    Hi all, db:oracle 9i I am facing below query prob. prob is that query is taking more time 45 min than earliar (10 sec). please any one suggest me ..... SQL> SELECT MAX (tdar1.ID) ID, tdar1.request_id, tdar1.lolm_transaction_id, 2 tdar1.transaction_ve

  • Choppy playback in CC, suddenly

    Yes, yet another mysterious choppy, jerky playback out-of-the-blue issue. Premiere Pro CC 7.01, Mac, was working relatively fine for a few weeks on a couple projects. Now, on new project, exact same setup and media as before, I get playback that is f

  • How can I get transparency on a Zoom?

    Captivate 3 Windows XP Pro I'm trying to use the Zoom Area tool to to move an image from one area of the screen to another. If I insert a transparent GIF or PNG as a static image, the image is legitimately transparent. When I select that same image f

  • Is there a command to know the current throughput fo an IPS

    Hi guys I need to get some information from my CISCO IPS. I need to get the current throughput from the IPS but I cannot find any command that could bring such information. If somebody know how to get this information it will be great. Regards!

  • Errors loading XMLParser

    I am getting the following errors when running the script oraclexmlsqlload.csh on an HP-UX 11.0 system running oracle 8i. loading : xmlparser_2.0.0.1.0_beta creating : xmlparser_2.0.0.1.0_beta Error while creating resource xmlparser_2.0.0.1.0_beta OR