JNI_CreateJavaVM and IPV6

Hi all,
I met the error on Linux.
Here is the scenario:
My C-code will create a JVM, it find method from a Java Class to execute.
My Java Class create a DatagramSocket with ipv6 address, but it throw a exception:"Exception creating server socket: java.net.SocketException: Protocol family unavailable".
I can not find out the solution to fix this. please help me.
These are some VM options that I add when create JVM
JVM Options:
-Denv.class.path=/opt/abc/xyz
-Djava.class.path=/opt/jre/lib/rt.jar:/opt/jre/lib/i18n.jar:/opt/jre/lib/sunrsasign.jar:/opt/jre/lib/classes:/opt/jre/lib/javaplugin.jar
-Djava.compiler=NONE
-Dapplication.home=/opt/abc
-DDaemon=true
-Djava.net.preferIPv6Addresses=true
vfprintf
=====-DDaemon=====
-DDaemon=true to start upon new Thread (option &)
thanks,
ndt
Edited by: 849647 on Nov 8, 2012 4:00 AM

sorry, this is the full stack trace
java.net.SocketException: Protocol family unavailable
java.net.PlainDatagramSocketImpl.bind0(Native Method)
java.net.AbstractPlainDatagramSocketImpl.bind(AbstractPlainDatagramSocketImpl.java:95)
java.net.DatagramSocket.bind(DatagramSocket.java:376)
java.net.DatagramSocket.<init>(DatagramSocket.java:231)
java.net.DatagramSocket.<init>(DatagramSocket.java:284)
com.lucent.qtek.common.util.Debug$DebugListener.run(Debug.java:237)
java.lang.Thread.run(Thread.java:722)
java.net.SocketException: Protocol family unavailable
     at java.net.PlainDatagramSocketImpl.bind0(Native Method)
     at java.net.AbstractPlainDatagramSocketImpl.bind(AbstractPlainDatagramSocketImpl.java:95)
     at java.net.DatagramSocket.bind(DatagramSocket.java:376)
     at java.net.DatagramSocket.<init>(DatagramSocket.java:231)
     at java.net.DatagramSocket.<init>(DatagramSocket.java:284)
     at com.lucent.qtek.common.util.Debug$DebugListener.run(Debug.java:237)
     at java.lang.Thread.run(Thread.java:722)
And this is my source code
public void run() {
               try {                    
                    String localaddress = "127.0.0.1";
                    if(SystemIPAddrType() == 6)
                         localaddress = "::1";
                    DatagramSocket serv = new DatagramSocket(0, InetAddress.getByName(localaddress));
                    serv.setReceiveBufferSize(ReceiveBufferSize);
It run ok with IPV4 address (127.0.0.1) but throw exception if I use IPV6 addresss ("::1")
====fork()==========
I forked a new process before create a JVM in my C code, if I dont fork new process, it run ok, but i need to fork to run many server services (listening).
The problem: JNI_CreateJavaVM in forked process and supporting IPV6
thanks,
ndt
Edited by: 849647 on Nov 8, 2012 6:30 PM
Edited by: 849647 on Nov 8, 2012 6:36 PM
Edited by: 849647 on Nov 8, 2012 7:55 PM
Edited by: 849647 on Nov 8, 2012 10:30 PM

Similar Messages

  • Cisco IOS Zone Based Firewall and IPv6

    Hello,
    I am trying to setup IPv6 tunnel to tunnel-broker Hurrican Electrics. IPv6 connection is working OK only if I disable zone security on WAN interface (Fe0 - IPv4 interface).
    Which protocols must be alloved to and from router?
    IOS version: 15.1.2T1 (Adv.ip services)
    Setup:
    HE (tunnel-broker)  --- Internet (IPv4)  ---- Cisco 1812 (Fe0 (IPv4) and interface tunnel 1 (IPv6))
    Config on router:
    IPv4 (self to internet and internet to self)
    policy-map type inspect Outside2Router-pmap
    class type inspect SSHaccess-cmap
      inspect
    class type inspect ICMP-cmap
      inspect
    class type inspect IPSEC-cmap
      pass
    class type inspect Protocol41-cmap
      pass log
    class class-default
      drop
    interface Tunnel1
    description Hurricane Electric IPv6 Tunnel Broker
    no ip address
    zone-member security IPv6tunnel
    ipv6 address 2001:47:25:105B::2/64
    ipv6 enable
    ipv6 mtu 1300
    tunnel source FastEthernet0
    tunnel mode ipv6ip
    tunnel destination xxx.66.80.98
    interface FastEthernet0
    description WAN interface
    ip address xxx.xxx.252.84 255.255.0.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    zone-member security WAN
    duplex auto
    speed auto
    zone-pair security IPv6Tunnel_2_WAN source IPv6tunnel destination WAN
    service-policy type inspect IPv6-out-pmap
    zone-pair security WAN_2_IPv6tunnel source WAN destination IPv6tunnel
    service-policy type inspect IPv6-out-pmap
    policy-map type inspect IPv6-out-pmap
    class type inspect IPv6-internet-class
      inspect
    class class-default
      drop
    class-map type inspect match-all IPv6-internet-class
    match protocol tcp
    match protocol udp
    match protocol icmp
    match protocol ftp
    ipv6 route ::/0 Tunnel1
    ipv6 unicast-routing
    ipv6 cef
    parameter-map type inspect v6-param-map
    ipv6 routing-header-enforcement loose
    sessions maximum 10000

    OK, removed the cmap the packet was getting dropped on, so the current self to wan zone-pair policy map looks like this:
    policy-map type inspect pm-selftowan
    class type inspect cm-selftowan-he-out
      inspect
    class type inspect cm-dhcpwan
      pass
    class class-default
      drop
    class-map type inspect match-all cm-selftowan-he-out
    match access-group name HETunnelOutbound
    ip access-list extended HETunnelOutbound
    permit 41 any any
    permit ip any host 64.62.200.2
    permit ip any host 66.220.2.74
    permit ip any host 216.66.80.26
    Now we see the same error, just on the 'new' first cmap in the pmap:
    *Oct  5 02:39:31.316 GMT: %FW-6-DROP_PKT: Dropping Unknown-l4 session :0 216.66.80.26:0 on zone-pair selftowan class cm-selftowan-he-out due to  Invalid Segment with ip ident 0
    Yet as you can see above, we are allowing proto 41 any any.
    I didn't expect any other result really since the previous cmap had 'permit ip any any' but still
    any ideas?
    Thanks,
    //TrX
    EDIT: Out of curiosity after reading this post: https://supportforums.cisco.com/thread/2043222?decorator=print&displayFullThread=true
    I decided to change the outbound cm-selftowan-he-out action to 'pass'.
    I suddently noticed the following log:
    *Oct  5 02:39:31.316 GMT: %FW-6-DROP_PKT: Dropping Unknown-l4 session  216.66.80.26:0 :0 on zone-pair wantoself class  cm-wantoself-he-in due to  Invalid Segment with ip ident 0
    Notice this is now inbound having trouble where as before was outbound.
    I changed the inbound pmap policy for cmap cm-wantoself-he-in to pass also and IPv6 PACKETS ARE GETTING ICMP6 REPLIES FROM GOOGLE!
    Looking at the original outbound PMAP:
    policy-map type inspect pm-selftowan
    class type inspect cm-selftowan
      inspect
    class type inspect cm-selftowan-he-out
      inspect
    class type inspect cm-dhcpwan
      pass
    class class-default
      drop
    cm-selftowan has always been infront of cm-selftowan-he-out, and because that is ip any any, it has been 'grabbing' the IP proto 41 packets and doing ip inspect on them (which fails as it seems ip inspect only handles a handful of proto's).
    This is why setting cm-selftowan-he-out and cm-wantoself-he-in both to 'pass' instead of 'inspect' in the past has not been doing anything, because the outbound packets were never getting to the cm-selftowan-he-out cmap.
    Would never have got to this without ip inspect log. Why didn't I think of just trying ip inspect logging two days ago!
    Anyway, thank you, I have now restored my faith in my own knowledge of ZBF!
    Hope this helps the OP too
    //TrX

  • Network Load Balancing and IPv6 Ping Timeout

    I've noticed interesting behavior with NLB on Windows 2012 R2 and IPv6. I have two systems that use NLB on a Hyper-V cluster, each system is on a different node in the cluster. When I do an IPv6 ping within the same subnet, I notice that the reply time is
    normally 1-3ms, but every so often it goes to 100+ms. I also notice that both members of the NLB reply to a ping to the cluster IPv6 address. This is interesting.
    When I do a ping to the cluster IPv6 address from a different subnet, I notice that the reply is intermittent. The NLB nodes will either both reply to the ping or both won't. At first I thought that there was an issue with my network, but when I do a span
    on the ports that the cluster is attached to, I see that the IPv6 ping packets arrive, but the NLB nodes don't always send a reply.
    What is also interesting is that the NLB web farm I have setup seem to be working fine and is not intermittent, so this issue only has to do with ping. Has anyone else seen this type of issue, or is this a bug?
    Thanks!

    Hi Nathan,
    So are you running both IPV6 and IPV4? Do you have any clients that can't connect at all? Just on ping?
    The reason I ask is we had a server that was receiving IPV6 fine, but on receiving IPV4 would switch to IPV6 to connect SSL back to the client. Of course the clients never received it and just got a timeout. Funny thing is cell phones had no issue
    at all because they were straight IPV6. Only clients with both protocols got the timeout.
    So the ack was send back via the wrong protocol and nothing but the timeout is what the client sees. This may be an LLMNR issue. It came out from 2008R2 but think it may still apply
    Check this out:
    http://technet.microsoft.com/en-us/library/bb878128.aspx
    David Perkins
    IT Help Point, Inc.

  • Best way to pass IPv4 and IPv6 traffic over a GRE Tunnel

    Hello,
    We have two 3825 routers with Advanced Enterprise IOS 12.4.9(T). Each of them serves many IPv4 (private and public) and IPv6 networks on their respective site.
    We have created a wireless link between the two, using 4 wireless devices, with IP Addresses 10.10.2.2, 3, 4, 5 respectively (1 and 6 are the two end Ethernet interfaces on the routers).
    Then we created a GRE tunnel over this link using addresses 172.16.1.1 and 2 (for the two ends) to route traffic over this link.
    Now we want to route IPv6 traffic over the same link. However, we found that simply routing the IPv6 traffic over the above GRE / IP tunnel did not work.
    Questions:
    Is there a way we can use the same (GRE / IP) tunnel to transport both IPv4 and IPv6 traffic?
    If not, can we setup two GRE tunnels over the same wireless link, that is, one GRE / IP for IPv4 traffic and a second one GRE / IPv6 for IPv6 traffic?
    In brief, what is the suggested way to transport IPv4 and IPv6 traffic over the aforementioned (wireless) link?
    I have read http://www.cisco.com/c/en/us/td/docs/ios/12_4/interface/configuration/guide/inb_tun.html#wp1061361 and other Internet material, however I am still confused.
    Please help.
    Thanks in advance,
    Nick

    We have set up two tunnels over the same link, one GRE / IP for the IPv4 traffic and one IPv6 / IP ("manual") for the IPv6 traffic. This setup seems to be working OK.
    If there are other suggestions, please advise.
    Thanks,
    Nick

  • Firewall and IPv6, how to block ports?

    I am using free.fr in France, and IPv6 is enabled as part of the service. There are certain services running that were only accessible to the local network, but I now find that if I know the IPv6 address of the machine they are world accessible. I tried limiting services to be only accessible to the local machine, by adjusting the settings in the Firewall configurations in the system preferences, but the services still seem to be world accessible. Do the firewall configurations ignore IPv6? Is there any way to make it so that services are only available to machines in the local networks via IPv6. I suspect I going to need a command line tool or a third-party tool, but I am willing to deal with this until Apple sorts this out through a security update (please?).
    The machine in question is a G4 based PowerMac, so I can't upgrade to 10.5.

    Hi Andre,
    The machine in question is a G4 based PowerMac, so I can't upgrade to 10.5.
    What speed is it? 867
    Leopard requirements...
    * Mac computer with an Intel, PowerPC G5, or PowerPC G4 (867MHz or faster) processor
    minimum system requirements
    * 512MB of memory
    * DVD drive for installation
    * 9GB of available disk space
    Not sure on IPv6, since the whole purpose seems to be to pinpoint individual computers to the whole world, but IPFW may still work...
    WaterRoof is a firewall management frontend with bandwidth tuning, NAT setup, port redirection, dynamic rules tracking, predefined rule sets, wizard, logs, statistics and other features...
    http://www.macupdate.com/info.php/id/23317
    See also...
    http://oreilly.com/pub/a/mac/2005/03/15/firewall.html
    http://tadek.pietraszek.org/blog/2007/05/01/adding-custom-firewall-rules-in-osx/

  • WLC and IPv6

    Hi All,
    has anybody experiences with WLC and IPv6? I have activated the Check Box for IPv6 Support, but it does not work. Regards, Michael

    Hi ,
    Have you configued uplink router/sw to support ipv6 ; the sample config would look like this
    ipv6 unicast-routing
    interface FastEthernet0/0.6
    encapsulation dot1Q 56
    ip address 10.50.56.1 255.255.255.0
    ip access-group GNS2 in
    ip access-group GNS2 out
    ip helper-address 10.50.1.21
    ip pim sparse-dense-mode
    ip multicast ttl-threshold 1
    no snmp trap link-status
    ipv6 address 2006::/64 eui-64
    ipv6 address autoconfig
    ipv6 enable
    let me if this works for you or not
    regards
    Seema

  • U-verse, Time Capsule and IPv6

    Can anyone recommend the best settings related to IPv6 when using ATT U-verse and Time Capsule?  Time Capsule is set-up in Bridge Mode and IPv6 enabled on U-Verse Modem/Router.
    Should IPv6 be set to Automatic or Link-Local on Time Capsule or should I disable IPv6 all together?

    Because the other settings either do not work, or do not work reliably.....but Apple is "working on it".

  • ZBF in a mixed ipv4 and ipv6 environment, don't touch ipv4

    I have a dual stacked router for both ipv4 and ipv6. Ipv4 traffic should pass the zbf untouched due to the fact that there is another rock solid ipv4 firewall egress of the inside Interface. Is there a way that a class map like this could function on ipv6 traffic only?:
    class-map type inspect match-any fullproto
     description Permitted Traffic to internet
     match protocol http
     match protocol https
     match protocol dns
     match protocol imaps
     match protocol icmp
     match protocol ftp
     match protocol ntp
     match protocol rtsp
     match protocol realmedia
     match protocol netshow
     match protocol appleqtc
     match protocol streamworks
     match protocol vdolive
     match protocol ssh
     match protocol user-rdp
    So far there is only a CBAC solution in place for ipv6.
    I'm showing my Interfaces:
    interface FastEthernet0/0
     description *** Inside IPV6 ***
     no ip address
     speed auto
     full-duplex
     ipv6 address FE80::1 link-local
     ipv6 address ????:????:????:10::1/64
     ipv6 nd other-config-flag
     ipv6 dhcp relay destination ?:?:?:10::12
     ipv6 traffic-filter inne6-inn in
     no cdp enable
     no mop enabled
    interface FastEthernet0/0.4
     description *** Inside IPV4 ***
     encapsulation dot1Q 4
     ip address 82.?.?.129 255.255.255.248
     no cdp enable
    interface FastEthernet0/1
     description *** Outside ***
     ip address 82.?.?.42 255.255.255.252
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     speed auto
     full-duplex
     ipv6 address FE80::2 link-local
     ipv6 address ?:599::2/126
     ipv6 enable
     ipv6 nd prefix default no-advertise
     ipv6 nd prefix ?:599::/126 no-advertise
     ipv6 nd managed-config-flag
     ipv6 nd other-config-flag
     ipv6 nd router-preference High
     ipv6 inspect ipv6-cbac out
     ipv6 traffic-filter ut-inn6 in
     no cdp enable
     no mop enabled
    Please advise.
    Regards,
    Henning

    I didn't test it, but what about the following:
    Configure a new class-map where you match on an ipv6 access-list "any to any"
    Configure a third class map of type ""match all" where you match on your "fullproto" class-map and also the above ipv6 class-map. For this class map you configure your inspections.
    For ipv4-traffic you configure a class with a "pass" action in both directions.

  • Jpcap and ipv6 ?

    Hi everybody,
    I have to send and receive IPv6 packets. So I tried to use jpcap, and I encountered a problem : I can send ipv4 packets but when I try to send an ipv6 packet I get an error :
    java.io.IOException: only IPv4 packet is supported
    at jpcap.JpcapSender.sendPacket(Native Method)
    I send an IPPacket which can be filled with ipv4 and ipv6. Is this impossible or do I make a mistake ?
    Bests regards,
    Tycho

    pealse can you post the code allowing sending the packages IP v4
    because me I have probleme with these packet

  • E1200 PPPoE and IPv6

    Have a v2 E1200.  Connect with PPPoE to ISP.  IPv4 works fine.  With firmware included on router, 2.0.01, it would receive a /64 of IPv6 from the ISP.  This /64 would show up under 'status' / 'local network'.  Although it did not seem to advertise this space to PC's on my network so I was unable to use it.  I updated firmware to 2.0.04.  Now it does not even pick up the IPv6 /64 at all.
    Anyone have PPPoE and IPv6 working?  Anywhere I can download 2.0.01 to try it again?
    Is there a model of router that actually works with IPv6?

    Usually you have to power cycle both the modem and router to get it to work. Manual 6rd tunnel works on E4200v2/EA4500 with DSL PPPoE . Auto tunnel doesn't work with my connection, but it might with yours.
    If you have AT&T, here's the 6rd info.
    http://www.att.com/esupport/article.jsp?sid=KB414401&cv=801&title=IPv6%20compatibility%20for%20IFITL...
    Also, if your internet connection type is PPPoE, you should always check your MTU. More than likely you'll need to set it manual and enter the appropriate mtu.
    For ADSL PPPoE, the MTU is 1492.
    http://homekb.cisco.com/Cisco2/GetArticle.aspx?docid=266cc1c7b97c458fb04c2da21f985828_List_of_Common...

  • WAP300N and IPv6

    http://www.linksys.com/en-eu/products/accesspoints/WAP300N states that 
    "Equipped with the detachable antennas, built in DHCP server and IPv6 support, you will be guaranteed the latest in technology"
    However, I just took delivery of a unit today, and I have been unable to find a way to enable IPv6. It works fine on IPv4, but my network is dual stack, so some way of enabling IPv6 (at least forwarding so clients can autoconfigure and communicate) would be nice.
    Do I need a more recent firmware? I have 
     Firmware Version: 1.0.00, build 72, Dec 11, 2012
    - Peter

    You're right of course - once the rtadvd config actually included information for the relevant interface, it Just Worked(tm)
    - P

  • WRT54G v6 not working with new Motorola SB6141 on Comcast (IPv4 and IPv6)

    My WRT54G v6 not working with a new Motorola SB6141 Cable Modem on Comcast (IPv4 and IPv6).
    Yesterday, I had my old DOCSIS 1.1 cable modem and the WRT54G had been working just fine for the past 8 years.
    Last night, I swap in the DOCSIS 3.0 SB6141 cable modem, and now the WRT54G keeps losing the internet connection.  When I go into the status page for the WRT54G, I often do not see DNS servers and sometimes do not even see an IP address.
    If I connect a PC directly to the SB6141 cable modem, I have no problems whatsoever.  But whenever I connect through the WRT54G and power cycle both devices, then I have internet connectivity for about an hour before it drops out.  I have noticed my gateway IP address and DNS servers change at that time as well.  I can also force the Linksys to lose connectivity by doing a DHCP release/renew on the Linksys status page.
    Is this behavior because of the dual stack (IPv4 and IPv6) coming through the cable modem from Comcast now?  Is there any way I can keep using my WRT54G v6 now that I have the SB6141 cable modem?  

    You just have to install it correctly.
    http://kb.linksys.com/Linksys/ukp.aspx?pid=80&login=1&app=search&vw=1&articleid=3686

  • LabVIEW network library with support for SSL, Ping and IPv6

    I have posted on LAVA
    an OpenG package that will install a LabVIEW network library with
    support for SSL, Ping and IPv6.
     Please go there if you are
    interested to look it up.
    Rolf Kalbermatter
    CIT Engineering Netherlands
    a division of Test & Measurement Solutions

    Bob Y. wrote:
    OK,  but what is it and why should I use it?  What need does it fulfill?  I have been unable to find much documentation for this at the wiki page and maybe a couple of paragraphs here would help.
    Thanks,
    Bob Young
    Hi Bob,
    Yes, this info got burried.  Basically, it's a tool for building LabVIEW-based software products.  It is highly flexible/extensible and tries to fill the holes left by LabVIEW's built-in Application Builder.  Here are some good links to more info:
    OpenG Builder Homepage
    OpenG Builder 1.0 Documentation
    Thanks,
    -Jim

  • Dynamic DNS for ipv4 AND ipv6?

    tl;dr: do you know any dynamic dns service and updater daemon that supports both ipv4 and ipv6?
    Hi,
    ever since my provider supplied me with a proper dual stack account (real ipv4, real ipv6) for internet access I got some kind of little problem regarding the services I host at home. So this is mainly about email. I have a server sitting behind my router that has an open submission and IMAPS port. For ipv4 I've been using the NAT and dyndns features of my router (fritzbox) without any problem. For ipv6 there is no NAT (at least as far as my router is concerned). What I can do though is to open the firewall for incoming ports dynamically based on the interface identifier. So if someone wants to connect to an ipv6 address that would map to my server the router knows to not block the traffic. For this to work though I need update a dynamic DNS record with the public ipv6 address that my server gets to use (something out of the prefix my provider assignes me). This server is an arch linux box. I tried to use inadyn-mt with some systemd unit file I found through google but this does not seem to work right. When I'm in ipv4-only networks (on a mobile connection for example) I often can't resolve the right ip address of my server through dyndns. The thing is that my server doesn't know about a changed ipv4 address because this is handled by the router. It does only know about when his own ipv6 address changes/expires. Based on when this happens inadyn-mt might fire an update to dyndns and with that also pick up the new ipv4 address, but this is not guaranteed.
    Any suggenstions, tool and/or service proposals? Is there a way dns-wise to add a CNAME alias just for A records and not for AAAA?

    I currently use cloudflare as the DNS servers for my domain as it's free and allows to update certain records with their API. I only use it for IPv4, but since they support AAAA records, I assume it will work for IPv6 just as well. It should be quite simple for you to update the script to get the ip of a given interface instead of fetching it from the net.
    #!/bin/sh
    # modified by jfro from http://www.cnysupport.com/index.php/linode-dynamic-dns-ddns-update-script
    # Uses curl to be compatible with machines that don't have wget by default
    # modified by Ross Hosman for use with cloudflare.
    cfkey=<your api key>
    cfuser=<your username>
    cfhost=<hostname you want to update>
    WAN_IP=`curl -s http://icanhazip.com/`
    if [ -f $HOME/.wan_ip-cf.txt ]; then
    OLD_WAN_IP=`cat $HOME/.wan_ip-cf.txt`
    else
    OLD_WAN_IP=""
    fi
    perl -i -pe 'chomp if eof' /var/log/cfclient.log
    if [ "$WAN_IP" = "$OLD_WAN_IP" ]; then
    echo -ne "." >> /var/log/cfclient.log
    else
    echo $WAN_IP > $HOME/.wan_ip-cf.txt
    echo -ne "\nUpdating IP to $WAN_IP\n" >> /var/log/cfclient.log
    curl -s https://www.cloudflare.com/api.html?a=DIUP\&hosts="$cfhost"\&u="$cfuser"\&tkn="$cfkey"\&ip="$WAN_IP" >> /var/log/cfclient.log
    fi
    echo -ne "\n" >> /var/log/cfclient.log

  • Problem running apache dual stack IPv4 and IPv6

    Hello!
    I am running a single Lion-Server with one public IPv4 address. Because my Provider is able to support IPv6 now, I ordered a public IPv6 address for my server. (To learn IPv6)
    I setup IPv6 address and setup the firewall with ip6fw - everything works fine, I can connect to ssh and afp via IPv4 or IPv6 but when I try to connect to my wiki over IPv6 I get the certificate question (unknown certificate ... blah) click continue and the certificate is loeded againe - I end up in an infinte loop of certificate questions.
    The part of the firewall config looks like this:
    20515 allow tcp from any to any 443
    20516 allow tcp from any to any 8443
    20517 allow tcp from any to any 1640
    I looked into apache config:
    /etc/apache2/sites/virtual_host_global.conf has this entries:
    Listen  *:443
    NameVirtualHost *:443
    Listen  *:80
    NameVirtualHost *:80
    I have only one domain and only one single virtual host as defined in /etc/apache2/sites/0000_any_443_.conf:
    ## Default Virtual Host Configuration
    <VirtualHost *:443>
            ServerAdmin [email protected]
            DocumentRoot "/Library/Server/Web/Data/Sites/Default"
            DirectoryIndex index.html index.php /wiki/ default.html
            CustomLog "/var/log/apache2/access_log" combinedvhost
            ErrorLog "/var/log/apache2/error_log"
            <IfModule mod_ssl.c>
                    SSLEngine On
                    SSLCipherSuite "ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM"
                    SSLProxyEngine On
                    SSLProtocol -ALL +SSLv3 +TLSv1
                    SSLCertificateFile "/etc/certificates/www.ABCDE.de.1A00F8DFC2738F25D26E3248A4C8F687D7EA7F32.cert.p em"
                    SSLCertificateKeyFile "/etc/certificates/www.ABCDE.de.1A00F8DFC2738F25D26E3248A4C8F687D7EA7F32.key.pe m"
                    SSLCertificateChainFile "/etc/certificates/www.ABCDE.de.1A00F8DFC2738F25D26E3248A4C8F687D7EA7F32.chain. pem"
                    SSLProxyProtocol -ALL +SSLv3 +TLSv1
            </IfModule>
            <Directory "/Library/Server/Web/Data/Sites/Default">
                    Options All +MultiViews -ExecCGI -Indexes
                    AllowOverride None
                    <IfModule mod_dav.c>
                            DAV Off
                    </IfModule>
            </Directory>
    </VirtualHost>
    I have not modified the apache config by hand until now - but this was an upgrade from Snow Leopard Server. At the moment I am a littel scared to upgrade to Mountain Lion server because this server runs mail and calender services for my company.
    I tried to setup "Listen" entry with dedicated IP-addresses, one for IPv4 and one for IPv6 but this only leads to the same problem - IPv4 works, IPv6 ends in an infinte loop.
    I found somewhere that I had to duplicate virtual hosts setup for IPv4 and IPv6 but afaik "Server.app" will overwrite it, right?
    Every hint is welcome, bye
    Christoph
    P.S. Sorry just saw that I posted to ML-Server discussions not Lion-Server, but maybe someone can tell me that I can upgrade without scare.
    Message was edited by: Christoph Ewering1

    Hello!
    Did some more testing and found that FireFox works with the loopback-address.
    https://[::1]/
    So, the address above works with FireFox after accepting the certificate - Safari loops in the dialog accepting the certificate.
    Then I tried the link-local-address but it looks like apache does not listen to that address at all
    Then I tried the global-address and got to:
    Safari looping in the certificate dialog
    FireFox brings an alert „sec_err_bad_database"
    BTW this tests were made on the server that runs the apache. So no firewall between the browser and the server.
    No one using Mac OS X server in a dual stack enviroment?
    Bye,
    eweri

Maybe you are looking for

  • Remove null values from string array

    Hi , I have a string array in a jsp page which I save some values inside. After I store the values I want to print only those who are not null. How can I do this? Is there a way to delete the null values?

  • Oracle 11g New Feature

    Hi Experts I am currently doing a Oracle 9.2.0.8 32bit upgrade to 11gR2 64bit and I come across Oracle Document ID 7691270.8 and Oracle Database 11gR2 Upgrade Companion (Version 2.80). Both mention about the new feature of datafilewrite_errors_crash_

  • Trigger with sequence question

    figured it out Edited by: Jay on Apr 24, 2012 9:49 AM

  • 2 external displays? is it possible and how?

    any info would be nice i have a 15" MBP late 2008 just want to hook 2 external monitors up to it ... im about to go buy them soon.

  • How to update Activity based upon Campaign

    Hi ! We have created some Campaigns with campaignelements. These elements has been "connected" to different BP - based upon roles. The corresponding Activities, then has to be updated (Fields: Dates and Status) Our task is to create a routine/program