ListFiles in Applet but on the server-site

Hi,
does anyone knows how to get a list of files in Applet which are in folder on the server, where the applet is stored?
Thank you
KarFil

With just applet - No you cannot do that
With some server side component - Yes
You have to have server side component(servlet/rmis-server/ejb) which should be hosted in the same server. This server side component should code to query the files and provide it to the applet.

Similar Messages

  • What is the purpose of "Adobe Credential " in the server site ?

    Hi,
    I have read some installation pre-requisite in the server site for implement SAP Adobe Interactive form in the FAQ :
    1. SAP Web AS 6.40 Java (for all scenarios)
    2. SAP Web AS 6.40 ABAP (if you are looking at high-volume print scenarios)
    3. Adobe document services (run-time component)
    4. Adobe Credential (for creating interactive PDF forms).
    could you please give me some enlighteening on the number 4 ? is that compusory ?
    Thank You and Best Regards
    Fernand Lesmana

    Hi Fernand,
    4. Adobe Credential (for creating interactive PDF forms).
    could you please give me some enlighteening on the number 4 ? is that compusory ?
    The type of credential they are referring to in 4) is a Readers Right credential. Basically it is a special file of the form PKCS #12 that you install on your ADS system to enable your users using interactive forms to be able to save data into the form using Adobe Reader. It's a usage rights credential, without which you will not be able to save data in a PDF document. You will need to decide from a business point of view whether it is required or not as it is not compulsory unless you use interactive forms.
    You also get other credentials for digital signatures and certification.
    Regards,
    Nelis

  • How can I change the link color css in one module but not the whole site?

    I have a site built in muse but using modules from BC.  I changed the link color in the css for the online store and blog but of course it is applying it to everypage.  Is there a way to change the link color in an individual BC module instead of the whole site.?  I'm new to CSS obviously.
    Thanks
    Josh

    I don't think you can do it right in Muse but you can easily if you have access to the code of the page and the css file.
    You need to create a css class something like:
    .secondLink a      {     /*  secondLink can be any class name, I just chose that randomly
         color: #990000;     /* of course substitute your color code in there
    Then in your code add:
    class="secondLink"
    to your link's <a> tag. This will give any links with the class of secondLink the color assigned. Hope that helps get you started.

  • Why do emails on my Macbook Air take longer than they do to appear on the server site?

    When I send or receive an email by clicking on the email icon at the bottom of the screen, it often takes longer to be sent or be received than if I go directly into the internet email site where it appears immediately.  At times, some people to whom I have sent emails do not receive them until hours later and conversely, incoming emails appear on the internet email site soon than they appear on my computer.  Can this be remedied?

    Do you use Navionics for marine a marine chart plotter?  I noticed that after I installed all their (lousy) software on my MPB, this Navservice app would start up each time I booted.   It took me a while, but I tracked it down to the "LaunchAgents" folder in my system library.   Siince I quit the app each and every time I boot my MBP, I decided I didn't need it so I simply renamed the file from "com.apple.NavService.plist" to "com.apple.NavService.plist.old" and rebooted my MBP.  Voila, no more NavService app running in the background. 
    As far as the purpose of this thing, the plist entry is launching the following app:
    /Applications/Navionics World/NavService.app/Contents/MacOS/NavService
    Take a look and see if you have the same thing. 
    The Navionics software for the Mac is obviously written by someone that doesnt' understand how Macs really work, and they scattered junk all over the place with their install routines.  In fact, if you update the software it will place redundant copies in redundant folders, etc. making it impossible to know which versions are the latest, etc.

  • Password protecting a page, but not the whole site....

    Thanks for all the help so far, site is almost done.
    On the website www.kansascrew.com I want to have a members only section.  This will allow my rowers to download excuse letters etc.  How can I passord protect just that section/page of the website?  I don't want random students downloading the excuse letters and turning them in.
    Thanks for any help.

    You might want to get David Powers book  http://foundationphp.com/dwcs4/ work through the registration part and then setting up the pages you want to block, it is done with sessions, a great book to learn how this is done using dw cs4,  also you may want to validate your code, it has a number of errors, good luck with your project.

  • How to set the granted permission in RMI SERVER site

    Hi everyone,
    I have developin some simple RMi program but the error message is keep on prompting out and I cant really test out what is the result. I understand I got to GRANT the permission for the RMI but I I dun really know where should I start first. I know there are code that can be implement in the sErver site, just hope some one can guide me out.
    Thank lot...
    here is the code for server:
    import java.rmi.*;
    import java.rmi.server.UnicastRemoteObject;
    public class myRMIServer
    public static void main(String[] argv)
    System.setSecurityManager(new RMISecurityManager());
    try
    myRMIImpl implementation = new myRMIImpl("myRMIImplInstance");
    catch (Exception e)
    System.out.println("Exception occurred: " + e);
    Where should i code the getProperties and setProperties code...

    so, what u mean is the problem occur doesnt related to coding part ?? do you think it is because I did not start the rmiRegistry, but somehow when i started the rmiRegistry, the console window is blank an it is nothing in the window. pls pls help me to solve this problem... sound easy initially but end up it is not...
    by the way, here is the code
    Interface
    public interface myRMIInterface extends java.rmi.Remote
    public java.util.Date getDate() throws java.rmi.RemoteException;
    Interface Implementation
    import java.rmi.*;
    import java.rmi.server.UnicastRemoteObject;
    public class myRMIImpl extends UnicastRemoteObject implements myRMIInterface
    public myRMIImpl(String name) throws RemoteException
    super();
    try
    Naming.rebind(name, this);
    catch(Exception e)
    System.out.println("Exception occurred: " + e);
    public java.util.Date getDate()
    return new java.util.Date();
    server
    import java.rmi.*;
    import java.rmi.Naming;
    import java.rmi.RMISecurityManager;
    import java.rmi.server.UnicastRemoteObject;
    import java.rmi.registry.LocateRegistry;
    import java.util.Properties;
    public class myRMIServer
    public static void main(String[] argv)
    //System.setProperty("java.security.policy","C:\\workspace\\MyRMI\\java.policy");           
    //System.getProperty("java.security.policy","C:\\workspace\\MyRMI\\java.policy");
         //myRMIServer m = System.getProperties();
         //m.setProperty("java.security.policy","C:\\workspace\\MyRMI\\java.policy");
         //System.setSecurityManager(new RMISecurityManager());
    //Properties p = System.getProperties();
    //p.setProperty("java.security.policy","C:\\workspace\\MyRMI\\java.policy");
    try
    myRMIImpl implementation = new myRMIImpl("myRMIImplInstance");
    Properties p = System.getProperties();
         System.setProperty("java.security.policy","C:\\workspace\\MyRMI\\java.policy.txt");
         System.setProperty("java.rmi.server.codebase","file:///P:\\Projects\\RMIServer\\bin");
         if (System.getSecurityManager() == null) {
         System.setSecurityManager(new RMISecurityManager());
         System.out.println("Security manager registered");
         //System.out.println("Service registered");
    catch (Exception e)
    System.out.println("Exception occurred: " + e);
    here is the code, to run, I got a client one as well, but is just for displat purpose..
    thank you, guys....really appreciate ur help

  • Printout from applet varies depending on server

    We have always run our web app on Tomcat on Windows, but we're trying to move it to Linux. One small but important component of our site is a simple signed applet that allows users to print out 4x6 packing labels on a thermal printer. If the Zebra (or whatever brand) printer driver is installed properly, the label image lines up perfectly.
    Everything continues as normal when the web app is running on a Linux box in our internal/private network, but when the server is our new production Linux server (which is sitting outside our internal network), the image that gets pulled down by the applet is half an inch too far to the right. The code is the same, the Tomcat startup parameters telling it to start headless are the same, the version of Enterprise Red Hat is the same...what could be causing this difference?
    I know I'm reaching here, but does it have anything to do with SSL or the applet being signed or something like that? Obviously right now, we don't access that new production machine by DNS name yet--we just hit it by its public IP address (which goes through a BigIP load balancer). I just need to know what in the world to look for!
    Thanks...

    Weird...that problem was occuring when trying to print with Firefox 0.9.2, but it doesn't occur for IE 6. Both browsers have Java plug-ins associated with 1.4.2 versions of the JRE. This doesn't make me happy at all...that same Firefox browser prints labels from our current Windows-based webserver without a hitch. Why would this Firefox browser move the document/image over half an inch when the webserver was a Linux one, but the IE client browser wouldn't do that? Remember, both use the same JAR for the applet code...

  • Unable to access gif files from the server

    hi all,
    i have successfully signed an applet and it is loading in the client system also. in that applet, i instantiated a jbutton as given below:
    JButton jb = new JButton(new ImageIcon("http://192.168.91.154:8080/success/set.gif"));
    but the icon din appear and a blank button appears, even when accessed from the server system.
    if i give the exact path like c:/blazix/webfiles/success/ set.gif, the icon is coming in the server system but not in other systems. i tried without port no also but in vain. pl solve my problem. what i need is how to
    specify the path of the file[any file] which is present in server.
    or if i put all the gif files in the jar file, can i access the gif files present in the jar file [set for archive] ? if i can, give me the soln for accessing the gif file present in the jar file, so that i need not access the server to get the gif files.(i.e) how to specify the path of the gif files present in the jar file?
    i ve one more doubt. the jni library file shld be in the server, and the client has to access the library in the server. i think the applet loaded in the client ll search for the library in the local m/c only . how to make the applet to search for library in the server??
    i feel only by using rmi we can solve this problem. am i correct? if so i feel that an appln or applet running in the server shld access the jni library, and the applet in the client side should communicate with this server appln using rmi to get the data.is it correct? is there
    anyother way?
    i appreciate your help in this regard. thanks in advance. bye, padmanbhan.

    Better information on what you are doing with JNI might help you get an answer.
    If you have some server process that needs to use JNI, then I would code a servlet to call, instead of using RMI to ge there.
    Depending on your environment, and the target audiences environment, RMI may just cause you a lot of grief. Firewalls etc, get in the way of RMI connections and force security holes to be opened in order to work.
    If you use a servlet, then traffic to your server process is done via standard http calls, which will already be enabled, because your app runs in a browser.
    If ther data requirements are heavy duty, your server could always send an XML stream to the client, which would allow you to describe complex data to the client.
    Running JNI stuff from the client directly means a lot of local infrastructure to run your app. The code you want to run, the JNI library ....
    If what you have is really an application, but want the convenience of starting it from a browser, look at Java WebStart. Then you can distribute an application via the browser, and WebStart will worry about the deployment issues for you.
    In Summary:
    Stay away from RMI from applets if you can help it.
    If you really have an App, then try WebStart to manage the distribution issues for you.

  • Clear classloader when exit applet, but not browser

    Hi there,
    I've got some problems with the classloader.
    when i start my applet with the language de, it will correctly name the buttons etc. in german.
    in my site it is possible to change the language. after clicking on another lanuage, my applet
    restarts with the correct parameters (language=en), but the buttons and so on are still named in
    german.
    i figured out, that after clearing the classloader cache, the language is the correct one.
    how can i clear the classloader cache when i leave the applet, but not the browser?
    thanks in advance!

    Hi there,
    I've got some problems with the classloader.
    when i start my applet with the language de, it will correctly name the buttons etc. in german.
    in my site it is possible to change the language. after clicking on another lanuage, my applet
    restarts with the correct parameters (language=en), but the buttons and so on are still named in
    german.
    i figured out, that after clearing the classloader cache, the language is the correct one.
    how can i clear the classloader cache when i leave the applet, but not the browser?
    thanks in advance!

  • I can not connect to the server

    I just installed lion and server lion upgrades. At the beginning everything was fine. I was trying to change some of the parameters of the site. Since i restarted the server it does not recognizes the user/password. It does not open the application. I am logged in as admin. I have even created a new admin user but it does not allow me in. When I hit return the window shakes indicating it does not recognizes the password but how is that possible since I just logged in with that same user and password. The only thing I can think of is that I have changed without realizing the permission for the application to query the system passwords. But I have no idea how I could have done that. One more detail the server site can be accesed as an internet client... so I know it is running.
    Guillermo.

    Try the following:
    1. Turn router off for 30 seconds and on again
    2. Settings>General>Reset>Reset Network Settings
    3. Reset iPad; hold the Sleep and Home button down until you see the Apple Logo

  • Document.passivate() giving problem in the server environment

    I am having two J2EE web applications accessing PDF forms using LiveCycle API. They both are invoking a short-lived process with RenderPDFForm service that takes form and formdata and renders a PDF form. The code where these applications communicate with Livecycle server is same for both the apps. The applications work fine in the local environment. But in the server environment, one of them work and the other fails with security certificate exception. These applications are deployed to the same server. The application that fails is failing during document.passivate() call. Here is the log message.
    com.adobe.idp.DocumentError: javax.net.ssl.SSLHandshakeException: com.ibm.jsse2.util.h: PKIX path validation failed: java.security.cert.CertPathValidatorException: The certificate expired at Wed Jul 01 15:28:21 CDT 2009; internal cause is:
    java.security.cert.CertificateExpiredException: NotAfter: Wed Jul 01 15:28:21 CDT 2009
    at com.adobe.idp.Document.passivateInitData(Document.java:1562)
    at com.adobe.idp.Document.passivate(Document.java:1241)
    at com.adobe.idp.Document.passivate(Document.java:1185)
    at com.adobe.idp.DocumentManagerClient.passivate(DocumentManagerClient.java:236)
    at com.adobe.idp.dsc.provider.impl.base.RequestOutputStream.defaultPassivate(RequestOutputSt ream.java:40)
    at com.adobe.idp.DocumentRequestOutputStream.passivate(DocumentRequestOutputStream.java:56)
    at com.adobe.idp.Document.writeObject(Document.java:872)
    I know it looks like a security certificate exception. But the rest of the application work just fine. The application fails only during document.passivate().
    Any ideas ?
    Thanks,
    Jytohi

    I am having two J2EE web applications accessing PDF forms using LiveCycle API. They both are invoking a short-lived process with RenderPDFForm service that takes form and formdata and renders a PDF form. The code where these applications communicate with Livecycle server is same for both the apps. The applications work fine in the local environment. But in the server environment, one of them work and the other fails with security certificate exception. These applications are deployed to the same server. The application that fails is failing during document.passivate() call. Here is the log message.
    com.adobe.idp.DocumentError: javax.net.ssl.SSLHandshakeException: com.ibm.jsse2.util.h: PKIX path validation failed: java.security.cert.CertPathValidatorException: The certificate expired at Wed Jul 01 15:28:21 CDT 2009; internal cause is:
    java.security.cert.CertificateExpiredException: NotAfter: Wed Jul 01 15:28:21 CDT 2009
    at com.adobe.idp.Document.passivateInitData(Document.java:1562)
    at com.adobe.idp.Document.passivate(Document.java:1241)
    at com.adobe.idp.Document.passivate(Document.java:1185)
    at com.adobe.idp.DocumentManagerClient.passivate(DocumentManagerClient.java:236)
    at com.adobe.idp.dsc.provider.impl.base.RequestOutputStream.defaultPassivate(RequestOutputSt ream.java:40)
    at com.adobe.idp.DocumentRequestOutputStream.passivate(DocumentRequestOutputStream.java:56)
    at com.adobe.idp.Document.writeObject(Document.java:872)
    I know it looks like a security certificate exception. But the rest of the application work just fine. The application fails only during document.passivate().
    Any ideas ?
    Thanks,
    Jytohi

  • How to Generate PDF file on the server

    Hello Everybody !
    I Need to generate a PDF File on the server, and I'm usin the command :
    "OPEN DATASET p_path FOR OUTPUT IN BINARY MODE message l_verro .
           LOOP AT t_lines.
             TRANSFER t_lines-tdline TO p_path.
           ENDLOOP.
           CLOSE DATASET p_path.  "
    The File was generated, but is corrupt . Don't Open the file, It's wrong.
    When I use the function GUI_DOWNLOAD the file is generated  right. But in the server not.
    Can someone help me please ??
    Best Regards,
    Wagner Duarte

    Hi.
    did you check this post?
    Download PDF File to SAP Application Server
    It doest the same as you are asking.
          " Write PDF Binary Data to App Server
        OPEN DATASET lv_filename FOR OUTPUT IN BINARY MODE.
        IF sy-subrc = 0.
          LOOP AT lines INTO ls_data.
            TRANSFER ls_data TO lv_filename.
          ENDLOOP.
        ENDIF.
        CLOSE DATASET lv_filename.
    Regards
    Miguel

  • Logout works fine on Local Machine but not on Server

    I have the following code in my backing bean:
          ExternalContext external =
            FacesContext.getCurrentInstance().getExternalContext();
          HttpSession session = (HttpSession) external.getSession(false);
          session.invalidate();
         // redirect using response because logout is a HTML page
          HttpServletResponse response =
            (HttpServletResponse) external.getResponse();
          response.sendRedirect("../logout.html");The problem is that this works fine on my local machine http://localhost:8888/my-context-root
    but on the Server clicking on the Logout link gives Page cannot be displayed.
    The protocol is https://ip-address:port/my-context-root and on the local machine it's http
    Is it the https thats causing the problem ?
    I also tried using:
    external.redirect("../logout.html"); but this also didn't help.

    The URL for Login is
    https://ip address:port/my-context-root/restricted/home.facesWhen the logout link is clicked the same URL is rendered.
    Backing bean is
    public class HomeBackingBean
      public String logout()
        try
          ExternalContext external =
            FacesContext.getCurrentInstance().getExternalContext();
          HttpSession session = (HttpSession) external.getSession(false);
          session.invalidate();
          //FacesContext.getCurrentInstance().responseComplete(); 
          Utility.logDebug("Session invalidated, trying to redirect to logout.html");
          // redirect using response because logout is a HTML page
          HttpServletResponse response =
            (HttpServletResponse) external.getResponse();
         response.sendRedirect("../logout.html");
        catch (IOException ioEx)
          Utility.logDebug("Failed to logout due to IOException");
        return null;
    }The exit.jsp is :
    <%@ taglib uri="http://java.sun.com/jsf/html" prefix="h"%>
    <%@ taglib uri="http://myfaces.apache.org/trinidad" prefix="tr"%>
    <h:form>
        <tr:commandLink styleClass="logout" text="Logout"
                        action="#{homeBean.logout}"/>
    </h:form>The server log says:
    07/31 23:42:19 DEBUG [com.eds.send.common.Utility] Session invalidated, trying to redirect to logout.html
    07/31 23:42:19 DEBUG [com.sun.faces.application.NavigationHandlerImpl] No navigation rule found for outcome nulland viewId /r
    estricted/home.faces Explicitly remain on the current view
    07/31 23:42:19 DEBUG [com.sun.faces.lifecycle.InvokeApplicationPhase] Exiting InvokeApplicationsPhase
    07/31 23:42:19 DEBUG [com.sun.faces.el.ValueBindingImpl] getValue(ref=restricted$home)
    07/31 23:42:19 DEBUG [com.sun.faces.application.ApplicationImpl] Couldn't find a factory for restricted$home
    07/31 23:42:19 DEBUG [com.sun.faces.el.VariableResolverImpl] resolveVariable: Resolved variable:null
    07/31 23:42:19 DEBUG [com.sun.faces.el.ValueBindingImpl] getValue Result:null
    07/31 23:42:19 DEBUG [com.sun.faces.el.ValueBindingImpl] getValue(ref=restricted$home)

  • ACE: if one server is loaded and it want to use the server not loaded? how?

    Hello,
    I have 2 real Servers (10.24.8.200 and 10.24.8.201) in loadbalance (HTTP and HTTPS) with VIP 10.24.16.10, and the type of loadbalance is round robin, but when the server (10.24.8.200) has high proccessing for example memory or hard disk and users try to access to server (10.24.8.200) this is more slow. if this server is too loaded? how can the ACE switch to another real server? in 10 seconds for example?
    Best Regards
    My configuration is:
    ACE-MOD6/integracion1# sh runn
    Generating configuration....
    access-list anyone line 8 extended permit ip any any
    probe http get-index
    interval 4
    open 2
    recieve 2
    faildetect 2
    passdetect interval 10
    expect status 200 200
    rserver host Srv1
    ip address 10.24.8.200
    probe get-index
    inservice
    rserver host Srv2
    ip address 10.24.8.201
    probe get-index
    inservice
    serverfarm host servers
    rserver Srv1
    inservice
    rserver Srv2
    inservice
    class-map type management match-any ADM-CONTEX-SERV1
    2 match protocol telnet any
    3 match protocol ssh any
    4 match protocol icmp any
    class-map type http loadbalance match-all Check-Headers
    2 match http url .*
    3 match http header Host header-value "10.24.16.*"
    4 match http header User-Agent header-value ".*MSIE.*"
    class-map match-all VIP-10-HTTP
    2 match virtual-address 10.24.16.10 tcp eq www
    class-map type http loadbalance match-all other-HTTP
    2 match http url .*
    policy-map type management first-match ADM-CTX-SERV1
    class ADM-CONTEX-SERV1
    permit
    policy-map type loadbalance first-match L7-logic
    class Check-Headers
    serverfarm servers
    class other-HTTP
    serverfarm servers
    policy-map type loadbalance first-match lb-logic
    class class-default
    serverfarm servers
    policy-map multi-match client-vips
    class VIP-10-HTTP
    loadbalance vip inservice
    loadbalance policy L7-logic
    loadbalance vip icmp-reply active
    interface vlan 60
    description inside
    ip address 10.24.8.5 255.255.255.0
    access-group input anyone
    access-group output anyone
    service-policy input ADM-CTX-SERV1
    no shutdown
    interface vlan 233
    description outside
    ip address 10.24.16.5 255.255.255.0
    access-group input anyone
    access-group output anyone
    service-policy input ADM-CTX-SERV1
    service-policy input client-vips
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.24.16.1

    If your server is running an SNMP agent, the ACE can use SNMP to pull stats from the server. You'll just need the correct OID. For instance, if you were using Linux, you might use something like the following as a probe:
    probe snmp linux-stats
    interval 10
    community public
    oid .1.3.6.1.4.1.2021.10.1.5.1
    threshold 75
    .1.3.6.1.4.1.2021.10.1.5.1 is the OID for CPU load average (for Linux, Windows would have a different OID). If it goes above 75, the server is marked as out. When used with the least-loaded predictor, it will also divert more traffic to the least loaded server, as defined by that OID. You can use multiple OIDs in conjunctions and give them different weights.
    However, judging from your timeout value of your get-http health check, I would check to see if the issue isn't that your servers are flapping because of a too-low receive threshold. Each server has 2 seconds to respond to the ACE, which may not enough time given that the servers may be getting a lot of traffic and you're doing these checks every 4 seconds.
    If one fails, the other gets all the traffic, until it is overloaded, and it fails. By this time, your other servers has calmed down, and gets all the traffic, and the cycle repeats itself. Check SNMP traps or SYSLOG to see if this is the case.
    Either way, you might want to change the timeout to 5 or 10, to give them more breathing room.

  • Rollback is not working when "The server threw an exception" error

    Hi
    These are my transaction steps
    1) Call the StartTransaction method of the company object (Function AA)
    2) Add  Goods Issue (Rollback if error occurs) (Function BB)
    3) Create record with oRecordSet object (Rollback if error occurs) (Function BB)
    4) Add Journal Entry (Rollback if error occurs) (Function CC)
    5) Add Goods Receipt (Rollback if error occurs) (Function DD)
    6) Create record with oRecordSet object (Rollback if error occurs) (Function DD)
    7) Call EndTransaction (with commit) to complete the whole process (Function AA)
    These are working fine usually.
    But problem is when user has "The server threw exception" error message.
    Whole transaction must be rollback but still step 2 and 3 records are exist on DB.
    Rollback is working fine with another error messages.
    I programmed call Rollback transaction if calling function has any error.
    Function BB, CC and DD are calling from Function AA.
    I never have "The server threw an exception" error on my development machine with B1 2005 PL 51.
    This is happened only  LIVE server with B1 2005 PL 51.
    B1 was upgraded from PL29 to PL51 recently becaseu of Locking issue.
    Then Locking issue was solved but have "The server threw an exception" error and rollback is not working properly.
    I hope someone can help me!!!!.
    Thank you
    2) & 3) steps

    Hi Joanne,
    There are 2 things to check here.
    1. is the Transaction
    2. is the RPC_E_SERVERFAULT.
    for the first one,
    in step 2, just before you add the Good Issue, can you try to check first if you are still in a transaction ?
    Just to make sure.
    If it is, maybe you should open a ticket to SAP support.
    BTW, Which version is your Live environment ?
    for the second one,
    try to search the error in this forum. there is a lot of posting about this.
    The problem might also go away if you upgraded your SBO.
    Please search and see if there is anything the same with your problem.
    Regards
    Edy

Maybe you are looking for