Load balance traffic to a service based on a added field in the HTTP Header

I am trying to use HTTP Header Load balancing but the field we want to use in order to load balance is "user-defined", example HTTP_TOTO = toto1.
Do you have any idea on how I could perform this ?
Thanks in advance

Load balancing using pre-defined headers is supported. Not sure if load balancing using user defined fields is possible. You could refer to the following document.
http://www.cisco.com/univercd/cc/td/doc/product/webscale/css/css_710/bsccfggd/httphead.htm
We would appreciate it if someone could share their experience if they know more about this.

Similar Messages

  • Timeouts on non load balanced traffic thru ACE

    I have a backend server creating a connection to a db server outside the ACE environment. This traffic is using the L3 function of the ACE and is not being load balanced. The connection is timing out after 1 hour. I have normalization disabled on the backend server VLAN but not on the front side VLAN of the ACE.
    2 Questions:
    - With normalization disabled do I still need to change the tcp inactivity timeout for this traffic? Or with normalization disabled shouldn't the non load balanced traffic be L3 routed and not effected by the tcp timeout value?
    - Also do I need to disable normalization on the front side VLAN of the ACE?
    thanks,
    kurt

    As per
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/v3.00_A1/configuration/security/guide/tcpipnrm.html#wp1075741
    "Disabling TCP normalization affects only Layer 4 traffic. TCP normalization is always enabled for Layer 7 traffic."
    By disabling TCP normalization the following Layer 4 connection parameters are ignored.
    exceed-mss-----Configure behavior if a packet exceeds MSS
    random-seq-num-disable----Disable TCP sequence number randomization
    reserved-bits-----Configure Reserved bits in TCP header
    syn-data-----Configure behavior for a SYN packet containing data
    tcp-options-----Configure TCP header options
    urgent-flag-----Allow/Clear Urgent flag
    I think you will need "Set timeout inactivity xxxx" command even if "no normalization" command is defined.
    Syed Iftekhar Ahmed

  • Load runner: in which the HTTP header is stored?

    I've used Mercury Load runner to stress test our Web application.
    We used a session variable in the url, so after I scripted, I can't replay it (error: session is expired). So, I want to know, in Mercury Load runner, where the HTTP header is stored?

    Hi,
    The issue is not where the http header is stored. For make it works you just have to create a correlation to get this session id dynamically in your script.
    For know how to do it have a look at the web_reg_save_param function documentation or ask google.
    Regards,
    Sylvain

  • Question on how does load balancing work on Firewall Services Module (FWSM)

    Hi everyone,
    I have a question about the algorithm of load balancing on Firewall Services Module (FWSM).
    I understand that the FWSM supports up to three equal cost routes on the same interface for load balancing.
    Please see a lower simple figure.
    outside inside
    --- L3 SW --+
    |
    MHSRP +--- FWSM ----
    |
    --- L3 SW --+
    I am going to configure the following default routes on FWSM point to each MHSRP VIP (192.168.13.29 and 192.168.13.30) for load balancing.
    route outside_1 0.0.0.0 0.0.0.0 192.168.13.29 1
    route outside_1 0.0.0.0 0.0.0.0 192.168.13.30 1      
    However I don't know how load balancing work on FWSM.
    On FWSM, load balancing work based on
    Per-Destination ?
    Per-Source ?
    Per-Packet ?
    or
    Other criteria ?
    Your information would be greatly appreciated.
    Best Regards,

    Configuring "tunnel default gateway' on the concentrator allowed traffic to flow as desired through the FWSM.
    FWSM is not capable of performing policy based routing, the additional static routes for the VPN load balancing caused half of the packets to be lost. As a result, it appears that the VPN concentrators will not be able to load balance.

  • Load-balancing between Analytical Provider service nodes in a cluster

    Hi All,
    - First a little background on my architecture. My EPM environment consist of 3 Solaris servers:
    Server1: Foundation Services + APS + EAS + WLS Admin server
    Server2: Foundation Services + APS + EAS
    Server3: Essbase server + Essbase Studio server
    All above services are deployed to a single domain. We have a load-balancer sitting in front of server1 and server2 that redirects request based on availability of the services.
    - Consider APS:
    We have a APS cluster "AnalyticProviderServices" with members AnalyticProviderServices1 deployed on Server1 and AnalyticProviderServices2 deployed on Server2.
    So I connect to APS and login as user1. Say the load-balancer decides to forward my request to server1, so all my request are then managed by APS on Server1. Now if APS on server1 is brought down, then any request to APS on server1 are redirected by weblogic to APS on server2.
    Now ideally APS on server2 should say "hey I see APS on server1 is down so I will take up your session where it left off". So I expect the 2nd APS node in the cluster to tale up my session. But this does not happen.. I need to login again when I hit refresh in excel as I get the error "Invalid session.. Please login again". When I open EAS I see I have been logged in with a new session ID. So it seems that the cluster nodes simply act as load-balancers  and are not smart enough to take up a failed nodes sessions where it left off.
    Is my understanding correct or have I to configure something to allow for this to happen?
    Thanks,
    Kent

    Thanks for your reply John!
    I was hoping APS could do something like that .. I am not sure if restoring sessions of a dead APS cluster node on another APS would be helpful but I can think of one situation where a drill-through report is running for a long time on the Essbase server and APS goes down.. it would be good to have the other APS to take up the session and return the drill-through output to the user.

  • Load balancing &scalability when OSB service is deployed in a single server

    Hi
    We have a file write service which we are deploying to clustered domain with a single admin and managed server.
    This we are doing since there can be issue of file locking if it is deployed cluster with multiple managed server and when more than one instance has to write to a same file (writing to the same file is the requirement).
    What are our options of load balancing and scalability and fail over?
    As i understand scalability in this case is limited to increasing the capacity of the hardware. There is no load balancing.
    For fail over, we can go for a backup domain is PASSIVE mode.
    Can someone please suggest any other options?
    Thanks
    kedar

    Hi,
    One SSA is ok, but you should think about access rights. If the access is clear cut between all the web apps you should be ok with one SSA. Multiple result sources limiting on content source also works, but could easily be bypassed.
    Multiple SSA's will eat up RAM/CPU like a mother :)
    As for popular etc.. it could be due to how those sources are set up, but haven't investigated or tested this much.
    Thanks,
    Mikael
    Search Enthusiast - SharePoint MVP/MCT/MCPD - If you find an answer useful, please up-vote it.
    http://techmikael.blogspot.com/
    Author of Working with FAST Search Server 2010 for SharePoint

  • Load Balance Forms and Reports Services

    Is it possible to Load Balance an application (written in Developer 9i) between
    two computers running Oracle Application Server 10g (9.0.4) Forms and Reports Services ?
    If it is possible, can anybody give an example or some kind of documentation, because
    the product documentation is not clear.
    Thanks in advance...

    Yes it is possible, but it all depends on what is your definition of load balancing?? Do you mean hardware machine balancing or service availability??? this is a large territory and you have to be specific, you even have the RAC.
    Oracle has [Oracle Application Server High Availability |http://download.oracle.com/docs/cd/B14099_19/core.1012/b14003/toc.htm] and metalink Note:740202.1 explains in detail how to configure it.
    Tony

  • Css stickiness based on the http header

    there is CSS 11503 that should load balances the traffic between 2 servers running IIS (http port 80). In front of load balancer there is a reverse proxy, that hides all real ip addresses of users that send requests to web-servers.
    The customer would like to have stickiness per user. The reverse proxy can add user real ip address to http header.
    What kind of load balancing mechanism is better to use  to fulfill customer requirements? HTTP load balancing? If "yes", are there standard field-types that is possible to use?

    You can't do sticky on http header in CSS , best solution is to insert a cookie for stickyness, individula clients will get a cookie and will stick based on cookie ppresented.
    see:
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/css11500series/v8.20/configuration/content_lb/guide/Sticky.html#wp1109390
    content testing
    vip address 192.168.128.131
    add service s1
    advanced-balance arrowpoint-cookie
    active

  • How to generate a value to field in a row based on another two fields in the same row ???

    I have a quantity and unit price and there is also a field in the same row called total price. I want to get the value automatically of total price from multiplying quantity and unit price.

    Here you go:
    page code
                            <af:panelGroupLayout id="pgl2" layout="horizontal" styleClass="AFStretchWidth">
                                <af:inputText label="Quantity" id="quantity" value="#{bindings.quantity1.inputValue}" autoSubmit="true"
                                              valueChangeListener="#{SetItemBean.valueChangeListenerItem}"/>
                                <af:spacer width="10" height="10" id="s1"/>
                                <af:inputText label="Price" id="price" value="#{bindings.price1.inputValue}" autoSubmit="true"
                                              valueChangeListener="#{SetItemBean.valueChangeListenerItem}"/>
                                <af:spacer width="10" height="10" id="s2"/>
                                <af:inputText label="Sum" id="total" value="#{bindings.total1.inputValue}" partialTriggers="quantity price" readOnly="true"/>
                            </af:panelGroupLayout>
    page bindings
    <?xml version="1.0" encoding="UTF-8" ?>
    <pageDefinition xmlns="http://xmlns.oracle.com/adfm/uimodel" version="12.1.2.66.68" id="SetItemPageDef" Package="de.hahn.blogtest12c.view.pageDefs">
      <parameters/>
      <executables>
        <variableIterator id="variables">
          <variable Name="quantity" Type="java.lang.Number"/>
          <variable Name="price" Type="java.lang.Number"/>
          <variable Name="total" Type="java.lang.Number"/>
        </variableIterator>
      </executables>
      <bindings>
        <attributeValues IterBinding="variables" id="quantity1">
          <AttrNames>
            <Item Value="quantity"/>
          </AttrNames>
        </attributeValues>
        <attributeValues IterBinding="variables" id="price1">
          <AttrNames>
            <Item Value="price"/>
          </AttrNames>
        </attributeValues>
        <attributeValues IterBinding="variables" id="total1">
          <AttrNames>
            <Item Value="total"/>
          </AttrNames>
        </attributeValues>
      </bindings>
    </pageDefinition>
    and bean code
        public void valueChangeListenerItem(ValueChangeEvent valueChangeEvent) {
            String comp = valueChangeEvent.getComponent().getId();
            BindingContainer bindings = BindingContext.getCurrent().getCurrentBindingsEntry();
            // get an ADF attributevalue from the ADF page definitions
            AttributeBinding attr = (AttributeBinding) bindings.getControlBinding("quantity1");
            Number q = (Number) attr.getInputValue();
            if (q == null)
                q = 0;
            attr = (AttributeBinding) bindings.getControlBinding("price1");
            Number p = (Number) attr.getInputValue();
            if (p == null)
                p = 0;
            if ("price".equals(comp)) {
                p = (Number) valueChangeEvent.getNewValue();
            } else {
                q = (Number) valueChangeEvent.getNewValue();
            // set new value
            attr = (AttributeBinding) bindings.getControlBinding("total1");
            Number t = q.doubleValue() * p.doubleValue();
            attr.setInputValue(t);
            // update Total
            FacesContext facesCtx = FacesContext.getCurrentInstance();
            UIComponent ui = facesCtx.getViewRoot().findComponent("total");
            if (ui != null) {
                // PPR refresh a jsf component
                AdfFacesContext.getCurrentInstance().addPartialTarget(ui);
    Timo

  • Feature Request : provide a way to create access policies or identities with matching condition based on the HTTP header's "Referer" field

    Hello,
    I have a use-case I would like to share with you. When a customer configures its WSA with highly restrictive internet access like in the example below, it may trigger some issues :
    1- allow internet access only for URLs defined in whitelist.
    2- block ALL other requests.
    Let's take the following example :
    1- the customer only allow requests to www.siteA.com. siteA.com is the only URL included in its whitelist.
    2- www.siteA.com contains many embedded objects (such as facebook like tags, youtube videos, links to partners sites, ...)
    In this configuration, the end user will be allowed to reach siteA but the page will not be fully displayed. All the embedded objects not directly located on siteA will be missing.
    With WSA, the easiest way I can imagine to solve the issue is to list all the embedded objects present on siteA, get back their URL and also add these URLs to the whitelist. But this solution if of course far to be really convenient since it involves to know exactly how each HTTP page you want to consult is built.
    With other proxies, such as Bluecoat proxies or McAfee Web Gateway proxies for example, I used to solve this kind of issue by using the HTTP referer field (the URL you come from). For example with Bluecoat :
    <Proxy>
        ALLOW request.header.Referer.url.domain=//www.siteA.com/
    => All requested objects from siteA.com will be automatically allowed by the proxy, even if they are not part of my whitelist.
    - Do you have a better suggestion than the one I'm currently using with WSA (adding each sites in whitelist) ?
    - Would it be possible to add the field HTTP referer as a matching condition for Identities and access policies in your next release ?
    Thanks in advance
    Best regards

    As far as I'm aware this functionality is still not available... would be an awesome feature to have, but could also be abused at the same time by a user writing their own "middleware" proxy and setting the referrer header to that allowed site..  could be done in like ~15 lines of perl / python.
    Either way... would still be a cool feature to have.

  • Load balance based on OS

    Is it possible to load balance incoming requests based on client's operating system on ACE?
    For example, we have different web pages specifically for Blackberry or iPhones.
    Instead of having multiple URL's & VIP's, we'd like to have a single VIP, but load balance traffic to different serverfarms based on client's OS.

    You can loadbalance based on User-Agent header, first you need to quantify what Iphone and blackberry use for user-agent for instance from a regular browser you might see:
    User-AgentT=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727)
    from an iphone you will typically see:
    User-Agent=Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en)
    AppleWebKit/420+ (KHTML, like Gecko) Version/3.0 Mobile/1C25 Safari/419.3
    you can go to http://www.user-agents.org to find out what strings are used
    That being the case you can make classes on the header to match for loadbalancing decisions:
    class-map type http loadbalance match-any mobile
    2 match http header User-Agent header-value .*iphone
    4 match http header Uswer-Agent header-value .*blackberry
    then in LB policy say we want to go to farmA for mobile and farmB for pc's
    policy-map type loadbalance first-match L7POLICY
       class mobile
         serverfarm farmA
        class class-default
        serverfarm farmB
    see:
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/v3.00_A2/configuration/slb/guide/classlb.html#wp1021388

  • 11i load balancing web nodes without use of Hardware http load balancer

    I am looking at note 217368.1 (Advanced Configurations and Topologies for Enterprise Deployments of E-Business Suite 11i) and some other notes on load balancing but some aspects are not clear.
    Aim is to implement load balancing traffic to web nodes without using Hardware ( BigIP, cisco etc) for HTTP layer load balancing.
    Which is more preferable between dns or Apache Jserv load balancer ?
    Need details like failover capabilities, death detection of node, functionality testing and ways to monitor Apache Jserv load balancer.
    Any help in this regard is welcome .
    thx
    arun

    Oracle recommends using loadbalancing hardware rather than using DNS. If you want the features you mention above, you will need a hardware loadbalancer.
    http://blogs.oracle.com/stevenChan/2006/06/indepth_loadbalancing_ebusines.html
    http://blogs.oracle.com/stevenChan/2009/01/using_cisco_ace_series_hardware_load-balancers_ebs12.html
    HTH
    Srini

  • Load Balancing Internet Sources with WSA

    Hello everyone,
    Is is possible to have multiple internet sources with the WSA like Microsoft Forefront TMG you can have multiple internet sources and adjust for example 33% load on the first link and 66% percent on the second link .
    We currently have the S160 .
    Thanks .

    If you mean "use the WSA to load balance traffic between 2 or more internet providers", no... the WSA won't do that.

  • OSPF load balancing across multiple port channels

    I have googled/searched for this everywhere but haven't been able to find a solution. Forgive me if I leave something out but I will try to convey all relevant information. Hopefully someone can provide some insight and many thanks in advance.
    I have three switches (A, B, and C) that are all running OSPF and LACP port channelling among themselves on a production network. Each port channel interface contains two physical interfaces and trunks a single vlan (so a vlan connecting each switch over a port channel). OSPF is running on each vlan interface.
    Switch A - ME3600
    Switch B - 3550
    Switch C - 3560G
    This is just a small part of a much larger topology. This part forms a triangle, if you will, where A is the source and C is the destination. A and C connect directly via a port channel and are OSPF neighbors. A and B connect directly via a port channel and are OSPF neighbors. B and C connect directly via a port channel and are OSPF neighbors. Currently, all traffic from A to C traverses B. I would like to load balance traffic sourced from A with a destination of C on the direct link and on the links through B. If all traffic is passed through B, traffic is evenly split on the two interfaces on the port channel. If all traffic is pushed onto the direct A-C link, traffic is evenly balanced on the two interfaces on that port channel. If OSPF load balancing is configured on the two vlans from A (so A-C and A-B), the traffic is divided to each port channel but only one port on each port channel is utilized while the other one passes nothing. So half of each port channel remains unused. The port channel on B-C continues to load balance, evenly splitting the traffic received from half of the port channel from A.
    A and C port channel load balancing is configured for src-dst-ip. B is a 3550 and does not have this option, so it is set to src-mac.
    Relevant configuration:
    Switch A:
    interface Port-channel1
    description Link to B
     port-type nni
     switchport trunk allowed vlan 11
     switchport mode trunk
    interface Vlan11
     ip address x.x.x.134 255.255.255.254
    interface Port-channel3
    description Link to C
     port-type nni
     switchport trunk allowed vlan 10
     switchport mode trunk
    interface Vlan10
     ip address x.x.x.152 255.255.255.254
    Switch B:
    interface Port-channel1
     description Link to A
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 11
     switchport mode trunk
    interface Vlan11
     ip address x.x.x.135 255.255.255.254
    interface Port-channel2
     description Link to C
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 12
     switchport mode trunk
    interface Vlan12
     ip address x.x.x.186 255.255.255.254
    Switch C:
    interface Port-channel1
     description Link to B
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 12
     switchport mode trunk
    interface Vlan12
     ip address x.x.x.187 255.255.255.254
    interface Port-channel3
     description Link to A
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 10
     switchport mode trunk
    interface Vlan10
     ip address x.x.x.153 255.255.255.254

    This is more FYI. 10.82.4.0/24 is a subnet on switch C. The path to it is split across vlans 10 and 11 but once it hits the port channel interfaces only one side of each is chosen. I'd like to avoid creating more vlan interfaces but right now that appears to be the only way to load balance equally across the four interfaces out of switch A.
    ME3600#sh ip route 10.82.4.0
    Routing entry for 10.82.4.0/24
      Known via "ospf 1", distance 110, metric 154, type extern 1
      Last update from x.x.x.153 on Vlan10, 01:20:46 ago
      Routing Descriptor Blocks:
        x.x.x.153, from 10.82.15.1, 01:20:46 ago, via Vlan10
          Route metric is 154, traffic share count is 1
      * x.x.x.135, from 10.82.15.1, 01:20:46 ago, via Vlan11
          Route metric is 154, traffic share count is 1
    ME3600#sh ip cef 10.82.4.0
    10.82.4.0/24
      nexthop x.x.x.135 Vlan11
      nexthop x.x.x.153 Vlan10
    ME3600#sh ip cef 10.82.4.0 internal       
    10.82.4.0/24, epoch 0, RIB[I], refcount 5, per-destination sharing
    sources: RIB 
    ifnums:
    Vlan10(1157): x.x.x.153
    Vlan11(1192): x.x.x.135
    path 093DBC20, path list 0937412C, share 1/1, type attached nexthop, for IPv4
    nexthop x.x.x.135 Vlan11, adjacency IP adj out of Vlan11, addr x.x.x.135 08EE7560
    path 093DC204, path list 0937412C, share 1/1, type attached nexthop, for IPv4
    nexthop x.x.x.153 Vlan10, adjacency IP adj out of Vlan10, addr x.x.x.153 093A4E60
    output chain:
    loadinfo 088225C0, per-session, 2 choices, flags 0003, 88 locks
    flags: Per-session, for-rx-IPv4
    16 hash buckets             
    < 0 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 1 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 2 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 3 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 4 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 5 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 6 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 7 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 8 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 9 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <10 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <11 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <12 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <13 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <14 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <15 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    Subblocks:                                                                                  
    None

  • How to see the Source IP Address of a client using ACE One-armed-mode to load balance HTTP proxy request

    I'm using an Ace 4710 Appliance deployed in One-Armed mode, using Source NAT to loadbalance HTTP request to a couple of Proxy servers.
    Everything is working fine, but the thing is that I can't see the Clients IP addresses on Proxy's logs, so I can't keep track of them.
    The Interfaces and Nat configs are:
    interface vlan 200
      description Server-Side-VLAN
      bridge-group 5
      nat-pool 5 10.1.1.5 10.1.1.5 netmask 255.255.255.0 pat
      service-policy input VIPS
    interface vlan 300
      description Client-Side-VLAN
      bridge-group 5
    interface bvi 5
      ip address 10.1.1.3 255.255.248.0
      description Client-Server-Virtual-Interface
    ip route 0.0.0.0 0.0.0.0 10.1.1.1
    and the policy map looks like this
    policy-map multi-match VIPS
      class Port80
        loadbalance vip inservice
        loadbalance policy Port80
        nat dynamic 5 vlan 200
    Resource assignment:
    sticky ip-netmask 255.255.255.255 address both RESOURCE-CLASS
      timeout 5
      serverfarm Service80
    Any suggestions will be appreciated,
    Thanks

    Hi Kanwal,
    Thanks for your quick reply,
    I've already tried this but it didn't work. The problem is that I don't manage the proxy servers so I rely on their skills to see the logs.
    The Proxies are Squid. Do you know if they need to do something else on the servers to see that field of the HTTP header?
    But I'll try again tomorrow and let you know how it goes.
    Thank you again.

Maybe you are looking for

  • Windows XP client needs to authenticate and not being logged on as guest

    Hello! I've got a problem with Leopards File Sharing: My father has a Windows XP notebook with installed Bonjour and when he connects to my MacBook Pro with OS X 10.5.3 he will be logged in as guest but my collegue has to type in a user name and a pa

  • Powerbook not recognized on Windows 7 PC

    Hi everyone, I am having trouble finding a driver for my PC to recognize my Powerbook G4 running Tiger OS X. The PC is running a Windows 7, 64bit system. When I connect the devices using a firewire cable the PC recognizes the new HW, but it cannot fi

  • How to activate new pricing procedure for old Pur Document

    Dear all, we have added some condition type  in our pricing procedure,every thing is ok but my question is this new condition added in pricing procedure are not reflecting in previously created purchasing document/po, how can we do it I kw that if we

  • In Mail, no icon to save email as a Draft

    Since switching to a new computer with Lion, I'm bewildered by some things. In Mail, working on an email and then saving it as a Draft to work on later was simple. I can't figure out how to do it in the new Mail program. Here's what the Help menu say

  • 2 questions about customizing screen

    Hi. * Is it possible to rearrange the order of the bind variables on a customization screen? The variables appear in the same order as they are stated in the query. * I have a dynamic page. The page has some bind variables. When the user enters the c