LSMW : Urgent SO - DI - Material Configuration Prob

Hello all,
[Direct Input Approach]
In my quest for uploading Legacy system SO through LSMW . I have reached at the stage where I am able to create Sales Order successfully but only 1 problem is..
Our client has customization done where by selecting a perticular value, the SO Item level table control shows few extra detail columns [extra charstics of material]. This is customized by Material Classification view.
My LSMW script is creating Order Correctly but for each item it displays the Configuration Screen and I asks for manual intervation[say pressing F3].
In my LSMW script if I programmatically supress this screen. Then those value doesn't apear in SO when we access it through VA02.
has any one come accross this kind of prblem ? Please help me as this seems to be only hurdle in my SO upload.

Hi!
I think, you need two different alternatives:
- You suppress the screen in LSMW -> no configuration data is filled -> later no configuration is available (columns missing). Do this for materials without configuration data.
- You handle the additional screen and fill (at least one) configuration data. Later view and changing (maybe adding the rest of values) should be possible.
Sales orders with configuration would be better created by BAPI - but this would be hard work to change right now (and this BAPI is not easy to handle in case of configuration).
Regards,
Christian

Similar Messages

  • BAPI for ME21N with Material Configuration

    Hi friends,
    I need to create a Z Program which will create the purchase order and during creation of purchase order it will also make the configuration of material in Material Data. I know the BAPI name BAPI_PO_CREATE1, but it will not do the configuration in Material Data.
    I have tryed the BDC but it is working for only one line item only.
    Please suggest any suitable way for the solution.
    Thanks in advance.
    Krishan

    Can you explain what exactly you mean by Material Configuration?
    BAPI_PO_CREATE1 is the right bapi for ME21N.
    YOu cannot do a BDC on this tansaction as it is a SAP Enjoy transaction.
    Regards,
    ravi

  • Material configuration with BAPI_SALESORDER_CREATEFROMDAT2

    Hi there,
    I am trying to create a new sales order with material configuration using BAPI_SALESORDER_CREATEFROMDAT2. It's not working though. I have seen some comments that it is not possible to create configuration directly with this BAPI - is this really true? - and that the config should be created after sales order creation using function CE_C_PROCESSING.
    I have played around a bit, but without succes. Could somebody help me out?
    Kins regards,
    Roy

    Hi, you can use this BAPI to create a sales order with configurable material.
    Fisrt you can try with some hardcode config items.
    You need the corresponding 'Characteristic values' in your system
    eg:
    *Header data
      wa_header-doc_type   = 'ZREK'.
      wa_header-sales_org  = '1020'.
      wa_header-distr_chan = 'AS'.
      wa_header-division   = 'AS'. "not mandantory
      wa_header-purch_no_c = 'mypohehe'.
    *Partner data
      it_partners-partn_role = 'AG'.
      it_partners-partn_numb = '0000000104'.
      APPEND it_partners.
      it_partners-partn_role = 'WE'.
      it_partners-partn_numb = '0000000105'.
      APPEND it_partners.
    *1st
    *items
      it_items-material   = 'BC263R'.
      it_items-po_itm_no  = '000010'.
      it_items-target_qty = '1.000'.
      it_items-target_qu  = 'ST'.
      APPEND it_items.
      it_schedules_in-itm_number = '000010'.
      it_schedules_in-req_qty = '1.000'.
      APPEND it_schedules_in.
    *it_items_inx
    not needed for creation
    *reference
      it_cfgs_ref-posex     = '000010'.
      it_cfgs_ref-config_id = '000001'.
      it_cfgs_ref-root_id   = '00000001'.
      APPEND it_cfgs_ref.
    *it_cfgs_inst
      it_cfgs_inst-config_id  = '000001'.
      it_cfgs_inst-inst_id    = '00000001'.
      it_cfgs_inst-obj_type   = 'MARA'.
      it_cfgs_inst-class_type = '300'.
      it_cfgs_inst-obj_key    = 'Z-BC263R'.
      APPEND it_cfgs_inst.
    configuration values
      it_cfgs_value-config_id  = '000001'.
      it_cfgs_value-inst_id    = '00000001'.
      it_cfgs_value-charc      = 'ATS_GRUNDLAGE'.
      it_cfgs_value-value      = p_conf.                        "01 - 07
      APPEND it_cfgs_value.
      it_cfgs_value-config_id  = '000001'.
      it_cfgs_value-inst_id    = '00000001'.
      it_cfgs_value-charc      = 'ATS_BESCHRIFTUNG'.
      it_cfgs_value-value      = 'N'.
      CALL FUNCTION 'BAPI_SALESORDER_CREATEFROMDAT2'
        EXPORTING
        SALESDOCUMENTIN               =
          order_header_in               = wa_header
        ORDER_HEADER_INX              =
        SENDER                        =
        BINARY_RELATIONSHIPTYPE       =
        int_number_assignment         =
        BEHAVE_WHEN_ERROR             =
        LOGIC_SWITCH                  =
        TESTRUN                       =
        CONVERT                       = ' '
       IMPORTING
          salesdocument                 = v_salesdocument
        TABLES
          return                        = it_return
          order_items_in                = it_items
          order_items_inx               = it_items_inx
          order_partners                = it_partners
          order_schedules_in            = it_schedules_in
        ORDER_SCHEDULES_INX           =
        ORDER_CONDITIONS_IN           =
          order_cfgs_ref                = it_cfgs_ref
          order_cfgs_inst               = it_cfgs_inst
        ORDER_CFGS_PART_OF            = it_cfgs_part_of
          order_cfgs_value              = it_cfgs_value
        ORDER_CFGS_BLOB               =
        ORDER_CFGS_VK                 =
        ORDER_CFGS_REFINST            =
        ORDER_CCARD                   =
        ORDER_TEXT                    =
        ORDER_KEYS                    =
        EXTENSIONIN                   =
        PARTNERADDRESSES              =
    *it_return
      READ TABLE it_return WITH KEY type = 'E'.
    Rgds,
    JP

  • ACE: Problem configuring probe snmp

    Hi,
    I have a problem when I configure probe snmp and My Server W2K3 dual core, snmp comunity public has an oid cpu .1.3.6.1.2.1.25.3.3.1.2, the output is:
    access-list anyone line 8 extended permit ip any any
    probe snmp was
    interval 4
    faildetect 2
    passdetect interval 10
    receive 2
    community public
    oid .1.3.6.1.2.1.25.3.3.1.2
    threshold 70
    rserver host was1
    ip address 10.24.8.200
    probe was
    inservice
    rserver host was2
    ip address 10.24.8.201
    probe was
    inservice
    serverfarm host servers
    rserver was1
    inservice
    rserver was2
    inservice
    class-map type management match-any ADM-CONTEX-SERV1
    4 match protocol icmp any
    5 match protocol snmp any
    class-map type http loadbalance match-all Check-Headers
    2 match http url .*
    3 match http header Host header-value "10.24.16.*"
    4 match http header User-Agent header-value ".*MSIE.*"
    class-map match-all VIP-10-HTTP
    2 match virtual-address 10.24.16.10 tcp eq www
    class-map type http loadbalance match-all other-HTTP
    2 match http url .*
    policy-map type management first-match ADM-CTX-SERV1
    class ADM-CONTEX-SERV1
    permit
    policy-map type loadbalance first-match L7-logic
    class Check-Headers
    serverfarm servers
    class other-HTTP
    serverfarm servers
    policy-map type loadbalance first-match lb-logic
    class class-default
    serverfarm servers
    policy-map multi-match client-vips
    class VIP-10-HTTP
    loadbalance vip inservice
    loadbalance policy L7-logic
    loadbalance vip icmp-reply active
    interface vlan 60
    ip address 10.24.8.5 255.255.255.0
    access-group input anyone
    access-group output anyone
    service-policy input ADM-CTX-SERV1
    no shutdown
    interface vlan 233
    ip address 10.24.16.5 255.255.255.0
    access-group input anyone
    access-group output anyone
    service-policy input ADM-CTX-SERV1
    service-policy input client-vips
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.24.16.1
    sh probe was detail
    probe : was
    type : SNMP
    state : ACTIVE
    description :
    port : 161 address : 0.0.0.0 addr type : TRANSPARENT
    interval : 4 pass intvl : 10 pass count : 3
    fail count: 2 recv timeout: 2
    version : 1 community : public
    oid string #1 : .1.3.6.1.2.1.25.3.3.1.2
    type : PERCENTILE max value : 100
    weight : 16000 threshold : 70
    --------------------- probe results --------------------
    probe association probed-address probes failed passed health
    ------------------- ---------------+----------+----------+----------+-------
    rserver : was1
    10.24.8.201 13 13 0 FAILED
    Socket state : CLOSED
    No. Passed states : 0 No. Failed states : 1
    No. Probes skipped : 0 Last status code : 0
    No. Out of Sockets : 0 No. Internal error: 0
    Last disconnect err : Server reply - bad SNMP OID
    Last probe time : Tue Feb 24 23:22:41 2009
    Last fail time : Tue Feb 24 23:20:47 2009
    Last active time : Never
    Server load : 16000
    rserver : was2
    10.24.8.200 12 12 0 FAILED
    Socket state : CLOSED
    No. Passed states : 0 No. Failed states : 1
    No. Probes skipped : 0 Last status code : 0
    No. Out of Sockets : 0 No. Internal error: 0
    Last disconnect err : Server reply timeout (no reply)
    Last probe time : Tue Feb 24 23:22:34 2009
    Last fail time : Tue Feb 24 23:20:52 2009
    Last active time : Never
    Server load : 16000

    Hi,
    For a multicore processor you need to make a few changes to get the load on each core/processor. You need to have an instance for each core.
    Try adding .1 or .2 to the OID to get the load on each core.
    Also try doing an snmpwalk on the OID to see what the real structure is.
    HTH
    Cathy

  • PRODUCTION order material configuration info

    HI,
    any one please let me know how can i get production order material configuration information.from which table we can get this info or is there any function module
    to get this info.
    Thanks & reagrds..
    Anil.T

    check this include Program , u will find out list of FMS
    <b>LCOOCCUXX</b>
    regards
    prabhu

  • VA01 - sale order Material Configuration values to be read

    Hi,
    I am trying to read the entered sale order material configuration values in TCode VA01 and update the xvbap in userexit USEREXIT_CHECK_VBAP in program MV45AFZB.
    Kindly let me know to get the material configuration values in this userexit.
    Regards,
    Rajanbabu R

    Dear Rajesh,
    The strategy type 25 has been copied and the following fields are modified as follows for the new strategy type Y5.
    Requirement type of customer requirement YT5 instead of standard entry KEK
    Requirement class YT5 instead of standard entry 046
    Account assignment category -  E instead of standard M
    Settlement profile - SO1
    Configuration field - defined as 'allowed' instead of standard setting ' Mandatory '
    The field PQTY in the procurement  tab page for that particular line item is greyed out and we are unable to key in the value YT5.Unless I entered this value I am not able to procure the component of that line item in that sale order.
    Please suggest me any means to enter this value . Shall I configure the BOM for that line item and fix it again in CU51.
    Thanks and Regards,
    Ram

  • I need to create a Contract material configuration in Va42 through a report or BDC any suggestions?

    Hi All I need to Create a Frame contract with incomplete material configuration through report , In the manual we have lock symbol which when unlocked enables to to save a contract with incomplete configuration.
    But through BDC , I am unable to save as there is no screen available like we do in manual way for BDC session.
    So I need a help to create a Frame contract with incomplete configuration.

    Hi Experts,
    I need  help to solve the need, may be if  have any sample code to create a Contract material configuration or classification will be much benifited.

  • User Exit / Badi for posting Material configuration in VA01

    Hi All
    I am looking for a user exit /Badi to automatically update the material configuration & its values while Sales Order Entry (VA01).
    Can any one tell me, is there any enhancement exist to do this.
    Thanks
    Ravi

    Hi,
    in MV45afzz, userexit_savedocument_prepare,
    CUCB_GET_SINGLE_instance use this function to get values for configuration, we need to pass XVBAP-CUOBJ to instance importing parameter.
    we can see there values line type in the tables parameter.
    we can update configuration data, just check function  group 'CUCB', you will get function module to update configuration for va01.
    Thanks
    Ramesh

  • Display material configuration options

    Hi all,
    I want to find a function module to get all material configuration options for a material.
    I found 'BAPI_CFGINST_CHARCS_READ' but unfortunately it does not take into account allready existing characteristics.
    For instance :
    - I have a charac "A" and a charac "B".
    - "B" only appears if "A" has the value X.
    What I'm looking for is a FM that gives me "A" if the actual config is initial, and that gives me "A" and "B" if "A" is valuated with X.
    Do you know if it exists ?
    Regards,
    Sylvain

    Hi Ram,
    'CACL_CLASS_READ_VALIDATION' is used "to display the restricted value set that was defined when your class was allocated to a superior class."
    I don't think it could help me such i do not not have a call allocated to a superior one, and I'm not searching for restricted value set but for restricted characteristics according to actual value.
    Regards,
    Sylvain

  • LSMW Direct input for Material Master

    Hi,
    I need to upload the following views data into SAP using direct input (RMDATIND)
    Basic Data 1
    Basic Data 2
    Classification
    Sales: Sales Org. Data 1
    Sales: Sales Org. Data 2
    Sales: General/Plant Data
    Foreign Trade: Export Data
    Sales Text
    Purchasing
    Foreign Trade: Import Data
    Purchase Order Text
    Work Scheduling
    General Plant Data / Storage 1
    General Plant Data / Storage 2
    Accounting 1
    Accounting 2
    Costing 1
    Costing 2
    Is it possible to upload these views through direct input or is there any limitation with the direct input method because i'm able to map the below fields only once
    Country of Origin
    Region of Origin
    Excemption Certificate
    Ex. Certificate number
    Issue date of Cert. No.
    Indicator: Military goods
    the above fields are repeated twice for the views
    Foreign Trade: Export Data
    Foreign Trade: Import Data
    If anybody has done material master in lsmw please let me know.
    Thanks in advance.
    Poorna

    Hi,
    I need to upload the following views data into SAP using direct input (RMDATIND)
    Basic Data 1
    Basic Data 2
    Classification
    Sales: Sales Org. Data 1
    Sales: Sales Org. Data 2
    Sales: General/Plant Data
    Foreign Trade: Export Data
    Sales Text
    Purchasing
    Foreign Trade: Import Data
    Purchase Order Text
    Work Scheduling
    General Plant Data / Storage 1
    General Plant Data / Storage 2
    Accounting 1
    Accounting 2
    Costing 1
    Costing 2
    Is it possible to upload these views through direct input or is there any limitation with the direct input method because i'm able to map the below fields only once
    Country of Origin
    Region of Origin
    Excemption Certificate
    Ex. Certificate number
    Issue date of Cert. No.
    Indicator: Military goods
    the above fields are repeated twice for the views
    Foreign Trade: Export Data
    Foreign Trade: Import Data
    If anybody has done material master in lsmw please let me know.
    Thanks in advance.
    Poorna

  • Urgent help with Material classification

    Thsi is regarding data into BW for Material classification.
    I am tryign to create the extractors as suggested in BW expert & in the forums posted by others.
    I did create 1CL_0MAT001 .but i did nto understand where to add the charerceristics & further steps. I have aroudn 15 charecteristics.-also i did not completely understand the Process of creating via CTBW t.code.
    It woudl be really great if someone could explain.
    Can anyone pls help me with this.
    This is realy urgent.

    Hi Chris,
    Choose the transaction SBIW (Customizing for the BW source system) and the menu path Business Information Warehouse &#61614; Customer-defined DataSources &#61614; Cross-application Components &#61614; Classification System &#61614; Maintain DataSources for Classification data.
    To maintain a DataSource, proceed as follows:
    Specify a Basis DataSource that has an InfoSource you want to enhance (for example, 0MATERIAL_ATTR). Choose a client, a class type, and an object table from which you want to transfer the classification data (for example, 100, 001, MARA).
    Click on Save.
    Then select the line in CTBW and select Characteristic.
    Specify the characteristics that you want to assign to the DataSource. Click on the generate datasources. The DataSource is generated, and given a status (N = new, for a newly created DataSource, and R = ready, following successful generation) and a technical prefix “1¬CL_...” is added to the name
    A Metadata upload replicates the DataSource along with its relevant properties in BW, where it can be assigned to an InfoSource.
    A Metadata upload on the InfoObject/source system level has to be carried out so that the DataSources created in the OLTP are also available in BW. You access this function by clicking the right mouse button on Source system for InfoObject &#61614; Replicate DataSources,
    Hope that helps. If you need any other info kindly let us know.
    Regards.

  • Lsmw : Direct Input : 0020 Material Master :Error

    hi all !
    I'm onto making a lsmw for material master direct input.i'm facing the following error : 
    1.The field Marc-LADGR is defined as a required field : it doesnt contain an entry
    2.You have not fully maintained the tax classifications.
    in my flat file i have duly filled in the field MARC-LADGR
    need help ,plz see if you can track wats the problem.
    thanks and regards,
    sachin

    ya sachin ... as u r telling .. download from the std program... & continue the process....
    my suggestion ... cross check again with ur fields of the source structure ....i mean decalre only fields .. which are required .. then do the field mapping again for the all the fields...
    i believe there will be documentation for the std program .... check it & go thru with that ..map it ... wherever needed ....
    try & let me know...
    thanks,
    manjunath ms

  • BOM and Material Configuration and Sales order..

    hi,
    in my requirement, i am supposed to create a project automatically based on sales order..
    additional requirement is that material components on the project are based on the the selections during the sales order creation
    (for example if customer chooses tiles instead of vinyl flooring then materials for tiles will be selected automaticall)
    i maintained reference points in my BOM and in the standard network activities.
    i also maintained the class and characteristics of the material..
    the missing part i believe lies in the dependency being set for the BOM. example:
             =if  floortype='vinyl' then get BOM_floortype..
    how to configure/set up that scenario? i cant seem to find the link between characteristic selection and output of selected BOM.
    Thanks in advance.

    Dear ramesh,
    If it  possible...can u explain...regarding
    (i also maintained the class and characteristics of the material..
    the missing part i believe lies in the dependency being set for the BOM. example:
    =if floortype='vinyl' then get BOM_floortype..
    how to configure/set up that scenario? i cant seem to find the link between characteristic selection and output of selected BOM.)
    Regards
    chandra

  • LSMW urgent

    hi.
    We have created a lsmw for material  master upload using direct  input method. We are uploading data for semi and finish material . however I am getting error as 'ERROR WHILE CHANGING ACCOUNTING VIEW".
    However if we upload data without this view , it creates material.Again if we upload data with accounting view , it extends accounting view.
    We have go-live tomorrow.Can any one suggest?
    Its on high priority.
    Fields we are using in accounting view are
    Valuation class -7921,
    Price control indicator - 'S'
    standard price - 3.30

    Hi,
    Accounting View is applicable for specific material types only, confirm the material type.
    If accounting view is required for the material type then please confirm, you have enable the Accounting View for change?
    In Structure mapping, you need to enable the respective structures in edit mode.
    Assing 'X' to the 'Accounting' view.

  • Material Configuration from Agreement

    Hello Specialists,
    My Customer is using Materials with Configuration in Material Master as basic.
    He uses also Contracts (Agreements) for this material with Configuration but with different characteristic-Data.
    In Sales Order a Purchase Requisition is created and this agreement is used as source of supply.
    Now the Configuration characteristic-Data from the Material Master is automaticly placed into the PR Configuration, but we need the characteristic-Data from the Contract.
    How is it possible to get the different Configuration characteristic-Data from the Contract  into the PR Configuration?
    Regards
    Wolfgang

    Hello Specialists,
    My Customer is using Materials with Configuration in Material Master as basic.
    He uses also Contracts (Agreements) for this material with Configuration but with different characteristic-Data.
    In Sales Order a Purchase Requisition is created and this agreement is used as source of supply.
    Now the Configuration characteristic-Data from the Material Master is automaticly placed into the PR Configuration, but we need the characteristic-Data from the Contract.
    How is it possible to get the different Configuration characteristic-Data from the Contract  into the PR Configuration?
    Regards
    Wolfgang

Maybe you are looking for

  • Possible Bug in iOS 8 via Streaming iTunes Video results in lost storage space?

    Hi looking for suggestions or help on this issue if you can. I'm not sure if the issue is my attempting to stream a movie from iTunes under iOS 8 or if it is a result of the iOS 8 update (size) itself or some type of memory leak or inability of memor

  • ISE 1.1.2.145 patch-3 and CLI password disable

    I am running ISE 1.1.2.145 patch-3 on VMWare ESXi 4.1  The ISE is running fine without any issues. During the initial setup of the ISE, I create an account called "admin" so that I can ssh into the ISE.  According to Cisco, the CLI password does NOT

  • Macbook Pro 13'' Late 2011 2 SSD RAID 0

    Hello everyone, This is my first message in the forum so I would like to introduce myself. My name is Guillem and I am studiny engineering in audiovisual systems. I want to get 2 SSD to change the original hard drive (which is ********) and the optic

  • Report designing problem

    Dear All, I have developed a report in which input is calyr/month (interval) and comparison calye/month. I have to display purchase value , qy etc ... I have done that. But now the requirement is i have to calculate average price(month)  which is  to

  • Problems wit the portal in ias release 2

    Hi. My NEW ias release2 installation seems to be working fine but I can't make my portal work. I can log into Login Server, but when I click on my portal link I get a WWC-00000 error. My httpd.conf file has my machine name in lower case, so there sho