Mapping error in PI 7.4 dual stack

Dear Experts,
    Recently we upgraded our system from PI 7.1 to PI 7.4 dual stack.
Scenerio is ECC->PI->SOAP(Webservice) synchronous
Issue in detail:
     We are creating a invoice in ECC system through PI its updating in third party site using SOAP webservice and will get a reference number from that site and then updating in ECC as in synchronous way.
Invoice data's are reached PI sucessfully from ECC but it not updating in the site and getting below mapping error after upgarded to PI 7.4.
Your points will be highly appreciable.
Kindly help to sort out this issue.
Best Regards,
Monikandan

Hi Monikandan,
It seems you are trying the sign the payload in your java mapping. So, looking at the attached error, there could be 2 possibilities:
1) Either there is no certificate with alias: *_PRD
2) This certificate is stored in some "System" type keystore view which is not accessible from you mapping code. Try to move your certificate to some "User" keystore view.
Thanks & regards,
Piyush

Similar Messages

  • Java Stack Vs Dual Stack in Pi 7.3

    Hi experts.
    I open this thread because I'd like to know your opinion about the newJava installation option in SAP PI 7.3. In previous realeses (7.0,7.1) I felt more comfortable and safe in abap stack and I'm a little afraid about working only with java stack.
    I'd like to know advantages and disadvantages to choose java stack instead of dual stack, why you'd choose one of two options or both in your nexts customers.
    Thank u so much and happy new year!!!!

    Java Stack  or Dual Stack in 7.3
    Java Stack alone: Almost all standard adapters including HTTP, IDOC and Proxy are all available in this stack. you need to use Integrated Configuration object for this. You are basically going to use Advance Adapter engine alone for the entire processing.
    Pros:
    No persistance steps here. So you would improve performance many folds for sure.
    Throughput is also improved very much.
    since 7.3, Solution Manager is available for monitoring inaddition to RWB and NWA. So monitoring would not be issue.
    If you are looking for real performance improvement, Single stack Java to  go.
    Cons:
    Abap mapping is not supported.
    Message split to multiple receivers are not completely supported.
    BPM interfaces are not seamless migration here.  SAP 7.1 and lower versions support BPEL wheras 7.3 supports BPMN standards. So you might have to tweak a bit to modify existing interfaces here
    Dual Stack:
    Your option is pretty open. If you need some specific interfaces to handle only java stack, still that is possible and increase the performance. Also if you have lot of existing interfaces that requires BPM interfaces, ABAP mapping , Multiple split /branching etc.
    still dual stack is the better option now. Here developer decides according to the requirement.
    Still safe mode is going for Dual Stack for now and change in the future to single java stack alone.

  • Parameterized mapping in PI 7.31 Dual Stack

    Hi All,
    I am working on PI 7.31 Dual Stack. I am getting the below exception in parameterized mapping:
    com.sap.aii.utilxi.misc.api.BaseRuntimeException; com.sap.aii.mapping.api.UndefinedParameterException: The input-parameter TestVal does not exist.
    I could test in MM test tab but facing the issue in runtime. Please suggest me where I am going wrong.
    Thanks,
    Madhurima

    Hi Madhurima,
    Have you checked if your PI version and patch level is being affected with this note  1933139 - Errors during execution of operation mapping with message mapping parameters names different from the operation mapping parameter names?
    Regards.

  • Error in phase import Homogeneous system copy from a BI 7.3 dual stack ABAPJAVA

    Hi
    I'm doing a Homogeneous system copy from a BI 7.3 dual stack ABAP+JAVA system with an Oracle DB (11g version, 11.2.0.3.0 patch level) with AIX ibm OS.
    Before starting export I've executed in the source system the report SMIGR_CREATE_DDL, as described in sap note 888210, and I generated *.SQL files.
    After, during the import in the target system I get the following error message:
    vi /expdb2/tmpDB0/sapinst_instdir/NW730/ORA/ORA/COPY/ORA/SYSTEM/STD/AS/import_monitor.log
    INFO: 2014-03-08 00:21:57 com.sap.inst.migmon.LoadTask run_report
    Monitor jobs: running 0, waiting 1, completed 60, failed 5, total 66  finish processing of package SAP0000
    You can see below the detail of the 5 packages in error:
    SAPAPPL0_1_5
    DbSlExecute: rc = 99
      (SQL error 2216)
      error message returned by DbSl:
    ORA-02216: tablespace name expected
    (DB) INFO: disconnected from DB
    /usr/sap/DB2/SYS/exe/uc/rs6000_64/R3load: job finished with 1 error(s)
    /usr/sap/DB2/SYS/exe/uc/rs6000_64/R3load: END OF LOG: 20140307141347
    SAPZPSA
    DbSlExecute: rc = 99
      (SQL error 2216)
      error message returned by DbSl:
    ORA-02216: tablespace name expected
    (DB) INFO: disconnected from DB
    SAPDODS
    DbSlExecute: rc = 99
      (SQL error 922)
      error message returned by DbSl:
    ORA-00922: missing or invalid option
    (DB) INFO: disconnected from DB
    SAPDFACT
    DbSl Trace: Error 1741 in exec_immediate() from oci_execute_stmt(), orpc=0
    DbSl Trace: ORA-01741 occurred when executing SQL stmt (parse error offset=8126464)
    (DB) ERROR: DDL statement failed
    (  ALTER TABLE "/BI0/F0TCT_C01"    ADD PARTITION "/BI0/F0TCT_C010000001131" VALUES LESS THAN ( 0000001131  )    TABLESPACE "" )
    DbSlExecute: rc = 99
      (SQL error 1741)
      error message returned by DbSl:
    ORA-01741: illegal zero-length identifier
    (DB) INFO: disconnected from DB
    SAPZOSO
    DbSl Trace: Error 922 in exec_immediate() from oci_execute_stmt(), orpc=0
    DbSl Trace: ORA-00922 occurred when executing SQL stmt (parse error offset=242024448)
    (DB) ERROR: DDL statement failed
    (CREATE TABLE "/BIC/B0000989000"    ("REQUEST" VARCHAR2 (000090)      DEFAULT ' ' NOT NULL,    "DATAPAKID" VARCHAR2 (000018)      DEFAULT '000000' NOT NULL,    "PART
    NO" NUMBER (000010)      DEFAULT 0 NOT NULL,    "RECORD" NUMBER (000010)      DEFAULT 0 NOT NULL,    "PLANT" VARCHAR2 (000012)      DEFAULT ' ' NOT NULL,    "MATERIA
    L" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "RPA_CURUOM" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "RPA_MVF" NUMBER (000017, 000002)      DEFAULT 0 NOT N
    ULL,    "PRICE_UNIT" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "RPA_QTYUOM" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "RT_SSMFGR" VARCHAR2 (000024)
        DEFAULT '00000000' NOT NULL,    "BASE_UOM" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "FRE_PLNPUR" VARCHAR2 (000036)      DEFAULT ' ' NOT NULL,    "FRE_MINS
    TK" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "FRE_SERLEV" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "FRE_SELCLS" VARCHAR2 (000003)      DEFAULT '
    0' NOT NULL,    "FRE_REPLST" VARCHAR2 (000006)      DEFAULT ' ' NOT NULL,    "ABCKEY" VARCHAR2 (000003)      DEFAULT ' ' NOT NULL,    "RECORDMODE" VARCHAR2 (000003)
        DEFAULT ' ' NOT NULL,    "RT_SERVLEV" VARCHAR2 (000003)      DEFAULT ' ' NOT NULL,    "RT_SUPS" VARCHAR2 (000003)      DEFAULT ' ' NOT NULL,    "VAL_TYPE" VARCH
    AR2 (000030)      DEFAULT ' ' NOT NULL,    "PUR_GROUP" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "RT_VPNEU" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,
    "CURRENCY" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "RT_VRKPE" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "DISMM" VARCHAR2 (000006)      DEFAULT ' '
    NOT NULL,    "SALES_UNIT" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "RT_VP_BT" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,    "RT_VPE_BT" NUMBER (000017,
    000003)      DEFAULT 0 NOT NULL,    "RT_VP_NT" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,    "RT_VPE_NT" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "R
    T_VWAERBT" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "RT_VWAERNT" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "RT_VPMEIBT" VARCHAR2 (000009)      DEFAULT '
    ' NOT NULL,    "RT_VPMEINT" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "LOC_CURRCY" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "UNIT" VARCHAR2 (000009)
      DEFAULT ' ' NOT NULL,    "CM_MCATDIV" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "CM_CDT1" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "CM_CDT2" VARCHAR2
    (000054)      DEFAULT ' ' NOT NULL,    "CM_CDT3" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "CM_CDT4" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "CM_HIEID"
    VARCHAR2 (000006)      DEFAULT ' ' NOT NULL,    "CPSTLC" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,    "CPSVLC" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL
    ,    "STOCK_VAL" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,    "STOCK_QTY" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "RT_SEASON" VARCHAR2 (000012)
      DEFAULT ' ' NOT NULL,    "RT_SEASYR" VARCHAR2 (000012)      DEFAULT '0000' NOT NULL,    "CALDAY" VARCHAR2 (000024)      DEFAULT '00000000' NOT NULL,    "CALWEEK"
    VARCHAR2 (000018)      DEFAULT '000000' NOT NULL,    "RF_BNDID" VARCHAR2 (000012)      DEFAULT ' ' NOT NULL,    "/BIC/ZCATTR3" VARCHAR2 (000006)      DEFAULT ' ' NOT
    NULL,    "/BIC/ZCSTYLE" VARCHAR2 (000006)      DEFAULT ' ' NOT NULL,    "/BIC/ZCIMAGE" VARCHAR2 (000006)      DEFAULT ' ' NOT NULL,    "/BIC/ZCBRNDTYP" VARCHAR2 (000
    003)      DEFAULT ' ' NOT NULL,    "/BIC/ZCGROUPE" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL)    PCTFREE 10    PCTUSED 00    INITRANS 001    TABLESPACE    STORAGE (
    INITIAL    0000000016 K            NEXT        0000001024 K            MINEXTENTS  0000000001            MAXEXTENTS  2147483645            PCTINCREASE 0000
        FREELISTS  001            FREELIST GROUPS 01)      PARTITION BY RANGE ("PARTNO")      (      PARTITION "/BIC/B00009890000000000002" VALUES LESS THAN      (00000
    00002)      NOCOMPRESS      ) )
    DbSlExecute: rc = 99
      (SQL error 922)
      error message returned by DbSl:
    ORA-00922: missing or invalid option
    (DB) INFO: disconnected from DB

    hello,
    Before anything update DB shared lib, R3load, R3ldctl and R3szchk in the target system. Also Check in source system if you have any tables o index missing in db02 transaction, If this system wa upgraded from a previous release please check TAORA and IAORA tables in source system and check all the tablespaces named in those tables are created in the target system.
    let me know how it goes.
    Regards,
    Michael

  • Error in Dual Stack Splitting:SAPControl:GetAccessPointList not implemented

    Hi,
    Am doing dual stack split with Keep Database option. Environment is
    OS- Sun Solaris SPARC 64 bit
    Database – Oracle 11.2.0.3
    System – ECC 6.0 (Netweaver 7.0) NUC
    We stuck in 1sr step while taking export of JAVA. Error is – GetAccessPointList fail:SAPControl:GetAccessPointList not implemented : method name or namespace not recognized
    I have upgraded kernel from 700 Sp 333 to 720 sp 700. also set parameter alternatively
    service/protectedwebmethods = SDEFAULT
    service/protectedwebmethods = DEFAULT
    service/protectedwebmethods = NONE in all profiles, but still no luck.
    Please find below logs.
    Also output of command
    Please find below log files, as I have executed command -
    sapcontrol '-prot' 'NI_HTTP' '-nr' '20' '-function' 'GetAccessPointList' which gets completed successfully(20- Instance No of ABAP). Log file
    -sapcontrol.log
    but when I execute command
    sapcontrol '-prot' 'NI_HTTP' '-nr' '00' '-function' 'GetAccessPointList'-- which shows error (00-instance no of SCS)
    log file - sapcontrol1.log
    Please find log files.
    Regards
    Vivek

    Hi Vivek ,
    Check for the permission of sapuxuserchk in all the exe directories including the local exe directory of SCS00
    1563660 - sapcontrol, user authorization issues (SUM)
    Thanks ,
    Manu

  • NW 720 Dual Stack Split Error

    Hi All,
    I am in the process of upgrading a NW 720 server to NW 740. Before I can continue, I was told that I need to first split my dual stack NW 720. Whist trying to split it, i have come across the following error (and I cant continue):
    I have tried using the "Keep DB" and "Move DB" options as well.
    Note: Im using Windows Server 2008 R2, Running SQL 2008
    Please help,
    Nish

    Exception in thread "main" java.lang.NoClassDefFoundError: com/sap/engine/offline/OfflineToolStart
    Caused by: java.lang.ClassNotFoundException: com.sap.engine.offline.OfflineToolStart
    Check whether these SAP notes are valid.
    1903663 - Java class is not found: com.sap.engine.offline.OfflineToolStart
    1678319 - Sapinst fails in step getUsageTypes during export of NW 7.0
    Regards
    RB

  • DMVPN on Dual Stack Hub Site

    Hi,
    I have a Dual Stacked DMVPN Hub site, VPN for ether IPv4 oder IPv6 is working properly, but not both at the same time.
    If the IPv4 Peers connect first, then the IPv6 Peers are unable to form an IPsec security association and the other way around. Crypto ISAKMP Phase1 is build correctly.
    A "show crypto ipsec sa" on the Hub shows only sa's for the kind of Peers that connected first. A "show crypto ipsec sa" on the Spoke that is unable to form an security association with the Hub shows an security association, but with no proposals and raising send error counters:
    Spoke (IPv4) SA
    interface: Tunnel1
        Crypto map tag: My-Profile-v4-head-1, local addr 2.2.2.1
       protected vrf: (none)
       local  ident (addr/mask/prot/port): (2.2.2.1/255.255.255.255/47/0)
       remote ident (addr/mask/prot/port): (1.1.1.1/255.255.255.255/47/0)
       current_peer 1.1.1.1 port 500
         PERMIT, flags={origin_is_acl,ipsec_sa_request_sent}
        #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
        #pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
        #pkts compressed: 0, #pkts decompressed: 0
        #pkts not compressed: 0, #pkts compr. failed: 0
        #pkts not decompressed: 0, #pkts decompress failed: 0
        #send errors 23255, #recv errors 0
         local crypto endpt.: 2.2.2.1, remote crypto endpt.: 1.1.1.1
         plaintext mtu 1500, path mtu 1500, ip mtu 1500, ip mtu idb (none)
         current outbound spi: 0x0(0)
         PFS (Y/N): N, DH group: none
         inbound esp sas:
         inbound ah sas:
         inbound pcp sas:
         outbound esp sas:
         outbound ah sas:
         outbound pcp sas:
       protected vrf: (none)
    I'm running IOS Version 15.3(2)T, is there some kind of known bug and/or a workaround for this?
    Interface Configuration
    interface GigabitEthernet0
    description ** Outside **
    ip address 1.1.1.1 255.255.255.0
    duplex auto
    speed auto
    ipv6 address 2001:1:1:1::1/64
    Crypto Configuration
    crypto isakmp policy 10
    encr aes 256
    authentication pre-share
    group 14
    crypto isakmp key cisco address 0.0.0.0 no-xauth
    crypto isakmp key cisco address ipv6 ::/0 no-xauth
    crypto isakmp keepalive 10 periodic
    crypto ipsec transform-set My-Set esp-aes 256 esp-sha512-hmac
    mode tunnel
    crypto ipsec profile My-Profile-v4
    description ** IPsec Profile fuer IPv4 Peers **
    set transform-set My-Set
    set pfs group2
    crypto ipsec profile My-Profile-v6
    description ** IPsec Profile fuer IPv6 Peers **
    set transform-set My-Set
    set pfs group2
    Tunnel Configuration
    interface Tunnel1
    description ** DMVPN Intranet IPv4 **
    bandwidth 1000
    ip vrf forwarding VPN
    ip address 10.0.10.1 255.255.255.0
    no ip redirects
    ip mtu 1416
    no ip next-hop-self eigrp 65351
    no ip split-horizon eigrp 65351
    ip pim sparse-mode
    ip nhrp map multicast dynamic
    ip nhrp network-id 1
    ip nhrp holdtime 360
    ip nhrp shortcut
    ip nhrp redirect
    ip tcp adjust-mss 1360
    load-interval 30
    shutdown
    keepalive 10 3
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint
    tunnel key 1
    tunnel protection ipsec profile My-Profile-v4 shared
    interface Tunnel2
    description ** DMVPN Intranet IPv6 **
    bandwidth 1000
    ip vrf forwarding VPN
    ip address 10.0.12.1 255.255.255.0
    ip mtu 1416
    no ip next-hop-self eigrp 65351
    no ip split-horizon eigrp 65351
    ip pim sparse-mode
    ip nhrp map multicast dynamic
    ip nhrp network-id 2
    ip nhrp holdtime 360
    ip nhrp shortcut
    ip nhrp redirect
    ip tcp adjust-mss 1360
    load-interval 30
    keepalive 10 3
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint ipv6
    tunnel key 2
    tunnel protection ipsec profile My-Profile-v6 shared
    Regards,
    Thomas

    Hello Marcin,
    it is working now :-)
    First I was running a dual stacked spoke as well, but now I am using one IPv4 and one IPv6 only spoke. The ipsec profiles are "shared", because besides the two shown tunnels I have one more IPv4 and IPv6 Tunnel for Extranetuse. The Spoke sites use "shared" as well, because they build a backup VPN Tunnel to a second Hub router.
    I have removed the "keepalive 10 3" from my Tunnel interfaces and rebooted the routers and everything is working now.
    Here are my final configurations:
    Crypto
    crypto isakmp policy 10
    encr aes 256
    authentication pre-share
    group 14
    crypto isakmp key cisco address 0.0.0.0         no-xauth
    crypto isakmp key cisco address ipv6 ::/0 no-xauth
    crypto isakmp keepalive 10 periodic
    crypto ipsec transform-set My-Set esp-aes 256 esp-sha512-hmac
    mode tunnel
    crypto ipsec profile My-Profile-v4
    description ** IPsec Profile fuer IPv4 Peers **
    set transform-set My-Set
    set pfs group2
    crypto ipsec profile My-Profile-v6
    description ** IPsec Profile fuer IPv6 Peers **
    set transform-set My-Set
    set pfs group2
    Tunnel Hub Dual Stacked
    interface Tunnel1
    description ** DMVPN Intranet IPv4 **
    bandwidth 1000
    ip vrf forwarding VPN
    ip address 10.0.10.1 255.255.255.0
    no ip redirects
    ip mtu 1416
    no ip next-hop-self eigrp 65351
    no ip split-horizon eigrp 65351
    ip pim sparse-mode
    ip nhrp map multicast dynamic
    ip nhrp network-id 1
    ip nhrp holdtime 360
    ip nhrp shortcut
    ip nhrp redirect
    ip tcp adjust-mss 1360
    load-interval 30
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint
    tunnel key 1
    tunnel protection ipsec profile My-Profile-v4 shared
    interface Tunnel2
    description ** DMVPN Intranet IPv6 **
    bandwidth 1000
    ip vrf forwarding VPN
    ip address 10.0.12.1 255.255.255.0
    ip mtu 1416
    no ip next-hop-self eigrp 65351
    no ip split-horizon eigrp 65351
    ip pim sparse-mode
    ip nhrp map multicast dynamic
    ip nhrp network-id 2
    ip nhrp holdtime 360
    ip nhrp shortcut
    ip nhrp redirect
    ip tcp adjust-mss 1360
    load-interval 30
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint ipv6
    tunnel key 2
    tunnel protection ipsec profile My-Profile-v6 shared
    end
    Tunnel Spoke IPv4
    interface Tunnel1
    description ** DMVPN Intranet IPv4 **
    ip vrf forwarding VPN
    ip address 10.0.10.2 255.255.255.0
    no ip redirects
    ip mtu 1416
    ip pim sparse-mode
    ip nhrp map 10.0.10.1 1.1.1.1
    ip nhrp map multicast 1.1.1.1
    ip nhrp network-id 1
    ip nhrp holdtime 360
    ip nhrp nhs 10.0.10.1
    ip nhrp shortcut
    ip tcp adjust-mss 1360
    delay 1000
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint
    tunnel key 1
    tunnel protection ipsec profile My-Profile-v4 shared
    end
    Tunnel Spoke IPv6
    interface Tunnel1
    description ** DMVPN Intranet IPv6 **
    ip vrf forwarding VPN
    ip address 10.0.12.2 255.255.255.0
    no ip redirects
    ip mtu 1416
    ip pim sparse-mode
    ip nhrp map 10.0.12.1 2001:1:1:1::1
    ip nhrp map multicast 2001:1:1:1::1
    ip nhrp network-id 2
    ip nhrp holdtime 360
    ip nhrp nhs 10.0.12.1
    ip nhrp shortcut
    ip tcp adjust-mss 1360
    delay 1000
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint ipv6
    tunnel key 2
    tunnel protection ipsec profile My-Profile-v6 shared
    end
    Thanks again
    Thomas

  • PI 7.1(dual stack) and PI 7.31(Single stack) -

    Friends,
    I have a proxy to proxy scenario - Proxy --> PI --> Proxy
    We have two servers PI 7.1(dual stack) and PI 7.31(Single stack)
    i did the development in ESR and my ESR is pointing to PI 7.1, when i execute the scenario i receive one error message "receiver could not be determined", i ensured that all my input is correct, still i get the same error message.
    the expectation is my scenario should point to PI 7.31, Can some one help me where and what settings i need to make in-order to make it work.
    Please Note: All my data is correct and i read some scn forums wherein they asked to refresh the cache , i have refreshed the cache also still the problem persists.
    Thanks in advance!

    Iñaki Vila
    Communication component in ID is the same as sender side.
    could you share your sender configuration?
    Did you mean Tcode - SXMB_ADM and under that Sender/Receiver configuration
    Krupa Rao Atluri
    In ID steps are correctly defined.
    I spoke to my colleague he hinted that at RUN TIME we want to point to PI7.31, he mentioned config change needed in SXMB_ADM
    any further inputs from any one could be useful.

  • Issue while creating Component Based Message Alerting in PI 7.31 Dual Stack

    Hi,
    We tried to implement Component Based Message Alerting following the steps mentioned in the below blog.
    http://scn.sap.com/community/pi-and-soa-middleware/blog/2012/03/25/michals-pi-tips-component-based-message-alerting
    Ours is PI 7.31 dual stack. However, after setting up the job with my own user id, I am getting the below error inside the log of Jobs tab:
    javax.jms.JMSSecurityException: You do not have permissions: action alertingVP.queue and instance:name alertingVP.queue
    action consumer
    instance jms/queue/xi/monitoring/alert/ALERT-TO-MAIL
    Please let us know what permission is required to set up the job.
    Thanks,
    Rahul

    Hi, 
    Now I am able to receive alert in my mailbox. But it's coming with improper content.
    I have set up the job at an interval of every 2 minutes in NWA, and in case if only 1 message fails in IE, in ideal case, I should receive only 1 message details in alert.
    However, in every 2 minutes, I am receiving junk data and the number is increasing for the particular scenario for which the alert has been created. Also the Error Category mentioned is showing improper.
    But in table SXMSALERTCONTENT I am able to view only the newly added failed entry.
    An erroneous alert email content is pasted below:
    63 messages failed for "Test_XXX" on "af.s0i.saps0i"
    Root cause: -1
    To navigate to the failed messages in the local message monitor use this link
    The first 1 messages of that data collection:
    "AdapterNamespace": "http://sap.com/xi/XI/System",
    "AdapterType": "File",
    "Channel": "FileSender_XXX",
    "ChannelParty": "",
    "ChannelService": "XXXXX",
    "Component": "af.s0i.saps0i",
    "ErrCat": "",
    "ErrCode": "",
    "ErrLabel": "-1",
    "ErrText": "Configured source directory '\\Outbound\\XXX\\CREMAS' does not exist",
    "FromParty": "",
    "FromService": "XXX",
    "Interface": "Z_CREMAS_SUSMM.CREMAS03",
    "Namespace": "urn:sap-com:document:sap:idoc:messages",
    "RuleId": "3a64dd6e1b1d3e58aff62ea70c97cb80",
    "Timestamp": "2013-02-01T09:43:23Z",
    "ToParty": "",
    "ToService": ""
    The failed message however do not relate to the 'source directory does not exist' issue. Please help.
    Thanks,
    Rahul

  • Mapping error in FCC to XML conversion

    hiii friends,
    im donig a simple fcc to xml conversion
    my Sender msg type is like
    TXT_mt
          records                             1.1   
                row                             1.n
                    id                             1
                    Name                       1
                    address                   1
    My receiver msg type like
    Xml_mt
          records                             1.1   
                row                             1.n
                    id                             1
                    Name                       1
                    address                   1
    msg mapping like
    records--->records
    id--->id
    Name-->Name
    address-->address
    **Im getting a mapping error like**
    <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="">
      <SAP:Category>Application</SAP:Category>
      <SAP:Code area="MAPPING">EXCEPTION_DURING_EXECUTE</SAP:Code>
      <SAP:P1>com/sap/xi/tf/_pepsi_fcc_file_mm_</SAP:P1>
      <SAP:P2>com.sap.aii.utilxi.misc.api.BaseRuntimeException</SAP:P2>
      <SAP:P3>RuntimeException in Message-Mapping transformatio~</SAP:P3>
      <SAP:P4 />
      <SAP:AdditionalText />
      <SAP:ApplicationFaultMessage namespace="" />
      <SAP:Stack>During the application mapping com/sap/xi/tf/_pepsi_fcc_file_mm_ a com.sap.aii.utilxi.misc.api.BaseRuntimeException was thrown: RuntimeException in Message-Mapping transformatio~</SAP:Stack>
      <SAP:Retry>M</SAP:Retry>
      </SAP:Error>
    I ve checked my adapeters they r green.
    Could u tell me the problem here and how to solve it???
    Regards
    Balaji

    Hii Volker,
    I have tried to understand the trace msg,. i got one interesting error message i hope it will tell the exact problem im facing,,,
    <Trace level="1" type="T">RuntimeException during appliction Java mapping com/sap/xi/tf/_pepsi_fcc_file_mm_</Trace>
      <Trace level="1" type="T">com.sap.aii.utilxi.misc.api.BaseRuntimeException: RuntimeException in Message-Mapping transformation: Cannot produce target element /ns:xml_mt/record/row. Check xml instance is valid for source xsd and target-field mapping fulfills requirements of target xsd at com.sap.aii.mappingtool.tf3.AMappingProgram
    My Sender CC  contains the following FCC parameters
    Document Name -
    > txt_mt
    Recordset Name -
    > records
    recordset Structure -
    >  row, *
    row.fieldNames -
    > id, Names,address
    row.fieldSeparator -
    > , (comma)
    row.endSeparator--- >  'nl'
    row.processConfiguration  -
    > FromConfiguration
    my TXT_in.txt contain
    100,balaji,chennai
    200,raj,orissa
    300,charakrat,bangalore
    Regards,
    Balaji
    Edited by: Balaji Pichaimuthu on Jul 1, 2009 3:44 PM

  • PI system upgrade from 7.1 to 7.4 dual stack

    Hi,
      We want to upgrade PI system to 7.4 .currently we are using PI 7.1 system (dual stack)and want to go for 7.4 dual stack.
      which one single stack or dual stack is the best approach and what are the impacts normally see when upgrading  to newer version.
      We are planning to install 7.4 freshly recomonded by SAP .
      We need to migrate objects from older system to newer system?
      I want to know the process from basis perspective also .
      Import/export or migrate is the best way to move objects from older sytem to newer system.
      Please suggest me any links about the process including basis point of view also suggestions for the approach.
    thanks,
    aman

    >>>> which one single stack or dual stack is the best approach and what are the impacts normally see when upgrading  to newer version.
    I would prefer single stack considering the SAP's future road map but of course it depends on how much effort your company is ready to spend. Incase you have lot of CCBPM's then you'll have to redesign them using Netweaver BPM if you go with single stack.
    As are going with fresh installation(migration) of dual stack then you don't need to invest much.
    >>>  We are planning to install 7.4 freshly recomonded by SAP .
      We need to migrate objects from older system to newer system?
      I want to know the process from basis perspective also .
    There is wizard using which you can move the directory objects ( classical scenario's to Integrated configurations). Please use it for ID objects
    Refer to the below blog for more details. (ignore blog's title. it's applicable for dual stack-> dual stack too)
    Moving Integration Directory Artifacts from dual stack to single stack
    For ESR you can simply export and import the tpz file.
    >>> I want to know the process from basis perspective also .
    They can simply follow the installation guide and execute the post installation steps properly.

  • MAPPING ERROR with IDOC

    Hi Friends,
           I am working on IDOC to JDBC scenario. Here i am using DEBMAS06 IDOC . when i tried to trigger an IDOC from BD12 T code its triggering an idoc but when i see it in MONI of XI, its giving mapping error. when i test my mapping program its executing successfully. even i tried to execute  with the incoming data in the sxmb_moni, i mean that i filles my mapping test with the same data coming into MONI  by filling all the segments coming into XI its executing successfully in mapping test.
       but  when i tried to trigger an idoc from we19 or from bd54 i am facing this error. can any one please let me know what else i can do for running  this scenario. let me know your comments.
    Thanks
    Ramana.

    Hi friends, I am getting the following error. On the sender side we dont need to take care of the structure because we will be importing the IDOC from the application system directly. on the receiver side i have created the structure for the data base. the mapping is running  fine in my mapping test. still i am not getting what else i need to do. please comment on this.
      <SAP:Code area="MAPPING">EXCEPTION_DURING_EXECUTE</SAP:Code>
      <SAP:P1>com/sap/xi/tf/_MessageMapping_</SAP:P1>
      <SAP:P2>com.sap.aii.utilxi.misc.api.BaseRuntimeException</SAP:P2>
      <SAP:P3>RuntimeException in Message-Mapping transformatio~</SAP:P3>
      <SAP:P4 />
      <SAP:AdditionalText />
      <SAP:ApplicationFaultMessage namespace="" />
      <SAP:Stack>com.sap.aii.utilxi.misc.api.BaseRuntimeException thrown during application mapping com/sap/xi/tf/_MessageMapping_: RuntimeException in Message-Mapping transformatio~</SAP:Stack>
      <SAP:Retry>M</SAP:Retry>
      </SAP:Error>

  • ChaRM for Dual Stack ABAP & JAVA - No http port for system SPD

    Hi,
    I have configured the CHARM for Dual stack ( Java, ABAP). when I perform the action 'Logon to System' it gives me following option
    " The system is a dual stack system. You can log
    on to the ABAP stack or non-ABAP stack
    To which stack do you want to log on?
    ABAP or Non ABAP"
    If I click on Non ABAP, one more message comes
    "You can logon to system SPD or just display its
    transport requests
    What do you want to run?
    Requests  Or Logon"
    If I click on Logon I get the Information " No http port for system SPD "
    & If I click Continue It will take me to Ugent Correction & error appears as 'Action System Logon in system SPD 100 of type Source Systems has been cancelled'
    How to Solve this error.
    Regards
    PK
    Edited by: PK on Sep 1, 2010 5:59 AM

    Its possible to login to portals(non-ABAP systems).
    Please check.
    http://wiki.sdn.sap.com/wiki/display/SMSETUP/Initial+Configuration
    Pl. make sure SLD for the Java stacks are defined correctly.
    regards,
    Arun.

  • NW2004s: SPS installation for dual-Stack-Installation (Java/ABAP) - PI(XI)

    Hello,
    we want to apply a new SP stack to a NW2004s (ECC 6.0) - dual stack (Java/ABAP) with PI(XI).
    The ABAP stack is sucessfully patched yet,
    but the Java stack needs still to be patched!
    In the SPS guide for SPS 9 and some OSS notes you can read that during the patching of the Java stack, the whole system (ABAP and Java engine) are restarted several times. But the JSPM should ask you before the restart.
    Do you have experiences how long the patching of the Java stack will take (downtime)?
    How often needs the system to be restarted?
    Is it possible to work with the ABAP engine (ABAP development, etc.) during the installation of the Java SPS with JSPM until the system needs to be restarted?
    How is it possible to minimize the downtime of the system during the Java SPS installation?
    Thanks in advance!
    Best regards,
    Stephan

    Hi Stephan,
    "Do you have experiences how long the patching of the Java stack will take (downtime)?"
    I believe this is most highly dependent on the hardware.  Although some patches will deploy more objects than others, the deploy time is shorter on better/faster hardware.  I applied SP9 on my laptop PC (java only, no ABAP stack) and it took a few hours total -- including my processing and error correcting time.  My laptop has only 2 GB RAM so this process was greatly slowed by the amount of available memory (I was running other applications, like Outlook, etc.) resulting in a lot of disk swapping.
    "How often needs the system to be restarted?"
    Again, I have a java only installation, no ABAP, but I believe there was only 1-2 system restarts.  The system had to be restarted after the application of the java kernel part of the patch, then shutdown and restarted again for the offline deployment phase.  I cannot remember if there was a restart after the online deployment phase.
    "Is it possible to work with the ABAP engine (ABAP development, etc.) during the installation of the Java SPS with JSPM until the system needs to be restarted?"
    Yes.
    "How is it possible to minimize the downtime of the system during the Java SPS installation?"
    I think the best way is to have the best hardware!  Also, be sure to be thoroughly prepared by reading the guide, all of the Notes, etc.  I was slowed by a previously correctable error (my administrator password had been previously changed and I had not changed it in the secure store -- Note 701654).
    Best Regards,
    Matt

  • Not able to start Jva Instance in Dual Stack System

    Hi All,
    We are facing problem while starting Java instance in dual stack system.Wile trying to coonect trough configtool,it is showing error message:
    Ora-01017:logon denied/
    We have updated password of sapr3 and sapsr3db through brtools,checked the password by trying to connect to database through SQL prompt via user sapr3 and sapsr3db.It comes ok.
    But when i am trying to connect to configtool and enter the crdentials through Direct Lgin instead of Secure Store then configtool opens but secure store does not gets loaded.
    Please tell me way to update new database user /password in configtool and hence in starting Java Patches.
    Thanks in advance as we are facing this issue in systemon whcih we need to apply the patches tomorrow.
    Regards
    Joy garg

    Hi Sven,
    That's correct i need to login through option No(not default settings i.e. Thorugh Direct Login) as via default settings it shows error in connection to DB.But after selcting No i.e.Direct Login and entering the required info i.e RDBMS URL,RDBMS User,RDBMS user's password it gets connected to DB but option of secure store does not come.So i guess there needs to update the password of SAPSR3DB somewhere in configtoll but w/t secure store how it can be done?
    Also following files are present at path /usr/sap/SRD/SYS/global/security/data;
    SecStore.1.key
    SecStore.1.properties
    SecStore.key
    SecStore.properties
    Please suggest.
    Regards
    Joy Garg

Maybe you are looking for


HashFlare