My iMac G5 with OSX 10.5.8 says Firefox 4 is not supported by the archetecture. Solution?

Downloaded Firefox 4, replacing older edition, which worked well. Icon of new version came up with circle with slash on it, and when I attempted to open the new Firefox, the Mac said it was not supported by the architecture.
What's the problem and solution? Will it not work with G5 models?

http://www.mozilla.com/en-US/firefox/4.0/system-requirements/ <br />
Mac
Operating Systems
* Mac OS X 10.5
* Mac OS X 10.6
Recommended Hardware
* Macintosh computer with an Intel x86 processor
* 512 MB of RAM
* 200 MB hard drive space
For older Macs that aren't supported in Firefox 4.0, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 . <br />
http://www.floodgap.com/software/tenfourfox/

Similar Messages

  • I am using a Seagate backup plus portable drive on my iMac 7 with OSX 10.9.2.  At startup up I always get a popup window stating "The disk you inserted is not readable by this computer.  I click ignore and everything seems OK. Is it?

    I am using a Seagate backup plus portable drive as my time machine backup on my iMac 7 with OSX 10.9.2 Mavericks.  At startup I always get popup window stating "The disk you inserted is not readable by this computer..?   I click ignore and everything seems to be OK.   Time machine seems to be backuping up to the seagate.   I can open time machine and see the history of backups.    Why does this message come up at startup of computer????

    If you installed the Seagate software, remove it according to the manufacturer's instructions.

  • IMac G5 with OSX 10.5.8 does not recognize my Western Digital external drive containing the majority of my music library.  Is there any way to access that drive and recover the music stored there?

    I have an iMac G5 with OSX 10.5.8 that does not recognize my Western Digital external drive.  I had no problems with this until I upgraded to 10.5.  Most of my music library is stored on the external drive.  Is there any way to access it to recover the music?

    How is it connected?  Have you tried different port?  How about logging in as a different user then trying to mount the drive.

  • Hey sur. my name anas and am from morocco i've just got a new iMac 2011 with OSX 10.7 and i want to downgrade to 10.6 please could you help sur to solve this it

    hey sur. my name anas and am from morocco i've just got a new iMac 2011 with OSX 10.7 and i want to downgrade to 10.6 please could you help sur to solve this it

    anas guellaf wrote:
    it still make 3 bips before starting the IMAC.
    That is another problem not related to the Mac OS X version you are trying to use.
    Three beeps at startup means you have a bad ram module in the computer.  Did you install the ram or did it come from another owner this way?  The first problem you need to solve is the bad ram.
    When the iMac starts, go to the apple left side of the menu bar, About This Mac, More Info, System Report, Hardware, Memory and see what the report is on the memory...does the iMac report all memory modules that have been installed as OK or does it show bad memory?  If there is not any information, you then need to remove the memory modules and restart one at a time to see which is bad.
    On the bottom of the screen there should be a small door that you can remove with a small screw driver.  You need to lay the iMac flat, disconnect the power cord, remove that small door and remove the memory modules.  You can then put two in (if it has four) and see if it starts without the beeps.  Do that with each module so you find out which is bad.  Once you know the bad memory, you can buy a new module, just like the ones installed, so the iMac starts without the beeps.
    Next, you cannot use a DVD for another computer for your iMac unless it is from one that is identical to yours.  So, you need to talk to Apple and have them send the DVD for your particular iMac.

  • I have an iMac (2007) with osx 10.5.8, I would like to upgrade to mountain lion 10.8. Is it possible?

    I have an iMac (2007) with OSX 10.5.8 and I want to upgrade it to mountain lion. It tells me I must have OSX 10.6 or higher but it won't let me upgrade to that. Is it possible or do I have to buy another iMac? Love my iMac! I'll never have a PC again. Macs all the way.

    Upgrade Paths to Snow Leopard, Lion, and/or Mountain Lion
    You can upgrade to Mountain Lion from Lion or directly from Snow Leopard. Mountain Lion can be downloaded from the Mac App Store for $19.99. To access the App Store you must have Snow Leopard 10.6.6 or later installed.
    Upgrading to Snow Leopard
    You must purchase Snow Leopard through the Apple Store: Mac OS X 10.6 Snow Leopard - Apple Store (U.S.). The price is $19.99 plus tax. You will be sent physical media by mail after placing your order.
    After you install Snow Leopard you will have to download and install the Mac OS X 10.6.8 Update Combo v1.1 to update Snow Leopard to 10.6.8 and give you access to the App Store. Access to the App Store enables you to download Mountain Lion if your computer meets the requirements.
         Snow Leopard General Requirements
           1. Mac computer with an Intel processor
           2. 1GB of memory
           3. 5GB of available disk space
           4. DVD drive for installation
           5. Some features require a compatible Internet service provider;
               fees may apply.
           6. Some features require Apple’s MobileMe service; fees and
               terms apply.
    Upgrading to Lion
    If your computer does not meet the requirements to install Mountain Lion, it may still meet the requirements to install Lion.
    You can purchase Lion by contacting Customer Service: Contacting Apple for support and service - this includes international calling numbers. The cost is $19.99 (as it was before) plus tax.  It's a download. You will get an email containing a redemption code that you then use at the Mac App Store to download Lion. Save a copy of that installer to your Downloads folder because the installer deletes itself at the end of the installation.
         Lion System Requirements
           1. Mac computer with an Intel Core 2 Duo, Core i3, Core i5, Core i7,
               or Xeon processor
           2. 2GB of memory
           3. OS X v10.6.6 or later (v10.6.8 recommended)
           4. 7GB of available space
           5. Some features require an Apple ID; terms apply.
    Upgrading to Mountain Lion
    To upgrade to Mountain Lion you must have Snow Leopard 10.6.8 or Lion installed. Purchase and download Mountain Lion from the App Store. Sign in using your Apple ID. Mountain Lion is $19.99 plus tax. The file is quite large, over 4 GBs, so allow some time to download. It would be preferable to use Ethernet because it is nearly four times faster than wireless.
         OS X Mountain Lion - System Requirements
           Macs that can be upgraded to OS X Mountain Lion
            1. iMac (Mid 2007 or newer)
             2. MacBook (Late 2008 Aluminum, or Early 2009 or newer)
             3. MacBook Pro (Mid/Late 2007 or newer)
             4. MacBook Air (Late 2008 or newer)
             5. Mac mini (Early 2009 or newer)
             6. Mac Pro (Early 2008 or newer)
             7. Xserve (Early 2009)
         Are my applications compatible?
             See App Compatibility Table - RoaringApps.
         Am I eligible for the free upgrade?
             See Apple - Free OS X Mountain Lion upgrade Program.
         For a complete How-To introduction from Apple see Upgrade to OS X Mountain Lion.
    Note that you need a specific 2007 model to run Mountain Lion.

  • With OSX 10.9.1 I can no longer receive updates through the App Store?

    With OSX 10.9.1 I can no longer receive updates through the App Store?

    Check your settings in Preferences
    AppleMenu()>System Preferences>App Store

  • I AM TRYING TO INSTALL MY CEATIVE SUITE 2 TO MAC PRO WITH OSX.9, really I don't know why I keep answering the same questiion

    I AM TRYING TO INSTALL MY CEATIVE SUITE 2 TO MAC PRO WITH OSX.9, really I don't know why I keep answering the same questiion

    Seriously, I have a full version of Creative Suites2 premium that I was told would be the last version I need to buy..... So I would like my version loaded on my Mac Pro!

  • HT1750 I tried to restore my iMac with my MacBook Pro Cd's but the computer say that the cd is not supported on the iMac,Now it does come out because there's no eject button on the screen.How could I take it out an how could I install the OS X Lion ok wit

    I tried to restore my iMac with my MacBook pro CDs but it's seem it got restored but it say this cd is not supported on this iMac, What could I do to take out the disk?

    Also, if you have Lion on the computer. You have a recovery partition on the drive. On startup hold down 'Control' to bring up your startup menu. Select "Recovery HD". That's how you get to it. Lion's recovery partition acts as the installation discs that came with all previous versions of OS X.

  • Latest version firefox cannot open not supported by architecture on mac G5 with OSX 10.5.8

    Have been using firefox as preferred browser on Mac G5 OSX 10.5.8. Today, message said new version optimized for yahoo available. I downloaded it and now firefox logo has do not enter sign superimposed and when I try to open, it says can't open not supported by architecture. I can't even go back to my older version of firefox which worked perfectly. Now have to use a different browser. How can problem be solved. Appreciate your help.

    Latest versions require an Intel chip on Mac
    *See --> https://www.mozilla.org/en-US/firefox/6.0/system-requirements/index.html
    You can try TenFourFox:
    *http://www.macupdate.com/app/mac/37761/tenfourfox
    *Developer's blog: http://tenfourfox.blogspot.com/
    '''If this reply solves your problem, please click "Solved It" next to this reply when <u>signed-in</u> to the forum.'''

  • "........iMac is not supported on the iPhone

    I have an older iphone - 2 I think.  When I try to connect the bluetooth I receive a message on the iphone, ".........iMac is not supported on the iPhone" Does anyone have a solution.  Both the iphone and imac can find each other, the iphone just will not accept the imac.  Is there a download to upgrade the iphone to accept my new imac.  Thank you.

    iPhone's have never been able to sync via Bluetooth.
    In the last year Apple added WiFi sync to iTunes, so you can sync an iPhone or iPad via WiFi with iTunes.
    You can also sync wirelessly over the internet using iCloud for contacts, calendars, bookmarks etc - again over WiFi.
    But you cannot, and never have been able to, sync an iOS device with a Mac over Bluetooth.

  • Whenever i try to login with my apple ID , it says this ID is not yet used on itunes. & because of this i can't even download apps. Please someone tell me what should i do ? ASAP.

    Whenever i try to login with my apple ID , it says this ID is not yet used on itunes. & because of this i can't even download apps. Please someone tell me what should i do ? ASAP.

    Read here:
    http://support.apple.com/kb/ht2589

  • TS1814 I had to restore my Ipod Touch and now I can't connect to anything on it. When it asks for my Apple ID it comes up with an error message and says that it can't connect to the server. I have checked my WiFi connection and its connected.

    I have had to restore my Ipod Touch and now I can't connect to anything on it. When it asks for my Apple ID it comes up with an error message and says that it can't connect to the server. I have checked my WiFi connection and its connected.

    Hi there,
    I would recommend taking a look at the troubleshooting steps found in the article below.
    Can't connect to the iTunes Store
    http://support.apple.com/kb/ts1368
    -Griff W.

  • Itunes account is under a comcast address along with all my 800  tunes, my .me address is not connected to the music.  how do I get itunes match to work for my iphone

    itunes account is under a comcast address along with all my 8000 +  tunes, my .me address is not connected to the music.  how do I get itunes match to work for my iphone

    U.S. Cellular does not unlock iPhones: iPhone: Wireless carrier support and features - Apple Support
    Sell the iPhone to someone that wants to use U.S. Cellular, and use the proceeds to purchase an iPhone that is usable on the wireles carrier you prefer.

  • I have tried to view videos created in premiere elements 10 and I get the following message: "this file type is not supported, or the required codec is  not installed.  When it opens there is a red screen in the monitor panel with Korean writing which als

    I have tried to view videos created in premiere elements 10 and I get the following message: "this file type is not supported, or the required codec is  not installed.  When it opens there is a red screen in the monitor panel with Korean writing which also appears in the place of each clip in the video.  I tried uninstalling and reinstalling premiere elements 10, but that did not have any effect on the video.  Do you have any suggestions?  I researched codec, but do not understand them at all.

    gloucester
    In case you did not find it, the following is a copy/paste of the Announcement on Premiere Elements 19/NVIDIA GeForce
    that appears at the top of this forum.
    Premiere Elements 10 NVIDIA Video Card Driver Roll Back
    If you are a Premiere Elements 10 user whose Windows computer uses a NVIDIA GeForce video card and you are experiencing
    Premiere Elements 10 display and/or unexplained program behavior, then your first line of troubleshooting needs to be rolling
    back the video card driver version instead of assuring that it is up to date.
    Since October 2013 to the present, there have been a growing number of reports about display and unexplained workflow
    glitches specific to the Premiere Elements 10 user whose Windows computer has a NVIDIA GeForce video card. If this applies
    to you, then the “user to user” remedy is to roll back the NVIDIA GeForce video card driver as far as is necessary to get rid of
    the problems. The typical driver roll back has gone back as far as March – July 2013 in order to get a working Premiere
    Elements 10. Neither NVIDIA nor Adobe has taken any corrective action in this regard to date, and none is expected moving forward.
    Since October 2013, the following thread has tried to keep up with the Premiere Elements 10 NVIDIA reports
    http://forums.adobe.com/thread/1317675
    Older NVIDIA GeForce drivers can be found
    http://www.nvidia.com/Download/Find.aspx?lang=en-us
    A February 2014 overview of the situation as well as how to use the older NVIDIA GeForce drivers for the driver roll back can be found
    http://atr935.blogspot.com/2014/02/pe10-nvidia-video-card-roll-back.html
    ATR

  • What do I do with this error? "could not complete your request because the file appears to be from a camera model which is not supported by the installed version of camera raw?"

    what do I do with this error? "could not complete your request because the file appears to be from a camera model which is not supported by the installed version of camera raw?"

    It can be that you have an old version of Photoshop Elements and a new camera.
    Please tell us
    Which operating system you are running on
    Which version of Photoshop Elements you are using
    Which camera the raw images come from (Make & model)
    Brian

Maybe you are looking for

  • Error while starting manage server

    Hi, I get the following error while starting the managed server. But there is no fatal error and the startup is successful. The domain has an admin and a managed instance. The admin server starts without any trouble. Please help resolve this problem.

  • ITunes crashed...and I lost my playlists and preferences

    I'm not quite sure how it happened, but iTunes crashed...and it took almost all of my playlists with it as well as resetting my preferences.  Very strange.  Is it possible to get it back to where I want it?  I have (had) hundreds of playlists for var

  • My ipod won't update

    When i open itunes and connect the ipod it recognizes it as usual and begins flashing the do not disconnect image on the ipod however it doesn't go away unless you manually eject the iPod and then the iPod does not update and add new songs. If you ri

  • DTW Error ( Pls Urgent )

    Hi In Dtw while uploading the data's in second step i am getting error like " source file muct be provided ". For business Partners i am doing up load : For this Some 8 Template is there as follows,   Bp account receivable   Bp adress   Bp bank accou

  • Transportable and non transportable requests in the SRM EBP cusomizing

    Hi friends, can u please give the list of transportable and non transportable requests for the ebp configuration. thank Arun Edited by: arun kumar on Aug 6, 2008 8:19 AM