Need help for coding and designing

Hi All,
Problem Statement
A financial institution is in the verge of automating their existing “customer data management” system. Currently they are maintaining their
customer data in a comma separated file (CSV) format. You, as a software consultant have been requested to create a system that is flexible,
extensible and maintainable. Your proposed system should also take care of moving the data from the old system to the new one.
Customer has following specific requirements
1.This is an internal offline application and need not be a web based solution
2.The new application should be cost effective
3.The application should have good response time as compared to the ones suggested by other vendors
4.Phase 1 work should concentrate mainly on building a simple system which moves the data from CSV to the new one and display the
moved data on the screen.
Sample CSV file containing customer data
<first name>, <age>, <pan number>, <date of registration>
Ramesh, 28, JWSLP1987, 30/01/2006
Rajesh, 32, POCVT2087, 23/10/2005
Shankar, 39, TRYUP3945, 24/7/2003
Shyam, 45 BLIWP5612, 15/3/2004
Requirements for coding DOJO
•Ensure that your solution is built around open source frameworks and tools to avoid licensing issues. (Ex: Eclipse, MySQL, etc)
•Please give me any idea to write code for this issue.
Thank you.
Edited by: user636482 on Oct 28, 2008 2:03 AM

The first requirement is to NOT use software like "Oracle".
The specifications are to use a CSV file as the "data source". The case asks you to "move" the data from CSV to "the new one" and display the moved data.
So this sounds more like a data load routine -- but not to load into Oracle.
You are in the wrong forum.

Similar Messages

  • Need help for Update and cancel SalesOrder

    Hi All,
    I  written java code for create sales order based on salesquotation,now i want to update and cancel sales order ,i need help to update and cancel salesorder.
    can give any related links for update and cancel salesorder.
    Thanks and Regards,
    Srinivas

    Hi srinivas.L
    It is simple, here is some sample code. You must use getbykey to get the document. Then once you got it you can make whatever changes you need. Then update it. where i have oOrder.Update() you can have oOrder.cancel
    Dim oOrder As SAPbobsCOM.Documents
            oOrder = oCompany.GetBusinessObject(SAPbobsCOM.BoObjectTypes.oOrders)
            If oOrder.GetByKey(530) Then
                oOrder.Lines.SetCurrentLine(1)
                oOrder.Lines.WarehouseCode = "01"
                If oOrder.Update() <> 0 Then
                    MsgBox(oCompany.GetLastErrorDescription)
                End If
            Else
                MsgBox("Nothing found")
            End If
    Hope this helps

  • I need help for cloud and ios5

    Help me for cloud and ios5

    Sounds like I have a similar problem.  I just updated iPad, and iPhone to iOS5.   I synced these devices with my iMac on iCloud.  Calendars and contacts synced just fine.   However for some strange reason I can no longer sync any music on my 32 GB iPhone.  iTunes is telling me that I am beyond the phone's capacity with an "Other" item that is nearly as large as my music collection.  Am I missing something here?  Your help will be greatly appreciated.

  • Need help for ACL and NAT for VoIP

    Dear experts
    I configure my PBX server to work with one VoIP provider. When I put the server in blank network, mean that without VLANs.
    The IP PBX server can register to the VoIP provider system normally and I can make call out and receive calls normally.
    However, when I put the PBX behind the Cisco router with some configuration. The PBX cannot register with the VoIP provider system.
    Eventhough I can receive calls from outside but can not make a call from inside to outside, because of the PBX cannot register.
    Could you please help me to point out what is wrong with my Cisco router configuration.
    Thanks a lot
    Building configuration...
    Current configuration : 1982 bytes
    ! Last configuration change at 17:18:27 UTC Mon Feb 24 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$ZJEF$8np0QvQTD1nTaOosa9yGW1
    no aaa new-model
    memory-size iomem 20
    no ipv6 cef
    ip source-route
    ip cef
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    license udi pid CISCO2911/K9 sn FTX1603AH9C
    interface Embedded-Service-Engine0/0
    no ip address
    interface GigabitEthernet0/0
    description internal-LAN
    ip address x.x.x.4 255.255.0.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/1.1
    encapsulation dot1Q 11
    ip address 172.x.x.1 255.255.240.0
    interface GigabitEthernet0/2
    description internet
    ip address 50.x.x.93 255.255.x.x
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list 100 interface GigabitEthernet0/2 overload
    ip nat inside source static udp x.x.x.8 5060 50.x.x.93 5060 extendable
    ip route profile
    ip route 0.0.0.0 0.0.0.0 50.x.x.94
    ip route 172.16.240.0 255.255.x.0 x.x.x.5
    ip route 172.16.242.0 255.255.x.0 x.x.x.5
    access-list 100 permit ip x.x.0.0 0.0.255.255 any
    access-list 100 permit ip 172.16.240.0 0.0.0.255 any
    access-list 100 permit ip 172.16.242.0 0.0.0.255 any
    access-list 100 permit udp any any range 5004 5090
    access-list 100 permit udp any any range 10000 20000
    control-plane
    line con 0

    You really don't want to use NAT with SIP. Odds are it won't work. This is because SIP embeds hostnames/IP Addresses inside the packets, and standard NAT does not look inside packets.
    If you want a NAT-type functionality for SIP, you need something called a session border controller. Look up Cisco CUBE
    http://www.cisco.com/c/en/us/products/unified-communications/unified-border-element/index.html
    https://supportforums.cisco.com/docs/DOC-17964
    http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-border-element/99863-cube-config.html
    GTG
    Please rate all helpful posts.

  • Need help for ACL and NAT

    Hi all
    I setup a router 2911 with the configuration below for the phone system inside handle all calls in and out from and to the outside provider VoIP.
    I can receive the calls from outside all time but I cannot make the call from the inside to outside.
    I think that I miss some configuration in router.
    The 172.a.b.c is the IP phone system.
    Please give me any advice
    Thanks a lot.
    The router configuration:
    interface Embedded-Service-Engine0/0
    no ip address
    interface GigabitEthernet0/0
    description internal-LAN
    ip address 172.x.x.4 255.255.x.x
    ip accounting output-packets
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/1.1
    encapsulation dot1Q 11
    ip address 172.16.208.1 255.255.240.0
    interface GigabitEthernet0/2
    description internet
    ip address 50.x.x.93 255.255.x.240
    ip accounting output-packets
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list 100 interface GigabitEthernet0/2 overload
    ip nat inside source static udp 172.a.b.c 5060 50.x.x.93 5060 extendable
    ip route profile
    ip route 0.0.0.0 0.0.0.0 50.240.226.94
    ip route 172.16.240.0 255.255.254.0 172.10.0.5
    ip route 172.16.242.0 255.255.254.0 172.10.0.5
    ip access-list extended VLAN-voice
    access-list 100 permit ip 172.x.0.0 0.0.255.255 any
    access-list 100 permit ip 172.16.240.0 0.0.0.255 any
    access-list 100 permit ip 172.16.242.0 0.0.0.255 any
    control-plane
    line con 0
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    login
    transport input all
    scheduler allocate 20000 1000
    end

    You really don't want to use NAT with SIP. Odds are it won't work. This is because SIP embeds hostnames/IP Addresses inside the packets, and standard NAT does not look inside packets.
    If you want a NAT-type functionality for SIP, you need something called a session border controller. Look up Cisco CUBE
    http://www.cisco.com/c/en/us/products/unified-communications/unified-border-element/index.html
    https://supportforums.cisco.com/docs/DOC-17964
    http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-border-element/99863-cube-config.html
    GTG
    Please rate all helpful posts.

  • Need help for email and BBM

    Hi i'm Alex and im having problems setting up my email and bbm on my blackberry curve 8520. i'm with orange as a dolphin plan and just wondering if any one can help set up my bbm and enterprise Activation Password.

    Hello !
    It seems you dont have BlackBerry Internet Service (BIS) Plan activated on your device.
    Please contact your Service Provider for activating it.
    Hope this resolves your Problem!
    If your problem has been resolved then would request you to Click on "Like" and accept as "Solution" so that other Advisors doesnt invest their time on this Message anymore.
    Thanks.

  • I need standard for coding and desiging in 9ids

    well me is new to oralce soo can any one help me to privide me the document or link or any reference material regarding the standard that is provided by the oracle co-operation for the its developer suite product development
    i will also appricatie that plz guide me for the standard develoment in this package so that it help me in making new projects in oracle according to its standard that been given thanks

    Tariq,
    as far as Forms is concerned there are no design patterns or design guidelines that I am aware of. For JDeveloper, which also is part of the Oracle9iDS you can follow any Java programming design guidlelines you want.
    Forms information can be found at
    otn.oracle.com/products/forms
    Reports
    otn.oracle.com/products/reports
    JDeveloper
    otn.oracle.com/products/jdev
    Frank

  • Need Help for Itunes and quicktime

    Hi there,
    I just formated my computer and my os is windows 2003 server. When I installed itunes, everything is fine however when I installed quicktime I got an error code : -3. What's going on? and after I done with the installation, I couldn't open an itunes as well I got an error message said : The exception Privileged instruction. (0xc0000096) occurred in the application at location 0x7ca2af84. I don't know what happened I did install itunes and quick time under windows 2003 before and it works fine, but now I got an error. I appreciate the answer, Thanks in advance.

    by any chance, did you try downloading the QT Player
    from the "QuickTime 7.1 with iTunes 6 for Windows
    2000/XP" link on the QT download page? that one
    actually leads to an itunes/QT installer bundle.
    I did it this way
    let's try a careful standalone QT 7.1 reinstall.
    download and save a copy of the QT 7.1 standalone
    installer to your hard drive. (we'll run the install
    from there rather than online.) switch off
    antivirus and antispyware applications prior to the
    install.
    Quicktime 7.1 Standalone Installer
    if that install goes through okay, does your itunes
    launch properly again?
    I did like you said and I can not even uninstall quicktime from my computer. When I double click the installation package: It shows
    Unhandled Exception
    Error Number : 0x80040707
    Description : DLL function call crashed : QTInstallCode.QuickTimeUninstallProc
    Setup will now terminate
    Also, itunes does not launch properly. I think there is something wrong because when I install the windows from the cd I can install and run these two programs(itunes and quicktime). They work fine and no problem at all. However, after I update windows by using windows update web site, I couldn't use these programs since then. I have no idea what is going on? Before I reinstall my os, I also use windows server 2003 with sp1 and I could run these two programs. I think may be the new version of itunes and quicktime that they put on the web site have some issues with the windows server 2003, not sure about that.
    Thanks.
    (if you get an error message on the QT standalone
    reinstall, let us know what it says. include error
    message numbers if you're getting any.)
    love, b

  • I need help for install and configure password sync from AD to OID

    Hi guys!
    I need to sync passwords from AD to OID, first all, ¿What software do I need? I read some docs and don't find the good config.
    I'm trying with:
    -Database 11g
    -Weblogic 11g
    -SOA 11g
    -IDM 11g
    -IAM 11g
    First I install the Database and load the schemas with RCU, next install Weblogic without domian, next install SOA, next install IDM (OID and DIP) in a new Weblogic Domain, next install IAM, next configure IAM in the domain created before, next configure SSL, check the config by using ldapbind, next configure DIP.
    It's that ok?
    ¿What I am doing wrong?
    Thank you all.

    If all you need is AD & OID then OIM is not required. DIP alone can handle this
    Password sync should work using DIP. if this is not working then check synchronization mapping and verify that password attribute is also part of this AD-OID sync. Enable debug in synchronization profile or raise an Service Request with Oracle support.
    Check
    http://docs.oracle.com/cd/E23943_01/oid.1111/e10031/odip_actdir.htm#CHDIGDEH
    and
    http://docs.oracle.com/cd/E23943_01/oid.1111/e10031/odip_config_integration.htm#BABBFAAJ
    and
    http://docs.oracle.com/cd/E23943_01/oid.1111/e10031/odip_adpasswordsync.htm#CHDBIIJC
    Atul Kumar

  • Need help for java and linux

    Hi, guys,
    I am being involved in a project.My current task is to build an interface using java. This interface will obtain some information from a linux-based software called NistNet, which is done by C and has GUI as well. My question is, can I use this java-based interface to obtain some information that is typed in this NistNet'GUI? If I can, how can I do that?
    Any hint available?
    Thanks!

    You can bridge between Java and C using the "Java Native Interface" (JNI). There used to be a good tutorial on this site but it vanished for no apparent reason in some resent update, so try a websearch.
    See also
    http://java.sun.com/j2se/1.4/docs/guide/jni/
    http://java.sun.com/j2se/1.5.0/docs/guide/jni/

  • Please help me!--rendering makes the images or video blurry (very pixelated) deteriorates the image  Adobe Premier Elements 13  need help!  .jpg and mpeg images,  but I have never "rendered" before since I got APE 13 about 6 weeks ago.  I am desperate for

    Please help me!--rendering makes the images or video blurry (very pixelated) deteriorates the image  Adobe Premier Elements 13  need help!  .jpg and mpeg images,  but I have never "rendered" before since I got APE 13 about 6 weeks ago.  I am desperate for assistance!

    That's going to be a ridiculous waste of money and energy.
    First of all, the current ATI drivers don't support multiple GPUs, so at the moment even a single 4870X2 would be only a 'normal' 4870 (which is quite a speed beast already). GFX drivers evolve rapidly, so things might look different next month, but when it comes to Linux and hardware there's one Golden Rule: stay away from the newest stuff and wait for proper support to get coded.
    I also wonder what power supply could possibly cope with the differences between idle and full load; that's way beyond 400W. But then, I'm one of those "quiet&green" types where >100W idle is already a bit much.
    I kind of understand that you want to get it done and not worry about hardware for the next 10 years or so, but that's simply not how the hardware world works and never did. At least not for the average consumer.

  • Hello i need help for adobe creative cloud...when i launch application adobe  cc 2014  for photoshop or illustrator.....the apps launch and i can see the workspace and menu bar  for a while and  suddenly this application close automatic

    hello i need help for adobe creative cloud...when i launch application adobe  cc 2014  for photoshop or illustrator.....the apps launch and i can see the workspace and menu bar  for a while and  suddenly this application close automatic

    Sign in, activation, or connection errors | CS5.5 and later
    Mylenium

  • Hi, I need help for my notebook Macbook Pro - I turned on the notebook and the screen look like start but did not start nothing, the screen froze and continuing load, load and never stop.

    Hi, I need help for my notebook Macbook Pro - I turned on the notebook and the screen look like start but did not start nothing, the screen froze and continuing load, load and never stop

    screen look on

  • Need help for publishing web intelligence document (universe) into InfoView

    Post Author: mirage
    CA Forum: Publishing
    Hello all,
    I need help for publishing web intelligence document (universe) into InfoView.
    can't find this information in Business Objects Designer's Guide and in Business Objects Administrator Guide.
    Can somebody give short instructions how can I do it?
    Regards, Slava

    If the change between the 2 types of data has to happen dynamically during run time them
    1. Use 2 dataproviders
         a. Current
         b. Historic
    2. Merge the 2 dimensions
    3. Use Webi variable to switch between the measure of the current and historic universe
    Ex  if [year] < 2010 then historic.[expense] else current.[expense]
    Hope this helps,
    Divya

  • Need help for writing extract program

    hi
    i need help for writing extract program to retriew data from legacy system.
    i already developed bdc programs for me31k and me21.
    my requirement is to write extract program s for those t.codes.
    to retriew data from legacy system and stored in flat file.

    i need help with a java program. it is a program that allows the user to enter a student's GPA, number of extracurricular activities, and number of service activities. The user can not enter a gpa above 4.0 or below 0. The user can not enter a negative number for the number of both activities. If the student meets the following criteria: 1) GPA of 3.8 or above and at least one extracurricular activity and one service activity, 2) GPA below 3.8 but at least 3.4 and a total of at least three extracurricular and service activities, 3) GPA below 3.4 but at least 3.0 and at least two extracurricular activities and three service activities, the message "Scholarship candidate" should display. If the student does not meet the criteria above, then the message"not a candidate" should display. Can you help me, please?
    You haven't posted ANY 'java program' for us to help with.
    The forum is NOT a coding service. It is to help you with YOUR code.
    Post the code you have written and SHOW us (don't just tell us) how you compile it and execute it and the results you get. Then we can help you with any problems you are are having.
    If you need help understanding just what the program should be doing you need to ask your instructor to clarify the assignment.

Maybe you are looking for

  • Curve 9360 battery drains quickly!

    Hi Folks, I bought new BB curve 9360 three days back. The probem I am facing is with battery. The battery does not last for even 6 hours. Very disappointing. I use standard BB services, with 3G connection. Let me know if this normal. Solved! Go to So

  • Synchronizing recurring lunar calendar meetings

    I am using outlook on my desktop and have set a couple of recurring meetings to occur on Lunar calendar dates. When I synchronize my calendar with my phone these meetings don't appear in the phone's calendar, although their meeting instance is in the

  • Odd errors in repairing disk permissions...

    I get the following log when I go to repair my disk permissions: Repairing permissions for "Mac" Warning: SUID file "usr/libexec/load_hdi" has been modified and will not be repaired. Warning: SUID file "System/Library/PrivateFrameworks/DiskManagement

  • Front Row is listing particular TV Shows as Movies, even though the "Type" attribute is correctly set to "TV Show" in iTunes.

    Here's the whole story: My friend gave me access to a whole season of one of my favorite TV shows, with all the commericals removed! Lucky me!  I imported them into iTunes using File, Add To Library, and at first they all showed up in Movies.  I then

  • No export in Bookmarks toolbar on !.8 for mac

    Running OSX 10.6.8. Firefox 1.8 for Yahoo 22.0. Want to export bookmarks to Safari. Go to bookmarks tab and click on "show all bookmarks" then to "bookmarks toolbar". No export bookmark available. Thanks