Need help for Update and cancel SalesOrder

Hi All,
I  written java code for create sales order based on salesquotation,now i want to update and cancel sales order ,i need help to update and cancel salesorder.
can give any related links for update and cancel salesorder.
Thanks and Regards,
Srinivas

Hi srinivas.L
It is simple, here is some sample code. You must use getbykey to get the document. Then once you got it you can make whatever changes you need. Then update it. where i have oOrder.Update() you can have oOrder.cancel
Dim oOrder As SAPbobsCOM.Documents
        oOrder = oCompany.GetBusinessObject(SAPbobsCOM.BoObjectTypes.oOrders)
        If oOrder.GetByKey(530) Then
            oOrder.Lines.SetCurrentLine(1)
            oOrder.Lines.WarehouseCode = "01"
            If oOrder.Update() <> 0 Then
                MsgBox(oCompany.GetLastErrorDescription)
            End If
        Else
            MsgBox("Nothing found")
        End If
Hope this helps

Similar Messages

  • I need help for cloud and ios5

    Help me for cloud and ios5

    Sounds like I have a similar problem.  I just updated iPad, and iPhone to iOS5.   I synced these devices with my iMac on iCloud.  Calendars and contacts synced just fine.   However for some strange reason I can no longer sync any music on my 32 GB iPhone.  iTunes is telling me that I am beyond the phone's capacity with an "Other" item that is nearly as large as my music collection.  Am I missing something here?  Your help will be greatly appreciated.

  • Need help with updates and new apple programs

    something happened to my pc. having problems with my pc when it restarts.
    wondered if anyone whichapple updates require a restart, and which don't?
    if they require a restart to finish installation, they fail, and my pc crashes, and i have to resintall os.
    i know the iwork does not require a restart, where ilife does. so for now, i can install iwork, but not ilife.
    in anyone familiar with 10.5.6 knows which updates/add ond require a restart and which don't, please post. any help appreciated. 4th re install now.

    Hey network --
    Sorry to hear of your problems . . .
    What Mac are you running there?
    Did the installation of 10.5.6 finally go well?
    You're having problems with iLife, but what about Snow Leopard?

  • Need help for ACL and NAT for VoIP

    Dear experts
    I configure my PBX server to work with one VoIP provider. When I put the server in blank network, mean that without VLANs.
    The IP PBX server can register to the VoIP provider system normally and I can make call out and receive calls normally.
    However, when I put the PBX behind the Cisco router with some configuration. The PBX cannot register with the VoIP provider system.
    Eventhough I can receive calls from outside but can not make a call from inside to outside, because of the PBX cannot register.
    Could you please help me to point out what is wrong with my Cisco router configuration.
    Thanks a lot
    Building configuration...
    Current configuration : 1982 bytes
    ! Last configuration change at 17:18:27 UTC Mon Feb 24 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$ZJEF$8np0QvQTD1nTaOosa9yGW1
    no aaa new-model
    memory-size iomem 20
    no ipv6 cef
    ip source-route
    ip cef
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    license udi pid CISCO2911/K9 sn FTX1603AH9C
    interface Embedded-Service-Engine0/0
    no ip address
    interface GigabitEthernet0/0
    description internal-LAN
    ip address x.x.x.4 255.255.0.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/1.1
    encapsulation dot1Q 11
    ip address 172.x.x.1 255.255.240.0
    interface GigabitEthernet0/2
    description internet
    ip address 50.x.x.93 255.255.x.x
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list 100 interface GigabitEthernet0/2 overload
    ip nat inside source static udp x.x.x.8 5060 50.x.x.93 5060 extendable
    ip route profile
    ip route 0.0.0.0 0.0.0.0 50.x.x.94
    ip route 172.16.240.0 255.255.x.0 x.x.x.5
    ip route 172.16.242.0 255.255.x.0 x.x.x.5
    access-list 100 permit ip x.x.0.0 0.0.255.255 any
    access-list 100 permit ip 172.16.240.0 0.0.0.255 any
    access-list 100 permit ip 172.16.242.0 0.0.0.255 any
    access-list 100 permit udp any any range 5004 5090
    access-list 100 permit udp any any range 10000 20000
    control-plane
    line con 0

    You really don't want to use NAT with SIP. Odds are it won't work. This is because SIP embeds hostnames/IP Addresses inside the packets, and standard NAT does not look inside packets.
    If you want a NAT-type functionality for SIP, you need something called a session border controller. Look up Cisco CUBE
    http://www.cisco.com/c/en/us/products/unified-communications/unified-border-element/index.html
    https://supportforums.cisco.com/docs/DOC-17964
    http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-border-element/99863-cube-config.html
    GTG
    Please rate all helpful posts.

  • Need help for ACL and NAT

    Hi all
    I setup a router 2911 with the configuration below for the phone system inside handle all calls in and out from and to the outside provider VoIP.
    I can receive the calls from outside all time but I cannot make the call from the inside to outside.
    I think that I miss some configuration in router.
    The 172.a.b.c is the IP phone system.
    Please give me any advice
    Thanks a lot.
    The router configuration:
    interface Embedded-Service-Engine0/0
    no ip address
    interface GigabitEthernet0/0
    description internal-LAN
    ip address 172.x.x.4 255.255.x.x
    ip accounting output-packets
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/1.1
    encapsulation dot1Q 11
    ip address 172.16.208.1 255.255.240.0
    interface GigabitEthernet0/2
    description internet
    ip address 50.x.x.93 255.255.x.240
    ip accounting output-packets
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list 100 interface GigabitEthernet0/2 overload
    ip nat inside source static udp 172.a.b.c 5060 50.x.x.93 5060 extendable
    ip route profile
    ip route 0.0.0.0 0.0.0.0 50.240.226.94
    ip route 172.16.240.0 255.255.254.0 172.10.0.5
    ip route 172.16.242.0 255.255.254.0 172.10.0.5
    ip access-list extended VLAN-voice
    access-list 100 permit ip 172.x.0.0 0.0.255.255 any
    access-list 100 permit ip 172.16.240.0 0.0.0.255 any
    access-list 100 permit ip 172.16.242.0 0.0.0.255 any
    control-plane
    line con 0
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    login
    transport input all
    scheduler allocate 20000 1000
    end

    You really don't want to use NAT with SIP. Odds are it won't work. This is because SIP embeds hostnames/IP Addresses inside the packets, and standard NAT does not look inside packets.
    If you want a NAT-type functionality for SIP, you need something called a session border controller. Look up Cisco CUBE
    http://www.cisco.com/c/en/us/products/unified-communications/unified-border-element/index.html
    https://supportforums.cisco.com/docs/DOC-17964
    http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-border-element/99863-cube-config.html
    GTG
    Please rate all helpful posts.

  • Need help for email and BBM

    Hi i'm Alex and im having problems setting up my email and bbm on my blackberry curve 8520. i'm with orange as a dolphin plan and just wondering if any one can help set up my bbm and enterprise Activation Password.

    Hello !
    It seems you dont have BlackBerry Internet Service (BIS) Plan activated on your device.
    Please contact your Service Provider for activating it.
    Hope this resolves your Problem!
    If your problem has been resolved then would request you to Click on "Like" and accept as "Solution" so that other Advisors doesnt invest their time on this Message anymore.
    Thanks.

  • Need Help for Itunes and quicktime

    Hi there,
    I just formated my computer and my os is windows 2003 server. When I installed itunes, everything is fine however when I installed quicktime I got an error code : -3. What's going on? and after I done with the installation, I couldn't open an itunes as well I got an error message said : The exception Privileged instruction. (0xc0000096) occurred in the application at location 0x7ca2af84. I don't know what happened I did install itunes and quick time under windows 2003 before and it works fine, but now I got an error. I appreciate the answer, Thanks in advance.

    by any chance, did you try downloading the QT Player
    from the "QuickTime 7.1 with iTunes 6 for Windows
    2000/XP" link on the QT download page? that one
    actually leads to an itunes/QT installer bundle.
    I did it this way
    let's try a careful standalone QT 7.1 reinstall.
    download and save a copy of the QT 7.1 standalone
    installer to your hard drive. (we'll run the install
    from there rather than online.) switch off
    antivirus and antispyware applications prior to the
    install.
    Quicktime 7.1 Standalone Installer
    if that install goes through okay, does your itunes
    launch properly again?
    I did like you said and I can not even uninstall quicktime from my computer. When I double click the installation package: It shows
    Unhandled Exception
    Error Number : 0x80040707
    Description : DLL function call crashed : QTInstallCode.QuickTimeUninstallProc
    Setup will now terminate
    Also, itunes does not launch properly. I think there is something wrong because when I install the windows from the cd I can install and run these two programs(itunes and quicktime). They work fine and no problem at all. However, after I update windows by using windows update web site, I couldn't use these programs since then. I have no idea what is going on? Before I reinstall my os, I also use windows server 2003 with sp1 and I could run these two programs. I think may be the new version of itunes and quicktime that they put on the web site have some issues with the windows server 2003, not sure about that.
    Thanks.
    (if you get an error message on the QT standalone
    reinstall, let us know what it says. include error
    message numbers if you're getting any.)
    love, b

  • Need help for coding and designing

    Hi All,
    Problem Statement
    A financial institution is in the verge of automating their existing “customer data management” system. Currently they are maintaining their
    customer data in a comma separated file (CSV) format. You, as a software consultant have been requested to create a system that is flexible,
    extensible and maintainable. Your proposed system should also take care of moving the data from the old system to the new one.
    Customer has following specific requirements
    1.This is an internal offline application and need not be a web based solution
    2.The new application should be cost effective
    3.The application should have good response time as compared to the ones suggested by other vendors
    4.Phase 1 work should concentrate mainly on building a simple system which moves the data from CSV to the new one and display the
    moved data on the screen.
    Sample CSV file containing customer data
    <first name>, <age>, <pan number>, <date of registration>
    Ramesh, 28, JWSLP1987, 30/01/2006
    Rajesh, 32, POCVT2087, 23/10/2005
    Shankar, 39, TRYUP3945, 24/7/2003
    Shyam, 45 BLIWP5612, 15/3/2004
    Requirements for coding DOJO
    •Ensure that your solution is built around open source frameworks and tools to avoid licensing issues. (Ex: Eclipse, MySQL, etc)
    •Please give me any idea to write code for this issue.
    Thank you.
    Edited by: user636482 on Oct 28, 2008 2:03 AM

    The first requirement is to NOT use software like "Oracle".
    The specifications are to use a CSV file as the "data source". The case asks you to "move" the data from CSV to "the new one" and display the moved data.
    So this sounds more like a data load routine -- but not to load into Oracle.
    You are in the wrong forum.

  • I need help for updating my ipod touch 1g to 3.1.1

    I can't update my ipod touch 1g to 3.1.1. I am using MAC lion latest version and the latest version of itunes. Also, I didn't install any security programs. Every time I try to download the update files an error show saying an error occurred 8288.

    I would search the forum using the Communities search in the upper right of this page.  Search for:
    8288
    I recall that yu have to contact iTunes.
    Apple - Support - iTunes Store - Contact Us

  • Need help for java and linux

    Hi, guys,
    I am being involved in a project.My current task is to build an interface using java. This interface will obtain some information from a linux-based software called NistNet, which is done by C and has GUI as well. My question is, can I use this java-based interface to obtain some information that is typed in this NistNet'GUI? If I can, how can I do that?
    Any hint available?
    Thanks!

    You can bridge between Java and C using the "Java Native Interface" (JNI). There used to be a good tutorial on this site but it vanished for no apparent reason in some resent update, so try a websearch.
    See also
    http://java.sun.com/j2se/1.4/docs/guide/jni/
    http://java.sun.com/j2se/1.5.0/docs/guide/jni/

  • I need help for install and configure password sync from AD to OID

    Hi guys!
    I need to sync passwords from AD to OID, first all, ¿What software do I need? I read some docs and don't find the good config.
    I'm trying with:
    -Database 11g
    -Weblogic 11g
    -SOA 11g
    -IDM 11g
    -IAM 11g
    First I install the Database and load the schemas with RCU, next install Weblogic without domian, next install SOA, next install IDM (OID and DIP) in a new Weblogic Domain, next install IAM, next configure IAM in the domain created before, next configure SSL, check the config by using ldapbind, next configure DIP.
    It's that ok?
    ¿What I am doing wrong?
    Thank you all.

    If all you need is AD & OID then OIM is not required. DIP alone can handle this
    Password sync should work using DIP. if this is not working then check synchronization mapping and verify that password attribute is also part of this AD-OID sync. Enable debug in synchronization profile or raise an Service Request with Oracle support.
    Check
    http://docs.oracle.com/cd/E23943_01/oid.1111/e10031/odip_actdir.htm#CHDIGDEH
    and
    http://docs.oracle.com/cd/E23943_01/oid.1111/e10031/odip_config_integration.htm#BABBFAAJ
    and
    http://docs.oracle.com/cd/E23943_01/oid.1111/e10031/odip_adpasswordsync.htm#CHDBIIJC
    Atul Kumar

  • Need help, just updated and now i cant open

    so i try to open itunes and it says the item you selected is unavailable. it might have been names or moved ect ect. so what do i Do?
    Everytime I update itunes i always have an issue...

    should i try to uninstall and reinstall? will i loose my library?

  • I don't know why whenever i choose " check for updates " and download itunes 11.1 , it never shows any downloads , and i need itunes 11.1 so i can restore my iphone again .. help please

    I don't know why whenever i choose " check for updates " and download itunes 11.1 on my desktop , it never shows any downloads .. even when i tried downloading it from the website, and i need itunes 11.1 so i can restore my iphone again .. help please

    When you see a beachball cursor or the slowness is especially bad, note the exact time: hour, minute, second.  
    These instructions must be carried out as an administrator. If you have only one user account, you are the administrator.
    Launch the Console application in any of the following ways:
    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)
    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.
    ☞ Open LaunchPad and start typing the name.
    The title of the Console window should be All Messages. If it isn't, select
              SYSTEM LOG QUERIES ▹ All Messages
    from the log list on the left. If you don't see that list, select
              View ▹ Show Log List
    from the menu bar at the top of the screen.
    Each message in the log begins with the date and time when it was entered. Scroll back to the time you noted above.
    Select the messages entered from then until the end of the episode, or until they start to repeat, whichever comes first.
    Copy the messages to the Clipboard by pressing the key combination command-C. Paste into a reply to this message by pressing command-V.
    The log contains a vast amount of information, almost all of it useless for solving any particular problem. When posting a log extract, be selective. A few dozen lines are almost always more than enough.
    Please don't indiscriminately dump thousands of lines from the log into this discussion.
    Please don't post screenshots of log messages—post the text.
    Some private information, such as your name, may appear in the log. Anonymize before posting.

  • I want to use a mac mini as a server supporting storage. Can I pair my macair to it for when I need to perform updates and maintenance ?

    I want to use a mac mini as a server supporting storage. I have other devices such as an iMac and iPad that will access information from the server. I do not want to purchase a monitor and keyboard as the unit will sit in a cupboard out of sight. Can I pair my macair to it for when I need to perform updates and maintenance ?

    I have a 2010 Mac Mini running Yosemite and Server which I use
    as a headless home server.
    I have is set up to allow screen sharing and can connect to it and
    control it with my iMac, Macbook Pro, iPhone, and a 2011 Mini Server
    that I use as an HTPC.
    You can check this out for all the Yosemite Server capabilities:
    https://help.apple.com/advancedserveradmin/mac/4.0/
    I have iTunes Home Sharing set up on it and have my entire iTunes
    library on it.  I can then use any of my Macs to play Movies or Songs
    from it and only keep locally a select subset of that on my individual
    devices.
    Rather than and update server, I utilize Server's Caching Service.  The caching
    server will duplicate any update download (system or MacApp Store purchases)
    any time a device that is connected to my network down loads one.  The update will
    then be stored locally and all other devices will download the update from it which
    can be faster than from Apple directly.  This has the advantage of only having to download
    once with limited bandwidth internet connections.  There is also an Update Server service
    available, but it is some what more involved in setting up.  However, it will download
    and store all available updates.
    There is another thing as well if you do not care for syncing things like Contacts, Calendar, etc.
    to iCloud, you can set Server up to sync these items across devices locally.

  • I have installed itunes 10.7 several times.  All goes well.  After reboot, I go into itunes and check for updates and it says I need to download the update 10.7! (And so cant sync with my Iphone)

    I have installed itunes 10.7 several times, all goes well. After reeboot, I go to check for updates and it still wants to update to version 10.7! I cant sync to my iphone4 because I get an error message saying I need version 10.6.3 or later. Help

    Thank you for getting me started on the track by mentioning "Revo" Uninstaller.  The results of "Revo" spoke volumns on why a successful install of ITunes is so difficult to achieve.  It is the evil "BONJOUR".
    I then tripped upon the following site by Apple and the detailed directions (I read, printed, re-read and followed the instructions.  It was intense) brought a successful ITunes, Quick Time and the lovely Bonjour home.  Thank you for the start JD42.
    http://support.apple.com/kb/HT1923

Maybe you are looking for

  • Printing w/ border in iPhoto 5

    Hi, I am using a Pixma iP4200 printer and have no problem printing borderless but now I want to brint WITH borders. In iPhoto I go to page setup and choose my iP4200 and 4X6. However, when I got to print I get an error message as the preview picture.

  • Blackbook Apps - licence key probleme after purchase

    Hello, I am a french user of BB. I bought Blackbook app yesterday but It don't generate a license key. I have received the confirmation of the purchase by email with my order number but no license key. How sould I do to resolve this problem? I don t

  • Content conversion parameters necessary for fixed length file

    Hi, I new to xi.The scenario is that i have to handle a fixed length file where the records repeat after every 80 characters.Can anyone help me as to how thw identify the start of every record based on length thanks and regards , srinadh

  • H: not found when insert the card of flash drive for auto import In Lightroom CC

    when i try to auto import Inside Lightroom 6 or CC getting an error "H: not found" as soon as i plug the memory card or any flash drive to the computer. i'm using lightroom CC win 7 64 bit

  • Error creating frame 32631 (error -1)

    So I shot this video of my friend's band. Single camera on a tripod, one long shot of about 26 minutes. Synced up some pro recorded audio, threw in some intro and outro titles. Now trying to export. Each time I export, it gets about 70% of the way th