Need help with jsp that uses a java program

Hi, sorry for my english but i am italian.
I've got a problem: i use java builder and i have a java program(this program has got a main and includes libraries) about graphich on tree, this program visualizes these trees and makes operations on these.
Now i must use JSP so that a client can see this program (this program is on the server) and can interact with it.
I can't use applet.I must use only jsp.
Who can tell me how can i start???
Thanks.

If you are not allowed to use an applet, then you are limited by what can be achieved with HTML in a browser.
You would have to figure out how to render it with HTML, then program your jsp to write out this html programatically.

Similar Messages

  • Need help in html that use in java

    I want to know .. can I open new frame and use the whole frame for a HTML document (located on the client) .. and can anyone give me an example or tell me where can I find the example.. I will use it in the system that build use JDK 1.3 or JDK 1.2

    Hi mutia
    If I understand you correctly, the code below is what you're looking for. It is just a crude example with a start screen with a help button, when you click on the help button, a new frame is opened and a string containing HTML tags is displayed. You can compile and test it like this:
    javac myFrame.java
    java myFrame
    myFrame.java
    =======================
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    public class myFrame extends JFrame implements ActionListener {
       public static void main(String args[]) {
          myFrame frame = new myFrame();
          frame.pack();
          frame.setVisible(true);
       public myFrame() {
          setTitle("Main Frame");
          JPanel pan=new JPanel();
          pan.setLayout(new BorderLayout());
          pan.setPreferredSize(new Dimension (200, 100));
          setContentPane(pan);
          JButton helpButton = new JButton("H E L P");
          pan.add(helpButton);
          helpButton.addActionListener(this);
          addWindowListener(new WindowAdapter() {
             public void windowClosing(WindowEvent e) {
                System.exit(0);
       public void actionPerformed(ActionEvent e) {
          JFrame F=new JFrame();
          F.setTitle("Help Screen");
          JPanel pan=new JPanel();
          pan.setLayout(new BorderLayout());
          pan.setPreferredSize(new Dimension (200, 100));
          F.setContentPane(pan);
    * lab can be read in from a file but I'll leave that part up to you
          JLabel lab=new JLabel("<html><font size=+1 color=blue>This is a test help<br>message</html>");
          pan.add(lab);
          F.pack();
          F.setVisible(true);
    }V.V.

  • Need Help With Redirect That Uses Session Variable

    I am new to dynamic sites, php, and developer toolbox, but I have been able to create a login site using the different form wizards fairly easily (in CS3 with Developers toolbox).
    <br />
    <br />I am trying to set a server behavior on a page that redirects the user to a new page if a session variable matches a recordset.
    <br />
    <br />I was using an extension (PHP Sessions - http://www.adobe.com/cfusion/exchange/index.cfm?event=extensionDetail&amp;extid=681308 ) that worked great, but when I installed developers toolbox, it stopped working (get error message about runtime/MX environment).
    <br />
    <br />Ive been struggling for days and this is what Ive come up with so far:
    <br />------------------------------------
    <br />session_start();
    <br />if (!isset($HTTP_SESSION_VARS[$_SESSION['kt_firstname']]) || $HTTP_SESSION_VARS[$_SESSION['kt_firstname']] = $row_Recordsetfname['firstname']) {
    <br /> header ("Location: ../firstname/firstname1.php");
    <br />}
    <br />------------------------------------
    <br />
    <br />It redirects regardless of the match. Any ideas on what I can do to get this working? Here is all of the code (with block from above inserted) up until the doc type:
    <br />------------------------------------
    <br /><?php require_once('../Connections/project1.php'); ?>
    <br /><?php<br />// Load the tNG classes<br />require_once('../includes/tng/tNG.inc.php');<br /><br />// Make unified connection variable<br />$conn_project1 = new KT_connection($project1, $database_project1);<br /><br />//Start Restrict Access To Page<br />$restrict = new tNG_RestrictAccess($conn_project1, "../");<br />//Grand Levels: Any<br />$restrict->Execute();<br />//End Restrict Access To Page<br /><br />if (!function_exists("GetSQLValueString")) {<br />function GetSQLValueString($theValue, $theType, $theDefinedValue = "", $theNotDefinedValue = "") <br />{<br />  $theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue;<br /><br />  $theValue = function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : mysql_escape_string($theValue);<br /><br />  switch ($theType) {<br />    case "text":<br />      $theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";<br />      break;    <br />    case "long":<br />    case "int":<br />      $theValue = ($theValue != "") ? intval($theValue) : "NULL";<br />      break;<br />    case "double":<br />      $theValue = ($theValue != "") ? "'" . doubleval($theValue) . "'" : "NULL";<br />      break;<br />    case "date":<br />      $theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";<br />      break;<br />    case "defined":<br />      $theValue = ($theValue != "") ? $theDefinedValue : $theNotDefinedValue;<br />      break;<br />  }<br />  return $theValue;<br />}<br />}<br /><br />// FELIXONE - 2002   SB by Felice Di Stefano - www.felixone.it<br />session_start();<br />if (!isset($HTTP_SESSION_VARS[$_SESSION['kt_firstname']]) || $HTTP_SESSION_VARS[$_SESSION['kt_firstname']] = $row_Recordsetfname['firstname']) {<br />  header ("Location: ../firstname/firstname1.php");<br />}<br /><br />$colname_Recordsetfname = "-1";<br />if (isset($_SESSION['kt_user_name'])) {<br />  $colname_Recordsetfname = $_SESSION['kt_user_name'];<br />}<br />mysql_select_db($database_project1, $project1);<br />$query_Recordsetfname = sprintf("SELECT firstname FROM registration WHERE user_name = %s", GetSQLValueString($colname_Recordsetfname, "text"));<br />$Recordsetfname = mysql_query($query_Recordsetfname, $project1) or die(mysql_error());<br />$row_Recordsetfname = mysql_fetch_assoc($Recordsetfname);<br />$totalRows_Recordsetfname = mysql_num_rows($Recordsetfname);<br /><br />$colname_Recordset1 = "-1";<br />if (isset($_SESSION['kt_user_name'])) {<br />  $colname_Recordset1 = $_SESSION['kt_user_name'];<br />}<br />mysql_select_db($database_project1, $project1);<br />$query_Recordset1 = sprintf("SELECT `Date` FROM registration WHERE user_name = %s", GetSQLValueString($colname_Recordset1, "text"));<br />$Recordset1 = mysql_query($query_Recordset1, $project1) or die(mysql_error());<br />$row_Recordset1 = mysql_fetch_assoc($Recordset1);<br />$totalRows_Recordset1 = mysql_num_rows($Recordset1);<br />?>
    <br />
    <br />------------------------------

    I am new to adobe toolbox... I ve created a ligin page but not sure how to pass the session variable. I am trying to direct successful login to a page like... index.php?id=filter
    <br />
    <br />been struggling all day with this. Please help!!!
    <br />
    <br /><?php require_once('Connections/comm.php'); ?>
    <br /><?php<br />// Load the common classes<br />require_once('includes/common/KT_common.php');<br /><br />// Load the tNG classes<br />require_once('includes/tng/tNG.inc.php');<br /><br />// Make a transaction dispatcher instance<br />$tNGs = new tNG_dispatcher("");<br /><br />// Make unified connection variable<br />$conn_comm = new KT_connection($comm, $database_comm);<br /><br />// Start trigger<br />$formValidation = new tNG_FormValidation();<br />$formValidation->addField("kt_login_user", true, "text", "", "", "", "");<br />$formValidation->addField("kt_login_password", true, "text", "", "", "", "");<br />$tNGs->prepareValidation($formValidation);<br />// End trigger<br /><br />// Make a login transaction instance<br />$loginTransaction = new tNG_login($conn_comm);<br />$tNGs->addTransaction($loginTransaction);<br />// Register triggers<br />$loginTransaction->registerTrigger("STARTER", "Trigger_Default_Starter", 1, "POST", "kt_login1");<br />$loginTransaction->registerTrigger("BEFORE", "Trigger_Default_FormValidation", 10, $formValidation);<br />$loginTransaction->registerTrigger("END", "Trigger_Default_Redirect", 99, "{kt_login_redirect}");<br />// Add columns<br />$loginTransaction->addColumn("kt_login_user", "STRING_TYPE", "POST", "kt_login_user");<br />$loginTransaction->addColumn("kt_login_password", "STRING_TYPE", "POST", "kt_login_password");<br />$loginTransaction->addColumn("kt_login_rememberme", "CHECKBOX_1_0_TYPE", "POST", "kt_login_rememberme", "0");<br />// End of login transaction instance<br /><br />// Execute all the registered transactions<br />$tNGs->executeTransactions();<br /><br />// Get the transaction recordset<br />$rscustom = $tNGs->getRecordset("custom");<br />$row_rscustom = mysql_fetch_assoc($rscustom);<br />$totalRows_rscustom = mysql_num_rows($rscustom);<br /><br />?>
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <script src="includes/common/js/base.js" type="text/javascript"></script>
    <br />
    <script src="includes/common/js/utility.js" type="text/javascript"></script>
    <br />
    <script src="includes/skins/style.js" type="text/javascript"></script>
    <br /><?php echo $tNGs->displayValidationRules();?>
    <br />
    <br />
    <br />
    <br /><?php<br /> echo $tNGs->getLoginMsg();<br />?>
    <br /><?php<br /> echo $tNGs->getErrorMsg();<br />?>
    <br />
    <form method="post" id="form1" class="KT_tngformerror" action="%3C?php%20echo%20KT_escapeAttribute(KT_getFullUri());%20?%3E">
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <br />
    <table cellpadding="2" cellspacing="0" class="KT_tngtable">
    <tr>
    <td class="KT_th">
    <label for="kt_login_user">Username:</label>
    </td>
    <td>
    <input type="text" name="kt_login_user" id="kt_login_user" value="<?php echo KT_escapeAttribute($row_rscustom['kt_login_user']); ?>" size="32" />
    <br /> <?php echo $tNGs->displayFieldHint("kt_login_user");?> <?php echo $tNGs->displayFieldError("custom", "kt_login_user"); ?></td>
    </tr>
    <tr>
    <td class="KT_th">
    <label for="kt_login_password">Password:</label>
    </td>
    <td>
    <input type="password" name="kt_login_password" id="kt_login_password" value="" size="32" />
    <br /> <?php echo $tNGs->displayFieldHint("kt_login_password");?> <?php echo $tNGs->displayFieldError("custom", "kt_login_password"); ?></td>
    </tr>
    <tr>
    <td class="KT_th">
    <label for="kt_login_rememberme">Remember me:</label>
    </td>
    <td>
    <input <?php if (!(strcmp(KT_escapeAttribute($row_rscustom['kt_login_rememberme']),"1"))) {echo "checked";} ?> type="checkbox" name="kt_login_rememberme" id="kt_login_rememberme" value="1" />
    <br /> <?php echo $tNGs->displayFieldError("custom", "kt_login_rememberme"); ?></td>
    </tr>
    <tr class="KT_buttons">
    <td colspan="2">
    <input type="submit" name="kt_login1" id="kt_login1" value="Login" />
    <br /></td>
    </tr>
    </table>
    <br />
    <a href="forgot_password.php">Forgot your password?</a>
    <br /></form>
    <br />
    <p>&#160;</p>
    <br />
    <br />

  • Need help with query that uses 'SELECT INTO'

    Hi guys,
    I am trying to duplicate the values of a table to another by using the script below:
    ACCEPT TBSNAME           CHAR PROMPT 'Tablespace name>'
    PROMPT Connect As System
    Connect system
    CREATE TABLE FREESPACE
         TABLESPACE_NAME          VARCHAR(20)          NOT NULL,
              CONSTRAINT FREESPACE_PKEY PRIMARY KEY(TABLESPACE_NAME),
         TOTAL_FREE_STORAGE     NUMBER(10)          NOT NULL
    ) TABLESPACE USERS;
    SELECT     TABLESPACE_NAME,
              SUM(BLOCKS) TOTBLOCKS
    INTO      FREESPACE
    FROM      SYS.DBA_FREE_SPACE
    WHERE      TABLESPACE_NAME = UPPER('&TBSNAME')
    GROUP BY TABLESPACE_NAME;
    However, when I execute this script, I was prompted with the 'missing keyword' error which happens at the third line of the select statment. Any idea what's missing here?
    Thanks in advance.

    If you mean "fill up the table FREESPACE" by using "select...into..." then it is totally wrong. You cannot do it in plsql also.
    Use this:
    insert into freespace(tablespace_name,total_free_storage)
    SELECT TABLESPACE_NAME,SUM(BLOCKS) TOTBLOCKS
    FROM SYS.DBA_FREE_SPACE
    WHERE TABLESPACE_NAME = UPPER('&TBSNAME')
    GROUP BY TABLESPACE_NAME;
    Message was edited by:
    Yas

  • I need help with setting up my Sun Java Studio Creator

    Hello all, i need help with setting up the Studio Creator, i"m new to all that staff so is there anyone to help me just a little with all that if yes email me at [email protected] or get me on AOL Instant Messanger with the screen name: wretch17
    thanks :-)

    Hi,
    Welcome to the Creator community! Thanks for your interst in Sun Java Studio Creator. Please feel free to post any question related to creator on this forum .
    Take a look the creator website at
    http://developers.sun.com/prodtech/javatools/jscreator/
    CreatorTeam

  • Please Help with range of uncertainty in java program

    I really need help with this, I've been searching for an answer all day and have found nothing.
    This is the original program and I'm trying to make it so instead of stoppingDistance having to be equal to tailgateDistance for it to print minor wreck, it will allow a range of 40 feet. Like a range of uncertainty of plus or minus 20 feet, and I need to use a named constant that is: RANGE = 40.0
    import java.util.Scanner;
    public class StoppingA
    public static void main(String[] args)
    Scanner stdIn = new Scanner(System.in);
    double speed; // speed car is traveling;
    double tailgateDistance; // distance from other car;
    double stoppingDistance; // calculated distance
    System.out.print ("Enter your speed (in mph): ");
    speed = stdIn.nextDouble();
    System.out.print ("Enter your tailgate distance (in feet): ");
    tailgateDistance = stdIn.nextDouble();
    stoppingDistance=speed*(2.25+speed/21);
    if (stoppingDistance < tailgateDistance)
    System.out.println("No problem.");
    else if (stoppingDistance == tailgateDistance)
    System.out.println("Minor wreck.");
    else if (stoppingDistance > tailgateDistance)
    System.out.println("Major wreck!");
    } // end main
    } // end class StoppingA
    Edited by: Ensanvoration on Feb 23, 2010 3:31 PM

    Encephalopathic wrote:
    Ensanvoration wrote:
    Thanks, but I already tried that exact thing and it didn't work either. It's ridiculousIf you don't show us how you tried it, then we can only guess why it's not working.
    ... but if you wait around long enough, I bet you'll see JosAH post a recursive solution! :)Where is JosAH. Is he on vacation? Since I've been back, I haven't seen him.
    Well, let's raise a bottle of Grolsch to him anyway. More for us.
    ¦ {Þ                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  • Need Help with JSP and Soap

    Trying to write a JSP page that pulls information from a Soap Call. Below is the JSP page and the Soap Code. Any Help would be great:
    The soap call needs to come back with a variable in the line: <td class="detail-item-value" colspan="2"><%= request.getobject %>
    The JSP Page:
    <%@page import="java.sql.DriverManager, java.sql.Connection, java.sql.ResultSet, java.sql.Statement"%>
    <nested:define id="recordId" property="detailId" />
    <%
    //String payorId = (String) recordId;
    String payorId = "1001850";
    Set objgetobject = Server.CreateObject("soapdemo.SoapServer")
    getobject = objgetobject.GetPayorByIdRequest(payorId)
    %>
    <table id="detailTable" class="detail-outer-table">
    <tr>
    <td colspan="4"
    class=
    "detail-inner-group-header" >
    <center>Party Attributes</center></td></tr>
    <tr>
    <td colspan="2" class="detail-item-prompt">Test Field</td>
    <td class="detail-item-value" colspan="2"><%= request.getobject %>
    </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Customer Name</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(stdName1)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">PO Box</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(poBox)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Address 1</td>
    <td class="detail-item-value"><nested:write property="detailValue(stdAddr1)" filter="false"/></td>
    <td class="detail-item-prompt">PO Box City</td>
    <td class="detail-item-value"><nested:write property="detailValue(poBoxCity)" filter="false"/></td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Address 2</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(stdAddr2)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">PO Box Region/State</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(poBoxState)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">City</td>
    <td class="detail-item-value"><nested:write property="detailValue(stdCity)" filter="false"/></td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Region State</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(stdState)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Party ID</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(entId)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Zip Code</td>
    <td class="detail-item-value"><nested:write property="detailValue(stdZipCode)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Last Published</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(lastPublished)" filter="false"/></td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Telephone</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(phone)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Last Changed By</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(lastChangeUserName)" filter="false"/></td>
    </tr>
    <tr>
    <td colspan="4"
    class=
    <nested:equal property="isSourceItem" value="false">"detail-first-group-header"</nested:equal>
    <nested:equal property="isSourceItem" value="true">"detail-inner-group-header"</nested:equal>
    <center>Reference Data</center></td></tr>
    <tr>
    <td colspan="2" class="detail-item-prompt" bgcolor="e9eef4"><center>Dun and Bradstreet</center></td>
    <td colspan="2"class="detail-item-prompt" bgcolor="e9eef4"><center>Verispan</center></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">D&B DUNS</td>
    <td class="detail-item-value"><nested:write property="detailValue(dnbDunsNumber)" filter="false"/></td>
    <td class="detail-item-prompt">SMG Business Type</td>
    <td class="detail-item-value"><nested:write property="detailValue(smgBusType)" filter="false"/></td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Trade Style</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(tradestyle)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">SMG ID</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(smgId)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Line Of Business</td>
    <td class="detail-item-value"><nested:write property="detailValue(lineOfBusiness)" filter="false"/></td>
    <td class="detail-item-prompt">HIN_ID</td>
    <td class="detail-item-value"><nested:write property="detailValue(hinId)" filter="false"/></td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Status Code</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(statusCode)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">DEA_ID</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(deaId)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Subsidiary Code</td>
    <td class="detail-item-value"><nested:write property="detailValue(subsidiaryCode)" filter="false"/></td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-value"> </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    <td BGcolor="e4f2f5" class="detail-item-value"> </td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Domestic Ultimate DUNS</td>
    <td class="detail-item-value"><nested:write property="detailValue(dnbDomUltimateDuns)" filter="false"/></td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Domestic Ultimate Name</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(domUltimateBusinessName)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-value"> </td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Global Ultimate DUNS</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(dnbGlobalUltimateDuns)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Global Ultimate Name</td>
    <td class="detail-item-value"><nested:write property="detailValue(globalUltimateBusinessName)" filter="false"/></td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-prompt"> </td>
    </tr>
    <tr><td colspan="4" class="detail-inner-group-header"><center>Database Details</center></td></tr>
    <tr><td class="detail-item-prompt">Created</td>
    <td class="detail-item-value"><nested:write property="detailValue(creationTimestamp)" filter="false"/></td>
    <td class="detail-item-prompt">Last Changed</td>
    <td class="detail-item-value"><nested:write property="detailValue(lastChangeTimestamp)" filter="false"/></td></tr>
    <!-- Future: display creation and last change username after editing is implemented -->
    <nested:equal property="isSourceItem" value="false">
    <tr><td class="detail-item-prompt">Purisma Composite Id</td>
    </nested:equal>
    <nested:equal property="isSourceItem" value="true">
    <tr><td class="detail-item-prompt">Purisma Id</td> </nested:equal>
    <td class="detail-item-value"><nested:write property="detailId" filter="false"/></td>
    <td class="detail-item-prompt"><nested:write property="detailSourceName" filter="false"/></td>
    <td class="detail-item-value"><nested:write property="detailExternalId" filter="false"/></td></tr>
    <!--
    <tr><td colspan="4" class="detail-inner-group-header"><center>Family Tree Information</center></td></tr>
    <tr><td class="detail-item-prompt">Linkage Last Changed</td>
    <td class="detail-item-value"><nested:write property="detailValue(linkageChangeTimestamp)" filter="false"/></td>
    <td class="detail-item-prompt">Linkage Last Edited</td>
    <td class="detail-item-value"><nested:write property="detailValue(linkageEditTimestamp)" filter="false"/></td>
    </tr>
    <tr><td class="detail-item-prompt">Linkage Edited by</td>
    <td class="detail-item-value"><nested:write property="detailValue(linkageEditUserName)" filter="false"/></td></tr>
    -->
    </table>
    SOAP CALL
    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:purisma-pcr:CUSTOMER">
    <soapenv:Header/>
    <soapenv:Body>
    <urn:GetPayorByIdRequest urn:registryId="?" urn:sourceStartIndex="0" urn:sourcePageSize="0">
    <!--Zero or more repetitions:-->
    <fieldName>?</fieldName>
    </urn:GetPayorByIdRequest>
    </soapenv:Body>
    </soapenv:Envelope>

    Trying to write a JSP page that pulls information from a Soap Call. Below is the JSP page and the Soap Code. Any Help would be great:
    The soap call needs to come back with a variable in the line: <td class="detail-item-value" colspan="2"><%= request.getobject %>
    The JSP Page:
    <%@page import="java.sql.DriverManager, java.sql.Connection, java.sql.ResultSet, java.sql.Statement"%>
    <nested:define id="recordId" property="detailId" />
    <%
    //String payorId = (String) recordId;
    String payorId = "1001850";
    Set objgetobject = Server.CreateObject("soapdemo.SoapServer")
    getobject = objgetobject.GetPayorByIdRequest(payorId)
    %>
    <table id="detailTable" class="detail-outer-table">
    <tr>
    <td colspan="4"
    class=
    "detail-inner-group-header" >
    <center>Party Attributes</center></td></tr>
    <tr>
    <td colspan="2" class="detail-item-prompt">Test Field</td>
    <td class="detail-item-value" colspan="2"><%= request.getobject %>
    </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Customer Name</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(stdName1)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">PO Box</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(poBox)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Address 1</td>
    <td class="detail-item-value"><nested:write property="detailValue(stdAddr1)" filter="false"/></td>
    <td class="detail-item-prompt">PO Box City</td>
    <td class="detail-item-value"><nested:write property="detailValue(poBoxCity)" filter="false"/></td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Address 2</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(stdAddr2)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">PO Box Region/State</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(poBoxState)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">City</td>
    <td class="detail-item-value"><nested:write property="detailValue(stdCity)" filter="false"/></td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Region State</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(stdState)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Party ID</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(entId)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Zip Code</td>
    <td class="detail-item-value"><nested:write property="detailValue(stdZipCode)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Last Published</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(lastPublished)" filter="false"/></td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Telephone</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(phone)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Last Changed By</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(lastChangeUserName)" filter="false"/></td>
    </tr>
    <tr>
    <td colspan="4"
    class=
    <nested:equal property="isSourceItem" value="false">"detail-first-group-header"</nested:equal>
    <nested:equal property="isSourceItem" value="true">"detail-inner-group-header"</nested:equal>
    <center>Reference Data</center></td></tr>
    <tr>
    <td colspan="2" class="detail-item-prompt" bgcolor="e9eef4"><center>Dun and Bradstreet</center></td>
    <td colspan="2"class="detail-item-prompt" bgcolor="e9eef4"><center>Verispan</center></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">D&B DUNS</td>
    <td class="detail-item-value"><nested:write property="detailValue(dnbDunsNumber)" filter="false"/></td>
    <td class="detail-item-prompt">SMG Business Type</td>
    <td class="detail-item-value"><nested:write property="detailValue(smgBusType)" filter="false"/></td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Trade Style</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(tradestyle)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">SMG ID</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(smgId)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Line Of Business</td>
    <td class="detail-item-value"><nested:write property="detailValue(lineOfBusiness)" filter="false"/></td>
    <td class="detail-item-prompt">HIN_ID</td>
    <td class="detail-item-value"><nested:write property="detailValue(hinId)" filter="false"/></td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Status Code</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(statusCode)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt">DEA_ID</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(deaId)" filter="false"/></td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Subsidiary Code</td>
    <td class="detail-item-value"><nested:write property="detailValue(subsidiaryCode)" filter="false"/></td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-value"> </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    <td BGcolor="e4f2f5" class="detail-item-value"> </td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Domestic Ultimate DUNS</td>
    <td class="detail-item-value"><nested:write property="detailValue(dnbDomUltimateDuns)" filter="false"/></td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Domestic Ultimate Name</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(domUltimateBusinessName)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-value"> </td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td BGcolor="e4f2f5" class="detail-item-prompt">Global Ultimate DUNS</td>
    <td BGcolor="e4f2f5" class="detail-item-value"><nested:write property="detailValue(dnbGlobalUltimateDuns)" filter="false"/></td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    <td BGcolor="e4f2f5" class="detail-item-prompt"> </td>
    </tr>
    <tr>
    <td class="detail-item-prompt">Global Ultimate Name</td>
    <td class="detail-item-value"><nested:write property="detailValue(globalUltimateBusinessName)" filter="false"/></td>
    <td class="detail-item-prompt"> </td>
    <td class="detail-item-prompt"> </td>
    </tr>
    <tr><td colspan="4" class="detail-inner-group-header"><center>Database Details</center></td></tr>
    <tr><td class="detail-item-prompt">Created</td>
    <td class="detail-item-value"><nested:write property="detailValue(creationTimestamp)" filter="false"/></td>
    <td class="detail-item-prompt">Last Changed</td>
    <td class="detail-item-value"><nested:write property="detailValue(lastChangeTimestamp)" filter="false"/></td></tr>
    <!-- Future: display creation and last change username after editing is implemented -->
    <nested:equal property="isSourceItem" value="false">
    <tr><td class="detail-item-prompt">Purisma Composite Id</td>
    </nested:equal>
    <nested:equal property="isSourceItem" value="true">
    <tr><td class="detail-item-prompt">Purisma Id</td> </nested:equal>
    <td class="detail-item-value"><nested:write property="detailId" filter="false"/></td>
    <td class="detail-item-prompt"><nested:write property="detailSourceName" filter="false"/></td>
    <td class="detail-item-value"><nested:write property="detailExternalId" filter="false"/></td></tr>
    <!--
    <tr><td colspan="4" class="detail-inner-group-header"><center>Family Tree Information</center></td></tr>
    <tr><td class="detail-item-prompt">Linkage Last Changed</td>
    <td class="detail-item-value"><nested:write property="detailValue(linkageChangeTimestamp)" filter="false"/></td>
    <td class="detail-item-prompt">Linkage Last Edited</td>
    <td class="detail-item-value"><nested:write property="detailValue(linkageEditTimestamp)" filter="false"/></td>
    </tr>
    <tr><td class="detail-item-prompt">Linkage Edited by</td>
    <td class="detail-item-value"><nested:write property="detailValue(linkageEditUserName)" filter="false"/></td></tr>
    -->
    </table>
    SOAP CALL
    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:purisma-pcr:CUSTOMER">
    <soapenv:Header/>
    <soapenv:Body>
    <urn:GetPayorByIdRequest urn:registryId="?" urn:sourceStartIndex="0" urn:sourcePageSize="0">
    <!--Zero or more repetitions:-->
    <fieldName>?</fieldName>
    </urn:GetPayorByIdRequest>
    </soapenv:Body>
    </soapenv:Envelope>

  • Need help with JSP - Session Bean scenario

    I have massive problems with a simple JSP <--> Statefull Session Bean scenario with Server Platform Edition 8.2 (build b06-fcs)
    What I do is generating a Collection in session bean returning it to JSP
    and giving the List back to Session Bean.
    A weird exception happens when giving the List back to Session Bean
    (see Exception details below)
    The same code runs without any trouble on Jboss Application Server 4.0.3
    Any help would be great!
    Please see code below
    Statefull Session Bean
    <code>
    package ejb;
    import data.Produkt;
    import java.util.ArrayList;
    import java.util.Collection;
    import java.util.Iterator;
    import javax.ejb.*;
    * This is the bean class for the WarenkorbBean enterprise bean.
    * Created 17.03.2006 09:53:25
    * @author Administrator
    public class WarenkorbBean implements SessionBean, WarenkorbRemoteBusiness, WarenkorbLocalBusiness {
    private SessionContext context;
    // <editor-fold defaultstate="collapsed" desc="EJB infrastructure methods. Click the + sign on the left to edit the code.">
    // TODO Add code to acquire and use other enterprise resources (DataSource, JMS, enterprise bean, Web services)
    // TODO Add business methods or web service operations
    * @see javax.ejb.SessionBean#setSessionContext(javax.ejb.SessionContext)
    public void setSessionContext(SessionContext aContext) {
    context = aContext;
    * @see javax.ejb.SessionBean#ejbActivate()
    public void ejbActivate() {
    * @see javax.ejb.SessionBean#ejbPassivate()
    public void ejbPassivate() {
    * @see javax.ejb.SessionBean#ejbRemove()
    public void ejbRemove() {
    // </editor-fold>
    * See section 7.10.3 of the EJB 2.0 specification
    * See section 7.11.3 of the EJB 2.1 specification
    public void ejbCreate() {
    // TODO implement ejbCreate if necessary, acquire resources
    // This method has access to the JNDI context so resource aquisition
    // spanning all methods can be performed here such as home interfaces
    // and data sources.
    // Add business logic below. (Right-click in editor and choose
    // "EJB Methods > Add Business Method" or "Web Service > Add Operation")
    public Collection erzeugeWarenkorb() {
    //TODO implement erzeugeWarenkorb
    ArrayList myList = new ArrayList();
    for (int i=0;i<10;i++)
    Produkt prod = new Produkt();
    prod.setID(i);
    prod.setName("Produkt"+i);
    myList.add(prod);
    return myList;
    public void leseWarenkorb(Collection Liste) {
    //TODO implement leseWarenkorb
    Iterator listIt = Liste.iterator();
    while(listIt.hasNext())
    Produkt p = (Produkt)listIt.next();
    System.out.println("Name des Produktes {0} "+p.getName());
    </code>
    <code>
    package data;
    import java.io.Serializable;
    * @author Administrator
    public class Produkt implements Serializable {
    private int ID;
    private String Name;
    /** Creates a new instance of Produkt */
    public Produkt() {
    public int getID() {
    return ID;
    public void setID(int ID) {
    this.ID = ID;
    public String getName() {
    return Name;
    public void setName(String Name) {
    this.Name = Name;
    </code>
    <code>
    <%@page contentType="text/html"%>
    <%@page pageEncoding="UTF-8"%>
    <%@page import="java.util.*"%>
    <%@page import="data.*"%>
    <%@page import="javax.naming.*"%>
    <%@page import="javax.rmi.PortableRemoteObject"%>
    <%@page import="ejb.*"%>
    <%--
    The taglib directive below imports the JSTL library. If you uncomment it,
    you must also add the JSTL library to the project. The Add Library... action
    on Libraries node in Projects view can be used to add the JSTL 1.1 library.
    --%>
    <%--
    <%@taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c"%>
    --%>
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <title>JSP Page</title>
    </head>
    <body>
    <h1>Online Shop Warenkorb Test</h1>
    <%--
    This example uses JSTL, uncomment the taglib directive above.
    To test, display the page like this: index.jsp?sayHello=true&name=Murphy
    --%>
    <%--
    <c:if test="${param.sayHello}">
    <!-- Let's welcome the user ${param.name} -->
    Hello ${param.name}!
    </c:if>
    --%>
    <%
    Context myEnv = null;
    WarenkorbRemote wr = null;
    // Context initialisation
    try
    myEnv = (Context)new javax.naming.InitialContext();
    /*Hashtable env = new Hashtable();
    env.put(Context.INITIAL_CONTEXT_FACTORY,"org.jnp.interfaces.NamingContextFactory");
    //env.put(Context.PROVIDER_URL, "jnp://wotan.activenet.at:1099");
    env.put(Context.PROVIDER_URL, "jnp://localhost:1099");
    env.put(Context.URL_PKG_PREFIXES, "org.jboss.naming:org.jnp.interfaces");
    myEnv = new InitialContext(env);*/
    catch (Exception ex)
    System.err.println("Fehler beim initialisieren des Context: " + ex.getMessage());
    // now lets work
    try
    Object ref = myEnv.lookup("ejb/WarenkorbBean");
    //Object ref = myEnv.lookup("WarenkorbBean");
    WarenkorbRemoteHome warenkorbrhome = (WarenkorbRemoteHome)
    PortableRemoteObject.narrow(ref, WarenkorbRemoteHome.class);
    wr = warenkorbrhome.create();
    ArrayList myList = (ArrayList)wr.erzeugeWarenkorb();
    Iterator it = myList.iterator();
    while(it.hasNext())
    Produkt p = (Produkt)it.next();
    %>
    ProduktID: <%=p.getID()%><br></br>Produktbezeichnung:
    <%=p.getName()%><br></br><%
    wr.leseWarenkorb(myList);
    catch(Exception ex)
    %><p style="color:red">Onlineshop nicht erreichbar</p><%=ex.getMessage()%>
    <% }
    %>
    </body>
    </html>
    </code>
    the exception
    CORBA MARSHAL 1398079745 Maybe; nested exception is: org.omg.CORBA.MARSHAL: ----------BEGIN server-side stack trace---------- org.omg.CORBA.MARSHAL: vmcid: SUN minor code: 257 completed: Maybe at com.sun.corba.ee.impl.logging.ORBUtilSystemException.couldNotFindClass(ORBUtilSystemException.java:8101) at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.read_value(CDRInputStream_1_0.java:1013) at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.read_value(CDRInputStream_1_0.java:879) at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.read_abstract_interface(CDRInputStream_1_0.java:873) at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.read_abstract_interface(CDRInputStream_1_0.java:863) at com.sun.corba.ee.impl.encoding.CDRInputStream.read_abstract_interface(CDRInputStream.java:275) at com.sun.corba.ee.impl.io.IIOPInputStream.readObjectDelegate(IIOPInputStream.java:363) at com.sun.corba.ee.impl.io.IIOPInputStream.readObjectOverride(IIOPInputStream.java:526) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:333) at java.util.ArrayList.readObject(ArrayList.java:591) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:585) at com.sun.corba.ee.impl.io.IIOPInputStream.invokeObjectReader(IIOPInputStream.java:1694) at com.sun.corba.ee.impl.io.IIOPInputStream.inputObject(IIOPInputStream.java:1212) at com.sun.corba.ee.impl.io.IIOPInputStream.simpleReadObject(IIOPInputStream.java:400) at com.sun.corba.ee.impl.io.ValueHandlerImpl.readValueInternal(ValueHandlerImpl.java:330) at com.sun.corba.ee.impl.io.ValueHandlerImpl.readValue(ValueHandlerImpl.java:296) at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.read_value(CDRInputStream_1_0.java:1034) at com.sun.corba.ee.impl.encoding.CDRInputStream.read_value(CDRInputStream.java:259) at com.sun.corba.ee.impl.presentation.rmi.DynamicMethodMarshallerImpl$14.read(DynamicMethodMarshallerImpl.java:333) at com.sun.corba.ee.impl.presentation.rmi.DynamicMethodMarshallerImpl.readArguments(DynamicMethodMarshallerImpl.java:393) at com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie._invoke(ReflectiveTie.java:121) at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.dispatchToServant(CorbaServerRequestDispatcherImpl.java:648) at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.dispatch(CorbaServerRequestDispatcherImpl.java:192) at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleRequestRequest(CorbaMessageMediatorImpl.java:1709) at com.sun.corba.ee.impl.protocol.SharedCDRClientRequestDispatcherImpl.marshalingComplete(SharedCDRClientRequestDispatcherImpl.java:155) at com.sun.corba.ee.impl.protocol.CorbaClientDelegateImpl.invoke(CorbaClientDelegateImpl.java:184) at com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.invoke(StubInvocationHandlerImpl.java:129) at com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.invoke(StubInvocationHandlerImpl.java:150) at com.sun.corba.ee.impl.presentation.rmi.bcel.BCELStubBase.invoke(Unknown Source) at ejb._WarenkorbRemote_DynamicStub.leseWarenkorb(_WarenkorbRemote_DynamicStub.java) at org.apache.jsp.index_jsp._jspService(index_jsp.java:122) at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:105) at javax.servlet.http.HttpServlet.service(HttpServlet.java:860) at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:336) at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:297) at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:247) at javax.servlet.http.HttpServlet.service(HttpServlet.java:860) at sun.reflect.GeneratedMethodAccessor96.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:585) at org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:249) at java.security.AccessController.doPrivileged(Native Method) at javax.security.auth.Subject.doAsPrivileged(Subject.java:517) at org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:282) at org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:165) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:257) at org.apache.catalina.core.ApplicationFilterChain.access$000(ApplicationFilterChain.java:55) at org.apache.catalina.core.ApplicationFilterChain$1.run(ApplicationFilterChain.java:161) at java.security.AccessController.doPrivileged(Native Method) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:263) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:551) at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:225) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:173) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:551) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:551) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:132) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:551) at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:933) at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:189) at com.sun.enterprise.web.connector.grizzly.ProcessorTask.doProcess(ProcessorTask.java:604) at com.sun.enterprise.web.connector.grizzly.ProcessorTask.process(ProcessorTask.java:475) at com.sun.enterprise.web.connector.grizzly.ReadTask.executeProcessorTask(ReadTask.java:371) at com.sun.enterprise.web.connector.grizzly.ReadTask.doTask(ReadTask.java:264) at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:281) at com.sun.enterprise.web.connector.grizzly.WorkerThread.run(WorkerThread.java:83) Caused by: java.lang.ClassNotFoundException ... 69 more ----------END server-side stack trace---------- vmcid: SUN minor code: 257 completed: Maybe

    Hi,
    I have found a way out by passing the reference of my EJB in the HttpSession object and using it inside the javabean..

  • Need Help With Military DTD Using FrameMaker 8

    Fellow Forum Members,
    I hope someone out there with experience in using Department of Defense DTDs with FrameMaker can contribute to this thread.
    Attached is the MIL STD 400051-2 DTD that needs to play with FrameMaker. Does anyone out there know where I could find FrameMaker templates already setup that comply and play with the MIL STD 400051-2 DTD standard? If the Department of Defense is freely distributing the MIL STD 400051-2 DTD, shouldn't somebody in the Department of Defense also be providing MIL STD 400051-2 FrameMaker Templates for free that are already setup?  I would greatly appreciate if anyone out there could provide an online source where I could download MIL STD 400051-2 FrameMaker templates.
    Lastly, can anyone out there clarify what the purpose of the entities are inside the "Charant" and "Boilerplate" folders?  The Department of Defense does not provide a readme file that define what the "Charant" and "Boilerplate" folders are about.
    Any info will be greatly appreciated. Thanks.

    I'll answer the specifics that I know about your questions, but please look at the post from Srini for additional info:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=yA full export will move as much information (metadata/data) as possible. In order to do a full export/import, you need to do this from a
    privileged account. A privileged account is one with EXP_FULL_DATABASE for export and IMP_FULL_DATABASE for import.
    2) Will there be any data corruption while export.The data in the objects that you are exporting is being read, nothing is written to user data. I'm not sure what this is available in 8.0.6,
    but if you need a consistent export, look to see if consistent=y is available in 8.0.6. All this means is that the dump file created will have
    consistent data in it.
    3) Is export/import the only method of migration/upgradation.If you are changing hardware, the only supported way from 8.0 to 10.2.0.4, that I know of, is using exp/imp.
    Hope this helps.
    Dean

  • Need help with database migration using export/import

    Hi,
    I am planning to do a database migration from 8.0.6 to 10.2.0.4. I am using export/import. Please answer some of my queries:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=y
    2) Will there be any data corruption while export.
    3) Is export/import the only method of migration/upgradation.
    Please help
    Thanks.

    I'll answer the specifics that I know about your questions, but please look at the post from Srini for additional info:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=yA full export will move as much information (metadata/data) as possible. In order to do a full export/import, you need to do this from a
    privileged account. A privileged account is one with EXP_FULL_DATABASE for export and IMP_FULL_DATABASE for import.
    2) Will there be any data corruption while export.The data in the objects that you are exporting is being read, nothing is written to user data. I'm not sure what this is available in 8.0.6,
    but if you need a consistent export, look to see if consistent=y is available in 8.0.6. All this means is that the dump file created will have
    consistent data in it.
    3) Is export/import the only method of migration/upgradation.If you are changing hardware, the only supported way from 8.0 to 10.2.0.4, that I know of, is using exp/imp.
    Hope this helps.
    Dean

  • Need help with reading XML using File Adapter

    I have created a simple BPEL process that uses a file adapter to read files containing XML messages of a simple xsd schema. But when reading the xml, I get the following error message:
    [2010/03/01 23:43:13] Invalid data: The value for variable "Receive_1_Read_InputVariable", part "revision-report" does not match the schema definition for this part.The invalid xml document is shown below: More...
    [2010/03/01 23:43:13] "{http://schemas.oracle.com/bpel/extension}invalidVariables" has been thrown. less
    -<invalidVariables xmlns="http://schemas.oracle.com/bpel/extension">
    -<part name="code">
    <code>
    9710
    </code>
    </part>
    -<part name="summary">
    <summary>
    Invalid xml document.
    According to the xml schemas, the xml document is invalid. The reason is: Error::cvc-complex-type.4: Attribute 'doc' must appear on element 'revision-report'.
    Error::cvc-complex-type.4: Attribute 'model' must appear on element 'revision-report'.
    Error::cvc-complex-type.4: Attribute 'pubdate' must appear on element 'revision-report'.
    Error::cvc-complex-type.2.4.b: The content of element 'revision-report' is not complete. One of '{"http://xmlns.oracle.com/xmlfile":alternategroup}' is expected.
    Please make sure that the xml document is valid against your schemas.
    </summary>
    </part>
    </invalidVariables>
    It seems that there is some issue with the namespace, but even after trying out various combinations, I am not able to resolve this.
    Here the message schema (xsd):
    <?xml version="1.0" encoding="UTF-8" ?>
    <xs:schema elementFormDefault="qualified"
    targetNamespace="http://xmlns.oracle.com/xmlfile"
    xmlns:tns="http://xmlns.oracle.com/xmlfile"
    xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:element name="revision-report">
    <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
    <xs:element name="alternategroup">
    <xs:complexType>
    <xs:attribute name="name" use="required" type="xs:string"/>
    <xs:attribute name="Desc" use="required" type="xs:string"/>
    </xs:complexType>
    </xs:element>
    </xs:sequence>
    <xs:attribute name="doc" use="required" type="xs:string"/>
    <xs:attribute name="model" use="required" type="xs:string"/>
    <xs:attribute name="pubdate" use="required" type="xs:string"/>
    </xs:complexType>
    </xs:element>
    </xs:schema>
    And here is the xml file to be read by the file adapter:
    <?xml version="1.0" encoding="UTF-8" ?>
    <revision-report doc="doc2" model="model4" pubdate="pubdate5">
    <alternategroup Name="ABC" Desc="ABC-Desc">
    </alternategroup>
    <alternategroup Name="DEF" Desc="DEF-Desc">
    </alternategroup>
    <alternategroup Name="GHI" Desc="GHI-Desc">
    </alternategroup>
    </revision-report>
    Appreciate any help.
    Thanks in advance for your attention.
    Jay

    Thanks for your response.
    I am not sure if there is any easier way, but I tried out the following tool available on the net to check an xml against a xsd:
    http://tools.decisionsoft.com/schemaValidate/
    There were a few issues, that I corrected and finally had a xsd and xml that were matching and valid. I tried this out in my file reading BPEL process, but the error still remained the same!
    Here is my updated/simplified xsd and xml:
    <?xml version="1.0" encoding="UTF-8" ?>
    <xs:schema targetNamespace="http://xmlns.oracle.com/xmlfile"
    xmlns:tns="http://xmlns.oracle.com/xmlfile"
    xmlns:xs="http://www.w3.org/2001/XMLSchema"
    xmlns="http://xmlns.oracle.com/xmlfile">
    <xs:element name="revision-report">
    <xs:complexType>
    <xs:sequence>
    <xs:element maxOccurs="unbounded" ref="alternategroup"/>
    </xs:sequence>
    <xs:attribute name="doc" use="required" type="xs:string"/>
    <xs:attribute name="model" use="required" type="xs:string"/>
    <xs:attribute name="pubdate" use="required" type="xs:string"/>
    </xs:complexType>
    </xs:element>
    <xs:element name="alternategroup">
    <xs:complexType>
    <xs:attribute name="Name" use="required" type="xs:string"/>
    <xs:attribute name="Desc" use="required" type="xs:string"/>
    </xs:complexType>
    </xs:element>
    </xs:schema>
    <?xml version="1.0" encoding="UTF-8" ?>
    <revision-report doc="doc2" model="model4" pubdate="pubdate5" xmlns="http://xmlns.oracle.com/xmlfile">
    <alternategroup Name="ABC" Desc="ABC-Desc"/>
    <alternategroup Name="DEF" Desc="DEF-Desc"/>
    <alternategroup Name="GHI" Desc="GHI-Desc"/>
    </revision-report>
    I even tried the option that is available in JDeveloper to generate a sample xml from a xsd (when in the context of a Transformation activity). The xml generated by this also seems exactly like the one above.
    So, I am not able to figure out why my BPEL process errors out with the message Invalid xml document.

  • I am Stuck! Need Help With Multicast Streaming Using VLC Player

    I have a Multicast network topology shown below
    and my configs
    HUB ROUTER
    no ip domain lookup
    ip domain name primestarhotel.com
    ip multicast-routing
    interface Loopback0
    ip address 5.5.5.5 255.255.255.255
    ip pim sparse-dense-mode
    interface FastEthernet0/0
    ip address 200.0.0.2 255.255.255.240
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.65
    description "Server Vlan"
    encapsulation dot1Q 65
    ip address 10.1.65.1 255.255.255.0
    ip pim sparse-dense-mode
    ip virtual-reassembly
    router ospf 200
    log-adjacency-changes
    network 5.5.5.5 0.0.0.0 area 0
    network 10.1.65.0 0.0.0.255 area 0
    network 200.0.0.0 0.0.0.15 area 0
    ip route 200.1.1.0 255.255.255.252 200.0.0.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    no ip http server
    no ip http secure-server
    ip pim send-rp-announce Loopback0 scope 6
    ip pim send-rp-discovery Loopback0 scope 6
    ISP ROUTER
    interface FastEthernet1/0
    interface FastEthernet1/1
    no switchport
    ip address 200.0.0.1 255.255.255.240
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/2
    no switchport
    ip address 200.1.1.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/3
    no switchport
    ip address 200.2.2.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    router ospf 200
    log-adjacency-changes
    network 200.0.0.0 0.0.0.15 area 0
    network 200.1.1.0 0.0.0.3 area 0
    network 200.2.2.0 0.0.0.3 area 0
    SPOKE 1 Router
    interface FastEthernet0/0
    ip address 200.1.1.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    no ip address
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.12
    description "Workstation pc"
    encapsulation dot1Q 12
    ip address 10.1.12.1 255.255.255.0
    ip pim sparse-dense-mode
    router ospf 200
    log-adjacency-changes
    network 10.1.12.0 0.0.0.255 area 0
    network 200.1.1.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.1.1.1
    SPOKE 2
    interface FastEthernet0/0
    ip address 200.2.2.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    ip address 10.2.22.1 255.255.255.0
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    router ospf 200
    log-adjacency-changes
    network 10.2.22.0 0.0.0.255 area 0
    network 200.2.2.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.2.2.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    I have implemented multicast on the network in a hub and spoke topology. i have set up ospf routing protocol and broadcast all network and can successfully ping.
    I am currently using VLC player as my media streaming server and client. i have set up rtp streaming from the HUb router using multicast ip 224.2.2.2 and unable to broadcast the multicast traffic across the spokes 1 and 2 PC's
    I have never used vlc player  never set up multicast network before and i am struggling with this and need help.
    these are my router configs below
    http://dl.dropbox.com/u/20145606/ip%20video%20config.txt
    Message was edited by: Louis Ojuwu

    I have edited the message and the configs and topology are visible above now. instead of the links i provided

  • Need help with select that month range with flexible first date

    Hello everyone,
    I am trying to create a selection of month range (will be in a WITH clause) for a report to display monthly data. But the first month start date can be any date. (Not necessarily the first date of the month)
    Examples:
    Report input parameters:
    Start Date: 08/10/12
    End Month: Dec 2012
    I was trying to build a with select that will list
    Month_Start, Month_End
    08/10/12, 31/10/12
    01/11/12, 30/11/12
    01/12/12, 31/12/12
    OR
    Month_Start, Next_Month
    08/10/12, 01/11/12
    01/11/12, 01/12/12
    01/12/12, 01/01/13
    End month is optional, so if no value the select will list only
    08/10/12, 01/11/12
    Oracle Database Details is
    Oracle Database 11g Enterprise Edition Release 11.1.0.7.0 - 64bit Production
    PL/SQL Release 11.1.0.7.0 - Production
    My code so far is
    VARIABLE  P50_START_DATE  VARCHAR2 (10)
    VARIABLE  P50_END_MONTH    VARCHAR2 (10)
    EXEC  :P50_START_DATE  := '10/10/2012';
    EXEC  :P50_END_MONTH   := '31/12/2012';
      SELECT  to_char(:P50_START_DATE) AS start_date
            ,  ADD_MONTHS( TRUNC(to_date(:P50_START_DATE,'DD/MM/YYYY'),'MONTH'), 1) AS next_month
      FROM dual
      union
       SELECT to_char(ADD_MONTHS( TRUNC(to_date(:P50_START_DATE,'DD/MM/YYYY'),'MONTH'), ROWNUM-1)) AS start_date
       ,      ADD_MONTHS( TRUNC(to_date(:P50_START_DATE,'DD/MM/YYYY'),'MONTH'), ROWNUM) AS next_month
       --, rownum
       from all_objects
       where
       rownum <= months_between(to_date(NVL(:P50_END_MONTH, :P50_START_DATE),'DD/MM/YYYY'), add_months(to_date(:P50_START_DATE,'DD/MM/YYYY'), -1))
       and rownum > 1If I put comment – on line and rownum > 1, as
    -- and rownum > 1The result I get is
    START_DATE                     NEXT_MONTH               
    01/10/12                       01/10/12                 
    01/11/12                       01/11/12                 
    01/12/12                       01/01/13                 
    10/10/2012                     01/11/12    But when I try to remove the duplicate period (of the first month) out by restrict rownum, it do not return any rows for the second select at all. The result I get is:
    START_DATE                     NEXT_MONTH               
    10/10/2012                     01/11/12    Can anyone advise what wrong with the select statement ?
    Thanks a lot in advance,
    Ann

    Hi,
    Here's one way:
    WITH   params      AS
         SELECT     TO_DATE (:p50_start_date, 'DD/MM/YYYY')     AS start_date
         ,     TO_DATE (:p50_end_month,  'DD/MM/YYYY')     AS end_date
         FROM     dual
    SELECT     GREATEST ( start_date
               , ADD_MONTHS ( TRUNC (start_date, 'MONTH')
                            , LEVEL - 1
              )               AS month_start
    ,     LEAST     ( end_date
              , ADD_MONTHS ( TRUNC (start_date, 'MONTH')
                          , LEVEL
                        ) - 1
              )               AS month_end
    FROM    params
    CONNECT BY     LEVEL     <= 1 + MONTHS_BETWEEN ( end_date
                                      , TRUNC (start_date, 'MONTH')
    ;:p50_end_month doesn't have to be the last day of the month; any day will work.
    If you want to generate a Counter Table containing the integers 1 througn x in SQL, you could say
    SELECT  ROWNUM  AS n
    FROM    all_objects
    WHERE   ROWNUM  <= x
    ;but, starting in Oracle 9.1, it's much faster to say
    SELECT  LEVEL   AS n
    FROM    dual    -- or any table containing exactly 1 row
    CONNECT BY  LEVEL <= x
    ;Also, x can be greater than the number of rows in all_objects.

  • I need help with motion control. I am programming in Visual Basic. I will need help with what parts I need to purchase from NI, along with help on the code.

    I am using a Papst servo motor and I need to know where to start and what to purchase to get this motor to spin. I am using visual basic and in my program I calculate the direction and RPM's needed from the motor. It will spin anywhere from 1 to 10000 RPM's. It seems rather easy, but I have no idea on how to spin the motor at the specific RPM, and stop it with a command stop in the program. Please help.

    We really should know a little more about your intended uses for this system, but assuming you want to do relatively simple (or even not so simple!) motion, you'll need a few components...
    A motion controller, such as the PCI-7342, can take your VB commands and turn them into the commands needed to "run" the motor. Next you'll need a drive, such as the MID-7342. This includes the servo amplifier that actually powers the motor. It also has connections to "pass through" the encoder signals from the motor back to the motion controller.
    The above-named pieces assume one or two axes of motion. You'll also need a cable to connect the two (can't remember the model right now). You can use MAX to configure the motion controller, and there are just a few VB calls you
    'll need to make using NI-Motion functions to define the motion and get it going.
    Hope this helps!

  • Need to change the directory using the java program

    hi,
    can anyone give me the code to change the directory in the java program by using the system command.
    as in C where we use the system call system("cd");
    the same way how to do that in java. please help me with that!!!

    Please search the forums for "runtime.exec", there are dozens of examples posted.
    Although this may not do you any good, since changing the os's directory is not likely to change anything you're using in Java. What are you trying to do?

Maybe you are looking for

  • Getting COM Component error while opening SSIS Script task.

    Hi All, While click on EDIT SCRIPT Button in script task it's not opening the script editing window. Getting below error message: "Error HRESULT E_FAIL has been returned from a call to a COM component. (EnvDTE)" We have added ADODB reference in scrip

  • Bug in new ThinkPad Switchable Graphics Driver - 8.752.4-101022a-107489C

    After installing Lenovo's recent Wind 7 switchable graphics driver update v 8.752.4-101022a-107489C (Link) , an error dialogue appears upon bootup or when the Catalyst Control Center ("CCC") application is run.  The error dialogue box says: "Could no

  • Retrieve iweb site from godaddy

    I had to do a clean install on my mac pro - so could not alter my iweb site which is hosted on godaddy, using fetch I retrieved the all web site files in one folder, but cannot seem to get iweb to run them. Is there a special place that I should put

  • Purchase Order from Material Master Price

    Hi All, Can I customise the system in such a way without any development in which I want that while creating PO the system should take the Price from Material Master if no Info record is maintained. Thanks, Lekhram

  • IMAP server times out, Why?

    For 6 days now I have been having a problem acesssing my sites and email accounts. Finally the hosting company has found that it is the number of email accounts (49) trying to access the IMAP mail server at the same time? I have disable automatic "ch


HashFlare