[SOLVED] l2tp-ipsec-vpn-daemon from AUR fails to build

Please let me know if there are other details that require posting:-
==> Starting build()...
/usr/bin/qmake -o qttmp-Release.mk -after "OBJECTS_DIR=build/Release" "DESTDIR=dist/Release" nbproject/qt-Release.pro
mv -f qttmp-Release.mk nbproject/qt-Release.mk
make -f nbproject/qt-Release.mk dist/Release/L2tpIPsecVpnControlDaemon
make[1]: Entering directory '/tmp/yaourt-tmp-nimda/aur-l2tp-ipsec-vpn-daemon/src/l2tp-ipsec-vpn-daemon'
g++ -c -pipe -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/lib/qt/mkspecs/linux-g++ -Inbproject -isystem /usr/include/qt -isystem /usr/include/qt/QtNetwork -isystem /usr/include/qt/QtCore -Isrc/generated -I. -o build/Release/main.o src/main.cpp
g++ -c -pipe -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/lib/qt/mkspecs/linux-g++ -Inbproject -isystem /usr/include/qt -isystem /usr/include/qt/QtNetwork -isystem /usr/include/qt/QtCore -Isrc/generated -I. -o build/Release/VpnClientConnection.o src/VpnClientConnection.cpp
src/VpnClientConnection.cpp: In member function 'void VpnClientConnection::readyRead()':
src/VpnClientConnection.cpp:133:99: error: 'class QString' has no member named 'toAscii'
::syslog(LOG_DEBUG|LOG_DAEMON, "Executing command %s", m_strActiveCommand.toAscii().constData());
^
src/VpnClientConnection.cpp:140:75: error: 'class QString' has no member named 'toAscii'
if (COMMANDS[iCommand].pPipe->write(strCommand.toAscii().constData()) == strCommand.length())
^
src/VpnClientConnection.cpp:159:63: error: 'class QString' has no member named 'toAscii'
if (::mkfifo(strCommandParts[1].toAscii().constData(), DEFFILEMODE) == 0)
^
src/VpnClientConnection.cpp:161:84: error: 'class QString' has no member named 'toAscii'
const int iChmodResult(::chmod(strCommandParts[1].toAscii().constData(), DEFFILEMODE));
^
src/VpnClientConnection.cpp:168:87: error: 'class QString' has no member named 'toAscii'
const int iChownResult(::chown(strCommandParts[1].toAscii().constData(), pPwdInfo->pw_uid, pPwdInfo->pw_gid));
^
src/VpnClientConnection.cpp:193:77: error: 'const class QString' has no member named 'toAscii'
if (COMMANDS[iCommand].pPipe->write(str.toAscii().constData()) != str.length())
^
src/VpnClientConnection.cpp: In member function 'void VpnClientConnection::onCommandError(QProcess::ProcessError)':
src/VpnClientConnection.cpp:250:96: error: 'class QString' has no member named 'toAscii'
::syslog(LOG_DEBUG|LOG_DAEMON, "Command %s finished with error code %d", m_strActiveCommand.toAscii().constData(), ERR_COMMAND_FAILED_TO_START + iError);
^
src/VpnClientConnection.cpp: In member function 'void VpnClientConnection::onCommandFinished(int)':
src/VpnClientConnection.cpp:257:95: error: 'class QString' has no member named 'toAscii'
::syslog(LOG_DEBUG|LOG_DAEMON, "Command %s finished with exit code %d", m_strActiveCommand.toAscii().constData(), iExitCode);
^
src/VpnClientConnection.cpp: In member function 'bool VpnClientConnection::send(VpnClientConnection::ResponseType, VpnClientConnection::ResponseResult, const QString&)':
src/VpnClientConnection.cpp:268:118: error: 'const class QString' has no member named 'toAscii'
m_pSocket->write((QString::number(responseType) + " " + QString::number(resultCode) + " " + strCommand + '\n').toAscii().constData());
^
src/VpnClientConnection.cpp: In member function 'bool VpnClientConnection::send(VpnClientConnection::ResponseType, VpnClientConnection::ResponseInformation)':
src/VpnClientConnection.cpp:281:108: error: 'const class QString' has no member named 'toAscii'
m_pSocket->write((QString::number(responseType) + " " + QString::number(responseInformation) + '\n').toAscii().constData());
^
src/VpnClientConnection.cpp: In member function 'bool VpnClientConnection::send(VpnClientConnection::ResponseType, const QString&)':
src/VpnClientConnection.cpp:294:78: error: 'const class QString' has no member named 'toAscii'
m_pSocket->write((QString::number(responseType) + " " + strOutputline).toAscii().constData());
^
nbproject/qt-Release.mk:319: recipe for target 'build/Release/VpnClientConnection.o' failed
make[1]: *** [build/Release/VpnClientConnection.o] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-nimda/aur-l2tp-ipsec-vpn-daemon/src/l2tp-ipsec-vpn-daemon'
Makefile:62: recipe for target 'build' failed
make: *** [build] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build l2tp-ipsec-vpn-daemon.
Last edited by n1md4 (2014-06-06 09:47:25)

Have you tried 0.9.9-2 from the comments: https://aur.archlinux.org/packages/l2tp … pn-daemon/ ?

Similar Messages

  • [SOLVED] Surf-hg and tabbed-hg from aur fail to build

    Hi,
    I'm trying to install surf-hg and tabbed-hg from aur and when I makepkg -i this happens:
    ==> ERROR: A failure occurred in build().
    Aborting...
    I've tried to apply this patch to surf's config.mk but it fails anyway.
    diff -paur surf/config.mk surf.new/config.mk
    --- surf/config.mk 2012-01-29 11:46:00.851597838 +0100
    +++ surf.new/config.mk 2012-01-29 11:46:36.633503895 +0100
    @@ -15,7 +15,7 @@ GTKLIB = `pkg-config --libs gtk+-2.0 web
    # includes and libs
    INCS = -I. -I/usr/include -I${X11INC} ${GTKINC}
    -LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${GTKLIB} -lgthread-2.0
    +LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${GTKLIB} -lgthread-2.0 -ljavascriptcoregtk-1.0
    # flags
    CPPFLAGS = -DVERSION=\"${VERSION}\"
    Can anyone help me please?
    Last edited by whooper (2012-03-01 21:42:10)

    Yes they both fail to build, manually or with packer.
    I deleted the src directory but it still fails.
    packer -S surf-hg
    Aur Targets (1): surf-hg
    Proceed with installation? [Y/n] y
    Edit surf-hg PKGBUILD with $EDITOR? [Y/n] n
    ==> Determining latest hg revision...
    pulling from http://hg.suckless.org/surf
    searching for changes
    no changes found
    -> Version found: 238
    ==> Making package: surf-hg 238-1 (Thu Mar 1 00:27:47 WET 2012)
    ==> Checking runtime dependencies...
    ==> Checking buildtime dependencies...
    ==> Retrieving Sources...
    ==> Extracting Sources...
    ==> Removing existing pkg/ directory...
    ==> Entering fakeroot environment...
    ==> Starting build()...
    cleaning
    pulling from http://hg.suckless.org/surf
    searching for changes
    no changes found
    ==> ERROR: A failure occurred in build().
    Aborting...
    The build failed.

  • Ruby-audio from AUR fails to build [SOLVED]

    I'm attempting to install ruby-audio from AUR.  Got the PKGBUILD file.  Running makepkg results in a complaint about options for an install directory.   I'm not expert enough at the ruby ecosystem and gem to see any obvious problem.  What is the fix? 
    => makepkg
    ==> Making package: ruby-audio 1.6.1-1 (Mon Jun 16 09:51:10 PDT 2014)
    ==> Checking runtime dependencies...
    ==> Checking buildtime dependencies...
    ==> Retrieving sources...
      -> Found ruby-audio-1.6.1.gem
    ==> Validating source files with md5sums...
        ruby-audio-1.6.1.gem ... Passed
    ==> Extracting sources...
    ==> Removing existing pkg/ directory...
    ==> Entering fakeroot environment...
    ==> Starting package()...
    ERROR:  Use --install-dir or --user-install but not both
    ==> ERROR: A failure occurred in package().
        Aborting...
    Apparently the error is in the package() routine in PKGBUILD:
    package() {
      cd "$srcdir"
      # _gemdir is defined inside package() because if ruby[gems] is not installed on
      # the system, makepkg will exit with an error when sourcing the PKGBUILD.
      local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
      gem install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" \
        "$_gemname-$pkgver.gem"
    A search here in the Arch forums turned up nothing.
    Last edited by darenw (2014-06-19 03:43:00)

    Tell me if this works for you:
    # Maintainer: Josh Klar <[email protected]>
    # Contributor: Joel Almeida <aullidolunar at gmail dot c0m>
    pkgname=ruby-audio
    pkgver=1.6.1
    pkgrel=2
    pkgdesc="Wrapper around libsndfile to provide simplified sound reading and writing support for Ruby"
    arch=("any")
    url="http://rubygems.org/gems/ruby-audio"
    license=('GPL')
    depends=("ruby" "libsndfile")
    source=("https://rubygems.org/downloads/$pkgname-$pkgver.gem")
    noextract=('$pkgname-$pkgver.gem')
    md5sums=('d4f5cea4c14190ca67231a0349b6e141')
    package() {
    cd "$srcdir"
    local _gemdir="$(ruby -e'puts Gem.default_dir')"
    gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $pkgname-$pkgver.gem
    rm "$pkgdir/$_gemdir/cache/$pkgname-$pkgver.gem"
    install -Dm644 "$pkgdir$_gemdir/gems/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/MIT-LICENSE"
    build() {
    cd "$srcdir"
    Last edited by Joel (2014-06-19 01:22:00)

  • DarkRadiant from AUR fails to build

    Hello,
    I am trying to install DarkRadiant (Doom 3 and Dark Mod level editor) from AUR using yaourt, but all I get is this:
    darkradiant 1.1.0-1 : Open-source fork of GtkRadiant: a level editor for Doom 3 and The Dark Mod
    ( Unsupported package: Potentally dangerous ! )
    ==> Edit the PKGBUILD (highly recommended for security reasons) ? [Y/n]("A" to abort)
    ==> ----------------------------------------------
    ==>n
    ==> darkradiant dependencies:
    - boost (already installed)
    - freealut (already installed)
    - glew (already installed)
    - gtkglext (already installed)
    - gtksourceview2 (already installed)
    - openal (already installed)
    - python (already installed)
    - svn (package that provides svn already installed)
    ==> Continue the building of darkradiant ? [Y/n]
    ==> ----------------------------------------------
    ==>
    ==> Install or build missing dependencies for darkradiant:
    ==> Building and installing package
    ==> darkradiant dependencies:
    - boost (already installed)
    - freealut (already installed)
    - glew (already installed)
    - gtkglext (already installed)
    - gtksourceview2 (already installed)
    - openal (already installed)
    - python (already installed)
    - svn (package that provides svn already installed)
    ==> Making package: darkradiant 1.1.0-1 x86_64 (Mon Feb 22 16:48:50 EET 2010)
    ==> Checking Runtime Dependencies...
    ==> Checking Buildtime Dependencies...
    ==> Retrieving Sources...
    ==> Extracting Sources...
    ==> Removing existing pkg/ directory...
    ==> Entering fakeroot environment...
    ==> Starting build()...
    ==> Retrieving sources via svn for darkradiant version 1.1.0...
    -> Done
    ==> Validating sources from svn: if building fails here try to
    ==> delete the directory 'sources' and try again.
    ==> If it continues to fails the sources are changed and
    ==> the package needs to be updated.
    ==> ERROR: Build Failed.
    Aborting...
    Error: Makepkg was unable to build darkradiant package.
    I have tried to delete sources folder but it did not help. Any ideas?

    Seems MD5Sums outdated, i don't know the yaourt way but here's the manual fix to bypass stepbystep:
    $ wget http://aur.archlinux.org/packages/darkr … ant.tar.gz
    $ tar xvzf darkradiant.tar.gz
    $ cd darkradiant
    $ nano PKBUILD <- edit this file and remove theese two lines:
        echo "a79fe9432899ccdd883fd1c56cef4f2b  -" >"$srcdir"/md5sources
        find . -type f -print0 | xargs -0 cat | md5sum --status -c "$srcdir"/md5sources || return 1
    $ makepkg -c -i -s
    Hope that helps...

  • Sage-mathematics from AUR fails to build

    Anyone have any ideas why eclib shared libraries failed to build. I'd like to get the program running quickly, as I'm using it for college. On an unrelated note, why hasn't it remained in the repos? Its takes quite a long time to build. Let me know if anything else will help.
    [duke@cii ~]$ cd '/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0' && '/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/sage' -sh
    Starting subshell with Sage environment variables set.
    Be sure to exit when you are done and do not do anything
    with other copies of Sage!
    Bypassing shell configuration files ...
    SAGE_ROOT=/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8
    (sage subshell) cii:eclib-20100711.p0 duke$ make
    make: *** No targets specified and no makefile found. Stop.
    SAGE_ROOT=/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8
    (sage subshell) cii:eclib-20100711.p0 duke$ ./configure
    bash: ./configure: No such file or directory
    SAGE_ROOT=/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8
    (sage subshell) cii:eclib-20100711.p0 duke$ ls
    spkg-check spkg-install SPKG.txt src
    SAGE_ROOT=/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8
    (sage subshell) cii:eclib-20100711.p0 duke$ ./spkg-install
    Deleting old versions of eclib libraries, which
    would interfere with new builds.
    rm: cannot remove `libcurvesntl.*': No such file or directory
    rm: cannot remove `libg0nntl.*': No such file or directory
    rm: cannot remove `libjcntl.*': No such file or directory
    rm: cannot remove `librankntl.*': No such file or directory
    rm: cannot remove `libmwrank.*': No such file or directory
    Deleting old include directory
    mkdir -p include
    mkdir -p lib
    cd procs && make lib install
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/procs'
    Makefile:92: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:95: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:108: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    ar r libjcntl.a interface_n.o arith_n.o marith_n.o gpslave_n.o conic_n.o legendre_n.o unimod_n.o quadratic_n.o cubic_n.o illl_n.o hilbert_n.o parifact_n.o p2points_n.o compproc_n.o kbessel_n.o vector_n.o matrix_n.o subspace_n.o mvector_n.o mmatrix_n.o msubspace_n.o xsplit2_n.o timer_n.o svector_n.o smatrix_n.o smatrix_elim_n.o polys_n.o realroots_n.o gf_n.o
    ranlib libjcntl.a
    chmod a+r *
    (cd ../include; rm -f interface.h templates.h arith.h xmod.h marith.h gpslave.h compproc.h vec.h vector.h mat.h matrix.h sub.h subspace.h rat.h bigrat.h kbessel.h svec.h svector.h smat.h smatrix.h smat_elim.h smatrix_elim.h mvector.h mmatrix.h msubspace.h method.h splitbase.h xsplit.h conic.h legendre.h quadratic.h unimod.h illl.h hilbert.h timer.h cubic.h gf.h polys.h realroots.h parifact.h p2points.h)
    cp -p interface.h templates.h arith.h xmod.h marith.h gpslave.h compproc.h vec.h vector.h mat.h matrix.h sub.h subspace.h rat.h bigrat.h kbessel.h svec.h svector.h smat.h smatrix.h smat_elim.h smatrix_elim.h mvector.h mmatrix.h msubspace.h method.h splitbase.h xsplit.h conic.h legendre.h quadratic.h unimod.h illl.h hilbert.h timer.h cubic.h gf.h polys.h realroots.h parifact.h p2points.h ../include
    chmod a+r ../include/*.h
    rm -f ../lib/libjcntl.a
    ar r ../lib/libjcntl.a interface_n.o arith_n.o marith_n.o gpslave_n.o conic_n.o legendre_n.o unimod_n.o quadratic_n.o cubic_n.o illl_n.o hilbert_n.o parifact_n.o p2points_n.o compproc_n.o kbessel_n.o vector_n.o matrix_n.o subspace_n.o mvector_n.o mmatrix_n.o msubspace_n.o xsplit2_n.o timer_n.o svector_n.o smatrix_n.o smatrix_elim_n.o polys_n.o realroots_n.o gf_n.o
    ar: creating ../lib/libjcntl.a
    ranlib ../lib/libjcntl.a
    chmod a+rx ../lib/libjcntl.a
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/procs'
    cd qcurves && make lib install
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qcurves'
    Makefile:123: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:126: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:134: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    make[1]: Nothing to be done for `lib'.
    (cd ../include; rm -f curve.h points.h cperiods.h isogs.h reader.h mwprocs.h lambda.h sifter.h sieve_search.h htconst.h egr.h saturate.h divpol.h pointsmod.h curvemod.h ffmod.h tlss.h elog.h getcurve.h )
    for f in curve.h points.h cperiods.h isogs.h reader.h mwprocs.h lambda.h sifter.h sieve_search.h htconst.h egr.h saturate.h divpol.h pointsmod.h curvemod.h ffmod.h tlss.h elog.h getcurve.h ; \
    do cp ${f} ../include; \
    done
    chmod a+r ../include/*
    rm -f ../lib/libcurvesntl.a
    cp libcurvesntl.a ../lib
    chmod a+rx ../lib/libcurvesntl.a
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qcurves'
    cd qrank && make lib install
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qrank'
    Makefile:78: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:122: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:146: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    rm -f librankntl.a
    ar r librankntl.a mrank1_n.o mrank2_n.o mequiv_n.o mquartic_n.o mlocsol_n.o mglobsol_n.o qc_n.o sqfdiv_n.o desc2_n.o transform_n.o minim_n.o reduce_n.o bitspace_n.o GetOpt_n.o twoadic_n.o descent_n.o
    ar: creating librankntl.a
    ranlib librankntl.a
    (cd ../include; rm -f mrank2.h mequiv.h mlocsol.h mglobsol.h msoluble.h mquartic.h mrank1.h qc.h sqfdiv.h version.h minim.h reduce.h transform.h desc2.h bitspace.h options.h GetOpt.h twoadic.h descent.h)
    for f in mrank2.h mequiv.h mlocsol.h mglobsol.h msoluble.h mquartic.h mrank1.h qc.h sqfdiv.h version.h minim.h reduce.h transform.h desc2.h bitspace.h options.h GetOpt.h twoadic.h descent.h; \
    do cp ${f} ../include; \
    done
    chmod a+r ../include/*
    rm -f ../lib/librankntl.a
    cp librankntl.a ../lib
    chmod a+rx ../lib/librankntl.a
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qrank'
    cd g0n && make lib install
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/g0n'
    Makefile:115: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:118: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:121: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    make[1]: Nothing to be done for `lib'.
    (cd ../include; rm -f periods.h cusp.h homspace.h newforms.h nflist.h moddata.h oldforms.h symb.h fixc6.h pcprocs.h)
    for f in periods.h cusp.h homspace.h newforms.h nflist.h moddata.h oldforms.h symb.h fixc6.h pcprocs.h; \
    do cp ${f} ../include; \
    done
    chmod a+r ../include/*
    rm -f ../lib/libg0nntl.a
    cp libg0nntl.a ../lib
    chmod a+rx ../lib/libg0nntl.a
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/g0n'
    cd procs && make install_so && make tests progs
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/procs'
    Makefile:92: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:95: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:108: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    g++ -fPIC --shared libjcntl.a interface_n.o arith_n.o marith_n.o gpslave_n.o conic_n.o legendre_n.o unimod_n.o quadratic_n.o cubic_n.o illl_n.o hilbert_n.o parifact_n.o p2points_n.o compproc_n.o kbessel_n.o vector_n.o matrix_n.o subspace_n.o mvector_n.o mmatrix_n.o msubspace_n.o xsplit2_n.o timer_n.o svector_n.o smatrix_n.o smatrix_elim_n.o polys_n.o realroots_n.o gf_n.o -o libjcntl.so -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -lgmp -lpari -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -lgmp -lpari -lm
    cp libjcntl.so ../lib/
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/procs'
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/procs'
    Makefile:92: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:95: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:108: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    make[1]: Nothing to be done for `tests'.
    make[1]: Nothing to be done for `progs'.
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/procs'
    cd qcurves && make install_so && make tests progs
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qcurves'
    Makefile:123: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:126: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:134: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    cp libcurvesntl.so ../lib/
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qcurves'
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qcurves'
    Makefile:123: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:126: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:134: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    make[1]: Nothing to be done for `tests'.
    g++ -o ./torsion torsion_n.o libcurvesntl.a -ljcntl -L../lib -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -lm
    g++ -c -fPIC -g -O2 -DNEW_OP_ORDER -DUSE_PARI_FACTORING -I../include -DNTL_ALL -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include conductor.cc -o conductor_n.o
    g++ -o ./conductor conductor_n.o libcurvesntl.a -ljcntl -L../lib -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -lm
    g++ -c -fPIC -g -O2 -DNEW_OP_ORDER -DUSE_PARI_FACTORING -I../include -DNTL_ALL -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include twist.cc -o twist_n.o
    g++ -o ./twist twist_n.o libcurvesntl.a -ljcntl -L../lib -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -lm
    g++ -c -fPIC -g -O2 -DNEW_OP_ORDER -DUSE_PARI_FACTORING -I../include -DNTL_ALL -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include allisog.cc -o allisog_n.o
    g++ -o ./allisog allisog_n.o libcurvesntl.a -ljcntl -L../lib -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -lm
    g++ -c -fPIC -g -O2 -DNEW_OP_ORDER -DUSE_PARI_FACTORING -I../include -DNTL_ALL -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include findinf.cc -o findinf_n.o
    g++ -o ./findinf findinf_n.o libcurvesntl.a -ljcntl -L../lib -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -lm
    g++ -c -fPIC -g -O2 -DNEW_OP_ORDER -DUSE_PARI_FACTORING -I../include -DNTL_ALL -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include indep.cc -o indep_n.o
    g++ -o ./indep indep_n.o libcurvesntl.a -ljcntl -L../lib -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -lm
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qcurves'
    cd qrank && make install_so && make tests progs
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qrank'
    Makefile:78: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:122: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:146: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    g++ -fPIC --shared librankntl.a mrank1_n.o mrank2_n.o mequiv_n.o mquartic_n.o mlocsol_n.o mglobsol_n.o qc_n.o sqfdiv_n.o desc2_n.o transform_n.o minim_n.o reduce_n.o bitspace_n.o GetOpt_n.o twoadic_n.o descent_n.o -o librankntl.so -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -L../lib -lcurvesntl -ljcntl -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -lpari -lm
    cp librankntl.so ../lib/
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qrank'
    make[1]: Entering directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qrank'
    Makefile:78: warning: overriding recipe for target `clean'
    ../Makefile:76: warning: ignoring old recipe for target `clean'
    Makefile:122: warning: overriding recipe for target `veryclean'
    ../Makefile:84: warning: ignoring old recipe for target `veryclean'
    Makefile:146: warning: overriding recipe for target `check'
    ../Makefile:95: warning: ignoring old recipe for target `check'
    g++ -c -fPIC -g -O2 -DNEW_OP_ORDER -DUSE_PARI_FACTORING -I../include -DNTL_ALL -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include version.cc -o version_n.o
    g++ -c -fPIC -g -O2 -DNEW_OP_ORDER -DUSE_PARI_FACTORING -I../include -DNTL_ALL -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include -I/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/include mwrank.cc -o mwrank_n.o
    chmod og+r *
    g++ -o mwrank version_n.o mwrank_n.o descent_n.o mrank1_n.o mrank2_n.o mequiv_n.o mquartic_n.o \
    mlocsol_n.o mglobsol_n.o qc_n.o sqfdiv_n.o desc2_n.o \
    transform_n.o minim_n.o reduce_n.o bitspace_n.o GetOpt_n.o twoadic_n.o \
    -L../lib -lcurvesntl -ljcntl -lpari -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -L/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/local/lib -lntl -L../lib -lgmp -lpari -lpari -lm
    collect2: ld returned 1 exit status
    make[1]: *** [mwrank] Error 1
    make[1]: Leaving directory `/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8/spkg/build/eclib-20100711.p0/src/qrank'
    make: *** [so] Error 2
    Error building eclib shared libraries
    SAGE_ROOT=/tmp/yaourt-tmp-duke/aur-sage-mathematics/src/sage-4.8

    I'm getting something slightly different when I try to build this package. They all seem to be the same as this, except with different function names.
    error: ‘mulColDense’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
    Does anyone have any ideas on how to remedy this?

  • Lancelot from aur fails to build

    I tried installing the lancelot menu from the AUR and it fails at compile time. Here's the output. http://pastie.org/436602
    this seems to be the only place to get the lancelot menu, as kdemod dropped it from their repositories.

    theringmaster wrote:
    I tried installing the lancelot menu from the AUR and it fails at compile time. Here's the output. http://pastie.org/436602
    this seems to be the only place to get the lancelot menu, as kdemod dropped it from their repositories.
    The error message mentions that the FindPlasma.cmake has been deprecated. You can go in and change all the constant values that it asks you to change and see if it will successfully build. The other thing you could do is, wait until the maintainer of the app fixes it.

  • [SOLVED]Connecting to L2TP/IPSec VPN problem: pppd seems not starting

    I'm trying to connect to an L2TP/IPsec VPN server, by ipsec-tools + xl2tpd.
    Here is my setup:
    /etc/racoon.conf:
    log debug;
    path pre_shared_key "/etc/racoon/psk.txt";
    padding {
    maximum_length 20;
    randomize off;
    strict_check off;
    exclusive_tail off;
    remote anonymous {
    exchange_mode main;
    doi ipsec_doi;
    situation identity_only;
    generate_policy on;
    nat_traversal on;
    proposal_check obey;
    proposal {
    encryption_algorithm aes 256;
    lifetime time 3600 sec;
    hash_algorithm sha1;
    authentication_method pre_shared_key;
    dh_group modp1024;
    sainfo anonymous {
    lifetime time 3600 sec;
    encryption_algorithm aes 256;
    authentication_algorithm hmac_sha1;
    compression_algorithm deflate;
    /etc/racoon/psk.txt:
    #broadband
    137.189.192.201 the-server-psk
    137.189.192.204 the-server-psk
    Here the two IPs are the IPs of vpn.cuhk.edu.hk, which is the VPN server.
    /etc/xl2tpd/xl2tpd.conf:
    [global]
    port = 1701
    auth file = /etc/ppp/pap-secrets
    debug network = yes
    debug avp = yes
    debug packet = yes
    debug state = yes
    debug tunnel = yes
    [lac connect]
    lns = vpn.cuhk.edu.hk
    name = vpn-server
    redial = yes
    redial timeout = 15
    max redials = 5
    hidden bit = yes
    refuse chap = yes
    require pap = yes
    ppp debug = yes
    pppoptfile = /etc/ppp/options.xl2tpd
    /etc/ppp/pap-secrets:
    # Secrets for authentication using PAP
    # client server secret IP addresses
    myusername * mypassword *
    /etc/ppp/options.xl2tpd:
    lock
    debug
    mtu 1000
    nobsdcomp
    nodeflate
    noaccomp
    nopcomp
    novj
    defaultroute
    refuse-chap
    refuse-mschap
    refuse-mschap-v2
    connect-delay 5000
    name myusername
    password mypassword
    spd.sh:
    #!/bin/sh
    Then I do the following:
    # 192.168.1.1 is my lan gateway
    sudo ip route add 137.189.192.201 via 192.168.1.1
    sudo ip route add 137.189.192.204 via 192.168.1.1
    # For adding spd, script from the VPN server
    echo -e flush\; | sudo setkey -c
    echo -e spdflush\; | sudo setkey -c
    echo -e spdadd 192.168.1.173/32\[1701\] 0.0.0.0\/0\[0\] any \-P out ipsec esp\/transport\/\/require\; | sudo setkey -c
    sudo systemctl start racoon
    sudo systemctl start xl2tpd
    echo "c connect" | sudo tee /var/run/xl2tpd/l2tp-control
    I expect that some network interface like ppp0 will be created, but nothing happened.
    Then I check the record, and find something weird in xl2tpd log (from journalctl, racoon and sudo logs skipped):
    8月 21 01:13:40 nkdesktop systemd[1]: Stopped Level 2 Tunnel Protocol Daemon (L2TP).
    8月 21 01:13:41 nkdesktop systemd[1]: Starting Racoon IKEv1 key management daemon for IPSEC...
    8月 21 01:13:41 nkdesktop systemd[1]: Started Racoon IKEv1 key management daemon for IPSEC.
    8月 21 01:13:43 nkdesktop systemd[1]: Starting Level 2 Tunnel Protocol Daemon (L2TP)...
    8月 21 01:13:43 nkdesktop systemd[1]: Started Level 2 Tunnel Protocol Daemon (L2TP).
    8月 21 01:13:43 nkdesktop xl2tpd[19639]: xl2tpd[19639]: setsockopt recvref[30]: Protocol not available
    8月 21 01:13:43 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Using l2tp kernel support.
    8月 21 01:13:43 nkdesktop xl2tpd[19639]: xl2tpd[19639]: xl2tpd version xl2tpd-1.3.6 started on nkdesktop PID:19639
    8月 21 01:13:43 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
    8月 21 01:13:43 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Forked by Scott Balmos and David Stipp, (C) 2001
    8月 21 01:13:43 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Inherited by Jeff McAdams, (C) 2002
    8月 21 01:13:43 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Forked again by Xelerance (www.xelerance.com) (C) 2006
    8月 21 01:13:43 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Listening on IP address 0.0.0.0, port 1701
    8月 21 01:13:45 nkdesktop xl2tpd[19639]: xl2tpd[19639]: get_call: allocating new tunnel for host 137.189.192.204, port 1701.
    8月 21 01:13:45 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Connecting to host vpn.cuhk.edu.hk, port 1701
    8月 21 01:13:45 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: message type is (null)(0). Tunnel is 0, call is 0.
    8月 21 01:13:45 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: sending SCCRQ
    8月 21 01:13:46 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: select timeout
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: select timeout
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: recv packet from 137.189.192.204, size = 103, tunnel = 30858, call = 0 ref=0 refhim=0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: handle_avps: handling avp's for tunnel 30858, call 0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: message_type_avp: message type 2 (Start-Control-Connection-Reply)
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: protocol_version_avp: peer is using version 1, revision 0.
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: framing_caps_avp: supported peer frames: async sync
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: bearer_caps_avp: supported peer bearers:
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: firmware_rev_avp: peer reports firmware version 1648 (0x0670)
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: hostname_avp: peer reports hostname 'eriwan'
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: vendor_avp: peer reports vendor 'Adtran, l2tpd'
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: assigned_tunnel_avp: using peer's tunnel 4733
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: receive_window_size_avp: peer wants RWS of 4. Will use flow control.
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: message type is Start-Control-Connection-Reply(2). Tunnel is 4733, call is 0.
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: sending SCCCN
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Connection established to 137.189.192.204, 1701. Local: 30858, Remote: 4733 (ref=0/0).
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Calling on tunnel 30858
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: message type is (null)(0). Tunnel is 4733, call is 0.
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: sending ICRQ
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: recv packet from 137.189.192.204, size = 12, tunnel = 30858, call = 0 ref=0 refhim=0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: recv packet from 137.189.192.204, size = 28, tunnel = 30858, call = 63662 ref=0 refhim=0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: handle_avps: handling avp's for tunnel 30858, call 63662
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: message_type_avp: message type 11 (Incoming-Call-Reply)
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: assigned_call_avp: using peer's call 31346
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: message type is Incoming-Call-Reply(11). Tunnel is 4733, call is 31346.
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: Sending ICCN
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Call established with 137.189.192.204, Local: 63662, Remote: 31346, Serial: 1 (ref=0/0)
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: start_pppd: I'm running:
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "/usr/sbin/pppd"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "passive"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "nodetach"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: ":"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "refuse-chap"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "name"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "vpn-server"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "debug"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "file"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "/etc/ppp/options.xl2tpd"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "plugin"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "pppol2tp.so"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "pppol2tp"
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: "7"
    8月 21 01:13:47 nkdesktop pppd[19647]: Plugin pppol2tp.so loaded.
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: recv packet from 137.189.192.204, size = 12, tunnel = 30858, call = 0 ref=0 refhim=0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: recv packet from 137.189.192.204, size = 12, tunnel = 30858, call = 63662 ref=0 refhim=0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: recv packet from 137.189.192.204, size = 38, tunnel = 30858, call = 63662 ref=0 refhim=0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: handle_avps: handling avp's for tunnel 30858, call 63662
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: message_type_avp: message type 14 (Call-Disconnect-Notify)
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: result_code_avp: peer closing for reason 1 (General request to clear control connection), error = 0 ()
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: assigned_call_avp: using peer's call 31346
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: message type is Call-Disconnect-Notify(14). Tunnel is 4733, call is 31346.
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: Connection closed to 137.189.192.204, serial 1 ()
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: Terminating pppd: sending TERM signal to pid 19647
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: recv packet from 137.189.192.204, size = 38, tunnel = 30858, call = 0 ref=0 refhim=0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: handle_avps: handling avp's for tunnel 30858, call 0
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: message_type_avp: message type 4 (Stop-Control-Connection-Notification)
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: assigned_tunnel_avp: using peer's tunnel 4733
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: result_code_avp: peer closing for reason 1 (General request to clear control connection), error = 0 ()
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: message type is Stop-Control-Connection-Notification(4). Tunnel is 4733, call is 0.
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: control_finish: Connection closed to 137.189.192.204, port 1701 (), Local: 30858, Remote: 4733
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: build_fdset: closing down tunnel 30858
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: select returned error 9 (Bad file descriptor)
    8月 21 01:13:47 nkdesktop xl2tpd[19639]: xl2tpd[19639]: network_thread: select returned error 4 (Interrupted system call)
    ... then xl2tpd repeatedly trying to build a connection and fails for every 15s ...
    I think pppd should have showed more logs, rather than just loading a module.
    But I have no idea about what's wrong.
    Or did I just forget to turn on the log function of pppd? If so, how should I turn it on?
    Anyone can help?
    Last edited by nnkken (2014-08-24 08:42:03)

    Additional information:
    Today I decrypted the IPSec ESP packets by Wireshark (what an awesome function) and compared the L2TP message of my ArchLinux and MacOSX to the same VPN Server.
    And I found that while both ArchLinux and MacOSX sends Incomming_Call_Connection (ICCN) packet, the packet are quite different:
    The ArchLinux ICCN Packet has 2 additional AVP fields: Random Vector AVP and RX Connect Speed AVP.
    Also, the Connect Speed AVP (and also the RX Connect Speed AVP) field is 0, which is different from MacOSX (100000).
    After the ICCN packet, MacOCX sends a PPP packet over L2TP, while ArchLinux sends nothing and the server sends a Call_Disconnect_Notification to ArchLinux.
    Anyone knows whether this is a bug or something wrong in config?
    Last edited by nnkken (2014-08-22 20:19:49)

  • Looking for help to set up l2tp Ipsec vpn on asa 5055

    I am trying to set up a L2tp Ipsec vpn on asa 5055 and I am using windows 8.1 build in VPN client to connect to it. I got the following error. Anyone has experence please help.
    Apr 17 22:48:21 [IKEv1]Group = DefaultRAGroup, IP = 209.171.88.81, All IPSec SA proposals found unacceptable!
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, sending notify message
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, constructing blank hash payload
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, constructing ipsec notify payload for msg id 1
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, constructing qm hash payload
    Apr 17 22:48:21 [IKEv1]IP = 209.171.88.81, IKE_DECODE SENDING Message (msgid=6a50f8f9) with payloads : HDR + HASH (8) + NOTIFY (11) + NONE (0) total length : 84
    Apr 17 22:48:21 [IKEv1]Group = DefaultRAGroup, IP = 209.171.88.81, QM FSM error (P2 struct &0xad6946b8, mess id 0x1)!
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, IKE QM Responder FSM error history (struct &0xad6946b8)  <state>, <event>:  QM_DONE, EV_ERROR-->QM_BLD_MSG2, 
    EV_NEGO_SA-->QM_BLD_MSG2, EV_IS_REKEY-->QM_BLD_MSG2, EV_CONFIRM_SA-->QM_BLD_MSG2, EV_PROC_MSG-->QM_BLD_MSG2, EV_HASH_OK-->QM_BLD_MSG2, NullEvent-->QM_BLD_MSG2, 
    EV_COMP_HASH
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, sending delete/delete with reason message
    Apr 17 22:48:21 [IKEv1]Group = DefaultRAGroup, IP = 209.171.88.81, Removing peer from correlator table failed, no match!
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, IKE SA MM:d8870fa5 rcv'd Terminate: state MM_ACTIVE  flags 0x00000042, refcnt 1, tuncnt 0
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, IKE SA MM:d8870fa5 terminating:  flags 0x01000002, refcnt 0, tuncnt 0
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, sending delete/delete with reason message
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, constructing blank hash payload
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, constructing IKE delete payload
    Apr 17 22:48:21 [IKEv1 DEBUG]Group = DefaultRAGroup, IP = 209.171.88.81, constructing qm hash payload
    Apr 17 22:48:21 [IKEv1]IP = 209.171.88.81, IKE_DECODE SENDING Message (msgid=232654dc) with payloads : HDR + HASH (8) + DELETE (12) + NONE (0) total length : 80
    Apr 17 22:48:21 [IKEv1]Group = DefaultRAGroup, IP = 209.171.88.81, Session is being torn down. Reason: Phase 2 Mismatch
    I am new to this so I don't know what I should do next. Thanks

    Here it is. Thanks.
    CL-T179-12IH# show run crypto
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
    crypto ipsec ikev2 ipsec-proposal DES
     protocol esp encryption des
     protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
     protocol esp encryption 3des
     protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
     protocol esp encryption aes
     protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
     protocol esp encryption aes-192
     protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES256
     protocol esp encryption aes-256
     protocol esp integrity sha-1 md5
    crypto ipsec security-association pmtu-aging infinite
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-192-SHA ESP-AES-256-SHA ESP-3DES-SHA ESP-DES-SHA ESP-AES-128-SHA-TRANS ESP-AES-192-SHA-TRANS ESP-AES-256-SHA-TRANS ESP-3DES-SHA-TRANS ESP-DES-SHA-TRANS
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ca trustpoint vpn
     enrollment self
     subject-name CN=174.142.90.17
     crl configure
    crypto ca trustpool policy
    crypto ca certificate chain vpn
     certificate 2d181c55
        308201ff 30820168 a0030201 0202042d 181c5530 0d06092a 864886f7 0d010105
        05003044 31163014 06035504 03130d31 37342e31 34322e39 302e3137 312a3028
        06092a86 4886f70d 01090216 1b434c2d 54313739 2d313249 482e7072 69766174
        65646e73 2e636f6d 301e170d 31353034 31363033 31393439 5a170d32 35303431
        33303331 3934395a 30443116 30140603 55040313 0d313734 2e313432 2e39302e
        3137312a 30280609 2a864886 f70d0109 02161b43 4c2d5431 37392d31 3249482e
        70726976 61746564 6e732e63 6f6d3081 9f300d06 092a8648 86f70d01 01010500
        03818d00 30818902 818100bf 797d1cc1 cfffc634 8c3b2a4b ce27b1c9 3fc3e026
        4f6cd8f4 c9675aca b5176cef 7f3df142 35ba4e15 2613d34c 91bb5da3 14b34b6c
        71e4ff44 f129046f 7f91e73f 2c9d42f9 93001559 ea6c71c1 1a848073 15da79f7
        a41081ee b4cd3cc3 baa7a272 3a5fb32d 66dedee6 5994d4b2 ad9d7489 44ec9eb9
        44038a2a 817e935f 1bb7ad02 03010001 300d0609 2a864886 f70d0101 05050003
        8181002c 6cee9ae7 a037698a 5690aca1 f01c87db 04d9cbc6 65bda6dc a17fc4b6
        b1fd419e 56df108f b06edfe6 ab5a5eb3 5474a7fe 58970da3 23e6bc6e 36ab8f62
        d5c442bf 43581eb3 26b8cf26 6a667a8b ddd25a73 a094f0d0 65092ff8 d2a644d8
        3d7da7ca efeb9e2f 84807fdf 0cf3d75e bcb65ba4 7b51cb49 f912f516 f95b5d86
        da0e01
      quit
    crypto ikev2 policy 1
     encryption aes-256
     integrity sha
     group 5 2
     prf sha
     lifetime seconds 86400
    crypto ikev2 policy 10
     encryption aes-192
     integrity sha
     group 5 2
     prf sha
     lifetime seconds 86400
    crypto ikev2 policy 30
     encryption 3des
     integrity sha
     group 5 2
     prf sha
     lifetime seconds 86400
    crypto ikev2 policy 40
     encryption des
     integrity sha
     group 5 2
     prf sha
     lifetime seconds 86400
    crypto ikev2 enable outside client-services port 443
    crypto ikev2 remote-access trustpoint vpn
    crypto ikev1 enable outside
    crypto ikev1 policy 10
     authentication crack
     encryption aes-256
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 20
     authentication rsa-sig
     encryption aes-256
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 30
     authentication pre-share
     encryption aes-256
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 40
     authentication crack
     encryption aes-192
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 50
     authentication rsa-sig
     encryption aes-192
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 60
     authentication pre-share
     encryption aes-192
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 70
     authentication crack
     encryption aes
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 80
     authentication rsa-sig
     encryption aes
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 90
     authentication pre-share
     encryption aes
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 100
     authentication crack
     encryption 3des
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 110
     authentication rsa-sig
     encryption 3des
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 120
     authentication pre-share
     encryption 3des
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 130
     authentication crack
     encryption des
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 140
     authentication rsa-sig
     encryption des
     hash sha
     group 2
     lifetime 86400
    crypto ikev1 policy 150
     authentication pre-share
     encryption des
     hash sha
     group 2
     lifetime 86400

  • Port Forwarding for L2TP/IPSec VPN Behind Verizon Actiontec MI424WR-GEN2 Rev. E v20.21.0.2

    I've got a NAS setup with various services running on custom ports to help minimize exposure (especially to script kiddies). I've tested everything both internally and externally to confirm they all work, and even had someone at a remote location confirm accessibility as well.  Port forward configurations performed on the Actiontec are working well. 
    I installed an L2TP/IPSec VPN server, tested internally and it connected successfully.  So for all intents & purposes, this validates that the VPN server is correctly configured to accept inbound connections and functioning correctly.
    I logged into the Verizon Actiontec MI424WR router, setup port forwarding for UDP ports 500, 1701 & 4500.
    Note: I added the AH & ESP protocols based on what I saw on the built-in L2TP/IPSec rules
    With the port forwarding in place, I tested VPN externally but it didn't connect.
    I've done the following so far to no avail:
    Double & triple checked the port forwards, deleted & recreated the rules a few times to be sure
    There are no other pre-existing L2RP/IPSec port forward rules or otherwise conflicting port forward rules (e.g.: another rule for ports 500, 1701 or 4500)
    There was an L2TP port triggering rule enabled, that I toggled on and off with no change
    Verified the firewall on VPN server had an exclusion for L2TP, or that the firewall is off. (Firewall is off to reduce a layer of complexity, but it worked internally to begin with so I doubt that's the issue.)
    Since it works internally, and there are no entries in the logs on the device indicating inbound connections, I'm convinced its an issue with the Verizon Actiontec router.  But unfortunately, I'm not sure what else to try or where else to look to troubleshoot this.  For instance, is there a log on the router that I can view in real time (e.g.: tail) that would show me whether or not the inbound connection attempt is reaching the device, and whether or not the device allowed or blocked it?
    My router details:
    Verizon Actiontec
    MI424WR-GEN2
    Revision E
    Firmware 20.21.0.2
    Verizon Actiontec built-in L2TP/IPSec rule templates.  They're not currently in use, but are baked into the firmware for easy configuration/selection from a drop down menu.
    Solved!
    Go to Solution.

    normally a vpn on that router, will have a GRE tunneling protocol as well.
    two ways to build the PF rules,
    Manually
    Preconfigured
    I know the preconfigured VPN rules will do the GRE protocol as well, but if you do it by hand you can't get it.

  • Establishing L2TP/IPSEC vpn

    I have a new laptop, running Windows 8.1 Pro. I am trying to set up an L2TP/IPSEC vpn to my office.
    I have created the connection, and filled in the various settings including PSK, but whenever I try and connect it fails with Error 789. I have checked this against my Windows XP / Vista / 7 laptops (which all work fine), and the VPN setup details are all
    identical. It works fine on all the other laptops, but not on Windows 8.1.
    Is there something special about Windows 8.1 that would prevent this from working?

    Hi,
    Please check the solution in this thread:
    http://social.technet.microsoft.com/Forums/windows/en-US/630488b8-e638-488d-803a-08ef9281e4fb/windows-7-ipsecl2tp-vpn-connection-problem
    Also, please check solution “Error Code: 789, 835” in this article:
    Troubleshooting common VPN related errors
    http://blogs.technet.com/b/rrasblog/archive/2009/08/12/troubleshooting-common-vpn-related-errors.aspx
    Since this issue can also be caused by third-part security program, please disable it and recreate the connection again to check the results.
    Please take time to perform the steps above and let me know the results.
    Karen Hu
    TechNet Community Support

  • Problem with L2TP IPSEC VPN login...

    Hello,
    I have a problem with my trying to login on my laptop to my work vpn.  I was given from my work, the vpn's ip address, the psk, my username, and password for the vpn.  I feel like I am hitting a brick wall and makes me just want to forget it all together...  I can get in with my info on this same laptop on the same connection at my apartment from my windows 8.1 partition just fine.  I have also verified and triple checked all my vpn information required.  I also don't know but I think have it setup to use PAP, MS CHAP, or MS CHAP v2..  Any help I would be greatly appreciated.  Pretty much the way my VPN for my work works is you have to VPN on L2TP over IPSEC with a username and password and a psk to allow you to remote desktop to my desktop at work.  Really wish this could work as I am tired of supporting windows at home when I pretty much only use it to VPN into work when I have to get work done...
    pacman -Q openswan
    openswan 2.6.41-1
    pacman -Q xl2tpd
    xl2tpd 1.3.6-1
    uname -a
    Linux tux 3.17.1-1-ARCH #1 SMP PREEMPT Wed Oct 15 15:04:35 CEST 2014 x86_64 GNU/Linux
    Now I have all the configs setup below following the L2TP/IPsec VPN client setup arch wiki page and I keep getting this:
    ipsec auto --up <vpn connection name>
    022 "<vpn connection name>": We cannot identify ourselves with either end of this connection.
    my process to run the vpn connection:
    sudo systemctl start openswan
    sudo systemctl start xl2tpd
    ipsec auto --up <vpn connection name>
    echo "c <vpn connection name>" > /var/run/xl2tpd/l2tp-control
    how I added my vpn connection:
    sudo ipsec auto --add <vpn connection name>
    /etc/xl2tpd/xl2tpd.conf
    [global]
    ; listen-addr = <my ip address>
    debug avp = no
    debug network = no
    debug packet = no
    debug state = no
    debug tunnel = no
    [lac <vpn connection name>]
    lns = <vpn ip address>
    pppoptfile = /etc/ppp/<vpn connection name>.options.xl2tpd
    length bit = no
    redial = no
    /etc/ppp/<vpn connection name>.options.xl2tpd
    plugin passprompt.so
    ipcp-accept-local
    ipcp-accept-remote
    idle 72000
    ktune
    noproxyarp
    asyncmap 0
    noauth
    crtscts
    lock
    hide-password
    modem
    noipx
    ipparam L2tpIPsecVpn-<vpn connection name>
    promptprog "/usr/bin/L2tpIPsecVpn"
    refuse-eap
    remotename ""
    name "<vpn username>"
    password <vpn password>
    usepeerdns
    /etc/ipsec.secrets
    %any @<vpn ip address>: PSK <psk key here>
    Last edited by adramalech (2014-10-25 04:53:46)

    Hello,
    I have a problem with my trying to login on my laptop to my work vpn.  I was given from my work, the vpn's ip address, the psk, my username, and password for the vpn.  I feel like I am hitting a brick wall and makes me just want to forget it all together...  I can get in with my info on this same laptop on the same connection at my apartment from my windows 8.1 partition just fine.  I have also verified and triple checked all my vpn information required.  I also don't know but I think have it setup to use PAP, MS CHAP, or MS CHAP v2..  Any help I would be greatly appreciated.  Pretty much the way my VPN for my work works is you have to VPN on L2TP over IPSEC with a username and password and a psk to allow you to remote desktop to my desktop at work.  Really wish this could work as I am tired of supporting windows at home when I pretty much only use it to VPN into work when I have to get work done...
    pacman -Q openswan
    openswan 2.6.41-1
    pacman -Q xl2tpd
    xl2tpd 1.3.6-1
    uname -a
    Linux tux 3.17.1-1-ARCH #1 SMP PREEMPT Wed Oct 15 15:04:35 CEST 2014 x86_64 GNU/Linux
    Now I have all the configs setup below following the L2TP/IPsec VPN client setup arch wiki page and I keep getting this:
    ipsec auto --up <vpn connection name>
    022 "<vpn connection name>": We cannot identify ourselves with either end of this connection.
    my process to run the vpn connection:
    sudo systemctl start openswan
    sudo systemctl start xl2tpd
    ipsec auto --up <vpn connection name>
    echo "c <vpn connection name>" > /var/run/xl2tpd/l2tp-control
    how I added my vpn connection:
    sudo ipsec auto --add <vpn connection name>
    /etc/xl2tpd/xl2tpd.conf
    [global]
    ; listen-addr = <my ip address>
    debug avp = no
    debug network = no
    debug packet = no
    debug state = no
    debug tunnel = no
    [lac <vpn connection name>]
    lns = <vpn ip address>
    pppoptfile = /etc/ppp/<vpn connection name>.options.xl2tpd
    length bit = no
    redial = no
    /etc/ppp/<vpn connection name>.options.xl2tpd
    plugin passprompt.so
    ipcp-accept-local
    ipcp-accept-remote
    idle 72000
    ktune
    noproxyarp
    asyncmap 0
    noauth
    crtscts
    lock
    hide-password
    modem
    noipx
    ipparam L2tpIPsecVpn-<vpn connection name>
    promptprog "/usr/bin/L2tpIPsecVpn"
    refuse-eap
    remotename ""
    name "<vpn username>"
    password <vpn password>
    usepeerdns
    /etc/ipsec.secrets
    %any @<vpn ip address>: PSK <psk key here>
    Last edited by adramalech (2014-10-25 04:53:46)

  • [SOLVED] Building VCS packages from AUR fails

    Hello,
    Whenever I try to build a git or svn package from AUR, build fails with the error in a clean chroot enviroment:
    ==> ERROR: Unknown download protocol: svn
    Aborting...
    When the build starts, makepkg actually downloads source files properly. Any clues?
    Last edited by yuan_modu (2015-04-02 16:31:03)

    Trilby wrote:How many packages has this happened with?  Can you give an example of one that produces this error?  If the download proceeds when the build starts, it sounds like the PKGBUILD is outdated and is manually grabbing the source in the build function (in pacman<4.0 style).
    I was building https://aur.archlinux.org/packages/uefi-shell-svn: a popular and up-to-date PKGBUILD.
    Indeed I didn't merge the conf files of  clean chroot. There was a makepkg.conf.pacnew, the lacking part in my old makepkg.conf was:
    VCSCLIENTS=('bzr::bzr'
    'git::git'
    'hg::mercurial'
    'svn::subversion')
    and some small changes. Everything works fine now. Was my bad. Sorry for incovenience and thanks for your help.
    Last edited by yuan_modu (2015-04-02 13:08:21)

  • Is there a limit to the number of concurrent L2TP/IPSec VPN connections in Snow Leopard

    Hi,
    I'm currently running an L2TP/IPSec service from a Snow Leopard server VM running on the latest version of Lion Server ( Had loads of issues with Lion VPN connectivity from outside our network when I first upgraded the physical server to Lion. quickest way to get the service back was to run an S/L VM. I know that there have been some changes to Lion in the VPN area, but this works... sort of;;;)
    I've got an IP address pool of 20 addresses confgured as this is only for ICT staff members. Each user has a local userid/password on the S/L server. For me, things just work.
    iPhone, iPad, OS X lion client they all work and I've had about 3 simultaneous connections up and running.However, the majority of staff users use Windows 7 client machines and they're been reporting sporadic connection failures where one moment they can get connected and the next they can't.  I'm currently wondring if there is some concurrent limit setting they are hitting and are getting slung off because I've got other users using the service.  It would be a bit strange if S/L can only support 2 or 3 connections out of the box.
    Then again it might be VMWare Fusion (Vsn 4.1.1) thats the problem.
    Any help apppreciated
    Rgds
    Alex

    You have to count to have about 30GB at least free on the startup disk, after you have the library loaded.
    On the external you have space enough.
    As far as I know there is no limit for iPhoto, but I suggest to not let it grow too much, because everything will become sluggish, also making backups. It should be possible to split up in more libraries, one that is really actual and one that is the past. Physical splitting up I mean, not smart collections. You can switch libraries by holding the Alt(option) at startup of iPhoto.

  • REMOVING IPSEC VPN CONFIG FROM PIX 6.3 FIREWALL

    Hey,
    we have pix 6.3 serving as internet firewall and we are int process of replacing it with new ASA Device. currently there are several site to site and remote vpn are configured for access purposes. 
    i tried to remove one site2site ipsec vpn from pix and it starts acting like a loop generating the same error with qty that processor got 100% CPU, couldn't logged in through normal ssh so i connected via console and place back the isakmp and crypto map commands back in and the error stops.
    My purpose of this question is that how can i remove vpn config from pix without generating any error is there any formal process or order of removing rules from pix or we can do it one by one no order is required.
    MY PROCESS OF REMOVING CONFIG:
    REMOVE THE ACCESS-LIST INSIDEOUT AND OUTSIDE IN COMMANDS 
    REMOVE THE OBJECTS AND OBJECTS GROUPS
    REMOVE THE VPN DEFINED ACCESS-LIST FOR INTERESTING TRAFFIC
    REMOVE CRYPTO MAP TRANSFORM-SET
    REMOVE ISAKMP-POLICY
    REMOVE CRYPTO MAP 
    WE DO USE ISAKMP SHARED KAY MECHANISM "I DID NOT REMOVE THAT "
    BUT AS SOON AS I REMOVE THE CRYPTO MAP FROM THE PIX I GOT THIS ERROR
    IPSEC(crypto_map_check): crypto map XYZ 20 incomplete.  No peer or access-list specified.
    20 IS THE ISAKMP POLICY NUMBER & Peer and Access-list was removed from pix
    any help would great
    regards

    Hi
    You could do either of 2 things.
    1) Enable NAT-Traversal on your ASA
    2) Add the following on your pix :
    fixup protocol esp-ike
    This allows one IPSEC connection to run through PAT.
    HTH
    Jon

  • Package from AUR failed to install after doing many steps, how to rm?

    How can I see what files have been left on my hard drive after a package failed to install. I can't pacman -Rsu the package because it didnt install, but now i got some other packages that i don't need then. and probably some other stuff while the package was being extracted..
    How can i prevent from leaving a messy trail?

    Yeah gen2ly, i was using yaourt to get a package from AUR.
    I was able to uninstall the extra packages that were uninstalled, but is it possible that when the PKGBUILD failed that it left some random files somewhere? That's what I trully want to know. The other dependancies i have already removed.
    Hey thanks for the info on unzip, Runiq! unzip works miracles!!!! I installed it, and now the front end "File Roller" AKA "Archive Manager" in Gnome can suddenly handle .zip files! It's awesome! no need for p7zip or xarchiver.
    Every newbie or windows transferee should know about it!
    But anyways, is it possible the failed PKGBUILD left files somewhere?

Maybe you are looking for