Sychronous Interfacing

We have a requirement to send multiple WebSservice requests from one dedicated outbound port in XI to the WebService :
Which of these scenarios is more likely:
1. Only a single request can be sent at any one time and because this is synchronous communication the response must be received to this before the next request can be sent.
2. It is possible to send multiple requests out through different communication channels with no interdependency.

><i>You mean to say use BPM par for each to accept all the four responses and keep it in block</i>
yes. This is a standard featutre of use of a BPM.
><i>As all are been sent in different communication channel, will the interdependency matters!</i>
if you are planning to use a Block, you will be able to send the requrest only to one Receievr SOAP adapter.
Any reason as to why you want to send the request to different SOAP adapter?
If you want to send the request messages to different SOAP adapters then you will need to,
1. Either use a Single SOAP adapter with Adapter message Attributes being set in the mapping for the SOAP adapter ( the SOAP Url and SOAP action can be set dyncamically from the mapping )
2. Or, use a Fork and separate Send Steps with different Interfaces and receievr determinations to send it to multiple Adapters.
Option 1 is a better option though.
Regards
Bhavesh
Regards
Bhavesh

Similar Messages

  • There was an error opening this document. This file cannot be found

    An automation script on one of our QA environments kept tripping on the error: "There was an error opening this document. This file cannot be found".  The same script ran fine against our Production servers (hint, which were "whitelisted").
    It took a little time to resolve/trace what was happening (but with the aid of ProcessMonitor and tracing all "pdf"-related file activity...)
    The problem lies squarely between McAfee (75%), Adobe (20%) and Microsoft (5%):
    NORMAL WORKFLOW.  IE (Internet Explorer) when popping a PDF document, has to (1) write the document to the IE cache, then (2) launching and "handing off" the document reference to the Adobe viewer (which might then be able to open the document, et al) -- assuming largely a "synchronous" workflow.
    BUT "WAIT", HOLD THE HORSES -- McAfee takes ownership and decides infact "wait for us" (during the workflow), it wants to first perform a virus scan on the document (ahead of writing the document to cache) involving potentially large latency (delay) before making the document available to the system. However, instead of "fessing up"-that their scan may be taking too long, McAfee appears to have taken their work "off-line" in violation of the sychronous interface above. I'm guessing the developers at McAfee might have been trying to hide any extra processing overhead being incurred by assuming they could somehow convert this to an "asychronous" event.  (This may also have more reach than just PDF's.)
    Unfortunately, the browser's "PDF OPEN"-dialog box pops allowing Adobe to launch-and-open the "as-yet-not-virus-scanned-and-thus-not-yet-cached"-document. Thus clicking the OPEN-button will cause the related "...FILE NOT FOUND"-error to be seen (because the file is still in McAfee "limbo").
    Note: If you close the ADOBE reader (but don't yet close the popup-OPEN-dialog) you can click OPEN a second time and it will probably now open the document - which McAfee finally finished scanning!
    You can observe all these interactions with ProcessMonitor, and use the monitored file states to adjust the timings of events to reproduce both the failure and non-failure scenarios.
    - Best Regards, Ziggy
    ps. My assessed distribution of "ownership" of the problem is because ALL these parties should be aggressively resolving this for the customer-base!

    What, exactly, were you trying to do when you got it, and how?

  • XML not well formed - Java Mapping, Webservice to RFC Scenario

    Hello All Experts,
    I have facing a strange type of error. I have written a Java Mapping which implements a DOM parser to take a request from a Webservice and validate it on the basis of some prerequisites. i.e. If data in the incoming request is valid, it creates a message of the same structure type as the input. If the incoming data is incorrect or incomplete; It generates an Error response structure.
    When I run and test the same mapping program using Editplus Java editor for the error scenario; it executes perfectly and creates the correct error XML structure. (I checked it by importing the structure in the XI Message mapping test tab). But when I create jar of my java mapping program and test it in my interface mapping, it gives me "XML not well formed error" (Problem while building the tree).
    Any idea as to why is it behaving in such a way? There are 2 reasons which come to my mind as of now:
    1. The initilization of my input and output streams in the public static void main:
                InputStream in = new FileInputStream(new File("Input.xml"));
               OutputStream out = new FileOutputStream(new File("Output.xml"));
               validateXML myMapping = new ValidateXML();
                myMapping.execute(in, out);
    The Output.xml has the xml structure for the correct case, do I have to initialize my outputstream for the error file? say error.xml
    2. My Webservice interface is a sychronous interface (Request / Response) and output of the Java mapping program are two asynchronous interface. (I'll use a synch-asynch bridge when this works) - Is that causing a problem?
    Please help.
    Best regards,
    Varun

    Hello Varun,
    it gives me "XML not well formed error" (Problem while building the tree).
    I have come across the same error message while testing in interface mapping. My problem was when an exception occured in java mapping, the execution terminates with the messages XML not well formed error". In order to solve this issue what i did was catch the exception type TransformerException and in that catch block throw StreamTransformationException exception in main methos of mapping program i.e execute().
    eg:-                                                                               
    catch (TransformerException e) {
                   throw new StreamTransformationException("Can not write XML.", e);
    By doing this you will see the exception raised , because some times when you execute your mapping with mail() method, though it create the file, when you try to open it will give error if any exceptions occured in mapping. By using the above notation you can handle those in java mapping.
    Hope you have gone through this blog.
    [Handling and Tracing Exceptions in java mapping|http://www.sdn.sap.com/irj/scn/weblogs;jsessionid=(J2EE3417700)ID1055371050DB01666765031379427182End?blog=/pub/wlg/15061]
    Regards,
    Prasanna

  • Sychronous BPM

    My scenerio: R/3>PI>ExternalPartner via HTTPS URL. IDoc(Orders05) from R/3 will come  in Sychronous mode(Best Effort) and in PI I'm converting into xCBL format and sending to parnter. I'm  getting the functional ack xml file back immediately in the same URL. So far this design is working perfectly. Now i'm requirement is :  I've to convert  into two different output file for the IDOC which comes from R/3 in sychronous mode.
    1. Convert into xCBL format(which is the above one) and send to external parnter.
    2. Convert into another format and send back to R/3.
    I've done the above scenerio to convert the IDOC file into two different format using BPM. This in asychronous mode using BPM. But with this design, I'm not getting the functional ack file from my external partner since my message interface is asychronous mode.
    For my new requirement, I created Abstract Sychronous message interface but I'm not seeing that inside my BPM. When searched in the SDN, i understand that BPM doesn't support Abstract Sychronous message interface.
    So how to achieve this scenario.
    Thanks,

    The point you are misisng here is create  two abstract interfaces (req and response) for third party and use sync send step,so you will get response.
    Regards,
    Raj

  • Open Interface Rejects - SQL Report

    Hi guys, I'm trying to help out some folks in AP with an easier access to view Open Interface rejects. I already knew the relation between AP_INVOICES_INTERFACE and AP_INTERFACE_REJECTIONS was INVOICE_ID AND PARENT_ID (respectively). Now I've seen that some invoices also have a relation between AP_INVOICE_LINES_INTERFACE and AP_INTERFACE_REJECTIONS, same columns related (INVOICE_ID AND PARENT_ID respectively).
    What I'm having a problem with, maybe I've just been sitting here too long, but I cannot get it all into one report.
    I tried this, but it's giving me way more records than it should:
    SELECT AIR.CREATION_DATE
    , AIR.REJECT_LOOKUP_CODE
    , AII.PO_NUMBER
    , AII.GROUP_ID
    , AII.VENDOR_NUM
    , AII.INVOICE_NUM
    , AII.INVOICE_DATE
    , AII.INVOICE_AMOUNT
    , AII.SOURCE
    FROM AP.AP_INTERFACE_REJECTIONS AIR
    , AP.AP_INVOICES_INTERFACE AII
    , AP.AP_INVOICE_LINES_INTERFACE AILI
    WHERE (AII.INVOICE_ID = AIR.PARENT_ID AND AII.ORG_ID = 162)
    OR (AILI.INVOICE_ID = AIR.PARENT_ID AND AILI.ORG_ID = 162)
    Any thoughts on where I mucked it up or how I could actually go about this? What shows in the actual Open Interface app is a good start, it's just missing some fields like vendor name and reject lookup code.
    Thanks for any help!

    945273 wrote:
    Hi guys, I'm trying to help out some folks in AP with an easier access to view Open Interface rejects. I already knew the relation between AP_INVOICES_INTERFACE and AP_INTERFACE_REJECTIONS was INVOICE_ID AND PARENT_ID (respectively). Now I've seen that some invoices also have a relation between AP_INVOICE_LINES_INTERFACE and AP_INTERFACE_REJECTIONS, same columns related (INVOICE_ID AND PARENT_ID respectively).
    What I'm having a problem with, maybe I've just been sitting here too long, but I cannot get it all into one report.
    I tried this, but it's giving me way more records than it should:
    SELECT AIR.CREATION_DATE
    , AIR.REJECT_LOOKUP_CODE
    , AII.PO_NUMBER
    , AII.GROUP_ID
    , AII.VENDOR_NUM
    , AII.INVOICE_NUM
    , AII.INVOICE_DATE
    , AII.INVOICE_AMOUNT
    , AII.SOURCE
    FROM AP.AP_INTERFACE_REJECTIONS AIR
    , AP.AP_INVOICES_INTERFACE AII
    , AP.AP_INVOICE_LINES_INTERFACE AILI
    WHERE (AII.INVOICE_ID = AIR.PARENT_ID AND AII.ORG_ID = 162)
    OR (AILI.INVOICE_ID = AIR.PARENT_ID AND AILI.ORG_ID = 162)
    Any thoughts on where I mucked it up or how I could actually go about this? What shows in the actual Open Interface app is a good start, it's just missing some fields like vendor name and reject lookup code.
    Thanks for any help!I don't know the table strructures or relationships, but based on what you said, I think you want something more like:
    SELECT air.creation_date, air.reject_lookup_code, aii.po_number, aii.group_id,
           aii.vendor_num, aii.invoice_num, aii.invoice_date, aii.invoice_amount,
           aii.source
    FROM ap.ap_interface_rejections air, ap.ap_invoices_interface aii,
         ap.ap_invoice_lines_interface aili
    WHERE ali.invoice_id = alii.invoice_id and
          ali.invoice_id = air.parent_id and
          aii.org_id = 162You may need/want to add the org_cd predicate to the interfact lines as well, depending if there could be invoices with the same id in multiple orgs.
    Assuming you have the relations correct, this should give you a row for every line on every invoice that has a row in the ap_interface_rejections table. It might be worthwhile to look at the ap_interface_rejections table to see if it has an analog for the invoice line number, which could also be used in the join, to get a more specific result set.
    John

  • Logical interface in solaris 10

    Hi there,
    I need to configure logical interface in a solaris 10 3/05 server. After reading the Solaris 10 IP services manual, I am not quite sure what to do. All the examples and explanation are about using the new subcommand addif of ifconfig. It was not clear in the documentation if the setting logical interfaces via addif will persist across boot.
    Can one still configure logical interface in Solaris 10 in a more traditional way like in Solaris 8? In an Solaris 8 server I will do the following.
    Let's assume I want to configure in a solaris 8 server a logical interface named hme0:1 with IP address 192.168.20.28 with netmask 255.255.255.0 for hostname host001
    # cat /etc/hostname.hme0:1
    host001
    ^D
    # echo "192.168.20.28 host001" >> /etc/inet/hosts
    # echo "192.168.20.0 255.255.255.0" >> /etc/inet/netmasks
    # reboot -- -r
    Can one still do that in solaris 10 3/05 server?

    Hi there,
    I need to configure logical interface in a solaris 10
    3/05 server. After reading the Solaris 10 IP services
    manual, I am not quite sure what to do. All the
    examples and explanation are about using the new
    subcommand addif of ifconfig. It was not clear in the
    documentation if the setting logical interfaces via
    addif will persist across boot.No. No 'ifconfig' command is persistent.
    Can one still configure logical interface in Solaris
    10 in a more traditional way like in Solaris 8? In an
    Solaris 8 server I will do the following.
    Let's assume I want to configure in a solaris 8
    server a logical interface named hme0:1 with IP
    address 192.168.20.28 with netmask 255.255.255.0 for
    hostname host001
    # cat /etc/hostname.hme0:1
    host001
    ^D
    # echo "192.168.20.28 host001" >> /etc/inet/hosts
    # echo "192.168.20.0 255.255.255.0" >>
    /etc/inet/netmasks
    # reboot -- -r
    Can one still do that in solaris 10 3/05 server?Absolutely.
    You don't need to reboot (you can run ifconfig for this boot and let the files do the work next time) and the -r doesn't do anything with interfaces (expecially virtual interfaces) anyway.
    Darren

  • Unable to see interface on ASA 5510 Firewall

    Hi All,
    I am unable to see 4th interface on my firewall i.e fastether0/3 on my firewall ASA 5510.
    Below is the output.
    ciscoasa# sh int ip br
    Interface                  IP-Address      OK? Method Status                Protocol
    Ethernet0/0                x.x.x.x           YES CONFIG up                    up
    Ethernet0/1                x.x.x.x           YES CONFIG up                    up
    Ethernet0/2                unassigned      YES unset  administratively down down
    Internal-Control0/0        127.0.1.1       YES unset  up                    up
    Internal-Data0/0           unassigned      YES unset  up                    up
    Management0/0              192.168.1.1     YES CONFIG up                    up
    Please suggest what could be the reason.
    Regards
    Pankaj

    Hi Ramraj,
    Even i have the base license for my ASA 5510 which is showing all the 4 interfaces in sh ver. I don't think so license would be an issue. There should be some IOS code bug that needs to be upgraded. If this goes for an OS upgrade it should get resolved.
    Its not showing up in sh ver . As Karsten said he might be running on old IOS version.
    fy-a# sh ver
    Cisco Adaptive Security Appliance Software Version 8.4(4)1
    Device Manager Version 6.4(5)
    Compiled on Thu 14-Jun-12 11:20 by builders
    System image file is "disk0:/asa844-1-k8.bin"
    Config file at boot was "startup-config"
    fy-a up 1 day 1 hour
    Hardware:   ASA5510, 1024 MB RAM, CPU Pentium 4 Celeron 1600 MHz
    Internal ATA Compact Flash, 256MB
    BIOS Flash M50FW016 @ 0xfff00000, 2048KB
    Encryption hardware device : Cisco ASA-55x0 on-board accelerator (revision 0x0)
                                 Boot microcode   : CN1000-MC-BOOT-2.00
                                 SSL/IKE microcode: CNLite-MC-SSLm-PLUS-2.03
                                 IPSec microcode  : CNlite-MC-IPSECm-MAIN-2.06
                                 Number of accelerators: 1
    0: Ext: Ethernet0/0         : address is 2c54.2d0c.8f1a, irq 9
    1: Ext: Ethernet0/1         : address is 2c54.2d0c.8f1b, irq 9
    2: Ext: Ethernet0/2         : address is 2c54.2d0c.8f1c, irq 9
    3: Ext: Ethernet0/3         : address is 2c54.2d0c.8f1d, irq 9
    4: Ext: Management0/0       : address is 2c54.2d0c.8f1e, irq 11
    5: Int: Not used            : irq 11
    6: Int: Not used            : irq 5
    Licensed features for this platform:
    Maximum Physical Interfaces       : Unlimited      perpetual
    Maximum VLANs                     : 50             perpetual
    Inside Hosts                      : Unlimited      perpetual
    Failover                          : Disabled       perpetual
    VPN-DES                           : Enabled        perpetual
    VPN-3DES-AES                      : Enabled        perpetual
    Security Contexts                 : 0              perpetual
    GTP/GPRS                          : Disabled       perpetual
    AnyConnect Premium Peers          : 2              perpetual
    AnyConnect Essentials             : Disabled       perpetual
    Other VPN Peers                   : 250            perpetual
    Total VPN Peers                   : 250            perpetual
    Shared License                    : Disabled       perpetual
    AnyConnect for Mobile             : Disabled       perpetual
    AnyConnect for Cisco VPN Phone    : Disabled       perpetual
    Advanced Endpoint Assessment      : Disabled       perpetual
    UC Phone Proxy Sessions           : 2              perpetual
    Total UC Proxy Sessions           : 2              perpetual
    Botnet Traffic Filter             : Disabled       perpetual
    Intercompany Media Engine         : Disabled       perpetual
    This platform has a Base license.
    Serial Number: JMX1AXXXXX
    Running Permanent Activation Key: XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    Configuration register is 0x1
    Configuration has not been modified since last system restart.
    fy-a#
    Ramraj please do correct me if am wrong.
    Please do rate if the given information helps.
    By
    Karthik

  • ASA 5505 backup interface

    Hello,
    I have setup ASA 5505 with 2 ISP, named outside (primary)  and backup, the scenario is if outside down, then backup will take over, it works now.
    But it is not working when the primary connection cannot reach the gateway with the interface still up.
    Is it possible when the primary connection cannot reach the gateway then backup automatically take over?
    Thanks before..
    My configuration is:
    ASA Version 8.2(1)
    hostname cisco
    domain-name default_domain
    enable password ********* encrypted
    passwd ********* encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 172.10.10.10 255.255.255.0
    interface Vlan3
    no forward interface Vlan2
    nameif backup
    security-level 0
    ip address 172.20.10.10 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 1
    interface Ethernet0/1
    switchport access vlan 2
    interface Ethernet0/2
    switchport access vlan 3
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default domain
    same-security-traffic permit intra-interface
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu backup 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (inside) 1 interface
    global (outside) 1 interface
    global (backup) 1 interface
    nat (inside) 1 192.168.1.0 255.255.255.0
    access-group inside_out in interface inside
    access-group outside_in in interface outside
    access-group backup_in in interface backup
    route outside 0.0.0.0 0.0.0.0 172.10.10.1 1
    route backup 0.0.0.0 0.0.0.0 172.20.10.1 254
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd lease 1048575
    dhcpd auto_config outside
    dhcpd address 192.168.1.100-192.168.1.200 inside
    dhcpd dns 8.8.8.8 8.8.4.4 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect icmp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:24af050f332deab3e38eb578f8081d05
    : end

    Hi Amrin,
    you can configure SLA monitoring on ASA and that woudl work fine for you:
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00806e880b.shtml
    Hope that helps.
    Thanks,
    Varun

  • Run SAP PI Interfaces 24X7. How

    How I can run PI Interfaces 24X7 to achieve Business Continuity.
    The solution provided as u2013
         Install Separate additional PI System u2013 called as Federation PI.
    Is this solution really applicable?
    Details:
    1.     Our Current Production Landscape holds only One PI System
    2.     These interfaces hold Critical, Sensitive Finance, employee Data posting to ECC etc.
    3.     HA options are available and Planned Outages are communicated with Non-SAP Process teams.
    4.     No performance issues.
    5.     PI Scaling is in progress to balance load on PI System.
    Requirement: We seek PI Production System up and running 24X7 for all above interfaces with out any interruption.
    Below Issues: Makes our PI Production System Shut-down for certain period
    1.     Planned outages
    2.     Un-planned outages
    3.     Upgrades
    4.     Allowed Down-time
    5.     SPOF
    Solution: Federation of SAP PI
    1.     A very good solution u2013 so that we can switch to another PI System when first PI system is down for any reason.
    2.     We need to maintain IR, ID objects of interfaces that we planned for 24X7 in both PI Systems.
    3.     Communication Channels are active in only One PI system.
    4.     Manual activation of Communication Channels is required when we plan to switch Second PI Server.
    That Implies
    5.     There is minimum amount of downtime is present.
    6.     So, 24X7 of runtime is not achievable.
    My Only one Question:
    Is there any automated procedure for this runtime procedure..!!?
    Switching in between PI Systems might be possible.
    But, how we can implement activation of CC in Second PI System with out manual interaction?

    Hi,
    Currently we are about to start the POC for my client, and the scenarion is like this
    We have a ECC system( which will send the IDOC ) and it will be received by my central PI system.( which is is in UK).
    The client is present in multiple locations( UK,AUS,US), they want to install the additional PI boxes in AUS and US and they want to have a federation with central PI system which present in UK.
    we have two scenarios.
    1) The IDOC will trigger from ECC and then it will go to central PI system and then it has to go to local PI system and then to the third party system.
    2) The IDOC will trigger from ECC system and then it has to go to the local PI and then to the central PI box and then to the third party system.
    Can you please let me know how can achieve these two scenarios and how to install local PI boxes in federation with the central PI box.
    Regards,
    Pradeep J

  • I am trying to transfer sound created on a Fantom X7 to my mac and garage band and have gotten so many different directions from others regarding the mode of connection - I am trying to use an interface and usb connection - anybody have advice?

    Good morning!
    I am trying to transfer sound from a FantomX7 keyboard synthesizer to garageband  through an interface (MAudio) and with a usb cable.  I see the image of the sound being recorded but I cannot hear anything - I know that there is a speaker button somewhere that must be muted - but I can't find it .  Can anyone tell me what I am doing wrong.  thanks, Musicmimi.

    Good morning!
    I am trying to transfer sound from a FantomX7 keyboard synthesizer to garageband  through an interface (MAudio) and with a usb cable.  I see the image of the sound being recorded but I cannot hear anything - I know that there is a speaker button somewhere that must be muted - but I can't find it .  Can anyone tell me what I am doing wrong.  thanks, Musicmimi.

  • Problems access to a web application (Web Interface or Web report)

    Hi,
    We found problems with the access to web application. Some users have problems with direct links to the web applications(Web Interface or Web reporting), when they click on the link an error message appears, the message displays the following text:
    "Cannot open file Bex?sap-language=ENbsplanguge=ENcmd=idoc_TE.."
    Clicking in details the message is "No Access to specified file"
    For this users the access to excel reporting is correct, the message appears when they click on the direct web links through the browser or directly in BW system, but if they type the URL they can access. Other users can use the direct web link without problems.
    I highly appreciate any help or idea about how to solve this issue.
    Thanks in advance.

    HI,
    please ask to your basis that check the language of every single user on su01 tx.
    This is the problem i think.
    Natalia.

  • AP error while submitting "Payable Open interface"

    Hello,
    I am trying to run the request 'Payables open interface'. I got the output once and the error was because the supplier site was invalid. I created a supplier site saved it and ran the request again. Now, I am getting the following error.
    Payables: Version : 11.5.0 - Development
    Copyright (c) 1979, 1999, Oracle Corporation. All rights reserved.
    APXIIMPT module: Payables Open Interface Import
    Current system time is 21-JUN-2009 08:15:01
    +-----------------------------
    | Starting concurrent program execution...
    +-----------------------------
    Arguments
    p_source='SQLLDR'
    p_batch_name='N/A'
    p_purge_flag='N'
    p_trace_switch='N'
    p_debug_switch='N'
    p_summary_flag='N'
    p_commit_batch_size='1000'
    p_user_id='1007990'
    p_login_id='2532036'
    APPLLCSP Environment Variable set to :
    XML_REPORTS_XENVIRONMENT is :
    /u02/applmgr/lmtestora/8.0.6/guicommon6/tk60/admin/Tk2Motif_UTF8.rgb
    XENVIRONMENT is set to: /u02/applmgr/lmtestora/8.0.6/guicommon6/tk60/admin/Tk2Motif_UTF8.rgb
    Current NLS_LANG and NLS_NUMERIC_CHARACTERS Environment Variables are :
    American_America.UTF8
    Spawned Process 1752
    MSG-01104: (Before Report) Modified file
    MSG-00000: p_purge_flag :N
    MSG-00000: c_nls_yes :Yes
    MSG-00000: c_nls_no :No
    MSG-00000: p_summary_flag :N
    MSG-00000: p_nls_summary :No
    MSG-00000: p_nls_purge :No
    REP-1419: 'beforereport': PL/SQL program aborted.
    Report Builder: Release 6.0.8.27.0 - Production on Sun Jun 21 08:15:02 2009
    (c) Copyright 1999 Oracle Corporation. All rights reserved.
    Enter Username:
    Start of log messages from FND_FILE
    End of log messages from FND_FILE
    Program exited with status 1
    Concurrent Manager encountered an error while running Oracle*Report for your concurrent request 2776668.
    Review your concurrent request log and/or report output file for more detailed information.
    Executing request completion options...
    Finished executing request completion options.
    Concurrent request completed
    I am trying this for first time. Any help is highly appreciated.
    Thanks.

    Hi,
    Please go through the following documents and see if it helps.
    Note: 107628.1- Payables Open Interface Invoice Import Troubleshooting Guide (APXIIMPT)
    https://metalink2.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=107628.1
    Note: 220355.1- APXIIMPT-Payables Open Interface Import Fails Rep-1419:'Beforereport' : Pl/Sql Program Aborted
    https://metalink2.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=220355.1
    Regards,
    Hussein

  • Facing issues in Payables Open Interface Import Program

    Hi,
    We have a requirement of calling Payables Open Interface Import Program from Pl/sql package.
    Invoices are getting created.
    But the issue is when we query our invoice from invoice workbench and we try to view  the record history (help->record history)
    We are getting the error as ‘fdxwho failed due to ORA-01403’.
    The code is
    l_num_req_id :=
                fnd_request.submit_request
                                          (application      => 'SQLAP',
                                           program          => 'APXIIMPT',
                                           argument1        => fnd_global.org_id,
                                           -- org_id
                                           argument2        =>l_chr_source, 
                                           -- Invoice source
                                           argument3        => NULL,
                                           argument4        => l_chr_batch_name,
                                           -- Batch Name
                                           argument5        => NULL,
                                           argument6        => NULL,
                                           --  Hold Raeson
                                           argument7        => NULL,    -- GL Date
                                           argument8        => 'N',
                                           argument9        => 'N',
                                           argument10       => 'N',
                                           argument11       => 'N',
                                           argument12       => '1000',
                                           argument13       => fnd_global.user_id,
                                           argument14       => fnd_global.login_id
    Regards
    Suresh

    Hi,
    Please review notes:
    APP-01564 ORA-01403 in FDXWHO In Any Payables Form (Doc ID 1077762.6)
    "APP-FND-01564 ORACLE error 1403 in fdxwho" in Record History (Doc ID 879528.1)
    Thanks &
    Best Regards,

  • Error when running Payables Open Interface Import

    Hi Experts,
    I need help. I'm facing a problem when run Payables open interface import. Before that, I was running same concurrent many times and the concurrent program is completed normal. But, when I try again I'm getting error. what exacly problem is? What should I do?
    arguments
    p_org_id='84'
    p_sources='manual invoice entry'
    p_batch_name='N/A,
    p_purge_flag='Y'
    p_trace_switch='N'
    p_debug_switch='Y'
    p_summary_flag='Y'
    p_commit_batch_size='1000'
    p_user_id='1110'
    p_login_id='75025'
    Current NLS_NUMERIC_CHARACTERS Envirotment Variables are :
    American_America.US7ASCII
    Enter Password:
    REP-0004 : Warning : Unable to open user preference file.
    MSG-00001 : (Before Report) After SRWINIT
    MSG-00002 : (Before Report) After Get_Company_Name
    MSG-00003 : (Before Report) After Get_NLS_Strings
    MSG-00001 : (Get Base Curr data 1) Get Base Currency Information
    MSG-00004 : (Before Report) After Get_Base_Curr_Data
    MSG-00005 : After Get Operating Unit
    MSG-00006 : After Get Purge Flag
    MSG-00002 : (Before Report Trigger 1) Import Invoices.
    MSG-00003 : (Before Report Trigger 3) Exception : When Others.
    REP-1419 : 'beforereport' : PL/SQL program aborted.
    REP-0069 : Internal Error
    REP-57054 : In-process job terminated: Terminated with error:
    REP-1419 : MSG-00001 : (Before Report) After SRWINIT
    MSG-00002 : (Before Report) After Get_Company_Name
    MSG-00003 : (Before Report) After Get_NLS_Strings
    MSG-00001 : (Get Base Curr data 1) Get Base Currency Information
    MSG-00004 : (Before Report) After Get_Base_Curr_Data
    MSG-00005 : After Get Operating Unit
    MSG-00006 : After Get Purge Flag
    MSG-00002 : (Before Report Trigger 1) Import Invoices.
    MSG-00003 : (Before Report Trigger
    Best Regards,
    Ade Hilman

    Hi Ade;
    Please check below note which is mention similar error
    Validate AAD fails with ORA-20001: -: XLA-95103: An internal error occurred. [ID 943024.1]
    Hope it helps
    Regard
    Helios

  • Issue with Supplier Open Interface Import Program

    Hello Folks,
    I need help with supplier conversion. I am trying to load suppliers through the supplier open interface program. I see that the record got rejected in AP_SUPPLIERS_INT table with status as REJECTED. However i do not see the record in AP_SUPPLIER_INT_REJECTIONS. Therefore, i am not able to understand the rejection reason. I enabled debug can seeing this log..
    assign_party_usage (+)
    do_assign_party_usage (+)
    effective_start_date = 2011/05/12 effective_end_date = 4712/12/31
    duplicates_exist (+)
    No date tracking for this usage SUPPLIER. Check duplicate assignment.
    l_has_duplicates = Y
    duplicates_exist (-)
    assign_party_usage (-)
    Rejected Vendor_Interface_Id: 15004, No. of Messages from Create_Vendor API: 2, Message From Create_Vendor API:
    Enter Password:
    REP-0004: Warning: Unable to open user preference file.
    MSG-00999: Custom Report
    MSG-00001: After SRWINIT
    MSG-00002: After Get_Company_Name
    MSG-00003: After Get_NLS_Strings
    MSG-00004: After Importing Suppliers
    MSG-00005: After Get_Header_Information
    MSG-00020: After SRWEXIT
    As per my understanding from the log, there is some problem with party_usage_assignment. I would really appreciate is someone can help me debug the exact problem. Else i would have to open a SR for this
    Thanks so much looking forward for your answers.

    Pl post details of OS, database and EBS versions.
    Pl see if MOS Doc 1060824.1 (R12: Supplier Open Interface APXSUIMP Errors with REP-0004 Output Does Not Indicate Reason for Rejection) is applicable
    HTH
    Srini

Maybe you are looking for