Tiered QOS

Hi,
I am trying to mark packets at VAI interfaces and then use this markings to
classify traffic in different classes when they exit the router downstream
to carrier. I dont see packet being classified at physical interface yet
the ip precedence accounting shows correct marking
this is on 7200 12.2(33)SRE6 SP services and have also tried on 12.4 T but same results.
Scenario:
Traffic IN >>> LNS>>> VAI (policy outbound mark traffic) >>> Physical
interface >>(Shaping + queueing)
Configuration
VAI Class-maps and policy-map
class-map match-all GOLD
match access-group 101
class-map match-all SILVER
match access-group 102
access-list 101 permit icmp host 111.111.111.111 any
access-list 102 permit icmp host 222.222.222.222 any
policy-map STD_POLICY1
class GOLD
set dscp af21
class SILVER
set dscp af22
class class-default
Show commands for VAI
LNS#show policy-map session
SSS session identifier 7 -
Service-policy output: STD_POLICY1
Class-map: GOLD (match-all)
4135 packets, 4522926 bytes
30 second offered rate 9000 bps, drop rate 0000 bps
Match: access-group 101
QoS Set
dscp af21
Packets marked 4138
Class-map: SILVER (match-all)
3649 packets, 3831450 bytes
30 second offered rate 9000 bps, drop rate 0000 bps
Match: access-group 102
QoS Set
dscp af22
Packets marked 3653
Class-map: class-default (match-any)
418 packets, 37270 bytes
30 second offered rate 0000 bps, drop rate 0000 bps
Match: any
LNS# show access-lists
Extended IP access list 101
10 permit icmp host 111.111.111.111 any (4171 matches)
Extended IP access list 102
10 permit icmp host 222.222.222.222 any (3685 matches)
====
Physical Interface Class-map and policy-map Configuration:
class-map match-all EF
match dscp ef
class-map match-any CS1
match dscp af11
match dscp af12
match dscp af13
class-map match-any CS2
match dscp af21
match dscp af22
match dscp af23
match dscp cs2
class-map match-any CS3
match dscp af31
match dscp af32
match dscp af33
class-map match-any CS4
match dscp af41
match dscp af42
match dscp af43
policy-map CHILD_POLICY
class EF
priority percent 10
class CS4
bandwidth percent 30
random-detect dscp-based
fair-queue
class CS3
bandwidth percent 20
random-detect dscp-based
fair-queue
class CS2
bandwidth percent 10
fair-queue
random-detect dscp-based
class CS1
bandwidth percent 5
fair-queue
random-detect dscp-based
class class-default
>> Shaping policy
policy-map PARENT_1M_POLICY
class class-default
shape average 1000000
service-policy CHILD_POLICY
SHOW COMMANDS FOR PHYSICAL INT
LNS# show policy-map interface
FastEthernet0/0
Service-policy output: PARENT_1M_POLICY
Class-map: class-default (match-any)
1148 packets, 90689 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 8439/7685662
shape (average) cir 1000000, bc 4000, be 4000
target shape rate 1000000
Service-policy : CHILD_POLICY
queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0
Class-map: EF (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: dscp ef (46)
Priority: 10% (100 kbps), burst bytes 2500, b/w exceed drops: 0
Class-map: CS4 (match-any)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: dscp af41 (34)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp af42 (36)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp af43 (38)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0
(pkts output/bytes output) 0/0
bandwidth 30% (300 kbps)
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
dscp Transmitted Random drop Tail/Flow drop
Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes
thresh thresh prob
Fair-queue: per-flow queue limit 16
Class-map: CS3 (match-any)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: dscp af31 (26)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp af32 (28)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp af33 (30)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0
(pkts output/bytes output) 0/0
bandwidth 20% (200 kbps)
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
dscp Transmitted Random drop Tail/Flow drop
Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes
thresh thresh prob
Fair-queue: per-flow queue limit 16
Class-map: CS2 (match-any)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: dscp af21 (18)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp af22 (20)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp af23 (22)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp cs2 (16)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0
(pkts output/bytes output) 0/0
bandwidth 10% (100 kbps)
Fair-queue: per-flow queue limit 16
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
dscp Transmitted Random drop Tail/Flow drop
Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes
thresh thresh prob
Class-map: CS1 (match-any)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: dscp af11 (10)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp af12 (12)
0 packets, 0 bytes
5 minute rate 0 bps
Match: dscp af13 (14)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0
(pkts output/bytes output) 0/0
bandwidth 5% (50 kbps)
Fair-queue: per-flow queue limit 16
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
dscp Transmitted Random drop Tail/Flow drop
Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes
thresh thresh prob
Class-map: class-default (match-any)
1148 packets, 90689
bytes #####PACKETS
MATCHING HERE INSTEAD OF CLASSES ABOVE
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 8439/7685662
###PRECEDENCE ACCOUNTING
LNS# show int fa0/0 precedence
FastEthernet0/0
Output
Precedence 0: 697 packets, 46002 bytes
Precedence 2: 7062 packets, 7697580 bytes
Precedence 6: 430 packets, 51888 bytes
So in short the VAI policy is marking packet correctly, IP precedence
accounting shows hits but on the main policy it skips its..
Interestingly if i remove VAI policy and mark the packets from an upstream
router using extended pings they are identified by the physical interface
correctly and matches against appropriate classes.
Any hints will be appreciated.
Cheers
Hitesh

Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Logically, what you're doing makes sense, but only Cisco "knows" how their queuing really works.  I've long suspected their embedded CBWFQ shapers have their own queues, which you may not have direct control over for setting their queue depths.
Yes, logically, there's a relationship between bandwidth (including shaping) and queue limits, but it depends on multiple factors.  Shaping is also a special case, because although you're trying to emulate a certain link bandwidth, it's not the same.

Similar Messages

  • WAN multi-site traffic shaping/QoS setup

    We have multiple sites connected to a private WAN cloud (Layer 2) with varying CIR's.  Our QoS setup from our main site is 3 tiered in order to shape traffic to our overall CIR at the main site and shape traffic on different child classes based on the remote CIR.  Parent policy is applied to interface connected to the service provider.  We continue to have drops even though we don't seem to be reaching the CIRs for the remote sites or the CIR limit on the ciruit.  I've worked with TAC and we have adjusted queue limits based on drops but this is an ongoing issue.  Should there be a relationship between the queue limits and shape averages?
    Sample config
    NOTE: Shape averages are 95% of CIR
    Policy-map Parent
    class class-default
      shape average 142500000
      queue-limit 1024 packets
       service-policy ASE-Remotes-Policy
    policy-map ASE-Remotes-Policy
    Class site1
    shape average 4750000
      queue-limit 400 packets
       service-policy ASE-QoS-Policy
    Class site2
    shape average 19000000
      queue-limit 1024 packets
       service-policy ASE-QoS-Policy
    class site 3
    shape average 95000000
      queue-limit 1024 packets
       service-policy ASE-QoS-Policy
    multiple other sites
    policy-map ASE-QoS-Policy
     class VoIP
      priority percent 40
      queue-limit 1024 packets
     class Citrix
      bandwidth percent 40
      queue-limit 1024 packets
     class class-default
      queue-limit 1024 packets

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    Logically, what you're doing makes sense, but only Cisco "knows" how their queuing really works.  I've long suspected their embedded CBWFQ shapers have their own queues, which you may not have direct control over for setting their queue depths.
    Yes, logically, there's a relationship between bandwidth (including shaping) and queue limits, but it depends on multiple factors.  Shaping is also a special case, because although you're trying to emulate a certain link bandwidth, it's not the same.

  • Question Regarding QoS and Firewalls Rules

    Hello experts, I hope a simple question for you today. I am working to elevate our outdated H323 traffic down a VPN tunnel we are only getting 600k throughput on.
    Under "Networking --> QOS --> WAN QOS" I have configured the downstream and upstream bandwidth rates using the 85% rule. I have also created a bandwidth profile called VOIP using 128-256kbps with a priority of "High"
    Under "Traffic Selector" I have created the profile using the VLAN 100 for the IP phones with the VOIP bandwidth profile.
    My question, is this the correct configuration and I'm done? Or do I need to go further and create the same IPv4 rules in the firewall rules giving it a QoS Priority of "Minimize Delay"
    Is there a way in SA540 to see the QOS statistics to see if they are working correctly?  I appreciate your input as always experts!!

    It's about the relevance of the link. Some will post a vague link to the SAP help that adds no value to anyone trying to find the answer to the question, whereas a targeted link to a - possibly difficult to find - page can be very useful.
    It's a bit of a subjective thing, example:
    A detailed question asks about technical info behind assigning a cost center to an organizational unit in the org chart.
    A reply such as:
    Check [this link|http://help.sap.com/saphelp_erp60_sp/helpdata/en/0b/dfba3692dc635ce10000009b38f839/frameset.htm].
    Is just wasting everyone's time. Unfortunately we see a lot of these, people seem to think it's a quick way of getting cheap points but it just frustrates everyone else.
    Asimilar answer can however be very useful if it contains a targeted link that relates directly to the question, e.g.
    See the help on [account assignment infotypes|http://help.sap.com/saphelp_erp60_sp/helpdata/en/bb/bdb2b6575911d189240000e8323d3a/frameset.htm].
    However a generic link as per my first example as part of a detailed explanation with a comment of "further info can be found over here" is a good post since the purpose of the link it more for convenience or reference info in addition to the answer in the post.
    Hope that helps,
    Mike

  • Cisco Jabber Client - QoS Config

    Hi Guys,
    I'll be deploying the new jabber client for a customer and i'm unsure of what QoS to configure on the switch ports for end users. Users will also have 7942 handsets, so if i configure auto qos voip cisco-phone, I doubt this will protect the voice/video for Jabber.
    Has anyone got any config or tips they can share?
    Cheers,
    James

    Hi,
    I believe you can use "auto qos voip cisco-softphone"
    Please see below QOS SRND.
    http://www.cisco.com/univercd/cc/td/doc/solution/esm/qossrnd.pdf
    Regards
    Ronak

  • Cisco 7206 has with LLQ QOS and cpu 85 %

    hi all ,
    i want to mention issue about cisco router 7206 npeg2 :
    can this router handle traffic  780 Mbps  as download  and 75 MBps as upload ?? with cpu 85 % and with LLQ  qos ??
    im asking this question because my QOS althoug it matched alot of traffic , it some time get slow and seems that QOS not working fine , im sure that my work is  fine, because it was fine , but recent days i added more bw   ???!!!!!
    dont know if  need more memory for router for QOS :
    ===============================================================
    7200Gateway#sh memory
                    Head    Total(b)     Used(b)     Free(b)   Lowest(b)  Largest(b)
    Processor    6B97A80   1883669308   114125456   1769543852   1768174580   1760364316
          I/O   78000000    67108864     4482572    62626292    62598896    62617884
    Transient   77000000    16777216       22196    16755020    16222412    16728368
              Processor memory
    Address      Bytes     Prev     Next Ref     PrevF    NextF Alloc PC  what
    06B97A80 0000010004 00000000 06B9A1C4 001  -------- -------- 01A493D8  CEF: fib
    06B9A1C4 0000000028 06B97A80 06B9A210 000  87F3D04  87FD620  015FC24C  AAA Attr Binary/String
    06B9A210 0000004700 06B9A1C4 06B9B49C 001  -------- -------- 01AC85B4  ADJ: adjacency
    06B9B49C 0000004100 06B9A210 06B9C4D0 001  -------- -------- 0011245C  HTTP CORE
    06B9C4D0 0000004100 06B9B49C 06B9D504 001  -------- -------- 00112548  HTTP CORE
    06B9D504 0000004100 06B9C4D0 06B9E538 001  -------- -------- 00112548  HTTP CORE
    06B9E538 0000004100 06B9D504 06B9F56C 001  -------- -------- 00112548  HTTP CORE
    06B9F56C 0000004100 06B9E538 06BA05A0 001  -------- -------- 00112548  HTTP CORE
    06BA05A0 0000000756 06B9F56C 06BA08C4 001  -------- -------- 0343C38C  Process
    06BA08C4 0000000204 06BA05A0 06BA09C0 001  -------- -------- 0343FAB4  Process Events
    06BA09C0 0000022764 06BA08C4 06BA62DC 001  -------- -------- 04055CB4  IPSM Octet Str
    06BA62DC 0000014488 06BA09C0 06BA9BA4 001  -------- -------- 0405C0C4  ipsm IPSEC Fai
    06BA9BA4 0000004100 06BA62DC 06BAABD8 001  -------- -------- 00112548  H
    ===========================================================================
    ==========================================
    7200Gateway#sh version
    Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 12.4(24)T7, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2012 by Cisco Systems, Inc.
    Compiled Tue 28-Feb-12 12:53 by prod_rel_team
    ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)
    7200Gateway uptime is 2 weeks, 5 days, 19 hours, 43 minutes
    System returned to ROM by power-on
    System image file is "disk2:/c7200p-adventerprisek9-mz.124-24.T7.bin"
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    If you require further assistance please contact us by sending email to
    [email protected].
    Cisco 7206VXR (NPE-G2) processor (revision A) with 1966080K/65536K bytes of memory.
    Processor board ID 13252317
    MPC7448 CPU at 1666Mhz, Implementation 0, Rev 2.2
    6 slot VXR midplane, Version 2.0
    Last reset from power-on
    PCI bus mb1 (Slots 1, 3 and 5) has a capacity of 600 bandwidth points.
    Current configuration on bus mb1 has a total of 0 bandwidth points.
    This configuration is within the PCI bus capacity and is supported.
    PCI bus mb2 (Slots 2, 4 and 6) has a capacity of 600 bandwidth points.
    Current configuration on bus mb2 has a total of 0 bandwidth points.
    This configuration is within the PCI bus capacity and is supported.
    Please refer to the following document "Cisco 7200 Series Port Adaptor
    Hardware Configuration Guidelines" on Cisco.com <http://www.cisco.com>
    for c7200 bandwidth points oversubscription and usage guidelines.
    1 FastEthernet interface
    3 Gigabit Ethernet interfaces
    2045K bytes of NVRAM.
    250880K bytes of ATA PCMCIA card at slot 2 (Sector size 512 bytes).
    65536K bytes of Flash internal SIMM (Sector size 512K).
    Configuration register is 0x2102
    ==============================================================
    7200Gateway#sh processes cpu
    CPU utilization for five seconds: 85%/84%; one minute: 84%; five minutes: 84%
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
       1          32         416         76  0.00%  0.00%  0.00%   0 Chunk Manager   
       2       32788      342520         95  0.00%  0.05%  0.05%   0 Load Meter      
       3           0           1          0  0.00%  0.00%  0.00%   0 chkpt message ha
       4           0           1          0  0.00%  0.00%  0.00%   0 EDDRI_MAIN      
       5     2624584      213262      12306  0.00%  0.03%  0.04%   0 Check heaps     
       6          56         373        150  0.00%  0.00%  0.00%   0 Pool Manager    
       7           0           2          0  0.00%  0.00%  0.00%   0 Timers          
       8           0           2          0  0.00%  0.00%  0.00%   0 ATM AutoVC Perio
       9           0           2          0  0.00%  0.00%  0.00%   0 ATM VC Auto Crea
      10          16       28543          0  0.00%  0.00%  0.00%   0 IPC Dynamic Cach
      11           0           1          0  0.00%  0.00%  0.00%   0 IPC Zone Manager
      12         688     1670887          0  0.00%  0.00%  0.00%   0 IPC Periodic Tim
      13         520     1670887          0  0.00%  0.00%  0.00%   0 IPC Deferred Por
      14           0           1          0  0.00%  0.00%  0.00%   0 IPC Seat Manager
      15           0           1          0  0.00%  0.00%  0.00%   0 IPC BackPressure
      16     9007072    30711869        293  1.35%  0.15%  0.11%   0 EnvMon          
      17           0           1          0  0.00%  0.00%  0.00%   0 OIR Handler     
      18           0           1          0  0.00%  0.00%  0.00%   0 Crash writer    
      19        1380        3892        354  0.00%  0.00%  0.00%   0 ARP Input       
      20        1584     1784473          0  0.00%  0.00%  0.00%   0 ARP Background  
      21           0           2          0  0.00%  0.00%  0.00%   0 ATM Idle Timer  
      22           0           1          0  0.00%  0.00%  0.00%   0 CEF MIB API     
      23           4         134         29  0.00%  0.00%  0.00%   0 AAA high-capacit
      24           0           1          0  0.00%  0.00%  0.00%   0 AAA_SERVER_DEADT
      25           0           1          0  0.00%  0.00%  0.00%   0 Policy Manager  
      26           0           2          0  0.00%  0.00%  0.00%   0 DDR Timers      
      27           0           5          0  0.00%  0.00%  0.00%   0 Entity MIB API  
      28           0           2          0  0.00%  0.00%  0.00%   0 Serial Backgroun
      29           0           1          0  0.00%  0.00%  0.00%   0 RO Notify Timers
      30           0           1          0  0.00%  0.00%  0.00%   0 RMI RM Notify Wa
      31          28         281         99  0.00%  0.00%  0.00%   0 EEM ED Syslog   
      32           0           2          0  0.00%  0.00%  0.00%   0 SMART           
      33         724     1712571          0  0.00%  0.00%  0.00%   0 GraphIt         
      34           0           2          0  0.00%  0.00%  0.00%   0 Dialer event    
      35           0           1          0  0.00%  0.00%  0.00%   0 SERIAL A'detect 
      36           0           2          0  0.00%  0.00%  0.00%   0 XML Proxy Client
      37           0           2          0  0.00%  0.00%  0.00%   0 VSA background  
      38           0           1          0  0.00%  0.00%  0.00%   0 VSA Cleanup Proc
      39           0           1          0  0.00%  0.00%  0.00%   0 Critical Bkgnd  
      40        4348      444483          9  0.00%  0.00%  0.00%   0 Net Background  
      41           0           2          0  0.00%  0.00%  0.00%   0 IDB Work        
      42          32         501         63  0.00%  0.00%  0.00%   0 Logger          
      43        1236     1710802          0  0.00%  0.00%  0.00%   0 TTY Background  
      44       16504     1712627          9  0.07%  0.00%  0.00%   0 Per-Second Jobs 
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
      45          20          34        588  0.00%  0.00%  0.00%   0 IF-MGR control p
      46           8          40        200  0.00%  0.00%  0.00%   0 IF-MGR event pro
      47           0           1          0  0.00%  0.00%  0.00%   0 Inode Table Dest
      48           0           1          0  0.00%  0.00%  0.00%   0 IKE HA Mgr      
      49           0           1          0  0.00%  0.00%  0.00%   0 IPSEC HA Mgr    
      50           4           4       1000  0.00%  0.00%  0.00%   0 rf task         
      51       12808      179149         71  0.00%  0.00%  0.00%   0 Net Input       
      52        1304      342532          3  0.00%  0.00%  0.00%   0 Compute load avg
      53      610136       28974      21058  0.00%  0.00%  0.00%   0 Per-minute Jobs 
      54           0           1          0  0.00%  0.00%  0.00%   0 Token Daemon    
      55           4       10570          0  0.00%  0.00%  0.00%   0 Transport Port A
      56        1272      505453          2  0.00%  0.00%  0.00%   0 HC Counter Timer
      57           0           1          0  0.00%  0.00%  0.00%   0 Coproc Event Pro
      58           0           1          0  0.00%  0.00%  0.00%   0 POS APS Event Pr
      59           0           1          0  0.00%  0.00%  0.00%   0 SONET alarm time
      60           0           1          0  0.00%  0.00%  0.00%   0 CSP Timer       
      61         204           4      51000  0.00%  0.00%  0.00%   0 USB Startup     
      62           0           2          0  0.00%  0.00%  0.00%   0 FPD Management P
      63           0           1          0  0.00%  0.00%  0.00%   0 FPD Action Proce
      64           0           2          0  0.00%  0.00%  0.00%   0 VNM DSPRM MAIN  
      65           0           1          0  0.00%  0.00%  0.00%   0 RF_INTERDEV_DELA
      66           0           1          0  0.00%  0.00%  0.00%   0 RF_INTERDEV_SCTP
      67         464     1712577          0  0.00%  0.00%  0.00%   0 ISA Common Helpe
      68           0           2          0  0.00%  0.00%  0.00%   0 Flash MIB Update
      69           0          58          0  0.00%  0.00%  0.00%   0 Flash Card Oir  
      70           0           1          0  0.00%  0.00%  0.00%   0 CES Line Conditi
      71           0           1          0  0.00%  0.00%  0.00%   0 CF_INTERDEV_SCTP
      72           0           1          0  0.00%  0.00%  0.00%   0 Async write proc
      73           0           2          0  0.00%  0.00%  0.00%   0 Ethernet CFM    
      74         736     1670893          0  0.00%  0.00%  0.00%   0 Ethernet Timer C
      75           0           1          0  0.00%  0.00%  0.00%   0 delayed evt hand
      76          28         112        250  0.00%  0.00%  0.00%   0 AAA Server      
      77           0           1          0  0.00%  0.00%  0.00%   0 AAA ACCT Proc   
      78           0           1          0  0.00%  0.00%  0.00%   0 ACCT Periodic Pr
      79           0           2          0  0.00%  0.00%  0.00%   0 AAA Dictionary R
      80         744     1670882          0  0.00%  0.00%  0.00%   0 BGP Scheduler   
      81           0           2          0  0.00%  0.00%  0.00%   0 Ethernet OAM Pro
      82           0           2          0  0.00%  0.00%  0.00%   0 Ethernet LMI    
      83           0           2          0  0.00%  0.00%  0.00%   0 CEF switching ba
      84        3684       14726        250  0.00%  0.00%  0.00%   0 ADJ resolve proc
      85           8          30        266  0.00%  0.00%  0.00%   0 IP ARP Adjacency
      86           0           1          0  0.00%  0.00%  0.00%   0 IP ARP Retry Age
      87     3481296     6804010        511  0.00%  0.02%  0.01%   0 IP Input        
      88           0           1          0  0.00%  0.00%  0.00%   0 ICMP event handl
      89           0           9          0  0.00%  0.00%  0.00%   0 TurboACL        
      90           0           2          0  0.00%  0.00%  0.00%   0 TurboACL chunk  
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
      91           0           1          0  0.00%  0.00%  0.00%   0 IPv6 Echo event 
      92          16        2854          5  0.00%  0.00%  0.00%   0 MOP Protocols   
      93           0           1          0  0.00%  0.00%  0.00%   0 LSP Tunnel FRR  
      94           0           1          0  0.00%  0.00%  0.00%   0 MPLS Auto-Tunnel
      95           0           3          0  0.00%  0.00%  0.00%   0 PPP Hooks       
      96           0           1          0  0.00%  0.00%  0.00%   0 Async write proc
      97           0           1          0  0.00%  0.00%  0.00%   0 SSS Manager     
      98           0           1          0  0.00%  0.00%  0.00%   0 SSS Feature Mana
      99           0           1          0  0.00%  0.00%  0.00%   0 SSS Feature Time
    100           0           2          0  0.00%  0.00%  0.00%   0 Spanning Tree   
    101           0           1          0  0.00%  0.00%  0.00%   0 X.25 Encaps Mana
    102          20          96        208  0.00%  0.00%  0.00%   0 SSM connection m
    103           0           1          0  0.00%  0.00%  0.00%   0 AC Switch       
    104           4        5709          0  0.00%  0.00%  0.00%   0 Authentication P
    105           0           1          0  0.00%  0.00%  0.00%   0 Auth-proxy AAA B
    106           0           2          0  0.00%  0.00%  0.00%   0 EAPoUDP Process 
    107           0           2          0  0.00%  0.00%  0.00%   0 IP Host Track Pr
    108           0           2          0  0.00%  0.00%  0.00%   0 KRB5 AAA        
    109        1152       49386         23  0.00%  0.00%  0.00%   0 IP Background   
    110        2276       28582         79  0.00%  0.00%  0.00%   0 IP RIB Update   
    111          60       34442          1  0.00%  0.00%  0.00%   0 CEF background p
    112        6784     2485297          2  0.00%  0.00%  0.00%   0 CEF: IPv4 proces
    113          12         104        115  0.00%  0.00%  0.00%   0 ADJ background  
    114           0           2          0  0.00%  0.00%  0.00%   0 PPP IP Route    
    115           0           2          0  0.00%  0.00%  0.00%   0 PPP IPCP        
    116           0           1          0  0.00%  0.00%  0.00%   0 IP Traceroute   
    117        7292     7550370          0  0.00%  0.00%  0.00%   0 TCP Timer       
    118        1300       10511        123  0.00%  0.00%  0.00%   0 TCP Protocols   
    119           0           1          0  0.00%  0.00%  0.00%   0 Socket Timers   
    120       18228       11429       1594  0.00%  0.00%  0.00%   0 HTTP CORE       
    121           0           2          0  0.00%  0.00%  0.00%   0 RLM groups Proce
    122           0           1          0  0.00%  0.00%  0.00%   0 L2X Data Daemon 
    123           0           1          0  0.00%  0.00%  0.00%   0 ac_atm_state_eve
    124           0           2          0  0.00%  0.00%  0.00%   0 SNMP Timers     
    125        1320     1710737          0  0.00%  0.00%  0.00%   0 RUDPV1 Main Proc
    126           0           1          0  0.00%  0.00%  0.00%   0 bsm_timers      
    127         568     1710728          0  0.00%  0.00%  0.00%   0 bsm_xmt_proc    
    128           0           1          0  0.00%  0.00%  0.00%   0 COPS            
    129           0           2          0  0.00%  0.00%  0.00%   0 Dialer Forwarder
    130           0           3          0  0.00%  0.00%  0.00%   0 Flow Exporter Ti
    131           0           2          0  0.00%  0.00%  0.00%   0 ATM OAM Input   
    132           0           2          0  0.00%  0.00%  0.00%   0 ATM OAM TIMER   
    133           0           1          0  0.00%  0.00%  0.00%   0 RARP Input      
    134           0           1          0  0.00%  0.00%  0.00%   0 IPv6 Inspect Tim
    135           0           1          0  0.00%  0.00%  0.00%   0 LAPB Process    
    136           0           2          0  0.00%  0.00%  0.00%   0 LFDp Input Proc 
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
    137           0           1          0  0.00%  0.00%  0.00%   0 PAD InCall      
    138           0           2          0  0.00%  0.00%  0.00%   0 X.25 Background 
    139           0           2          0  0.00%  0.00%  0.00%   0 PPP Bind        
    140           0           2          0  0.00%  0.00%  0.00%   0 PPP SSS         
    141           0           1          0  0.00%  0.00%  0.00%   0 MQC Flow Event B
    142       35504   424737438          0  0.23%  0.25%  0.23%   0 HQF Shaper Backg
    143        4068    17031478          0  0.00%  0.00%  0.00%   0 RBSCP Background
    144           0           2          0  0.00%  0.00%  0.00%   0 SCTP Main Proces
    145           0           1          0  0.00%  0.00%  0.00%   0 VPDN call manage
    146           0           1          0  0.00%  0.00%  0.00%   0 CHKPT EXAMPLE   
    147           0           1          0  0.00%  0.00%  0.00%   0 CHKPT DevTest   
    148           0           1          0  0.00%  0.00%  0.00%   0 IPS Process     
    149           0           2          0  0.00%  0.00%  0.00%   0 IPS Auto Update 
    150           0           2          0  0.00%  0.00%  0.00%   0 SDEE Management 
    151         948     3338807          0  0.00%  0.00%  0.00%   0 Inspect process 
    152           0           1          0  0.00%  0.00%  0.00%   0 xcpa-driver     
    153          52      136947          0  0.00%  0.00%  0.00%   0 FW DP Inspect pr
    154        1112     3338806          0  0.00%  0.00%  0.00%   0 CCE DP URLF cach
    155           0           2          0  0.00%  0.00%  0.00%   0 URL filter proc 
    156           0           1          0  0.00%  0.00%  0.00%   0 XSM_EVENT_ENGINE
    157         144      171238          0  0.00%  0.00%  0.00%   0 XSM_ENQUEUER    
    158          68      171238          0  0.00%  0.00%  0.00%   0 XSM Historian   
    159           0           1          0  0.00%  0.00%  0.00%   0 Select Timers   
    160           4           2       2000  0.00%  0.00%  0.00%   0 HTTP Process    
    161           0           2          0  0.00%  0.00%  0.00%   0 CIFS API Process
    162           0           2          0  0.00%  0.00%  0.00%   0 CIFS Proxy Proce
    163           0           1          0  0.00%  0.00%  0.00%   0 Crypto HW Proc  
    164          56      114166          0  0.00%  0.00%  0.00%   0 ACE policy loade
    165         156       68505          2  0.00%  0.00%  0.00%   0 CRM_CALL_UPDATE_
    166       36688      172862        212  0.00%  0.00%  0.00%   0 BGP I/O         
    167           0           2          0  0.00%  0.00%  0.00%   0 AAA Cached Serve
    168           0           2          0  0.00%  0.00%  0.00%   0 ENABLE AAA      
    169           0           1          0  0.00%  0.00%  0.00%   0 EM Background Pr
    170           0           1          0  0.00%  0.00%  0.00%   0 Key chain liveke
    171           0           2          0  0.00%  0.00%  0.00%   0 LINE AAA        
    172          44         112        392  0.00%  0.00%  0.00%   0 LOCAL AAA       
    173           0          42          0  0.00%  0.00%  0.00%   0 MPLS Auto Mesh P
    174           0           2          0  0.00%  0.00%  0.00%   0 TPLUS           
    175           0           2          0  0.00%  0.00%  0.00%   0 VSP_MGR         
    176           0           1          0  0.00%  0.00%  0.00%   0 FW_TEST_TRP     
    177           0           1          0  0.00%  0.00%  0.00%   0 EPM MAIN PROCESS
    178           4           3       1333  0.00%  0.00%  0.00%   0 Crypto WUI      
    179           0           2          0  0.00%  0.00%  0.00%   0 Crypto Support  
    180           0           1          0  0.00%  0.00%  0.00%   0 IPSECv6 PS Proc 
    181           0           1          0  0.00%  0.00%  0.00%   0 CCVPM_HTSP      
    182           0           1          0  0.00%  0.00%  0.00%   0 CCVPM_R2        
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
    183           0           1          0  0.00%  0.00%  0.00%   0 EPHONE MWI Refre
    184           0        1903          0  0.00%  0.00%  0.00%   0 FB/KS Log HouseK
    185           0           2          0  0.00%  0.00%  0.00%   0 EPHONE MWI BG Pr
    186           0           1          0  0.00%  0.00%  0.00%   0 Skinny HW confer
    187           0           1          0  0.00%  0.00%  0.00%   0 CCSWVOICE       
    188      206492      114180       1808  0.00%  0.00%  0.00%   0 BGP Scanner     
    189           0           1          0  0.00%  0.00%  0.00%   0 http client proc
    190           0           3          0  0.00%  0.00%  0.00%   0 BGP Event       
    191           0           1          0  0.00%  0.00%  0.00%   0 QOS_MODULE_MAIN 
    192           0           1          0  0.00%  0.00%  0.00%   0 RPMS_PROC_MAIN  
    193           0           1          0  0.00%  0.00%  0.00%   0 VoIP AAA        
    194           0           2          0  0.00%  0.00%  0.00%   0 Dialog Manager  
    195         184         104       1769  0.00%  0.00%  0.00%   0 crypto engine pr
    196           0           4          0  0.00%  0.00%  0.00%   0 Crypto CA       
    197           0           1          0  0.00%  0.00%  0.00%   0 Crypto PKI-CRL  
    198       28008       64288        435  0.00%  0.00%  0.00%   0 encrypt proc    
    199      384768       28300      13596  0.00%  0.00%  0.00%   0 crypto sw pk pro
    200           8          27        296  0.00%  0.00%  0.00%   0 Crypto INT      
    201         456        2019        225  0.00%  0.00%  0.00%   0 Crypto IKE Dispa
    202        2128        2714        784  0.00%  0.00%  0.00%   0 Crypto IKMP     
    203           0           1          0  0.00%  0.00%  0.00%   0 IPSEC manual key
    204         180       85737          2  0.00%  0.00%  0.00%   0 IPSEC key engine
    205           0           1          0  0.00%  0.00%  0.00%   0 CRYPTO QoS proce
    206          28         142        197  0.00%  0.00%  0.00%   0 Crypto ACL      
    207           0           1          0  0.00%  0.00%  0.00%   0 Crypto PAS Proc 
    208           0           1          0  0.00%  0.00%  0.00%   0 GDOI GM Process 
    209           0           1          0  0.00%  0.00%  0.00%   0 UNICAST REKEY   
    210           0           1          0  0.00%  0.00%  0.00%   0 UNICAST REKEY AC
    211           0           1          0  0.00%  0.00%  0.00%   0 MV64 TDR Process
    212           0           1          0  0.00%  0.00%  0.00%   0 IMA Traps       
    213           0           1          0  0.00%  0.00%  0.00%   0 SYSMGT Events   
    214           0           2          0  0.00%  0.00%  0.00%   0 Control-plane ho
    215           0           1          0  0.00%  0.00%  0.00%   0 DATA Transfer Pr
    216           0           1          0  0.00%  0.00%  0.00%   0 DATA Collector  
    217           0           1          0  0.00%  0.00%  0.00%   0 Async write proc
    218         116         292        397  0.00%  0.00%  0.00%   0 AAA SEND STOP EV
    219         136      171243          0  0.00%  0.00%  0.00%   0 RMON Recycle Pro
    220           0           2          0  0.00%  0.00%  0.00%   0 RMON Deferred Se
    221           0           1          0  0.00%  0.00%  0.00%   0 Syslog Traps    
    222           0           2          0  0.00%  0.00%  0.00%   0 EEM ED Resource 
    223           0           2          0  0.00%  0.00%  0.00%   0 EEM ED Routing  
    224           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Track    
    225          80       53575          1  0.00%  0.00%  0.00%   0 Crypto cTCP proc
    226           0           1          0  0.00%  0.00%  0.00%   0 IP SLAs Ethernet
    227           4           1       4000  0.00%  0.00%  0.00%   0 RMON Packets    
    228         820     1709984          0  0.00%  0.00%  0.00%   0 trunk conditioni
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
    229           0           1          0  0.00%  0.00%  0.00%   0 trunk conditioni
    230          12         120        100  0.00%  0.00%  0.00%   0 EEM Server      
    231           4           2       2000  0.00%  0.00%  0.00%   0 Call Home proces
    232          52         260        200  0.00%  0.00%  0.00%   0 Syslog          
    233           0           1          0  0.00%  0.00%  0.00%   0 VPDN Test       
    234           0           2          0  0.00%  0.00%  0.00%   0 EEM Policy Direc
    235           0           2          0  0.00%  0.00%  0.00%   0 EEM ED CLI      
    236           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Counter  
    237           0           3          0  0.00%  0.00%  0.00%   0 EM ED GOLD      
    238           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Interface
    239           0           3          0  0.00%  0.00%  0.00%   0 EEM ED IOSWD    
    240           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Ipsla    
    241           0           3          0  0.00%  0.00%  0.00%   0 EEM ED None     
    242           0           2          0  0.00%  0.00%  0.00%   0 EEM ED Nf       
    243           0           3          0  0.00%  0.00%  0.00%   0 EEM ED OIR      
    244           0           3          0  0.00%  0.00%  0.00%   0 EEM ED RF       
    245           0           3          0  0.00%  0.00%  0.00%   0 EEM ED SNMP     
    246           0           2          0  0.00%  0.00%  0.00%   0 EEM ED SNMP Noti
    247          36       42890          0  0.00%  0.00%  0.00%   0 EEM ED Timer    
    248           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Test     
    249           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Config   
    250           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Env      
    251           0           3          0  0.00%  0.00%  0.00%   0 EEM ED RPC      
    252           0           2          0  0.00%  0.00%  0.00%   0 cpf_process_msg_
    253           0           1          0  0.00%  0.00%  0.00%   0 Key Proc        
    254          36       28543          1  0.00%  0.00%  0.00%   0 Call Home Timer 
    255           0           1          0  0.00%  0.00%  0.00%   0 tHUB            
    256           0           1          0  0.00%  0.00%  0.00%   0 Async write proc
    257         104         953        109  0.00%  0.00%  0.00%   0 SSH Event handle
    258          16       28543          0  0.00%  0.00%  0.00%   0 Secure Login    
    259          84          54       1555  0.00%  0.00%  0.00%   0 Tunnel Security 
    260          56          67        835  0.00%  0.00%  0.00%   0 Crypto SS Proces
    261           0           1          0  0.00%  0.00%  0.00%   0 cpf_process_tpQ 
    262           0           1          0  0.00%  0.00%  0.00%   0 TCP Listener    
    263           0           2          0  0.00%  0.00%  0.00%   0 IP Flow Top Talk
    264        1180     3338804          0  0.00%  0.00%  0.00%   0 IP NAT Ager     
    265           0           1          0  0.00%  0.00%  0.00%   0 IP NAT WLAN     
    266          24       28563          0  0.00%  0.00%  0.00%   0 IP SLAs Event Pr
    267      434504     1489526        291  0.00%  0.00%  0.00%   0 IP SNMP         
    268      170304      877961        193  0.00%  0.00%  0.00%   0 PDU DISPATCHER  
    269      495704      877992        564  0.00%  0.00%  0.00%   0 SNMP ENGINE     
    270           0           2          0  0.00%  0.00%  0.00%   0 IP SNMPV6       
    271           0           1          0  0.00%  0.00%  0.00%   0 SNMP ConfCopyPro
    272           0           1          0  0.00%  0.00%  0.00%   0 SNMP Traps      
    273     1185420     1715196        691  0.00%  0.00%  0.00%   0 NTP             
    274         412          29      14206  0.00%  0.00%  0.00%   0 VTEMPLATE Backgr
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
    275       18608      174262        106  0.00%  0.00%  0.00%   0 BGP Router      
    276          36       27171          1  0.00%  0.00%  0.00%   0 DFS flush period
    277           8          12        666  0.00%  0.00%  0.00%   0 Collection proce
    278          16         651         24  0.00%  0.00%  0.00%   0 CRYPTO IKMP IPC 
    279        1724         850       2028  0.00%  0.00%  0.00%   2 SSH Process     
    281           0           1          0  0.00%  0.00%  0.00%   0 Skinny MOH Event
    282          64      173856          0  0.00%  0.00%  0.00%   0 Skinny Socket Se
    283           0        1451          0  0.00%  0.00%  0.00%   0 Web Write Housek
    ==============================================================
    wish to help ASAP

    JosephDoherty wrote:DisclaimerThe   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.Liability DisclaimerIn   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.PostingThe fact you are matching with any ACLs, will decrease maximum performance.The fact you are using a policy-may, will decrease maximum performance.The fact is a -G2 only has finite capacity.In other words, what you're seeing might be completely normal for your traffic volume, your traffic composition and your configuration.If you believe your router is overloaded, and generally above 75% CPU might be so considered, either you'll need a faster device (see ASR 1Ks), or you might try changing your configuration to decrease your configuration load on the router.What's your CPU load if your remove the policy-map from the interface?If removing the policy-map from the interface shows a significant CPU loading decrease - QED.If you need/desire such QoS, then you'll want a "faster" router.You might be also able to decrease your CPU a little by some "tuning".  I already mention the TurboACL feature statement.  With ACLs, fewer are faster, and how they ordered (especially without TurboACL) impacts CPU.  How you order you class-maps, within a policy, and how the match statements are ordered will also have some impact on the CPU load.  If buffers are being allocated/deallocated, that too will impact CPU loading.  I assume CEF is enabled, but for some traffic, flow caching might decrease CPU load.Remember a software based router, like the 7200s, are, more or less, a computer that takes your configuration and determines what's to be done with every packet it "sees".  The more your configuration requires for per packet analysis, the more load for each packet.There are whitepapers addressing high CPU load caused by "process switching", but what you posted appears to be mostly all interrupt processing, which is "fast path", or optimal, packet forwarding.  There's not much you can normally do to improve against that, other than insuring your configuration is as optimal as possible for your needs (again, things like sequencing/ordering of statements).
    hi ,
    thanks very very much for this nice information,
    let me answer you :
    you said that NPE G2 has finite capacity , but how to know this full capacity ???
    i mean that my policy map is matching the traffic , but the matched traffic is not being enhancemend ??!!!
    last about two weeks , the matched traffic of youtube was excellent and no interrupt durting the my rush hour.
    i didnt change any thing, but my bw increased from 730 Mbps to 760Mbps ,
    im un able to make sure that i need to chnage my platform to faster one.
    agian
    my cpu is 60 % without QOS
    after QOS it increase to 80-85 %
    agian ,
    about NBAR
    i want to tell you that i cant depend on NBAR , as an example , im matching the ips of videos of facebook , i cant depend on NBAR because it is https videos.
    but in summary ,
    my qos is matching well , but i have no real enhancement for my traffic.
    did you face my issue before  ???
    i mean have you see like my problem ?
    like my router platform  with cpu over 80 % and 750Mbps , and matched qos without good result ??
    note that i upgraded to iso 15 , but seems same issue !!!
    regards

  • How to apply Qos in the precedence of cache server

    m in an isp  and iwant to apply the QOS to enhance my network internet performance
    actually i  have two requests , i will start with showing brief topology about my network and start asking the questions .
    here is the topology below :
    from the topology above , my access is only on R1 which is BGP internet gateway router and R2 is my ISP router.
    1- i want to apply Qos on R1 so that a subnet of 32 ips to have gurantee bandwidth of 30M .
    assume  the subnet  is 10.20.30.0/27  that need to be bw gurantee .
    2- i want the download traffic by idman or ftp on my Router R1 dont exceed 50 % of my total bw .
    i mean that i have 450M bandwith from my isp , & sometimes we have a  slow in browsing , so i want to enhance the browsing quality because  its more important that downloading files from internet.
    here is my two requests above , i dont know how it will work with the precedence of the cache server .
    anyway , i will paste my config of router and i will replace my puplic ips with xxx for privacy .
    7200Gateway#sh run
    Building configuration...
    Current configuration : 10149 bytes
    upgrade fpd auto
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname 7200Gateway
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    logging buffered 50000
    enable secret xxxxxxxxxxxxxx
    no aaa new-model
    ip source-route
    ip wccp 80 redirect-list CACHE80
    ip wccp 90 redirect-list CACHE90
    ip cef
    no ip domain lookup
    ip accounting-threshold 4294967295
    login block-for 180 attempts 3 within 60
    login quiet-mode access-class telnet
    login on-failure log
    login on-success log
    no ipv6 cef
    multilink bundle-name authenticated
    username xxxxxx password xxxxx
    archive
    log config
      hidekeys
    interface GigabitEthernet0/1
    description LAN
    bandwidth 230000
    ip address 10.160.150.2 255.255.255.0
    ip wccp 80 redirect in
    ip policy route-map CACHE-REDIRECT
    load-interval 30
    duplex auto
    speed auto
    media-type rj45
    negotiation auto
    interface FastEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    interface GigabitEthernet0/2
    description Cache
    bandwidth 150000
    ip address x.x.x.x 255.255.255.248
    ip wccp redirect exclude in
    load-interval 30
    duplex auto
    speed 1000
    media-type rj45
    negotiation auto
    interface GigabitEthernet0/3
    description Internet
    bandwidth 230000
    ip address x.x.x.x 255.255.255.252
    ip wccp 90 redirect in
    load-interval 30
    duplex full
    speed 1000
    media-type sfp
    negotiation auto
    router bgp zzzzzzz
    no synchronization
    bgp log-neighbor-changes
    network xxxx mask xxxxx
    network xxxx mask xxxx
    network xxxx mask xxxxx
    network xxxx mask xxxx
    network xxxx mask xxxxx
    network xxxx mask xxxx
    redistribute connected
    redistribute static
    neighbor zzzzzzzz remote-as zzzzzzz
    neighbor zzzzzzz password zzzzzzz
    neighbor zzzzzz route-map Pipo out
    no auto-summary
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 xxxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    no ip http server
    no ip http secure-server
    ip flow-top-talkers
    top 200
    sort-by bytes
    cache-timeout 5000
    ip access-list extended bb
    permit ip xxxx.xxxx.xx.0 0.0.1.255 any
    ip access-list extended CACHE80
    permit tcp xxxxxxx any eq www
    ip access-list extended CACHE90
    permit tcp any xxxxx.0 0.0.0.255
    ip access-list extended pipo
    permit ip xxxxx xxxxxxx any
      permit ip xxxxx xxxxxxx any
    ip access-list extended private
    permit tcp 172.16.0.0 0.0.255.255 any eq www
    permit ip 10.20.30.0 0.0.0.255 any
    ip access-list extended telnet
    permit ip xxxxxx xxxxxxx.255.255 any log
    permit ip xxxx xxxxx 0.0.0.255 any log
    ip prefix-list bb seq 5 permit xxxxx
    ip prefix-list bbseq 10 permit xxxxxx
    logging history size 500
    no cdp run
    route-map pipo permit 10
    match ip address prefix-list pipo1
    route-map pipo permit 20
    match ip address prefix-list newsubnet
    set metric 500
    set origin incomplete
    set as-path prepend xxxxxxxxx
    route-map permit 10
    match ip address prefix-list bibo
    route-map CACHE-REDIRECT permit 10
    match ip address  private
    set ip next-hop 1vvvvvv
    route-map CACHE-REDIRECT permit 20
    match ip address bibo e1
    set ip next-hop vvvvvv
    route-map CACHE-REDIRECT permit 30
    match ip address pipo
    set ip next-hop vvvvvvvvvv
    route-map CACHE-REDIRECT permit 100
    snmp-server community xxxxxx RO
    control-plane
    dial-peer cor custom
    line con 0
    password xxxxxxxx
    logging synchronous
    login
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    exec-timeout 60 0
    password xxxxxxxxxxxxxxxxx
    logging synchronous
    login local
    end

    Hi Vinay,
    Please check the program. I have used the replace statement but it is not working.
    IF NOT v_sap_bom_rec IS INITIAL.
    Spliting the records at '~' delimiter
        SPLIT v_sap_bom_rec AT c_del INTO  wa_bom_file-model_name
                                           wa_bom_file-product_code
                                           wa_bom_file-description
                                           wa_bom_file-product_type
                                           wa_bom_file-mfg_part_num
                                           wa_bom_file-mfg_part_desc.
        REPLACE cl_abap_char_utilities=>horizontal_tab IN wa_bom_file-mfg_part_desc WITH space .
        wa_bom_file-status = c_status.
        APPEND wa_bom_file  TO i_bom_file.
    But it is not working.
    Please help me..
    Thanks
    Neelima

  • How to change default FCoE QoS class - Nexus 5020

    I see that on a Nexus 5020, the default FCoE QoS class is 50%. I am not using FCoE so I would like to adjust this value to 0%. I switch complains and says I can't change default values. How should I go about getting around this to eliminate the FCoE queue and give 100% BW to default? Thanks.

    No. The default classloader is a builtin classloader in
    the JRE. You can use other classloaders.
    The java.net.URLClassLoader is provided in
    the JDK. That's the only one. Otherwise you
    should subclass ClassLoader and implement
    the loadClass method (f.i.
    loadClass("my.program") {
    String file="my.program".replace('.','/') + ".class";
    // find the file in classpath
    // read the class file in a byte[]
    return defineClass(byte[]);
    although this is not the advised way to do it. Search the web for how to implement a classloader directly.

  • VoIP QoS for Site-to-Site Tunnel

    Hi all,
    I need some help with setting up QoS for VoIP between two Cisco ASA 5505 with Site-to-Site VPN.
    There is no need for bandwith reservation, only DSCP 46 (EF) should be highest and DSCP 26 second highest queue and the rules should only apply to a site-to-site VPN.
    Usually i try to configure the ASAs via ASDM and found out in the Cisco Documentations how to setup QoS for the DSCP bits with a Service Policy and how to set up QoS for a Site-to-Site VPN (Service Policy Rule -> Traffic Match). But how do i configure the QoS for a DSCP bit to only apply to a Site-to-Site Tunnel? And how do i configure different priorities for the two DSCP bits, is this defined by the order of Service Policies?
    The QoS has to be enabled on both ASAs for the inside interface?
    Thanks in advance
    Tobias

    Hi Collin,
    ok so from the document i think this has to be added on both ASAs to prioritize DSCP 46. Could you have a quick look if this is all i need?
    class-map voice_traffic
    match dscp ef
    class-map data
    match tunnel-group <Tunnel Name>
    match flow ip destination-address
    policy-map voice_policy
    class voice_traffic
      priority
    class Data
     police output 200000 37500
    service-policy voice_policy interface outside
    But there is still the question how two configure another DSCP bit for priority 2, I could not find out how this is done, neither CLI nor ASDM. Any ideas?
    BR
    Tobias

  • Problem with QOS for SIP on RV082

    Hello,
    I have problem with quality of VOIP call with Linskys RV082.  Firmware is 2.0.0.19tm.
    Router is configured as dual-wan , one port (WAN2) is for ADSL 8000/512kb and other one is (WAN1) SHDSL 8000/8000kb.
    VOIP traffic from certain IP of LAN is routed to WAN2 (through protocol binding). We have quaranted QOS on ADSL by ISP.
    Problem is that voice is dropping when we load WAN2 with other data  connection.  Last week i reload new firmware, restore default factory and configured router whole again. All was ok only for 1 day and then voice was dropping again.  I mean that problem is at mark packets, because when I put VOIP PBX in front of behind router , QOS is working fine.
    Can you help me? Is this know issue?
    Thanks.
    Jan Babak
    Message was edited by: jabacomCZ

    thank you for reply !!!
    below is the show output :
    ciscoasa# show priority-queue statistics outside_wan
    Priority-Queue Statistics interface outside_wan
    Queue Type = BE
    Tail Drops = 0
    Reset Drops = 0
    Packets Transmit = 7971924
    Packets Enqueued = 0
    Current Q Length = 0
    Max Q Length = 0
    Queue Type = LLQ
    Tail Drops = 0
    Reset Drops = 0
    Packets Transmit = 189321
    Packets Enqueued = 0
    Current Q Length = 0
    Max Q Length = 0
    ciscoasa#
    so does the command look like, the one I should use instead of priority-queue outside_wan ??

  • Incorrect Data Overage Charges on my wife's phone after forced to tiered data

    My billing cycle starts on the 1st of the month.  I upgraded my wife's phone from a Droid X to an iPhone 4S on 7/2.  I was told at that time that she would lose her unlimited data and be placed on a 2gb tiered data plan at the same price.  Fine for her since she has never gone near 2gb in several years of smart phone use.  I never set up wifi on her old phone since she had unlimited data and it wasn't a concern for me.  Once getting switched to the new plan I set up wifi so when she is at work or at home she is automatically connected to wifi for her data usage.  Looking at the usage report on verizon's bill for her old phone she used 1071mb for June which was actually a high usage month for her but still nowhere near 2048mb (2gb).  Her first month on her new data plan she used 795mb according to the Data Usage Report (which they conveniently don't give a total for) which I exported to Excel and added the column.  Then for August's bill the usage report for her phone totals 440mb.  On the August bill they show an "Unbilled Usage from Previous Months" bill for $10 on top of the $30 we pay for the 2gb Data Plan
    July Data
    August Data
    I like how they show an exact usage on my phone which is still on an Unlimted Data Plan but her's which is on a Tiered Data Plan they just round up conveniently to the next GB.  Even if you add up there Unbilled and Current Usage it only adds up to 2048mb which is the limit.  So she did not exceed it!
    I called in and complained about the bill and the first CSR was trying to hand me off to a Tech Support saying the charges are accurate.
    I told her this is a Billing issue not a Tech issue and I would like to talk to a Supervisor.  After several minutes of arguing about the charges with the Supervisor he said he could credit the $10 back to me since he didn't want to continue arguing with me.  I told him I will just be in the same boat next month and having to dispute the false charges all over again burning more of my time.  I told him I would like to cancel my NFL Mobile on my phone at this time since my bill is so high and we got to talking about football which calmed both of us down.  Then I pleaded my case again about the bill which he eventually could see the issue and agreed that there is some sort of billing issue going on. 
    Just wanted to put this up so that if someone else is in a similar situation that they know this is not ok and others are being billed in-accurately as well.
    I have attached the spreadsheets straight from Verizon's site so you can tally them up for yourself as well and see that my wife only used 795mb of her allowed 2048mb (2gb) plan and was being charged overage charges. This is a pretty good gimmick since if you do this to even a couple 100k customers it would add up quickly to millions of dollars...
    I am completely fed up with Verizon now after being with them for 15+ years, I was not happy about the non-grandfathering anymore of unlimited data and now being wrongfully billed for data overage charges when she didn't go over her allowed usage. 
    I am thinking of making a FCC and BBB complaint to see if I can get out of my contract with them.

    For someone who spends soo much time on this forum I would expect you to know more about what you are talking about
    My wife's wifi radio is always on and her phone DOES automatically connect to our wifi and her work wifi as soon as she is near it.  I can videotape it if you need more proof.(don't understand your point anyways as even according to Verizon's usage report she did not come near 2GB of data)
    If you read my very first sentence I state that my billing cycle starts on the 1st of the month and the phone was purchased on the 2nd (don't understand your point anyways)
    I state in my original post that Verizon rounds up the data on her phone to the nearest GB instead of giving an exact amount used on the bill (so thank you for pointing out the obvious)
    Point being, she used 440mb  and we were charged data overage charges of $10 and I am sure that this is not an isolated incident.

  • Is there ANY way to get QOS with an airport extreme base station?

    I recently moved and decided to go with Primus VOIP for my phone line. It works fine as long as i don't have any torrents going...if i do then call quality goes to **** (i wish someone would've told me before)
    I was told to use a QOS on teh VOIP ports...but my airport extreme doesn't support this (and apparently neither will the new one). Honestly this is something Apple REALLY needs to fix. This is outrageous. They're supposed to be on teh cutting edge of technology, and their routers don't even won't properply with VOIP services??? That's ********.
    Is there any way i could get this to work - perhaps thru software?
    It seems the only solution i have is to get a Linksys router and sell off the airport

    Sorry that this may not seem like an ideal solution, but one option is to use an application that runs on a Windows PC that allows you to format HDDs for HFS+. Once formatted as such, it can be shared out to either OS X, Windows, or Linux users from an AirPort Extreme or Time Capsule. HFS+, like NTFS, supports much larger HDDs.

  • How to Configure Multiple Portal Middle Tiers with a Load Balancing Router

    Hi,
    Portal version trying to install 10.1.2 on Windows 2003 boxes.
    I am following the guide http://download.oracle.com/docs/cd/B14099_19/portal.1012/b14037/cg_advnc.htm#i1046354. I have InfraStructure installed on a different box and am trying to install 2 Portal Midtiers each on separate boxes and using LBR. The above document is kind of confusing as I am trying to following
    5.3.1 Step 1: Install a Single Portal and Wireless Middle Tier (M1)
    5.3.2 Step 2: Configure OracleAS Portal on M1 to Be Accessed Through the LBR (AND FOLLOW ARE THE STEPS 1 to 14 in sequence)
    if I follow 1 to 14 steps in sequence the information is not consistent what is being listed in the following sections
    5.4.1 Create Virtual Hosts
    5.4.2 Configure OracleAS Web Cache
    5.4.3 Register OracleAS Portal with OracleAS Single Sign-On
    i.e.
    ptlconfig -dad portal -sso -host www.abc.com -port 7779
    ptlconfig -dad portal -sso -host www.xyz.com -port 7779
    as in the above steps it says to run
    ptlconfig -dad portal -wc -site
    and ssoreg command that always fails because I am running it from midtier as it gives error saying invalid username/password
    as oppoesed to steps listed in point 8, 9, 10, 11 and 12.
    Can someone please privide the steps in sequence I need to follow when installing 2 midtiers with frontend LBR and one infrastructure. I am trying to follow the architecture listed in the above link.
    Any help is really appreciated.
    Thanks

    Hi,
    Will appreciate any inputs on the following.
    I am planning to install Infrastructure and one Midtier BI Forms Reports Discoverer, Portal on one windows box and the second midtier BI Forms Discoverer, Portal on the second windows box.
    Please correct me if I am wrong on installing and configuring the mid-tiers as following are the steps I have compiled going through the document and want to make sure this time I do it right.
    As I'll be installing BI Forms Reports Discoverer, Portal so wondering when I install the second midtier do I need to unselect all Portal, Forms, Reports, Discoverer or just the Portal I need to unselect.
    Also in the host file of both the windows boxes do I just need to keep the LBR IP Address entry and remove the rest.
    LBR:_
    Computer Name: bigip5.prd.com
    IP Address: *167.123.2.5*
    Listen Port: *80*
    Invaidation Port: *9401*
    Infrastructure:_
    Computer Name: portal1.prd.com
    IP Address: *167.123.2.6*
    Oracle HTTP Server Listening Port: *7777*
    Application Server Control port: *1800*
    M1 (Portal & BI Forms Reports Discoverer):_
    Computer Name: portal1.prd.com
    IP Address: *167.123.2.6*
    Oracle HTTP Server Listening Port: *7778*
    OracleAS Web Cache Listening Port: *80*
    OracleAS Web Cache Invalidation Port: *9401*
    OracleAS Web Cache Administration Port: *9400*
    Web Cache Statistics port: *9402*
    Application Server Control port: *1810*
    M2 (Portal & BI Forms Reports Discoverer):_
    Computer Name: portal2.prd.com
    IP Address: *167.123.2.7*
    Oracle HTTP Server Listening Port: *7778*
    OracleAS Web Cache Listening Port: *80*
    OracleAS Web Cache Invalidation Port: *9401*
    OracleAS Web Cache Administration Port: *9400*
    Web Cache Statistics port: *9402*
    Application Server Control port: *1810*
    First to create MetadataRepository and then Install Infrastructure and then follow the below steps to install Midtiers
    Install and Configure of M1 (Portal and BI Forms Reports Discoverer):-_
    *5.3.1 Step 1*: Install a Single Portal and BI Forms Reports Discoverer (M1 i.e. portal1.prd.com)
    *5.3.2 Step 2*: Configure OracleAS Portal and BI Forms Reports Discoverer on M1 to Be Accessed Through the LBR
    *1.* Configure LBR
    *2.* Follow Section 5.4.1.1 to create the Virtual Host for bigip5.prd.com (LBR) and portal1.prd.com (M1)
    *3.* Define a site that matches the virtual host entry for bigip5.prd.com (LBR) on Webcache of M1
    *4.* Use OracleAS Web Cache Manager on M1, to map the site bigip5.prd.com (LBR) to middle tier portal1.prd.com (M1).
    Follow steps 5 and 6 as per the document
    *7.* Configure bigip5.prd.com (LBR) to accept invalidation requests from the OracleAS Metadata Repository on a separate port i.e. 9401
    *8.* Change iasconfig.xml on M1
    *9.* run ptlconfig -encrypt
    *10.* Register the URL changes with OracleAS Portal by running ptlconfig -dad portal -wc -site
    *11.* No need as it is http only
    *12.* Run the follwoing
    MID_TIER_ORACLE_HOME_M1\sso\bin\ssoreg.bat
    -site_name bigip5.prd.com
    -mod_osso_url http://bigip5.prd.com:80
    -config_mod_osso TRUE
    -oracle_home_path MID_TIER_ORACLE_HOME_M1
    -config_file MID_TIER_ORACLE_HOME_M1\Apache\Apache\conf\osso\osso.conf
    -admin_info cn=orcladmin
    -virtualhost
    *13.* Edit targets.xml to enable monitoring of the LBR's front-end host and port settings for OracleAS Portal
    +<Property NAME="PortalListeningHostPort" VALUE=http://bigip5.prd.com:80/>+ and then run
    MID_TIER_ORACLE_HOME_M1\bin\emctl reload
    *14.* Test the setup
    Install and Configure of M2 (Portal and BI Forms Reports Discoverer):-_
    *5.3.4 Step 4*: Install a Single Portal and BI Forms Reports Discoverer (M2 i.e. portal2.prd.com)
    *1.* As I am installing on wiondows so will not set IASCONFIG_LOC environment variable as I can just copy the iasconfig.xml file from M1 to M2
    *2.* Run OUI on M2
    *3.* Clear the selection for OracleAS Portal but don't know if I need to unselect Forms , Reports, Discoverer also.
    *4.* Enable OracleAS Portal
    *5.3.5 Step 5:* Configure the New Middle Tier (M2) to Run Your Existing Portal
    *1.* Create both virtual hosts as done on M1
    *2.* Copy dads.conf, oradav.conf, cache.conf, web.xml from M1 to M2
    *3.* Re-register mod_osso on M2. To do this, perform the following steps by copying osso.conf from M1 to M2
    *4.* Synchronize the DCM by using the following command
    MID_TIER_ORACLE_HOME_M2/Apache/Apache/bin/ssotransfer MID_TIER_ORACLE_HOME_M2/Apache/Apache/conf/osso/osso.conf
    *5.* Run dcmctl updateConfig
    *6.* add the necessary mod_rewrite and mod_oc4j directives to the httpd.conf and mod_oc4j.conf files respectively
    *7.* Restart Oracle HTTP Server on M2
    *8.* Access the OracleAS Web Cache Manager on M1 and follow steps 9,10,11,12,13,14,15,16 for Webcache seetings and clustering.
    Also will appreciate if can get some info on the following:
    *1.*
    When I configure the Webcache as per the Document but if I bring down one Midtier Instance the requests are not going to the other Instance that is up and ignores the case whether an instance is down. Any idea how what and where do I need to provide any setting which in case of instance is down routes the requests to the one that is up.
    *2.*
    What exactly happens when it says To enable monitoring of the LBR's front-end host and port settings for OracleAS Portal edit target.xml. Is this for LBR to find if an Instance is down or not and route the requests appropriately.
    Thanks again for all the help.

  • How to configure QOS on certain IP in the Cisco ASA 5510

    Hi,
    I am need to configure QOS on certain IP in the Cisco ASA 5510. Assume the IP's are 10.0.1.5 , 10.0.1.6 , 10.0.1.7. Here i have to configure 512 KBPS for 10.0.1.5 and 2 MBPS for 10.0.1.6 and 10.0.1.7
    Can this done on a ASA 5510 series? if yes can you help me how ?
    Regards,
    Venkat

    Yes you can do it.You can match the ip addresses in an access-list, put in a class-map and the class-map in a policy map that will do policing.
    Good examples for what you want to do are here https://supportforums.cisco.com/docs/DOC-1230
    I hope it helps.
    PK

  • [Solved for me]Distinguishing SSH and SFTP (for QoS purposes)

    Hi there,
    I'm thinking about shutting down the FTP on my homeserver and use SFTP instead. There is only one thing I couldn't solve so far: In my router I have QoS-rules that make FTP low priority traffic so my normal activities don't get affected by the file transfers. I would like to have the same setup for the SFTP. Now the problem is this: SFTP and SSH are both coming from the same ssh server, listening on port 22. So there is no way of distinguishing them on a ip/port basis. Is there any way of distinguishing SFTP and SSH? Like using iptables to tag one of them and then doing QoS based on the tag or something along those lines? I don't want to slow down my ssh-connections together with the sftp. If anyone has an idea how to accomplish this I would be really glad to hear about it.
    Thanks in advance
    seiichiro0185
    Last edited by seiichiro0185 (2010-08-22 11:27:32)

    briest wrote:Well, a simple, though definitely not bulletproof solution: define multiple ports in sshd_config, then use one of them for sftp, and another for ssh?
    Thanks for this hint, I didn't know that ssh could listen on multiple ports. Its not totally bulletproof, but good enough for my case. The only people who will have access to the server are trustworthy and won't fiddle with the settings to circumvent my restrictions.
    Thanks to all of you for your suggestions.

  • How to set up a QOS on 3750 switch to limit outbound bandwidth on a server ?

    Hi,
    I have three LAN ports on a VM server. I want to limit a VM guest (guest server) outbound bandwidth to 3750 swith .
    How do I do it ? I want to apply QoS on the switch.
    thanks

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    If you're looking to limit bandwidth FROM your server, you can use an ingress policy on the server's interface and police selectively.  For example, if your specific VM has its own IP address, you could police inbound (from the server) traffic matching that IP.

Maybe you are looking for