TS1702 I have an iPhone 3G and I had skype installed before it updated to v.4. Now, during a backup, iTunes tells me i can no longer run Skype on my iPhone because the latest version of Skype is not compatible. Is there any way I can install an older vers

I have an iPhone 3G and I had skype installed before it updated to v.4. Now, during a backup, iTunes tells me i can no longer run Skype on my iPhone because the latest version of Skype is not compatible. Is there any way I can install an older version?

How can I contact Viber support? When I go to their website there's no such thing as 'email us' or 'contact us'.
They may have a do-it-yourself troubleshoot system but that doesnt help my problem at all.

Similar Messages

Maybe you are looking for