Unidirectional vs bidirectional association

Hi,
I've read lots of examples and it seems to me that, in reality, these are bidirectional associations:
Employee and Department (given an employee, you can find out what department(s) s/he belongs to; given a department, you can find out which employees are in it)
Parent and Child (given a parent, you can find out who are his/her children; given a child, you can find out who his/her parent(s) are)
Bid and Item (given a bid, you should be able to tell which item it is for; given an item, you can tell which bids were made on it).
To show unidirectional, the author just omitted the reference to the other in one class. In my opinion, all of the above should be bidirectional (in real life, they would be, I think).
Can someone give me some real life examples of a unidirectional association?
Are most associations bidirectional?
Thanks,
C

Hi,
I've read lots of examples and it seems to me that,
in reality, these are bidirectional associations:
Employee and Department (given an employee, you can
find out what department(s) s/he belongs to; given a
department, you can find out which employees are in
it)
Parent and Child (given a parent, you can find out
who are his/her children; given a child, you can find
out who his/her parent(s) are)
Bid and Item (given a bid, you should be able to tell
which item it is for; given an item, you can tell
which bids were made on it).
To show unidirectional, the author just omitted the
reference to the other in one class. In my opinion,
all of the above should be bidirectional (in real
life, they would be, I think).
Can someone give me some real life examples of a
unidirectional association?
Are most associations bidirectional?You're quite correct - in "real" life, relationships like the ones you cite are bidirectional.
However, that does not mean that every software representation of real life situation require the bidirectional relationship. If the model you've derived has no need of the many-to-one inverse relationship, it's possible to leave it out. Why do it? If the model doesn't require it, looser coupling.
If I'm modeling a parent-child relationship in a financial application, the parent has to know about child dependents, but there might not be any reason for the child object to know who their parent is. I only navigate to children objects by accessing the parent first.
%

Similar Messages

  • Unidirectional and Bidirectional association

    Can someone explain the difference between Unidirection association and Bidirectional association.
    An example will be a great help....
    Thanx to all of you.
    Satya

    montefusco,
    I believe you are correct in stating that in an information system (implementation) often there is a unidirectional association between two objects where in the Real World (conceptual) there is a bidirectional association.
    When I mentioned callbacks I was exclusively thinking of an actual callback impelementation.
    In an observer pattern implementation, for example, the Observer object has a reference to the Observable object so that the Observer can register itself to the Observable object. The Observable object has a reference to the Observer object for notifications. (of course there are other ways of implementing this pattern, but you get the point, I hope)
    So, I don't think we contradict each other here. There was just a confusion with coneptual-level class diagrams and implementation-level class diagrams.

  • Bidirectional association

    Hello,
    I am designing an application where there are Employee objects and there are WorkBlock objects. A WorkBlock object is simply a block of time that the Employee is scheduled to work.
    Each Employee can be scheduled to work one or more WorkBlocks. Each WorkBlock, of course, has one Employee that is assigned to it.
    My question is this: I was thinking of having the Employee maintain a List of WorkBlocks that they are assigned to, and also giving a reference to each WorkBlock pointing back to its assigned Employee. This appears to be a bidirectional association, from what I've read in UML book. I thought that this would be a good idea in the long run since you can query the WorkBlock for its Employee and you can query the Employee for its WorkBlocks.
    But is this bad code style? Should I instead just have a unidirectional association, and just loop through the entire collection of one item to find the other item?
    (For instance, if I only gave WorkBlocks a reference to its Employee, then the only way I could find out which WorkBlocks are assigned to a given employee is to iterate over the entire list of WorkBlocks and look for matching Employees. Does this make sense?)

    Erik,
    By 'dynamic' I meant that the bidirectional associations can come and go during the lifetimes of the objects involved.
    By delegating the job of handling the relationship to something else (the mediator), you can simplify the problem and it's a natural consequence of using the mediator pattern that integrity is maintained. Very nice.
    What the mediator does is something like what jschell describes above. How you implement it depends on whether the associations are one-to-one, one-to-many or many-to-many and also it depends on how you want to find or traverse the objects on the other end of the relationship.
    Have a look at http://patterndigest.com/patterns/Mediator.html for a quick summary.
    One final piece of advice: keep the use of the mediator as an implementation detail shared by the classes that exhibit the bidirectional association. i.e. do not let the rest of the object model become aware of the existence of the mediator. This is often simply a case of getting the object at one end of the association to delegate to the mediator.
    Regards,
    Lance

  • Block Traffic under two VLAN's : Unidirectional OR Bidirectional ???

    I have a Ciso L3 switch with 4 VLANs and all host computer connected to rest of 8 cisco 2960 switch's:
    VLAN 1  : 192.168.1.0/24
    VLAN 10: 192.168.10.0/24
    VLAN 20: 192.168.20.0/24
    VLAN 50: 192.168.30.0/24
    There are list of my some Questions about Extended ACL serialwise :
    1. For Restrict traffic from VLAN 10 to VLAN 20, I am using  only one ACL is : Access-list 100 deny ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255.
        What will happen in this scenerio if we talk about traffic from VLAN 20 to VLAN 10. Will it communicate or not ???
    2.   How to Block the traffic from VLAN 10  to  VLAN 20 but allow the traffic from VLAN 20  to  VLAN 10 ? Plz tell access list command for this.
          Question # 2 Depends on Question# 1...................
    Plz find here My cisco 3560 switch configuration in Blog below :
    Regards
    Kuldeep

    Hi Richard,
                      See this cisco 3560 switch Configuration, and tell me answers accordingly:
    CORE_3560#sh run
    Building configuration...
    Current configuration : 5299 bytes
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    hostname CORE_3560
    enable secret 5 $1$d6GO$No/vGsChZP5O.5ANOYI2m/
    no aaa new-model
    ip subnet-zero
    ip routing
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface Port-channel1
    description *** CONNECTING TO CISCO-2960 SWITCH-1 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface Port-channel2
    description *** CONNECTING TO CISCO-2960 SWITCH-2 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/1
    description *** CONNECTING TO CISCO-2960 SWITCH-1 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    interface GigabitEthernet0/2
    description *** CONNECTING TO CISCO-2960 SWITCH-1 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    interface GigabitEthernet0/3
    description *** CONNECTING TO CISCO-2960 SWITCH-2 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 2 mode on
    interface GigabitEthernet0/4
    description *** CONNECTING TO CISCO-2960 SWITCH-2 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 2 mode on
    interface GigabitEthernet0/5
    description *** CONNECTING TO CISCO-2960 SWITCH-3 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/6
    interface GigabitEthernet0/7
    description *** CONNECTING TO CISCO-2960 SWITCH-4 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/8
    interface GigabitEthernet0/9
    description *** CONNECTING TO CISCO-2960 SWITCH-5 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/10
    interface GigabitEthernet0/11
    description *** CONNECTING TO CISCO-2960 SWITCH-6 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/12
    interface GigabitEthernet0/13
    description *** CONNECTING TO CISCO-2960 SWITCH-7 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/14
    description *** CONNECTING TO CISCO-2960 SWITCH-8 ***
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/15
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/16
    interface GigabitEthernet0/17
    interface GigabitEthernet0/18
    interface GigabitEthernet0/19
    interface GigabitEthernet0/20
    interface GigabitEthernet0/21
    interface GigabitEthernet0/22
    interface GigabitEthernet0/23
    interface GigabitEthernet0/24                       
    description Connecting to Cisco-1800 Router             
    switchport access vlan 50
    switchport mode access
    interface GigabitEthernet0/25
    interface GigabitEthernet0/26
    interface GigabitEthernet0/27
    interface GigabitEthernet0/28
    interface Vlan1                                     ***** L2 switch's Vlans
    ip address 192.168.1.1 255.255.255.0      
    interface Vlan10
    ip address 192.168.10.1 255.255.255.0
    ip access-group 101 in
    interface Vlan20
    ip address 192.168.20.1 255.255.255.0
    ip access-group 101 in
    interface Vlan50
    ip address 192.168.30.1 255.255.255.0
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.30.10
    ip http server
    access-list 101 deny ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
    access-list 101 permit ip any any
    access-list 101 permit icmp any any
    control-plane
    line con 0
    line vty 0 4
    password cisco
    no login
    line vty 5 15
    no login
    end

  • Ip tcp adjust-mss unidirection or bidirectional?

    If i configure this command on my cisco CPE with a value of 1440, why do i still have packets who has a mss of 1460, while i clearly see the TCP three-way handshake? I'm no wireshark expert, but maybe you guys can tell me what i am doing wrong? I have made a capture between two hosts who are communicating with each other. 
    Here is the direct link for a more clearer picture http://s16.postimg.org/4vyeqpg91/syn_bit.png

    Hi there,
    Correct me if i m wrong, is the capture taken from a PC connected to Cisco? 
    The default MSS is 1460 which MTU 1500 - 40 Header = 1460 which is announced by the PC in syn and as you can see from the second packet which is syn ack received on the PC through the router the MSS is set to 1440, which means the MSS was modified / adjusted by the router.
    Please refer below link for more information and testing MSS.
    http://www.cisco.com/c/en/us/td/docs/ios/12_2sb/12_2sba/feature/guide/sb_admss.pdf
    HTH
    Hitesh

  • Heap Exhaustion Exception for One-to-One Unidirectional

    Using Glassfish 2.1 with TopLink, EJB3 and JPA in WinXP SP2 environment. Am observing heap exhaustion exceptions apparently whenever an entity references a different entity via a one-to-one unidirectional relation.
    Have resolved two heap exhaustion exception problems but have one more remaining.
    The first heap exhaustion problem occurred when entity "A" declared a one-to-many relationship with entity "B", and entity "B" declared a many-to-one relationship with entity "A". But entity "A" also erroneously declared a one-to-one unidirectional relationship with entity "B". As soon as entity "A" had an entity "B" inserted into it, a heap exhaustion exception occurred when entity "A" was serialized in a return statement. As soon as the erroneous one-to-one unidirectional relationship was removed from entity "A", the heap exhaustion exceptions ceased.
    The second heap exhaustion problem occurred when the same entity "A" mistakenly declared a one-to-one unidirectional relationship with entity "C", and entity "C" correctly declared a many-to-one relationship with entity "A". Once again as soon as entity "A" had an entity "C" inserted into it, a heap exhaustion exception occurred when entity "A" was serialized in a return statement. As soon as the erroneous one-to-one was corrected to a one-to-many, the heap exhaustion exceptions ceased.
    But the third heap exhaustion problem occurs when the same entity "A" correctly declares a one-to-one unidirectional relationship with entity "D". As soon as entity "A" has an entity "D" inserted into it, a heap exhaustion exception occurs when entity "A" is serialized in a return statement. I cannot "fix" this as I did in the two above cases because this time the one-to-one unidirectional relationship is correct.
    Have one-to-one bidirectional relationships as well as one-to-many / many-to-one that do not trigger heap exhaustion exceptions when serialized in a return statement.
    Here is the Java code that declares the problem one-to-one bidirectional relationship in entity "A":
    @OneToOne(cascade={CascadeType.MERGE, CascadeType.PERSIST, CascadeType.REFRESH }, optional=true, fetch=FetchType.LAZY)
    @JoinColumn(name="fk_asset_type_id", referencedColumnName="asset_type_id", updatable=false)
    public AssetType getAssetType() {
    return this.assetType;
    public void setAssetType(AssetType assetType) {
    this.assetType = assetType;
    Here is the SQL used to generate the table associated with entities "D" and "A":
    CREATE TABLE [dbo].[asset_type](
         [asset_type_id] [numeric](18, 0) IDENTITY(1,1) NOT NULL,
         [asset_name] [varchar](40) NULL,
         [asset_description] [varchar](50) NULL,
         [last_user] [varchar](50) NULL,
         [last_mod] [timestamp] NOT NULL,
    CONSTRAINT [PK_asset_type] PRIMARY KEY CLUSTERED
    ([asset_type_id] ASC)WITH (PAD_INDEX = OFF, STATISTICS_NORECOMPUTE = OFF, IGNORE_DUP_KEY = OFF, ALLOW_ROW_LOCKS = ON, ALLOW_PAGE_LOCKS = ON) ON [PRIMARY]) ON [PRIMARY]
    GO
    CREATE TABLE [dbo].[server_asset](
         [server_asset_id] [numeric](18, 0) IDENTITY(1,1) NOT NULL,
         [nsn] [varchar](40) NULL,
         [gov_furnish_equip_asset_id] [varchar](255) NULL,
         [server_name] [varchar](255) NULL,
         [server_ip_addr] [varchar](255) NULL,
         [serial_nbr] [varchar](50) NULL,
         [outfitting_list] [text] NULL,
         [update_cst] [varchar](255) NULL,
         [update_pst] [varchar](255) NULL,
         [date_decommissioned] [datetime] NULL,
         [server_asset_org_date] [datetime] NULL,
         [server_asset_update_date] [datetime] NULL,
         [fk_manufacturer_id] [numeric](18, 0) NULL,
         [fk_trade_partner_id] [numeric](18, 0) NULL,
         [fk_asset_type_id] [numeric](18, 0) NULL,
         [fk_model_id] [numeric](18, 0) NULL,
         [fk_item_part_id] [numeric](18, 0) NULL,
         [fk_gold_disk_asset_id] [numeric](18, 0) NULL,
         [fk_jtdi_location_id] [numeric](18, 0) NULL,
         [last_user] [varchar](50) NULL,
         [last_mod] [timestamp] NOT NULL,
    CONSTRAINT [PK_server_asset] PRIMARY KEY CLUSTERED
    ([server_asset_id] ASC)WITH (PAD_INDEX = OFF, STATISTICS_NORECOMPUTE = OFF, IGNORE_DUP_KEY = OFF, ALLOW_ROW_LOCKS = ON, ALLOW_PAGE_LOCKS = ON) ON [PRIMARY]) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
    GO
    ALTER TABLE [dbo].[server_asset] WITH CHECK ADD CONSTRAINT [FK_server_asset_asset_type] FOREIGN KEY([fk_asset_type_id])
    REFERENCES [dbo].[asset_type] ([asset_type_id])
    GO
    Have been batting this issue around on the Manning Panda forum. Consensus there is that the problem may be TopLink related. Would be most grateful for any suggestions. The easy way out would be to change the one-to-one unidirectional to bidirectional but don't want to do that unless there is no alternative. Thanks.

    Looking at the stack trace (found in your post on the GlassFish forum) it appears to be an issue with corba serialization in the container. I found this bug, https://glassfish.dev.java.net/issues/show_bug.cgi?id=2693 in which the stack looks almost identical to yours.
    The only way that I think TopLink could be involved is that TopLink is weaving your code, and potentially so is corba. You can try turning off weaving to see if that 'solves' your problem. (Note: I am not confidant that this will work, but I notice that the corba stack may be doing some weaving of it's own.)
    The persistence unit property is toplink.weaving. Setting it to false will turn off TopLink weaving.
    <property name="toplink.weaving" value="false"/>

  • How can I configure a 802.1x in a switch 2960 with IOS 15.0.2?

    Hi,
    I'm trying to config a switch WS-C2960+24PC-L with IOS 15.0(2)SE5 and C2960-LANBASEK9-M to use 802.1x in my network but when I type the following commands the IOS doesn't recognize the interface commands and I can't complete the settings:
    Router# configure terminal
    Router(config)# dot1x system-auth-control
    Router(config)# aaa new-model
    Router(config)# aaa authentication dot1x default group radius
    Router(config)# interface fastethernet2/1
    Router(config-if)# switchport mode access
    Switch(config-if)# authentication port-control auto (or dot1x port-control auto)
    Switch(config-if)# authentication host-mode multihost
    Router(config-if)# dot1x pae authenticator
    Router(config-if)# end
    Source: http://www.cisco.com/en/US/docs/ios-xml/ios/sec_usr_8021x/configuration/15-2mt/config-ieee-802x-pba.html#GUID-C11588CB-31B6-4CD9-9E74-CF2199FB1807
    I've used the same commands in other switch with IOS 12.x and I don't have any problem to complete the settings so.... somebody know if:
    * Should I use others commands to activate this feature in this IOS?
    * Do I need to use other IOS?
    Thanks in advance,

    The authentication manager commands in Cisco IOS Release 12.2(50)SE or later
    The equivalent 802.1x commands in Cisco IOS Release 12.2(46)SE and earlier
    Description
    authentication control-direction { both | in}
    dot1x control-direction { both | in}
    Enable 802.1x authentication with the wake-on-LAN (WoL) feature, and configure the port control as unidirectional or bidirectional.
    authentication event
    dot1x auth-fail vlan
    dot1x critical (interface configuration)
    

dot1x guest-vlan6
    Enable the restricted VLAN on a port.
    Enable the inaccessible-authentication-bypass feature.
    Specify an active VLAN as an 802.1x guest VLAN.
    authentication fallback fallback-profile
    dot1x fallback fallback-profile
    Configure a port to use web authentication as a fallback method for clients that do not support 802.1x authentication.
    authentication host-mode [ multi-auth | multi-domain | multi-host | single-host]
    dot1x host-mode { single-host | multi-host | multi-domain}
    Allow a single host (client) or multiple hosts on an 802.1x-authorized port.
    authentication order
    mab
    Provides the flexibility to define the order of authentication methods to be used.
    authentication periodic
    dot1x reauthentication
    Enable periodic re-authentication of the client.
    authentication port-control { auto | force-authorized | force-un authorized}
    dot1x port-control { auto | force-authorized | force-unauthorized}
    Enable manual control of the authorization state of the port.
    authentication timer
    dot1x timeout
    Set the 802.1x timers.
    authentication violation { protect | restrict | shutdown}
    dot1x violation-mode { shutdown | restrict | protect}
    Configure the violation modes that occur when a new device connects to a port or when a new device connects to a port after the maximum number of devices are connected to that port.
    show authentication
    show dot1x
    Display 802.1x statistics, administrative status, and operational status for the switch or for the specified port. authentication manager: compatibility with earlier 802.1x CLI commands
    http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960x/software/15-0_2_EX/security/configuration_guide/b_sec_152ex_2960-x_cg/b_sec_152ex_2960-x_cg_chapter_010000.html#concept_6275D339A9074AC0BB06F872D7A54FBB

  • Problem in mapping 1:M relationship

    I am using toplink+jpa in my application.
    I have a 1:M unidirectional relationship (without association table) in my application.
    I am not able to find correct annotations to define it.
    Kindly help.
    Following code works when I use JPA+Hibernate but doesnot work for JPA+Toplink:
    @Entity
    @IdClass(PersonPK.class)
    public class Person {
    /* to store the age*/
    private int age;
    /* to store the firstName*/
    @Id
    @Column(name="fname")
    private String firstName;
    /* to store the lastName*/
    @Id
    @Column(name="lname")
    private String lastName;
    /* to store the addressList*/
    @OneToMany(cascade = CascadeType.ALL)
    @JoinColumns({
    @JoinColumn(name="_fname", referencedColumnName="fname"),
    @JoinColumn(name="_lname", referencedColumnName="lname")
    private List<Address> addressList;
    public PersonPK getPersonPK() {
    return new PersonPK(this.firstName, this.lastName);
    public void setPersonPK(PersonPK personPK) {
    this.setFirstName(personPK.getFirstName());
    this.setLastName(personPK.getLastName());
    /* @return Returns the age */
    public int getAge() {
    return age;
    /* @param the age to set */
    public void setAge(int age) {
    this.age = age;
    /* @return Returns the firstName */
    public String getFirstName() {
    return firstName;
    /* @param the firstName to set */
    public void setFirstName(String firstName) {
    this.firstName = firstName;
    /* @return Returns the lastName */
    public String getLastName() {
    return lastName;
    /* @param the lastName to set */
    public void setLastName(String lastName) {
    this.lastName = lastName;
    /* @return Returns the addressList */
    public List getAddressList() {
    return addressList;
    /* @param the addressList to set */
    public void setAddressList(List addressList) {
    this.addressList = addressList;
    Thanks

    The JPA 1.0 spec explicitly states that doing this kind of thing is not portable, and in general is not a good object model design to match the relational schema.
    It is recommended that if a foreign key to another table exists in an entity row that there be a relationship from the entity to the corresponding entity of the target table, or that a join table be used.

  • Canon iR7105, iR-ADV9065 with GX300 server, and Mountain Lion

    I am having no luck setting up two relatively recent, large and expensive Canon printers in Mountain Lion. The situations are different so there are two chapters to this wall of text.
    This is a fresh Mac, so it didn't have any 'old' Canon driver trash on it. I have installed UFRII 2.43 and PS 3.60 from Canon and restarted.
    The iR7105
    The iR7105 doesn't show up automatically in the Print & Scan add-printer menus. No problem; I go to IP, using LPD, and set it up there. (LPD access is enabled in the printer.) After that, I have tried setting it up with each of three drivers: a nondescript Canon iR7086-7105, Canon iR7086-7105 PS (US), and Canon iR7086-7105 UFR II (US).
    The nondescript driver results in no setup options for the printer, so I know there's  a problem. This is, however, the closest to a successful setup I have so far. In the print dialog I get finishing options that seem promising, including for our saddle finisher. However, the saddle finisher doesn't engage when I send the print job -- I have to assume this is because the print driver doesn't have a setup where I can tell it what model of  finisher it needs to talk to? Further, there are no options for printing to the printer's Mail Boxes, so I can't just send a file there and fix up the saddle stitch on the printer directly (a workaround we've used with various jobs in the past). However, after the job has run, I CAN go into Command Workstation 5.4.1.25 and adjust the settings on the job there, and then get it to run through the saddle finisher (or to the Mail Boxes). This is the best I have so far, but it's not very good.
    So I try to set up the PS driver. Now I get setup options and I can select the saddle finisher model. I also get a popup asking about unidirectional or bidirectional; I choose bidirectional because the printer is on a network. Also, setting it to unidirectional doesn't change what happens next:  when I do send the print job, the printer cheerfully spits out a dozen or more pages of single-line garbage instead of what I sent to print.
    On to the UFR II driver. Again I get setup options as expected when I set up the printer. Again, the print options are exactly what I expect as well. Unfortunately, the print job doesn't go through: I get an error that says, "Canon UFR II Printer Driver / Cannot communicate with the printer, or the printer is not supported. If the printer is supported, check the printer connection and add it again, then start Printer Utility to get the printer information." Well, the printer is pretty certainly connected, based on the performances above. It's also supported, if Canon's suggesting I should download and use this driver is any indication. Finally, Printer Utility gets printer information that looks quite accurate. Nevertheless, after all of that, actual attempts to print still get the UFR II Printer Driver error message, and no prints.
    The iR-ADV9065 and its GX300V2.0US server
    After installing all the Canon drivers mentioned above, the print server (Canon iR-ADV C9000s GX300V2.0US) shows up in the '+' drop-down in Print & Scan. Great, right?! I can configure the server directly and control the printer that way! Yay!
    Nope. I get a warning: "Some of the software for the printer is missing. You may have to reinstall the software to be able to successfully print." I click Continue, since that's an option, and then I get "Setting up 'Canon iR-ADV C9000s GX300V2.0US...' The software for the printer was installed incorrectly. Please reinstall the software from the manufacturer." This time there is no option except Cancel.
    What would be awesome now would be to know what software I need to reinstall. Since I just installed the UFRII and the PS software on a fresh Mac, I'm not sure what's missing.
    So, back to manually installing with the IP address. From this point forward the results mimic those above, with variations for the printer's specific capabilities. The best driver option is still the non-PS, non-UFR version, and that 'best' option still won't control the finishing units. I must go through Command WorkStation to accomplish that.
    Bottom Line
    Because I am so close to having these set up properly, but not quite, I feel like I must be doing something wrong. Something small and subtle, probably, but hey, maybe it's something big and glaring! Can anyone help?

    mapinoregon wrote:
    The iR7105
    The iR7105 doesn't show up automatically in the Print & Scan add-printer menus.
    The Canon print controllers do not support Bonjour, so using IP > LPD as you have done is the correct procedure.
    mapinoregon wrote:
    The iR7105
    The nondescript driver results in no setup options for the printer, so I know there's  a problem.
    There's no problem. This is how the PPD works on 10.8. For older versions of PPD it was necessary to configure the options. But with the latest versions of PPD, it is assumed that all options are available, even when the machine may not have them or supports them.
    mapinoregon wrote:
    The iR7105
    In the print dialog I get finishing options that seem promising, including for our saddle finisher. However, the saddle finisher doesn't engage when I send the print job -- I have to assume this is because the print driver doesn't have a setup where I can tell it what model of  finisher it needs to talk to?
    It is not a lack of being able to set what finisher you have installed. You just cannot saddle-finish with the PPD. This is only supported with the full driver, such as the UFR2 or PS, because you need the additional plugins that are included with these full drivers to get the additional functions.
    mapinoregon wrote:
    The iR7105
    Further, there are no options for printing to the printer's Mail Boxes, so I can't just send a file there and fix up the saddle stitch on the printer directly (a workaround we've used with various jobs in the past).
    Again, this is due to the lack of a plugin to support the submission to the mailbox. So it is another limitation of the PPD.
    And with you sending the print job to the mailbox in the past, you would have been using a full driver - not the PPD - to achieve this.
    mapinoregon wrote:
    The iR7105
    However, after the job has run, I CAN go into Command Workstation 5.4.1.25 and adjust the settings on the job there, and then get it to run through the saddle finisher (or to the Mail Boxes). This is the best I have so far, but it's not very good.
    If you can connect to the iR7105 with Command Workstation, then you must have a Fiery connected to it, such as the imagePASS-S2. So this would explain why the UFR2 and Canon PS v3.60 driver did not work. The Fiery does not support either driver. They are for the iR7105 that is using its internal Canon controller. Not the optional imagePASS (Fiery).
    Now the issue for you with the imagePASS-S2 is that no 10.8 driver exists - the iR7105 was released in mid 2006. So you will have to use the Fiery Express driver, which has limited functions but it is better than using the Generic Postscript driver.
    mapinoregon wrote:
    The iR-ADV9065 and its GX300V2.0US server
    After installing all the Canon drivers mentioned above, the print server (Canon iR-ADV C9000s GX300V2.0US) shows up in the '+' drop-down in Print & Scan. Great, right?! I can configure the server directly and control the printer that way! Yay!
    Nope. I get a warning: "Some of the software for the printer is missing. You may have to reinstall the software to be able to successfully print." I click Continue, since that's an option, and then I get "Setting up 'Canon iR-ADV C9000s GX300V2.0US...' The software for the printer was installed incorrectly. Please reinstall the software from the manufacturer." This time there is no option except Cancel.
    Like the iR7105 with the Fiery attached, the GX300 connected to the ADV C9065 does not support the UFR2 or PS v3.60 driver. But at least there is a 10.8 driver available for this model. Here is a link to the GX300 page from Canon USA.
    Now with this driver installed you can add it by selecting the "Canon iR-ADV C9000s GX300V2.0US" that appears in the Default Add Printer view (and the Nearby Printers window). The driver should be automatically found by the Mac, meaning the Use menu will be set to the correct driver. This will let you print and use most finishing features of the iR ADV C9065.
    Hope the above helps you. Reply if you need more info.

  • Cannon C2880i shared printer on windows network

    Hi gang,
    I'm a total rookie with apple. I have logged on to our network at work without a problem. I don't know how to connect to our fancy all-in-one which is so critical to my productivity. It's a Cannon C2880i. Can somebody point me in the right direction. I can't even find it to connect properly.
    Thanks

    The adding of the Canon iR network printer is a two step process. First you need to add the driver software to your Mac and then you need to create a printer queue to connect to it.
    The iRC2880 has two driver options for Mac OS X, the Canon PS driver v2.11 or UFR2 driver v1.70. You can download either driver from most Canon web sites. With the driver downloaded, once you have unpacked the file, as it is often compressed, you can run the Installer to add the necessary files to your Mac.
    Once the installer has completed, you can add a printer queue to the copier. Since the machine typically doesn't advertise itself on the network, you will need to know its ip address. There are a number of ways you can do this, but probably the easiest is to check one of the other computers that is printing to it. Better still, if they are using Windows, get them to print a test page which will show the ip address.
    Once you know the ip address, you can create the printer queue.
    1. Open System Preferences then Print & Fax.
    2. If you installed the PS v2.11 driver, click the + button and select IP.
    3. Change the menu to HP Jetdirect.
    4. Enter the ip address of the iRC2880.
    5. You will notice the name shows the same ip address, so if you want to change the name to something more meaningful, like Color Printer, then you can. You can also enter a location, but this is just for your reference.
    6. In the Print Using menu, change the menu to 'select a driver to use' and in the search window, type 2880. This should show you 'Canon iR C2880/3380 PS (UK)'. Select this.
    7. Click Add to complete the installation
    8. With the PS v2.11 driver you may be asked about selecting Unidirectional or Bidirectional for the communication. Select Bidirectional as it gives you more features.
    9. Once the printer queue is created, you can try printing to it.
    Note that if you use the UFR2 driver instead of the PS driver, the steps to create the printer queue are different.
    1. Click the + button to add the printer queue
    2. Click More Printers
    3. Change the menu to Canon IP (UFR2)
    4. Enter the IP address of the iRC2880
    5. Enter a queue name of LP
    6. Click Add.
    The driver talks to the printer to select the appropriate model from its list. So you should see the iRC2880 in your printers list if everything works as it should.
    HTH
    PaHu

  • Regarding Coherence Network Performance test?

    Hi,
    We have performed the datagram tests for two servers that we have using the coherence datagram test scripts.
    We have shared the results that we got after a run of 60 – 65 seconds each for the unidirectional and bidirectional tests.
    Please refer to
    https://docs.google.com/spreadsheet/ccc?key=0Atn1ma-myp6ndEc0THBKRTFDSnBaN0NqV1o1Ym1jRnc#gid=0
    for the results.But we want to understand from these results if this performance is under the agreeable range, for which we don’t have any absolute references with us.
    Can someone suggest if this network performance is good enough or if there are any problems based on these statistics?
    Quick help much appreciated. Thanks in advance.
    Edited by: saiyansharwan on Jan 11, 2012 5:40 AM

    Appreciate your response much. For your reference I am putitng the details on the excel sheet right on the reply.
    For unidirectional test
    =============
    Test Parameters -
    1     Buffersize     89 (Changed as exception occurred due to OS buffer size limitations)
    2     Packet size     1468 (default size adopted)
    3     Command on Server A     sh datagram-test.sh serverb
    4     Command on Server B     sh datagram-test.sh -rxBufferSize 89 ( to limit the receive buffer size assumed by coherence to match with the actual value in the OS.)
    Results:
    Server A as publisher and Server B as listener          
    Publisher Details     Byte transfer rate for Server A     111 MB/sec
         Packet transfer rate for Server A     79550 packets/sec
    Listener Details
    Sl.No     Parameter     Server B values
    1     elapsed     61547ms
    2     packet size     1468 packets
    3     throughput     111 MB/sec
              79614 packets/sec
    4     received     4900000 of 4902366
    5     missing     2366 packets
    6     success rate     0.9995174
    7     out of order     0
    8     avg offset     0
    9     gaps     802
    10     avg gap size     2
    11     avg gap time     0ms
    12     avg ack time     -1.0E-6ms; acks 0
    For Bidirectional test
    ============
    Test Parameters -
    Sl.No     Parameters     Values     Remarks
    1     Buffersize     89     Changed as exception occurred due to OS buffer size limitations
    2     Packet size     1468     default size adopted
    3     Command on Server A     sh datagram-test.sh -polite serverb -rxBufferSize 89     started on polite mode to wait till it receives data
    4     Command on Server B     sh datagram-test.sh servera -rxBufferSize 89     
    Results:
    Publisher Details
         Byte transfer rate for Server A     114 MB/sec
         Packet transfer rate for Server A     81367 packets/sec
         Byte transfer rate for Server B     84 MB/sec
         Packet transfer rate for Server B     59768 packets/sec
    Listener Details
    Sl.No     Parameter          Server A               Server B
    1     elapsed          65037ms               64932ms
    2     packet size          1468 packets          1468 packets
    3     throughput          107 MB/sec               65 MB/sec
                   76618 packets/sec          46202 packets/sec
    4     received          4982987 of 5050738          3000000 of 3001389
    5     missing          67751 packets          1389 packets
    6     success rate          0.9865859               0.9995372
    7     out of order          0               0
    8     avg offset          0               0
    9     gaps          20097               119
    10     avg gap size          3               11
    11     avg gap time     0ms               0ms
    12     avg ack time          1.149157ms; acks 309602     1.169717ms; acks 1017381
    As you may observe, unlike the test you performed, bidirectional tests are showing much better success rate in this case.
    But what I was looking for was some standards to compare against to decide if these statistics indicate good network performance.
    Any suggestions?
    Best Regards.

  • General query on CSM and CSS flow timeout values

    Hi all,
    i have a SLB Application Processor Complex module on my Cisco 6504 which basically does some load balancing work. I am pretty new to this device but the configurations and setup looks somewhat similar to the Cisco ACE but i only have some experience with the Cisco CSS.
    What i would like to know is what the equivalent command to the CSS "flow timeout" is on the CSM. Would that be the "idle timeout" command? I understand that the "pending timeout" is more to governing how long it takes to setup a 3 way handshake from client to server and the "idle timeout" is what i am looking for. Please correct me if i am wrong...
    On the CSS, a flow timeout is on 16secs for most standard ports and 8 secs for HTTP. I would like to know what the default setting is for the CSM idle timeout?? Thanks alot!!
    Daniel

    Hi Daniel,
    For Idle Timeout the the default is 1 hour/ 3600 sec.
    As you know for Cicso CSM thare are 2 timers per vserver.
    Idle timeout
    Pending timeout.
    If a connection is timed out it's because of one of these timers.
    Idle timeout per vserver - If there is no traffic neither from client nor server. Idle connection timer duration in seconds; the range is from 0 (connection remains open indefinitely) to 13500000. The default is 1 hour. If you do not specify a duration value, the default value is applied.
    Examples
    This example shows how to specify an idle timer duration of 4000:
    Cat6k-2(config-slb-vserver)# idle 4000
    Pending timeout per vserver - is the max time allowed to complete the 3-way handshake.The default is 30 sec.Range is from 1 to 65535. This is a SLB virtual server configuration submode command. The pending connection timeout sets the response time for terminating connections if a switch becomes flooded with traffic. If the 3-way handshake does not complete within this time, the connection is dropped.
    The CSM expect to see 2-way traffic within the pending timeout. If no traffic is received from the server, the session is removed.
    Examples
    This example shows how to set the number to wait for a connection to be made to the server:
    Cat6k-2(config-slb-vserver)# pending 300
    These are not counted as failures.
    A failure is when the server does not respond or respond with a reset.
    The CSM can hold 1 million connections in memory at the max.
    So, if you set the idle timeout to 10 hours, your max connection rate is 1 M / 10 * 3600 = ~250 conn/sec.
    Assuming they would all be open and then idle.
    When the number of pending connections exceeds a configurable threshold, the CSM begins using the SYN cookies feature, encrypting all of the connection state information in the sequence numbers that it generates. This action prevents the CSM from consuming any flow state for pending (not fully established) TCP connections. This behavior is fully implemented in hardware and provides a good protection against SYN attacks.
    Generic TCP termination
    Some connections may not require TCP termination for Layer 7 load balancing. You can configure any virtual server to terminate all incoming TCP connections before load balancing those connections to the real servers. This configuration allows you to take advantage of all the CSM DoS features located in Layer 4 load-balancing environments.
    To select the traffic type and appropriate timeout value, use the unidirectional command in the SLB virtual server submode.
    [no | default] unidirectional
    some protocol automatically set the 'unidirectional' function.
    For example : UDP.
    You can see if a vserver is unidirectional or bidirectional by doing a 'sho mod csm X vser name detail'
    When a virtual server is configured as unidirectional, it no longer uses the pending timer. Instead, the idle timer will determine when to close idle or errant flows. Because the idle timer has a much longer default duration than the pending timer, be sure to set the idle timer to an appropriate value.
    Use the command  "show module csm slot# stats" to get the details of connection.
    The statistics counters are 32-bit. Totals are accumulated since the last time the counters were cleared.
    Examples
    This example shows how to display SLB statistics:
    Cat6k-2# show module csm 4 stats
    Connections Created:       180
    Connections Destroyed:     180
    Connections Current:       0
    Connections Timed-Out:     0
    Connections Failed:        0
    Server initiated Connections:
          Created:0, Current:0, Failed:0
    L4 Load-Balanced Decisions:180
    L4 Rejected Connections:   0
    L7 Load-Balanced Decisions:0
    L7 Rejected Connections:
          Total:0, Parser:0,
          Reached max parse len:0, Cookie out of mem:0,
          Cfg version mismatch:0, Bad SSL2 format:0
    L4/L7 Rejected Connections:
          No policy:0, No policy match 0,
          No real:0, ACL denied 0,
          Server initiated:0
    Checksum Failures: IP:0, TCP:0
    Redirect Connections:0,  Redirect Dropped:0
    FTP Connections:           0
    MAC Frames:
          Tx:Unicast:1506, Multicast:0, Broadcast:50898,
              Underflow Errors:0
          Rx:Unicast:2385, Multicast:6148349, Broadcast:53916,
              Overflow Errors:0, CRC Errors:0
    Table mentioned below describes the fields in the display.
    Table for "show module csm stats" Command Field Information
    Field
    Description
    Connections Created
    Number of connections that have been created on the CSM.
    Connections Destroyed
    Number of connections that have been destroyed on the CSM.
    Connections Current
    Number of current connections at the time the command was issued.
    Connections Timed-Out
    Number of connections that have timed out, which can occur for the following reasons:
    •connection has been idle (in one or both directions) for longer than the configured idle timeout.
    •TCP connection setup not completed successfully.
    Connections Failed
    Number of connections failed because the server did not respond within the timeout period, or the server replied with a reset.
    Server initiated Connections
    Number of connections created by real servers, the number of current connections, and the number of connections that failed (because the destination is unreachable).
    L4 Load-Balanced Decisions
    Number of Layer 4 load-balancing decisions attempted.
    L4 Rejected Connections
    Number of Layer 4 connections rejected because no real server was available
    L7 Load-Balanced Decisions
    Number of Layer 7 load-balancing decisions attempted.
    L7 Rejected Connections: Total
    Number of Layer 7 connections rejected.
    L7 Rejected Connections: Parser
    Number of Layer 7 connections rejected because the Layer 7 processor in the CSM ran out of session buffers to save the parsing state for multi-packet HTTP headers. The show module csm tech-support proc 3 command will show detailed buffer usage.
    L7 Rejected Connections: Reached max parse len
    Number of Layer 7 connections rejected because the HTTP header in the packet is longer than max-parse-len. When a virtual server is configured with HTTP persistent rebalancing or cookie matching/sticky, the CSM must parse to the end of HTTP header. The default max-parse-len value is 2000 bytes.
    L7 Rejected Connections: Cookie out of mem:
    Number of Layer 7 connections rejected because of no memory to store cookies. When a virtual server is configured with cookie matching, the CSM must save the cookie contents in memory.
    L7 Rejected Connections: Cfg version mismatch
    Number of Layer 7 connections rejected because part of the request was processed with an older version of the configuration. This counter should only increase after configuration changes.
    L7 Rejected Connections: Bad SSL2 format:
    Number of Layer 7 connections rejected because the request is using an unsupported SSL format or the format is not valid SSL.
    L4/L7 Rejected Connections
    Number of Layer 4 and Layer 7 connections rejected for policy related reasons:
    No policy: connection rejected because the request matched a virtual server, but this virtual server did not have a policy configured.
    No policy match: connection rejected because the request matched a virtual server, but the request did not match any policy configured on the virtual server.
    No real: connection rejected because no real server was available to service the request
    ACL denied: connection rejected because a request matched a policy with a client-access-list entry and the entry is configured to deny the request.
    Server Initiated: connection initiated by a real server is rejected.
    Checksum Failures
    Number of checksum failures detected (there are separate counters for IP and TCP failures).
    Redirect Connections
    Number of connections redirected, and the number of redirect connections dropped.
    FTP Connections
    Number of FTP connections opened.
    MAC Frames
    Number of MAC frames received and transmitted on the CSM backplane connection.
    For getting details on all of these commands kindy refer Catalyst 6500 Series Switch Content Switching Module Command Reference, 4.2 URL mentioned below:
    http://cisco.biz/en/US/docs/interfaces_modules/services_modules/csm/4.2.x/command/reference/cmdrfIX.html
    Kindly Rate.
    HTH
    Sachin Garg

  • Want to know more about their work topology of GoldenGate?  And example

    work of GoldenGate example uni-direction,bidirection and other
    thankyou

    The examples shown in the admin guide are easy to understand. What - specifically - is it you do not understand about unidirectional and bidirectional configurations?
    Unidirectional
    Source - primary extract and secondary extract (data pump)
    Target - replicat
    Bidirectional
    Source - primary extract and secondary extract for source/A database, and replicat to process trails sent from the target/B database
    Target - primary extract and secondary extract for target/B database, and replicat to process trails sent from the source/A database
    Do the tutorial in the link provided earlier. Put hands on keyboard and try.
    Using Oracle GoldenGate for Oracle to Oracle Database Synchronization
    This tutorial provides instructions on how to configure GoldenGate to provide Oracle to Oracle database synchronization.
    http://apex.oracle.com/pls/apex/f?p=44785:24:8700699511844680::NO:24:P24_CONTENT_ID,P24_PREV_PAGE:5340,2

  • Neural Nets + Face detection/recognition

    Does anyone have any experience with this, I've been struggling to find decent resources on whether or not building an ANN in Java for this purpose is a reasonable idea or not, even to produce something that wouldn't necessarily, or likely, be massively successful.
    In fact, I've come across very little actual code for this in any programming language so whilst preferring Java, to see any implementation would be interesting for me. I'm aware of JOONE(?) but I suspect that's a relatively mature project and I'd like to see smaller examples of ANNs so I can get some of the concepts first.
    Is it feasible? Are there any online documented instances of people doing this where their code is available? It needs to be *nix too, I did find a link to a VB program but that's not much good as I don't have a Windows box.
    Thanks

    For face detection/recognition, a BAM (Biderectional Associative Memory) neural net would do fine.
    Google for 'Kosko' or ''Bidirectional Associative Memory'. It's quite easy to implement, just a bit
    of matrix multiplications ...
    kind regards,
    Jos

  • Domain in other Forest Dont See Object in other domain forest

    hi to all
    i have one problem that confused me for weeks
    i hope that you have solution for it
    i have 2 domain in 2 forest that trust between 2 forest established and verified . 
    administrator from domain a in forest a can see all objects in domain b in forest b and administrator from domain b in forest b can see all object from windows client with os 7 by admin pack installed . problem is admin from domain controller in forest b
    cannot see any object in domain a . i delete antivirus from 2 domain and disable firewall but problem still exist . can you help me ?

    The first thing to check is if your trust relationship in unidirectional or bidirectional.
    If it is unidirectional then that would explain the things. In this case, you will need to have a bidirectional trust relationship.
    If you already have a bidirectional trust relationship then you might want to make sure that DCs and AD replication in both domains are in healthy state using
    dcdiag and repadmin commands. That would help: http://www.ahmedmalek.com/web/fr/articles.asp?artid=23
    Also, use NSlookup to make sure that you can do properly the DNS resolution from both domains and that, from each domain, you can do a DNS resolution for resources in the other domain: http://social.technet.microsoft.com/wiki/contents/articles/29184.nslookup-for-beginners.aspx
    You can also validate the trust relationship in both directions and see if any error is thrown.
    This posting is provided AS IS with no warranties or guarantees , and confers no rights.
    Ahmed MALEK
    My Website Link
    My Linkedin Profile
    My MVP Profile

Maybe you are looking for

  • Upgraded new itunes and wont open!!!

    I too have upgraded and can not open it, I have tried everything posted in support, and what i have read from the discussions. I even tried to reinstall it with the original ipod CD and it still didnt work. when i click itune nothing happens, and it

  • Webcams for Toshiba TV's

    What web cam (Toshiba preferably) is compatible with Toshiba TV 50L7300U - thanks?

  • [AS CS5] Sorting out multiple nested objects

    I have documents where we have labelled frames for scripting. Some of our artist have pasted these labelled frames inside of duplicates of the original labelled frame, or they have group multiple objects, and pasted then into (using **paste into) the

  • Business Delegate and Service Locator

    Hi all, I read the Business Delegate Pattern and my question is about how many Business Delegate I must write: a) one for every Session Beans ? (in a Session Facade Pattern) b) one for all Session Beans ? Is it right that I must have a single Busines

  • HT4889 Can I make a bootable backup of my machine and OS on a Firewire drive?  If so, how?  Thanks.

    I waqnt to make abootable backup of My OS Lion and internal hard drive on an external FW800 hard drive, I can use it if the Mac crashes, so I can re-install the OS and all my software on the Mac. Is this possible? Also, I used time machine on an exte