3750X rate-limit (QoS)

Hello,
I'm trying to configure a rate-limit in a 3750X but I'm not seeing any result... 
These are my configurations:
RF#show run 
Building configuration...
Current configuration : 23410 bytes
! Last configuration change at 08:53:35 UTC Sun Mar 14 1993
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname RF
boot-start-marker
boot-end-marker
no aaa new-model
switch 1 provision ws-c3750x-48p
system mtu routing 1500
ip routing
ip domain-name erf.carco.com.mx
rep admin vlan 100
mls qos
spanning-tree mode pvst
spanning-tree extend system-id
vlan internal allocation policy ascending
vlan 2
vlan 4 
vlan 6
vlan 8
vlan 10
vlan 20
vlan 21   
vlan 22
vlan 23
vlan 25 
vlan 26
vlan 30
vlan 50
vlan 53
vlan 70
vlan 81
vlan 91
vlan 92
vlan 93
vlan 95
vlan 96
vlan 99
vlan 100
vlan 102
vlan 110
vlan 122
vlan 129
vlan 200
vlan 213
vlan 227
vlan 333
vlan 357
vlan 417
vlan 444
vlan 500
vlan 502
vlan 555
vlan 700
vlan 712
vlan 910
vlan 911
vlan 951
vlan 1105
vlan 1508
vlan 1830
vlan 1870
vlan 1890
vlan 1891
vlan 1892
class-map match-any test
  match access-group 100
policy-map test
 class test
  police 150000000 512000 exceed-action drop
interface Loopback0
 ip address 10.20.40.106 255.255.255.0
interface Port-channel22
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 bandwidth 10000000
 rep segment 10
interface Port-channel24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 bandwidth 10000000
 rep segment 10
interface FastEthernet0
 no ip address
 no ip route-cache
 shutdown
interface GigabitEthernet1/0/1
interface GigabitEthernet1/0/2
interface GigabitEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport trunk allowed vlan 2,10,50,53,60,70,91-93,95,96,99,100,110,213,227
 switchport trunk allowed vlan add 500,700,910,911,951,1830,1870,1890-1892
 switchport mode trunk
 no logging event link-status
 shutdown
 speed 1000
 duplex full
interface GigabitEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport trunk allowed vlan 2,8,10,20,50,53,70,91-93,95,96,99,100,110,213
 switchport trunk allowed vlan add 227,500,700,910,911,951,1830,1870,1890-1892
 switchport mode trunk
 shutdown
 speed 1000
 duplex full
interface GigabitEthernet1/0/5
interface GigabitEthernet1/0/6
interface GigabitEthernet1/0/7
interface GigabitEthernet1/0/8
interface GigabitEthernet1/0/9
interface GigabitEthernet1/0/10
 switchport access vlan 91
 switchport mode access
 logging event link-status
interface GigabitEthernet1/0/11
interface GigabitEthernet1/0/12
interface GigabitEthernet1/0/13
interface GigabitEthernet1/0/14
interface GigabitEthernet1/0/15
 switchport access vlan 91
 switchport mode access
 logging event link-status
interface GigabitEthernet1/0/16
interface GigabitEthernet1/0/17
interface GigabitEthernet1/0/18
interface GigabitEthernet1/0/19
interface GigabitEthernet1/0/20
 switchport access vlan 91
 switchport mode access
 logging event link-status
interface GigabitEthernet1/0/21
interface GigabitEthernet1/0/22
interface GigabitEthernet1/0/23
interface GigabitEthernet1/0/24
interface GigabitEthernet1/0/25
 switchport access vlan 910
 switchport mode access
interface GigabitEthernet1/0/26
interface GigabitEthernet1/0/27
interface GigabitEthernet1/0/28
interface GigabitEthernet1/0/29
interface GigabitEthernet1/0/30
interface GigabitEthernet1/0/31
interface GigabitEthernet1/0/32
interface GigabitEthernet1/0/33
interface GigabitEthernet1/0/34
interface GigabitEthernet1/0/35
interface GigabitEthernet1/0/36
interface GigabitEthernet1/0/37
 no switchport
 bandwidth 150000
 ip address 10.20.103.13 255.255.255.252
 rate-limit output access-group 100 24000000 3000000 3000000 conform-action transmit exceed-action drop
 logging event link-status
interface GigabitEthernet1/0/38
interface GigabitEthernet1/0/39
interface GigabitEthernet1/0/40
interface GigabitEthernet1/0/41
interface GigabitEthernet1/0/42
interface GigabitEthernet1/0/43
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 bandwidth 10000000
 channel-group 24 mode on
interface GigabitEthernet1/0/44
interface GigabitEthernet1/0/45
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport trunk allowed vlan 2,10,50,53,60,70,91-93,95,96,99,100,110,213,227
 switchport trunk allowed vlan add 500,700,910,911,951,1830,1870,1890-1892
 switchport mode trunk
 shutdown
interface GigabitEthernet1/0/46
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport trunk allowed vlan 2,10,50,53,60,70,91-93,95,96,99,100,110,213,227
 switchport trunk allowed vlan add 500,700,910,911,951,1830,1870,1890-1892
 switchport mode trunk
 shutdown
interface GigabitEthernet1/0/47
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 bandwidth 10000000
 channel-group 22 mode on
interface GigabitEthernet1/0/48
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 6
 switchport trunk allowed vlan 2,7,10,20,50,53,70,91-93,95,96,99,100,110,213
 switchport trunk allowed vlan add 227,700,910,911,951,1830,1870,1890-1892
 switchport mode trunk
 logging event link-status
 shutdown
interface GigabitEthernet1/1/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport trunk allowed vlan 2,8,10,20,50,53,60,70,91-93,95,96,99,110,213,227
 switchport trunk allowed vlan add 500,700,910,911,951,1830,1870,1890-1892
 switchport mode trunk
 shutdown
interface GigabitEthernet1/1/2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport trunk allowed vlan 2,8,10,20,50,53,60,70,91-93,95,96,99,110,213,227
 switchport trunk allowed vlan add 500,700,910,911,951,1830,1870,1890-1892
 switchport mode trunk
 shutdown
interface GigabitEthernet1/1/3
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 6
 switchport trunk allowed vlan 2,6,8,10,20,50,53,70,91-93,95,96,99,100,110,213
 switchport trunk allowed vlan add 227,700,910,911,951,1830,1870,1890-1892
 logging event link-status
 shutdown
interface GigabitEthernet1/1/4
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 6
 switchport trunk allowed vlan 2,6,8,10,20,50,53,70,91-93,95,96,99,100,110,213
 switchport trunk allowed vlan add 227,700,910,911,951,1830,1870,1890-1892
 switchport mode trunk
 logging event link-status
 shutdown
interface TenGigabitEthernet1/1/1
interface TenGigabitEthernet1/1/2
interface Vlan1
 no ip address
 shutdown
interface Vlan6
 description ***LANERF**
 ip address 10.20.6.106 255.255.255.0
 no ip redirects
interface Vlan23
 description < TRANSITO MUR >
 no ip address
 no ip redirects
interface Vlan100
 description < VLAN MAN >
 ip address 10.20.100.106 255.255.255.0
 no ip redirects
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 032368342B2F0F
 ip ospf dead-interval minimal hello-multiplier 4
router ospf 1
 router-id 10.20.40.106
 auto-cost reference-bandwidth 100000
 area 0.0.0.0 authentication message-digest
 area 1.80.1.1 authentication message-digest
 redistribute connected subnets
 redistribute static subnets
 passive-interface default
 no passive-interface Vlan23
 no passive-interface Vlan100
 no passive-interface GigabitEthernet1/0/37
 network 10.20.6.0 0.0.0.0 area 0.0.0.0
 network 10.20.40.106 0.0.0.0 area 0.0.0.0
 network 10.20.91.6 0.0.0.0 area 0.0.0.0
 network 10.20.100.106 0.0.0.0 area 0.0.0.0
 default-information originate
ip http server
ip http secure-server
access-list 100 permit ip 10.50.80.0 0.0.0.255 10.80.80.0 0.0.0.255
access-list 100 permit ip 10.80.80.0 0.0.0.255 10.50.80.0 0.0.0.255
snmp-server community ASComRO RO
line con 0
line vty 0 4
 login
line vty 5 15
 login
event manager applet track_qos_down authorization bypass
 event syslog pattern "TRACKING-5-STATE: 15 ip sla 15 reachability Up->Down"
 action 1 cli command "enable"
 action 2 cli command "configure terminal"
 action 3 cli command "interface giga1/0/37"
 action 4 cli command "rate-limit output access-group 100 400000000 50000000 50000000 conform-action transmit exceed-action drop"
 action 5 cli command "end"
event manager applet track_qos_up authorization bypass
 event syslog pattern "TRACKING-5-STATE: 15 ip sla 15 reachability Down->Up"
 action 1 cli command "enable"
 action 2 cli command "configure terminal"
 action 3 cli command "interface giga1/0/37"
 action 4 cli command "no rate-limit output access-group 100 400000000 50000000 50000000 conform-action transmit exceed-action drop"
 action 5 cli command "end"
end
ERF#     
ERF#show mls qos 
QoS is enabled 
QoS ip packet dscp rewrite is enabled 
ERF#show mls qos inter gigabitEthernet 1/0/37 
GigabitEthernet1/0/37 
trust state: not trusted 
trust mode: not trusted 
trust enabled flag: ena 
COS override: dis 
default COS: 0 
DSCP Mutation Map: Default DSCP Mutation Map 
Trust device: none 
qos mode: port-based 
When I apply the command I'm seeing a gauge using a 3rd party but I'm not seeing that the traffic will be truncated @ 50Mbps.
Any thoughts??? 

Hi
Bandwidth commands allocates the particular amount of bandwidth you mention or configure over there.
Basically you have the liberty to configure upto 75% of the available interface bandwidth to different classes.
most widelys used with CBWFQ technique..
so while configuring up the same better to watch out for the exact bandwidth value keyed in on the interface to have your alloocation work properly.
policing basically used for limiting the traffic or to control the bursts by dropping them or marking them with different ip precedence or DSCP values.
its very much similar to the rate-limit command applied on the interface level which again uses token bucket system either single or dual based on the configuration parameters.
for more info on above mentioned clis do check these links..
http://www.cisco.com/en/US/tech/tk543/tk545/tsd_technology_support_protocol_home.html
http://www.cisco.com/en/US/tech/tk543/tk544/tsd_technology_support_protocol_home.html
regds

Similar Messages

  • Bandwidth Management(Rate Limit) Using QoS Policies

    Hello,
    I need some advice. We have an ASA 5525 running version 8.6(1)2 and a 10 MG pipe. I have execs that want to limit bandwidth on users for stuff like youtube, stream media, and downloads. I found the article on ‘Bandwidth Management(Rate Limit) Using QoS Policies’ so it appears our firewall can do what we want. I’m not a cisco person. My knowledge is limited when it comes to configuration – that’s why we have SmartNet :). The advice I need is what to ask for, so to speak, when I put a case in. Can bandwidth be limited on end users and/or can they limit the ‘bandwidth rate limit’ to just youtube, steaming media, and downloads? If so, what should the limit be? and I’m assume this would be for ‘incoming’ traffic only? we’re running into some bandwidth hogs – usually youtube and/or streaming media. We have a Barracuda web filter which we’ve used to block and monitor activity but I simply do not have time to babysit this all day. I should also mention we do have critical data running up and down the pipe; such as credit card processing, DB replication between in house DB and hosted website, TPCx and EDI, FTP, and such that we don’t want restricted.
    Need input please,
    Thanks,
    D

    Hello,
    That's a question that you as the network admin of that organization could answer.
    How much traffic for business purposes must travel via HTTP/HTTPS?
    How much bandwith are you willing to provide to this 2 protocols?
    Those are the kind of answers you need to answer before setting the number
    Regards
    Remember to rate all of the helpful posts, Just click the 5 stars at the left of each post
    Julio

  • QoS bandwidth rate limit don't work

    Hello
    Buy a router RV120W, and one of the reasons is limit of bandwidth (QoS). I set up a profile of 1-256 kbps limit, and apply it to the only VLAN that is configured, but does not work and can navigate using the full bandwidth of the internet connection. My firmware version is 1.0.2.6
    Screenshots attached
    thanks
    screenshots attached

    Struggling with a similar issue:
    the setup: internet adsl <--1mbs--> combined router/modem <--100mbs--> RV 120W
    Internet speed is 1mbs. I want to priotize voip calls (via port) and deprioritize one machine (doing downloads). rest of the network should have something in between.
    Firmware upgraded to 1.0.3.10
    I created the profiles bindings, then in QoS settings, selected Priority, Wan total bandwidth 1mbs, and distributed my profiles onto low/med/high (10/31/61).
    When what should be low is downloading, it gets the whole 1mbs and the other are dead slow.
    Changed to rate limit, changed the parameters, etc... no more luck.
    Can you please shed some light as how to configure this - in my case, the whole bw of wan is being used, and prioriization is not happening,
    Rgds

  • SGE2000 QoS: Ingress Rate Limit BUG ?

    I buyed a new unit of SGE2000. Thirst I changed firmware to newest one (3.0.0.18) so I do not know what firmware was installed before.
    The problem is that it is not posssible to change Ingress Rate Limit to value lower than 3500...
    Hardware Version
    00.00.01
    Software Version
    3.0.0.18
    Boot Version
    2.0.0.03
    Manual says:
    Ingress Rate Limit — Defines the amount of bandwidth assigned to the interface.
    For FE ports, the rate is 62 - 100,000 Kbps.
    For GE ports, the rate is 62 - 1,000,000 Kbps
    ====
    Default value for Ingress Rate Limit field is 3500, while I change it to eg. 512 the combobox is opening with warning information:
    "Entered value in highlighted field must be an Integer. Range 3500...1000000"
    "Committed Information Rate (CIR)" field allow to put a value down to 64, so it is ok.
    Should I downgrade firmware to v3.0.0.17 ?
    Any help appreciated.

    My appologies for the lack of reply here.  I checked with the PM for the product and they asked me if there is a case open with the Small Business Support Center (SBSC) on this issue.  Have you had a case open on this yet?  If not can I ask you to log a case and then respond back to this postig with the case number please?  It seems this is a bug so the product team will need to process the fix for this via the standard problem identification/case reporting process.
    Thanks in advance!

  • Bandwidth Rate-Limit -w- WWR-Queue

    How would one convert a layer-2 port's "switchport rate-limit" bandwidth statement, on a 6509 -w- WS-X6748-SFP ports, to a routed/layer-3 "wrr-queue" bandwidth statement policy? Basically trying to hard-core the port's speed to 20MB.  Current/tested layer-2 port bandwidth setting:
    rate-limit input 20000000 5000 5000 conform-action transmit exceed-action drop
    rate-limit output 20000000 5000 5000 conform-action transmit exceed-action drop
    Got lost in how to use/configure all WRR's four queues... just need to limit the port's bandwidth to 20MB.  Any suggestions would be appreciated.
    Thanks, Kevin

    1) Enabled QoS globally...
    2960(config)#mls qos
    2) Configure an ACL to define the matched traffic...
    2960(config)#access-list 111 permit ip any any
    3) Configure a class map for the matched traffic...
    2960(config)#class-map traffic
    2960(config-cmap)#match access 111
    4) Configure a policy-map to define action...
    2960(config)#policy-map Control
    2960(config-pmap)#class traffic
    2960(config-pmap-c)#police 10000000 8000 exceed-action drop
    5) Attached the policy-map to the interface.
    a) Example
    -In this case, I'll attach the policy map to port_1....
    2960(config)#int fa0/1
    2960(config-if)#service-policy input Control
    >>>>>> This will rate-limit traffic coming from the PC

  • Per user bandwidth rate limit.

                       How to configure per user bandwidth rate limit for wireless guest client, authentication server is ISE 1.2 & wireless controller is 5760.

    The Cisco 5760 WLC supports better QoS than other c
    ontrollers, allowing prioritization of mission-crit
    ical
    applications:

    The Cisco 5760 WLC supports four wireless hardware
    queues and priority-based queuing compared to
    software-based queuing in existing controllers.

    The Cisco 5760 WLC follows MQC based commands, allo
    wing usage of exact commands for configuring
    QoS on different types of network devices.

    The Cisco 5760 WLC supports QoS policies to be appl
    ied in a hierarchical fashion with more granularity
    per SSID per radio, while on the current controller
    s granularity is per WLAN.

    The Cisco 5760 WLC supports approximate fair bandwi
    dth to make sure of fairness at client, SSID, and
    radio levels for Non-Real Time (NRT) traffic. There
    fore, if one user consumes excessive bandwidth, we
    can
    limit the amount of bandwidth that user receives an
    d thereby not deprive other users.

  • WLC 5508 and Anchor/GuestNet rate limit traffic?

    Running WLCs 5508s 7.0.116.0 with GuestNet and Anchor setup, how can I limit the bandwidth on the GuestNet SSDI to 2 Mbps, etc?
    The DMZ WLC (Anchor) runs thru a ASA 5508 7x, can I rate limit traffic via ASA?

    That's really a matter of preference.  This document describes things to keep in mind when altering these QoS profile configurations, FYI.
    http://www.cisco.com/en/US/partner/docs/wireless/controller/7.0MR1/configuration/guide/cg_controller_setting.html#wp1254532
    It really depends on how many guests, what type of traffic, etc, to make a judgement call as to where you should set these.  I'm sorry but I don't have any examples from existing configurations, but hopefully the document explains how to best alter these settings.

  • Rate-limit command 3560 does it exist?

    I have just come across a command in my router IOS which might be useful too me. I was wondering if the following command is available on a 3560 Switch. I don't see it on my 3550 but the IOS is quite old. I don't have a 3560 avaiable currently to check.
    Config t > int vlan x > rate-limit input/output
    does this exist on the 3560? I am also interest if it does in the Bits per second range and if available input/output.
    Thanks for any help

    Hello,
    what kind of feature are you looking for?
    CAR?
    http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_command_reference_chapter09186a0080087f26.html#wp1037428
    For command list check the following link:
    Catalyst 3560 Switch Command Reference, Rel. 12.2(25)SEE
    http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12225see/cr/index.htm
    For QOS configs:
    http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12225see/scg/swqos.htm
    If you need to rate limit traffic on an interface check:
    Limiting the Bandwidth on an Egress Interface
    http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12225see/scg/swqos.htm#wp1253412
    Hope this help a bit,
    if it does, please rate this post.
    Vlad

  • Can I rate-limit on the sub-interface in cisco asr 1013?

    Hi,
    I am looking for the command of rate-limit on a sub-interface in cisco asr 1013.
    Cisco IOS Software, IOS-XE Software (X86_64_LINUX_IOSD-ADVENTERPRISEK9-M), Version 15.2(2)S, RELEASE SOFTWARE (fc1)
    IOS XE Version: 03.06.00.S
    Please let me know if it is possible in cisco asr 1013. If yes then what are the commands.
    Zobair

    The ASR no longer supports the rate-limit command, but it does support the same functionality in a QoS policy.
    Please find a sample configuration -
    ASR1004(config)#policy-map test
    ASR1004(config-pmap)#class class-default
    ASR1004(config-pmap-c)#shape average 10000
    Applying for both ingress and egress : -
    ASR1004(config)#int gig1/1/0
    ASR1004(config-if)#service-policy output test   
    or
    ASR1004(config-if)#service-policy input test

  • Service-Policy Or Bandwidth Rate Limit for IP

    Hii Netpros,
    Is this possible to configure the Service Policy(for Bandwidth) or Bandwidth Rate Limit for Single IP. For eg: If we want to configure the Service Policy(for Bandwidth) or Bandwidth Rate Limit of 2Mb for only IP " 10.10.10.3" on network  i.e the Host or device which is configured with this IP can access upto 2Mb only.
    Actual Network :-   We need this to configure this for wireless customers, Actually we have created one Vlan 2 (IP:- 10.10.10.1/29 @ our end router) , 10.10.10.2 on Basestation wiresss device (Vlan 2 allowed on this wireless device) and this wireless device is working as point to multipoint wireless. i.e 2 or more then 2 wireless customers or last mile will connect to this basestation wireless.  Wireless customer-1 is 10.10.10.3 (2Mb bandwidth)  and Wireless Customer-2  10.10.10.4 (512Kb).
    Hence we require to limit the bandwidth for this 2 wireless customers having different bandwidth. how to acheive & control bandwidth @ our end router for them. please suggest.
    Thanks

    This topic is probably better suited in another Infrastructure forum, but I suppose it depends on which features are supported by your Cisco hardware and software. This doc discusses a variety of options:
    http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfpolsh.html
    For example, with the older CAR (committed access rate) approach:
    interface FastEthernet5/0
         rate-limit input access-group 101 20000000 [normal burst size] [excess burst size] conform-action transmit exceed-action drop
         rate-limit input access-group 102 5120000 [normal burst size] [excess burst size] conform-action transmit exceed-action drop
    access-list 101 permit ip 10.10.10.3 0.0.0.0
    access-list 102 permit ip 10.10.10.4 0.0.0.0
    You can observe CAR in action with "show interfaces fa5/0 rate-limit" for example.

  • Rate limit guest ssid 5500 foreign to 2504 anchor

    Hi
    We have a need to limit bandwidth on guest ssid that is tunnelled to anchor controller.  The 2504 doesn't have rate limiting options but the 5500 does.  If we enabled the rate limit on the SSID details on the foreign would it work (seeing as though the anchor can't have same settings).  I would have thought that the access points terminate on the foreign therefore the rate limit would apply there.
    Would this work or do I need another 5500 as the anchor so that rate limits can match on the SSID?

    Thanks.  It would be nice if Cisco documentation actually clarified this as all guest anchor docs seem not to mention having to have both controllers supporting QoS profiles.

  • Wireless rate limit

    Hi,
    My network infrastructure as simple as following:
    LAN(edge switches 3560).......>Aggregator switch(3750)........>Firewall(ASA 5510)........>Router.......>Internet
    I define 3 wireless VLANs with 3 SSIDs on the Aggregator switch(3750):
    1. one SSID for company employees.
    2. one SSID for wireless IP phones.
    3. one SSID for company guest which access only internet.
    And the wireless APs connected to the LAN(edge switches) direct with trunks.
    My question is how to apply a rate limit for SSID for company guest to access internet with B.W. of 128kbps only.
    I tried policy map to be applied on the aggregator switch(3750) on the VLAN interface, but, it is not working.
    So, any suggested help, please.

    Hi Ahmed:
    With autonomous APs, rate limiting isn't possible.  All the autonomous APs support is QoS and that's pretty iffy.  At the core of the issue, you're dealing with radio waves and which ones arrive at the radio first, and who was prevented from talking because someone else was talking.  Dealing with these QoS and traffic shaping/policing issues are really tough with wireless because the transmission medium itself is unreliable.
    The "Configuring QoS" chapter of the autonomous AP configuration guide
      http://tools.cisco.com/squish/5aCf1
    will show you how you can map priority tagging to an SSID so that in that path from radio receiver to outbound on the fastethernet interface toward the rest of the network, you can control which SSID's packets get up into the network first, but the reverse path is a different story.  Because the wireless medium is half-duplex acknowledged, you can have a high priority packet out there on the radio interface trying to be beamed out to the client, and if the client isn't sending their ACK or what have you, it's going to sit and retry until its 63 retries are done before it gets out of the way to let the next high priority packet have a turn at getting transmitted out.
    Once the traffic gets past the edge switch, the fact that it was at one time wireless is irrelevant.  You should look at it as a general "rate limiting one VLAN's traffic over another" and check with the routing protocols or traffic shaping folks.
    Sincerely,
    Rollin Kibbe
    Network Management Systems Team

  • Configuring rate-limit in switch 6500

    Good morning gentlemen
    Consider a 6509E (supervisor 720 3B) switch with many interface VLANs configured, one of each related to each customer. Each interface VLAN had configured a rate-limit input and output configured representing the maximum bandwidth permitted for the customer.
    I could configured that way using the old IOS s72033-ipservicesk9_wan-mz.122-18.SXF7.
    Last weekend I had to upgrade that IOS to s72033-ipservicesk9_wan-mz.122-33.SXJ7. All rate-limits in VLAN interfaces disappeared, probably not supported in this new version.
    Now, what's you recommendation to perform the same in this IOS version?...I only found the policy-map/service-policy way.
    Follow my questions:
    1 - "mls qos" is globally disabled. Should I configure globally or by interface VLAN?... Expected any impact?
    I believe that only need "police" for QOS. No need for any other kind of QOS.
    2 - Should I enable "mls qos vlan-based" for each physical layer 2 port connected to that switch related to each interface vlan with police?
    Expected only one physical port (or port-channel) for each customer (and each VLAN) connected to a switch.
    Thank you and regards
    Christian

    Interesting that I have just upgraded the IOS to the last version 12 release.
    I think that for the reason that we are facing high CPU usage for "IP Input" process, something related to mls/cef is not tunned.
    Anyone has any idea regarding the configuration presented?
    Regards
    Christian

  • Rate-limit Burst explanation

    Hi All - I need your help to understand the Burst value in the Rate-Limit
    Example: rate-limit input access-group 101 20000000 24000 32000
    I understand the above configuration limit the traffic to 20Mbps. How to calculate the Burst-Normal (as per example above 24000 Bytes) and Burst-Max(as per above example 32000 Bytes). What is the logic for arriving the Burst-Normal & Burst-Max?
    Thanks in advance
    SAIRAM

    Hi Sairam,
    below are definitions of few terms which are involved here
    CIR : committed information rate, in bits per second, defines the rate defined in the traffic contract.
    Tc : Time interval,measured in miliseconds, over which the committed burst (Bc) can be sent.
    Bc : Committed burst size,measured in bits. This is the amount of traffic that can be sent over the interval Tc.
    Be : Excess burst size, in bits. This is number of bits beyond Bc that can sent after a period of inactivity.
    Formula to calculate Bc is 
    Bc = CIR*Tc
    Now to understand Bc and Tc, say suppose you have applied 20mbps rate-limit on a 100mbps fastethernet link. Now link can send data (bits) with clock-rate only which is 100mbps so to achieve 20mbps rate on that link router needs to send traffic for 1/5th of a sec and remain idle for 4/5th of a second. 1/5th of sec is 200 msec. If router will send traffic for 200msec and not sending traffic for next 800msec, it can achieve rate of 20mbps but a packet arrived at 199th sec will need to wait for 800msec and this will add unnecessary latency to the packet. To avoid this, router sends few bits for short duration and then does not send for some duration. For the period it sends traffic is called Tc value. and the number of bytes it can send during that interval is called Bc  value. So CIR = Bc/Tc (bits per interval).
    Now we dont have option to configure Tc but we can configure CIR and Bc, and Tc will automatically be calculated. If we do not configure Bc then router takes default Tc of 125ms and calculates the Bc. 
    What value to choose for Bc
    If we configure Bc too large then Tc will go high for same CIR and this may cause delay or jitter for delay sensitive traffic. For delay sensitive traffic cisco recommends to have Tc 10ms or less.
    If i calculate Tc in the given example, it is coming as 9.6ms which is close to 10ms that is why Bc is set as 24000.
    Tc = Bc/CIR
       = 24000(bytes)/20000000(bits/sec)
       = 192000(bits)/20000(bits/ms)
       = 192/20
       = 9.6 msec
    Now Be is to give extra bandwidth for small interval(Tc) to cater some bursty traffic. Assume there is a bucket which gets filled with Bc amount of token in every Tc interval and router can send traffic if there is sufficient  amount of token available in the bucket, equal to the packet size. After forwarding packet router reduces same amount of token from the bucket. Size of bucket is also equal to Bc which means if there is no traffic for Tc interval, bucket can not hold more token. Be is to increase the size of bucket to (Bc + Be). Now in every Tc interval bucket will be filled with Bc token and if there is a period of inactivity then in next interval bucket can be filled with extra Bc amount of token till it reaches to (Bc + Be) and if there is any bursty traffic (more than Bc) same can be adjusted. So for a very small period router may send traffic with more rate (higher than CIR, since sending Bc+Be in Tc interval) but over a period does not cross CIR.
    You can also use below "Ask the expert" event for QoS to further queries related to QoS.
    https://supportforums.cisco.com/discussion/12259571/ask-expert-quality-service-qos-cisco-ios-routers
    Please dont forget to rate post if it has been helpful.
    Regards,
    Akash

  • Prevalence between service policy and rate limit

    Hi,
    I have a question, on the wan interface on my router I have configured two QoS configuration: one is based on rate-limit pointing to a an specified traffic but also I have a configuration with a service policy that include the same traffic with a restriction of bandwidth . I do not know what policy has prevalence if the service policy or the rate limit.
    Regards.

    Hi Rajan ,
    Thanks for teh reply.
    I'm but confused with your answer....
    We have SRM 5 implemented at our place and I see that service carts  created in the system using the link "ORDER" when converted to PO's in Sourcing create Purchase orders with HIERARCHY structure i.e. 1 header and 1 item(with the actual service line) but when they are replicated to ECC,we have done an enheancement to create LIMIT PO's for service orders.
    Hence I wanted to know when do we need to create SERVICE HIRERACHY based PO's in SRM and when we need to create LIMIT PO's directly in SRM?
    Also I understand that in SRM,for limit PO's,when the PO item is deleted in PROCESS PO trasnctions,the items are not returned back to sourcing.We dont want this to happen for all types of PO's(both material and Service).We want that when a PO item is deleted,the item should return back to sourcing.
    But other then above functionality,what are the advantages of creating SERVICE based HIERARHCY PO's v/s LIMIT PO's in SRM?
    Please advise.
    Any inputs from Experts on this forum will be appreciated.
    Thanks in advance.

Maybe you are looking for