Accessing midi ports in flash

Hi, I'd like to create an application in flash that interacts
with my Yahama Piano Keyboard, which has midi In and Out ports.
Does flash support this? I don't need flash to play midi sounds,
but just receive the midi message sent by my midi keyboard.
Thanks

Flash does not support that. It could be that some
third-party projector tool might provide some interface, but I
honestly doubt it that there is an "out of the box" solution.
Sorry
Markus

Similar Messages

  • How can I access files from a flash drive that were previously saved using a Windows computer? When I attempt to open the file on MacBook Pro, it is asking to "convert file to"; I also have Microsoft Word installed on the Mac as well.

    How can I access files from a flash drive that were previously saved using a Windows computer? When I attempt to open the file on MacBook Pro, it is asking to "convert file to"; none of the options I choose work. I also have Microsoft Office (with Word) installed on the Mac as well.

    Format the external drive as FAT32 or ExFAT. Both computers will then be able to read and write to it.

  • Using multiple MIDI-in sources - can you now select the incoming MIDI port?

    Exciting to see that Logic Pro X has launched at last!
    I'm hoping someone who has already had a chance to download it can report back on a specific feature.
    In previous versions of Logic, the only way to record multiple MIDI sources (for example a V-Drums kit and a keyboard) at the same time has been to make sure they are on different MIDI channels, and then choose the "auto demix MIDI channels" option in preferences.
    In this way, the MIDI data is separated by channel and recorded to separate tracks.
    However, it only separates the channels when two or more tracks are armed for recording, and does not offer any option for selecting the specific MIDI port for incoming MIDI signals.
    DAWs such as Cubase and ProTools have always had a drop-down menu for MIDI channels, where the MIDI port can be chosen. This way, you can easily separate your MIDI controllers for either jamming or recording, and they will only play virtual instruments on tracks which are selected to their specific channel. This applies for recording as well as just jamming or trying parts prior to recording.
    I have several hardware synths in my studio and often record MIDI jams with multiple players, and on that basis moved back to Cubase last year. I have been hoping Logic would update this feature for a long, long time!
    Can anyone who is using Logic Pro X already confirm whether MIDI tracks now have a port select option, or whether the old channel-based system and the clumsy "auto demix MIDI channels" method remains...?
    Cheers,
    Mike

    Guys, this is really quite simple to accomplish in the midi environment, susprised you've been hunting for so long for the answers, here's a quick step by step:
    1. Go into Midi Environment
    2. Change the view in the Environment window to show Click & Ports
    3. To make things easier, click the 'Input Notes' label, and delete the object.  And also click the 'Input View' label, and delete that also, so you're left with a blank canvas.  (These are handy tools when testing, just deleting them to make things clearer).
    You should now be left with just the Sequencer Input  (And midi click, but ignore that) - Basically anything that connects into this input goes through as an input into logic... So, all we have to do now is to split each device into seperate channels.  This is simply done through the 'transform' objects.
    4. Add 2x Transformer objects via the 'new' menu (Or however many external inputs you need).
    5. Drag the connection from each device listed on the left, to it's own transformer as shown:
    6. Then plug each transformer into the Sequencer input
    7. Double click each Transformer object and simply FIX the midi channel to be whatever you desire, in this example i've picked channel 2 and channel 3
    8. Now, just make sure the 'Auto demix by channel if multitrack record' option is selected in project settings, and you're good to go!
    Now just simply select the channel number that corresponds to the devices you transformed, and when more than one track is armed for recording it will be split to how you would like.  *Please take note, that the demix only kicks in when multitracking, i.e. more than one track is armed*
    Now, this seems really long winded on a forum with screenshots etc. - But it's truly not, takes about 30 seconds, and once you've done it a few times makes sense.  Plus going through an environment like this opens up possibilites such as splitting one midi keyboard into different zones which can transmit to different channels, so you can have bass on your left hand, and lead on the right for example.  But the midi data will split to each track when recording.
    Reply back if you get stuck, more than happy to help!

  • The three main hurdles to porting existing Flash projects to iOS with AIR

    The purpose of this discussion is to identify significant problems currently preventing AIR for iOS from being a viable solution for porting existing Flash apps.  These issues have been largely ignored by Adobe, so I hope that everyone will add to this discussion if you have also run into these roadblocks in targeting iOS with the AIR SDK.  I hope that Adobe staff will address and provide some much needed information with regard to fixing these problems.
    There are 3 main problems with targeting iOS currently, which are probably affecting anyone who is trying to port a project that is both medium to large in size and makes use of SWF loading.  Pretty much any project that has a MVC architecture is going to load SWF assets that are compiled against a view class, so this is likely affecting many people.
    1. Bug - ADT packager runs out of memory when packaging "large" numbers of SWF assets
    https://bugbase.adobe.com/index.cfm?event=bug&id=3511656
    This is a blocking bug that prevents packaging projects with a large number of SWF assets.  It is preventing me from being able to package all the needed assets for my project.  I provided Adobe with my project to package a couple months ago so this bug can be reproduced in house and fixed.  The Adobe employee who was handling this never tried to reproduce the issue and has stopped responding to email and comments in the bug.  Adobe, please have someone take charge of testing and fixing this bug.  It seems like it would be a straightforward fix once the failure is reproduced within a debugger.
    Has anyone who has encountered this problem determined the number of files or classes where it starts to fail.  I've spent some time trying to reverse engineer what the packager is doing when it runs out of memory, so think I can determine how many classes it's working with, but obviously the size of the classes will be variable and so this number will probably be more of a range where we start to get into the failure state.
    Please let me know if you can reproduce this issue with your project with many SWF assets and upvote the bug if you are already aware of this one.
    2. Bug - SWF reloading when doing a "real" (AOT) compile
    https://bugbase.adobe.com/index.cfm?event=bug&id=3636385 
    There is already a forum post that covers the history of this issue (http://forums.adobe.com/message/4920638) but that also covers some issues in older AIR builds with loading of any SWF asset (previously fixed), where this bug deals specifically with reloading of SWF assets that include compiled bytecode (ABC).
    The expectation here is that all versions of the Flash runtime should handle SWF reloading with ABC in the same way, so that a single codebase can be used to target web and iOS (or any other platform).  This is the only issue of the 3 that has a legitimate work around, in my opinion, because the assets can be cached within the app within a loading manager layer.  All the application code that makes loading calls can stay the same, and a compiler flag can be used to enable this caching for iOS builds, with subsequent requests returning a new instance of the cached asset.  This can potentially lead to a very bloated memory footprint for the running app after a period of time, though, which could make some apps perform poorly, so a bugfix is ultimately needed.
    3. Unimplemented feature (?) - The constraint that a single ApplicationDomain is used when running AIR for iOS 
    I did ask about this in the same forum post as SWF reloading but didn't get an Adobe response.  Why does this constraint exist?  My guess is that the AIR runtime for iOS simply hasn't implemented multiple ApplicationDomain support at this point, and that this was done to focus resources on other high priority features for the iOS runtime.  It's possible that there is some aspect of the iOS operating system that makes it difficult or impossible to implement this feature, which may be why it's been avoided to this point, but obviously this is all conjecture without hearing from Adobe on it.
    This is a major issue that needs to be addressed.  For us, the problem is that our SWFs for multiple instances of the same type of asset use the same name for the AS export.  For example, each item an avatar can equip is a single SWF with multiple sub assets -- the parts which comprise the item.  Each of the parts will have an AS export name based on the avatar facing and where it is equipped, like "fv_head".  This naming is consistent across all items, so we will load a lot of assets containing "fv_head" simultaneously.  This normally works fine because the default behavior for Flash has always been that each SWF is loaded into a new ApplicationDomain instance, but for iOS a single ApplicationDomain must be used, causing these names to collide.  The last SWF loaded containing a given AS export name overwrites the previous ones of that name.
    The work around for this, and I use that term loosely, is to go through and uniquely name every AS export in every asset where sets of assets with the same export name is used. For us that is hundreds of items with multiple exports.  Maintaining unique naming across all these parts is also a very error prone process, not to mention all the code that manipulates the parts needs to be modified to handle the new naming and make sure it's referring to the now uniquely named assets.
    The expectation here is that all versions of the Flash runtime should handle asset loading in the same way and place each loaded asset into its own ApplicationDomain container as the default behavior.  I'd like an Adobe employee to address my assumption that this is an unimplemented feature of AIR for iOS at this point, and let the community know if a solution for this will be implemented.
    Summary
    All three of these issues in combination are a major roadblock to porting existing Flash games to iOS with AIR.  Issues with one can make it hard to test and try to work around others.  All need to be fixed, but If I could only pick one of these to fix, it would have to be issue 3 -- that lack of proper ApplicationDomain support when loading assets.  This issue is completely inconsistent with standard Flash behavior and creates a major roadblock to ports of existing applications with no viable solution for a workaround.
    I look forward to Adobe's feedback on each of these issues and hopefully fixes that will allow those of us working with AIR for iOS to get our products to market.

    About the 3rd issue being an AoT design limitation, I'm not sure I understand why it's necessary to know during AoT packaging what the domain is that a child will be loaded into to be able to have SWF loading work as on the browser.
    Isn't the ApplicationDomain an internal construct in the AIR runtime that you guys define in order to manage namespaces of loaded SWFs?  To be clear, when I say "runtime" I know that the resulting code isn't being interpreted within the iOS app, but clearly you have a set of AIR libraries that get compiled into the IPA that provides support for all the Flash APIs.  If that's the case, then wouldn't it be possible for the iOS version of the AIR libraries to define a new ApplicationDomain on the fly when code that has been cross-compiled to iOS native code loads a packaged SWF?
    I don't have a clear picture of how ApplicationDomains are managed internal to the runtime of course, but a little more detail would be very helpful.  Thanks.

  • Remote TC access via port forwarding

    I have been trying to setup my network for remote TC access via port forwarding. Here's my setup:
    Verizon FiOS router (main router, dhcp & nat) -> connected to TC set in bridge mode with a static IP
    I can remotely access the TC using Back to my Mac with no problems, and of course locally on the home network via Wifi.
    Since the TC has to connect in bridge mode, port forwarding is done on the FiOS router.
    If I set a port forwarding rule in the FiOS router TCP,UDP (any) to port 548, it works. However I want to use a specific connection port
    so others can't connect unless they know the forwarded port. BTW, I have remote disk sharing set with Use Device Password.
    So here's what works:
    FiOS Router (TCP any -> 548, UDP any ->548)
    What doesn't work:
    FiOS router (TCP 8990 -> 548, UDP 8990 -> 548).
    Is there any additional setting required for specific port forwarding to work?

    You're my hero!
    I also have my TC in Bridge Mode to my Verizon FIOS Router.  I used to be able to access my TC remotely, but since I upgraded my router (MI424WR GigE), I had forgotten some port forwarding rules I must have established in my old router.  Once I re-created these two port forwarding rules (just like yours), I can remote access my TC (with TC password) again.
    In addition, I have a static host name aliased to my dynamic IP address through dyndns.org (I have the free version, which I don't think is available anymore, but there are other free providers out there) for easier remote access.
    Regarding, Secure Share Disks: with TC password vs a disk password. Is one more secure than the other?
    Thanks!

  • Changing MIDI Port Order is wreaking havoc on my Environment

    Anyone seen this before?
    I've got a MOTU Midi Express with 4 ins and outs - it's my main interface.
    I've also got a Novation Remote25SL which works as a control surface/controller with 3 out ports. It requires some special Environment cabling to work properly with Logic.
    Everything was working fine until lately all my projects stopped responding to MIDI from my master keyboard...
    I eventually discovered it was because Logic had some how changed the order of MIDI ports. It used to be "Midi Express 1.... 4" followed by "Remote25SL 1...3".
    Now if I look at the "outputs & Ports" page in the Environment, it's reversed. "Remote25SL 1...3" followed by "Midi Express 1....4".
    So what? Well, the dumb cables in the environment don't move when the ports do. So the cables that used to be connected to the Remote25SL are now connected to the Motu Midi Express, which wreaks havoc on my project.
    Any ideas a) what causes this, and b) how to re-order the ports so it goes back the way it was before?
    I've tried messing around in the AudioMidi setup tool but don't see any thing here that will help.
    It points up, I think, a flaw in Logic's "logic". Environment cables should be tied to physical/logical ports, not just handed out on a 'first come, first serve' to whoever shows up on the midi bus first. The system apparently can "see" the difference between the Motu and the Novation. So why can't Logic?
    Grrr. Time to start reading the Nuendo brochures again.

    I HAVE A SOLUTION
    and it works fine for me after a series of trial and error experiments.
    Quit Logic (for now) and do the following.
    1) Download the app MidiPipe from this site:
    http://www.apple.com/downloads/macosx/audio/midipipe.html
    2) Plug in all of your MIDI controllers (I mean, all of them)
    3) Start making one 'pipe' at a time. Think of them as 'rules' for MIDI flow.
    I wish I could post screen shots here... I can show you that I have 6 'pipes' happening.
    Why: I have these controllers (according to Logic) happening:
    Korg nanoKEYS, nanoPAD, nanoKONTROL; Alesis Photon X25; midiman (now M-Audio) midisport 2x2; Tascam US-144 (the MIDI portion)
    4) In these pipes, ONE AT A TIME, these pipes are very simple:
    -drag a •Midi In for each controller,
    -click the 'hijack' button.
    -drag a •Midi Out next,
    -create a new virtual Midi Out Port and name it. In my case I went numerically (e.g. 1 nanoPAD, 2 nanoKEYS...) just so I can see the port name is different than the input. Do what works for you here
    5) Create a new pipe, redo step 4 until you've created a new pipe for every controller you have.
    Save this Midipipe file, and open it prior to any Logic session, before you open Logic.
    6) Open Logic. In the global preferences, go to Controller Assignments (Command-K)
    and you'll have to define any custom controller data (this may not be necessary for you). But I had to change the controller listening port for all nanoKONTROL assignments. You may not have to do anything here at all.
    7) In the case of the folks trying to use two (or more) controllers, as in three keyboards at a time you still have to change one setting: and unfortunately this is not global for Logic, you'll have to change it every single project:
    -Under File>Project Settings>Recording, you need to check the box that says
    "Auto Demix by channel if multitrack recording"
    -For each virtual instrument, you need to set the Midi Channel it responds to. Generally on the left above your channel strip, named Inst 1 (2, 3, 4, ...) depending on which track you're on, click the drop-triangle and you'll see: MIDI Channel: ALL --- change it to whatever you assigned your controller to
    -After you've assigned those MIDI Channe;s per track; now arm each track you wish to record onto (or play, trigger, etc) ---arm meaning 'click the R so it's red'
    You should be good to go!
    To boil it down to simply: download MidiPipe, figure it out, define controller data if necessary, check Demix by Channel in Project Settings, Set each track's Midi Channel, Arm each track, record two (or more) parts at once.
    You'll spend 30 minutes or more figuring out MidiPipe for your setup (less if you're brilliant); anywheres up to an hour or more in Controller Assignments but you may not need to do anything here); and less than a minute for the rest. Do the heavy work once (and tweak it) -- after that, the checkboxes/Midi Channel assignments/track arming is like, 10 clicks every project.
    Good luck!
    Works great for me with this setup:
    all the controllers listed above, Logic 8.0.2, iMac 2.4Ghz, OSX 10.5.6
    ~Robb

  • Midi ports line in ports Fire Wire etc on the Audigy 2 platinum, new Creative Driver for Vis

    Hi, I have been using my Audigy 2 platinum dri've for a few years now and have been very pleased with it, the main things I do on my pc is music creation mainly Midi but also some analogue audio as well, I also do lots of video making. I am just about to build a new system with Vista ultimate as the platform, I currently use XP Pro. I have little use for Creative?s own software and personally I do not think it is that good, I know Creative have released a new driver for my sound card But, my question is will my Midi port connections and things like my line in and the auxiliary ports and the fire wire port on the front platinum panel work with this new driver, and without the Creative software installed on my pc, and as we all no by now it looks like we will not be seeing any at all, or not for ages yet. you see I am a wheelchair user and I can not readily fiddly about a the back of my pc that is why a bought the sound blaster so I can easily plug in and unplug what I like, can anyone give me some help or advice on this issue please. ??

    Guess I wasn't clear enough. I have uninstalled the soundcard and reinstalled over a dozen times even going so far as making sure all the drivers that the device properties lists are really deleted from the system. I have resinstalled DirectX at least twice using the latest version from MS. The only thing I have not done with DirectX so far is installed the SDK version which I will be doing eventually anyway. I even uninstalled and then reinstalled my video card as it shared files with the sound card. As for getting the latest version of openAL I see little point in that as Windows forces openAL through DirectX anyway and none of my games use it. Nor does the device depend on it to work. Any other suggestions?

  • HT3576 how can i verify that the network or firewall is not blocking access to port 5223.

    how can i verify that the network or firewall is not blocking access to port 5223?

    Talk to someone who knows something about networking and/or firewalls on an appropriate forum.
    Configuring your network and/or firewall is beyond the scope of this forum, which is devoted to issues using the iPhone.

  • HT3576 How do you, verify that the network or firewall is not blocking access to port 5223.

    How do you, verify that the network or firewall is not blocking access to port 5223.

    Maybe:
    http://answers.yahoo.com/question/index?qid=20110606132954AAZH4Tc
    http://forum1.netgear.com/showthread.php?t=48533

  • Exception while accessing com port from servlet

    I am trying to access communication port from a Servlet using java communications api's.
    But Following exception was thrown
    Caught java.lang.NullPointerException:name can't be null while loading driver com.sun.comm.Win32Driver
    The SecurityManager do not allow that opeartion.
    java.security AccessControlException:access denied (java.io.FilePermission c:\j2sdk1.4.1\jre\lib\javax.comm.properties delete)
    at java.security.AccessControlContext.java:270) at java.security.AccessController.checkPermission(SecurityManager.java)
    at java.lang.SecurityManager.checkDelete()
    at java.comm.CommPortIdentifier.getPortIdentifiers(CommportIdentifier.java)
    Please help me.Tell me what to do.how to successfully access a communication port from a Servlet.

    Hi there. I am also facing the problem accessing com port via servlet. if u have the solution, kindly forward to me at [email protected]
    many thanks

  • Security Exception while accessing com port from servlet

    I am trying to access communication port from a Servlet using java communications api's.
    But Following exception was thrown
    Caught java.lang.NullPointerException:name can't be null while loading driver com.sun.comm.Win32Driver
    The SecurityManager do not allow that opeartion.
    java.security AccessControlException:access denied (java.io.FilePermission c:\j2sdk1.4.1\jre\lib\javax.comm.properties delete)
    at java.security.AccessControlContext.java:270) at java.security.AccessController.checkPermission(SecurityManager.java)
    at java.lang.SecurityManager.checkDelete()
    at java.comm.CommPortIdentifier.getPortIdentifiers(CommportIdentifier.java)
    Please help me.Tell me what to do.how to successfully access a communication port from a Servlet.

    Well, have you tried the obvious to add the following permission to your web server's policy file?
    grant "file:<wherever my servlet resides>\myservlet.jar" {
    permission java.io.FilePermission "c:\j2sdk1.4.1\jre\lib\javax.comm.properties", "write,delete";
    }

  • Can air for html/ajax accessing serial port or usb?

    I just have made use of Adobe AIR .I want to use printer with
    air . Do air have some poperties to accessing serial port or usb?
    I look up that on the Adobe AIR documents.I only found
    'Adobe® AIR™ provides the eans to check for changes to
    the network connectivity of the computer on which an AIR
    application is installed'.
    Do you have some demo with Adobe AIR accessing serial port or
    usb ?
    Or has another poperties to do that!
    thank you!!

    There is no API for accessing the serial port. USB devices
    can only be accessed through the file system (and only if they are
    storage devices).

  • Cannot access forwarded ports from the internet

    Hi all,
    I have a Cisco 800 Series router that i configured to do some port forwarding. However i must have done something wrong, because i am unable to access the ports .
    Here is the configuration file of the router.
    Sorry it i pasted too much info, i'm new working with Cisco routers
    Building configuration...
    Current configuration : 9429 bytes
    ! Last configuration change at 13:39:12 PCTime Thu Jan 5 2006 by xxx
    ! NVRAM config last updated at 19:45:42 PCTime Mon Jan 2 2006 by xxx
    version 15.0
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    hostname pbr.mtn.w
    boot-start-marker
    boot system tftp c860-universalk9-mz.153-3.M.bin 255.255.255.255
    boot-end-marker
    logging buffered 51200
    logging console critical
    enable secret 5 xxx
    no aaa new-model
    memory-size iomem 10
    clock timezone PCTime 2
    crypto pki trustpoint TP-self-signed-2673109117
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2673109117
    revocation-check none
    rsakeypair TP-self-signed-2673109117
    crypto pki certificate chain TP-self-signed-2673109117
    certificate self-signed 01
      30820250 308201B9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32363733 31303931 3137301E 170D3036 30313032 31373232
      35395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 36373331
      30393131 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100CD17 E55A2286 3F4D2F14 98499254 8DE9B540 7413A05A C229BD7E 72C6E7AA
      7BD657C2 D824C6E4 0C0FD8AB 5EF6871B A28F298C 391DA225 FA4C92D7 5E3C6B06
      B3447494 EA058319 72A69FEA 305751EE B7D7087A 406216C3 6CC14AB8 056B52F4
      117366AD 531E0515 6801228D 7DAA8454 A00A880D 4023B8B3 983DE19C FB00F077
      32450203 010001A3 78307630 0F060355 1D130101 FF040530 030101FF 30230603
      551D1104 1C301A82 18706272 2E6D746E 2E772E79 6F757264 6F6D6169 6E2E636F
      6D301F06 03551D23 04183016 80148E65 3A8C9B6B E552653E EA96DCD1 F13DD1F1
      8198301D 0603551D 0E041604 148E653A 8C9B6BE5 52653EEA 96DCD1F1 3DD1F181
      98300D06 092A8648 86F70D01 01040500 03818100 B6F568EE 3AFBBF7A B4DEC150
      B6B8860B D953E444 8925C26C 4186AED4 8EAF9F2F D2F335E4 916F941C 1E831EEE
      77C5A9A2 EB7EB7AA 540FF094 8FA28668 91C39BB2 2852DEB9 414DD37B EE984C20
      CE755A14 37C41233 B0B93B55 52E15783 089B59AA AAE54620 352D3820 59DD24A3
      F1E3EC91 CCDE72AA 7544C9C6 1C12EDAF 95767D97
          quit
    no ip source-route
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 192.168.1.1 192.168.1.219
    ip dhcp excluded-address 192.168.1.241 192.168.1.254
    ip dhcp excluded-address 10.10.10.21 10.10.10.254
    ip dhcp pool ccp-pool1
       import all
       network 10.10.10.0 255.255.255.0
       default-router 10.10.10.1
    ip dhcp pool GuestPool
       import all
       network 192.168.1.0 255.255.255.0
       default-router 192.168.1.80
       dns-server 217.14.128.50 212.99.2.8 212.108.200.77 212.82.225.7
       lease 7
    ip cef
    no ip bootp server
    ip domain name yourdomain.com
    ip name-server 196.44.250.214
    ip name-server 196.44.250.215
    ip name-server 41.223.226.30
    ip name-server 212.118.241.1
    ip name-server 213.157.176.2
    ip name-server 62.128.175.14
    license udi pid CISCO861W-GN-E-K9 sn FCZ161392V5
    username xxx privilege 15 secret 5 xxx
    ip tcp synwait-time 10
    ip ssh time-out 60
    ip ssh version 2
    class-map type inspect match-any ccp-cls-insp-traffic
    match protocol cuseeme
    match protocol dns
    match protocol ftp
    match protocol h323
    match protocol https
    match protocol icmp
    match protocol imap
    match protocol pop3
    match protocol shell
    match protocol realmedia
    match protocol rtsp
    match protocol smtp
    match protocol sql-net
    match protocol streamworks
    match protocol tftp
    match protocol vdolive
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-insp-traffic
    match class-map ccp-cls-insp-traffic
    class-map type inspect match-any ccp-cls-icmp-access
    match protocol icmp
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-invalid-src
    match access-group 100
    class-map type inspect match-all ccp-icmp-access
    match class-map ccp-cls-icmp-access
    class-map type inspect match-all ccp-protocol-http
    match protocol http
    policy-map type inspect ccp-permit-icmpreply
    class type inspect ccp-icmp-access
      inspect
    class class-default
      drop
    policy-map type inspect ccp-inspect
    class type inspect ccp-invalid-src
      drop log
    class type inspect ccp-protocol-http
      inspect
    class type inspect ccp-insp-traffic
      inspect
    class class-default
      drop
    policy-map type inspect ccp-permit
    class class-default
      drop
    zone security out-zone
    zone security in-zone
    zone-pair security ccp-zp-self-out source self destination out-zone
    service-policy type inspect ccp-permit-icmpreply
    zone-pair security ccp-zp-in-out source in-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security ccp-zp-out-self source out-zone destination self
    service-policy type inspect ccp-permit
    interface Null0
    no ip unreachables
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    description $ES_WAN$$FW_OUTSIDE$
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    duplex auto
    speed auto
    pppoe-client dial-pool-number 1
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered Vlan1
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    arp timeout 0
    interface Wlan-GigabitEthernet0
    description Internal switch interface connecting to the embedded AP
    switchport mode trunk
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
    ip address 192.168.1.80 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly
    zone-member security in-zone
    ip tcp adjust-mss 1412
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    zone-member security out-zone
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname xxx
    ppp chap password 7 xxx
    ppp pap sent-username xxx password 7 xxx
    no cdp enable
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip flow-top-talkers
    top 20
    sort-by bytes
    cache-timeout 20
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static tcp 192.168.1.25 8890 interface Dialer0 8890
    ip nat inside source static tcp 192.168.1.25 80 interface Dialer0 80
    ip nat inside source static tcp 192.168.1.45 21 41.186.26.35 21 extendable
    ip route 0.0.0.0 0.0.0.0 Dialer0
    logging trap debugging
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark CCP_ACL Category=2
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 100 remark CCP_ACL Category=128
    access-list 100 permit ip host 255.255.255.255 any
    access-list 100 permit ip 127.0.0.0 0.255.255.255 any
    dialer-list 1 protocol ip permit
    no cdp run
    control-plane
    banner exec ^C
    % Password expiration warning.
    Cisco Configuration Professional (Cisco CP) is installed on this device
    and it provides the default username "cisco" for  one-time use. If you have
    already used the username "cisco" to login to the router and your IOS image
    supports the "one-time" user option, then this username has already expired.
    You will not be able to login to the router with this username after you exit
    this session.
    It is strongly suggested that you create a new username with a privilege level
    of 15 using the following command.
    username <myuser> privilege 15 secret 0 <mypassword>
    Replace <myuser> and <mypassword> with the username and password you
    want to use.
    ^C
    banner login ^C---------------------------------------------------------------------------
                                  NOTICE TO USERS
    THIS IS A PRIVATE COMPUTER SYSTEM.  Unauthorized or improper use of this
    system may result in administrative or disciplinary action and civil and
    criminal penalties.
    Any or all uses of this system and all files on this system are monitored,
    and recorded.
    This system is the property of xxx .
    Disconnect IMMEDIATELY if you are not an authorized user!
    ^C
    line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    line vty 0 4
    privilege level 15
    login local
    transport preferred telnet
    transport input telnet
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end

    You need...
    Either a Fixed IP from your ISP, or a service like no-ip.org to look up your current IP.
    How to find the "Outside" IP on that machine go here...
    http://www.whatsmyip.org/
    If there's a Router involved at home then incoming ports must be directed to the proper local IP.
    Setup Sharing on the home Mac.

  • HOW TO ACCESS PARALLEL PORT USING JAVA

    hello guys.. Please Solve my Problem..
    I have to access motor through pc using Parallel Port. I want to know how to program in java to access Parallel Port. So How can i code to access the any Port of Parallel Port. Please Guide me in this..

    well I cannot give a more detailed answer than "use the java comm API".
    http://java.sun.com/products/javacomm/
    http://java.sun.com/developer/Books/javaprogramming/cookbook/11.pdf
    However Java wasn't built to do these kinds of operations, so it may well be that the API does not provide the functionality you need. In that case you may need a native library to do the work for you, which can make things a lot more difficult.

  • How to access parallel ports using LabVIEW?

    I want to send data to a device which is connected through LPT1.when Iam using serial port write.vi with port number 10(for LPT1) it is giving an error code 37 which means the device not found. whether those vis are only for accessing serial ports? Then how to access LPT1 using LabVIEW?

    Most likely you need to modify your labview ini file to let it know that LPT1 (or whichever) will be controled through the serial port control. See the following link for a knowledgebase answer to this question:
    http://digital.ni.com/public.nsf/3efedde4322fef19862567740067f3cc/a5abd9d76665217b86256333005ac9a5?OpenDocument
    Jared

Maybe you are looking for

  • I don't get it: Address Book's low quality, UI mess, and bugs stand out...

    ... especially compared to all other great Leopard apps. Hi Folks. I'm a switcher from Windows XP, and generally I've been very impressed with 10.5.2, and happy with my decision (Macbook Pro 2GB, 2.2GHz). However, one of the most incredibly painful e

  • How to get podcast arrow to go to iTunes store page

    Right now, when I click on the arrow next to the name of my podcast, it goes to the website affiliated with the podcast instead of the podcast page on the iTunes store like most podcasts do. How can I fix this? The feed is located at http://www.uscaa

  • Change folders color labels

    Hi, I want to change the color label of folders which contain specified files, eg movs, jpegs. I don´t want to copy or remove files, because folder size is about 140 GB. The biggest group of files is about 50 GB. I mention this, because I think getti

  • Cancel a service entry sheet

    Hello to everyone, does anybody know how to cancel a service entry sheet? Thanks and Best Regards

  • Rounding Big Decimals

    I am using BigDecimal to minimize the error in rounding and the such, but I am getting a problem. I am using numbers that get no more complicated than .025 and yet I am getting BigDecimals that look like 2.9779999999999998. I need this number to actu