ACE 4710 multiple services running on load balanced Servers

Our Exchange 2010 hub servers run multiple services/ports:  smtp, www, pop3,135, 143, https, 993, 995, 6001,6002,6003,60200,60201,8400, and 8402
what is the best way of balancing these servers so that if only one of the services failed on a server, it would switch only the failed service to remaining servers.
At present I only use an smtp probe, so as log as that sevrice is running the server is marked good. It seems to me the setup could get quite complicated so any responses welcome.

Jorge,
Please see config below
logging enable
logging buffered 5
logging monitor 5
access-list ALL line 10 extended permit ip any any
access-list ALL line 18 extended permit icmp any any
ip domain-name simplot.com.au
ip name-server 172.16.7.210
ip name-server 172.16.5.228
probe icmp icmp
interval 7
faildetect 2
passdetect interval 30
passdetect count 2
receive 5
probe tcp tcp25
port 25
interval 20
passdetect interval 60
passdetect count 2
open 1
rserver host chihub73
description hub73
ip address 172.16.6.196
inservice
rserver host chihub74
description hub74
ip address 172.16.6.197
inservice
serverfarm host Exchange
description DSI servers
failaction purge
probe tcp25
fail-on-all
rserver chihub73
inservice
rserver chihub74
inservice
sticky ip-netmask 255.255.255.255 address source Sticky
serverfarm Exchange
class-map type management match-any EXCH
201 match protocol snmp any
202 match protocol https any
203 match protocol telnet any
204 match protocol icmp any
class-map match-any EXCH_vip
2 match virtual-address 172.16.93.2 tcp eq smtp
3 match virtual-address 172.16.93.2 tcp eq www
4 match virtual-address 172.16.93.2 tcp eq pop3
5 match virtual-address 172.16.93.2 tcp eq 135
6 match virtual-address 172.16.93.2 tcp eq 143
7 match virtual-address 172.16.93.2 tcp eq https
8 match virtual-address 172.16.93.2 tcp eq 993
9 match virtual-address 172.16.93.2 tcp eq 995
10 match virtual-address 172.16.93.2 tcp eq 6001
11 match virtual-address 172.16.93.2 tcp eq 6002
12 match virtual-address 172.16.93.2 tcp eq 6003
13 match virtual-address 172.16.93.2 tcp eq 60200
14 match virtual-address 172.16.93.2 tcp eq 60201
15 match virtual-address 172.16.93.2 tcp eq 8400
16 match virtual-address 172.16.93.2 tcp eq 8402
policy-map type management first-match EXCHANGE
class EXCH
permit
policy-map type loadbalance first-match ldap-slb
class class-default
sticky-serverfarm Sticky
policy-map multi-match multi-vips
class EXCH_vip
loadbalance vip inservice
loadbalance policy ldap-slb
loadbalance vip icmp-reply
nat dynamic 6 vlan 93
interface vlan 93
description client server vlan
ip address 172.16.93.4 255.255.255.0
peer ip address 172.16.93.1 255.255.255.0
access-group input ALL
nat-pool 6 172.16.93.8 172.16.93.20 netmask 255.255.255.0 pat
service-policy input EXCHANGE
service-policy input multi-vips
no shutdown
ip route 0.0.0.0 0.0.0.0 172.16.93.254
snmp-server contact "Comms team"
snmp-server location "Chifley park CR"
snmp-server community OVSimplot group Network-Monitor
snmp-server trap-source vlan 93

Similar Messages

  • Azure: "Cloud Services" for VM - Load Balancing, yes, and other things?

    I'm trying to get a handle on the significance of the cloud service
    (that is created when a new VM is created). I understand that a group of
    VMs need to belong to the same cloud service in order to participate in
    Load Balancing. I can't see any other reason to group VMs into a single
    Cloud Service. On the other hand it seems like overkill to create a
    cloud service for each VM.
    Are there any advantages/reasons to adding a group of VMs to Cloud Service other than Load Balancing?

    Hi,
    If you made a group VMs as a cloud service, you can configure them and manage them by yourself, you could select Linux or Windows Server VMs and either compose the VM images in the cloud or upload a VHD you’re previously
    created using Hyper-V, You can capture a VM and add it your image gallery for easy reuse. you also could run a product like Active Directory or SQL Server or SharePoint Server successfully, etc...
    I suggest you have a look at following article. (create VM as cloud service belong to IaaS)
    #http://davidpallmann.blogspot.in/2012/07/windows-azure-is-3-lane-highway-how-to.html
    Best Regards
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • ACE: load balancing servers using DMZ ports on FWSM

    devices; (2 core with the ff config)
    6500
    fwsm
    idsm
    msfc
    SETUP;
    Servers are connected to the dmzs on the core
    REQUIREMENT;
    to load balance the servers
    QUESTION;
    Using the ACE module, is it possibe to load balance the servers which are connected to the port which is configured as DMZ?
    Thanks

    does not matter where the servers are connected.
    However, be aware that the flows from client to server needs to go through the loadbalancer BUT also the flows server to client.
    So, you should be careful where you attach the ACE module.
    The easier would be to attach to the DMZ as well between the FW and the servers.
    Gilles.

  • How to configure RZ12  and SM59 ABAP connection settings when we have work with Load Balancing servers rather than a specific server .

    Hi ,
    If we have a specific server say 10.10.10.10 (abc.co.in) on which we are working, Then under RZ12 we make the following entry  as :
    LOGON GROUP          INSTANCE
    parallel_generators        abc.co.in_10         ( Lets assume : The instance number is 10 )
    Now in SM59 under ABAP Connections , I am giving the following technical settings:
    TARGET HOST          abc.co.in
    IP address                  10.10.10.10
    Instance number          10
    Now if we have a scenario of load balancing servers with following server details (with all servers on different instance numbers ) :
    10.10.10.11    
    10.10.10.13
    10.1010.10
    10.10.10.15
    In this case how can we make the RZ12 settings and SM59 settings such that we don't have to hardcode any IP Address.
    If the request is redirected to 10.10.10.11 and not to 10.10.10.10 , in that case how will the settings be.
    Regards,
    SHUBHAM

    Hi,
    No one using FMS behind a load balancer? No one using RTMPT?

  • ACE load balancing servers on different subnets...

    Hello,
    I have the following issue.... need to load balance traffic between two servers already working in two different subnets (vlans), at this point is highly desirable to avoid changing IP addresses. Is it possible to accomplish this goal using ACE? routed or bridged mode? is it strictly necessary to have all servers belonging to a serverfarm in the same subnet?
    Thanks in advanced for your support.

    Hi,
    You can do this, but you have to use client-NAT (Source-NAT) to force the return traffic to pass back through the ACE. You also then need static routes in the ACE context to point at each server. PBR is an alternative approach but I have not implemented that in a live network. The important thing is that the ACE sees both sides of the conversation.
    The following extract from a configuration shows the basic principle:
    rserver host master
    ip address 10.199.95.2
    inservice
    rserver host slave
    ip address 10.199.38.68
    inservice
    serverfarm host FARM-web2-Master
    description Serverfarm Master
    probe PROBE-web2
    rserver master
    inservice
    serverfarm host FARM-web2-Slave
    description Serverfarm Slave
    probe PROBE-web2
    rserver slave
    inservice
    class-map match-any L4VIPCLASS
    2 match virtual-address 10.199.80.12 tcp eq www
    3 match virtual-address 10.199.80.12 tcp eq https
    policy-map type management first-match REMOTE-MGMT-ALLOW-POLICY
    class REMOTE-ACCESS
    permit
    policy-map type loadbalance first-match LB-POLICY
    class class-default
    serverfarm FARM-web2-Master backup FARM-web2-Slave
    policy-map multi-match L4POLICY
    class L4VIPCLASS
    loadbalance vip inservice
    loadbalance policy LB-POLICY
    loadbalance vip icmp-reply active
    loadbalance vip advertise
    nat dynamic 1 vlan 384
    service-policy input L4POLICY
    interface vlan 383
    description ACE-web2-Clientside
    ip address 10.199.80.13 255.255.255.248
    alias 10.199.80.12 255.255.255.248
    peer ip address 10.199.80.14 255.255.255.248
    access-group input ACL-IN
    access-group output PERMIT-ALL
    no shutdown
    interface vlan 384
    description ACE-web2-Serverside
    ip address 10.199.80.18 255.255.255.240
    alias 10.199.80.17 255.255.255.240
    peer ip address 10.199.80.19 255.255.255.240
    access-group input PERMIT-ALL
    access-group output PERMIT-ALL
    nat-pool 1 10.199.80.20 10.199.80.20 netmask 255.255.255.240 pat
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.199.80.9
    ip route 10.199.95.2 255.255.255.255 10.199.80.21
    ip route 10.199.38.68 255.255.255.255 10.199.80.21
    HTH
    Cathy

  • Oracle service bus, endpoint load balancing

    I was create configuration like this (dot instead of whitespace):
    ............................______osb1
    Client ---- Apache LB
    ...........................\______osb2
    Apache Load Balancer (Apache LB) have "Round-robin" load balancing algorithm
    Servers "osb1" and "osb2" are in the cluster.
    Proxy Service (PS) route to Business Service (BS).
    BS have two endpoints (EP1, EP2). Load balancing algorithm in properties of BS is "none".
    When i send request to Apache LB then i get info from like this order: EP1, EP2, EP1, EP2...
    Why load balancing beetween endpoints working instead get info from endpoint which is first in endpoint's list ?
    Edited by: 915814 on 19.07.2012 13:10
    i was check via tcpdump. Packets going beetween nodes, but messages going only to first node. This i can see in Dashboard at Service Health tab in business service properties. So "none" in Load Balancing algorithm is work.

    Hi Adel,
    Customization file will be the best solution for your problem. You may generate a environment specific customization file. To know more, please refer -
    http://download.oracle.com/docs/cd/E13159_01/osb/docs10gr3/consolehelp/customization.html#wp1129087
    Simplest solution would be to generate a customization file and replace the existing URI's with the required one's using replace all option of textpad. Run this customization file at target environment, after importing the OSB configuration.
    Regards,
    Anuj

  • Windows Azure Pack - VMM failed to deploy service through F5 Load Balancer

    I use server 2012 R2 (Windows Azure Pack) to deploy 2-tier service ( VMM -> Library -> Create Service Template -> Select two tier application -> Add F5 Load balancer -> Use connector to link NIC to Server Connection
    and link Client Connection to VM network   ). I was able to set up F5 Load balancer (virtual appliance) on Hyper V. I checked  VMM Orchestrator was able to create VIP pool and member correctly on F5 Appliance. I get the following
    error. I'm not sure how to resolve, If anyone experience this issue before, please let me know how to fix it. I copied the error log below. Thank you
    Error (22042)
    The service XXXXXXX was not successfully deployed. Review the event log to determine the cause and corrective actions.
    Recommended Action
    The deployment can be restarted by retrying the job.
    Error (21426)
    Execution of DataCenterManager.LB::AddLBVIP on the configuration provider a1af2238-5665-454a-8560-64fafbfe3385 failed. Detailed exception: Microsoft.SystemCenter.DataCenterManager.LB.LBConnectionFailedException: There is an error in XML document (246, 74).
    ---> F5Networks.Protocols.iControl.iControlException: There is an error in XML document (246, 74).
    Recommended Action
    Check the documentation for the configuration provider or contact the publisher support.
    Error (22725)
    VMM received computer name vmmBN6 for VM vmmBN6.domain.com. Expected computer name is vmmBN6.domain.com.
    Recommended Action
    Ensure that the VM has joined the right domain or workgroup and then retry the operation.
    Error (20400)
    1 parallel subtasks failed during execution.
    Error (20400)
    1 parallel subtasks failed during execution.
    Error (21952)
    Application deployment failed for one or more tiers or application hosts in the service XXXXXXXXX. Check job logs to get more information on the failed operation.
    Recommended Action
    Check error messages and retry the operation if needed.
    Thanks

    Hi Ryankorock,
    Sorry to revive an old post but is there any update on compatibility? We are running SCVMM 2012 R2 Build 3.2.7768.0 with an F5 BIG-IP
    running "11.6.0 Build 0.0.401 Final". We see the exact same error 
    Error (21426)
    Execution of DataCenterManager.LB::AddLBVIP on the configuration provider a1af2238-5665-454a-8560-64fafbfe3385 failed. Detailed exception: Microsoft.SystemCenter.DataCenterManager.LB.LBConnectionFailedException: There is an error in XML document (246,
    74). ---> F5Networks.Protocols.iControl.iControlException: There is an error in XML document (246, 74).
    The plugin creates everything on the F5, pools, nodes, and virtual server. We have tried with and without a health probe with no luck.

  • CSS on multiple subnets and separate load balancing

    Hello,
    I've a situation where I need to load balance incoming clients on subnet A to 3 real servers on subnet B - no problems there.
    But I also need to load balance different clients on subnet C to 3 other servers on subnet D and clients on subnet E to 2 servers on subnet F.
    Basically I want to use the CSS for 3 different load balancing operations.
    Rather than using 3 separate CSS11503s can I do all this with multiple VLANs on the LAN switches and 1 CSS?
    Any help appreciated
    Regards Tony

    you can have as many vlan as you want.
    So yes you can do what you want.
    Just be aware that the CSS can route as well between those vlans, so if you separation between them you may have to use ACL.
    Gilles.

  • ACE 4710: No image in GRUB loader

    I have an ACE 4710 appliance that has only a Linux kernel in its GRUB loader, no ACE image.  Is anyone aware of how I could copy the image to the ACE via TFTP, USB drive, etc.?

    Hi Joe,
    Take a look at this link.  It will show you how to copy and image to the ACE using the ACE-APPLIANCE-RECOVERY-IMAGE.bin.  If it can't find this, then you may need to RMA the device.
    Reformatting the Flash Memory
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_2_x/configuration/admin/guide/managesw.html#wp1069378
    Hope this helps,
    Sean

  • Ace 4710 - same context routed and load-sharing

    Hi All
    Can an ACE 4710 have , in the same context - servers which are
    a. just being routed to
    b. a set of load-shared servers
    I have been told you may not be able to do this on this version
    Does anyone know if this is correct
    Thanks
    Steve

    Hi Boris
    I have been on the ACE course and before we install the 4700 box i have been
    asked to set up a test setup.
    This would involve have a context which would have one ip address range and
    a few pcs (pretending to be servers ) and one which would be just routed.
    A colleague of mine seemed to think that something had been said on the course
    to the effect that if the ACE was deployed  in line the you couldnt have some
    of your servers in load-sharing and some just routed on the same subnet and
    in the same context.
    Steve

  • Multiple Session Connections, Manual Load Balance due to temp profiles

    Setup:
    DC: "2012 r2 St"
    TS1: RD gateway, session host 1, user security group 1 "2012 r2 St"
    TS2, session host for user security group 2 "2012 r2 St"
    Collection 1 > session host 1 for user security group 1
    Collection 2> session host 2 for user security group 2
    Issues/Goal:
    I would like to load balance the 2 hosts so some users log on to one server the others the other server, we originally had one collection with 2 session hosts in there running at 80/20 load balance.
    This caused major issues with user profile disks logging onto a temporary profile every time they logged onto the second server, seems to be a bug in the software has many users are having this issue and it doesn’t seem to be resolved yet so we decided to
    do a manual loads balance where half of the users are ts1 and the rest to ts2.
    I created 2 collections with separate security groups, the problem is when I connect to “remote desktop” rdgateway.domaniname.com.au only the ts1 secuirty group users can log in, it doesn't automatically point the users at the correct server (ts2).
    If I manually remote desktop to ts2 it lets me log is as a user from that security group.
    I would like to the gateway to automatically point my users to the correct session server/collection based on the security group they are in. Can someone tell me what is going wrong here?
    If i browse to the rdweb.xxx.xx and log in as a user from TS2 group it only shows the correct ts2 and lets me log in, its just remote desktop app that has the issue.

    how have you setup user profiles? user profile redirection or UPD? if you have a server outside of your TS farm acting as a file server to serve the profiles and your GPOs are setup correctly and are actually being applied correctly, you shouldn't see temp
    profile issues
    what you are doing now seems like a huge overhead and sort of defeats the purpose of having a connection broker when you're not taking advantage of load distribution

  • ACE: How to implement multiple services on a pair of servers

    We plan to loadbalance two mail servers which offer several services like http, imap and pop3. Those services are independent from each other.
    Our idea is to use an own serverfarm for each service, something like that :
    probe http http-probe
    probe imap imap-probe
    probe pop3 pop3-probe
    serverfarm host http-farm
    predictor leastconns
    probe http-probe
    rserver server1
    inservice
    rserver server2
    inservice
    serverfarm host imap-farm
    predictor leastconns
    probe imap-probe
    rserver server1
    inservice
    rserver server2
    inservice
    serverfarm host pop3-farm
    predictor leastconns
    probe pop3-probe
    rserver server1
    inservice
    rserver server2
    inservice
    Is that approach meaningful at all ?
    Can we use a common vip for all serverfarms or do we have to assign a unique vip for each farm ?
    How do we distinguish between the different requests ?
    Has somebody a sample configuration for that ?
    Thank you very much in advance.

    If the 3 services run on the same port, using different serverfarm does not make sense just because the problem would be different.
    If they run on different ports, then you have the distinction that you need to split the config.
    Gilles.

  • LRT224 Load Balancing Servers

    I get the process of load balancing outbound traffic, and even protocol binding so that servers send out traffic only on a specific WAN port. What I do not get is how to load balance INBOUND traffic also to those servers and ensure that the servers response goes out on the interface that it originated.
    I have two 50mb internet connections from different ISPs. Each with a static IP address.
    The web server is on a private IP address with appropriate forwarding.
    The web server IP address is bound to WAN2 which is the DNS address of the web server.
    All works perfect. Outboud traffic from the web server exits from the appropriate WAN port while residual traffic is load balanced.
    Now, I want to add an A record to the DNS for the web server so that INBOUND traffic ot he web server is balanced and providing a redundant service. However, the protocol binding should not allow any outbound connection through WAN1. Right?
    So my question is, is this setup impossible? Do we forget the protocol binding and hope that the outbound responses from the server exits through the originating port? Is there another method? Or, do I need a more advanced router?
    I do not even want to consider DMZ even as this is impossible since I am utilizing both ports as WAN ports. Anyone have any suggestions to do this?
    Thanks
    Mark

    Sorry I misunderstood.
    IMO for this to work on an LRT224 you would need:
    A second network adapter in the Server and the Server configured to answer requests on both NIC's
    Protocol Binding the second Server NIC to the other WAN port
    A DNS Hosting Service that support DNS Round Robin or you would run your own DNS Server with Round Robin DNS capabilities
    These days I'm seeing DNS propagation with namesecure only taking a few hours instead of the advertised 96hrs.
    Please remember to Kudo those that help you.
    Linksys
    Communities Technical Support

  • Load balance servers with 3560?

    Here is my scenario...
    I have two servers that are both connected to a single 3560 (SMI).
    These two servers are in a primary/secondary relationship. Right now, if the primary server goes down - we need to manually configure the secondary server to take over.
    I have two questions...
    What is the best way to set up fault tolerance with these devices, so the secondary server will automatically kick in if the primary goes down?
    In addition to that, is there any type of load balancing feature we can use on this 3560...so both the primary/secondary servers can run at the same time?
    Ideally, we would like communication to the second server kick in when the link to the primary server gets too congested.

    your best bet is to use IOS SLB or a content switch such as the cisco CSS series.
    please see the following links for more info on ciscos CSS and SLB capabilities:
    content switching (CSS) -
    http://www.cisco.com/en/US/netsol/ns340/ns394/ns50/ns254/networking_solutions_package.html
    SLB - (example of use)
    http://www.cisco.com/en/US/products/hw/modules/ps2706/products_configuration_example09186a0080093de3.shtml

  • How to remote deploy across load balanced servers

    I have a server farm that is load balanced, how would I deploy to 15 servers at the same time? Or what is the process to do such a thing using SJWS?
    Doing it manually one at a time just doesn't make sense...

    Hi,
    this is a known issue as you will be executing 2 report requests, one to execute the report and the other to retrieve and display the report, in this scenario the second request( to do the display) is forwarded by the LBR to the reports server where the request was NO executed so the error you are getting is expected.
    To resolve this please check the following notes.
         Rep-52251: Cannot Get Output of Job Id###, when Calling Reports from Forms (Doc ID 367887.1)
         Maintaining 6i Run_Report_Object Code in 10.1.2 Without Employing Clustering/HA (Doc ID 358436.1)
    Regarding the second question the issue I think is related to cacheSize and/or maxCacheFileNumber settings in your reports server configuration file.
    Hope it helps.
    Regards

Maybe you are looking for

  • How to add text in print module in LR4?

    want to add text twice in print module, seems only option is identity plate and it cant be duplicated, any suggestions?

  • HT2052 iOS Software Update for iPod touch (2nd generation)

    I am not able to use previous apps on my iPod touch 2nd generation or even install new apps cause of this issue. I find it very messed up that Apple is inputting these restrictions, because they want people to buy the latest versions of their gadgets

  • Radeon 2600 beats GeForce 8800 -- again

    I was doing some tests comparing two iMacs, one with the Radeon 2600 Pro and one with the GeForce 8800 GS. The test was to import a movie file into iMovie, which renders thumbnails of each segment of the video. The iMac with the Radeon completed the

  • How to implement custom socket option.

    In our application we use DatagramSocket. We are able to set the standard socket options that are implemented in SocketOption interface by using the setter methods available in DatagramSocket. We need to set a custom (non-standard) socket option in t

  • Calling a Java Applet - Javascript

    Hey guys, I'm still fairly new to Java. I'm having a hard time getting my Applet to run properly. Basically, this is what I want it to do: I have a web page with a series of fields on it (a form). I have a submit button. When the user clicks the subm