Backup interface on fiber ring

We recently installed a 100Meg MPLS fiber ring into our office, and we were given redundant connections (north loop and south loop).
The North loop is the primary interface, and will be used unless the fiber is cut.
I need to configure our router to automatically switch to the south loop in the event that the north loop goes down. 
Here is the config I have so far, I just want to make sure I'm not missing anything.
interface GigabitEthernet0/0/0
 description 100MB MPLS North Loop
  backup delay 30 never
 backup interface GigabitEthernet0/0/1
 ip address X.X.X.X 255.255.255.252
 media-type sfp
 negotiation auto
interface GigabitEthernet0/0/1
 description 100MB MPLS backup South Loop
 ip address X.X.X.X 255.255.255.252
 media-type sfp
 negotiation auto
Am I correct in thinking that, should the North loop on Gi0/0/0 go down, it will automatically switch to Gi0/0/1 after 30 seconds of down time?
If so, how do I go about switching back to the north loop when it comes back online?

Hi,
I have see this feature configure on few ISP. For this feature to work, interface needs to go down then only RP can send UP event to standby link and make it up. 
You can also go through below discussion on backup interface
https://supportforums.cisco.com/discussion/10921951/how-set-backup-delay-serial-interface-ethernet-interface
regarding backup delay , i am not sure why you want to put delay of 30 sec before standby interface becomes active and then deactivating delay is infinite, means it will always remain active even when primary interface comes up.
CCO document on backup delay
http://www.cisco.com/c/en/us/td/docs/ios/dial/command/reference/dia-cr-book/dia_a1.html#wp1011975
backup delay
To define how much time should elapse before a secondary line status changes after a primary line status has changed, use the backup delaycommand in interface configuration mode. To return to the default so that as soon as the primary fails, the secondary is immediately brought up without delay, use the no form of this command.
backup delay {enable-delay-period | never} {disable-delay-period | never}
no backup delay {enable-delay-period | never} {disable-delay-period | never}
Syntax Description
enable-delay-period
Number of seconds that elapse after the primary line goes down before the Cisco IOS software activates the secondary line.
disable-delay-period
Number of seconds that elapse after the primary line comes up before the Cisco IOS software deactivates the secondary line.
never
Secondary line is never activated or deactivated.
--Pls rate helpful posts--
Regards,
Akash

Similar Messages

  • ATT Fiber Ring 50MB line - no negotiating

    Hello,
    Firstly the situation we have here is that we are on the outskirts of an ATT Fiber Ring and we have servers currently hosted at an ATT Datacenter. They stated we could hop on that fiber box with their help and get a 50MB link to our cage in the datacenter...great news huh? They also stated that they would give us an Ethernet handoff...well they didn't...fiber instead. So we went out and bought 2 3560G with GBICs, one for each end. We tested the switches inside the office with a fiber cable and everything was fine.
    So then we hooked up these switches to the Cisco ONS 15327 and ATT repeatedly told us that the circuit was fine...no problem...great. Still no data...they said just hook them up and ping...nothing else to configure. We did this and nothing happened. Also when doing a "show int gig0/49" we get line down and no lights on the outside of the GBIC on the 3560G. But when we flip the fiber cables the wrong way the 15327 seems to respond so there doesn't seem to be anything physically wrong with our setup.
    I'm not terribly great with these things but ATT is not helping us at all. They said they have no Cisco techs that could help us...don't know why...seems pretty simple to me...we must be missing some sort of protocol or something for the handshake that isn't happening. I have included a copy of the configs maybe someone out there can at least shine some light before we tell ATT to shove it.
    Thank you

    The Cisco ONS 15305 transports Ethernet and TDM traffic inside an SDH frame for metropolitan-area network (MAN or metro) applications. The Cisco ONS 15305 can be used as customer premises equipment (CPE) for medium- and large-sized businesses - collecting voice and data traffic from each site for switched voiced and data services, Layer 1 and Layer 2 VPNs, and Internet access - for transport over an STM-1, STM-4, or STM-16 SDH uplink to the central office. The Cisco ONS 15305 can also be deployed as a central office aggregator; consolidating STM-1 access links from Cisco ONS 15302 Multiservice Provisioning Platforms or other Cisco ONS 15305 CPE, as well as directly connected customer TDM or data traffic from electrical interfaces

  • Loopback0 vs. "Backup interface GigabitEthernetx/x" for redundance

    Hi,
    I am a voice engineer. To configure MGCP gateways I have used the Cisco standard method of creating a loopback interface specially when there are redundant switch connections, e.g. GigabitEthernet0/0 and GigabitEthernet0/0.  Can anybody please explain if I use "backup interface" method, would it work same way.  The backup interface method also has a backup delay, not sure what is default, but secondary interface won't be active until the delay elapses.  If I configure "no backup delay" would there still be an event for MGCP?  Can somebody please share their experience?

    If your primary interface fails, is there an event for MGCP? What happens to active calls?
    Update: I just found that the default delay is 0 seconds (that means "no backup delay" is not required to be explicitly added, so I assume the MGCP gateway should not experience any impact at all. If you done this testing in your environment, please confirm.
    And thanks a lot for quick reply!

  • When I restore my iphone, all my music and ring tone are missing. Does Backing up by iphone backup my music and ring tone?

    When I restore my iphone, all my music and ring tone are missing. Does Backing up by iphone backup my music and ring tone?

    It doesn't matter what it is in your backup that's causing the problem because you can not selectively restore things from your backup. It's all or nothing.
    Set you phone up as a new device and start over.

  • How to check backup interface

    I want to rsh to all my machines,
    1. check if the backup interface is up if it is not bring it up. The problem is backup interface is named differently on every machines ie. eth1, bge1 etc.
    2. check if the back up netmask and IP is setup properly if not set it up
    How can I achieve this using a script?
    Thanks ever so much for your help.

    I am not able to do that. Do you have any suggestions on how i can achieve the above? Thanks

  • Cisco BackUp Interface Operation Failing

    OK Experts,
    I have made this issue very simple for you guys to help me out.
    I  have two routers R22 and R23. I have configured the back up interface  on R22 to be interface fas 0/1. Everything appears to be working fine. I  issue the command show backup and I get the following on R22
    r22#show backup
    Primary Interface   Secondary Interface   Status
    FastEthernet0/0     FastEthernet0/1       normal operation
    r22#
    Also I get the following:
    FastEthernet0/1            10.10.13.2      YES manual standby mode          down
    However, when I shutdown interface fast 0/0 to test the back up interface fast 0/1 I get the following:
    r22#show backup
    Primary Interface   Secondary Interface   Status
    FastEthernet0/0     FastEthernet0/1       disabled
    r22#
    FastEthernet0/1            10.10.13.2      YES manual standby mode/disabled down
    So it doesn't work.
    Attached are the configs.
    I was wondering if someone could help me figure out why this won't work.
    Cheers

    Hello Carlton,
    there are some notes about your tests:
    a)  the configuration of the primary interface includes two logical interfaces main interface and a vlan based subinterfaces both fail when you disable fas0/0, the secondary interface has only IP configuration at main interface level
    from your log files:
    interface FastEthernet0/0
    backup interface FastEthernet0/1
    ip address 10.10.14.2 255.255.255.0
    duplex auto
    speed auto
    interface FastEthernet0/0.1
    encapsulation dot1Q 12
    ip address 10.10.12.2 255.255.255.0
    You should remove the subinterface fas0/0.1 as a minimum to make interface configurations compatible,
    b) the specific type of interface you  would like to use for backup is LAN based Fastethernet.
    The backup command had been introduced for providing a backup interface for serial interface and the secondary interface may be a serial interface or ISDN based ( in this case a DDR call is triggered over ISDN).
    The dial backup command reference says that support for gigabit interfaces in C7600 has been later introduced.
    see
    http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_a1.html#wp1012054
    The use of backup command may be supported or not for fastethernet interface on your routers.
    If it is not supported, you can easily implement an alternate solution, because you are running OSPF in area 0 in all router interfaces
    router ospf 1
    log-adjacency-changes
    >>network 0.0.0.0 255.255.255.255 area 0
    So all you need to do  is to increase OSPF cost on fas0/1 to create a backup path
    on R22, R23:
    conf t
    interface fas0/1
    ip ospf cost 50
    Hope to help
    Giuseppe

  • Flex backup interface

    hey I have cisco 2960 switch I want to ask about flex backup interface configuration on it my ask is that the STP would remove from whole switch or in the interface only !!

    Setup your router interface cards such that the interface w/"physical-layer async" comes before the interface it will be used to back up. It will then get initialized before the "backup interface" command.
    Implementing dial-on-demand routing (DDR) backup on a router that uses
    Network Address Translation (NAT) involves more configuration than is
    neccessary for regular DDR backup. This is because the router must translate packets to and from the "inside" network using different "outside" addresses depending on whether the primary or backup link is active." ... "Make sure that your Internet Service Provider (ISP) can provide you with two different IP addresses or subnets. Use one IP address or subnet for the DSL connection and the other for the backup ISDN connection. IP addresses on the two dialer interfaces need to be explicitly assigned and cannot be negotiated during PPP negotiation. This means that the ip address negotiated command is not permitted under the dialer interfaces.
    For troubleshooting the 1706 router click this link.
    http://www.cisco.com/en/US/products/hw/routers/ps221/prod_tech_notes_list.html

  • ASA 5505 backup interface

    Hello,
    I have setup ASA 5505 with 2 ISP, named outside (primary)  and backup, the scenario is if outside down, then backup will take over, it works now.
    But it is not working when the primary connection cannot reach the gateway with the interface still up.
    Is it possible when the primary connection cannot reach the gateway then backup automatically take over?
    Thanks before..
    My configuration is:
    ASA Version 8.2(1)
    hostname cisco
    domain-name default_domain
    enable password ********* encrypted
    passwd ********* encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 172.10.10.10 255.255.255.0
    interface Vlan3
    no forward interface Vlan2
    nameif backup
    security-level 0
    ip address 172.20.10.10 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 1
    interface Ethernet0/1
    switchport access vlan 2
    interface Ethernet0/2
    switchport access vlan 3
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default domain
    same-security-traffic permit intra-interface
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu backup 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (inside) 1 interface
    global (outside) 1 interface
    global (backup) 1 interface
    nat (inside) 1 192.168.1.0 255.255.255.0
    access-group inside_out in interface inside
    access-group outside_in in interface outside
    access-group backup_in in interface backup
    route outside 0.0.0.0 0.0.0.0 172.10.10.1 1
    route backup 0.0.0.0 0.0.0.0 172.20.10.1 254
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd lease 1048575
    dhcpd auto_config outside
    dhcpd address 192.168.1.100-192.168.1.200 inside
    dhcpd dns 8.8.8.8 8.8.4.4 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect icmp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:24af050f332deab3e38eb578f8081d05
    : end

    Hi Amrin,
    you can configure SLA monitoring on ASA and that woudl work fine for you:
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00806e880b.shtml
    Hope that helps.
    Thanks,
    Varun

  • Cisco ASA 5510 Backup Interface configuration

    Hi Experts,
    I am a newbie with Cisco Firewalls, pls help.
    We have a BSNL Leased Line of 2MBPS with few Static IP's of Which 2 IP's are configured in Firewall 1 For the Outside Interface and one for publishing the DMZ server. Most of the times due to some reasons or the other the BSNL line is going down. so now I need to configure one another TATA Broadband 1MBPS Dialup Line as a Backup for the BSNL Line so as to provide a uninterupted Internet to our users.
    Pls guide me the Steps
    Thank in Advance.
    Anish N

    Hi Anish,
    Check the below mentioned link for configuration.
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00806e880b.shtml

  • Performing backup of SQL via backup interface

    Hello all,
    First of all , let me tell you that i don't have much knowledge regarding SQL so, excuse me in advance for any stupid questions.
    Here is my situation:
    I have SQL 2005 Standolne server. On the server there are two interfaces(NICs) one is so called production(prod) and backup(bkp). 
    The PROD is for main communication and it's with assigned FQDN - XYZ. The other one is for backup traffic and it's with FQDN - XYZ-b. The IPs are , PROD - xxx.xxx.1.xxx, BKP - xxx.xxx.2.xxx
    I'm using a HP Data Protector software , version 7.03, with latest patched installed on the backup software.
    Unfortunately when i'm trying to create a backup(there are 3 ways for authentication - Integrated, Windows and SQL server)  with the BKP interface i receive following error:
    *RETVAL*8010
    The user name which is used by the bkp software is added into the SQL server as admin, also it's with local admin from OS point of view. 
    So my question is , are there any way to perform backup via XYZ-B interface ?
    Thank you in advance !!!

    Hello,
    Seems to be more a HP Data Protector issue, see
    http://h30499.www3.hp.com/t5/Data-Protector-Support-and-News/Integration-cannot-be-configured-error-on-HP-data-protector/td-p/5961279#.U89zyGeKD5w
    Olaf Helper
    [ Blog] [ Xing] [ MVP]

  • CSS11501 - Unable to Telnet to VRRP backup interface IP

    Hi,
    I have 2 units of Cisco CSS11501 which configured running on VRRP active/standby on 2 different VLAN (Circuit). When unit 1 is master unit, I am able to telnet to its circuit IP address, but unable to telnet to any circuit IP of backup unit.
    Active unit configuration:
    !************************** CIRCUIT **************************
    circuit VLAN145
      ip address 172.19.145.182 255.255.255.0
        ip virtual-router 1 priority 101
        ip redundant-vip 1 172.19.145.184
        ip redundant-interface 1 172.19.145.183
    circuit VLAN550
      ip address 192.168.50.18 255.255.255.0
        ip virtual-router 2 priority 101
        ip redundant-vip 2 192.168.50.20
        ip redundant-interface 2 192.168.50.19
    !*************************** OWNER ***************************
    owner ***
      content ***
        vip address 172.19.145.184
        port 80
        protocol tcp
        add service ***
        active
    !*************************** GROUP ***************************
    group ***
      vip address 192.168.50.20
      active
    Backup unit configuration:
    !************************** CIRCUIT **************************
    circuit VLAN145
      ip address 172.19.145.183 255.255.255.0
        ip virtual-router 1 priority 90
        ip redundant-interface 1 172.19.145.182
        ip redundant-vip 1 172.19.145.184
    circuit VLAN550
      ip address 192.168.50.19 255.255.255.0
        ip virtual-router 2 priority 90
        ip redundant-vip 2 192.168.50.20
        ip redundant-interface 2 192.168.50.18
    !*************************** OWNER ***************************
    owner ***
      content ***
        vip address 172.19.145.184
        port 80
        protocol tcp
        add service ***
        active
    !*************************** GROUP ***************************
    group ***
      vip address 192.168.50.20
      active
    Please help!!
    Regards,
    Danny Lim

    Hi Marko,
    That means I could not to configure redundant-interface as I have redundant-vip configured already?
    Actually the topology is:
    VLAN550 is connecting to server farm
    VLAN145 is where user sitting
    my current config :
    circuit VLAN145
      ip address 172.19.145.182 255.255.255.0
        ip virtual-router 1 priority 101
        ip redundant-vip 1 172.19.145.184
        ip redundant-interface 1 172.19.145.183
        ip critical-service 1 PING_DEFAULT_GATEWAY
    circuit VLAN550
      ip address 192.168.50.18 255.255.255.0
        ip virtual-router 2 priority 101
        ip redundant-vip 2 192.168.50.20
        ip redundant-interface 2 192.168.50.19
        ip critical-service 2 PING_DEFAULT_GATEWAY
    !*************************** OWNER ***************************
    owner HLRLDAP
      content VIP_LDAP_16611
        vip address 172.19.145.184
        port 16611
        protocol tcp
        add service KPG-HV30-3
        add service KPG-HV30-6
        active
    !*************************** GROUP ***************************
    group Redundant_Server
      vip address 192.168.50.20
      active
    So, I should have change my config like this:
    CSS1
    circuit VLAN145
      ip address 172.19.145.182 255.255.255.0
        ip virtual-router 1 priority 101
        ip redundant-vip 1 172.19.145.184
        ip redundant-interface 1 172.19.145.181
        ip critical-service 1 PING_DEFAULT_GATEWAY
    circuit VLAN550
      ip address 192.168.50.18 255.255.255.0
        ip virtual-router 2 priority 101
        ip redundant-interface 2 192.168.50.20
        ip critical-service 2 PING_DEFAULT_GATEWAY
    CSS2
    !************************** CIRCUIT **************************
    circuit VLAN145
      ip address 172.19.145.183 255.255.255.0
        ip virtual-router 1 priority 90
        ip redundant-interface 1 172.19.145.181
        ip redundant-vip 1 172.19.145.184
        ip critical-service 1 PING_DEFAULT_GATEWAY
    circuit VLAN550
      ip address 192.168.50.19 255.255.255.0
        ip virtual-router 2 priority 90
        ip redundant-interface 2 192.168.50.20
        ip critical-service 2 PING_DEFAULT_GATEWAY

  • Iphone backup due to missing ring tones

    Hi, I am missing my personal  ring tones on my iphone. But I only have one backup in itunes. Is it possible to restore a previous backup with time machine? Or any other idea? Many thanks, Helmut

    The RMAN Crosscheck command only validates that what RMAN thinks is backed up really is.
    The Change archivelog all validate is what you need to run when you delete archivelogs before they have been backed up by RMAN.
    If you have to restore a backup that was made before you deleted the archive logs, you will not be able to perform a full recovery.
    You may want to consider running just archivelog backups more often and have RMAN delete them after they have been successfully backed up. In Oracle9i Release 2, there is an option to delete the archive logs after they have been backed up X number of times in case you want the logs duplex archivelog backups.

  • EtherChannel configuration between Copper interface and fiber Interface

    Hi,
    Need to check if Giga Etherchannel can be configured between Copper 10/100/1000BaseT and SFP 1000BaseT between two blades on a Cat 6506 with either Sup 720 or Sup32.

    I have configured etherchannel between two 3560G 48 port switches. Using a combination of 2 sx fiber and 2 1000tx copper interfaces. The resulting layer 2 channel supported upto 4gb. The notes from the cisco site indicate the following:
    Configure all LAN ports in an EtherChannel to operate at the same speed and in the same duplex mode.
    The following link refers to etherchannel for 6500 series switches:
    http://www.cisco.com/en/US/customer/products/hw/switches/ps708/products_configuration_guide_chapter09186a008007e6d3.html
    This link refers to etherchannel for the 3560 series:
    http://www.cisco.com/en/US/customer/products/hw/switches/ps5023/products_configuration_guide_chapter09186a00801cdea1.html

  • Incremental Backups Interface Problem???

    Maybe it's just me, but doing a simple task like backing up (full / incremental) should be very simple, and I'm having a problem. I should be able to select a backup location (a preference), do a Full backup, then do an Incremental...as many as I want...and at some time I may want to do a Full backup again. But it seems it's much more complex than that...
    Here's what I'm doing (obviously wrong):
    I've done a Full backup on Drive D in some directory, say 'My Backup'. Fine, I think I have a Full backup.
    Now later, I want to do an incremental, and I'm prompted to select a destination Drive (it's D), and then "chose browse to load your previous backup file."
    OK, I browse to my D | My Backup directory (that's the previous and ONLY backup location), but I'm warned that a backup file already exists, and do I want to overwrite it. Huh???
    An Incremental doesn't overwrite a Full Backup. What am I supposed to Browse to?
    And what does "Load previous backup file to determine size" have anything to do with a simple need to create an incremental backup file?
    Help hasn't helped. I'm missing something.
    I'd really appreciate if anyone can tell me what I'm doing wrong. I obviously don't want to overwrite a Full backup with an Incremental.

    See excellent answer in Technical side of the forum
    Michael Sobieski, "Problem with Full - Incremental Backup in 5.0" #1, 19 Oct 2006 8:21 am

  • Backup interface command

    if i use this command do I need to include a route for that interface ? how does it exactly work ?

    hi carl,,,
    i dont think u need more configuration for that...
    here u just need to configure bri...and need to publish that ip address in to your routing protocol...
    u can have clear picture by this link
    http://www.cisco.com/en/US/tech/tk801/tk379/technologies_configuration_example09186a00800b1148.shtml
    just readit it will clear you whole fundamental...
    rate this post if it helps
    regards
    Devang

Maybe you are looking for