BIA Load Check delivers wrong result for high availability

Hi all,
has anyone noticed the BIA Load Check (Function CHECK_BIALOAD_CHECK of class CL_RSDDTREX_SERVICE) handles a high-availability setup in the wrong way?
We have 2 times x blades, with each blade being mirrored in a high-availability setup (dedicated backup mode).
That means our usable space is: x * memory_size of blade
However, the load check calculates the load by doing:
load_factor = size_of_all_indexes / SUM(memory_per_blade)
=> If we have 36 GB/blade and 2 blades + 2 backup blades, total usable memory should be 236 = 72, and NOT 436 = 144!
So the CALCULATED load_factor is only half of the ACTUAL (real) load factor => the alerting for BIA overload is never triggered!
Do we need to write our own load check function then?
Thanx,
Hendrik
Edited by: HMaeder on Jan 20, 2010 5:44 PM

Hello Hendrik
I believe your finding is correct. Backup blades should not be taken into consideration for total memory. Please open a customer message so SAP development can analyze the issue and provide a solution (just cut&paste your posting).
Regards,
Marc
SAP NetWeaver RIG

Similar Messages

  • Content Search Web Part displaying wrong Results for anonymous Users.

    HI Forum Group,
    I am getting Wrong results for my content search web part. The requirement is to show the News Description for the selected news item.
    I have a catalog site which stores News like 
    News1
    News2
    News3
    as Items. and i have connected this catalog in publishing site which is anonymous. In the publishing site created one page "News.aspx"added search results webpart which shows all the news item. Added one page "Description.aspx" to show
    description to show the selected news item.
    When ever user selects any news from news.aspx page it will redirected to description.aspx with the selected item ID
    The "Description.aspx" the search results page gets the data based on the URL by QueryString parameter as shown below
    The problem is, if i multiple items to open in tabs all the items are showing the data same as the first selected item, though the article ID is different.
    Thanks
    Sithender

    Hi,
    Thank you for your feedback on how you were successful in resolving this issue.
    Your solution will benefit many other users, and we really value having you as a Microsoft customer.
    Have a nice day!
    Best Regards,
    Lisa Chen
    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact
    [email protected]

  • Best practice for highly available management / publishing servers

    I am testing a highly available appv 5.0 environment, which will deploy appv packages to a Xenapp farm.  I have two SQL 2012 servers configured as an availability group for the backend, and two publishing / management servers for the front end. 
    What is the best practice to configure the publishing / management servers for high availability?  Should I configure them as an NLB cluster, which I have tested and does seem to work, or should I just use the GPO to configure the clients to use both
    publishing servers, which I have also tested and appears to work?
    Thanks,
    Patrick Sullivan

    In App-V 5.0 the Management and Publishing Servers are hosted in IIS, so use the same approach for HA as you would any web application.
    If NLB is all that's available to you, then use that; otherwise I would recommend a proper load balancing solution such as Citrix NetScaler or KEMP LoadManager.
    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually
    answer your question). This can be beneficial to other community members reading the thread.
    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.
    Twitter:
    @stealthpuppy | Blog:
    stealthpuppy.com |
    The Definitive Guide to Delivering Microsoft Office with App-V

  • Hardware Sizing for high Availability system

    Hi,
    I have to perform Hardware sizing for high Availability system for a fresh installation and I am quite new to this area.
    It will be a User based sizing.
    Total user count 150. 
    105 - Info-consumer Users
    40 - Executive Users
    05 - Expert Users
    Can you please let me know what will be the best approch and what are the factors have to consider to perform the hardware sizing for high Availability system
    Your support will be appriciated.
    Regards,
    Basis

    Hi Sebastian,
    Thanks for your response. Yes, I am going through the doc.
    Solution will be BW 7.4 on HANA. If you can give me what are the factors I have to consider will be very helpfull for me.
    I already did sizing for standalone installation, but client is looking for Hardware Sizing for high availability system.
    Regards,
    Basis

  • Wrong results for context search on empty element tags

    I'm using Oracle DBMS 11.1 and 11.2 and created a context index on an XML column (section group: PATH_SECTION_GROUP).
    When entering a query like
    SELECT count(*) FROM my_table t WHERE contains (t.co_xml,'hasPath(/tag1/tag2)') > 0
    I get wrong results if tag2 is an empty element tag (<tag2/>) that appears somewhere within the
    XML instance, but NOT directly under tag1.
    E.g., the following XML instance is found (but shouldn't!):
    <a>
    <tag1>bla<tag3>bla</tag3></tag1>
    <tag4>bla<tag2/></tag4>
    </a>
    This seems to happen only for empty element tags. Is this a known bug and does anybody know a workaround?
    Thanks in advance for your help!
    Roman

    I am unable to reproduce the problem. Can you provide a copy and paste of an actual run, including create table, insert data, create index, and select, as I have done below?
    SCOTT@orcl_11g> select * from v$version
      2  /
    BANNER
    Oracle Database 11g Enterprise Edition Release 11.1.0.6.0 - Production
    PL/SQL Release 11.1.0.6.0 - Production
    CORE     11.1.0.6.0     Production
    TNS for 32-bit Windows: Version 11.1.0.6.0 - Production
    NLSRTL Version 11.1.0.6.0 - Production
    SCOTT@orcl_11g> create table my_table
      2    (co_xml     xmltype)
      3  /
    Table created.
    SCOTT@orcl_11g> insert into my_table values (
      2  xmltype ('<?xml version="1.0"?>
      3  <tag5>
      4    <tag1>bla<tag3>bla</tag3></tag1>
      5    <tag4>bla<tag2/></tag4>
      6  </tag5>'))
      7  /
    1 row created.
    SCOTT@orcl_11g> create index my_idx
      2  on my_table (co_xml)
      3  indextype is ctxsys.context
      4  parameters ('section group ctxsys.path_section_group')
      5  /
    Index created.
    SCOTT@orcl_11g> SELECT count(*)
      2  FROM   my_table t
      3  WHERE  contains (t.co_xml, 'hasPath (//tag1/tag2)') > 0
      4  /
      COUNT(*)
             0
    SCOTT@orcl_11g> SELECT count(*)
      2  FROM   my_table t
      3  WHERE  contains (t.co_xml, 'hasPath (//tag1/tag3)') > 0
      4  /
      COUNT(*)
             1
    SCOTT@orcl_11g>

  • Best practice for High availability design, HSRP

    Hi,
    I am planning to create High Availability for LAN to WAN connectivity.
    But I want to know your opinion about the best way how to do this. I googled for a solution/best way how to do this, but I didn't found in my opinion right answer.
    The situation:
    I have 2 3945E Routers and 2 3560 switches. The design that I am planning to implement is below.
    The main goal is to have redundant connection, whatever one of the devices will fail. For example, if the R1 will fail, R2 should become active, if the SW1 will fail, the SW2 will take care about reachability and vice versa. The router 1 should be preferred always, if the link to ISP isn't down, because of greater bandwidth. So why am I drown 2 connections to 2 separate switches. If the SW1 will fail, I will still have a connection to WAN using R1 router.
    The Router interface should be configured with sub interfaces (preferred over secondary IP address of interface), because more than 10 subnets will be assigned to the LAN segment. The routers have 4 Gi ports.
    HSRP must be enabled on LAN side, because PC's on LAN must have redundant def. getaway.
    So, the question is - what is the best and preferred way to do this?
    In my opinion, I should use BVI and combine R1 routers 2 interfaces in to logical one and do the same for the R2.
    Next, turn the router in to L3 switch using IRB and then configure HSRP.
    What would be your preferred way to do this?

    Hi Audrius,
    I would suggest you to go with HSRP. GLBP you will use where you want load balance.
    I think the connectivity between your Routers (3945) and switches (3560) is gigabit connection which is high speed. So keep one physical link from your switches to each router and do HSRP on those router physical interfaces.
    In this way you will have high availability like if R1 fails then R2 will take over.
    Regarding the config see the below which I have for one of my Customer DC.
    ACTIVE:
    track 1 interface GigabitEthernet0/0 line-protocol
    track 2 interface GigabitEthernet0/0 line-protocol
    interface GigabitEthernet0/1
    ip address 10.10.10.12 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex full
    speed 100
    standby use-bia scope interface
    standby 0 ip 10.10.10.10
    standby 0 priority 110
    standby 0 preempt
    standby 0 authentication peter2mo
    standby 0 track 1 decrement 30
    standby 0 track 2 decrement 30
    STANDBY:
    track 1 interface GigabitEthernet0/0 line-protocol
    interface GigabitEthernet0/1
    ip address 10.10.10.11 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex full
    speed 100
    standby use-bia scope interface
    standby 0 ip 10.10.10.10
    standby 0 priority 90
    standby 0 authentication peter2mo
    standby 0 track 1 decrement 30
    Please rate the helpfull posts.
    Regards,
    Naidu.

  • User experience question for High Availability

    Hi Experters,
    Not sure whether this is right forum to post this message.
    If anybody has already captured user experience for the failover environment, will appreciate their help on this. I will give overview of environment. Using PowerHA for ASCS/SCS failover, ORACLE Data Guard for Database failover.
    Trying to capture user experience for the failover environment
    if ASCS/SCS fail,
    App Server Fail (using F5 Load Balancer which should reroute, unless all app server fail),
    Database fail
    with following cases:
    1. User logged in, NO ACTIVITY. I believe NO IMPACT either ASCS/SCS fail or DB fail or App Server fail.
    2. User logged in and run a transaction before failover.
         What will happen in case of ASCS / SCS
         What will happen in case of DB failover
       and  what will happen in case of App server fail (NO High Availability, only redundant app servers.      MAX 4 app servers for each component)
    3. User logged in and run a transaction during failover.
       What will happen in case of ASCS / SCS
         What will happen in case of DB failover
       and  what will happen in case of App server fail (NO High Availability, only redundant app servers.      MAX 4 app servers for each component)
    Not sure which one possible or not. Some case thinking system will hang need to refresh. Some case hour glass and then come back once failover complete. and some case session closed completely.
    Thanks for your time and god bless the knowledge you have.
    Saroj

    just try to answer as much as I can (guess)
    > 1. User logged in, NO ACTIVITY. I believe NO IMPACT either ASCS/SCS fail or DB fail or App Server fail.
    DB failed and SCS failed won't have any impact to enduser, but if app server failed, the user session will lost, user will see a pop up error message at their SAPGUI.
    > 2. User logged in and run a transaction before failover.
    >      What will happen in case of ASCS / SCS
    user wont'be effected during failover if user is doing nothing but idle (replica enqueue is working before failover)
    >      What will happen in case of DB failover
    App server won't be able to do much thing but it's work processes into reonnecting status. it should resume (reconnect to DB) when failover is compoleted. So user should be able to continue the sessions.
    >    and  what will happen in case of App server fail (NO High Availability, only redundant app servers.      MAX 4 app servers for each component)
    user sessions in failed app server will be lost. However user should be able to logon agan if
    1)  logon via group, and
    2) within the group, there is at least one appl server alive.
    > 3. User logged in and run a transaction during failover.
    hanging or
    >    What will happen in case of ASCS / SCS
    if the transaction is using enqueue service, for example, then user will get error message.  otherwise, user won't be effected, e.g. if use is just search a list of order. user wont to able to logon via group during the failover.
    You also should be pepared for user connected through message server, .e.g. http request dispatching through message server directly , or via web dispatchr. user wont be able to connect during the failover.
    >      What will happen in case of DB failover
    user will get error message, transaction will be aborted.
    >    and  what will happen in case of App server fail (NO High Availability, only redundant app servers.      MAX 4 app servers for each component)
    very similar case  as case 2.

  • Need to add a second weblogic server for high availability

    I have a weblogic 10.3.3 server with forms and reports 11.1.1.3.
    I have an adminServer, WLS_FORMS and WLS_REPORTS managed servers setup.
    This was setup with the wizard, so the WLS_FORMS is in the cluster_forms cluster group and WLS_REPORTS in the cluster_reports group.
    I now need to add a second server with forms and reports also to act as one big server and provide high availability and load balancing.
    How do I achieve thsi, is there a wizard that will do this?
    The two servers are setup in exactly the same way, with the same versions of Weblogic and Forms and Reports.
    Thanks in advance.

    I do not know "reports 11.1.1.3" application, but from your description this application is already targeted on a clustered configuration.
    So it should be sufficient to add 2 new instances in the WebLogic domain "WLS_FORMS_2", "WLS_REPORTS_2", include them into the existing clusters and add a load balancer (like apache + wleblogic-plugin) that will balance requests on instances.
    I never heard of wizards to create such clustered environments. However it is not hard to do:
    1- Install binaries on the new machine
    2- Create the domain configuration directory on the new machine using config.sh wizard in the same way you have aleady done with the first machine.
    In this step you can create a clone of the existing domain, but it is enough to create a domain with the same name and the same admin instance.
    Instead of using config.sh, you can also copy the domain directory from the existing machine and change diretories in scripts if needed.
    The domain configuration is needed only to find the binaries, the basic domain files common to all installations, and to allow startup scripts (see point 4-) to connect to the admin and download the domain/instance configuration.
    3- Configure the new instances on the existing WebLogic console
    4- Create startup scripts for "WLS_FORMS_2", "WLS_REPORTS_2" on the second machine
    Bye
    Mariano

  • Configure OAS with dataguard for high availibility

    Hi,
    We use oracle application server to connect to 10g database. This prod db has a physical standby db. I am trying to do a failover test where I make the physical standby as primary and connect to that db from our application.
    I change the dads.conf file to point to the physical db. but I get ORA-01033: ORACLE initialization or shutdown in progress Error-Code:1033 Error TimeStamp:Fri, 8 May 2009 21:57:55 GMT
    but this physical db is up & open and in read write stage.
    The db name is prod and prod_stby. is this because of the different names ??

    Hello,
    I think you need to keep the infrastructure database names the same. Have you considered using the failover capabilities within 10gAS for your application servers? This is different from
    Data Guard standby database option. Here is a good Metalink note on how to setup and configure 10g Application Server failover:
    Understanding OracleAS 10g High Availability - A Roadmap- Metalink Note #412159.1
    Cheers,
    Ben

  • Unable to download web test results for failed Availability Monitor request - HTTP 500

    When attempting to download the Web Test results for a failed request in my availability monitor, the server returns HTTP 500.
    The full URL attempting to be accessed is https://stamp2.app.insightsportal.visualstudio.com/api/WebTestResult?fileName=eProd Dx1 Api_2015-02-25T16:58:00.000Z.webtestresult&subscriptionId=REMOVEDFORSECURITYPURPOSES&resourceGroup=eprod-dx1webapi&webTestId=eprod
    dx1 api-eprod-dx1webapi&location=us-ca-sjc-azr&timestamp=1424883480
    I can provide the sub ID as needed.

    Thinking this is an Azure Portal issue. Please move.

  • How to configure two TMG 2010 Standard Edition for High Availability

    I've classic scenario.
    TMG2010 as Edge Firewall, with two NICs, one from ISP and the other for LAN.
    I've standard edition, and i want to setup two TMG2010.
    Can i create some high availability with these two tmg2010 in some way??
    maybe some NLB?? to share their internal IP and Public IP?
    in case that TMG01 fails, the services to be offered by TMG02?
    Regards
    Lasandro Lopez

    Hi,
    Thank you for your post here.
    I do not think it is  a good idea.
    Please refer to the article below:
    http://www.experts-exchange.com/Microsoft/Windows_Security/Q_28014001.html
    Best Regards
    Quan Gu

  • Wrong result for decimal in currency

    Hi All,
    I loaded the history data by pc_file to the bw systems and when ı check the data in the infocube and in the source file, they are same. But when ı executed the report, for example the value of the keyfigure in the cube and source file is 118,36 but in the report it seems 11836,00.   How can it happen??
    Please help me on this.
    Regards,
    Turan

    Hi,
    There could be scaling used in the reports.
    just go to the properties of the RKF and CKF and also key figures and see if some scaling ( *100)is used.
    Also try to see if u are making correct inetrpreatation of ,(comma) and .(dots)
    Thanks
    Ajeet

  • Wrong result for query with like and %

    I have a strange problem with query with like and %.
    When I run this script:
    ALTER SESSION SET NLS_SORT = 'BINARY_CI';
    ALTER SESSION SET NLS_COMP = 'LINGUISTIC';
    -- SELECT * FROM NLS_SESSION_PARAMETERS;
    -- drop table test1;
    CREATE TABLE TEST1(K1 NVARCHAR2(80));
    INSERT INTO TEST1 VALUES ('gsdk');
    INSERT INTO TEST1 VALUES ('ąxyz');
    INSERT INTO TEST1 VALUES ('ŁFa');
    INSERT INTO TEST1 VALUES ('ła');
    INSERT INTO TEST1 VALUES ('Śab');
    INSERT INTO TEST1 VALUES ('Śrrrb');
    commit;
    select * from TEST1 where k1 like N'Ł%';
    I get this:
    K1
    ŁFa
    ła
    Śab <- WRONG
    Śrrrb <- WRONG
    4 rows selected
    When i change datatype to varchar2 this code work correct.
    Is this a bug or what ?
    The execution plan:
    PLAN_TABLE_OUTPUT
    SQL_ID d3d64aupz4bb5, child number 2
    select * from TEST1 where k1 like N'Ł%'
    Plan hash value: 4122059633
    | Id | Operation | Name | Rows | Bytes | Cost (%CPU)| Time |
    | 0 | SELECT STATEMENT | | | | 2 (100)| |
    |* 1 | TABLE ACCESS FULL| TEST1 | 1 | 82 | 2 (0)| 00:00:01 |
    Predicate Information (identified by operation id):
    1 - filter((NLSSORT("K1",'nls_sort=''BINARY_CI''')>=HEXTORAW('014200'
    ) AND NLSSORT("K1",'nls_sort=''BINARY_CI''')<HEXTORAW('01610100') ))
    Note
    - dynamic sampling used for this statement (level=2)

    DATABASE NLS CONFIGURATION:
    NLS_CHARACTERSET AL32UTF8
    NLS_NCHAR_CHARACTERSET     AL16UTF16
    NLS_COMP     BINARY
    NLS_SORT     BINARY
    Oracle version 11.2.0.2.0

  • Load from Setup tables breaking for high volume

    Hello Friends,
    There are around 50,000 records in the setup table for 03 related appl area. The load is breaking for 50,000 records in BW. But it works if I further select only one day data in the BW scheduler.
    Why is this?
    Immediate help is appreciated.
    Regards,
    Simmi

    Hello gurus,
    So, I tried reducing the packet size to 20,000 and no of Idocs to 10 per Infopckage. But this is working for only 40K records which a just a weeks data for the 2LIS_03_BF extractor.
    If I run 30 days worth of load form setup tables for the same etxractor, the load is breaking.
    The same is happening for a customer built Zextractor. For this I actually tried with 10,000 records and 5 IDOCS per package.
    Does, this mean for sure that there is a memory issue?
    Also, I see that all the BGD WPs have been occupied by other jobs. Is this an issue?
    But we have deltas running every night from R3, but t hese are less volumes(<10,000)and we have not seen this issue.
    However within BW there are heavy loads between data targets and they don't break.
    Is this a issue only for full loads from R3?
    Appreciate your immediate response.
    Thanks
    Simmi
    Edited by: simmi on Jun 20, 2008 1:39 AM

  • Week function gives wrong result for last week in year

    Week(CreateDate(2011,12,25)) returns 51 - correct
    Week(CreateDate(2011,12,26)) returns 53 - wrong
    It looks like all last weeks of the year are 53 whereas the next year with 53 weeks should be 2015.
    See http://tuxgraphics.org/toolbox/calendar.html for example.
    I am running CF9 on Windows 7 with Java V6 update 29.
    This is causing me a problem. Any ideas for a workaround?
    Doug

    Here is my general solution for my cfc which seems to work for all dates up to 2100 at least.
    Hope it can help if you need a Week function to replace the CF one.
    <cffunction name="getISOWeekNum" access="public" returntype="Numeric" hint="Gets ISO week number in which date occurs.">
        <cfargument name="date" type="date" required="true" hint="Date for which you wish to know the week number">
        <cfset var weeknum = 0>
        <cfset var isLeap = isLeapYear(Year(date))>
        <cfset var dayInWeek = dayOfWeek(date)>
        <cfset var isoDayOfWeek = iIf(dayInWeek GT 1, dayInWeek - 1, 7)>
        <cfset var nearestThur = dateAdd("d", 4 - isoDayOfWeek, date)>
        <cfset var fourthDayOfYear = createDate(year(nearestThur), 1, 4)>
        <cfset var fourthDayInWeek = dayOfWeek(fourthDayOfYear)>
        <cfset var fourthIsoDayOfWeek = iif(fourthDayInWeek GT 1, fourthDayInWeek - 1, 7)>
        <cfset var firstThur = dateAdd("d", 4 - fourthIsoDayOfWeek, fourthDayOfYear)>
        <cfset var lastWeek = iIf(fourthDayInWeek EQ 8 OR (isLeap AND fourthDayInWeek EQ 7), 53, 52)>
        <cfset var firstIsoDayOfFirstWeek = dateAdd("d", -(fourthIsoDayOfWeek-1), fourthDayOfYear)>
        <cfset var firstIsoDayOfLastWeek = dateAdd("d", -7, firstIsoDayOfFirstWeek)>
        <cfset var lastIsoDayOfFirstWeek = dateAdd("d", 6, firstIsoDayOfFirstWeek)>
        <cfset var weekDiff = iIf(dateCompare(date, firstIsoDayOfFirstWeek, "d") EQ -1, 0, 1)>
        <cfif dateCompare(date, firstIsoDayOfFirstWeek, "d") EQ -1 AND dateCompare(date, firstIsoDayOfLastWeek, "d") NEQ -1>
            <cfset weeknum = lastWeek>
        <cfelseif dateCompare(date, lastIsoDayOfFirstWeek, "d") NEQ 1 AND dateCompare(date, firstIsoDayOfLastWeek, "d") NEQ -1>
            <cfset weeknum = 1>
        <cfelse>
            <cfset weeknum = weekDiff + (dateDiff("d", firstThur, nearestThur) / 7)>
        </cfif>
        <cfreturn weeknum>
    </cffunction>
    Doug

Maybe you are looking for