Bridge domain issue

Hi,
Im Currently using a 4431 router configuring it with a bridge domain. Im encountering problems with the bridge domain interface not able to ping my load balancer IP address.
We have one 4431 router connected to 2 2960 switches with 2 F5 connected to both of the switches also.
Below is my configuration for the bridge domain:
interface BDI1
 ip address 192.168.1.219 255.255.255.224
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no cdp enable
interface GigabitEthernet0/0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 negotiation auto
 service instance 1 ethernet
  encapsulation untagged
  bridge-domain 1
interface GigabitEthernet0/0/2
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 negotiation auto
 service instance 1 ethernet
  encapsulation untagged
  bridge-domain 1
Im not able to ping my load balancer IP address:
sg-wr01#ping 192.168.1.220
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.220, timeout is 2 seconds:
Success rate is 0 percent (0/5)
sg-wr01#ping 192.168.1.221
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.221, timeout is 2 seconds:
Success rate is 0 percent (0/5)
sg-wr01#ping 192.168.1.222
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.222, timeout is 2 seconds:
Success rate is 0 percent (0/5)
But when I change the bridge domain interface to a layer 3 interface I can ping the load balancer IP address:
interface GigabitEthernet0/0/1
 ip address 192.168.1.219 255.255.255.224
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 negotiation auto
end
sg-wr01#ping 192.168.1.220
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.220, timeout is 2 seconds:
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
sg-wr01#ping 192.168.1.221
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.221, timeout is 2 seconds:
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
sg-wr01#ping 192.168.1.222
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.222, timeout is 2 seconds:
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Has anyone encountered this before?
Below is the network diagram:
Thanks,
Marvin

Did you do a no shut on the BDI?
"The initial administrative state of a BDI depends on how the BDI is created. When a BDI is created at boot time in the startup configuration, the default administrative state for the BDI will be up, and will remain in this state unless the startup configuration includes the shutdown command. This behavior is consistent with all the other interfaces. When a BDI is created dynamically by a user at command prompt, the default administrative state is down."

Similar Messages

  • How to make ASR9000 bridge domain forward traffic between sub interfaces of same physical interface?

    Hi,
    I regularly use bridge domains to connect sub interfaces on different vlans using this sort of configuration:
    interface GigabitEthernet0/0/0/5.21 l2transport
    description CUSTOMER A WAN
    encapsulation dot1q 21
    rewrite ingress tag pop 1 symmetric
    interface GigabitEthernet0/0/0/10.3122 l2transport
    description CUSTOMER A CORE
    encapsulation dot1q 3122
    rewrite ingress tag pop 1 symmetric
    l2vpn
    bridge group WANLINKS
      bridge-domain CUSTOMERA
       interface GigabitEthernet0/0/0/5.21
       interface GigabitEthernet0/0/0/10.3122
    When I try to use the same method to bridge two sub interfaces on the same physical interface so as to create a L2 VPN no data flows:
    interface GigabitEthernet0/0/0/5.21 l2transport
    description CUSTOMER A WAN
    encapsulation dot1q 21
    rewrite ingress tag pop 1 symmetric
    interface GigabitEthernet0/0/0/5.22 l2transport
    description CUSTOMER A WAN2
    encapsulation dot1q 22
    rewrite ingress tag pop 1 symmetric
    l2vpn
    bridge group WANLINKS
      bridge-domain CUSTOMERA
       interface GigabitEthernet0/0/0/5.21
       interface GigabitEthernet0/0/0/5.22
    If I add a BVI interface to the bridge domain then the CE devices at the remote end of the WAN interface can both ping the BVI IP but they remain unable to ping each other.
    Is this because tag rewrites are not happening since packets don't leave the physical interface?
    How can I work around this and establish a L2 connection between the two subinterfaces?
    Thank you

    a vlan is usually the equivalent of an l3 subnet, so linking 2 vlans together in the same bridge domain, likely needs to come with some sort of routing (eg a BVI interface).
    If these 2 vlans are still in the same subnet, then there is still arp going on, from one host to the other that traverses the bD.
    you will need to verify the state of the AC, the forwarding in the BD and see if something gets dropped somewhere and follow the generic packet troubleshooting guides (see support forums for that also).
    that might give a hint to what the precise issue in your forwarding is.
    regards
    xander

  • ME3600-ME3800: service-instance & bridge-domain syntax

    Hello,
    what is the best practice for the configuration of L3VPN on Cisco ME3XXX ?
    Old Syntax:
    interface GigabitEthernet0/1
    switchport trunk allowed vlan none
    switchport mode trunk
    service instance 2 ethernet
      encapsulation dot1q 3
      rewrite ingress tag pop 1 symmetric
      bridge-domain 4
    interface vlan 4
    vrf forwarding L3VPN-1
    ip address 2.2.2.1 255.255.255.0
    New Syntax:
    interface GigabitEthernet0/1
    switchport trunk allowed vlan none
    switchport mode trunk
    service instance 2 ethernet
      encapsulation dot1q 3
      rewrite ingress tag pop 1 symmetric
    bridge-domain 4
    member GigabitEthernet0/1 service-instance 2
    interface vlan 4
    vrf forwarding L3VPN-1
    ip address 2.2.2.1 255.255.255.0
    The new syntax is very much similar to the new syntax for L2VPN, see:
    http://www.cisco.com/en/US/docs/switches/metro/me3600x_3800x/software/design/guide/ME3600x_Design_Guide.pdf
    I'm soon sending in the field some more ME3600, so I'd like to start right.
    Best Regards
    Andrea

    Hello.
    You might have confused service instance configuration and usual switchport mode trunk.
    Please refer figure 11-10 in the document http://www.cisco.com/c/en/us/td/docs/switches/metro/me3600x_3800x/software/release/12-2_52_ey/configuration/guide/3800x3600xscg/swevc.html
    >But there is a typo - per description it should be "enc doat1q 20" under service instance 9on the picture).
    Also under Figure 11-2 we have following example:
     QinQ is also supported when sending packets between an EFP and a switchport trunk, because the switchport trunk is implicitly defined as rewrite ingress tag pop 1 symmetric. The same external behavior as Method 1 can be achieved with this configuration:
    Switch (config)# interface gigabitethernet0/1 
    Switch (config-if)# service instance 1 Ethernet 
    Switch (config-if-srv)# encapsulation dot1q 1-100 
    Switch (config-if-srv)# bridge-domain 30
    Switch (config)# interface gigabitethernet0/2 
    Switch (config-if)# switchport mode trunk
    Again, service instance 1 on Gigabit Ethernet port 0/1 is configured with the VLAN encapsulations used by the customer: C-VLANs 1-100. These are forwarded on bridge-domain 30. The service provider facing port is configured as a trunk port. The trunk port implicitly pushes a tag matching the bridge-domain that the packet is forwarded on (in this case S-VLAN 30). 

  • Bridge-domain and trunk configuration on ES20 card.

    Hello.
    I have two 7609-S boxes equipped with ESM20G cards and WS-X6748-GE-TX cards. A trunk is configured on ports of WS cards between these devices. A very important system is to be connected with two optical links to both devices via ES20 cards for redundancy. I consider configuring it using EVC framework in the following way:
    service instance -> bridge-domain XXX -> interface VLAN XXX and enable HSRP on my devices.
    I am not sure what is the structure of conecting system so I would like to have some kind of L2 connectivity between my devices for this connection. For other connections made using ports on WS card a dedicated VLAN is allocated for every one of them and then this VLAN is simply put in trunk between devices. Can I simply add vlan XXX to the list of VLANs allowed on the WS-card-based-trunk or do I have to utilize some completely different solution? Links to any related documentation are appreciated. Tomorrow I am going to test this configruation any way but I would like to have some backup solution in case this will not work.
    Thanks in advance,
    Andrew.

    Hi Andrei,
    Im having the same dilemna and im wondering if you were able to find a solution for this?
    I need to support HSRP on a vlan interface with bridging over port channel bundled interface between routers.
    im trying this but i cant seem to get this to work.
    ----R2----
    interface Vlan10
    ip vrf forwarding BOB
    ip address 10.1.1.2 255.255.255.248
    standby 1 ip 10.1.1.1
    standby 1 priority 110
    standby 1 preempt
    end
    interface Port-channel1
    no ip address
    service instance 10 ethernet
      encapsulation dot1q 10
      bridge-domain 10
    --- R2----
    interface Vlan10
    ip vrf forwarding BOB
    ip address 10.1.1.3 255.255.255.248
    standby 1 ip 10.1.1.1
    end
    interface Port-channel1
    no ip address
    service instance 10 ethernet
      encapsulation dot1q 10
      bridge-domain 10
    BR//
    Chanuka

  • Bridge domain questions

    Hi everybody.
    At work , I have seen a lot of bridge domains configured on a single switch. My question is what is bridge domain and why we use them. An example with configurations will be great.
    Thanks and have a great day.

    Hi Marvin and Rick
    Please consider the following config and questions:
    R1#  show platform
    Interrupt Throttling:
      Throttle Count   = 00052552   Timer Count      = 00039372
      Netint usec      = 00000800   Netint Mask usec = 00000240
      Active           =        0   Configured       =        1
      Longest IRQ(usec)= 00003999
    MSFC CPU IDPROM:
    IDPROM image:
      (FRU is 'C7600 MSFC4 Daughterboard')
    +++++++++++++++++++++++++++++++++++++++++
    R1#show running-config interface gigabitEthernet 9/7
    service instance 1251 ethernet
      encapsulation dot1q 1251
      rewrite ingress tacg pop 1 symmetri
      bridge-domain 440
    service instance 2001 ethernet
      encapsulation dot1q 2001
      rewrite ingress tag pop 1 symmetric
      bridge-domain 440
    +++++++++++++++++++++++++++++++++++++++++
    Let say R1 receives a packet with vlan tag 1251 on g9/7. What will happen next? will R1 update its MAc table with source mac?
    1)Will there be a mac table for bridge -domain 440?  Do we have one-to one correspondence between the two i.e each  bridge-domain has its own mac table.?
    2)Let say R1 receives a packet with vlan tag 1251 on g9/7. What will happen next? will R1 update its MAc table with source mac?
    3) Let say R1 receives a frame with vlan tag 1251 with destination mac ff:ff:ff:ff
    What will R1 do next?
    4)Will R1 forward it to all service instance in bridge-domain 440 except the one R1 receives the broadcast frame? 
    ( in our case we have two service instances under  bridge -domain 440 i.e service instance 1251 ethernet,service instance  2001 ethernet)
    5) Will R1 change the vlan tag 1251 to 2001 when forwarding the broadcast frame out of instance 2001?
    Appreciate your help.
    Thanks

  • Bridge-domain vs xconnect

    Hi guys, I have been readying a few documents about VPLS/EoMPLS but still confuse about the bridge-domain and xconnect. Could you please provide any ideas which scenarios I should use bridge-domain and which should be for xconnect? What is the difference between them, any documens can explain this?
    Thanks, Leo

    The simple difference between the 2 is mac learning.
    An Xcon will just throw everything it received over to the other end.
    A bridge-domain will forward traffic based on the dmac knowing where it should go. If it doesnt know it goes flooding.
    So if you have 2 circuits to connect only, VPWS or XCON is the right choice as it is simple, light weight and fast.
    If you have more then 2 end points you will need a Bridge Domain which constitutes mac learning with the notion that flooding is intensive from a hw forwarding perspective and will consume more system resources in terms of mac tables.
    xander
    Xander Thuijs #6775
    Principal Engineer ASR9000

  • High bridge domain (BD) utlization

    Hello,
    is there any way to know which brdige domain/P2P Xconnect is getting more utlizaiton or traffic.
    since many BD are sharing the same physical interface there is a need to know which BD is getting more of link bandwidh.
    Mohamed.

    Hi Mohammed,
    You can run mpls netflow on the core facing interface and based on the VC label you can figure out which pseudowire is getting lot of traffic.
    other way to check would be "sh l2vpn bridge-domain bd-name xxx detail" and look at the
    Statistics:
            packets: received 0, sent 0
            bytes: received 0, sent 0
    which will be cumbersome if you have lot of p2p in the network.
    HTH,
    Chander

  • VPLS: bridge-domain o xconnect?

    Hi all,
    to attach an interface to a vfi I have seen two kind of possible solution:
    L2 vfi <name> manual
    Vpn id <VPNid>
    bridge-domain <bridge-domain id>
    Neighbor <Remote-PE>
    interface fastethernetx/y
    bridge-domain < bridge-domain id>
    or
    interface fastethernetx/y
    xconnect vfi <name>
    What is the difference between the command bridge-domain o xconnect? When I must use one or the other?
    Thanks in advance
    Gianluca

    hi! I am not entirely sure about it but this is my best shot...
    X-connect would be used to establish a pseudo-wire (point-to-point) for an EPL service like EoMPLS. That will just connect the 2 UNI together to the VC created by the X-connect command. In this case ther would be no mac table maintained for the VSI in the router.
    Bridge domain can be used so that you create a seperate bridge domain ( like a virtual bridge) and add ports to that and connect it to remote PE so that you create a VPLS connection. The PE will maintain a seperate mac table for the VSI.
    So thats what I think - PWE3 v/s VPLS..
    Correct me if I am wrong.
    Thanks....

  • Bridge Domain and multicast traffic

    Hi All,
    i am planning to build a Point to multipoint network based on ME3600X switch at the HQ and ISR 2900 routers at the Branches. i need to simulate a lan service.
    i though of using EOMPLS at the ISR 2900 and closing them at the ME3600X. at the ME3600X i will use bridge domain to have this point to multipoint functionality.
    at the configuration guide i saw that when i am using bridge domain i need to disable IGMP snooping on every Vlan.
    my question is how the bridge domain treat Multicast traffic ?
    furthermore, can i mix EOMPLS and Bridge Domain ?
    Thanks,
    Avi.

    Hi Avi,
    ME3600X doesn't support VPLS yet (check with your account team for the roadmap) so I don't think your design will work here. What you can do is having a router behind the ME3600X which will have a dedicated VLAN with each remote site.
    HTH
    Laurent.

  • Bridge-domain traffic paths

    Hi guys,
    Couldn't really get into logic of bridge-domain and hsrp coexistence. How traffic will be flooded?
    Imagine following topology:
    Bridge-domain and hsrp is running between ASR1 and ASR2.
    Host C has two network adapters. Both are in UP state, but only one of them is forwarding traffic.
    I am curious, what path traffic will take from host A to host C and from B to C in situation when :
    1) net.adapter #1 is active
    2) net.adapter #2 is active
    p.s. active router for hsrp remains the same.
    We have captured traffic on the devices, and it was a bit confusing to me that standby hsrp router was forwarding traffic from host B out of g0/0/0/0 and pw 3
    I would appriciate any help...

    Okay, that really make sence. Thank You very much for the explanation!
    Yes, You are right, that's RNC.
    Theoretically the MAC address should be flushed away from the memory when the switchover of the network card appears, because, the connection for some seconds goes down.
    Could You please tak a look on the following output:
    As I understand, both ASR's do know where 0040.4384.8260 (This is RNC NPGEP mac address) is. So basically there should not be any flooding..
    RP/0/RSP1/CPU0:ASR9k-1#sh l2vpn forwarding bridge-domain RNC:RNC3_TEST mac-address detail location 0/0/CPU0
    Mon Dec  2 21:05:25.639 EET
    Bridge-domain name: RNC:RNC3_TEST, id: 20, state: up
    MAC learning: enabled
    MAC port down flush: enabled
    Flooding:
       Broadcast & Multicast: enabled
       Unknown unicast: enabled
    MAC aging time: 300 s, Type: inactivity
    MAC limit: 4000, Action: none, Notification: syslog
    MAC limit reached: no
    MAC Secure: disabled, Logging: disabled
    DHCPv4 snooping: profile not known on this node
    Dynamic ARP Inspection: disabled, Logging: disabled
    IP Source Guard: disabled, Logging: disabled
    IGMP snooping: disabled, flooding: enabled
    Routed interface: BVI3, Xconnect id: 0x8000001f, state: up
      IRB platform data: {0x14000a, 0x1, 0x0, 0x80000000}, len: 16
    Bridge MTU: 1500 bytes
    Number of bridge ports: 2
    Number of MAC addresses: 2
    Multi-spanning tree instance: 0
    Mac Address: 0000.0c07.ac03, LC learned: N/A
       Resync Age: N/A, Flag: static, BVI
    Mac Address: 6c9c.ed0a.2e3d, LC learned: N/A
       Resync Age: N/A, Flag: static, BVI
      GigabitEthernet0/0/0/0, state: oper up
        Number of MAC: 1
        Statistics:
          packets: received 48765801690, sent 309298266072
          bytes: received 33416543382293, sent 54307173696538
        Storm control drop counters:
          packets: broadcast 0, multicast 0, unknown unicast 0
          bytes: broadcast 0, multicast 0, unknown unicast 0
        Dynamic arp inspection drop counters:
          packets: 0, bytes: 0
        IP source guard drop counters:
          packets: 0, bytes: 0
    Mac Address: 0040.4384.8260, LC learned: 0/0/CPU0
       Resync Age: 0d 0h 0m 0s, Flag: local
      Nbor 10.9.9.253 pw-id 3
        Number of MAC: 1
        Statistics:
          packets: received 19771488146, sent 198111062527
          bytes: received 10977874479587, sent 50825792902418
        Storm control drop counters:
          packets: broadcast 0, multicast 0, unknown unicast 0
          bytes: broadcast 0, multicast 0, unknown unicast 0
        Dynamic arp inspection drop counters:
          packets: 0, bytes: 0
        IP source guard drop counters:
          packets: 0, bytes: 0
    Mac Address: 6c9c.ed0a.9ced, LC learned: 0/0/CPU0
       Resync Age: 0d 0h 0m 0s, Flag: global
       L3 encapsulation Vlan: 2558
    RP/0/RSP1/CPU0:ASR9k-2#sh l2vpn forwarding bridge-domain RNC:RNC3_TEST mac-address detail location 0/0/CPU0
    Mon Dec  2 21:05:49.504 EET
    Bridge-domain name: RNC:RNC3_TEST, id: 15, state: up
    MAC learning: enabled
    MAC port down flush: enabled
    Flooding:
       Broadcast & Multicast: enabled
       Unknown unicast: enabled
    MAC aging time: 300 s, Type: inactivity
    MAC limit: 4000, Action: none, Notification: syslog
    MAC limit reached: no
    MAC Secure: disabled, Logging: disabled
    DHCPv4 snooping: profile not known on this node
    Dynamic ARP Inspection: disabled, Logging: disabled
    IP Source Guard: disabled, Logging: disabled
    IGMP snooping: disabled, flooding: enabled
    Routed interface: BVI3, Xconnect id: 0x8000001a, state: up
      IRB platform data: {0xf000a, 0x1, 0x0, 0x80000000}, len: 16
    Bridge MTU: 1500 bytes
    Number of bridge ports: 2
    Number of MAC addresses: 3
    Multi-spanning tree instance: 0
    To Resynchronize MAC table from the Network Processors, use the command...
        l2vpn resynchronize forwarding mac-address-table location
      GigabitEthernet0/0/0/0, state: oper up
        Number of MAC: 0
        Statistics:
          packets: received 782133119087, sent 620642426712
          bytes: received 514958352902308, sent 107302134940298
        Storm control drop counters:
          packets: broadcast 0, multicast 0, unknown unicast 0
          bytes: broadcast 0, multicast 0, unknown unicast 0
        Dynamic arp inspection drop counters:
          packets: 0, bytes: 0
        IP source guard drop counters:
          packets: 0, bytes: 0
      Nbor 10.9.9.254 pw-id 3
        Number of MAC: 3
        Statistics:
          packets: received 297905813562, sent 17722149746
          bytes: received 68165206300571, sent 10642920750826
        Storm control drop counters:
          packets: broadcast 0, multicast 0, unknown unicast 0
          bytes: broadcast 0, multicast 0, unknown unicast 0
        Dynamic arp inspection drop counters:
          packets: 0, bytes: 0
        IP source guard drop counters:
          packets: 0, bytes: 0
    Mac Address: 0000.0c07.ac03, LC learned: 0/0/CPU0
       Resync Age: 0d 0h 0m 0s, Flag: global
       L3 encapsulation Vlan: 510
    Mac Address: 0040.4384.8260, LC learned: 0/0/CPU0
       Resync Age: 0d 0h 0m 0s, Flag: global
       L3 encapsulation Vlan: 510
    Mac Address: 6c9c.ed0a.2e3d, LC learned: 0/0/CPU0
       Resync Age: 0d 0h 0m 0s, Flag: global
       L3 encapsulation Vlan: 3582

  • How to configure 8192 bridge domain default limit shows 2048

    Hello,
     How can i scale up bridge-domain from 2048 to 8192.
     As per the link (http://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k_r4-1/lxvpn/configuration/guide/lesc41/lesc41p2mps.html) ASR9000 series routers can scale up to 8192 bridge-domains.
     However my ASR9k shows the l2vpn capability to be only around 2048. How can i configure 8192 bridge-domain
    RP/0/RSP0/CPU0:ci-asr9k#show l2vpn capability 
    Tue Feb 10 14:11:36.797 EST
    Capability mode: mixed-mode
    L2vpn all-capable: N
    System capability:
      VPLS Max MAC addresses: 32000 
      VPLS Max bridge-domains: 2048 
      VPLS Max attachment circuits: 32768 
      VPLS Max pseudowires: 32768 
      RSI bit size: 13 
      Per-AC drop counters supported: Y 
      VPLS Preferred path allowed: Y 
      VPLS Preferred path fallback enable allowed: Y 
      VPLS Preferred path fallback disable allowed: Y 
      MAC withdrawal allowed: Y 
      Max attachment circuits per bridge-domain: 16384 
      VPLS Max virtual forwarding interfaces: 2048 
      VPLS Max virtual forwarding interfaces per bridge-domain: 1 
      VPLS Max pseudowires per bridge-domain: 512 
      VPLS Max pseudowires per virtual forwarding interface: 512 
      VPWS PW redundancy supported: Y 
      VPLS Access PW supported: Y 
      Bundle AC supported: Y 
      Security config supported: Y 
      DHCP snooping supported: Y 
      VPLS Static MAC filter supported: Y 
      VPLS MAC configs on bridge port supported: Y 
      VPLS Flooding config on bridge port supported: Y 
      Flood unknown unicast disable supported: Y 
      IGMP snooping supported: Y 
      MMRP flood optimization supported: Y 
      MMRP flood optimization max multicast address entries: 8192 
      MMRP flood optimization max PW participants: 262144 
      VPLS MAC Aging Default Timer Value: 300 
      VPLS MAC Aging Min Timer Value: 300 
      VPLS MAC Aging Max Timer Value: 30000 
      VPWS Max attachment circuits: 32768 
      VPWS Max pseudowires: 32768 
      VPWS Preferred path fallback enable allowed: Y 
      VPWS Preferred path fallback disable allowed: Y 
    -Ramdas

    Are there any LC scale profiles configured in the admin mode? If so, that would reduce L2 resources. If you don't need the L3 profile, remove it and reboot the router to gain back 8k bridge domains.
    Regards, 
    /A

  • Creation of domain issues - migration from weblogic 10.3.0 to 10.3.5 versio

    Hello,
    i would like to kindly ask for a help with following issue:
    Basically we are migrating from the 10.3.0 to the 10.3.5 version. We are building the domain using the template in "silent mode". And when i try to create the domain with new weblogic 10.3.5 im getting some errors.
    The command to run the creation of the domain is following:
    ${WL_HOME}/common/bin/config.sh -mode=silent -silent_script=${SILENT_SCRIPT} -log=${WLLOGFILE} >> ${LOGFILE} 2>&1
    returnCode=$?
    SILENT_SCRIPT contains following commands:
    read template from "/local/wg372/BM/appl/config/NEW_DOMAIN_CONFIGURED.jar";
    write domain to "/local/wg372/BM/appl/BmDomain";
    set OverwriteDomain "true";
    close template;
    When i setup new env(solaris) with weblogic 10.3.5 im getting following error when the silent_script command (*write domain to "/local/wg372/BM/appl/BmDomain";*) is executed:
    2011-07-18 16:53:00,427 INFO [runScript] com.oracle.cie.domain.script.ScriptExecutor - succeed: read template from "/local/wg372/BM/appl/config/NEW_DOMAIN_CONFIGURED.jar"
    2011-07-18 16:53:00,427 INFO [runScript] com.oracle.cie.domain.script.ScriptExecutor - write Domain to "/local/wg372/BM/appl/BmDomain"
    2011-07-18 16:53:00,505 ERROR [runScript] com.oracle.cie.wizard.domain.silent.tasks.RunScriptTask - There was an error executing the script: /local/wg372/BM/appl/installer/silent_script
    java.lang.NullPointerException
         at com.oracle.cie.domain.security.SecurityGenerateLDIFT.buildSecurityInfo(SecurityGenerateLDIFT.java:460)
         at com.oracle.cie.domain.security.SecurityGenerateLDIFT.<init>(SecurityGenerateLDIFT.java:119)
         at com.oracle.cie.domain.script.ScriptExecutor.writeDomain(ScriptExecutor.java:718)
         at com.oracle.cie.domain.script.ScriptParserClassic$StateMachine.processWrite(ScriptParserClassic.java:573)
         at com.oracle.cie.domain.script.ScriptParserClassic$StateMachine.execute(ScriptParserClassic.java:429)
         at com.oracle.cie.domain.script.ScriptParserClassic.parseAndRun(ScriptParserClassic.java:148)
         at com.oracle.cie.domain.script.ScriptParserClassic.doExecute(ScriptParserClassic.java:110)
         at com.oracle.cie.domain.script.ScriptParser.execute(ScriptParser.java:72)
         at com.oracle.cie.domain.script.ScriptParser.execute(ScriptParser.java:35)
         at com.oracle.cie.wizard.domain.helpers.Executor.runSilentScript(Executor.java:68)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:597)
         at com.oracle.cie.wizard.domain.silent.tasks.RunScriptTask.runScriptWithExecutor(RunScriptTask.java:551)
         at com.oracle.cie.wizard.domain.silent.tasks.RunScriptTask.execute(RunScriptTask.java:335)
         at com.oracle.cie.wizard.silent.tasks.AbstractSilentTask.run(AbstractSilentTask.java:28)
         at java.lang.Thread.run(Thread.java:662)
    In Windows env im getting following error:
    create.domain:
    [exec] -mode="silent" -silent_script=J:/_dev/build/installer/silent_script
    [exec] << read template from "J:/_dev/build/config/NEW_DOMAIN_CONFIGURED.jar"
    [exec] >> succeed: read template from "J:/_dev/build/config/NEW_DOMAIN_CONFIGURED.jar"
    [exec] << write Domain to "J:/_dev/build/BmDomain"
    [exec] CFGFWK-60550: Script execution aborted. The script may contain an error.
    [exec] null
    CFGFWK-60550: - doc says
    CFGFWK-60550: Script execution aborted. The script may contain an error.
    Cause:
    Action:
    Level: 1
    Type: ERROR
    Impact: Configuration
    I tried to google for this issue, look into the weblogic documentation but with no luck.
    So i would like to kindly ask, if anyone of you perhaps could give me a hint/advise with this problem.
    Thanks in advance.

    Hi,
    thanks for the reply but im not sure if we are talking about the same thing. What i need is to upgrade the weblogic "DOMAIN" not the weblogic installation itself.
    Anyway,
    after some googling and testing im again stucked with another issue:
    1. First i have created the old doman (10.3.0)
    2. Then i have tested the domain with the new weblogic version 10.3.5 - as it should be (and is) compatible within those 2 versions
    ---> worked fine
    3. Then via offline WLST(of weblogic 10.3.5) i have managed to create new template with command writeTemplate(nameOfTemplate.jar)
    4. But when i try to create the new domain with the new template via WLST(of weblogic 10.3.5) im again stucked (im able to read the template in wlst but not able to writeDomain ) - error:
    wls:/offline> readTemplate('/home/wg372/tmp/new_template.jar')
    wls:/offline/BmDomain>writeDomain('/home/wg372/tmp/new_domain')
    Error: writeDomain() failed. Do dumpStack() to see details.
    wls:/offline/BmDomain>dumpStack()
    com.oracle.cie.domain.script.jython.WLSTException: com.oracle.cie.domain.script.ScriptException: The application location must have write permission.
    at com.oracle.cie.domain.script.jython.CommandExceptionHandler.handleException(CommandExceptionHandler.java:51)
    at com.oracle.cie.domain.script.jython.WLScriptContext.handleException(WLScriptContext.java:1538)
    at com.oracle.cie.domain.script.jython.WLScriptContext.writeDomain(WLScriptContext.java:803)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.python.core.PyReflectedFunction.__call__(Unknown Source)
    at org.python.core.PyMethod.__call__(Unknown Source)
    at org.python.core.PyObject.__call__(Unknown Source)
    at org.python.core.PyInstance.invoke(Unknown Source)
    at org.python.pycode._pyx3.writeDomain$15(/var/tmp/WLSTOfflineIni6651397525640719781.py:71)
    at org.python.pycode._pyx3.call_function(/var/tmp/WLSTOfflineIni6651397525640719781.py)
    at org.python.core.PyTableCode.call(Unknown Source)
    at org.python.core.PyTableCode.call(Unknown Source)
    at org.python.core.PyFunction.__call__(Unknown Source)
    at org.python.pycode._pyx24.f$0(<console>:1)
    at org.python.pycode._pyx24.call_function(<console>)
    at org.python.core.PyTableCode.call(Unknown Source)
    at org.python.core.PyCode.call(Unknown Source)
    at org.python.core.Py.runCode(Unknown Source)
    at org.python.core.Py.exec(Unknown Source)
    at org.python.util.PythonInterpreter.exec(Unknown Source)
    at org.python.util.InteractiveInterpreter.runcode(Unknown Source)
    at org.python.util.InteractiveInterpreter.runsource(Unknown Source)
    at org.python.util.InteractiveInterpreter.runsource(Unknown Source)
    at weblogic.management.scripting.WLST.main(WLST.java:173)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at weblogic.WLST.main(WLST.java:29)
    Caused by: com.oracle.cie.domain.script.ScriptException: The application location must have write permission.
    at com.oracle.cie.domain.script.ScriptExecutor.writeDomain(ScriptExecutor.java:757)
    at com.oracle.cie.domain.script.jython.WLScriptContext.writeDomain(WLScriptContext.java:795)
    ... 29 more
    I tried to have a look around for the "The application location must have write permission." problem but again with no luck.
    Furthemore when i try to do the same with old domain template, with old version of WLST (of weblogic 10.3.0), i have no problems with creating of the domain.
    Any ideas?
    Ill keep you updated :-)

  • SharePoint 2013 multi App domain issues

    Hello,
    All urls on purpose have a space character, this is because the forum didn't let me enter URLs.
    We have a problem with the new feature of SharePoint 2013 March PU “New-SPWebApplicationAppDomain”.
    We are implementing this feature for a client in Windows Azure. This lead to several technical issues to overcome and in previous LAB tests it seems that we have overcome these problems, using named binding instead of wildcard, and SNI.
    Goal:
    1 Webapplication with three zones:
    Default zone: https: //portal-ntlm.contoso.com
    Intranet zone: https: //portal-adfs.contoso.com
    Extranet zone: https: //portal-fba.contoso.com
    Default zone in NTLM of course is to make Search work.
    With the new feature described in http ://technet.microsoft.com/en-us/library/dn144963.aspx we should be able to get App Domains working on all three (or at least two out of three zones).
    In my LAB (Single server farm, running SP2013 SP1) I currently configured two zones, both NTLM to test the basics.
    Default zone: https: //portal.contoso.com Intranet zone: https: //portal-ta.contoso.com
    I have enabled the feature using these commands:
    $contentService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
    $contentService.SupportMultipleAppDomains = $true
    $contentService.Update()
    Iisreset
    Then I do this:
    New-SPWebApplicationAppDomain -AppDomain app1.fabrikam.com -WebApplication https: //portal.contoso.com -zone default -port 443 –SecureSocketsLayer       (This command works)
    and then:
    New-SPWebApplicationAppDomain -AppDomain app2.fabrikam.com -WebApplication https: //portal-ta.contoso.com -zone intranet -port 443 –SecureSocketsLayer   (This one doesn’t)
    Then we get this powershell error in RED:
    New-SPWebApplicationAppDomain : The IIS Web Site you have selected is in use
    by SharePoint.  You must select another port or hostname.
    At line:1 char:1
    + New-SPWebApplicationAppDomain -AppDomain apps2-ta.talentenik.nl
    -WebApplication  ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...cationAppDomain:
       SPCmdletNewWebApplicationAppDomain) [New-SPWebApplicationAppDomain], Argum
      entException
        + FullyQualifiedErrorId : Microsoft.SharePoint.Administration.SPAppCmdlets
       .SPCmdletNewWebApplicationAppDomain
    Extra info:
    I have tried using a single IP, multi IP, remove current IIS Binding, add the binding already etc. Nothing seems to work.
    When I change the PORT number of the second command to anything else it binds to the expected IIS Site but on the wrong port nr.
    The most strange thing also: I have a working set of VMs that actually works. I created a snapshot of the working situation. Reverted back to the before snapshot and tried to replay my steps but I keep running into issues when I try to add the second app-domain.
    Can anyone help me set this up.
    Thx
    Stefan Peters
                       

    I was in the same situation with my on-premises environment. I did a little bit more investigation and checked the code behind New-SPWebApplicationAppDomain. I wrote a full article about this issue
    http://www.vioreliftode.com/index.php/new-spwebapplicationappdomain-the-iis-web-site-you-have-selected-is-in-use-by-sharepoint-you-must-select-another-port-or-hostname/
    I also provided a way to bypass the limitation and be able to reuse the 80 and 443 ports for multiple app domains.

  • Windows 8.1 Pro join to domain issues....

    We bought some Windows 8.1 laptops and purchased the upgrade to the Pro version.  When I attempt to join the laptops to the domain, it prompts me for domain credentials, I enter them, and I get an error....
          Changing the Primary Domain DNS name of this computer to "mydomain.com" failed.
          The name will remain "mydomain.com".  The error was:
          The specified domain either does not exist or could not be contacted.
    Of course, the domain DOES exist and we have plenty of Windows 7 workstations signed into it just fine.  I hit OK then login to the laptop using a domain account.  At this point, I get an error telling me that no logon servers are available to authenticate.
    This is a Windows 2008 domain controlled environment.  Everything works fine otherwise for the Windows 7 systems, only these Windows 8.1 systems are having any issues.  The new laptops are even showing up in DNS on the domain controller.
    Any ideas what I might be missing?  Is there something special about joining Windows 8.1 Pro systems to a domain?

    OK; took a couple of more days than planned to get back on site.  We're continuing to do testing, but here's the IPConfig /ALL that was requested.  10.0.0.1 is the gateway, 10.0.0.10 is the DC.  The laptop is "Me-L" and the domain is "mydomain.com".
     The below was pulled after getting IP information assigned via DHCP.  The laptop is not joined to the domain at the moment and login is a local account.
    Windows IP Configuration
       Host Name . . . . . . . . . . . . : Me-L
       Primary Dns Suffix  . . . . . . . : mydomain.com
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : mydomain.com
    Wireless LAN adapter Local Area Connection* 3:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
       Physical Address. . . . . . . . . : A0-88-69-46-A4-CF
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    Ethernet adapter Bluetooth Network Connection:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
       Physical Address. . . . . . . . . : A0-88-69-46-A4-D2
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    Ethernet adapter Ethernet:
       Connection-specific DNS Suffix  . : mydomain.com
       Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
       Physical Address. . . . . . . . . : EC-F4-BB-9C-36-56
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 10.0.0.108(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Thursday, August 21, 2014 11:29:52 AM
       Lease Expires . . . . . . . . . . : Wednesday, August 27, 2014 11:29:50 AM
       Default Gateway . . . . . . . . . : 10.0.0.1
       DHCP Server . . . . . . . . . . . : 10.0.0.10
       DNS Servers . . . . . . . . . . . : 10.0.0.10
                                           10.0.0.10
       NetBIOS over Tcpip. . . . . . . . : Enabled
    Wireless LAN adapter Wi-Fi:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 3160
       Physical Address. . . . . . . . . : A0-88-69-46-A4-CE
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

  • After effects & Adobe Bridge preview Issue *freezing*

    Hello all,
    I wanted to begin learning After Effects CS4, unfortunately Adobe Bridge CS4 is halting my education.
    If I explore any kind of After effects CS4 preset, and preview it inside of Adobe bridge, my pc freezes. The preview window, within Bridge CS4 turns blank white while it freezes,
    the Windows toolbar of Adobe bridge, says not responding temporarily, if a wait a little while around 30-45 seconds I regain control of my pc again, the preview box occasionally will show a still image and sometimes it will stay white or flicker. If I do wait the 30-45 seconds the toolbar window no longer says 'not responding' I can click to a (non) After effects preset folder, (for example) 'My family pictures' and it will operate normally but if I go back to the After effects CS4 presets again the freezing will occur once more.
    What I find strange is that Adobe Bridge previewing, works absolutely fine for my photoshop documents, Illustrator documents, and any Jpeg photos I have, all after effect presets fail to preview, regardless of type if it's a still shape background or animated sprite, the same freeze issue occurs
    I was wondering if anyone has helpful tips?
    so far I have downloaded all important driver updates for my graphics card, my card is a nVidia GeForce 7900 GS 256, I have also reinstalled bridge and AfterEffects, I have downloaded all the relevent players.
    I am a Windows vista user, also I have enough RAM I believe, just over 3 Giga
    I dont know how useful the info is on my Pc spec is, but I thought it could be worth mentioning.
    I have looked for a few hours to find some kind of thread with a similar problem I have been unsuccessful, I hope someone can help
    Kindest regards Julian

    Hi Curt y,
    I do have the latest Quicktime player installed, I would'nt have have thought that would halt me previewing CS4 after effect still shapes and backgrounds? but.. I'm not to sure if I'm honest.
    well I tried uninstalling and reinstalled my player still no sucess sadly.
    do you know roughly what date all these old threads popped up?
    I'm going to scavenge for them anyway in the the hope I find something useful. *must be positive*
    thank you Curt y, for giving me some of your time.
    regards Julian

Maybe you are looking for