C3PO question

Hello,
I am very new here. I was following the instructions and example for
adding a customized button to the Groupwise toolbar. And everything went
fine for adding the icon via the "Using Visual Basic .dll" instructions.
It all worked fine. I selected Run-->Start from the Visual Studio menu,
and then restarted Groupwise, and lo and behold, there was my new icon on
the toolbar. However, I need to be able to push this out to all our PCs.
And they will not have visual Studio on them, and we want it automatically
installed. How do I push out this .dll? How do I get the .dll to run from
a command line prompt? Are there any other .dlls that I will have to make
sure are on the PC's as well? Any ideas appreciated.
Thanx, Janet

Adam Bradley wrote:
>
> In my question to get a working C# GDS plugin C3PO I return! When I
> try to use "ClientState.SelectedMessages()" such as with
> ---snip---
> GroupwareTypeLibrary.MessageList _messageList =
> (C3POTypeLibrary.IGWClientState6)GDS3CPOv2.g_C3POM anager.ClientState.SelectedMessages();
>
> ---snip---
> The IDE returns the error "Error 2 'object' does not contain a
> definition for 'SelectedMessages'".
>
> Any ideas?
> Thanks in advance.
> Adam
From now on I'll wait 30 minutes before posting anything - seems the
following works just fine
---snip---
GDS3CPOv2._clientState =
(C3POTypeLibrary.IGWClientState6)GDS3CPOv2.g_C3POM anager.ClientState;
GroupwareTypeLibrary.Message _message =
(GroupwareTypeLibrary.Message)GDS3CPOv2._clientSta te.CommandMessage;
---snip---
Adam

Similar Messages

  • Satellite P300 keeps restarting itself after initial start up screen.

    My Satellite P300 keeps restarting itself after the initial start up screen.
    The initial start up screen with the F2 & F12 options at the bottom appears, the screen then goes black, then a cursor appears in the top left hand corner and flashes a couple of times. Then the laptop shuts down and restarts itself and goes through the same process over and over.
    This is all with the power adaptor plugged in. If unplugged, it will go through the above mentioned process and shut itself down with no restart.
    Any help or advice would be much appreciated.
    Message was edited by: aic-poppy

    F8 is not listed in this meny, just F2 and F12 but F8 should help you to enter Advanced boot options .
    Can you please give an answer to C3POs question?
    Have you made some hardware upgrades in the past (RAM, HDD)?
    Have you changed anything?

  • C3PO - Scanning a Folder & Detecting user's "drag-and-drop" operations

    We are using Novell C3PO to export messages in XML format when the user
    press a button at the GroupWise Client message window, and this was done to
    provide an integration with a ERP software (from a very famous company here
    in Brazil), so the user reads his emails and can click this button and open
    the ERP ORDER SCREEN with all costumer's data filled in, that increases the
    productivity of the Sales Departament.
    REsuming, the main porpouse is to collect information of each email to open
    the Order Screen of the ERP system, without having to type everything again.
    The costumer wanted to go on and get several messages at the same time, that
    was stored on a GroupWise Folder, using a simple redirection rule and this
    was done using Visual Basic (called here "looking process"), that looks for
    messages into a specific folder in the GroupWise Client called "_Send". So,
    convert that messages to XML and then move to another folder called
    "_History".
    Now we can drag many messages at the same time to the folder _Send and then
    they will be converted. It is working very well. The problem is that the
    GroupWise Client computers are becoming slower because of the "looking
    process" (that VB application). We used VB because we could not find a
    process or a feature in C3PO that selects several messages at the same time
    and read them one-by-one.
    QUESTIONS :
    1- Can I have this "Looking Process" using C3PO tools ?
    2- Is there a way to detect a "Drag-and-Drop" event in the GroupWise Client
    with C3PO, so I would not need to scan those folders ?

    Jose Calil Nassur wrote:
    > We are using Novell C3PO to export messages in XML format when the user
    > press a button at the GroupWise Client message window, and this was done to
    > provide an integration with a ERP software (from a very famous company here
    > in Brazil), so the user reads his emails and can click this button and open
    > the ERP ORDER SCREEN with all costumer's data filled in, that increases the
    > productivity of the Sales Departament.
    > REsuming, the main porpouse is to collect information of each email to open
    > the Order Screen of the ERP system, without having to type everything again.
    >
    >
    I've been doing something similar, but rather than creating a new
    message, I've been using custom properties
    on each mail, so as they arrive I add two tags, one with a tagID, and
    the other with metadata. I then write
    searches for each folder returning only the message that are yet to be
    tagged. Nice and efficient, written
    in C#. I've run over my big mailbox (2GB) and the box hardly raises a sweat.
    Sincerely,
    Adam Bradley
    Identity Concepts
    Mobile : +61 419 637 518
    email : adam_j_bradley \at\ identityconcepts.com.au
    irc: #nidm on freenode.net
    Web : http://www.identityconcepts.com.au

  • How to Add C3PO Toolbar Buttons with GroupWise in C#

    Hello
    i try How to Add C3PO Toolbar Buttons with GroupWise in C#. I do all like
    i read here
    http://support.novell.com/techcenter...a20000906.html
    But i can see any result
    i create file with Wizard(witout project)
    Then i add this file to my EXE project
    and add 2 button "Reg C3PO"(RegC3po();) and "Unreg C3PO"(UnRegC3po();)
    and init
    what i do wrong?
    i try find ansver but find only this
    http://newsportal.novell.com/article...sup.gwc3po#925
    what its mean?
    news:SR%Zg.16416$[email protected]:
    about this question
    http://newsportal.novell.com/article...sup.gwc3po#673
    C3POs still don't work in the address book?
    Kirill

    Kirill wrote:
    > Hello and Merry Chritmas :)
    >
    > regsvr32 onlu for DLL. My project create EXE file :(
    >
    > Kirill
    Ups......
    You'll, according to the readme generated by your C3PO Wizard, have to run
    Regasm.exe <your C3PO server>
    That will create the needed regkeys...
    Also, you might have to add the typelib wrapper and assambly to the GAC, bu typing:
    Gacutil -i <your C3PO server>
    Best Regards
    Tommy Mikkelsen
    IT Quality A/S
    Denmark
    Novell Developer Forums SYSOP
    Please Report back any success or failure, That way we all learn
    Sorry, but no support through email
    "I hate bugs".......Tommy Lee Jones, MIB
    Be a GroupWiseR, go http://www.groupwiser.net

  • GW Interface Questions

    We are looking for direction regarding communicating with Groupwise 7 for the purpose of generating 'Tasks', 'Alerts' and E-mail messages to individuals and groups. It has been suggested that communicating with the Groupwise Gateway API or SOAP would allow us to do this. Is there documentation in regards to how to communicate with these interfaces? If so, where would we be able to obtain them.
    We are currently using GroupWise 7.01 on NetWare 6.5. The application or service we are looking to develop will most likely be run on the Linux platform.
    Thank you in advance.
    Robert

    First ofall, there aRE developer forums accessible via nntp.
    Second, "through a GW interface" has no meaning in any language or
    universe. If you mean "can I create tasks programmatically?" Yes, via
    SOAP, object api, or api gateway. I already commented on this.
    I'll mention two other APIs
    C3PO allows CLIENT-SIDE plugins (win32 only) (eg adding a menu to client
    )...TokenAPI allows interactive use of Client (Win32 only) (eg popping
    up the busy search interface)
    now....see below
    >>>
    >>>
    >
    > Thank you for the quick response. Currently we have an admin who does
    > this manually by placing tasks in each individual's task list as a
    > reminder on appeal due dates. We assumed that if it could be done
    > manually, we could automate this function.
    Of course. All things can be automated. At worst, you reverse engineer
    the code nad write your own. But that's not what you mean
    Is there no way to do this
    > through a GroupWise interface?... or should we be developing this
    > outside of GroupWise?
    >
    Already commented. Your statement is poorly and unclearly worded, so I'm
    ignoring it, after having added what I could.
    > Just to clarify, here are our requirements:
    > We need to be able to have a process that can create Tasks on
    > employee's task lists to alert them to various milestones in the
    > appeals process. For instance, 30, 15, and 5 days before letters are
    > due, certain people should receive a task from the system to complete
    > their work.
    >
    You can create a task programmatically. Of course the user has to accept
    the tasks, otherwise they only show in the inbox, but that's eactly like
    currently. SOAP and Object API
    > -Any replies generated to these tasks need to go back to humans (a
    > receipt notification of completion)
    Well, that's nice. You can set the notification options for the task
    before sending. SOAP and object api are again good options.
    The FROM address is not settable. It is set as whoever you log in as.
    Yes you log in as the sender. Either you supply the username, password
    or you use the "Trusted Application API" to access all mailboxes as a
    trusted user. The initial generation of the Trusted Key requires Win32,
    thenceforth Object API or SOAP.
    >
    > -Some recipients of these automated messages will need to be a mailing
    > list: we need to send alert messages to certain members or groups
    >
    Why do I care. Yes yes recipients. Groupwise supports recipients.
    Recipients are good because email travels from one place to another. Of
    course if these are internet users they just get the ical equiv of the
    task, which isn't quite as good.
    Seriously, whatever, programmatically this matters very little. I guess
    I should be happy you were complete.
    > -Different messages will be sent daily, potentially many messages
    > (10-20) sent on a given day.
    >
    Yes, yes. Of course you'll have to write said program and it will some
    how be configured as to this schedule. But that's easy.
    BTW 10-20 isnt many. 20000-100000 is many. GW laughs at your feeble
    10-20 messages (well assuming they aren't 1 million recips each).
    >
    >
    > Thank you again.
    You are welcome. Now, go to developer.novell.com/groupwise . Choose
    Object API (if win32 is acceptable, it's a bit easier, more mature, and
    faster), or SOAP (cross platform, becoming the flagship), download the
    NDK, and write the durn thing. More questions? NNTP the support forums,
    and you'll find the dev forums magically too.
    >
    > Robert
    >
    >

  • C3Po error

    I have a C3PO that works off of the email send button. It seems to work
    fine for all users except one. For that user, it works fine most of the
    time but sometimes GroupWise spell checker returns an error:
    "Error - A valid dialect is required to spell check text"
    Obviously the spell checker works most of the time so I have ruled out
    changing or setting the dialect used. So I think that my c3po and the
    spell checker are both trying to execute at the same time and sometimes
    they don't get along well.
    My question is: Is there a way to wait for the spell checker to finish
    before my code executes? Or is there another way to work around the spell
    checker?
    Any other ideas would be appreciated!
    Thanks,
    Harry

    Having exactly the same problem - help gratefully received!
    > I have a C3PO that works off of the email send button. It seems to work
    > fine for all users except one. For that user, it works fine most of the
    > time but sometimes GroupWise spell checker returns an error:
    >
    > "Error - A valid dialect is required to spell check text"
    >
    > Obviously the spell checker works most of the time so I have ruled out
    > changing or setting the dialect used. So I think that my c3po and the
    > spell checker are both trying to execute at the same time and sometimes
    > they don't get along well.
    >
    > My question is: Is there a way to wait for the spell checker to finish
    > before my code executes? Or is there another way to work around the
    spell
    > checker?
    >
    > Any other ideas would be appreciated!
    > Thanks,
    > Harry

  • Questions on Print Quote report

    Hi,
    I'm fairly new to Oracle Quoting and trying to get familiar with it. I have a few questions and would appreciate if anyone answers them
    1) We have a requirement to customize the Print Quote report. I searched these forums and found that this report can be defined either as a XML Publisher report or an Oracle Reports report depending on a profile option. Can you please let me know what the name of the profile option is?
    2) When I select the 'Print Quote' option from the Actions drop down in the quoting page and click Submit I get the report printed and see the following URL in my browser.
    http://<host>:<port>/dev60cgi/rwcgi60?PROJ03_APPS+report=/proj3/app/appltop/aso/11.5.0/reports/US/ASOPQTEL.rdf+DESTYPE=CACHE+P_TCK_ID=23731428+P_EXECUTABLE=N+P_SHOW_CHARGES=N+P_SHOW_CATG_TOT=N+P_SHOW_PRICE_ADJ=Y+P_SESSION_ID=c-RAuP8LOvdnv30grRzKqUQs:S+P_SHOW_HDR_ATTACH=N+P_SHOW_LINE_ATTACH=N+P_SHOW_HDR_SALESUPP=N+P_SHOW_LN_SALESUPP=N+TOLERANCE=0+DESFORMAT=RTF+DESNAME=Quote.rtf
    Does it mean that the profile in our case is set to call the rdf since it has reference to ASOPQTEL.rdf in the above url?
    3) When you click on submit button do we have something like this in the jsp code: On click call ASOPQTEL.rdf. Is the report called using a concurrent program? I want to know how the report is getting invoked?
    4) If we want to customize the jsp pages can you please let me know the steps involved in making the customizations and testing them.
    Thanks and Appreciate your patience
    -PC

    1) We have a requirement to customize the Print Quote report. I searched these forums and found that this report can be defined either as a XML Publisher report or an Oracle Reports report depending on a profile option. Can you please let me know what the name of the profile option is?
    I think I posted it in one of the threads2) When I select the 'Print Quote' option from the Actions drop down in the quoting page and click Submit I get the report printed and see the following URL in my browser.
    http://<host>:<port>/dev60cgi/rwcgi60?PROJ03_APPS+report=/proj3/app/appltop/aso/11.5.0/reports/US/ASOPQTEL.rdf+DESTYPE=CACHE+P_TCK_ID=23731428+P_EXECUTABLE=N+P_SHOW_CHARGES=N+P_SHOW_CATG_TOT=N+P_SHOW_PRICE_ADJ=Y+P_SESSION_ID=c-RAuP8LOvdnv30grRzKqUQs:S+P_SHOW_HDR_ATTACH=N+P_SHOW_LINE_ATTACH=N+P_SHOW_HDR_SALESUPP=N+P_SHOW_LN_SALESUPP=N+TOLERANCE=0+DESFORMAT=RTF+DESNAME=Quote.rtf
    Does it mean that the profile in our case is set to call the rdf since it has reference to ASOPQTEL.rdf in the above url?
    Yes, your understanding is correct.3) When you click on submit button do we have something like this in the jsp code: On click call ASOPQTEL.rdf. Is the report called using a concurrent program? I want to know how the report is getting invoked?
    No, there is no conc program getting called, you can directly call a report in a browser window, Oracle reports server will execute the report and send the HTTP response to the browser.4) If we want to customize the jsp pages can you please let me know the steps involved in making the customizations and testing them.
    This is detailed in many threads.Thanks
    Tapash

  • Satellite P300D-10v - Question about warranty

    HI EVERYBODY
    I have these overheating problems with my laptop Satellite P300D-10v.
    I did everything I could do to fix it without any success..
    I get the latest update of the bios from Toshiba. I cleaned my lap with compressed air first and then disassembled it all and cleaned it better.(it was really clean insight though...)
    BUT unfortunately the problem still exists...
    So i made a research on the internet and I found out that most of Toshiba owners have the same exactly problem with their laptop.
    Well i guess this is a Toshiba bug for many years now.
    Its a really nice lap, cool sound (the best in laptop ever) BUT......
    So I wanted to make a question. As i am still under warranty, can i return this laptop and get my money back or change it with a different one????
    If any body knows PLS let me know.
    chears
    Thanks in advance

    Hi
    I have already found you other threads.
    Regarding the warranty question;
    If there is something wrong with the hardware then the ASP in your country should be able to help you.
    The warranty should cover every reparation or replacement.
    But I read that you have disasembled the laptop at your own hand... hmmm if you have disasembled the notebook then your warrany is not valid anymore :(
    I think this should be clear for you that you can lose the warrany if you disasemble the laptop!
    By the way: you have to speak with the notebook dealer where you have purchased this notebook if you want to return the notebook
    The Toshiba ASP can repair and fix the notebook but you will not get money from ASP.
    Greets

  • Question regarding NULL and forms

    Hi all, i have a survey that im working on that will be sent via email.
    I'm having an issue though. if i have a multiple choice question, and the user only selects one of the choices, all the unselected choices return as NULL. is there a way i can filter out anytihng that says "NULL" so it only shows the selected options?
    thanks.
    here is the page that retrieves all the data. thanks
    <body>
    <p>1) Is this your first visit to xxxxxxx? <b><%=request.getParameter("stepone") %></b>
    </p>
    <p> </p>
    <p>2) How did You Learn About xxxxxxx?</p>
    <p><b><%=request.getParameter("steptwoOne") %></b>
      <br>
        <b><%=request.getParameter("steptwoTwo") %></b>
      <br>
        <b><%=request.getParameter("steptwoThree") %></b>
      <br>
        <b><%=request.getParameter("steptwoFour") %></b>
      <br>
        <b><%=request.getParameter("steptwoOther") %></b>
    </p>
    <p> </p>
    <p>3) What was your main reason for visiting xxxxx?</p>
    <p><b><%=request.getParameter("stepthreeOne") %></b>
        <br>
          <b><%=request.getParameter("stepthreeTwo") %></b>
        <br>
          <b><%=request.getParameter("stepthreeThree") %></b>
        <br>
          <b><%=request.getParameter("stepthreeFour") %></b>
        <br>
          <b><%=request.getParameter("stepthreeOther") %></b>
    </p>
    <p>4) did you find the information you were looking for on this site?</p>
    <p><b><%=request.getParameter("stepfour") %>
    <br>
    <b><%=request.getParameter("stepfourOther") %></b>
    </b></p>
    <p>5) Do you plan on using this website in the future?</p>
    <p><b><%=request.getParameter("stepfive") %></b></p>
    <p>6) What is your gender</p>
    <p><b><%=request.getParameter("stepsix") %></b></p>
    <p>7) What is your age group</p>
    <p><b><%=request.getParameter("stepseven") %></b></p>
    8) Would you like to take a moment and tell us how we can improve your experience on xxxxxxxxxx?
    <p><b><%=request.getParameter("stepeightFeedback") %></b></p>

    i was messing around and came up with this. it doesnt remove the null, but if it is null it adds ABC beside it. so i think i might be getting close. i just need to figure out how to replace the null.
    code]
    <b><%=request.getParameter("steptwoFour") %></b>
         <% if (request.getParameter("steptwoFour") == null ) {
         %>
         <% out.print("abc"); %>
         <% }
         %>

  • Anyone know how to remove Overdrive books from my iphone that have been transferred from my computer? They do not show up on itunes. I see a lot of answers to this question but they all are based on being able to see the books in iTunes.

    How do I remove Overdrive books from the library that were downloaded onto my computer then transferred to my iphone? The problem is that they do not show up in iTunes.
    I see this question asked a lot when I google, but they always give answers that assumes you can find the books in iTunes either under the books tab, or the audio books tab or in the music. They do not show up anywhere for me. They do not remove from the app like the ones I downloaded directly onto my iphone.the related archived article does not answer it either.  I even asked a guy working at an apple store and he could not help either.   Anybody...?
    Thanks!

    there is an app called daisydisk on mac app store which will help you see exactly where the memory is focused and consumed try using that app and see which folders are using more memory

  • Basic question

    Hello, i have a basic question. if i have defined 2 fields in a cube or a dso:
    Name Quantity
    and from the external flat file i get some characters for my quantity field. would my load fail?  for standard dso and for write optimized?
    NOTE: quantity field is a keyfigure defined as numeric.
    and the load coming in has "VIKPATEL" for Quantity field and not numbers.
    thanks

    Hi Vik,
    Yes, the load will fail.
    May be you coud first load this data into BW (into PSA) and set both fields as characters fields. Then you can create DSO, do transformation from this PSA to the DSO, and put your logic as to what do you want to do with those Quantity that is not number (e.g. convert to 0, or 'Not assgined', etc).
    You can use transfer rule, or a clean up ABAP code in the start routine.
    Hope this helps.

  • Mid 2010 15" i5 Battery Calibration Questions

    Hi, I have a mid 2010 15" MacBook Pro 2.4GHz i5.
    Question 1: I didn't calibrate my battery when I first got my MacBook Pro (it didn't say in the manual that I had to). I've had it for about a month and am doing a calibration today, is that okay? I hope I haven't damaged my battery? The calibration is only to help the battery meter provide an accurate reading of how much life it has remaining, right?
    Question 2: After reading Apple's calibration guide, I decided to set the MacBook Pro to never go to sleep (in Energy Saver System Preference) and leave it on overnight so it would run out of power and go to sleep, then I'd leave it in that state for at least 5 hours before charging it. When I woke up, the light on the front wasn't illuminated. It usually pulsates when in Sleep. Expectedly, it wouldn't wake when pressing buttons on the keyboard. So, what's happened? Is this Safe Sleep? I didn't see any "Your Mac is on reserve battery and will shut down" dialogues or anything similar, as I was asleep! I've left it in this state while I'm at work and will charge it this afternoon. Was my described method okay for calibration or should I have done something different?
    Question 3: Does it matter how quickly you drain your battery when doing a calibration? i.e is it okay to drain it quickly (by running HD video, Photo Booth with effects etc) or slowly (by leaving it idle or running light apps)?
    Thanks.
    Message was edited by: Fresh J

    Fresh J:
    A1. You're fine calibrating the battery now. You might have gotten more accurate readings during the first month if you'd done it sooner, but no harm has been done.
    A2. Your machine has NOT shut down; it has done exactly what it was supposed to do. When the power became critically low, it first wrote the contents of RAM to the hard drive, then went to sleep. When the battery was completely drained some time later, the MBP went into hibernation and the slepp light stopped pulsing and turned off. In that state the machine was using no power at all, but the contents of your RAM were still saved. Once the AC adapter was connected, a press of the power button would cause those contents to be reloaded, and the machine would pick up again exactly where you left off. It is not necessary to wait for the battery to be fully charged before using the machine on AC power, but do leave the AC adapter connected for at least two hours after the battery is fully charged. Nothing that you say you've done was wrong, and nothing that you say has happened was wrong.
    A3. No, it does not matter.

  • Jabber/WebEx Connect SSO Questions

    I've got a few questions around exactly what needs to be done to get SAML working for our Connect accounts to successfully authenticate from Jabber for Windows, Mac, iPhone, and Android.
    We have both a Meeting Center and Connect account under WebEx using Loose Coupled Integration. Just this past week I enabled SAML for our Meeting Center accounts which went off without a hitch with the exception of Meeting Center integration with Jabber, which is now broken with a message about SSO enabled Meeting Sites not being supported (I think this would maybe be fixed if we had Tight Coupled Integration with our two account?).
    Anyway, my questions are...
    For Windows, I understand all clients will need to be reinstalled with the MSI argument for the SSO_ORG_DOMAIN switch I've read about, is that correct? Are there any other switches needed for the reinstall? 
    How will this work with the Mac and mobile clients? There's obviously no command line options to specify for the installations here, will they just know to kick over to my IdP for authentication once they see an email address that falls under an org with SSO enabled? If so, why does the Windows client need to be completely reinstalled and not just know to find the IdP from the Cloud Connect service like Meeting Center does with the Productivity Tools?
    We're just doing this for our Connect Web IM accounts, not attempting any sort of SSO with the phone accounts/UC integration yet.
    Any ideas on getting the Meeting Center integration into Jabber working again?

    I'd suggest posting your question over on the Jabber Pilot forum, as this forum is specific to Jabber Guest questions:
    https://supportforums.cisco.com/community/4551/jabber-pilot-support
    -jim

  • My iPad wont let me download apps bc security questions, but when I try to make them it freezes

    Every time I try to download an app it tells me I need to update my security questions, but once I click to make the questions the box goes white. So I'm not sure how to fix it

    The new questions show on your account on http://appleid.apple.com ? If they do then try logging out and back into your account on your phone (assuming that is where you are trying to purchase from) and see if the new questions then show on it.

  • ASA VPN QUESTION

    Hi All
    The question is pretty simple. I can successfully connect  to my ASA 5505  firewall via cisco vpn client 64 bit , i can ping any ip  address on the LAN behind ASA but none of the LAN computers can see or  ping the IP Address which is assigned to my vpn client from the ASA VPN  Pool.
    The LAN behind ASA is 192.168.0.0 and the VPN Pool for the cisco vpn client is 192.168.30.0
    I would appreciate some help pls
    Here is the config:
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password J7NxNd4NtVydfOsB encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.0.11 EXCHANGE
    name x.x.x.x WAN
    name 192.168.30.0 VPN_POOL2
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address WAN 255.255.255.252
    interface Ethernet0/0
    switchport access vlan 2
    <--- More --->
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa724-k8.bin
    ftp mode passive
    clock timezone EEST 2
    clock summer-time EEDT recurring last Sun Mar 3:00 last Sun Oct 4:00
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list nk-acl extended permit tcp any interface outside eq smtp
    access-list nk-acl extended permit tcp any interface outside eq https
    access-list customerVPN_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 VPN_POOL2 255.255.255.0
    access-list inside_access_in extended permit ip any any
    access-list VPN_NAT extended permit ip VPN_POOL2 255.255.255.0 192.168.0.0 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool VPN_POOL2 192.168.30.10-192.168.30.90 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (inside) 10 interface
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    nat (outside) 10 access-list VPN_NAT outside
    static (inside,outside) tcp interface smtp EXCHANGE smtp netmask 255.255.255.255
    static (inside,outside) tcp interface https EXCHANGE https netmask 255.255.255.255
    access-group inside_access_in in interface inside
    access-group nk-acl in interface outside
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    aaa authorization command LOCAL
    http server enable
    http 192.168.0.0 255.255.255.0 inside
    snmp-server host inside 192.168.0.16 community public
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 20 set pfs group1
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp nat-traversal  20
    telnet 192.168.0.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcp-client client-id interface outside
    dhcpd dns 217.27.32.196
    dhcpd address 192.168.0.100-192.168.0.200 inside
    dhcpd dns 192.168.0.10 interface inside
    dhcpd enable inside
    group-policy DfltGrpPolicy attributes
    banner none
    wins-server none
    dns-server none
    dhcp-network-scope none
    vpn-access-hours none
    vpn-simultaneous-logins 3
    vpn-idle-timeout 30
    vpn-session-timeout none
    vpn-filter none
    vpn-tunnel-protocol IPSec l2tp-ipsec
    password-storage disable
    ip-comp disable
    re-xauth disable
    group-lock none
    pfs disable
    ipsec-udp disable
    ipsec-udp-port 10000
    split-tunnel-policy tunnelall
    split-tunnel-network-list none
    default-domain none
    split-dns none
    intercept-dhcp 255.255.255.255 disable
    secure-unit-authentication disable
    user-authentication disable
    user-authentication-idle-timeout 30
    ip-phone-bypass disable
    leap-bypass disable
    nem disable
    backup-servers keep-client-config
    msie-proxy server none
    msie-proxy method no-modify
    msie-proxy except-list none
    msie-proxy local-bypass disable
    nac disable
    nac-sq-period 300
    nac-reval-period 36000
    nac-default-acl none
    address-pools none
    smartcard-removal-disconnect enable
    client-firewall none
    client-access-rule none
    webvpn
      functions url-entry
      html-content-filter none
      homepage none
      keep-alive-ignore 4
      http-comp gzip
      filter none
      url-list none
      customization value DfltCustomization
      port-forward none
      port-forward-name value Application Access
      sso-server none
      svc none
      svc keep-installer installed
      svc keepalive none
      svc rekey time none
      svc rekey method none
      svc dpd-interval client none
      svc dpd-interval gateway none
      svc compression deflate
    group-policy customerVPN internal
    group-policy customerVPN attributes
    dns-server value 192.168.0.10
    vpn-tunnel-protocol IPSec
    password-storage enable
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value customerVPN_splitTunnelAcl
    default-domain value customer.local
    username xxx password 8SYsAcRU4s6DpQP1 encrypted privilege 0
    username xxx attributes
    vpn-group-policy TUNNEL1
    username xxx password C6M4Xy7t0VOLU3bS encrypted privilege 0
    username xxx attributes
    vpn-group-policy PAPAGROUP
    username xxx password RU2zcsRqQAwCkglQ encrypted privilege 0
    username xxx attributes
    vpn-group-policy customerVPN
    username xxx password zfP8z5lE6WK/sSjY encrypted privilege 15
    tunnel-group customerVPN type ipsec-ra
    tunnel-group customerVPN general-attributes
    address-pool VPN_POOL2
    default-group-policy customerVPN
    tunnel-group customerVPN ipsec-attributes
    pre-shared-key *
    tunnel-group-map default-group DefaultL2LGroup
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:a4dfbb82008f78756fe4c7d029871ec1
    : end
    ciscoasa#                           

    Well lots of new features have been hinted at for ASA 9.2 but I've not seen anything as far as an Engineering Commit or Customer Commit for that feature.
    Site-site VPN in multiple context mode was added in 9.0(1) and I have customers have been asking for the remote access features as well.
    I will remember to ask about that at Cisco Live next month.

Maybe you are looking for

  • Making a sound clip sync with rest of movie.

    So I solved this problem and realized I posted it under AS3 and it should have been here.  So I figured it may help somone.  All I did was change the setting to "Stream" under the properties panel for each sound clip! Making sound sync with my contro

  • Using Functions in tables

    I am trying to create a flowing table for a mortgage collection. Table labeled in 6 columns; Pay Date, Amount Paid, Interest, Principal, Balance Due, Interest paid Thru. The functions used are as follows, Interest = Balance due*6%/12 Principal = Amou

  • How do I import/export bookmarks in firefox 4?

    I am trying to copy bookmarks from an older computer to a new computer and I can't find import/export as in versions of Firefox. I am currently using version 4.

  • Pricing table missing

    hi experts, when any purchase order is created in development server the system is giving error message :" condition table missing:Acess JST1 60(pricing taxes) Can any one tell me what is the reason behind that? how to solve the error? Sudipto

  • Group by characteristic

    Hi all!! I have requeriment, I have the char 0DEBITOR, and I need to group this for three diferentes areas that the client call nacional, filial and internacional; this group not exist in R/3; I think that can be created in hiercharchy, but maybe can