Can I connect two switches to a server?

We share an office with another company but we currently have separate servers and networks.
I'm looking into the possibility of us sharing their server.
The thing is we both have our own switches and and I want to avoid any rewiring of the network. Will I be able to use two switches?
It's a 2x 2.8 GHz quad core intel xeon (with dual ethernet). So is it just a matter of connecting both switches to the server and configuring them in some way?

Hi Christiaan,
I end up doing this quite often. You have a few options, the simplest is below...
How many users and devices that require network connections does each company have? If it's under 254 which it sounds like it is and your happy to have the users on the same network, sharing the same ISP. Then the easiest option is going to be your company sharing their network. You'd save a bit of money on your internet connection which could be used to increase the bandwidth on the other companies line if needed.
You would do following. Make sure all devices that need a fixed IP address such as printers/mfds'/switches/WiFI/phone system (if applicable) are changed to a fixed IP address with the relevant subnet mask, dns and gateway from the other companies network. You'd obviously need to get the relevant numbers from their IT guy.
Then you could use your switch as extra capacity on their network by linking it with their switch. Obviously you'd want to use the fastest possible connection between the switches or look to buying something new with more ports. If you both have something like the HP 1810G ProCurve or a compatible switch you can buy two fibre transceivers and connect them with a fibre cable, this will free up more ports for users on the switch or simply connect them via an ethernet cable. On the 1800 series you can use LACP which allows you to use up to 4 ethernet ports to improve the bandwidth thus giving you a 4gigabit connection to their network. Depending on how much traffic there is going to be you might want to skip that as there might be no need.
Then it's just a case of creating your users on their server and creating an area for your company that only you have the access rights to and creating a shared area inter-company area if you want to easily ping them over files.
What do you both use for email? Are you going to look to share a server for it?
Hope that helps
Beatle

Similar Messages

  • Networking Best Practices - Connecting Two Switches

    Connecting two switches together is an easy task, which makes it so frustrating when it doesn’t work. Here we will outline a basic scenario of connecting two switches and achieving connectivity. In these scenarios we will be using commands and settings that will work for most modern PowerConnect switches. However this does not cover all possible scenarios and the commands may differ slightly from switch to switch.
    For instance, in most cases you can use General or Trunk mode when connecting two switches. However, on the PowerConnect 62xx series switches, you must use General mode if you want to allow management traffic onto the switch over the PVID.  If you use Trunk mode, you will not have the default VLAN on those ports.  The ports will only allow tagged traffic.
    For more details on the difference between Access, General, and Trunk modes, follow this link.
    http://en.community.dell.com/support-forums/network-switches/f/866/p/19445142/20089157.aspx#20089157
    It is always a good idea to have the user and CLI guide for your switch, to reference any possible changes in command syntax.
    http://support.dell.com/support/edocs/network/
    Layer 2
    Layer 2 switches operate at the data link layer of the OSI model. Layer 2 is responsible for error checking and transmitting data across the physical media. MAC addressing sources and destination protocols are layer 2 protocols. Layer 2 switches use the MAC address of data packets to determine where those packets should go. It learns the MAC addresses of all devices and creates a segment/forwarding table.
    When a switch receives a frame with a destination address that isn't in its forwarding table, the switch forwards the frame to all other ports. If the destination machine responds to the server, the switch will listen to the reply and learn which port the destination machine is attached to. It then adds that MAC address to the forwarding table.
    The Dell PowerConnect Layer 2 switches have ports that all operate in VLAN 1 by default. If it is acceptable to have all traffic on the same broadcast domain, then you can simply leave the default alone, connect the two switches and traffic will flow.
     If you do not want all traffic on the same broadcast domain, then we need to look at adding additional broadcast domains through the use of VLANs.
     We will use 3 VLANs for the following scenario.
    VLAN 1=Management
    VLAN 2=Client
    VLAN 3=Server
    To create these VLANs we do the following commands (VLAN 1 is already created by default)
    console(config)# vlan database
    console(config-vlan)# VLAN 2
    console(config-vlan)# VLAN 3
    console(config-vlan)# exit
    We can then name the VLANs to help keep things organized.
    console(config)# interface vlan 2
    console(config-vlan)# name Client
    console(config-vlan)# exit
    console(config)# interface vlan 3
    console(config-vlan)# name Server
    console(config-vlan)# exit
    Once we have the VLANs created we can place a device in that VLAN by placing the port it plugs into, in access mode for the specific VLAN.
    So we have a workstation on port e2 we want to be placed in VLAN 2, we would issue the following commands.
    console(config)# interface ethernet 1/e2
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 2
    console(config-if)# exit
    The next port plugs into a server on port e3 we want on VLAN 3, we would issue these commands.
    console(config)# interface ethernet 1/e3
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 3
    console(config-if)# exit
    For the ports connecting the two switches together, we place the ports in trunk mode and specify the native VLAN and allowed VLANs.
    For the port e1 that connect the two switches to each other would be configured like this.
    console(config)# interface ethernet 1/e1
    console(config-if)# switchport mode general
    console(config-if)# switchport general allowed vlan add 2,3 tagged
    console(config-if)# switchport general pvid 1
    console(config-if)# exit
    Once these VLANs and port settings are made on both switches. A server connected to switch A on VLAN 3 should be able to communicate with another Server connected to switch B that is also in VLAN 3.  Without the use of a router the devices in VLAN 3 will not be able to communicate with devices that are outside of their broadcast domain (i.e. VLAN 2 devices could not reach VLAN 3 devices)
    Layer 3 + Layer 2
     Until recently, routers were the only devices capable of layer 3 protocols. Switches capable of routing are now available and in widespread use. In most cases we will connect our layer 2 switches to a Layer 3 capable switch to perform our routing for us.
     On the layer 3 switches we will use the same VLANs and setup that we did with the layer 2 switches.  Then we will add to the configuration.
     We can assign an IP address to each switch with the following command.
    Switch A
    console(config)#ip address 172.16.1.1 255.255.255.0
    Switch B
    console(config)#ip address 172.16.2.1 255.255.255.0
    Then we will enable routing only on Switch A
    console(config)# ip routing
    Switch A we assign an IP address to VLAN 2 and enabling routing on the VLAN.
    console(config)# interface vlan 2
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.20.1 255.255.255.0
    console(config-if-vlan2)# exit
    Switch A we assign an IP address to VLAN 3 and enabling routing on the VLAN.
    console(config)# interface vlan 3
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.30.1 255.255.255.0
    console(config-if-vlan2)# exit
    On both switch A and switch B we will keep things simple and use interface 1/e1 for the connection between each switch. Setting both switches 1/e1 to general mode, allowing the additional VLAN 2,3, and keeping the PVID of 1.
    console(config)# interface ethernet 1/e1
    console(config-if)# switchport mode general
    console(config-if)# switchport general allowed vlan add 2,3 tagged
    console(config-if)# switchport general pvid 1
    console(config-if)# exit
    We will have one client computer connect to switch A on port 1/e2 and one client connect to switch B on port 1/e2. These ports will be in access mode for VLAN 2, and the config should look like this on both switches.
    console(config)# interface ethernet 1/e2
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 2
    console(config-if)# exit
    We will have another client computer connect to switch A on port 1/e3 and one client connect to switch B on port 1/e3. These ports will be in access mode for VLAN 3, and the config should look like this on both switches.
    console(config)# interface ethernet 1/e3
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 3
    console(config-if)# exit
    On Clients connected to Switch A we will assign an IP address and gateway based on the VLAN they are in access mode for.
    Client connected to access port for VLAN 2.
    IP Address:172.16.20.11
    Default Gateway:172.16.20.1
    Client connected to access port for VLAN 3.
    IP Address:172.16.30.11
    Default Gateway:172.16.30.1
    On Clients connected to Switch B we will assign an IP address and gateway based on the VLAN they are in access mode for.
    Client connected to access port for VLAN 2.
    IP Address:172.16.20.12
    Default Gateway:172.16.20.1
    Client connected to access port for VLAN 3.
    IP Address:172.16.30.12
    Default Gateway:172.16.30.1
    External Connection
    At some point we may want traffic to have an external connection. To do this we can create a new VLAN for our point to point connection from Switch A to our router. We will use VLAN 7 for this and assign an IP address.
    console(config)# vlan database
    console(config-vlan)# VLAN 7
    console(config-vlan)# exit
    console(config)# interface vlan 7
    console(config-vlan)# name WAN
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 10.10.10.2 255.255.255.0
    console(config-if-vlan2)# exit
    On our router we will assign an IP address of 10.10.10.1
    Then place the port connecting the switch and router into access mode for VLAN 7.  In this case we use port e4.
     console(config)# interface ethernet 1/e4
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 7
    console(config-if)# exit
    We will then need to put in a default route with the next hop as the router IP address.  This allows the switch to know where to route traffic not destined for VLANs 2, 3, or 7.
    console(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
    Next on the router we’ll need to add a route back so the router knows about the networks attached to switch A.  Generally adding a static route on most routers is done with the following command: 
    ip route {Network} {Wildcard Mask} {Next Hop-IP}
    In our case here are the 2 static routes we could use.
    Ip route 172.16.20.0 0.0.0.255 10.10.10.2
    Ip route 172.16.30.0 0.0.0.255 10.10.10.2
    The routing that we enabled on Switch A will enable traffic from the other VLANs to traverse over port 1/e4 to the router, connecting us to external traffic. The routes we added to the router allow the traffic to flow back to the switch over port 1/e4.
    Layer 3 + Layer 3
    In some situations we have two switches, each setup to route for its own broadcast domain, which we want to connect together. In this situation we no longer have a need to use Trunk or General mode between the switches. Instead we can create a common VLAN that will be used for the connection between the two switches.
    To create this VLAN we will run the following commands on both switch A and B
    console(config)# vlan database
    console(config-vlan)# vlan 6
    console(config-vlan)# exit
    console(config)# interface vlan 6
    console(config-vlan)# name Connection
    console(config-vlan)# exit
    On switch A we assign an IP address to VLAN 6 and enable routing on the VLAN.
    console(config)# interface vlan 6
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.60.1 255.255.255.0
    console(config-if-vlan2)# exit
    On switch B we assign an IP address to VLAN 6 and enable routing on the VLAN.
    console(config)# interface vlan 6
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.60.2 255.255.255.0
    console(config-if-vlan2)# exit
    On both switch A and B we place the connecting ports into Access mode for VLAN 6.
    console(config)# interface ethernet 1/e1
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 6
    console(config-if)# exit
    We then need to make some changes to switch B now that it is layer 3 and not layer 2 and has its own broadcast domain.
    We will enable routing on Switch B
    console(config)# ip routing
    What used to be VLAN 2 and 3 will now be VLAN 4 and 5 for our separate broadcast domains.
    Switch B we assign an IP address to VLAN 4 and enabling routing on the VLAN.
    console(config)# interface vlan 4
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.40.1 255.255.255.0
    console(config-if-vlan2)# exit
    Switch B we assign an IP address to VLAN 5 and enabling routing on the VLAN.
    console(config)# interface vlan 5
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.50.1 255.255.255.0
    console(config-if-vlan2)# exit
    On Clients connected to Switch B we will assign an IP address and gateway based on the VLAN they are in access mode for.
    Client connected to access port for VLAN 4.
    IP Address:172.16.40.11
    Default Gateway:172.16.40.1
    Client connected to access port for VLAN 5.
    IP Address:172.16.50.11
    Default Gateway:172.16.50.1
    The end result should look like this.
     Troubleshooting
    If we are having issues with connectivity, we may need to place some static routes in place to help traffic to the next hop in the network.
    On switch A we configure a static route to help traffic to the next hop in the network, which is the router.
    console(config)# ip route 0.0.0.0 0.0.0.0 10.10.10.1
    The external router will also need a path defined back to all networks/VLANs.
    To check the status of a port we can use the command. Show interfaces detail, this will help us see the port status. For example to check the status of port 48, we would run this command.
    console# show interfaces detail ethernet 1/g48
     To check routing paths:
    console# show ip route
    The IP address of the network for each VLAN should be listed as C – Connected. Then also a path or default route to your upstream router.
    We can use basic ping commands from a client to help test where connectivity is dropping off at. By doing this we can narrow down where in the network to start troubleshooting.
    -Ping from client to default gateway, being the VLAN the client is in access mode for. If this fails then we may need to double check our client settings making sure the proper IP and gateway are being used.
    -Ping from client to the ip address of the switch the client plugs into. If this fails we may not have VLAN routing enabled on the VLAN the client is in.
    -Ping from client to another client on same VLAN, same switch. If this fails we need to check on client settings, IP address and gateway.
    -ping from client to another client on different VLAN, same switch. If this fails we need to double check the VLAN routing commands are in place.
    -ping from client to the ip address of the next switch in the network. If this fails then check Trunk port configuration from switch to switch, ensuring the VLAN is added to the Trunk port.
    -ping from client to another client on same VLAN, different switch. If this fails, check Trunk port settings.
    -ping from client to another client on different VLAN, different switch. If this fails then check trunk settings and VLAN routing configuration.

    Derek,
    I tried to draw my prefered setup for this network configuration.
    I would create a Team with the two 1 GBit NICs and use it for Domain, DNS, Backup and any SystemCenter Agents.
    I would also Team the two 10 GBit NICs and than assign it to a Hyper-V Switch for the VMs. In Windows Server 2012 it is posible to create vNICs for the Management OS that use this Hyper-V Switch (Converged Network Design). I would create two vNICs SMB1
    and SMB2 to use them for Cluster and Livemigration traffic with SMB Multichannel. If your storage system supports SMB Multichannel you can also use both as storage NICs (but this depends wich vendor you have).
    Hope this helps.
    Grüße/Regards Carsten Rachfahl | MVP Virtual Machine | MCT | MCITP | MCSA | CCA | Husband and Papa |
    www.hyper-v-server.de | First German Gold Virtualisation Kompetenz Partner ---- If my answer is helpful please mark it as answer or press the green arrow.

  • Can I connect two apple tv on same network and same apple ID at a time ?

    Can I connect two apple tv on same network and same apple ID at a time ?

    Welcome to the  Discussion Forums.
    Yes you can do all that without needing to keep plugging things in and out. You will still need to manually turn on the receiver and turn down the volume from the tv though.

  • Can I connect two monitors to a Mac Mini?

    Can I connect two Monitors to a mac mini

    Yes, but how depends on what model of Mini and what kind of monitors.  Early models only had one monitor port.  Later models had a Mini-DVI port and a Mini-Displayport.  Current models have a Mini-Displayport and a HDMI port.  The Mini-DVI and Mini-Displayport can attach VGA or DVI monitors, whereas the HDMI port can't use VGA monitors.
    Beyond that, you can get Matrox's DualHead2Go or a USB->VGA or USB->DVI adapter.  The Matrox product is a bit expensive and the USB adapters are a bit to slow for games and such.  So, again, the answer is "yes", but with limitations

  • HT5219 how can I connect two thunderbolt monitors to my macmini in windows 8 and bootcamp? Works fine in OSX

    how can I connect two thunderbolt monitors to my macmini in windows 8 and bootcamp? Works fine in OSX

    Did you try to hook up both monitors to the Belkin adaptor? Trying will determine if your monitor has a bad input port. See if the Belkin adaptor is the problem. I have never used that specific adaptor, but I have always had luck with the Dr. Bott's DVI for ADC adaptor. Best of luck.
    www.drbott.com

  • I can't connect two shapes in Pages for IPAD, why?

    I was writing a document  in Pages for IPAD and i try to make an organichart, but i can't connect two shapes (two squares) with the "connecting line", i try many times in different ways, but never work. So i decide to try to connect two shape in Keynote for IPAD and in work perfectly.
    What i'm doing wrong in Pages for IPAD?
    thanks in advance
    Juan Pablo

    I found the option that you mention!, and it works!! thank you very much!
    BUT..... i have to change it manually for each object, either when insert the object or copy/paste the object!
    is there any way to set it before I insert and object?
    thanks again
    Juan Pablo.

  • Can i connect two monitors to my mac book pro with HDMI?

    can i connect two monitors to my mac book pro with HDMI?

    I retract my previous "No." If you can live with limited performance (slow refresh/choppy action video/no gaming) on the second external monitor, you could use a USB video adapter and a DVI-HDMI adapter to connect it to a USB port on your computer.
    http://eshop.macsales.com/item/NewerTech/VIDU2DVIA/
    Just a note about the system information that appears below your post: iOS 4.3.3 does not run on Macs, only on iPods, iPads and iPhones. When you're posting about your MBP, it would be more useful to those responding to know which version of Mac OS X you're running. Doesn't matter for purposes of this post, but something to remember for future posts.

  • Can't connect to the modem's server.

    Hi guys, I have a major problem.
    When ever I connect to the internet with my modem, it works. But, when I connect to internet with my router and modem, I can't connect. But I have solved my problem by resetting both, my wireless router and modem. Then after I reconfigure my wireless router all I need to do is to log into my modem's server. But I can't connect to the modem's server. I tired logging in with "admin" (being the password) but I still can't connect to it.
    I am using: Verizon Broadband Network
                     Ultra RangePlus Wireless-N Broadband Router model: WRT160N
                     Westell modem model 6100
    What is the problem? Has anyone experienced this problem before?
    Message Edited by machg on 04-11-2009 07:10 PM
    Solved!
    Go to Solution.

    You will not be able to log  into the modem as long as the router is plugged in
    You must configure the modem first to bridge mode,then plug in the router and log into it
       1.)unplug router and have only the modem in
           go to 192.168.1.1 enter
          that will take you into the verizon modem/ if you have reset the modem then your user is; admin
                                                                                                                         your password is ; password
         once you lopg into that it will ask you to change the username/password
          just type in ADMIN in all 3 blanks
    now you are logged into the modem;;;;;;go to network at the top,then network connections on the left,broadband connection ,you will then put your protocol on bridge/routed bridge,
    now go to wireless settings at the top and make sure wireless is turned on
    you have the option to set up a security key on basic security settings
    once your modem  resets then plug in your router,you are now in bridge mode and the modems connection has moved to your router.  you must restart modem and computer for everything to take effect....
    also make sure and refresh your network list on your laptop
    Hope this works 

  • Can I connect two macs with thunder bolt ?

    can i connect two macs with thunderbolt like I do with firewire and IP? I don't want to transfer files by using the control "T" at startup . I want use VNC to control one mac from the other and use thunderbolt vs ethernet.
    thanks for any help

    You can connect the two.  Whether you can use VNC, I have no idea.
    http://store.apple.com/us/product/MC913ZM/A
    Ciao.

  • Can I connect my application to mssql server

    Can I connect my application to mssql server ?

    nioe wrote:
    Something more specific, my search on Google does not appear something abuot mssql
    Perhaps you could help the process along by being a little more specific. Is this an in-house application. Will it ever leave your local network? Or does it need to run over the internet? Regardless, the best option will likely be some type of REST web service that any client can use.

  • Can't connect to the window application server.

    I have installed the Sun Secure Global Desktop Software 4.2,
    the client can connect to the unix application server but can't connect to the window applicaiont server.
    What can i do?
    Thank you.

    Hi.
    Are you sure you're using a Windows server which support Terminal Services? In other words, try (on the Windows server) by escaping to the CMD prompt and issue the
    netstat -n
    command as to see if port 3389 is listed in LISTEN state.
    Best,
    Rob

  • Can I connect two firewire devices?

    Ideally, I need two firewire devices running at the same time: One camera to capture footage and one firewire external hard disk for the media files (about 160 GB).
    a) I've been told that I need a firewire external disc, because a USB hard disk would slow down the editing in Final Cut. Is this true?
    b) If so, can I connect two firewire devices to my MBP (74.53 GB internal hard disk), which has only one 400 Firewire port?

    1. Yes, FireWire is faster than USB. However, it would be better to edit on your main hard drive. Use the external drive just for storage and backup.
    2. You can chain up to 255 FireWire devices provided the total power requirements did not exceed the port's capabilities. A single FireWire drive and a camera shouldn't be a problem. However, you should know that some FireWire cameras may not play well with other FireWire devices. If you find apparent problems when both are connected to the port, then you may need to use each separately. In this case you may need to put the hard drive on a USB port while the camera is connected to the FireWire port unless the camera also supports transfers on USB 2.0.

  • Can I connect two computers to one device?

    Can I connect two computers to one device? I am trying to have them control different aspects of the experiment that I'm running.

    That depends upon the device. If it's GPIB, you could
    use the E-NET card to convert it to LAN. That would
    allow control by many computers. The only problem with
    that might be sychronization. That is, Computer 1 does
    its setup. Then Computer 2 does a reset. Compuer 1's
    setup is now gone.
    As another poster suggested, you could always network
    between the two computers.
    [email protected]

  • Can I connect two USB external hdds at once?

    Can I connect two external hdds by USB at once and then transfer between the two?

    Yes. The practical limit is 126 drives (you need the appropriate USB hub to do that, of course )

  • Can i connect two iphone, just to update software, on one itune install

    Can I connect two i phones to one itunes installation. With two itunes account.

    Yes.  Best option is to create additional Windows user account and each user account will maintain their seperate iTunes Apple ID.
    Refer to this article:
    How to use multiple iPods, iPads, or iPhones with one computer
    http://support.apple.com/kb/HT1495

Maybe you are looking for

  • HP LaserJet M1536dnf cannot connect to internet but we are able to print wirelessly.

    I connected our HP LaserJet M1536dnf MFP via USB to our Aiport Express...  I was able locate and add it using the Print & Scan function in System Tools (and I am able to print wirelessly) but we cannot scan from our computers or use AirPrint. I pulle

  • Attempting to download IOS 5 for ipad2 do not see actual initiate download point

    See apple iOS 5 download on the support tab but no actual initiation button to Dow oaf. Connected ipad2 to laptop and accesses via ipad2 iTunes as well as from URL apple ios5 Dow OAS

  • Issue in DBM service order creation through RFC

    hi everyone,   I am using the RFC '/DBM/ORD_RFC_CREATE' to create the service order. I have executed in test run in SE37. The Serice Order is not getting created. I am getting message in return table that 'ordertype is not in table '/DBM/C_ORDERTP'.

  • Custom OBIEE Subtotal and Total Font Size

    Hello all Im trying to customize the font size of the subtotal or total row I was able to find the following and it got me half way there http://obieexpertise.blogspot.ca/2010/05/customize-format-of-subtotal-cells.html BUT the issue I have now is tha

  • Bringing BIS back to z10 possible ?

    Hey all now I 've searched all over the internet to find any method to get BIS to work again as old devices but unfortunately its  gone !!  its really worth disappointing. my question : Is there any way to bring it back by software update or somethin