Connect flex to cf

Im havin a real ball ache trying to connect fb 4 beta 2 to cf running another machine, can anyone help me

Ok so
I have Cf 7 (updated to 7.0.2) on a machine Windows server 2003
The admin for this machine has a url of
https://{domain_name}/CFIDE/administrator/index.cfm
The cf instance is installed on the c drive of this machine
The cfcs that im trying to access are on a different drive on the same machine
so
E:\hosting\{main_folder_name}
when i try and connect to cf using Configure Coldfusion server
im selecting Standalone
for cf root folder i put in \\{machine_name}\C$\CFusionMX7
for web root i put in \\{machine_name}\e$\hosting\{main_folder_name}\wwwroot
and then for root url
https://{domain_name}/
for this i get
" Cannot access the web server. The server may not be running, or the web root folder or root URL may be invalid."
Any info u can give on this will be greatly appreciated

Similar Messages

  • Upgrade c7000 to virtual connect flex-10/10D

    We have basic c7000 enclosure with 1 GB pass-thru modules (bay 1,2,5,6,7,8 for networking and brocade pass-thru for Fiber Channel - bay 3,4 for storage.  Have 5 bl460c Gen8 Blades.  Trying to upgrade to virtual connect flex-10/10D on the networking side.  Is their a way to import the existing server network information into the initial virtual connect domain?

    How I know, for work with VC Flex-10, you need to use separate switches between P4000 and chassis.

  • 4900M connection to HP Virtual Connect Flex 10

    Trying to connect a HP-C7000 blade server with a Virtual Connect Flex 10 connection with 10Gb links to a Catalyst 4900M.
    I have no control of the HP side. From the HP guide, we are following "HP Virtual Connect Ethernet Cookbook" "Scenario 1:5 - VLAN Tagging (802.1q) with Shared Uplink Set (SUS) with Link Aggregation using LACP (802.3ad) - VMware ESX"
    On the 4900M, LLDP sees the Virtual Connect and LCAP up with 2 active links. Show interface on Ten1/1, Ten1/2, Port-Channel 1 shows 0 packets input.
    Basically, we can not get any packets from the HP Server/VMware server side through the Catalyst 4900.
    IOS version: 12.2(54)SG
    Switch ports are as follows:
    interface Port-channel1
    description HP FLEX-10-VC
    switchport trunk allowed vlan 4,8,10,11,16,22-24,69,99-101,156,192,300,500
    switchport mode trunk
    switchport nonegotiate
    spanning-tree portfast trunk
    interface TenGigabitEthernet1/1
    description HP FLEX-10-VC
    switchport trunk allowed vlan 4,8,10,11,16,22-24,69,99-101,156,192,300,500
    switchport mode trunk
    switchport nonegotiate
    spanning-tree portfast trunk
    channel-protocol lacp
    channel-group 1 mode active
    interface TenGigabitEthernet1/2
    description HP FLEX-10-VC
    switchport trunk allowed vlan 4,8,10,11,16,22-24,69,99-101,156,192,300,500
    switchport mode trunk
    switchport nonegotiate
    spanning-tree portfast trunk
    channel-protocol lacp
    channel-group 1 mode active

    This command starts passing traffic on all of the VLANs using the trunk. If the Flex Connect sees layer-1 come up but is unable to pass traffic it may think the interface is not working. I enable this on trunk connections to VMware hosts and Flex Connect interfaces. It is possible disabling portfast will not cause problems for the Flex Connect interfaces. You can test this in your environment and see what works.

  • Connecting flex with php(wamp)

    i m trying to connect a flex application to a php (wamp server)..bt i m unable to do soo
    ma application runs fine....bt wen i click submit button it shows ..transfering data frm localhost n nothing happens......database is nt updated........
    //flex code
    <?xml version="1.0" encoding="utf-8"?>
    <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute" creationComplete="send_data()">
    <mx:Script>
    <![CDATA[
    import mx.controls.DataGrid
    private function send_data():void {
    userRequest.send();
    ]]>
    </mx:Script>
    <mx:Label x="79" y="89" text="username"/>
    <mx:Label x="79" y="128" text="rolnumber"/>
    <mx:TextInput id="nm" x="153" y="87"/>
    <mx:TextInput x="153" y="126" id="roll"/>
    <mx:Button x="127" y="191" label="submit" id="sub" click="send_data()"/>
    <mx:HTTPService id="userRequest" url="http://localhost/connect.php" useProxy="false" method="POST">
    <mx:request xmlns="">
    <username>{nm.text}</username><rollnumber>{roll.text}</rollnumber>
    </mx:request>
    </mx:HTTPService>
    </mx:Application>
    //php code
    <?php
    mysql_connect("localhost", "root", "") or die("cannot connect");
    mysql_select_db("std_db") or die("cannot select database");
    $q="INSERT INTO `std_db`.`student` (`name` ,`roll`)VALUES ( '$_POST[nm]', $_POST[roll])";
    if(mysql_query($q))
    echo "sucessfully inserted";
    else
    echo" error occured";
    //if($row=mysql_fetch_array($result))
    //echo $row['
    ?>

    naval joshi wrote:
    thanx a lot it worked........wat shd be the code fr display full datbasee nnnnnnshd i usee the datagrid?
    you can use a datagrid if you want, or a tile list, or a list, or an advanced datagrid, it's entirely up to you and what you plan to do with the data.
    The Full working basic code for what you're trying to do is this:
    Flex code:
    <?xml version="1.0" encoding="utf-8"?>
    <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute" creationComplete="send_data()">
        <mx:Script>
        <![CDATA[
            import mx.rpc.events.ResultEvent;
            import mx.controls.DataGrid
            private function send_data():void
                userRequest.send();
            private function handleResult(evt:ResultEvent):void
                dg1.dataProvider = evt.result.player;
        ]]>
        </mx:Script>
        <mx:Label x="79" y="89" text="username"/>
        <mx:Label x="79" y="128" text="rolnumber"/>
        <mx:TextInput id="nm" x="153" y="87"/>
        <mx:TextInput x="153" y="126" id="roll"/>
        <mx:Button x="127" y="191" label="submit" id="sub" click="send_data()"/>
        <mx:HTTPService id="userRequest" result="handleResult(event)" url="http://localhost/connect.php" useProxy="false" method="POST">
            <mx:request xmlns="">
                <username>{nm.text}</username><rollnumber>{roll.text}</rollnumber>
            </mx:request>
        </mx:HTTPService>
        <mx:DataGrid id="dg1" x="69" y="261">
            <mx:columns>
                <mx:DataGridColumn headerText="Name" dataField="name"/>
                <mx:DataGridColumn headerText="Roll" dataField="roll"/>
            </mx:columns>
        </mx:DataGrid>
    </mx:Application>
    PHP Code:
    <?php
        mysql_connect("localhost", "root", "") or die("cannot connect");
        mysql_select_db("std_db") or die("cannot select database");
        if ($_POST["username"])
            $name = mysql_real_escape_string($_POST["username"]);
            $roll = mysql_real_escape_string($_POST["rollnumber"]);
            $query = "INSERT INTO student (name , roll) VALUES ('$name', '$roll')";
            if(mysql_query($query))
                echo "sucessfully inserted";
            else
                echo" error occured";
        $query="SELECT * FROM student";
        $result = mysql_query($query);
        $num_rows = mysql_numrows($result);
        $i=0;
        while ($i < $num_rows)
            $getName = mysql_result($result,$i,"name");
            $getRoll = mysql_result($result,$i,"roll");
            print "<player><name>".$getName."</name><roll>".$getRoll."</roll></player>";
            $i++;
    ?>

  • Connecting Flex 2 To Data Sources

    I have order flex 2 (out of my own pocket) so I can learn how
    to use it. Hopefully I should have it in the next day or two.
    It seems that once I get going, the truly cool stuff will be
    connected to some sort of data source.
    Any suggestions for getting inexpensive data sources set up
    so I could learn that piece of flex?
    Currently my web host allows a SQL database, but I have not
    really made use of that feature.
    Paying for something like Cold Fusion out of my own pocket is
    a little to much for me. Paying for the upgrades for Production
    Studion and the old Macromedia Studio 8 will suck up most of my
    play cash in the next year or so.
    Thanks
    Mathias

    well you dont need to purchase anything to write .net and
    even ASP could fill the role of server side technology for most
    flex apps. In fact one nice thing about IIS is that you can write
    your server side script in javascript which is very similar to
    actionscript which is nice and if you need to do client side script
    you can swap your javascript functions back and forth in your
    client and server side scripts. Also you dont have to use MS
    technologies to talk to their DBs, you could use whatever script
    enviroment that your host has to offer. As far as rendering XML you
    can use dataBinding objects on the host or even just render it your
    self like
    var rName = ""+ sqlObject("Record_Name");
    var result= "";
    result= "<xml>\n\r<name>"+ rName+
    "</name>\n\r</xml>"
    Response.write(result);

  • How connect FLEX and SAP R3 via RFC

    Hi all
    Can anybody tell me, how to connect the SAP R3 and FLEX via RFC.
    Is this possible or can only be via webservice?
    Regards and thanks,
    morojan

    Well in theory you could build a flex component that uses the RFC library to call SAP (and viceversa) but it sems like a lot of trouble when you can just use the existing HTTP/XML methods already available.
    Cheers
    Graham Robbo

  • Connecting Flex to PHP returned XML

    Hello! im new to flex and i have a question that i am hoping
    someone can answer. I have a flex app that i am building that needs
    to display a list of dynamic images, preferably with icons. I've
    built the Title list, but i don't know how to connect the
    HTTPService data to the list. the HTTPService is returning XML
    data, so it must be easy. but, as i said, Im really new. Please
    Help Me!!

    "arthurlockman" <[email protected]> wrote in
    message
    news:g7kk4g$177$[email protected]..
    > Hello! im new to flex and i have a question that i am
    hoping someone can
    > answer. I have a flex app that i am building that needs
    to display a list
    > of
    > dynamic images, preferably with icons. I've built the
    list, but i don't
    > know
    > how to connect the HTTPService data to the list. the
    HTTPService is
    > returning
    > XML data, so it must be easy. but, as i said, Im really
    new. Please Help
    > Me!!
    >
    Depending on what you're wanting to do, you can either use a
    Repeater with
    an Image or custom component that contains an Image or you
    can use a List
    based component to display an Image or custom component with
    an Image (or
    SwfLoader, or Loader) in it. There is literally a ton of
    stuff about this
    in the Help. Here are some places you may want to try:
    Help>Flex Start Page>Creating a Simple RIA
    Help>Help Contents>User Interfaces
    - Using Data Providers and Collections
    - Controls
    - Image
    - SwfLoader
    - Using Data Driven Controls
    - Using Item Renderers and Item Editors
    - Dynamically Repeating Controls and Containers
    Here is an example that might get you running fast *if* you
    are not the type
    to read the docs:
    http://examples.adobe.com/flex2/inproduct/sdk/photoviewer/PhotoViewer.html
    HTH;
    Amy

  • Connectivity in flex to oracle using java

    hello,
            i have to connect flex  3 with java which uses oracle as a database.How i can connect flex with java.I am trying to access web services provided by          java in flex.Is it possible? Please help me out.
              Thanks,

    Hi,
    Are you using Flash Builder to build your application?
    Definitely you could connect to web services from flex .
    May be in your case, expose the JAVA class as web services using AXIS(may be) and access it as shown below:
    Sample snippet:
    <mx:WebService
      id="service"
      result="onResult(event)"
      fault="onFault(event)"
      wsdl="http://abc.cd.com/ PhoneNumber.asmx?WSDL/>
    Refer: http://livedocs.adobe.com/flex/3/html/help.html?content=data_access_3.html  for more details.
    Please revert back if you face any issue
    Thanks,
    Balaji
    http://balajisridhar.wordpress.com

  • Wish To Use Flex 2 For My University Project

    Dear All
    I am a mature student studying a Computer Science Degree in
    the UK .
    For my final year project, I am creating a Stock Market
    Simulation with a Database back end (e.g. SQLite ?) and some kind
    of front end, both to be run a a stand-alone machine.
    I have a 28 weeks to design, build and run it for my
    supervisors. I would like to push myself academically by building
    the software using Flex 2, for the GUI and even to carry out any
    calculations or processing needed for the simulation to operate
    correctly.
    My questions are
    1) Is it possible to create the simulation as I can find no
    definitive way to connect Flex 2 directly to a database back end in
    a similar way to ADO.net?
    2) If it is possible which book do you recommend to get the
    best and quickest results out of Flex 2?
    Thanks In Advance
    Steven

    You are correct, Flex does not natively connect to any
    database. Further, security restrictions on both the browser and
    the Flash Player prevent access to *any* client resources, such as
    the filesystem.
    So if you use standard Flex, you will need some back-end web
    technology. This can be almost any platform/language you choose.
    Now, the newest, coolest thing in the Adobe world is AIR. AIR
    applications can be written using Flex, Flash, HTML and javascript,
    and have full access to client asseets. AIR is essentially an
    internet delivered desktop application.
    AIR has SQLLite database built-in.
    AIR is currently in public Beta. I do not know what will be
    available as far as non-commercial or educational licensing when it
    is realeased.
    I don't have a book to recommend, but here is a partial list
    of on-line resources:
    Tracy
    Flex 2.x Resources
    Flex sites/blogs:
    Adobe:
    http://www.adobe.com/devnet/flex/
    DEVNET - start here!
    http://www.adobe.com/products/flex/productinfo/faq/
    http://www.adobe.com/cfusion/communityengine/index.cfm?event=homepage&productId=2
    http://blogs.adobe.com/
    http://weblogs.macromedia.com/mxna/
    http://labs.adobe.com/
    http://labs.adobe.com/community/
    http://www.adobe.com/cfusion/exchange/index.cfm#loc=en_us&view=sn610&viewName=Adobe%20Exch ange&avm=1
    http://blogs.adobe.com/flexdoc/
    Other:
    http://www.searchcoders.com/flex/
    http://www.flexination.info
    http://flexibleexperiments.wordpress.com/2007/03/14/flex-20-primitive-explorer/
    http://www.scalenine.com
    http://www.flexcursion.com
    http://www.theflexshow.com
    http://www.JeffryHouser.com
    http://blog.digitalbackcountry.com/
    http://code.google.com/p/flexlib/
    http://flexbox.mrinalwadhwa.com/
    http://dougmccune.com/blog/
    http://www.cflex.net/
    http://www.quietlyscheming.com/blog/
    http://www.everythingflex.com
    http://www.waldosmeets.com/
    http://www.jessewarden.com/
    http://www.cbetta.com/blog/
    http://www.cynergytv.com/
    http://www.flexdaddy.info/
    http://www.richinternet.de/blog/
    http://www.brightworks.com/technology/overview.html
    http://www.crossdomainxml.org/
    http://flexsearch.org/
    http://labs.flexcoders.nl/
    Flex style Explorer:
    http://examples.adobe.com/flex2/consulting/styleexplorer/Flex2StyleExplorer.html
    Documentation:
    http://www.adobe.com/support/documentation/en/flex/
    http://livedocs.macromedia.com/flex/2/
    http://www.adobe.com/cfusion/knowledgebase/index.cfm
    Lists:
    http://www.adobe.com/cfusion/webforums/forum/index.cfm?forumid=60
    http://groups.yahoo.com/group/flexcoders/
    http://groups.yahoo.com/group/flexcomponents/
    Bugs/enhancement requests:
    http://www.adobe.com/go/wish

  • FLEX WITH BLAZEDS/LCDS

    What are the roles and responsibilities of flex developer in blazeds application?
    Actually i am a flex developer by profession and having 2.5 years of experience of developing client side flex application with backend support of php using AMFPHP.Till now,our team member(only flex) interact with the backend team members(php members) and got the data as they want.
    But now i want to connect flex client to java using BLAZEDS OR LCDS ES , so i want to know that is the procedure will remains the same that flex developers now interact with the backend java developers as they did with php developers or flex developer have to manage the server of their own and write java code themselves.
    Thank you in advance.........

    It is usually common for teams with multiple developers to have a division of responsibilities between back-end (Java, PHP, .NET, etc) developers and front-end (HTML, Flex, Silverlight, etc.) developers. This makes it easier to divide up the work on a clear "boarder," so both sides can work in tandem with little interference.
    That being said, it may be beneficial for front-end developers to have a little bit of flexibility to make minor changes to the back end if the project is not clearly defined ahead of time. And as always, the feedback loop between designers, front-end developers, and back-end developers, should be kept as short as possible to achieve the greatest flexibility.
    Disclaimer: These are my own opinions based on how I work with my own team. Results may vary.

  • Flex 2, FDS 2.5 and CF 8: Still can't execute any kind of WebService!!!

    Hi everyone,
    I am starting to retract my brain from an intense 2 days to figure out how to use Flex with Coldfusion. I am using Coldfusion 8 Beta (this part is good, don't need help for CF itself). I am also using Flex Builder 2 (with chart but this not the topic). I installed FDS 2.5 before to install ColdFusion 8 but I think CF8 have is own FDS or something like that... anyway, it might help to mention it!
    Well, I tried HTTPService, RemoteObject, WebSer vice - NOTHING WORKS!!! Argh! Did I mention I spent 2 days? ;-)))
    Well, I start with the basic: a login form with an email (as a username) and a password to be validated. I have a CFC to do the validation and return a simple message (string): "OK' when it is valid and a custom message when it is not valid; depending if it is the password and/or the email which is not valid.
    I always got an error. Since the error is different depending of the method I use, I will explain the latest method I used in this message and try to concentrate on that method specifically! The method is WebService and here is the error:
    faultCode:Server.Error.Request
    faultString:'HTTP request error'
    faultDetail: 'Error: [IOErrorEvent type="ioError"
    bubbles:false cancelable=false eventPhase=2
    text="Error #2032: Stream Error . URL=http://localhost:8501/iDashboard/login.cfc"].
    URL: http://localhost:8501/iDashboard/login.cfc'
    Any help will be very useful!!!
    Thank's
    P.S.: I succeed to execute a HTTPService only if I call a XML file.

    You can connect Flex to CF with out the use of LCDS(FDS)<br />So a better place to look for answers to you question would be the Flex forums.<br />with that said make sure your Flex project is setup to use Coldfusion Flash Remoting Services.<br /><br />Then create a remote object in your mxml file<br /><mx:RemoteObject<br />      id="serv"<br />      destination="ColdFusion"<br />      source="path.toYour.cfc" <br />      showBusyCursor="true">  <br />     <mx:method name="nameOfFunctionOnCFC" result="resultHandlerFunction(event)" fault="Alert.show(event.fault.message)"/><br />   </mx:RemoteObject><br /><br />create the handler function<br /><br />private function resultHandlerFunction(event:Event):void{<br />     //do something with your results<br />}<br /><br />then make the call to the service<br /><br />serv.nameOfFunctionOnCFC(email,password);<br /><br />that should work if your paths to your CF server is correct.<br /><br />Russ

  • LMS 3.2 User Tracking 10GE trunk to HP BladeSystem c7000 w. Virtual Connect Flex10

    Hi All,
    situation:
    LMS 3.2
    Cat6509 w. 4 port 10 GE module connected with trunk to
    HP BladeSystem c7000 Enclosure
    with
    HP Virtual Connect Flex-10 10Gb Ethernet Module
    with
    #20 of ESX servers, Citrix
    UT settings: "config trunk for end host disc. = enable on this trunk."
    No show for connected MAC's of the server and end hosts (Citrix sessions).
    Note: this works well for a ESX based DL380 server connected with 1GB trunk to a C3750.
    Why is this not working for this Cat6509 configuration ?
    Is the 10 GE port supported in Campus manager?
    regards,

    Hi Joseph,
    Long time ago I started this discussion about UT support for portchannels. Right now we're on the level of LMS 4.2, do you know if there is any progress made with support for UT on portchannels?
    Kind regards
    Ad

  • Flex Developer Open Positions in NYC

    I am working for a financial ratings firm and have 2 Flex Developer roles open in downtown Manhattan, the job description is listed below. The hiring manager is doing phone screens tomorrow starting at 4pm. Please e-mail me your information at [email protected] or give me a call at 212-257-6123 as soon as possible if you are interested.
    Applicant should have at least 1year developing with Flex, and in connecting Flex to server-side Java objects and/or web services.  Experience with BlazeDS, a component of Flex, would be very helpful.  Experience with the Java Spring and/or Hibernate frameworks would also be helpful, and with J2EE in general.
    MVC Fameworks
    Data Binding
    Flex API
    Flex ActionScript3
    Asynch Event Handling - AJAX
    Serverside Objects

    This blog post might be useful for you: http://flexponential.com/2010/11/30/grouping-items-in-a-flex-mobile-list/

  • Flex to SQL server

    Hai
    I am very new to Flex.
    I am trying to connect Flex to remote SQL server database.
    I have seen few blogs but getting confused.
    Can someone post an example to connect to remote SQL server database, get the data to xml and populate datagrid/list from it.
    I am using Flex 4.
    Thanks a lot..

    Here is how I use HTTPService Objects. I am new to FLEX too, only 2 months in and I am launching a pretty huge app next week...
    Anyways, first you define your HTTPService Object(s). You can do this in ActionScript or MXML. Here I am defining them in MXML, in the Declaration section of my MXML component, like so:
    1. declare HTTPService Object
    <fx:Declarations>
            <s:HTTPService id="setSomeDataSRV"/>
            <s:CallResponder id="setSomeDataSRVResult" result="setSomeDataSRVResult_resultHandler(event)"/>
    </fx:Declarations>
    ^ you can specify many parameters here, like URL, result, etc. These are rather empty and do not use many of the attributes available. I initialize those later, in AS3 code. You can see two objects, a HTTPService and a CallResponder. The CallResponder basically listens and receives focus after the HTTPService is invoked and run. The CallResponder has a result method, setSomeDataSRVResult_resultHandler(event). This is where the code jumps after the HTTPService is run. We will get to that in a minute.
    2. In ActionScript/CDATA script section in the same component, I have the following function:
                private function executeSomeDataWebService():void {
                    if (_someDataChanged) {
                        var params:Object = {};
                        params["UserID"] = lblUserID.text;
                        params["Parameter2"] = lblParameter2.text;
                        params["Parameter3"] = someDataNumStepper.value.toString();
                        params["Parameter4"] = _userTempType.data.tempValue;
                        setSomeDataSRV.url = "http://255.255.255.255:8060/MyServiceLayer/MyDataService.asmx/MyWebServicesNameHere";
                        setSomeDataSRVResult.token = setSomeDataSRV.send(params);
    255.255.255.255:8060 needs to be your actual Server URL. This is only example stuff.
    3. here is the result handler, in Action Script 3. This gets called back when the HTTPService is completed:
                private function setSomeDataSRVResult_resultHandler(event:ResultEvent):void {
                    Alert.show('someData web service invokation was succesful');
    I hope this can put you in the right direction. May the FLEX force be with you.

  • Flex & CF: unable to open...

    Connecting flex to coldfusion cfc via a remote object.
    The error " unable to open
    '\CFusionMX7\wwwroot\WEB-INF\flex\services-config.xml' " appears.
    The file exist with its coldfusion-destination.
    I managed to connect flex to coldfusion on another computer.
    This computer has a 64-bit processor and cannot use the regular
    installer for coldfusion. I had to use a silent install to put
    7.0.2 on it.
    Do you think it has something to do with it?
    ///johan

    Nevermind. As you can see in the URL, there is no "c:" and I
    don't know why that was not there by default in the project set-up.
    It doesn't matter. Problem solved.
    ///johan

Maybe you are looking for

  • Session Timeout Alert + login page has changed

    Hello, We recently updated our SAP CRM 7.0 from EHP1 to EHP3. Since than we get this "Session Timeout Alert" error and it is very annoying. I've changed the rdisp/plugin_auto_logout parameter to 7200 s but the session is still ending after about 10mi

  • Unable to convert sender service(BPM) to an ALE logical system

    Hi All, I am working on simple File to File Scenario where XI picks the File and process thru BPM and sends the file to R/3 Application server and wait for SYSTAT STATUS IDoc for the acknowledgement from R/3 System. My scenario is working fine by rec

  • How can I transport a select-option structure into a RFC function

    hey, I want to import 10 select-option fields into RFC function. the structure likes follows: DATA: BEGIN OF T_EBELN,           SIGN      TYPE C,           OPTION(2) TYPE C,           LOW       LIKE EKKO-EBELN,           HIGH      LIKE EKKO-EBELN,   

  • Trouble playing Music Videos on 8.1

    Music videos on iTunes (8.1) will only play audio even though Movies and TV Shows will display regularly on Quicktime (7.6). I've followed standard "If you can't play a video" iTunes Help instructions to no avail.

  • My laptop won't, can't open add printer.

    Why can't I add a printer to my HP g62?  Says it can't open "add printer".