Controlling JScrollPane from outside

I'm making an application purposed for presenting. I use two JFrames, one for controlling which only i see, and one -the view- that the audience sees.
My wish is that i can control the JScrollPane on the view-frame with a JScrollBar on the control-frame. How do i do this?
I tried:
* creating a JScrollBar on the control-frame and then define it as the scrollbar on the view-frame by a using jScrollPane1.getVerticalScrollBar();
* creating a JScrollBar on the control-frame and then define it as the scrollbar on the view-frame by a using jScrollPane1.setVerticalScrollBar(jsb);
* more...
That all didn't have any of the wished effect.
Could you help me?

It is an interesting problem, so I had to try it myself. It works:
import javax.swing.BoundedRangeModel;
import javax.swing.DefaultListModel;
import javax.swing.JList;
import javax.swing.JPanel;
import javax.swing.JScrollPane;
public class ShareScrollBarModel
  private static final int MAX = 100;
  private JPanel mainPanel = new JPanel();
  private JScrollPane scrollpane;
  private DefaultListModel listModel;
  public ShareScrollBarModel()
    listModel = new DefaultListModel();
    for (int i = 0; i < MAX; i++)
      listModel.addElement(new Integer(i));
    JList list = new JList(listModel);
    scrollpane = new JScrollPane(list);
    scrollpane.getVerticalScrollBar().setEnabled(false);
    mainPanel.add(scrollpane);
  public JPanel getMainPanel()
    return mainPanel;
  public BoundedRangeModel getVertScrollBarModel()
    return scrollpane.getVerticalScrollBar().getModel();
  public DefaultListModel getListModel()
    return listModel;
import java.awt.Dimension;
import javax.swing.BoundedRangeModel;
import javax.swing.DefaultListModel;
import javax.swing.JDialog;
import javax.swing.JFrame;
import javax.swing.JList;
import javax.swing.JPanel;
import javax.swing.JScrollBar;
import javax.swing.JScrollPane;
public class ShareScrollBarModelTest
  private JPanel mainPanel = new JPanel();
  private JScrollPane scrollpane;
  private DefaultListModel listModel;
  public ShareScrollBarModelTest(BoundedRangeModel vertSBarModel, DefaultListModel listMod)
    JList list = new JList(listMod);
    JScrollBar vertBar = new JScrollBar();
    vertBar.setModel(vertSBarModel);
    scrollpane = new JScrollPane(list);
    scrollpane.setVerticalScrollBar(vertBar);
    mainPanel.setPreferredSize(new Dimension(400, 300));
    mainPanel.add(scrollpane);
  public JPanel getMainPanel()
    return mainPanel;
  public JScrollPane getScrollPane()
    return scrollpane;
  public DefaultListModel getListModel()
    return listModel;
  private static void createAndShowUI()
    ShareScrollBarModel ssbModel = new ShareScrollBarModel();
    ShareScrollBarModelTest modelTest = new ShareScrollBarModelTest(ssbModel.getVertScrollBarModel(), ssbModel.getListModel());
    JFrame frame = new JFrame("Frame Display");
    JDialog dialog = new JDialog(frame, "Dialog Display", false);
    dialog.getContentPane().add(ssbModel.getMainPanel());
    dialog.pack();
    dialog.setLocationRelativeTo(null);
    frame.getContentPane().add(modelTest.getMainPanel());
    frame.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
    frame.pack();
    frame.setLocationRelativeTo(null);
    frame.setVisible(true);
    dialog.setVisible(true);
  public static void main(String[] args)
    java.awt.EventQueue.invokeLater(new Runnable()
      public void run()
        createAndShowUI();
}

Similar Messages

  • Controll Flash from outside

    hi,
    i have a looped sound in one frame and changing pages in the
    other frame. some of these pages have videos or other soundcontent.
    how can i stop or fade the looped sound in a .swf file in
    frame 2 by the startscript of flashmovies in mainframe, or with JS?
    i'm using flash8 prof.
    thanks in advance for any advice
    rainer

    in addition: i forget to make clear - frames are html-frames,
    not flash-frames!
    rainer

  • How to access to EM Grid control from outside browser

    I want to access to EM Grid Control console from an other place, outside of my office but I can't, I configured my firewall with the default ports 1159,1830.
    I don't know if I have to add other port, I can't understand because I Have an other application e-business that I can access without any problems.

    You can get to grid control within your office?
    Try using the SECURE connection
    https://host.port#/em

  • Can not foward into voicemail from outside call on CUE and CUCM 8.6

    Dear Team,
    I have CUE Utility and CUCM 8.6.
    I can call from local, if user busy or go out office then call will foward to voice mail.It is ok.
    But when i call from outside to my phone(direct line), then call can not foward to voice mail on CUE.
    Please help me some solution.
    Thanks.

    Hi nam,
    A couple of things to check. Have you set the Forward Busy/No Answer "External"
    on the DN config page in CUCM?
    Are the calls coming in using a codec other than g.711?
    Best Practices for Deploying Cisco Unity Express
    • Each mailbox can be associated with a primary extension number and a primary E.164 number.
    Typically, this number is the direct-inward-dial (DID) number that PSTN callers use. If the primary
    E.164 number is configured to any other number, use Cisco IOS translation patterns to match either
    the primary extension number or primary E.164 number so that the correct mailbox can be reached
    during SRST mode.
    • Each Cisco Unity Express site must be associated with a CTI route point for voicemail and one for
    AA (if licensed and purchased), and you must configure the same number of CTI route points as
    Cisco Unity Express ports licensed. Ensure that the number of sites with Cisco Unity Express does
    not exceed the CTI scalability guidelines presented in the chapter on Call Processing, page 8-1.
    • Cisco Unity Express is associated with a JTAPI user on Cisco Unified CallManager. Although a
    single JTAPI user can be associated with multiple Cisco Unity Expresses in a system, Cisco
    recommends associating each dedicated JTAPI user in Cisco Unified CallManager with a single
    Cisco Unity Express.
    • Calls into Cisco Unity Express use G.711 only. Cisco recommends using a local transcoder to
    convert the G.729 calls traversing the WAN into G.711 calls. You can configure Cisco Unified
    CallManager regions with the G.711 voice codec for intra-region calls and the G.729 voice codec
    for inter-region calls.
    • If transcoding facilities are not available at the Cisco Unity Express site, provision enough
    bandwidth for the required number of G.711 voicemail calls over the WAN. Configure the Cisco
    Unified CallManager regions with the G.711 voice codec for calls between the IP phones and Cisco
    Unity Express devices (CTI ports and CTI route points).
    • The CTI ports and CTI route points can be defined in specific locations. Cisco recommends using
    location-based call admission control between Cisco Unified CallManager and Cisco Unity Express.
    RSVP may also be used.
    http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/4x/42unityx.pdf
    Cheers!
    Rob
    "Far away from your trouble and worry
    You belong somewhere you feel free" - Tom Petty

  • Remote Screen Sharing (VNC) from outside of my LAN

    I often have to connect to my parents' Macs to help them out with various things. I commute between two cities and stay with them when I'm there.
    (I set up a dynamic hostname with DynDNS to point to our router, which defaults to port 443, which on the home network is reserved for the QNAP NAS that's set up. I set the router up to be reachable at port 455 but I'm not sure if it is successfully sending IP address updates to DynDNS. I don't see a way to check if it is. DynDNS seems to require a paid account for that functionality and my routers log is also not very helpful. In short, I'm having trouble getting the whole dynamic DNS thing to work reliably with our router, which is otherwise a great little box: a Fritz!Box Fon WLAN 7390).
    I use Jolly's Fast VNC (http://goo.gl/UmllQ) to connect to a personal server and that works wonderfully, but then there the details are taken care of for me by my provider and I just have to type in the details.
    What I'd really love is something like Edovia's Screens (http://www.edovia.com/)... except for the Mac rather than the iPhone/iPad (though I do own an iPhone copy of it and it's wonderful).
    We do share a MobileMe subscription in the family, but that's not very helpful here either.
    So far, we've used iChat, Skype screen sharing and I often end up using TeamViewer because of its speed and near non-existant setup.
    My goal is to find a way to connect to my parents' Macbooks even when they are not around so I can help them out with problems while they may not even be around. The key here is that I want to be able to control their screens without needing any action on their part.
    Suggestions for the simplest possible way to do this are very welcome.

    I didn't know TeamViewer could be set up to be accessible without a second user having to be around to give me the session ID and password. I wonder if it's worth looking into that if LogMeIn Free with its server always running is a perfectly acceptable solution? Any advantages to using TeamViewer's solution?
    The free LogMeIn account does NOT allow file transfer. The free for personal use TeamViewer does.
    LogMeIn server hides in the background, so it is less likely your parents will Quit LogMeIn.com, were as TeamViewer looks like just another app, so they might Quit from it to get it out of the way.
    Of course if you need to transfer a file (or 2), you could use DropBox.com for that, and it is a very easy way to transfer files between systems. Or you could store the file on your MobileMe account in a public place, then via LogMeIn copy the file from your public space into your Parent's Mac(s). Or your could use LogMeIn to start TeamViewer, and then use TeamViewer to transfer the file.
    Basically once you can start applications on your Parent's Mac(s), you can use any number of utilities for transferring data.
    We do have MobileMe. I was under the impression that the way Back to my Mac works is that it will show you YOUR remote Macs in the Finder's sidebar. You know, ones that you're also logged in with YOUR MobileMe credentials. We all use our own, unique MobileMe accounts. Am I missing something?
    Yes, all the Macs would need to use the same MobileMe account. Do you all really need separate accounts? Maybe a Family account.
    I could deal with the port forwarding and DynDNS but I'll have to set that up to remotely administer my router and NAS, which is turning out to be quite the pain. So if I can simplify, I will. LogMeIn or TeamViewer will do the trick just fine.
    Port forwarding is a once and done thing for your parent's router. It allows you to get to their Macs from outside their home. It should have nothing to do with remote admin, or your router and NAS. Also once you can Screen Share your parent's Mac, you can then use that Mac to talk from the inside to their router. Although one must be very careful about making router config changes as one "Oops" and you could loose your remote access, and have to visit Mom and Dad to get physical access
    By the way, I've been using VNC/Screen Sharing and AFP file sharing over ssh tunnels in conjunction with port forwarding on the destination router for years. I do this, even though it is more work, because it was available long before most of the above services were available, and because it has a lot more flexibility once you know how to use it. Oh yea, I'm also a Unix software developer and spend a lot of time using ssh anyway

  • Break out of a while loop from outside the loop

    Hello,
    I have an application where I have some nested while loops. Is it possible to break the innermost loop from a control that is outside of the inner loop? My inner loop is running a scan and read operation on the serial port and is reading data as it somes in. I need this loop to break when the user presses a button located in one of the outer loops so that another section of the vi can execute. Thanks in advance.
    Greg
    Gregory Osenbach, CLA
    Fluke

    Greg,
    You should place the terminal of the button in the innermost loop and wire out from there to the other locations the value is needed. If these are nested loops, the controls will not get read until the outer loop iterates again and this can only happen if the inner loop has ended anyway. Thus your scheme will not work.
    Alternatively, you can place the control in a loop that executes in parallel,then use local variables of it in the other locations, but the above solution is better.
    LabVIEW Champion . Do more with less code and in less time .

  • ALV Grid editable - How to raise the data_changed event from outside object

    Hi,
    i'd like to like to raise the data_changed event from outside the ALV-Grid object in order to display errors to the user.
    For example a new row was inserted within the program. The user has only to complete the missing informations. Before saving the transactions the program has to execute some semantic checks. The errors of this check process should be shown to the user by creating an instance of the cl_alv_changed_data_portocol object.
    Thanks.
    Regards

    You don't need to raise the data_changed event to perform the edits or to issue messages using cl_alv_changed_data_protocol.
    The following assumes you have an ALV grid object g_alv based on the CL_GUI_ALV_GRID class.
    You can mark the inserted records upon insertion as selected using the set_selected_rows method, and then retrieve these rows later using get_selected_rows and perform necessary edits.
    Save the row number of each inserted row into a table of the appropriate type (see the method definition for this):
    DATA: t_index_rows    TYPE  lvc_t_row.
    DATA: s_row_no        TYPE  lvc_s_roid.
    DATA: t_row_no        TYPE  lvc_t_roid.
    Load entries into t_row_no after each insert.  Capture the row number and save in the table t_row_no.
    e.g.
    PERFORM insert_row USING s_row_no-row_id.
    APPEND s_row_no TO t_row_no.
    FORM insert_row would have whatever code you are using to insert the row.  Save the row id into s_row_no-row_id (which is an INT4).
    When done with all inserts do the following
      IF t_row_no[] IS NOT INITIAL.
        CALL METHOD g_alv->set_selected_rows
          EXPORTING
            it_index_rows            = t_index_rows
            it_row_no                = t_row_no
            is_keep_other_selections = 'X'.
      ENDIF.
    Then, if SAVE is pressed without the data_changed event having been raised (such as if the user just pressed SAVE without changing anything), use method get_selected_rows to retrieve the rows that were inserted and perform the necessary edits.
      DATA: l_t_rows    TYPE lvc_t_row.              " ALV control: Table rows
      CALL METHOD g_alv->get_selected_rows
        IMPORTING
          et_index_rows = l_t_rows.
    Loop through l_t_rows and use the row as an index into the grid, perform the necessary edits, just as you would if the data_changed event had been raised.
    If any edits fail, then send messages to the user, abort the save, and re-display the grid.
    Remember to refresh the t_row_no and t_index_rows tables if you load a new data set.
    You can also use a similar technique with the data_changed event to mark each changed row as selected by saving the row ids, and then you only have to update the changed rows on SAVE, which can minimize database I/O.
    Good luck.
    Brian

  • Control .swf from html

    Is there a way to control or communicate with a swf from
    outside of that swf. On my page Im loading an .swf and a separate
    layer with html. Can I create a link to tell the swf to load a
    movie?

    Funks Da Burn wrote:
    > Is there a way to control or communicate with a swf from
    outside of that swf. On my page Im loading an .swf and a separate
    layer with html. Can I create a link to tell the swf to load a
    movie?
    you are looking for LocalConnection
    google for "LocalConnection samples" or check the help files
    for details.
    Tho with all honesty, checking out samples is way more
    understandable than
    the attached help files.
    Best Regards
    Urami
    "Never play Leap-Frog with a Unicorn."
    <urami>
    If you want to mail me - DO NOT LAUGH AT MY ADDRESS
    </urami>

  • Want to control winamp from servlet

    hey pepole pls help me i want to control winap from a servlet
    i have used mpcontrol api in servlet but ist is not working
    i think a servlet cannnot acess the file outside the tomcat memory space plz some one help me so i can control the application which are ruunig on the same pc on which tomcat is instaled plz help me
    is there any change in tomcat by which we can we ca acess the other application

    Look I'll be blunt and direct, there are two reasons why your project is a bad idea in my opinion.
    1) java is not designed to do platform specific actions. Controlling winamp is highly platform specific. To do platform specific functions you need to rely on third party API's like the one you found and that may or may not work the way you want it to. Visual C# would be a better choice to do these kinds of windows specific projects simply because you have direct access to native libraries.
    2) the web was not designed to communicate, control or do anything with client applications and any project that tries to do something like this is a waste of time and effort if you ask me.
    If you really want to control winamp from a browser, install firefox and get a plugin that can do it. I know it exists.

  • How do i connect my time capsule from outside my home? i dont have static ip

    sorry about my english...
    its been 4 months now and still I am not able to connect my time capsule via internet from outside . i have read enough forums and discussion but i am confused because every discussion has different answer. please anyone can explain me the simplest way to configure my time capsule so i can connect it from other computers. i am using windows 7 64bit os.i am not advance user of networking so please explain me in detail.
    some questions.
    1. is it possible to use time capsule as nas using dynamic ip address?
    2. if yes how and where can i get exact detail about this.
    3. how to connect my time capsule form my iphone,ipad or other computers . connect through ip address or something else?
    4. is it any simple installation way to do this? i heard about bonjour and icloud but dont know how to connect through this.
    please help me
    thank you
    sachin

    i am using windows 7 64bit os.i am not advance user of networking so please explain me in detail.
    Here is your primary issue.. you cannot connect with win7 ..
    Windows only offers SMB protocol which just about every ISP.. all responsible ones ...block..
    Time Capule offers AFP to internet and only AFP.
    You need to use a Mac to connect.. then use BTMM and iCloud as there is no dyndns in the TC anyway. (Actually there is a dyndns but only for apple btmm use...  you cannot access.
    If you want to or have to use windows.. then get a proper vpn router that offers vpn endpoints to windows and has dyndns.. setup the TC in bridge behind the vpn router and access via vpn .. this is the only safe way of connecting using SMB.

  • Blocking access to file sharing (AFP/SMB) from outside of network

    Hello all,
    Is there a way to block access to file shares from outside of our LAN? I have a machine that has some sharing turned on (it is also my email server) and I can reach it across the internet and mount shares as if I was in the office.
    How can I block this access? Both SMB and AFP?
    Thank you,
    -John

    Justin, thank you for your reply. The machine is on a public ip address and is not behind a NAT router. I've turned on the software firewall and that is working now. However, I imagine it would be better to use a hardware firewall. Any suggestions on a good one? Thank you.

  • Why i cant access asa 8.4 thruogh asdm from outside interface ???

    hi all ,
    plz help e why i cant access asa asdm from outside interface
    my puclic ip on outisde is :
    x.x.55.34
    i changed  portf of asdm to 65000 because i have portforward  ,
    i tried to connect to my ip thriuogh asdm bu :
    x.x.55.34
    x.x.55.34:65000
    but no luck ,
    it succed if i try to connect locally
    here is my sh run command :
    ====================================================
    ASA5505#
    ASA5505# sh run
    : Saved
    ASA Version 8.4(2)
    hostname ASA5505
    enable password qsddsEGCCSH encrypted
    passwd 2KFsdsdbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    switchport access vlan 2
    interface Vlan1
    nameif ins
    security-level 100
    ip address 10.66.12.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 50
    ip address x.x.55.34 255.255.255.248
    boot system disk0:/asa842-k8.bin
    ftp mode passive
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network obj-0.0.0.0
    host 0.0.0.0
    object network localsubnet
    subnet 10.66.12.0 255.255.255.0
    description localsubnet
    object network HTTP-Host
    host 10.66.12.249
    description web server
    object network HTTPS-HOST
    host 10.66.12.249
    description Https
    object network RDP-Host
    host 10.66.12.122
    description RDP host
    object network citrix-host
    host 10.66.12.249
    description citrix
    object service rdp
    service tcp destination eq 3389
    object service https
    service tcp destination eq https
    object service citrix
    service tcp destination eq 2598
    object service http
    service tcp destination eq www
    object network RDP1
    host 10.66.12.249
    object network HTTPS-Host
    host 10.66.12.249
    object network CITRIX-Host
    host 10.66.12.249
    object-group network RDP-REDIRECT
    object-group network HTTP-REDIRECT
    object-group network HTTPS-REDIRECT
    object-group network CITRIX-ICA-HDX-REDIRECTION
    object-group network CITRIX-ICA-SESSION-RELIABILITY-REDIRECTION
    object-group service CITRIX-ICA-HDX
    object-group service CITRIX-SR
    object-group service RDP
    object-group network MY-insideNET
    network-object 10.66.12.0 255.255.255.0
    access-list outside_in extended permit tcp any host 10.66.12.249 eq www
    access-list outside_in extended permit tcp any host 10.66.12.249 eq https
    access-list outside_in extended permit tcp any host 10.66.12.249 eq 2598
    access-list outside_in extended permit tcp any host 10.66.12.122 eq 3389
    access-list outside_in extended permit tcp any host 10.66.12.249 eq citrix-ica
    access-list outside_in extended permit tcp any host x.x.55.34 eq 65000
    access-list outside_in extended permit tcp any host x.x.55.34 eq https
    access-list outside_in extended permit ip any any
    pager lines 24
    mtu ins 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-645.bin
    no asdm history enable
    arp timeout 14400
    object network localsubnet
    nat (ins,outside) dynamic interface
    object network HTTP-Host
    nat (ins,outside) static interface service tcp www www
    object network RDP-Host
    nat (ins,outside) static interface service tcp 3389 3389
    object network HTTPS-Host
    nat (ins,outside) static interface service tcp https https
    object network CITRIX-Host
    nat (ins,outside) static interface service tcp citrix-ica citrix-ica
    access-group outside_in in interface outside
    route outside 0.0.0.0 0.0.0.0 62.109.55.33 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable 65000
    http 10.66.12.0 255.255.255.0 ins
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
        308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
        0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
        30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
        13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
        0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
        20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
        65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
        65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
        30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
        30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
        496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
        74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
        68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
        3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
        63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
        0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
        a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
        9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
        7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
        15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
        63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
        18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
        4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
        81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
        db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
        7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
        ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
        45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
        2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
        1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
        03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
        69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
        02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
        6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
        c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
        69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
        1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
        551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
        1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
        2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
        4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
        b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
        6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
        481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
        b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
        5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
        6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
        6c2527b9 deb78458 c61f381e a4c4cb66
      quit
    telnet 0.0.0.0 0.0.0.0 outside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    management-access outside
    dhcpd address 10.66.12.160-10.66.12.180 ins
    dhcpd dns 212.112.166.22 212.112.166.18 interface ins
    dhcpd enable ins
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    username test password P4ttSdddd3SV8TYp encrypted privilege 15
    username ADMIN password 5dddd3ThngqY encrypted privilege 15
    username drvirus password p03BtCddddryePSDf encrypted privilege 15
    username cisco password edssdsdOAQcNEL encrypted privilege 15
    prompt hostname context
    call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DD
    CEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
    : end

    For access over VPN you need:
    management-access inside
    and don't forget:
    ssh inside
    http inside
    I'm guessing you forgot to grant ASDM (http/https) access to the IP addresses used by the VPN?  Can you SSH?  If not, that is your problem to solve first.

  • How to allow some fixed extension go in from outside to inside but not allow go from inside to outside

    how to allow some fixed extension go in from outside to inside but not allow go from inside to outside
    for example, allow JPEG, MOV, AVI data flow from outside to inside
    but not allow JPEG, MOV, AVI files access or upload or get by outside, in another words not from inside to outside
    how to configure?

    Hi,
    The ZBF link sent earlier show how we can inspect URI in http request
    parameter-map type regex uri_regex_cm
       pattern “.*cmd.exe”
    class-map type inspect http uri_check_cm
       match request uri regex uri_regex_cm
    ZBf is the feature on Cisco routers and ASA though concepts are little same but works differently. However it is important that you can be more granular with the protocol (layer 7) inspection only. Like on ASA if you will try to restrict .exe file from a p2p application that won't be possible, But on router you have some application for p2p in NBAR and you can use it file filtering. Please check configuartion example for both devices.
    Thanks

  • How can i call a plugin from outside of Acrobat Pro.?

    Hello All,
    Is it possible to call acrobat pro plugins from outside of Acrobat Pro.? I believe it is definitely possible.
    I am not able to get any pointers on this. Can someone suggest any pointers on this.
    Thanks.

    The plugins that come with Acrobat or custom ones that you write yourself?
    Custome ones. 
    Call them in what way?
    Through an executable. I mean from inside an exceutable.
    On what OS platform?
    Windows
    For what purpose?
    Just for fun Actually learning
    Thanks for the reply.

  • Access to Time Capsule in Bridge Mode from outside of the network

    I have a Time Capsule with an external hard drive set up in bridge mode on my home network. The main router and DHCP server is an Actiontec MI424, and is specific to my ISP (Verizon, required for TV Guide info from Fios) so the Time Capsule's AirPort can't be used as the primary. I need to access the external hard drive from outside my network (I.E. the internet), but I'm having trouble figuring out which ports are required for Sharepoint to work.
    So far I've forwarded 548, but I get an error "-36" when I try to connect from the outside. It works fine on the inside. Any suggestions?
    Thanks, JSD

    The Express units can extend wireless on the TC or each other.. but they cannot extend wireless on the Asus anyway..
    So the setup is Asus--TC (that has to be ethernet) The TC in bridge mode.
    Then TC -- express can be done by ethernet in roaming mode as bob listed above or extend wireless.
    I am guessing.. what model are the express units.. they are older Gen1 N model ??
    IMHO the TC is simply no longer viable.. replace it with one express as the AP and extend it with the other Express.. see if that works better.
    But I would be trying to use the wireless just from the AC66U.
    I would also force the Asus back to 20mhz on the 2.4ghz band.. so you can provide adequate channel separation.. 40mhz wireless on 2.4ghz works poorly anyway because you have too much wifi .. there is very limited number of non-overlapping channels.. ie 3. 11, 6 and 1.

Maybe you are looking for

  • Trying to backup my iphone4 from a new laptop

    Hey everyone!! I recently had my laptop stolen and i have no access to my previous itunes library, I just got a new macbook and I want to update to the latest software but i dont want to loose any data like my contacts, pictures, texts messages,notes

  • Changing background colour of W995 (when you don't have wallpaper)?

    Hello, If i set my phone to have no wallpaper the background colour for the main screen is grey.  Sorry if this is a dumb question, but does anyone know how to change this to black?  I think it was black to start with but somehow it got changed and I

  • How do I change MobileMe/iWeb member name?

    We registered the iWeb account on my computer in my husband's name because we thought we would use it for family purposes only. Recently, I have realized that I could better use this account for my work. Is there a way for me to change my MobileMe/iW

  • Changing PR request date

    Hi all, When we create a PR in the PR line item 'Quantities/Dates' tab the request date field gets the system date. i.e The date on which PR line item is created. Now let us take that a PR contains five line items. And I am creating the PR on 08/10/2

  • Displaying BLOB images from table in a report

    I am trying to upload images to a table, display them in a report afterwards. I have succeeded in the first part, but not in the second.<br> <br> I can display images in a report if they are in located in wwv_flow_file_objects$ where they are automat