DECODE-like behavior needed for substitution

Hi:
Problem: In the context of a single query, I need to transform a user specified wildcarded string to something standard to SQL. The user's idea of what wildcards are does not jive with SQL standards. In the mind of the users, '*' means "any string" (and that is easy enough to "translate" from '*' to '%'). But also underscore '_' means underscore, not "any single character", so that needs to be escaped. The problem is how to do that inside the context of a single SQL statement.
I believe I need to translate all occurances of '_' to something like '\_' after which I can "escape '\'". So, if the user inputs "ab_cd_ef*", it needs to become "ab\_cd\_cd%". I tried decode(str,'_','\_'), but that just comes up with a null a-la...
select decode('ab_cd','_','\_') from dual;
It sems to need to match the entire string 'ab_cd' in order for a translation to occur. Maybe I'm not using decode correctly or don't fully understand it.
"translate" seems to be good at substituting single chars with other single chars (like'*' becomes '%'), but I can't see how it can substitute a single '_' to the 2 chars '\_'.
Another viable solution would be to override how sql interprets wildcards. If I could tell the SQL interpreter to swap '*' and '%', and ignore '_' as being a wildcard alltogether, that would do the trick too.
Any idesa?
Thanks

try
SELECT REPLACE('ab_cd','_','\_') FROM dual;

Similar Messages

  • Better provisioning in Windows client: Remember templates for the Start Screen - like the need for categorization (taxonomy) in the Start Menu

    Better provisioning in Windows client: Remember templates for the Start Screen - like the need for categorization (taxonomy) in the Start Menu ...
    Like my previous suggestion about categories alike Linux to clean up the mess in the start menu:
    Please help new users to use the Start Screen in valuable way - demonstrate the value.
    You don't sell SharePoint with a completely unorded randomized site hierarchy - and without any templates.
    Not content - but abstract content like templates are everything when you need to learn to use ... i.e. a new product like the Start Screen. It gets you started right away. A like Word as well.
    Please bring order and form to the content. I.e. T E M P L A T E S parsing the layout of the tiles.
    Have context switching for virtualization working with the virtual desktop mode. So I only see those tiles that are in context with my actual workflow.
    Of course you would need a well-made taxonomy for apps - i.e. subclassed.

    Hello cor-el,
    Thanks for your help. The View > Zoom didn't work the first time, but I just tried it again on a couple of web pages and it works great!!
    Thanks again. Have a Great Day! You sure improved my attitude!
    You RocK!!!
    Best regards,
    Gael

  • Challenge: Spanning Tree Control Between 2 links from Switch DELL M6220 to 2 links towards 2 switches CISCO 3750 connected with an stack (behavior like one switch for redundancy)

    Hello,
    I have an Spanning tree problem when i conect  2 links from Switch DELL M6220 (there are blades to virtual machines too) to 2 links towards 2 switches CISCO 3750 connected with an stack (behavior  like one switch  for redundancy, with one IP of management)
    In dell virtual machine is Spanning tree rapid stp, and in 3750 is Spanning tree mode pvst, cisco says that this is not important, only is longer time to create the tree.
     I dont know but do you like this solutions i want to try on sunday?:
     Could Spanning tree needs to work to send one native vlan to negociate the bdpus? switchport trunk native vlan 250
    Is it better to put spanning-tree guard root in both 3750 in the ports to mitigate DELL to be root in Spanning Tree?
    Is it better to put spanning- tree port-priority in the ports of Swicht Dell?
    ¿could you help me to control the root? ¿Do you think its better another solution? thanks!
     CONFIG WITH PROBLEM
    ======================
    3750: (the 2 ports are of 2 switches 3750s conected with a stack cable, in a show run you can see this)
    interface GigabitEthernet2/0/28
     description VIRTUAL SNMP2
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 4,13,88,250
     switchport mode trunk
     switchport nonegotiate
     logging event trunk-status
     shutdown
    interface GigabitEthernet1/0/43
     description VIRTUAL SNMP1
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 4,13,88,250
     switchport mode trunk
     switchport nonegotiate
     shutdown
    DELL M6220: (its only one swith)
    interface Gi3/0/19
    switchport mode trunk
    switchport trunk allowed vlan 4,13,88,250
    exit
    interface Gi4/0/19
    switchport mode trunk
    switchport trunk allowed vlan 4,13,88,250
    exit

    F.Y.I for catylyst heroes - here is the equivalent config for SG-300 - Vlan1 is required on the allowed list on the catylyst side (3xxx/4xxx/6xxx)
    In this example:
    VLANS - Voice on 188, data on 57, management on 56.
    conf t
    hostname XXX-VOICE-SWXX
    no passwords complexity enable
    username xxxx priv 15 password XXXXX
    enable password xxxxxx
    ip ssh server
    ip telnet server
    crypto key generate rsa
    macro auto disabled
    voice vlan state auto-enabled !(otherwise one switch controls your voice vlan….)
    vlan 56,57,188
    voice vlan id 188
    int vlan 56
    ip address 10.230.56.12 255.255.255.0
    int vlan1
    no ip add dhcp
    ip default-gateway 10.230.56.1
    interface range GE1 - 2
    switchport mode trunk
    channel-group 1 mode auto
    int range fa1 - 24
    switchport mode trunk
    switchport trunk allowed vlan add 188
    switchport trunk native vlan 57
    qos advanced
    qos advanced ports-trusted
    exit
    int Po1
    switchport trunk allowed vlan add 56,57,188
    switchport trunk native vlan 1
    do sh interfaces switchport po1
    !CATYLYST SIDE
    !Must Explicitly allow VLan1, this is not normal for catalysts - or spanning tree will not work ! Even though it’s the native vlan on both sides.
    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,56,57,189
    switchport mode trunk

  • I have a box that will not go away, it says,  "To open JavaApplication, you need to install a Java SE 6 runtime.  Would you like to check for and install one?  If i push not now, it keeps popping up, if I push install, it says it's not available, help.

    I have a dialogue box that will not go away and it seems to have started when I upgraded to Mt. Lion.  the box says, "To open JavaApplication, you need to install a Java 6 SE runtime.  Would you like to check for and install one?  (smaller print)  Note: Usw of this software is subject to the Software License Agreement applicable to the software you are downloading.  A list of Apple SLAs may be found here: htp://www.apple.com/legal/sla/
    Finally there are two boxes to click.  One says not now.  If I click on that the box goes away for 2 to 3 seconds and then pops back up and WILL NOT go away.  If I click on the second box, Install, it says  The software is currently unavailable.  To install a Java SE 6 runtime later, open Java Application again.
    My confusion here is that I have no idea what the java application is, When I click "okay" on that box, the original box pops us again and WILL NOT go away. CGoing to the apple lega web site was no help.  My solution so far has been to drag the dialogue box as far to the lower right and out of the way as far as I can.  Help.

    Does this happen immediately after you log in? If so, one of your login items is probably causing it.

  • I can't download the apps with big size like need for spees, but in apps with normal size(less than 100KB)there is no problem,is there any body who can help me?

    I can't download the apps with big size like need for spees

    Have a little patience. 4 minutes is only a short time for someone to find your post and reply to it. Also clicking on "This Solved My Problem" marks your problem as solved so many folks that may otherwise help will pass the question by since it is "solved."
    I suggest you start a new question that gives a good title to a specific problem. Then in the body of the thread describe the problem in detail, tell us what steps you have tried so far to correct the problem, what happened, and what error messages you received.

  • I have an anatomy app on my iPad I would like to project for my class. What do I need to connect it to a projector?

    I have an anatomy app on my iPad I would like to project for my class. What do I need to connect it to a projector? Thanks.

    This should help:
    http://support.apple.com/kb/HT4108

  • Is there a software like flash player for ipad.what software do I exactly need in order to play videos from websites?

    Is there a software like flash player for ipad.what software do I exactly need in order to play videos from websites?

    NKafafi88-
    There may be a couple Apps that may help, but I understand they don't work very well.  The best solution would be to contact the owners of the websites and let them know they need to update their site.
    The alternative I use, is to download the problem video onto my computer, and convert it to M4V or MP4 format using a program like HandBrake <HandBrake>.  Then it can be added to iTunes and synced with the iPad.
    Fred

  • I want to start using the creative cloud programs but it has forced me to "start a trial" and looks like I need a redemption code to "license" the products on my computer for the next year. Where do I find or get this redemption code?

    I want to start using the creative cloud programs but it has forced me to "start a trial" and looks like I need a redemption code to "license" the products on my computer for the next year. Where do I find or get this redemption code?

    If you bought your subscription direct from Adobe, you should not need any codes, only your Adobe ID and password
    -Cloud programs do not use serial numbers... you log in to your paid Cloud account to download & install & activate... you MAY need to log out of the Cloud and restart your computer and log back in to the Cloud for things to work
    -Sign in help http://helpx.adobe.com/x-productkb/policy-pricing/account-password-sign-faq.html
    -http://helpx.adobe.com/creative-cloud/kb/sign-in-out-creative-cloud-desktop-app.html
    -http://helpx.adobe.com/x-productkb/policy-pricing/activation-network-issues.html
    -http://helpx.adobe.com/creative-suite/kb/trial--1-launch.html
    -Cloud Getting Started https://helpx.adobe.com/creative-cloud.html
    -Install, update or UNinstall, and launch after installing
    If you bought your subscription from some other vendor, ask that vendor for help
    -Redemption Code http://helpx.adobe.com/x-productkb/global/redemption-code-help.html

  • I'm in need for a thunderbolt display before December.  My old Imac is like new (don't want to invest in a new Imac yet).  Can I connect the thund-D to the old Imac via USB for the time being?

    I'm in need for a thunderbolt display before December.  My old Imac is like new (don't want to invest in a new Imac yet).  Can I connect the thund-D to the old Imac via USB for the time being?

    Their are some display adaptors you can get. I have an older Mac Pro with DVI but my monitor is a Thunderbolt Display. This used to be around $250. It is way cheaper now.
    http://www.bhphotovideo.com/bnh/controller/home?O=&sku=810627&Q=&is=REG&A=detail s

  • I downloaded ios 6 for my iPad 2 and some of the upgrades went through but not all. It sounds like I need to reinstall ios 6. How do you do that? Everytime I try to upgrade it says I'm already updated

    I downloaded ios 6 for my iPad 2 and some of the upgrades went through but not all. It sounds like I need to reinstall ios 6. How do you do that? Everytime I try to upgrade it says I'm already updated

    If you mean Siri then that is only on the iPad 3, it is not on the iPad 2 in iOS 6 (possibly because the iPad 2 doesn't have the Audience chip which the iPad 3 does). If there are other things that you think are missing (YouTube has been removed, and Passbooks is iPhone and iPod Touch only) ?

  • I just received my new 4gs  do I need to UPdate my phone by call *228 like I needed to for my LG touch

    I just received my new 4gs  do I need to UPdate my phone by call *228 like I needed to for my LG touch

    You need to activate it through itunes and then complete the *228, option 1 if you want.
    A word of note, if you have any saved voice mails on the old phone, they will be deleted since the iphone uses a different voice mail system and the old saved ones are not transferable.

  • I was given a 16Gb ipad mini retina with cellular but I need more storage. We do not have the receipt as it is a gift. I like to swap for a 64Gb unit and pay for the difference my self, how do I go about doing that? I have not open the packaging yet.

    I was given a 16Gb ipad mini retina with cellular but I need more storage. We do not have the receipt as it is a gift. I like to swap for a 64Gb unit and pay for the difference, how do I go about doing that? I have not open the packaging yet.

    Hi
    Thanks for that. Yes, the ipad was purchased recently. I called Apple last Friday and they ask for the receipt. I wonder if anyone were able to swap their ipad for a larger storage in the past at the apple store without a receipt? 16Gb is such a small storage.

  • Vendor Payment Method for Substitution in Invoice Document

    Hi,
    I would like to define a substitution to replace Payment Method Supplement(BSEG-UWAZE) if the vendor master defined with payment method is Cheque.
    I had copied RGGBS000 to ZRGGBS000.
    Now in ZFGGBS000 FORM Routine, I need to check for the payment method in the Vendor Master.
    Is this ZLSCH in BSEG table refering to the same value in the Vendor Master?
    If not, then what is the key to match between BSEG and the vendor master table in order for me to get the Payment Method from the vendor master?
    Appreciate helps. Thanks.

    Resolved

  • Which display driver package do I need for Nvidia Quadro NVS 110m?

    Hi there,
    I'm new to (Arch) Linux and was wondering which display driver package I need. I have a Dell Latitude D620 with a "nvidia quadro nvs 110m".
    In the Arch Linux beginners guide it says:
    1. nvidia-96xx slightly newer cards up to the GF 4.
    2. nvidia-173xx Geforce FX series cards
    3. nvidia newest GPUs after the GF FX
    Consult the NVIDIA-Homepage to see which one is for you.
    But on the NVIDIA-Homepage it says:
    The GeForce M series and GeForce Go series notebook GPUs use drivers that have been customized by the notebook manufacturers to support hot key functions, power management functions, lid close and suspend/resume behavior. NVIDIA has worked with some notebook manufacturers to provide notebook-specific driver updates, however, most notebook driver updates must come from the notebook manufacturer.
    And they just forward me to Dell Support which obviously neither offers a linux driver nor linux driver information for the D620.
    So which of the three packages do I have to install?
    Are these packages open-source drivers? Do I need proprietary nvidia drivers to get full 3D-performance?
    Does anybody have experience with the D620?
    Although I'm new to Linux and I like the KISS idea behind Arch Linux, I still want to have all that Compiz Fusion eye candy. I also want to play a few games which need 3D performance (once I'm familiar with wine). ;-)
    Thanks in advance for your help,
    Blackhole
    Last edited by blackhole (2008-12-14 10:22:05)

    Thanks a lot.
    Final question: How does Arch Linux deal with license issues? If the nvidia package includes the original nvidia drivers linked above, doesn't that cause any legal/moral problems? Like in Ubuntu for example they always point out that it's proprietary software you're gonna install when enabling the nvidia drivers.
    Just wondering...

  • Is virus protection need for the iMac, and if so, which product is recommended?

    Not sure about virus protection of the i Mac, any recommendations?

    Mac users often ask whether they should install "anti-virus" software. The answer usually given on ASC is "no." The answer is right, but it may give the wrong impression that there is no threat from what are loosely called "viruses." There  is a threat, and you need to educate yourself about it.
    1. This is a comment on what you should—and should not—do to protect yourself from malicious software ("malware") that circulates on the Internet and gets onto a computer as an unintended consequence of the user's actions. It does not apply to software, such as keystroke loggers, that may be installed deliberately by an intruder who has hands-on access to the computer, or who has been able to log in to it remotely. That threat is in a different category, and there's no easy way to defend against it.
    The comment is long because the issue is complex. The key points are in sections 5, 6, and 10.
    OS X now implements three layers of built-in protection specifically against malware, not counting runtime protections such as execute disable, sandboxing, system library randomization, and address space layout randomization that may also guard against other kinds of exploits.
    2. All versions of OS X since 10.6.7 have been able to detect known Mac malware in downloaded files, and to block insecure web plugins. This feature is transparent to the user. Internally Apple calls it "XProtect."
    The malware recognition database used by XProtect is automatically updated; however, you shouldn't rely on it, because the attackers are always at least a day ahead of the defenders.
    The following caveats apply to XProtect:
    ☞ It can be bypassed by some third-party networking software, such as BitTorrent clients and Java applets.
    ☞ It only applies to software downloaded from the network. Software installed from a CD or other media is not checked.
    As new versions of OS X are released, it's not clear whether Apple will indefinitely continue to maintain the XProtect database of older versions such as 10.6. The security of obsolete system versions may eventually be degraded. Security updates to the code of obsolete systems will stop being released at some point, and that may leave them open to other kinds of attack besides malware.
    3. Starting with OS X 10.7.5, there has been a second layer of built-in malware protection, designated "Gatekeeper" by Apple. By default, applications and Installer packages downloaded from the network will only run if they're digitally signed by a developer with a certificate issued by Apple. Software certified in this way hasn't necessarily been tested by Apple, but you can be reasonably sure that it hasn't been modified by anyone other than the developer. His identity is known to Apple, so he could be held legally responsible if he distributed malware. That may not mean much if the developer lives in a country with a weak legal system (see below.)
    Gatekeeper doesn't depend on a database of known malware. It has, however, the same limitations as XProtect, and in addition the following:
    ☞ It can easily be disabled or overridden by the user.
    ☞ A malware attacker could get control of a code-signing certificate under false pretenses, or could simply ignore the consequences of distributing codesigned malware.
    ☞ An App Store developer could find a way to bypass Apple's oversight, or the oversight could fail due to human error.
    Apple has so far failed to revoke the codesigning certificates of some known abusers, thereby diluting the value of Gatekeeper and the Developer ID program. These failures don't involve App Store products, however.
    For the reasons given, App Store products, and—to a lesser extent—other applications recognized by Gatekeeper as signed, are safer than others, but they can't be considered absolutely safe. "Sandboxed" applications may prompt for access to private data, such as your contacts, or for access to the network. Think before granting that access. Sandbox security is based on user input. Never click through any request for authorization without thinking.
    4. Starting with OS X 10.8.3, a third layer of protection has been added: a "Malware Removal Tool" (MRT). MRT runs automatically in the background when you update the OS. It checks for, and removes, malware that may have evaded the other protections via a Java exploit (see below.) MRT also runs when you install or update the Apple-supplied Java runtime (but not the Oracle runtime.) Like XProtect, MRT is effective against known threats, but not against unknown ones. It notifies you if it finds malware, but otherwise there's no user interface to MRT.
    5. The built-in security features of OS X reduce the risk of malware attack, but they are not, and never will be, complete protection. Malware is foremost a problem of human behavior, and no technological fix alone is going to solve it. Trusting software to protect you will only make you more vulnerable.
    The best defense is always going to be your own intelligence. With the possible exception of Java exploits, all known malware circulating on the Internet that affects a fully-updated installation of OS X 10.6 or later takes the form of so-called "Trojan horses," which can only have an effect if the victim is duped into running them. The threat therefore amounts to a battle of wits between you and Internet criminals. If you're better informed than they think you are, you'll win. That means, in practice, that you always stay within a safe harbor of computing practices. How do you know when you're leaving the safe harbor? Below are some warning signs of danger.
    Software from an untrustworthy source
    ☞ Software of any kind is distributed via BitTorrent, or Usenet, or on a website that also distributes pirated music or movies.
    ☞ Software with a corporate brand, such as Adobe Flash Player, doesn't come directly from the developer’s website. Do not trust an alert from any website to update Flash, or your browser, or any other software.
    ☞ Rogue websites such as Softonic, Soft32, and CNET Download distribute free applications that have been packaged in a superfluous "installer."
    ☞ The software is advertised by means of spam or intrusive web ads. Any ad, on any site, that includes a direct link to a download should be ignored.
    Software that is plainly illegal or does something illegal
    ☞ High-priced commercial software such as Photoshop is "cracked" or "free."
    ☞ An application helps you to infringe copyright, for instance by circumventing the copy protection on commercial software, or saving streamed media for reuse without permission. All "YouTube downloaders" are in this category, though not all are necessarily malicious.
    Conditional or unsolicited offers from strangers
    ☞ A telephone caller or a web page tells you that you have a “virus” and offers to help you remove it. (Some reputable websites did legitimately warn visitors who were infected with the "DNSChanger" malware. That exception to this rule no longer applies.)
    ☞ A web site offers free content such as video or music, but to use it you must install a “codec,” “plug-in,” "player," "downloader," "extractor," or “certificate” that comes from that same site, or an unknown one.
    ☞ You win a prize in a contest you never entered.
    ☞ Someone on a message board such as this one is eager to help you, but only if you download an application of his choosing.
    ☞ A "FREE WI-FI !!!" network advertises itself in a public place such as an airport, but is not provided by the management.
    ☞ Anything online that you would expect to pay for is "free."
    Unexpected events
    ☞ A file is downloaded automatically when you visit a web page, with no other action on your part. Delete any such file without opening it.
    ☞ You open what you think is a document and get an alert that it's "an application downloaded from the Internet." Click Cancel and delete the file. Even if you don't get the alert, you should still delete any file that isn't what you expected it to be.
    ☞ An application does something you don't expect, such as asking for permission to access your contacts, your location, or the Internet for no obvious reason.
    ☞ Software is attached to email that you didn't request, even if it comes (or seems to come) from someone you trust.
    I don't say that leaving the safe harbor just once will necessarily result in disaster, but making a habit of it will weaken your defenses against malware attack. Any of the above scenarios should, at the very least, make you uncomfortable.
    6. Java on the Web (not to be confused with JavaScript, to which it's not related, despite the similarity of the names) is a weak point in the security of any system. Java is, among other things, a platform for running complex applications in a web page, on the client. That was always a bad idea, and Java's developers have proven themselves incapable of implementing it without also creating a portal for malware to enter. Past Java exploits are the closest thing there has ever been to a Windows-style virus affecting OS X. Merely loading a page with malicious Java content could be harmful.
    Fortunately, client-side Java on the Web is obsolete and mostly extinct. Only a few outmoded sites still use it. Try to hasten the process of extinction by avoiding those sites, if you have a choice. Forget about playing games or other non-essential uses of Java.
    Java is not included in OS X 10.7 and later. Discrete Java installers are distributed by Apple and by Oracle (the developer of Java.) Don't use either one unless you need it. Most people don't. If Java is installed, disable it—not JavaScript—in your browsers.
    Regardless of version, experience has shown that Java on the Web can't be trusted. If you must use a Java applet for a task on a specific site, enable Java only for that site in Safari. Never enable Java for a public website that carries third-party advertising. Use it only on well-known, login-protected, secure websites without ads. In Safari 6 or later, you'll see a lock icon in the left side of the address bar when visiting a secure site.
    Stay within the safe harbor, and you’ll be as safe from malware as you can practically be. The rest of this comment concerns what you should not do to protect yourself.
    7. Never install any commercial "anti-virus" (AV) or "Internet security" products for the Mac, as they are all worse than useless. If you need to be able to detect Windows malware in your files, use one of the free security apps in the Mac App Store—nothing else.
    Why shouldn't you use commercial AV products?
    ☞ To recognize malware, the software depends on a database of known threats, which is always at least a day out of date. This technique is a proven failure, as a major AV software vendor has admitted. Most attacks are "zero-day"—that is, previously unknown. Recognition-based AV does not defend against such attacks, and the enterprise IT industry is coming to the realization that traditional AV software is worthless.
    ☞ Its design is predicated on the nonexistent threat that malware may be injected at any time, anywhere in the file system. Malware is downloaded from the network; it doesn't materialize from nowhere. In order to meet that nonexistent threat, commercial AV software modifies or duplicates low-level functions of the operating system, which is a waste of resources and a common cause of instability, bugs, and poor performance.
    ☞ By modifying the operating system, the software may also create weaknesses that could be exploited by malware attackers.
    ☞ Most importantly, a false sense of security is dangerous.
    8. An AV product from the App Store, such as "ClamXav," has the same drawback as the commercial suites of being always out of date, but it does not inject low-level code into the operating system. That doesn't mean it's entirely harmless. It may report email messages that have "phishing" links in the body, or Windows malware in attachments, as infected files, and offer to delete or move them. Doing so will corrupt the Mail database. The messages should be deleted from within the Mail application.
    An AV app is not needed, and cannot be relied upon, for protection against OS X malware. It's useful, if at all, only for detecting Windows malware, and even for that use it's not really effective, because new Windows malware is emerging much faster than OS X malware.
    Windows malware can't harm you directly (unless, of course, you use Windows.) Just don't pass it on to anyone else. A malicious attachment in email is usually easy to recognize by the name alone. An actual example:
    London Terror Moovie.avi [124 spaces] Checked By Norton Antivirus.exe
    You don't need software to tell you that's a Windows trojan. Software may be able to tell you which trojan it is, but who cares? In practice, there's no reason to use recognition software unless an organizational policy requires it. Windows malware is so widespread that you should assume it's in every email attachment until proven otherwise. Nevertheless, ClamXav or a similar product from the App Store may serve a purpose if it satisfies an ill-informed network administrator who says you must run some kind of AV application. It's free and it won't handicap the system.
    The ClamXav developer won't try to "upsell" you to a paid version of the product. Other developers may do that. Don't be upsold. For one thing, you should not pay to protect Windows users from the consequences of their choice of computing platform. For another, a paid upgrade from a free app will probably have all the disadvantages mentioned in section 7.
    9. It seems to be a common belief that the built-in Application Firewall acts as a barrier to infection, or prevents malware from functioning. It does neither. It blocks inbound connections to certain network services you're running, such as file sharing. It's disabled by default and you should leave it that way if you're behind a router on a private home or office network. Activate it only when you're on an untrusted network, for instance a public Wi-Fi hotspot, where you don't want to provide services. Disable any services you don't use in the Sharing preference pane. All are disabled by default.
    10. As a Mac user, you don't have to live in fear that your computer may be infected every time you install software, read email, or visit a web page. But neither can you assume that you will always be safe from exploitation, no matter what you do. Navigating the Internet is like walking the streets of a big city. It's as safe or as dangerous as you choose to make it. The greatest harm done by security software is precisely its selling point: it makes people feel safe. They may then feel safe enough to take risks from which the software doesn't protect them. Nothing can lessen the need for safe computing practices.

Maybe you are looking for