Developers Toolbox: MX Send Email php script generator

Hi,
I read Foundation PHP for Dreamweaver 8 (I have CS4
Dreamweaver but it’s still a good book).
In it, the author claims, that InterAKT has a product called
“MX Send Email” in the MX Kollection 3 suite of
Dreamweaver extensions, which automates the process of writing the
php script to process and send web email form data from forms
created in Dreamweaver, to the mail server. I went to their site
and it re directs to Adobe, and Adobe claims that they acquired
InterAKT a few years ago and included the above product in the
Developers Toolbox.
I downloaded the developers toolbox yesterday and for the
life of me I can’t figure out where I could find it or how it
works, it's very frustrating. Which makes me wonder if I should
plunk down an extra 300 bucks for the developers toolbox,
documentation is spotty at best – I can’t find any
books or discussion forums on the developers toolbox on how to use
this feature in the dev toolbox. No one seems to know anything
about it on the Extensions forum. Can someone give me some info
about this?
It seems to me there should be a simple way to generate some
PHP script for feedback forms created in Dreamweaver, especially
with the Developers toolkit.My other alternative is to buy a third
party extension to generate the scripts for 30 bucks, but if the
toolkit has it somewhere, where is the documentation or tutorial on
the adobe web site (which I dug for almost all day yesterday?
The Dev Toolkit has an option to insert a Captcha image so I
assume it's possible to do that too...
Or, Are there any on line tutorials which instruct on how to
create an email "Contact Us" form with Dreamweaver 4, which
includes info on writing the php script to process form data and
send it to mail server? If so can anyone direct me to it? Adobe has
one for Dreamweaver CS 3 on their site - but even that section of
the adobe site is not updated for CS4 and the tutorial even claims
that the Developers toolbox is not yet compatible with DW CS4 yet,
which contradicts the system requirements for the Dev Toolbox when
one downloads it.

Mr. Powers,
Thanks for the info! BTW I really enjoyed reading your book a
few years ago, it really helped me to learn Dreamweaver back then.
I’m quite rusty now and trying to get back up to speed after
not using it for a few years. Sorry to hear about the ADDT thingy.
Thanks for the thread DWFAQ.info, I bookmarked the threads
and will read them over the weekend. Thanks for the Dreamweaver
Developer Toolbox link too! I had no idea that there was a Dev
toolbox forum I was looking for it on the adobe site for two days,
now I just noticed it has been included on the main index page, I
don’t think it was posted there yesterday but maybe I missed
it.
Does anyone know if there are any books possibly in the works
or being planned for the toolbox?
Also I’m kind of curious now, are the mixed feelings
about the toolbox because it (appears but I’m no expert), to
be a bit less user friendly for the average web designer? Either
that or just not enough documentation yet?
I had never heard about the toolbox until I bought my CS4
suite a few weeks ago. From above -
quote:
"what has now become Adobe Dreamweaver Developer Toolbox"
- what
was the toolbox? Is the toolbox the former InterAKT suite or
extensions? Or was it a mix of theirs and/or other extension
authors stuff? Did adobe buy up a few companies and add their own
stuff to it and market it as the toolbox?
When was the toolbox first released? Recently? Did Adobe
create it out of the merger with InterAkt? I’ve been out of
the web design loop for a few years, just trying to catch up on
what’s been going on lately.

Similar Messages

  • Help downgrade a php script generated by FB back to the old Mysql way

    hey all
    i am a Flex developer who has written server side stuff with php scripts that were auto-generated by Flash Builder. These scripts use the Mysqli extention, which is not avilable on my shared hosting server. These scripts implement simple CRUD functions to a MySql database. Anyone who has used the data wizard will recognize these scripts.
    Just before i pay more bucks and move to a VPS server in order to enable Mysqli, is there anyone out there who can help me translate this script BACK to the old mysql way?
    much appriciated, Saar
    <?php
    class ClientService {
        var $username = "******";
        var $password = "******";
        var $server = "localhost";
        var $port = "3306";
        var $databasename = "rtdbcbx_saar";
        var $tablename = "clients";
        var $connection;
         * The constructor initializes the connection to database. Everytime a request is
         * received by Zend AMF, an instance of the service class is created and then the
         * requested method is invoked.
        public function __construct() {
            $this->connection = mysqli_connect(
                                    $this->server, 
                                    $this->username, 
                                    $this->password,
                                    $this->databasename,
                                    $this->port
            $this->throwExceptionOnError($this->connection);
         * Returns all the rows from the table.
         * Add authroization or any logical checks for secure access to your data
         * @return array
        public function getAllClient() {
            $stmt = mysqli_prepare($this->connection, "SELECT * FROM $this->tablename");       
            $this->throwExceptionOnError();
            mysqli_stmt_execute($stmt);
            $this->throwExceptionOnError();
            $rows = array();
            mysqli_stmt_bind_result($stmt, $row->ClientID, $row->First, $row->Last, $row->Phone, $row->Email, $row->Chain, $row->Branch, $row->Kiosk, $row->SubmitDate);
            while (mysqli_stmt_fetch($stmt)) {
              $row->SubmitDate = new DateTime($row->SubmitDate);
              $rows[] = $row;
              $row = new stdClass();
              mysqli_stmt_bind_result($stmt, $row->ClientID, $row->First, $row->Last, $row->Phone, $row->Email, $row->Chain, $row->Branch, $row->Kiosk, $row->SubmitDate);
            mysqli_stmt_free_result($stmt);
            mysqli_close($this->connection);
            return $rows;
         * Returns the item corresponding to the value specified for the primary key.
         * Add authorization or any logical checks for secure access to your data
         * @return stdClass
        public function getClientByID($itemID) {
            $stmt = mysqli_prepare($this->connection, "SELECT * FROM $this->tablename where ClientID=?");
            $this->throwExceptionOnError();
            mysqli_stmt_bind_param($stmt, 'i', $itemID);       
            $this->throwExceptionOnError();
            mysqli_stmt_execute($stmt);
            $this->throwExceptionOnError();
            mysqli_stmt_bind_result($stmt, $row->ClientID, $row->First, $row->Last, $row->Phone, $row->Email, $row->Chain, $row->Branch, $row->Kiosk, $row->SubmitDate);
            if(mysqli_stmt_fetch($stmt)) {
              $row->SubmitDate = new DateTime($row->SubmitDate);
              return $row;
            } else {
              return null;
         * Returns the item corresponding to the value specified for the primary key.
         * Add authorization or any logical checks for secure access to your data
         * @return stdClass
        public function createClient($item) {
            $stmt = mysqli_prepare($this->connection, "INSERT INTO $this->tablename (First, Last, Phone, Email, Chain, Branch, Kiosk, SubmitDate) VALUES (?, ?, ?, ?, ?, ?, ?, ?)");
            $this->throwExceptionOnError();
            mysqli_stmt_bind_param($stmt, 'ssssssss', $item->First, $item->Last, $item->Phone, $item->Email, $item->Chain, $item->Branch, $item->Kiosk, $item->SubmitDate->toString('YYYY-MM-dd HH:mm:ss'));
            $this->throwExceptionOnError();
            mysqli_stmt_execute($stmt);    
            $this->throwExceptionOnError();
            $autoid = mysqli_stmt_insert_id($stmt);
            mysqli_stmt_free_result($stmt);    
            mysqli_close($this->connection);
            return $autoid;
         * Updates the passed item in the table.
         * Add authorization or any logical checks for secure access to your data
         * @param stdClass $item
         * @return void
        public function updateClient($item) {
            $stmt = mysqli_prepare($this->connection, "UPDATE $this->tablename SET First=?, Last=?, Phone=?, Email=?, Chain=?, Branch=?, Kiosk=?, SubmitDate=? WHERE ClientID=?");     
            $this->throwExceptionOnError();
            mysqli_stmt_bind_param($stmt, 'ssssssssi', $item->First, $item->Last, $item->Phone, $item->Email, $item->Chain, $item->Branch, $item->Kiosk, $item->SubmitDate->toString('YYYY-MM-dd HH:mm:ss'), $item->ClientID);     
            $this->throwExceptionOnError();
            mysqli_stmt_execute($stmt);    
            $this->throwExceptionOnError();
            mysqli_stmt_free_result($stmt);    
            mysqli_close($this->connection);
         * Deletes the item corresponding to the passed primary key value from
         * the table.
         * Add authorization or any logical checks for secure access to your data
         * @return void
        public function deleteClient($itemID) {
            $stmt = mysqli_prepare($this->connection, "DELETE FROM $this->tablename WHERE ClientID = ?");
            $this->throwExceptionOnError();
            mysqli_stmt_bind_param($stmt, 'i', $itemID);
            mysqli_stmt_execute($stmt);
            $this->throwExceptionOnError();
            mysqli_stmt_free_result($stmt);    
            mysqli_close($this->connection);
         * Returns the number of rows in the table.
         * Add authorization or any logical checks for secure access to your data
        public function count() {
            $stmt = mysqli_prepare($this->connection, "SELECT COUNT(*) AS COUNT FROM $this->tablename");
            $this->throwExceptionOnError();
            mysqli_stmt_execute($stmt);
            $this->throwExceptionOnError();
            mysqli_stmt_bind_result($stmt, $rec_count);
            $this->throwExceptionOnError();
            mysqli_stmt_fetch($stmt);
            $this->throwExceptionOnError();
            mysqli_stmt_free_result($stmt);
            mysqli_close($this->connection);
            return $rec_count;
         * Returns $numItems rows starting from the $startIndex row from the
         * table.
         * Add authorization or any logical checks for secure access to your data
         * @return array
        public function getClient_paged($startIndex, $numItems) {
            $stmt = mysqli_prepare($this->connection, "SELECT * FROM $this->tablename LIMIT ?, ?");
            $this->throwExceptionOnError();
            mysqli_stmt_bind_param($stmt, 'ii', $startIndex, $numItems);
            mysqli_stmt_execute($stmt);
            $this->throwExceptionOnError();
            $rows = array();
            mysqli_stmt_bind_result($stmt, $row->ClientID, $row->First, $row->Last, $row->Phone, $row->Email, $row->Chain, $row->Branch, $row->Kiosk, $row->SubmitDate);
            while (mysqli_stmt_fetch($stmt)) {
              $row->SubmitDate = new DateTime($row->SubmitDate);
              $rows[] = $row;
              $row = new stdClass();
              mysqli_stmt_bind_result($stmt, $row->ClientID, $row->First, $row->Last, $row->Phone, $row->Email, $row->Chain, $row->Branch, $row->Kiosk, $row->SubmitDate);
            mysqli_stmt_free_result($stmt);    
            mysqli_close($this->connection);
            return $rows;
         * Utility function to throw an exception if an error occurs
         * while running a mysql command.
        private function throwExceptionOnError($link = null) {
            if($link == null) {
                $link = $this->connection;
            if(mysqli_error($link)) {
                $msg = mysqli_errno($link) . ": " . mysqli_error($link);
                throw new Exception('MySQL Error - '. $msg);
    ?>

    hello derekmosdell, in case this question isn't related to volume of media content in firefox in particular, we probably won't be able to answer that. please refer to apple's support resources or discussion fora instead.
    thank you for your understanding!

  • Help with code to send to PHP script

    For some reason my ActionScript code isn't working correctly. Would someone please tell me if this looks valid to send to a php processing script?
    var submitListener:Object = new Object();
    submitListener.click = function(evt:Object) {
    fname2 = fname.text;
    lname2 = lname.text;
    var send_lv:LoadVars = new LoadVars();
    send_lv.fname = fname.text;
    send_lv.lname = lname.text;
    send_lv.email = email.text;
    send_lv.dept = dept.text;
    send_lv.campus = campus.text;
    send_lv.uaid = uaid.text;
    send_lv.phone = phone.text;
    send_lv.send("process.php", _self, "POST");
    gotoAndStop("certificate");
    thanks!
    -sage

    that's not valid.
    try:
    var submitListener:Object = new Object();
    submitListener.click = function(evt:Object) {
    fname2 = fname.text;
    lname2 = lname.text;
    var receive_lv:LoadVars=new LoadVars()
    var send_lv:LoadVars = new LoadVars();
    send_lv.fname = fname.text;
    send_lv.lname = lname.text;
    send_lv.email = email.text;
    send_lv.dept = dept.text;
    send_lv.campus = campus.text;
    send_lv.uaid = uaid.text;
    send_lv.phone = phone.text;
    send_lv.send("process.php", receive_lv, "POST");
    gotoAndStop("certificate");

  • Sending Email from Script

    I am trying to send an email from a script when no agents are logged in. I think I have everything configured correctly but each time I test the script I on the send email step it times out and goes to the unsuccessful branch (so obviously I am not doing something right). I have tested via telnet that the email server is answering.
    In my script I have 2 steps set up under the true branch of no agents logged in:
    emailContact set is set with  the subject "test", the body is set with "testing 1 2", and the emailContact is set with a variable named emailContact which is set as a contact and set to null.
    the second step set is the sendeMail step and it is set with eMailContact set with varialbe emailContact, From is set with "shawnee" and to is set with my email address.
    Am I missing or setting up one of those steps wrong?
    thanks for your help!! 

    try from as an actual email address, not just a name.
    If its not fixed by tonight when I get home, load up your script and take a look.
    Glad I was able to fix part of your issue
    HTH, rate if helpful
    Chad

  • SMC 3.6 Cannot  send email alarm

    Dear All ,
    I just try SMC 3.6 ,on the server i am configure sendmail and test send email working fine ,but when i try attribut set to send email outside ,script email.sh not send alarm notify to send out email , i try also email to localhost smc server but not yet working ? any idea ?
    regards
    hadi

    Hi Hadi,
    The Release Notes say the "usermod" command listed in your URL may not work: maybe you can make the file changes by hand?:
    http://docs.sun.com/app/docs/doc/817-7553/6mms6q1ia?a=view
    Regards,
    [email protected]

  • Webserver on DMZ cannot send email via php script using SMTP (cisco firewall pix 515e)

    Hello,
    I have two web servers that are sitting in a DMZ behind a Cisco Firewall PIX 515e. The webservers appear to be configured correctly as our website and FTP website are up. On two of our main website, we have two contact forms that use a simple html for to call a php script that uses smtp as its mailing protocol. Since, I am not the network administrator, I don't quite understand how to  read the current configurations on the firewall, but I suspect that port 25 is blocked, which prevents the script from actually working or sending out emails.  What I've done to narrow the problem done is the following: I used a wamp server to test our scripts with our smtp servers settings, was able to successfully send an email out to both my gmail and work place accounts. Currently, we have backupexec loaded on both of these servers, and when I try to send out an alert I never receive it. I think because port 25 is closed on both of those servers.  I will be posting our configuration. if anyone can take a look and perhaps explain to me how I can change our webservers to communicate and successfully deliver mail via that script, I would gladly appreciate it. our IP range is 172.x.x.x, but it looks like our webservers are using 192.x.x.x with NAT in place. Please someone help.
    Thanks,
    Jeff Mateo
    PIX Version 6.3(4)
    interface ethernet0 100full
    interface ethernet1 100full
    interface ethernet2 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 DMZ security50
    enable password GFO9OSBnaXE.n8af encrypted
    passwd GFO9OSBnaXE.n8af encrypted
    hostname morrow-pix-ct
    domain-name morrowco.com
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    no fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 12.42.47.27 LI-PIX
    name 172.20.0.0 CT-NET
    name 172.23.0.0 LI-NET
    name 172.22.0.0 TX-NET
    name 172.25.0.0 NY-NET
    name 192.168.10.0 CT-DMZ-NET
    name 1.1.1.1 DHEC_339849.ATI__LEC_HCS722567SN
    name 1.1.1.2 DHEC_339946.ATI__LEC_HCS722632SN
    name 199.191.128.105 web-dns-1
    name 12.127.16.69 web-dns-2
    name 12.3.125.178 NY-PIX
    name 64.208.123.130 TX-PIX
    name 24.38.31.80 CT-PIX
    object-group network morrow-net
    network-object 12.42.47.24 255.255.255.248
    network-object NY-PIX 255.255.255.255
    network-object 64.208.123.128 255.255.255.224
    network-object 24.38.31.64 255.255.255.224
    network-object 24.38.35.192 255.255.255.248
    object-group service morrow-mgmt tcp
    port-object eq 3389
    port-object eq telnet
    port-object eq ssh
    object-group network web-dns
    network-object web-dns-1 255.255.255.255
    network-object web-dns-2 255.255.255.255
    access-list out1 permit icmp any any echo-reply
    access-list out1 permit icmp object-group morrow-net any
    access-list out1 permit tcp any host 12.193.192.132 eq ssh
    access-list out1 permit tcp any host CT-PIX eq ssh
    access-list out1 permit tcp any host 24.38.31.72 eq smtp
    access-list out1 permit tcp any host 24.38.31.72 eq https
    access-list out1 permit tcp any host 24.38.31.72 eq www
    access-list out1 permit tcp any host 24.38.31.70 eq www
    access-list out1 permit tcp any host 24.38.31.93 eq www
    access-list out1 permit tcp any host 24.38.31.93 eq https
    access-list out1 permit tcp any host 24.38.31.93 eq smtp
    access-list out1 permit tcp any host 24.38.31.93 eq ftp
    access-list out1 permit tcp any host 24.38.31.93 eq domain
    access-list out1 permit tcp any host 24.38.31.94 eq www
    access-list out1 permit tcp any host 24.38.31.94 eq https
    access-list out1 permit tcp any host 24.38.31.71 eq www
    access-list out1 permit tcp any host 24.38.31.71 eq 8080
    access-list out1 permit tcp any host 24.38.31.71 eq 8081
    access-list out1 permit tcp any host 24.38.31.71 eq 8090
    access-list out1 permit tcp any host 24.38.31.69 eq ssh
    access-list out1 permit tcp any host 24.38.31.94 eq ftp
    access-list out1 permit tcp any host 24.38.31.92 eq 8080
    access-list out1 permit tcp any host 24.38.31.92 eq www
    access-list out1 permit tcp any host 24.38.31.92 eq 8081
    access-list out1 permit tcp any host 24.38.31.92 eq 8090
    access-list out1 permit tcp any host 24.38.31.93 eq 3389
    access-list out1 permit tcp any host 24.38.31.92 eq https
    access-list out1 permit tcp any host 24.38.31.70 eq https
    access-list out1 permit tcp any host 24.38.31.74 eq www
    access-list out1 permit tcp any host 24.38.31.74 eq https
    access-list out1 permit tcp any host 24.38.31.74 eq smtp
    access-list out1 permit tcp any host 24.38.31.75 eq https
    access-list out1 permit tcp any host 24.38.31.75 eq www
    access-list out1 permit tcp any host 24.38.31.75 eq smtp
    access-list out1 permit tcp any host 24.38.31.70 eq smtp
    access-list out1 permit tcp any host 24.38.31.94 eq smtp
    access-list dmz1 permit icmp any any echo-reply
    access-list dmz1 deny ip any 10.0.0.0 255.0.0.0
    access-list dmz1 deny ip any 172.16.0.0 255.240.0.0
    access-list dmz1 deny ip any 192.168.0.0 255.255.0.0
    access-list dmz1 permit ip any any
    access-list dmz1 deny ip any any
    access-list nat0 permit ip CT-NET 255.255.0.0 192.168.220.0 255.255.255.0
    access-list nat0 permit ip host 172.20.8.2 host 172.23.0.2
    access-list nat0 permit ip CT-NET 255.255.0.0 LI-NET 255.255.0.0
    access-list nat0 permit ip CT-NET 255.255.0.0 NY-NET 255.255.0.0
    access-list nat0 permit ip CT-NET 255.255.0.0 TX-NET 255.255.0.0
    access-list vpn-split-tun permit ip CT-NET 255.255.0.0 192.168.220.0 255.255.255
    .0
    access-list vpn-split-tun permit ip CT-DMZ-NET 255.255.255.0 192.168.220.0 255.2
    55.255.0
    access-list vpn-dyn-match permit ip any 192.168.220.0 255.255.255.0
    access-list vpn-ct-li-gre permit gre host 172.20.8.2 host 172.23.0.2
    access-list vpn-ct-ny permit ip CT-NET 255.255.0.0 NY-NET 255.255.0.0
    access-list vpn-ct-ny permit ip CT-DMZ-NET 255.255.255.0 NY-NET 255.255.0.0
    access-list vpn-ct-tx permit ip CT-NET 255.255.0.0 TX-NET 255.255.0.0
    access-list vpn-ct-tx permit ip CT-DMZ-NET 255.255.255.0 TX-NET 255.255.0.0
    access-list static-dmz-to-ct-2 permit ip host 192.168.10.141 CT-NET 255.255.248.
    0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 192.168.220.0 255.255.25
    5.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 LI-NET 255.255.0.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 NY-NET 255.255.0.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 TX-NET 255.255.0.0
    access-list static-dmz-to-ct-1 permit ip host 192.168.10.140 CT-NET 255.255.248.
    0
    access-list static-dmz-to-li-1 permit ip CT-DMZ-NET 255.255.255.0 CT-NET 255.255
    .248.0
    access-list vpn-ct-li permit ip CT-NET 255.255.0.0 LI-NET 255.255.0.0
    access-list vpn-ct-li permit ip CT-DMZ-NET 255.255.255.0 LI-NET 255.255.0.0
    access-list vpn-ct-li permit ip host 10.10.2.2 host 10.10.1.1
    access-list in1 permit tcp host 172.20.1.21 any eq smtp
    access-list in1 permit tcp host 172.20.1.20 any eq smtp
    access-list in1 deny tcp any any eq smtp
    access-list in1 permit ip any any
    access-list in1 permit tcp any any eq smtp
    access-list cap4 permit ip host 172.20.1.82 host 192.168.220.201
    access-list cap2 permit ip host 172.20.1.82 192.168.220.0 255.255.255.0
    access-list in2 deny ip host 172.20.1.82 any
    access-list in2 deny ip host 172.20.1.83 any
    access-list in2 permit ip any any
    pager lines 43
    logging on
    logging timestamp
    logging buffered notifications
    logging trap notifications
    logging device-id hostname
    logging host inside 172.20.1.22
    mtu outside 1500
    mtu inside 1500
    mtu DMZ 1500
    ip address outside CT-PIX 255.255.255.224
    ip address inside 172.20.8.1 255.255.255.0
    ip address DMZ 192.168.10.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool ctpool 192.168.220.100-192.168.220.200
    ip local pool ct-thomson-pool-201 192.168.220.201 mask 255.255.255.255
    pdm history enable
    arp timeout 14400
    global (outside) 1 24.38.31.81
    nat (inside) 0 access-list nat0
    nat (inside) 1 CT-NET 255.255.0.0 2000 10
    nat (DMZ) 0 access-list nat0-dmz
    static (inside,DMZ) CT-NET CT-NET netmask 255.255.0.0 0 0
    static (inside,outside) 24.38.31.69 172.20.8.2 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.94 192.168.10.141 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.71 172.20.1.11 dns netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.93 192.168.10.140 netmask 255.255.255.255 0 0
    static (DMZ,inside) 24.38.31.93 access-list static-dmz-to-ct-1 0 0
    static (DMZ,inside) 24.38.31.94 access-list static-dmz-to-ct-2 0 0
    static (inside,outside) 24.38.31.92 172.20.1.56 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.91 192.168.10.138 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.90 192.168.10.139 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.72 172.20.1.20 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.73 172.20.1.21 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.70 172.20.1.91 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.88 192.168.10.136 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.89 192.168.10.137 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.74 172.20.1.18 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.75 172.20.1.92 netmask 255.255.255.255 0 0
    access-group out1 in interface outside
    access-group dmz1 in interface DMZ
    route outside 0.0.0.0 0.0.0.0 24.38.31.65 1
    route inside 10.10.2.2 255.255.255.255 172.20.8.2 1
    route inside CT-NET 255.255.248.0 172.20.8.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    aaa-server ct-rad protocol radius
    aaa-server ct-rad max-failed-attempts 2
    aaa-server ct-rad deadtime 10
    aaa-server ct-rad (inside) host 172.20.1.22 morrow123 timeout 7
    aaa authentication ssh console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication telnet console LOCAL
    http server enable
    http 173.220.252.56 255.255.255.248 outside
    http 65.51.181.80 255.255.255.248 outside
    http 208.65.108.176 255.255.255.240 outside
    http CT-NET 255.255.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community m0rroW(0
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    sysopt connection permit-pptp
    crypto ipsec transform-set 3des-sha esp-3des esp-sha-hmac
    crypto ipsec transform-set 3des-md5 esp-3des esp-md5-hmac
    crypto dynamic-map dyn_map 20 match address vpn-dyn-match
    crypto dynamic-map dyn_map 20 set transform-set 3des-sha
    crypto map ct-crypto 10 ipsec-isakmp
    crypto map ct-crypto 10 match address vpn-ct-li-gre
    crypto map ct-crypto 10 set peer LI-PIX
    crypto map ct-crypto 10 set transform-set 3des-sha
    crypto map ct-crypto 15 ipsec-isakmp
    crypto map ct-crypto 15 match address vpn-ct-li
    crypto map ct-crypto 15 set peer LI-PIX
    crypto map ct-crypto 15 set transform-set 3des-sha
    crypto map ct-crypto 20 ipsec-isakmp
    crypto map ct-crypto 20 match address vpn-ct-ny
    crypto map ct-crypto 20 set peer NY-PIX
    crypto map ct-crypto 20 set transform-set 3des-sha
    crypto map ct-crypto 30 ipsec-isakmp
    crypto map ct-crypto 30 match address vpn-ct-tx
    crypto map ct-crypto 30 set peer TX-PIX
    crypto map ct-crypto 30 set transform-set 3des-sha
    crypto map ct-crypto 65535 ipsec-isakmp dynamic dyn_map
    crypto map ct-crypto client authentication ct-rad
    crypto map ct-crypto interface outside
    isakmp enable outside
    isakmp key ******** address LI-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp key ******** address 216.138.83.138 netmask 255.255.255.255 no-xauth no-c
    onfig-mode
    isakmp key ******** address NY-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp key ******** address TX-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp identity address
    isakmp nat-traversal 20
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption 3des
    isakmp policy 10 hash sha
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    isakmp policy 30 authentication pre-share
    isakmp policy 30 encryption 3des
    isakmp policy 30 hash md5
    isakmp policy 30 group 1
    isakmp policy 30 lifetime 86400
    vpngroup remotectusers address-pool ctpool
    vpngroup remotectusers dns-server 172.20.1.5
    vpngroup remotectusers wins-server 172.20.1.5
    vpngroup remotectusers default-domain morrowny.com

    Amit,
    I applaud your creativity in seeking to solve your problem, however, this sounds like a real mess in the making. There are two things I don't like about your approach. One, cron -> calling Java -> calling PHP -> accessing database, it's just too many layers, in my opinion, where things can go wrong. Two it seems to me that you are exposing data one your website (with the PHP) that you may not want expose and this is an important consideration when you are dealing with emails and privacy and so on.
    I think the path of least resistance would be to get a new user account added to the MySQL database that you can access remotely with your Java program. This account can be locked down for read only access and be locked down to the specific IP or IP range that your Java program will be connecting from.
    Again I applaud your creativity but truly this seems like a hack because of the complexity and security concerns you are introducing and I think is a path to the land of trouble. Hopefully you will be able to get a remote account set up.

  • Sending emails in PDF & TXT format generated by SAP script/Smart forms

    Hi
    We have a requirement to configure SMTP node to send emails in PDF & TXT format. Currently, Output format for SAP Documents generated by SAP Script/Smart Forms configured in PDF. (Tx - SCOT - SMTP Node - Intetnet - Output Forms for SAP Documents). But, We also like to send emails in TXT format for other application in the same system. I see that you can send emails generated by SAP Script/Smart Forms either in PDF or TXT format not both.
    Is it possible to send the emails in both the formats by configuring in Tx SCOT?
    Your inputs will be appreciated.
    Regards
    Chandu

    Hi chandu,
    1.  emails in both the formats by configuring in Tx SCOT ?
      Scot will allow only ONE AT A TIME.
    2. The other workaround is,
      that using some FM
      convert the OTF (sapscript/smartform)
      data to TEXT,
      and send it as RAW
    3. Configure RAW =  TEXT in scot.
    regards,
    amit m.

  • Connecting my Email form to the PHP script to send to my email question

    How do I connect my form that a customer fill out to my php script?  I have my php script named contactformprocess.php. 

    anybody help?

  • Send PDF form to e-mail as attachment with a PHP script on the server

    Hi,
    For several days I've been searching though the internet looking for a solution, a quite simple one in my opinion, but I got a little desperate not getting any result I want.
    Okay. The Situation.
    I have a PDF form to order sandwiches and drinks.
    The PDF has serveral area's and columns where customers fill in the amount of the products they would like to order.
    At a position of a field, the kitchen can almost blindly see what products a customer ordered.
    Therefore, when someone fills in the form, I want to send the filled PDF by e-mail to the kitchen's e-mail adress. And important: the PDF in the kitchen's mailbox should be completely identical to the form the customer filled in.
    So, I have an Order button in my form. I set the action as 'Submit a form'.
    In the settings under 'Enter a URL for this link' I used just some PHP mailer script I also use on my website contact form.
    IF I check 'HTML' under 'Export Format' the PHP mailer works fine. I receive an HTML e-mail listed the ordered products.
    BUT
    I do want the original filled PDF in my mailbox instead of an HTML e-mail.
    So, for 'Export Format' I checked 'PDF The Complete Document'.
    But then my PHP mailer script doesn't work anymore.
    It gives errors like 'no valid e-mail adres' , etcetera etcetera.
    Who has a solution?
    Who has a working standard PHP script for me what just sends the kitchen an empty mail with the original PDF as attachment?!
    There is no need to use any database or other more complex functionality. Just mail the filled PDF.

    You can submit whole PDF format as long as you enable usage rights on the PDF.
    Normally Adobe Reader users can only submit the data, XFDF, FDF, XDP, XML.
    To enable usage rights on the PDF you will need to use Adobe Acrobat Std/Pro.
    As for the PHP Script; it depends on your PHP web server capabilities.
    The script will be slightly different, if the server uses PHP Mail or PHP PEAR.
    Just attach the submission to an email and send.
    If the client is submitting the form from a standalone pdf reader app, you can also respond with a success or failure FDF \status message; otherwise, you can redirect to a success / failure URL.
    For more information and online examples:
    http://www.pdfemail.net/examples/

  • Issue with script timeouts - trying to send email mail shots - hosting recommendations?

    Background is this - I look after a site for a recruitment agency, which has a backend mySQL database.
    It includes a table of potential candidates, which the site owner can search based on various criteria and then send all the returned candidates an email about potential jobs they might be interested in.
    I'm using an off the shelf script to send the emails, and have jumped through a few hoops to get this to work, but it looks like we need to move hosting unfortunately.
    The script is able to limit emails so that the hosting company doesn't get black flagged as a spammer.
    I've set it up with a progress bar in a new window so the site owner can see progress, but easily get back to the rest of the site.
    But where we have come unstuck is the script timeout on the server - so even though its set to send emails slowly enough, ie under 500 emails an hour, because of that slow pace, it fails if it takes more then five minutes to send them all as the script times out.
    My understanding is that the script includes a line to reset the script timeout value to 0, so enabling the script to keep running until all the emails have been sent. But unfortunately our current hosting company does not allow the script timeout to be reset at the PHP level.
    So my question is this - is anyone doing anything similar, and if so, can you recommend any hosting company that does allow the script timeout to be reset at the PHP level?
    Because at the minute it seems like a frustrating catch-22 - slow it down to get around the spam issue, and it won't run long enough to send all the emails. Speed it up, and it falls foul of the script timeout.
    Any advise on this, or hosting suggestons most welcome!
    Thanks.

    Although there is an AppleScript Forum, Automator can run AppleScripts, so sometimes things can go in either forum. In your script, other than not setting a recipient, you are just getting one of the persons. You need to get a list of your contact information, then build your outgoing messages from that list - for example:
    <pre style="
    font-family: Monaco, 'Courier New', Courier, monospace;
    font-size: 10px;
    font-weight: normal;
    margin: 0px;
    padding: 5px;
    border: 1px solid #000000;
    width: 720px; height: 340px;
    color: #000000;
    background-color: #FFEE80;
    overflow: auto;"
    title="this text can be pasted into the Script Editor">
    set theEmails to {} -- this will be a list of email addresses
    set theNames to {} -- this will be a list of names for the greeting
    tell application "Address Book"
    activate
    set theGroup to (choose from list (get the name of every group) with prompt "Choose a Group") as text
    if theGroup is "false" then return -- cancel
    repeat with aPerson in (get every person of group theGroup) -- build email and name lists
    set the end of theEmails to the first item of (get the value of the email of aPerson) -- just the first address
    set the end of theNames to the first name of aPerson
    end repeat
    end tell
    tell application "Mail"
    repeat with anItem from 1 to (count theEmails) -- make a new message for each entry
    tell (make new outgoing message at the front of outgoing messages with properties {subject:"Test Mail"})
    set visible to true
    get item anItem of theNames
    if the result is missing value then -- no name
    set the content to "message"
    else
    set the content to "Dear " & the result & "," & return & return & "message"
    end if
    make new to recipient at the end of to recipients with properties {address:(item anItem of theEmails)}
    end tell
    end repeat
    activate
    end tell
    </pre>

  • Using PHP to send email via Cool Stack

    I created an HTML form that takes a user's input data and passes it to a PHP file for processing. My problem is the following: when the 2 files (html & php) are put on a test server, the email information comes through to the MS Outlook Inbox within 2 seconds. When the same 2 files are put on a production server, it takes a minimum of 5 minutes to a maximum of 30 minutes for the email information to come through to the MS Outlook Inbox. What do you think the problem could be?
    The test server is configured as follows:
    OS release: Solaris 10 11/06 s10x_u3wos_10 X86
    Load: 0
    Idle: 91%
    Using Cool Stack 1.3 by the OpenSolaris Web Stack project which includes PHP version 5.2.6 and Apache Server version 2.2.9
    The production server is configured as follows:
    OS release: Solaris 10 8/07 s10s_u4wos_12b SPARC
    Load: 1
    Idle: 66%
    Using Cool Stack 1.3 by the OpenSolaris Web Stack project which includes PHP version 5.2.6 and Apache Server version 2.2.9
    If you need more info on the servers, please let me know. Any ideas on the cause of the slow email is greatly appreciated.
    Thanks for your help.

    Hi.
    You php script send mail direct to Mail Server or use local sendmail?
    It's may be problem sendmail configuration on product server.
    Check /var/log/syslog on production server.
    Check mailq on production server immediately after submitting form.
    Regards.

  • Need help adapting David Powers PHP email form script please!

    Hi all,
    I'm fairly inexperienced with PHP and I'm trying to adapt the David Powers email form script from THE ESSENTIAL GUIDE TO DREAMWEAVER CS4 WITH CSS, AJAX, AND PHP.
    I've created a basic form so that visitors to the site can request a telephone call back from the site owner. The form asks the visitor for their name, telephone number and to select a time of day suitable for the telephone call to be made using radio buttons selecting between morning and afternoon.
    I'd like to achieve my goal with minimal validation error messages and would like to redirect to another page when a message is sent successfully. It is also important that in the spirit of the David Powers script I'm trying to work with, that it filters out suspect input, avoids email header injection attacks and blocks submission by spam bots.
    There may be a really simple solution to this since I don't want users to be able to enter an email address at all but I don't know enough to be able to figure it out just yet.
    I'd be grateful for any advice.
    See below for the code for the form including PHP so far...
    Thanks to everyone looking in in advance
    Karl.

    GEAtkins wrote:
    > I am using the redirect to a personal page from page 515
    of The Essential
    > Guide to DWCS3 in the following form:
    $_SESSION[MM_Username].php in the "if
    > login succeeds" field.
    Thank you for reminding me. There's a mistake in the book,
    which I
    discovered over the Christmas period, so forgot to send to
    friends of ED
    for the errata page.
    Don't use $_SESSION[MM_Username]. Use $loginUsername instead.
    It then works.
    David Powers, Adobe Community Expert
    Author, "The Essential Guide to Dreamweaver CS3" (friends of
    ED)
    Author, "PHP Solutions" (friends of ED)
    http://foundationphp.com/

  • Does Dreamweaver generate a PHP script to process forms

    I am trying to get a basic form to proess using a downloaded
    php script from www.thesitewizard.com. I'm getting this error
    message: " . $headersep . "Reply-To: \"$name\" <$email>" .
    $headersep . "X-Mailer: chfeedback.php 2.07" ); header( "Location:
    $thankyouurl" ); exit ; ?>
    www.thesitewizard.com says this error is because the
    webserver does not support php but we have our own webserver and
    have done a test and it is working correctly.
    Does Dreamweaver 8 generate the processing php script that
    I'm unaware of? If not, can you recommend a simple processing
    script to work on a Windows server that uses php?
    Thanks for your help!

    HI, there you don`t nead a processing script, there may be 2
    problems:
    for first you must began the php script with : <?php
    for second your file must has a .php extension,
    Titti
    textures

  • Sending string to php script using HttpConnection, OutputStream, POST

    I am currently building an imode application using DoJa 2.5 standards and the problem I'm having is that when I send a string to a php script using a HttpConnection object and an OuputStream object via Http POST method, It does not seem to be sent at all. You'll probably understand a little better if you read the following code:
    * main.java
    * DATE : 2005/12/19 14:47
    import com.nttdocomo.ui.IApplication;
    import com.nttdocomo.ui.Display;
    import com.nttdocomo.util.Phone;
    import com.nttdocomo.io.HttpConnection;
    import java.io.*;
    import javax.microedition.io.*;
    import com.nttdocomo.net.URLEncoder;
    * main
    * @TetraCON
    public class main extends IApplication
         // Declareer een object van de klasse Gebruiker
         public Gebruiker gebruiker;
         // Declareer een object van de mainpanel klasse
         private MainPanel mainPanel;
         public void start()
              //Maak object van Gebruiker aan met het sim_nr van de simkaart
              gebruiker = new Gebruiker(Phone.getProperty("terminal-id"));
              /* Testing... *************/
              System.out.println(gebruiker.getSim_nr());
              // Declareer een nog niet ingestelde HttpConnection
              HttpConnection con = null;
              OutputStream out = null;
              InputStream is = null;          
              try
                   // Stel de parameters van de HttpConnection in en krijg er een object van
                    //con = (HttpConnection)Connector.open( IApplication.getCurrentApp().getSourceURL() + "validate-terminal.php", Connector.READ_WRITE, true);
    /* Testing.... ****************/
    con = (HttpConnection)Connector.open( IApplication.getCurrentApp().getSourceURL() + "validate-terminal-test.php", Connector.READ_WRITE, true);
                   con.setRequestMethod(HttpConnection.POST);
                   con.setRequestProperty("Content-Type", "application/x-www-form-urlencoded");
                   // Declareer een OutputStream en link deze aan de HttpConnection
                   out = con.openOutputStream();
                   // Zet het te versturen sim_nr in de buffer van de OutputStream
                   out.write((URLEncoder.encode("sim_nr=" + gebruiker.getSim_nr())).getBytes());
                   // Sluit de OutputStream
                   out.close();
                   // Maak verbinding met de server en verstuur het sim_nr
                   con.connect();
                   // Declareer een InputStream en link deze aan de HttpConnection
                   is = con.openInputStream();
                   // Declareer een byte array van 20 bytes om de data in op te vangen
                   byte[] b = new byte[200];
                   // Roep de read methode van de InputStream aan om de data in de byte array te zetten
                   is.read(b);
                   // Sluit de InputStream
                   is.close();
                   // Sluit de verbinding
                   con.close();
                   // Geef de gebruikersnaam uit de byte array aan het attribuut van gebruiker of geef geen toegang
    /* Testing..... **********************/
                   System.out.println(new String(b));
              catch(Exception e)
                   System.out.println(e.toString());
                   try
                        if(out != null) out.close();
                        if(is != null) is.close();
                        if(con != null) con.close();
                   catch(Exception e2)
                        System.out.println("Exception: " + e2.toString());
              // initialiseer het mainpanel
              mainPanel = new MainPanel();
              // Geef het mainPanel weer
              Display.setCurrent(mainPanel);
    }The data I'm trying to submit does not show up in the $_POST variable in PHP as it should.
    Is there anybody out there who can tell me what I'm doing wrong?

    Hi Antoni, you can delete the 'mx:request' section and pass
    the 'registrationModel' object into the send parameters.
    Code should be:
    <?xml version="1.0" encoding="iso-8859-1"?>
    <mx:Application xmlns:mx="
    http://www.adobe.com/2006/mxml">
    <mx:Script>
    <![CDATA[
    import mx.controls.Alert;
    public function submitForm():void {
    formSender.cancel();
    formSender.send(registrationModel);
    //formSender.showBusyCursor = true;
    Alert.show("Your request has been send successfully.", "Send
    Report", Alert.OK , this);
    //resetForm();
    private function getResultOk(r:Number,event:Event):void{
    if(!r){
    Alert.show('Error sending data!!');
    return;
    Alert.show( String(this.formSender.lastResult) );
    ]]>
    </mx:Script>
    <mx:HTTPService id="formSender"
    url="
    http://www.yourdomain.com/mailer.php"
    method="POST" showBusyCursor="true" useProxy="false"
    result="getResultOk(1,event)"
    fault="getResultOk(0,event)" >
    </mx:HTTPService>
    <mx:Model id="registrationModel">
    <firstname>{firstname.text}</firstname>
    <lastname>{lastname.text}</lastname>
    <email>{email.text}</email>
    <position>{position.text}</position>
    </mx:Model>
    <mx:Form width="100%" height="100%">
    <mx:TextInput id="firstname" text="pepe"/>
    <mx:TextInput id="lastname" text="lopez"/>
    <mx:TextInput id="email" text="[email protected]"/>
    <mx:TextInput id="position" text="director"/>
    <mx:Button label="send" click="submitForm()"/>
    </mx:Form>
    </mx:Application>
    And php...
    <?
    echo 'OK: Vars received:'.count($_POST)."\n";
    foreach($_POST as $k=>$v){
    echo $k.'='.$v."\n";
    exit;
    ?>

  • Why do azure developers use Sendgrid to send emails but not another service?

    Hello, I don't know if this question is possible here, if not I am sorry for posting it. but I want to send emails from my azure website, and i noticed that most azure users use Sendgrid service to do that, so i was wondering why Sendgrid? what is special
    about it? anything wrong with Mailgun or Mailjet or such services?
    Alan-SY

    Hello Alan-SY,
    1. We have a partnership with Windows Azure, where we work closely with their team to ensure a great experience for Windows Azure developers.
    2. Here are some resources that can help you get going fast:
    Announcing Native Windows Azure Libraries and Special Free Pricing Using SendGrid for Windows Azure Customers: http://blogs.msdn.com/b/windowsazure/archive/2012/01/25/announcing-native-windows-azure-libraries-and-special-free-pricing-using-sendgrid-for-windows-azure-customers.aspx
    (be sure to check out the GitHub libraries referenced in this post)
    How to Send Email Using SendGrid from Java in a Windows Azure Deployment: http://msdn.microsoft.com/en-us/library/windowsazure/hh801258.aspx
    Getting Started with SendGrid on Windows Azure: http://blogs.msdn.com/b/windowsazure/archive/2012/09/10/guest-post-getting-started-with-sendgrid-on-windows-azure.aspx
    How to Use the SendGrid Email Service from PHP: http://www.windowsazure.com/en-us/develop/php/how-to-guides/sendgrid-email-service/
    3. Our support team is available 24/7: http://support.sendgrid.com/home
    4. In addition to our Web and SMTP APIs, we have a Parse (Incoming) API http://docs.sendgrid.com/documentation/api/parse-api-2/ to easily process incoming mail and an Event API http://docs.sendgrid.com/documentation/api/event-api/ for instant notifications
    of events such as bounces, clicks, opens, etc. 
    5. Before you start coding, you can test our API from your browser here: http://docs.sendgrid.com/apiworkshop/
    6. What makes us most special; however, is our customers http://sendgrid.com/customers.html and partners http://sendgrid.com/partners/email-partner-network.html
    With regards to your specific provisioning issue, reach out to our team on twitter (http://www.twitter.com/sendgrid) or via email community at sendgrid. 
    With Best Regards,
    Elmer Thomas
    Developer Evangelist
    www.SendGrid.com
    Start hacking on SendGrid today free: https://sendgrid.com/user/signup
    twitter: @sendgrid ^et @thinkingserious

Maybe you are looking for