DHCP - stacked catalyst 3750's

i know this is quite possible but i am unsure if the switches i will be using can do this alone.
ive got IP endpoints that will be piggy backed to PC's at the desks. they will both be on seperate VLAN's. i am curious if they can pull addresses from two different DHCP scopes.
i can code the VLAN tag into the phone and am wondering if that will be sufficient to pull the address from the second scope, and if the PC's without the tag will pull from the first. thanks in advance.

Hi Allen,
The phones is Cisco IP Phone? If yes, you can config switchport as access port and use voice vlan command. The IP Phone will use the voice vlan and the PC will use the data vlan.
e.g.
interface FastEthernet1/0/1
switchport access vlan 10
switchport mode access
switchport voice vlan 20
For DHCP scope issue, you can define two dhcp scope in the c3750 switches, c3750 will lease different ip address to PC and IP Phone according to different vlan setting.
e.g.
ip dhcp pool voice
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
option 150 ip 192.168.20.250
ip dhcp pool data
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1

Similar Messages

  • Catalyst (3750 24 10/100/1000T) and (3750 12 SFP) Stacking Problems

    Dear all
    I'm having a very strange situation here (at least for me)
    we have 4 core switches
    2 x   WS-C3750G-24T-S Catalyst 3750 24 10/100/1000T + IPB Image
    and
    2 x   WS-C3750G-12S-S Catalyst 3750 12 SFP + IPB Image
    Stack configuration is done this way
    when the switches are powered on, the first two SFP core switches are seen as a single stack with the stack master LED turned green on the first switch
    the other two (24 10/100/1000T) switches have the RPS LEDs always green, mode cannot be changed, and cannot be accessed by Console connection
    but when the (24 10/100/1000T) are powered off, the first (SFP) switch in the stack reports that " Switch 3 and 4 has been removed from Stack "
    which means they are stacked but there's something wrong, because
    only the SFP ports are shown in the " Show interfaces status " , the ethernet ports of the bottom switches are not present !!!
    can you please tell me what's the poblem ?

    Dear Daniel
    Sorry for my delayed response but i was actually quite busy
    but the problem was actually in another sense
    the default profile for the Catalyst 3750 SFP is the Aggregate SDM Template
    while the 3750 10/100/1000 ethernet Switch Default SDM profile was Desktop profile
    so i had an SDM mismatch
    DATACENTER#sh switch detail
    Switch/Stack Mac Address : 081f.f3cf.1c80
                                               H/W   Current
    Switch#  Role   Mac Address     Priority Version  State
    *1       Master 081f.f3cf.1c80     1      0       Ready              
    2       Member 081f.f3cf.5900     1      0       Ready              
    3       Member aca0.16ac.0180     1      2       SDM Mismatch       
    4       Member aca0.16a3.bc80     1      2       SDM Mismatch 
             Stack Port Status             Neighbors    
    Switch#  Port 1     Port 2           Port 1   Port 2
      1        Ok         Ok                2        4
      2        Ok         Ok                3        1
      3        Ok         Ok                4        2
      4        Ok         Ok                1        3 
    all i did was changing the default profile of the SFP switches into the Desktop Profile and problem was solved
    switch 1 provision ws-c3750g-12s
    switch 2 provision ws-c3750g-12s
    switch 3 provision ws-c3750g-24t
    switch 4 provision ws-c3750g-24t
    system mtu routing 1500
    ip subnet-zero
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface GigabitEthernet1/0/1
    interface GigabitEthernet1/0/2
    interface GigabitEthernet1/0/3
    interface GigabitEthernet1/0/4
    interface GigabitEthernet1/0/5
    interface GigabitEthernet1/0/6
    interface GigabitEthernet1/0/7
    interface GigabitEthernet1/0/8
    interface GigabitEthernet1/0/9
    interface GigabitEthernet1/0/10
    interface GigabitEthernet1/0/11
    interface GigabitEthernet1/0/12
    interface GigabitEthernet2/0/1
    interface GigabitEthernet2/0/2
    interface GigabitEthernet2/0/3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet2/0/4
    interface GigabitEthernet2/0/5
    interface GigabitEthernet2/0/6
    interface GigabitEthernet2/0/7
    interface GigabitEthernet2/0/8
    interface GigabitEthernet2/0/9
    interface GigabitEthernet2/0/10
    interface GigabitEthernet2/0/11
    interface GigabitEthernet2/0/12
    interface GigabitEthernet3/0/1
    interface GigabitEthernet3/0/2
    interface GigabitEthernet3/0/3
    interface GigabitEthernet3/0/4
    interface GigabitEthernet3/0/5
    interface GigabitEthernet3/0/6
    interface GigabitEthernet3/0/7
    interface GigabitEthernet3/0/8
    interface GigabitEthernet3/0/9
    interface GigabitEthernet3/0/10
    interface GigabitEthernet3/0/11
    interface GigabitEthernet3/0/12
    interface GigabitEthernet3/0/13
    interface GigabitEthernet3/0/14
    interface GigabitEthernet3/0/15
    interface GigabitEthernet3/0/16
    interface GigabitEthernet3/0/17
    interface GigabitEthernet3/0/18
    interface GigabitEthernet3/0/19
    interface GigabitEthernet3/0/20
    interface GigabitEthernet3/0/21
    interface GigabitEthernet3/0/22
    interface GigabitEthernet3/0/23
    interface GigabitEthernet3/0/24
    interface GigabitEthernet4/0/1
    interface GigabitEthernet4/0/2
    interface GigabitEthernet4/0/3
    interface GigabitEthernet4/0/4
    interface GigabitEthernet4/0/5
    interface GigabitEthernet4/0/6
    interface GigabitEthernet4/0/7
    interface GigabitEthernet4/0/8
    interface GigabitEthernet4/0/9
    interface GigabitEthernet4/0/10
    interface GigabitEthernet4/0/11
    interface GigabitEthernet4/0/12
    interface GigabitEthernet4/0/13
    interface GigabitEthernet4/0/14
    interface GigabitEthernet4/0/15
    interface GigabitEthernet4/0/16
    interface GigabitEthernet4/0/17
    interface GigabitEthernet4/0/18
    interface GigabitEthernet4/0/19
    interface GigabitEthernet4/0/20
    interface GigabitEthernet4/0/21
    interface GigabitEthernet4/0/22
    interface GigabitEthernet4/0/23
    interface GigabitEthernet4/0/24
    that's it !
    : D
    cheers

  • Could connect two Nexus 5648 to a stack of Catalyst 3750?

    Good Morning,
    Can I connect a two Nexus 5600 (switchs distribution) with switch Catalyst 3750 (switch access)?
    I have tried to integrate the Nexus switch in the network as switch distribution, replacing a Catalyst 6500 switch and does not work. Everything is going very slow. Although all the ping function properly.
    Is there any incompatibility connect two nexus 5648 to a stack of Catalyst 3750 by VPC?
    Thank you.
    Greetings.

    Hi,
    There can be many reasons for the switches not joining the stack like SDM template mismatch.
    You may go through the following document:
    http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750/software/troubleshooting/switch_stacks.html#wp40112
    Thanks
    Ankur
    "Please rate the post if found useful"

  • Debian Linux Bonding and Cisco Catalyst 3750 - best practise?

    Hello everybody,
    I would like to know what's best practice to do this:
    The two NICs of a Debian Linux server wants to be connected with two Switchports of a Cisco Catalyst 3750 switch(stack). My goal is to have load-balancing and failover.
    My /etc/network/interfaces looks like this:
    iface bond0 inet static
           address 192.168.0.30
           netmask 255.255.255.0
           network 192.168.0.0
           broadcast 192.168.0.255
           gateway 192.168.0.1
           dns-nameservers 192.168.0.10 192.168.0.20
           dns-search xyz.mycompany.com
           slaves eth0 eth1
           bond_mode ???
           bond_miimon 100
           bond_downdelay 200
           bond-updelay 200
    First question: What bond mode should I use?
    The switchports looks like this:
    interface GigabitEthernet3/0/4
     switchport access vlan 20
     switchport mode access
     spanning-tree portfast
    What changes are necessery here? Something like this?
    interface GigabitEthernet3/0/4
     switchport trunk encapsulation dot1q
     switchport mode trunk
     spanning-tree portfast
    Thanks a lot for suggestions, hints, etc.! :-)
    Greets
    Stephan

    Hi Michael,
    thanks a lot for your answer - and sorry for my late reply!
    I like to show you my solution - I hope that it is a solution. ;-)
    My config on the switch(stack):
    switch#show etherchannel summary
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+-----------------------------------------------
    2      Po2(SU)         LACP      Gi3/0/3(P)  Gi4/0/3(P)
    switch#show running-config interface GigabitEthernet 3/0/3
    Building configuration...
    Current configuration : 172 bytes
    interface GigabitEthernet3/0/3
     description myserver, eth0
     switchport access vlan 20
     switchport mode access
     channel-group 2 mode active
     spanning-tree portfast
    end
    lansw01#show running-config interface GigabitEthernet 4/0/3
    Building configuration...
    Current configuration : 172 bytes
    interface GigabitEthernet4/0/3
     description myserver, eth1
     switchport access vlan 20
     switchport mode access
     channel-group 2 mode active
     spanning-tree portfast
    end
    switch#show running-config interface port-channel 2
    Building configuration...
    Current configuration : 82 bytes
    interface Port-channel2
     switchport access vlan 20
     switchport mode access
    end
    The /etc/network/interfaces of my Debian machine looks like this:
    auto lo
    iface lo inet loopback
    auto bond0
            iface bond0 inet static
            address 192.168.1.xxx
            netmask 255.255.255.0
            gateway 192.168.1.xxx
            dns-nameservers 192.168.1.xxx
            dns-search xxx.xxx.xxx
            bond-mode 4
            bond-miimon 100
            bond-downdelay 200
            bond-updelay 200
            bond-lacp-rate 1
            slaves eth0 eth1
    This setup seems to work well. But I'm wondering that there is nothing with "trunking" in my setup. Would you like to give me your opinion about this?
    Thanks a lot and many greets
    Stephan

  • Catalyst 3750 Switch

    How many total Vlans can you create in Catalyst 3750 Switch ? I read a document about Catalyst 3750 Switch. This document is said that "Although the switch stack supports a total of 1005 (normal-range and extended-range) VLANs, the
    number of routed ports". However, I am not sure. Can you confirm for me ? Thanks

    this link should be of some help to answer your question.
    http://www.cisco.com/en/US/products/hw/switches/ps5532/products_command_reference_chapter09186a00803ec324.html#wp1031710
    HTH-Cheers,
    Swaroop

  • Catalyst 3750 interface explaination

    Dear Sir,
    I don't understand as follows :-
    1.) why on Catalyst3750 interface fastethernet 1/0/1 ?? <--- what's the meaning of 1/0/1 ?
    2.) what's the meaning of no mdix auto?
    Please explain and advise.
    Thank you.

    The 3750 has many interesting features, I recommaned you go through before you connect your switches in a production environment.
    Basically, you should provision your stack master with the number of switches and their types. You could provision as well the interfaces with their corresponding configurations, even though the other elements are still not connected yet. This way, you ensure, when you add a provisioned element with the right number, it will take exactly the provisioned configuration you've already set on the master,... as well when changing an element with an other, when moving it,... you will have just to provision its number and then connect it to the stack while is not yet powered on.
    Second, it is recommanded to set priority to each element, this way you will have a deterministic configuration and you know in advance which one will be reelected as master in any sitution.
    If no provision is set on the stack master, when you connect a switch, it has by default the number "1", in this case the newly added switch will take the lowest switch number available (2).
    1.) 1/0/1 --> so the second will be 2/0/1.
    And to address its ports you tape: 2/0/1, 2/0/2, 2/0/3,2/0/4,...2/0/24,...
    How to stacked both of the catalyst 3750? just purchase one stackable cable to link both of them and will it automatically configure the 2nd switch from 1/0/1 to 2/0/1 after we plug in the stackable cable into the 2nd switch.
    For large deployment I recommand the switches to be provisioned manually: Before stacking the switches:
    1/ power on the switch that will be the stack master, then wait till it will be in "Ready" state by issuing "show switch detail" command.
    2/ Provision the stack master with the desired stack configuration (numbers of switches, types of switches and interfaces configurations).
    3/ Reload the stack master.
    4/ Provision the second switch with its number and type.
    5/ Power off the second switch afetr having saved its configuration.
    6/ Stack the second switch to the stack master.
    7/ power it on. It will take the provisioned configuration on the stack master.
    The advantage of this procedure is that switches could not be renumbered while stacked and running.
    Repeat steps 4 to 7 for each new element having been provisioned in the stack master.
    Do not forget to save after each step.
    2.) so i put "no mdix auto" on catalyst 3750, what's the meaning and impact?
    no mdix-auto will disable the advanced feature of abstructing the type of cable (staight throu or cross over). You will downgrade to the standard interfaces specifications. In fact, mdix-auto (activated by default) permits to not to have the "overhead" of distinguishing crossover and straight throu cables, the interfaces will adapt automatically to the type of cable.
    An other advantage of this function is that it opimises (combined with other functions) error and recovery procedures in layers 1 and 2.
    Mohamed BEN HASSINE

  • VLAN trunking from Cisco Catalyst 3750 to Cisco SF300-48P issue and related

    Hello expert,
    I'm having difficulties to configure VLAN trunking between Cisco Catalyst 3750 switch with Cisco SF300-48P switch and my workstation unable to get any DHCP IP from our DHCP server via Cisco SF300-48P switch. Below is the snippet of configuration on both switches:
    [Cisco Catalyst 3750 Switch]
    interface GigabitEthernet1/0/45
     description NCC-CC-1stFlr
     no switchport trunk encapsulation dot1q
     no switchport trunk allowed vlan 101-103
     spanning-tree portfast
    [Cisco SF300-48P Switch]
    interface fastethernet48
     spanning-tree link-type point-to-point
     switchport trunk allowed vlan add 101-103
     macro description switch
     !next command is internal.
     macro auto smartport dynamic_type switch
    interface fastethernet29
     switchport mode general
     switchport general allowed vlan add 103 tagged
     switchport general pvid 103
    Are these are correct? Kindly advice!
    Thank you very much!
    Regards,
    Alex

    Hi Alex,
    for the trunk port on Catalyst on port GE 1/0/45, we need to enable the trunk and for on encapsulation dot1q because this catalyst model is ISL capable also and the SF300 working only with Dot1q Encapsultion
    The configuration on catalyst should :
    #config terminal
    #interface Gi 1/0/45
    # switchport encapsulation 
    #switchport trunk encapsulation dot1q
    #switchport mode trunk 
    #switchport trunk allowed vlan 101-103
    #spanning-tree portfast
    For SF300 the port trunk it looks fine but for the port where the PC should receive an IP address
    #interface fastethernet29
     #switchport mode access
     #switchport ccess vlan 103
    Please let me know after this configuration
    Thanks
    Mehdi
    Please rate or mark as answered to help other Cisco Customers

  • Catalyst 3750 12.2(25)SD1 and dual nics

    When a Catalyst 3750 stack master fails or leaves the stack, a cross-stack EtherChannel in trunk mode running Link Aggregation Control Protocol (LACP) protocol might stop forwarding traffic on some VLANs.
    The workaround is to enable the stack-mac persistent feature by using the stack-mac persistent timer global configuration command. You can also use the shutdown interface configuration command and then the no shutdown command on the EtherChannel interface.
    Network Infrastructure: LAN Routing and Switching
    I have upgrade a Catalyst 37024 TS 2 switch stack to 12.2(25)SED1 from 12.1(14)EA. The switch has an Alpha Server Custer connected to it the cluster has two servers each having two nics . There is a active server which has an application IP address and each server has a Server IP address one nic active ata time.
    All worked ok upto the upgrade. Now every night when the backup runs noone can access the application ip address or the acive server address but te offline server is pingable. This is only for devices outside the serrver VLAN. Devices within the server VLAN can hapily ping any address.
    I thought this was arouing issue but all looks ok and the offline server can be pinged from any where.
    the active server nics areon 1/0/20 and 2/0/24
    Any one have any ideas?

    I forgot to add if I shut both interfaces an then do a no shout on both the issue is resolved until the next night.

  • Cisco Catalyst 3750-X or 3560-X Series Switches

    Recently, our company was deciding to buy Cisco switches, but they just tell the requirements and I finally focused on two kinds of switches, Cisco Catalyst
    3750-X or 3560-XSeries Switches? Who can tell me, tnx in advance.

     As I read a blog recently, it listed the specific differences between Cisco 3750-X and 3560-X, except for the common features of Cisco 3750-X and 3560-X, Cisco 3750-X can also offer-- Cisco StackPower technology: An innovative feature and industry first for sharing power among stack members; 
    Cisco StackWise Plus technology for ease of use and resiliency with 64 Gbps of throughput; 
    Investment protection with backward compatibility with all other models of Cisco Catalyst 3750 Series Switches. 
    And made a more detailed comparison between the two products, for ur reference.

  • Password problem on Catalyst 3750

    Hi all,
    I am an Unix administrator and we lost all account and password informations to connect on a Catalyst 3750 switch.
    Is there a way to connect to the switch (With a serial cable?) an to create a new account without losing the configuration ?
    Thank's for your reply.
    Regards.

    This method won't reset the configuration.
    During the boot process, you rename the current configuration so it doesn't get loaded.
    rename flash:config.text flash:config.old
    When  the switch boots, it loads a blank image. Then you rename the config  file and load it into the running config and you can change the logon  credentials to something you know.
    It's important that you follow the steps exactly so you don't lose the configuration. Password recovery is a pretty common procedure.
    The  only other method of recovery is if you have a copy of the current  running configuration. Send me a private message if you have this config and we can discuss the possibility.

  • Policer with IPv6 class-map on Catalyst 3750

    Hi,
    I've the following problem.
    It's my goal to ratelimit incoming IPv6 traffic dependent on the destination IP address range.
    On a Catalyst 3750 (Image: c3750-ipservicesk9-mz.122-55.SE1.bin) I've set up the configuration as follows:
    mls qos
    ipv6 access-list DESTINATION-RANGE-A
     permit ipv6 any 2007::/16
    ipv6 access-list DESTINATION-RANGE-B
     permit ipv6 any 2B03::/16
    class-map match-all A
     match access-group name DESTINATION-RANGE-A
    class-map match-all B
     match access-group name DESTINATION-RANGE-B
    policy-map RL-POLICY
     class A
      police 2000000 8000 exceed-action drop
     class B
      police 6000000 8000 exceed-action drop
    interface GigabitEthernet1/0/7
     switchport access vlan 90
     load-interval 30
     service-policy input RL-POLICY
    The last CLI command which should bind the policy to the specific interface, leads to the following error message
    QoS: class(A) IPv6 class not supported on interface GigabitEthernet1/0/7
    Are hardware/software limitations the reason for this behavior or is there any misconfiguration?
    Thanks in advance for your help!
    Regards,
    Jens

    If you are thinking of IPv6 prefix I tried everything. From /128 for single host to /64, nothing works.

  • Ratelimiter with IPv6 class-map on Catalyst 3750

    Hi,
    I've the following problem.
    It's my goal to ratelimit incoming IPv6 traffic dependent on the destination IP address range.
    On a Catalyst 3750 (Image: c3750-ipservicesk9-mz.122-55.SE1.bin) I've set up the configuration as follows:
    mls qos
    ipv6 access-list DESTINATION-RANGE-A
     permit ipv6 any 2007::/16
    ipv6 access-list DESTINATION-RANGE-B
     permit ipv6 any 2B03::/16
    class-map match-all A
     match access-group name DESTINATION-RANGE-A
    class-map match-all B
     match access-group name DESTINATION-RANGE-B
    policy-map RL-POLICY
     class A
      police 2000000 8000 exceed-action drop
     class B
      police 6000000 8000 exceed-action drop
    interface GigabitEthernet1/0/7
     switchport access vlan 90
     load-interval 30
     service-policy input RL-POLICY
    The last CLI command which should bind the policy to the specific interface, leads to the following error message
    QoS: class(A) IPv6 class not supported on interface GigabitEthernet1/0/7
    Are hardware/software limitations the reason for this behavior or is there any misconfiguration?
    Thanks in advance for your help!
    Regards,
    Jens

    If you are thinking of IPv6 prefix I tried everything. From /128 for single host to /64, nothing works.

  • Make Fiber Ports Live on Catalyst 3750?

    Hello All,
    Have 2 Catalyst 3750's connected via fiber to the cisco gbics converts. Both gbic's are plugged into Slot 1 of 4 on the switches. Everything is physically hooked up correctly. My question is what command do I type to make the fiber ports active? I know the fiber led should go orange for 30 sec then green when you plug the fiber cable in the gbic but it's not working because I've got to make that port or interface active first right? Any help would be appreciated. Thanks in advanced!

    Double check the cabling. Unplug one of the patch cables from one of the gbics. Look at which connector on the gbic has the light coming out of it. Compare to the fiber patch for which connector has light coming out of it. Ensure you have the fiber plugged into the gbic such that light from one connects to dark on the other. Do this at both ends.
    Also, pull the gbics out of the switches & validate both are appropriate for the fiber type you are using. 1000-LX is for single mode fiber; 1000-SX is for multimode fiber.
    If you have the interface administratively shut down, this will fix it:
    int gig 0/1
    no shut

  • Interconnecting Catalyst 3750 and 2948G-L3

    I am trying to interconnect a Catalyst 3750 and a 2948G-L3 using fiber GBIC. The interfaces where the GBIC and fiber are attached show up as physically down. I have tried different ports and also changed both switches. No Luck. If I connect a 3524 to the 3750 using the same connection it works.
    Are 2948G-L3 switches compatible with the 3750?
    Thanks,
    VT

    Should have no problem. Can you try the following on the 3750's gig interface:
    speed nonegotiate
    See of the link comes up.
    Please rate all posts.

  • Catalyst 3750 Ingress SPQ/SRR behavior

    Do Cisco engineers review this community at all?
    I am working on the latest version of QoS standard for our Enterprise and noticed the following conflicting information officially provided by Cisco.
    My question relates to ingress/pre-ring Strict Priority Queue (SPQ) logic.
    Cisco Catalyst 3750 QoS Configuration Examples document states that SPQ on ingress is configured and serviced as follows
    mls qos srr-queue input priority-queue 2 bandwidth 10
    mls qos srr-queue input bandwidth 90 10
    SPQ services Q2 up to the configured 10% of ingress bandwidth
    Any excessive traffic in Q2 is not dropped, but is serviced by SRR in accordance with the configured weights
    For example, a momentary 5Gbps of aggregated ingress EF traffic will be serviced in the following way
    SQP services 10% of total ring's bandwidth, or 3.2Gbp, leaving 1.8Gbps for SRR processing
    SRR services excessive 1.8Gbps in accordance w/ weights Q1 - 90 and Q2 - 10, such as Q1 gets 25.92Gbps and Q2 get 2.88Gbps more.
    The following pictures provides in-depth look into Ingress queuing logic.
    Alternatively, Cisco Medianet Campus Design v4.0 provides the following example w/ comments
    C3750-E(config)#mls qos srr-queue input priority-queue 2 bandwidth 30
    ! Q2 is enabled as a strict-priority ingress queue with 30% BW
    C3750-E(config)#mls qos srr-queue input bandwidth 70 30
    ! Q1 is assigned 70% BW via SRR shared weights
    ! Q2 SRR shared weight is ignored (as it has been configured as a PQ)
    Basically, they now say Q2 bandwidth weight is ignore because it is configured as Strict Priority Queue.  Doesn't it look contradictory?
    In my humble opinion Medianet (or SRND v4.0!!!) provides an incorrect information re ingress queuing on Catalyst 3750 platform.
    I am not sure I can easily test it, providing that an internal ring must experience a congestion. I don't think I can send more than 32Gbps of traffic into any of my lab 3750 switches.
    Also, I don't think this mistake can be critical in my environment as I don't expect to have momentary full capacity load on those... but it can be critical for others.
    Much appreciate
    Tim

Maybe you are looking for