Download speed detect

Dear Reader,
I have made my simple download utility program in java.
In there i can count the number of bytes downloaded.
--Problem i am facing is to get bytes per second of the download in progress.
For this purpose i take system time at definite intervals(one or two seconds) and count
the bytes downloaded in that specific intervals.
Doing so slows down the speed of the program(execution speed).
If you have any alternative to get bytes per second which does not consume time please
notify...
Thank you

Getting the time every second or so should have no measurable impact on performance. How are you spacing your measurements? Are you running some loop in a thread until the time has elapsed (very bad!), using Thread.sleep() (better) or using java.util.Timer and TimerTask (probably best)?
Chuck

Similar Messages

  • Download Speed on PIX 515E is Pretty Slow

    Hello, I have a PIX 515E set up between our office switch and our Comcast Business Router and the download speeds are not as fast as they should be. We are paying for 30 down 30 up but it's more like 10 down 30 up. I plugged in a computer directly into the router and got 30/30 so I know its not a comcast issue. I think it might be the low amount of memory on the PIX because its running at 109 out of a total 128mb. The PIX has a site-to-site VPN tunnel with a remote ASA 5520 firewall. The inside/outside ports are both auto/auto. The running config is only 161 lines.
    Here's some information about the PIX 515E...
    Version 8.0(4)
    ASDM 6.1(3)
    Memory 128MB
    Here is the running config..
    Result of the command: "show running-config"
    : Saved
    PIX Version 8.0(4)
    hostname --------------------
    domain-name -----------------
    enable password -------------------------
    passwd --------------- encrypted
    names
    name 1.1.1.1 Data-Center-Firewall    #### Outside Address Changed
    name 10.0.0.0 Data-Center-Subnet
    dns-guard
    interface Ethernet0
    nameif inside
    security-level 100
    ip address 10.10.1.1 255.255.255.0 standby 10.10.1.254
    interface Ethernet1
    nameif outside
    security-level 0
    ip address 2.2.2.1 255.255.255.252   #### Outside Address Changed
    interface Ethernet2
    description LAN/STATE Failover Interface
    ftp mode passive
    clock timezone EST -5
    clock summer-time EDT recurring
    dns server-group DefaultDNS
    domain-name -------------
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group service http8080 tcp
    description http8080
    port-object eq 8080
    object-group service DM_INLINE_TCP_1 tcp
    port-object range 50000 50100
    port-object eq 990
    access-list outside_access_in remark ip, tcp/990
    access-list outside_access_in extended permit tcp host 1.1.1.1 host 2.2.2.5 object-group DM_INLINE_TCP_1
    access-list outside_access_in extended permit icmp any any
    access-list ACL-VPN extended permit ip 10.10.1.0 255.255.255.0 Data-Center-Subnet 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    failover
    failover lan unit primary
    failover lan interface failover Ethernet2
    failover lan enable
    failover key *****
    failover replication http
    failover mac address Ethernet0 001e.f732.008f 000d.28f9.628f
    failover mac address Ethernet1 001e.f732.0090 000d.28f9.6290
    failover link failover Ethernet2
    failover interface ip failover 10.10.10.10 255.255.255.252 standby 10.10.10.20
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    icmp permit any outside
    asdm image flash:/asdm-613.bin
    no asdm history enable
    arp timeout 14400
    nat-control
    global (outside) 1 interface
    nat (inside) 0 access-list ACL-VPN
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) 2.2.2.5 10.10.1.102 netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 2.2.2.2 1
    route inside 10.10.0.0 255.255.255.0 10.10.1.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 10.10.0.0 255.255.255.0 inside
    http 10.10.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    service resetoutside
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set AES128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto map MAP-VPN 1 match address ACL-VPN
    crypto map MAP-VPN 1 set pfs
    crypto map MAP-VPN 1 set peer Data-Center-Firewall
    crypto map MAP-VPN 1 set transform-set ESP-3DES-SHA
    crypto map MAP-VPN 1 set security-association lifetime seconds 28800
    crypto map MAP-VPN 1 set security-association lifetime kilobytes 4608000
    crypto map MAP-VPN interface outside
    crypto isakmp enable inside
    crypto isakmp enable outside
    crypto isakmp policy 5
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet 10.10.1.0 255.255.255.0 inside
    telnet 10.10.0.0 255.255.255.0 inside
    telnet timeout 5
    ssh 10.10.0.0 255.255.255.0 inside
    ssh 10.10.1.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics host
    threat-detection statistics port
    threat-detection statistics protocol
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    tunnel-group 1.1.1.1 type ipsec-l2l
    tunnel-group 1.1.1.1 ipsec-attributes
    pre-shared-key *
    class-map class_ftp
    match port tcp eq ftp-data
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
    class class_ftp
      inspect ftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:b795d4f5f5da3d8283d452ba857d5534
    : end

    Please check on the speed and duplex settings whether the downstream and upstream links are fine and healthy.
    Inside/outside are both set to auto/auto at
    Check for the processes usage of the cpu of the pix.
    CPU is running at 2%
    Process:      tmatch compile thread, PROC_PC_TOTAL: 2, MAXHOG: 8, LASTHOG: 8
    LASTHOG At:   19:01:15 EST Dec 31 1992
    PC:           26b616 (suspend)
    Process:      tmatch compile thread, NUMHOG: 2, MAXHOG: 8, LASTHOG: 8
    LASTHOG At:   19:01:15 EST Dec 31 1992
    PC:           26b616 (suspend)
    Traceback:    26b616  26bdb9  26ec89  1182b3
    Process:      Dispatch Unit, NUMHOG: 1, MAXHOG: 5, LASTHOG: 5
    LASTHOG At:   09:25:12 EDT Jul 18 2012
    PC:           130114b (interrupt)
    Traceback:    100178  12edd0c  9771e5  8c0e66  927164  928996  8ec3f5
                  8ec7ed  79d35e  2780c3  1182b3
    Process:      Unicorn Admin Handler, NUMHOG: 1, MAXHOG: 5, LASTHOG: 5
    LASTHOG At:   12:27:25 EDT Jul 18 2012
    PC:           130114b (interrupt)
    Traceback:    100178  d870cb  13016b3  15cf68  e91a6f  e9118b  abfcea
                  a7cb2e  a7daeb  18d800  5ae9a9  5a6aa0  5a7272  5a75e5
    Process:      Unicorn Admin Handler, PROC_PC_TOTAL: 4, MAXHOG: 7, LASTHOG: 7
    LASTHOG At:   12:34:10 EDT Jul 18 2012
    PC:           5ae903 (suspend)
    Process:      Unicorn Admin Handler, NUMHOG: 4, MAXHOG: 7, LASTHOG: 7
    LASTHOG At:   12:34:10 EDT Jul 18 2012
    PC:           5ae903 (suspend)
    Traceback:    5ae903  5a6aa0  5a7272  5a75e5  5ad3d5  1182b3
    Process:      Unicorn Admin Handler, PROC_PC_TOTAL: 4, MAXHOG: 5, LASTHOG: 5
    LASTHOG At:   12:37:47 EDT Jul 18 2012
    PC:           f4078b (suspend)
    Process:      Unicorn Admin Handler, NUMHOG: 4, MAXHOG: 5, LASTHOG: 5
    LASTHOG At:   12:37:47 EDT Jul 18 2012
    PC:           f4078b (suspend)
    Traceback:    f40be2  130f41e  aab54d  aac3b0  5a6c2e  5a7272  5a75e5
                  5ad3d5  1182b3
    Process:      IKE Daemon, NUMHOG: 1, MAXHOG: 5, LASTHOG: 5
    LASTHOG At:   23:07:40 EDT Jul 19 2012
    PC:           1b6dd0 (interrupt)
    Traceback:    100178  1b8a31  1baaeb  6438d7  12efc6f  64250b  653fe9
                  654b78  1182b3
    Process:      IKE Daemon, PROC_PC_TOTAL: 347, MAXHOG: 31, LASTHOG: 30
    LASTHOG At:   16:01:55 EDT Jul 23 2012
    PC:           654bab (suspend)
    Process:      CTM message handler, PROC_PC_TOTAL: 346, MAXHOG: 27, LASTHOG: 27
    LASTHOG At:   16:01:55 EDT Jul 23 2012
    PC:           2087ec (suspend)
    Process:      IKE Daemon, NUMHOG: 693, MAXHOG: 31, LASTHOG: 27
    LASTHOG At:   16:01:55 EDT Jul 23 2012
    PC:           654bab (suspend)
    Traceback:    1182b3
    Process:      Unicorn Admin Handler, NUMHOG: 1, MAXHOG: 5, LASTHOG: 5
    LASTHOG At:   17:23:30 EDT Jul 23 2012
    PC:           130003b (interrupt)
    Traceback:    100178  13008b8  f5a0cd  f5ac32  f5ae40  f60828  f617c1
                  d38a0d  aab50b  aac14a  5a6c2e  5a7272  5a75e5  5ad3d5
    Process:      Dispatch Unit, PROC_PC_TOTAL: 227, MAXHOG: 432, LASTHOG: 35
    LASTHOG At:   17:37:03 EDT Jul 23 2012
    PC:           278207 (suspend)
    Process:      Dispatch Unit, NUMHOG: 227, MAXHOG: 432, LASTHOG: 35
    LASTHOG At:   17:37:03 EDT Jul 23 2012
    PC:           278207 (suspend)
    Traceback:    278207  1182b3
    Process:      Unicorn Admin Handler, PROC_PC_TOTAL: 1901, MAXHOG: 8, LASTHOG: 7
    LASTHOG At:   17:44:20 EDT Jul 23 2012
    PC:           118ed5 (suspend)
    Process:      Unicorn Admin Handler, NUMHOG: 1901, MAXHOG: 8, LASTHOG: 7
    LASTHOG At:   17:44:20 EDT Jul 23 2012
    PC:           118ed5 (suspend)
    Traceback:    118ed5  b2d032  f5a80d  f5ac0a  f5ae40  f607e5  f617c1
                  d38a0d  aab50b  aac14a  5a6c2e  5a7272  5a75e5  5ad3d5
    CPU hog threshold (msec):  5.120
    Last cleared: None
    Check on the inetrface whetehr u get any crc/input/overrun errors. Please check with the physical connectivity.
    Interface Ethernet0 "inside", is up, line protocol is up
      Hardware is i82559, BW 100 Mbps, DLY 100 usec
        Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)
        MAC address __________, MTU 1500
        IP address 10.10.1.1, subnet mask 255.255.255.0
        60862937 packets input, 29025667892 bytes, 0 no buffer
        Received 1371 broadcasts, 0 runts, 0 giants
        0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
        0 L2 decode drops
        68515603 packets output, 44084404472 bytes, 0 underruns
        0 output errors, 0 collisions, 0 interface resets
        0 babbles, 0 late collisions, 0 deferred
        0 lost carrier, 0 no carrier
        input queue (curr/max packets): hardware (0/1) software (0/47)
        output queue (curr/max packets): hardware (0/67) software (0/1)
      Traffic Statistics for "inside":
        60997029 packets input, 28080179952 bytes
        68553614 packets output, 43104566708 bytes
        29544 packets dropped
          1 minute input rate 63 pkts/sec,  30371 bytes/sec
          1 minute output rate 64 pkts/sec,  16557 bytes/sec
          1 minute drop rate, 0 pkts/sec
          5 minute input rate 91 pkts/sec,  45254 bytes/sec
          5 minute output rate 93 pkts/sec,  56181 bytes/sec
          5 minute drop rate, 0 pkts/sec
    Interface Ethernet1 "outside", is up, line protocol is up
      Hardware is i82559, BW 100 Mbps, DLY 100 usec
        Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)
        MAC address ___________, MTU 1500
        IP address ___________, subnet mask 255.255.255.252
        67730933 packets input, 44248541375 bytes, 0 no buffer
        Received 4493 broadcasts, 0 runts, 0 giants
        0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
        0 L2 decode drops
        60418640 packets output, 29310509840 bytes, 0 underruns
        0 output errors, 0 collisions, 0 interface resets
        0 babbles, 0 late collisions, 0 deferred
        0 lost carrier, 0 no carrier
        input queue (curr/max packets): hardware (0/1) software (0/39)
        output queue (curr/max packets): hardware (0/42) software (0/1)
      Traffic Statistics for "outside":
        67782987 packets input, 43276611710 bytes
        60562287 packets output, 28342787997 bytes
        206651 packets dropped
          1 minute input rate 57 pkts/sec,  14273 bytes/sec
          1 minute output rate 61 pkts/sec,  30258 bytes/sec
          1 minute drop rate, 0 pkts/sec
          5 minute input rate 89 pkts/sec,  54426 bytes/sec
          5 minute output rate 87 pkts/sec,  45115 bytes/sec
          5 minute drop rate, 0 pkts/sec
    enable flowcontrol recieve on on the firewall interfaces and switch/router interfaces connected to the firewall.
    Not sure how to do that.

  • ASA 5505 Slow download speed

    Hello, as the title states, I have an ASA 5505 at one facility that is only getting around 16mb down on a 100mb circuit. No errors on either interface, and we've tried manually setting port speed and duplex, and auto, (both sides show it negotiating at 100 / full).
    Here is the sanitized config:
    : Saved
    : Written by mlsysadmin at 05:43:12.139 CST Fri Mar 6 2015
    ASA Version 8.2(5) 
    hostname fw01
    domain-name domain.com
    enable password xxxxxxxx encrypted
    passwd xxxxxxxx encrypted
    names
    name x.x.x.x WindStream-External-3100
    interface Ethernet0/0
     switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
     nameif inside
     security-level 100
     ip address 172.16.5.254 255.255.255.0 
    interface Vlan2
     nameif outside
     security-level 0
     ip address WindStream-External-3100 255.255.255.248 
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    dns server-group DefaultDNS
     domain-name materialogic.com
    same-security-traffic permit intra-interface
    object-group network obj-SrcNet
    object-group network obj-amzn
    access-list inside_access_in extended permit ip any any 
    access-list inside_access_in extended permit tcp any any 
    access-list inside_access_in extended permit tcp 172.16.5.0 255.255.255.0 172.17.5.0 255.255.255.0 
    access-list outside_access_in extended permit ip x.x.x.x 255.255.255.248 172.16.5.0 255.255.255.0 
    access-list outside_access_in extended permit icmp any any 
    access-list outside_access_in extended permit ip 10.10.200.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list outside_access_in extended permit icmp 10.10.0.0 255.255.0.0 172.16.5.0 255.255.255.0 
    access-list outside_access_in extended permit tcp 172.16.5.0 255.255.255.0 172.17.5.0 255.255.255.0 
    access-list outside_access_in extended permit tcp interface outside 172.16.5.0 255.255.255.0 
    access-list acl-amzn extended permit ip any 10.10.0.0 255.255.0.0 
    access-list acl-amzn extended permit ip 172.16.5.0 255.255.255.0 172.16.3.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.5.0 255.255.255.0 172.16.4.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.3.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.4.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.2.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list acl-amzn extended permit ip 172.16.5.0 255.255.255.0 172.16.2.0 255.255.255.0 
    access-list amzn-filter extended permit ip 10.10.0.0 255.255.0.0 172.16.5.0 255.255.255.0 
    access-list amzn-filter extended permit icmp 10.10.0.0 255.255.0.0 172.16.5.0 255.255.255.0 
    access-list amzn-filter extended permit ip any any 
    access-list <outside_access_in> extended permit ip host 54.240.217.164 host WindStream-External-3100 
    access-list <outside_access_in> extended permit ip host 72.21.209.193 host WindStream-External-3100 
    access-list inside_mpc extended permit ip 172.16.0.0 255.255.0.0 172.16.0.0 255.255.0.0 
    access-list NORAND extended permit ip 172.16.0.0 255.255.0.0 172.16.0.0 255.255.0.0 
    access-list outside_cryptomap extended permit ip any 10.10.0.0 255.255.0.0 
    access-list outside_cryptomap extended permit ip 172.16.5.0 255.255.255.0 172.16.4.0 255.255.255.0 
    access-list outside_cryptomap extended permit ip 172.16.4.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list outside_cryptomap extended permit ip 172.16.3.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list outside_cryptomap extended permit ip 172.16.5.0 255.255.255.0 172.16.3.0 255.255.255.0 
    access-list inside_nat0_outbound extended permit ip 172.16.5.0 255.255.255.0 172.17.5.0 255.255.255.0 
    access-list inside_nat0_outbound extended permit ip 172.17.5.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list inside_nat0_outbound extended permit tcp 172.17.5.0 255.255.255.0 172.16.5.0 255.255.255.0 
    access-list inside_nat0_outbound extended permit tcp 172.16.5.0 255.255.255.0 172.17.5.0 255.255.255.0 
    pager lines 24
    logging enable
    logging timestamp
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    icmp permit any outside
    no asdm history enable
    arp timeout 14400
    nat-control
    global (outside) 1 interface
    nat (inside) 0 access-list acl-amzn
    nat (inside) 1 0.0.0.0 0.0.0.0
    access-group inside_access_in in interface inside
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 40.139.91.233 1
    route inside 172.16.2.0 255.255.255.0 172.16.5.1 1
    route inside 172.16.3.0 255.255.255.0 172.16.5.1 1
    route inside 172.16.4.0 255.255.255.0 172.16.5.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL 
    aaa authentication http console LOCAL 
    http server enable
    http server idle-timeout 1440
    http 192.168.1.0 255.255.255.0 inside
    http 172.16.0.0 255.255.0.0 inside
    http 216.43.24.82 255.255.255.255 outside
    http 64.199.141.26 255.255.255.255 outside
    snmp-server host inside 10.10.10.20 community mlogic
    snmp-server location 3100 Communications room
    no snmp-server contact
    snmp-server community mlogic
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sysopt connection timewait
    sysopt connection tcpmss 1387
    sla monitor 1
     type echo protocol ipIcmpEcho 10.10.0.1 interface outside
     frequency 5
    sla monitor schedule 1 life forever start-time now
    crypto ipsec transform-set transform-amzn esp-aes esp-sha-hmac 
    crypto ipsec security-association lifetime seconds 3600
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto ipsec security-association replay window-size 128
    crypto ipsec df-bit clear-df outside
    crypto map amzn_vpn_map 1 match address acl-amzn
    crypto map amzn_vpn_map 1 set pfs 
    crypto map amzn_vpn_map 1 set peer 54.240.217.164 72.21.209.193 
    crypto map <amzn_vpn_map> 1 match address acl-amzn
    crypto map <amzn_vpn_map> 1 set pfs 
    crypto map <amzn_vpn_map> 1 set peer 54.240.217.164 72.21.209.193 
    crypto map <amzn_vpn_map> 1 set transform-set transform-amzn
    crypto map <amzn_vpn_map> interface outside
    crypto isakmp identity address 
    crypto isakmp enable outside
    crypto isakmp policy 201
     authentication pre-share
     encryption aes
     hash sha
     group 2
     lifetime 28800
    telnet timeout 5
    ssh 172.16.0.0 255.255.0.0 inside
    ssh x.x.x.x 255.255.255.255 outside
    ssh x.x.x.x 255.255.255.255 outside
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 216.171.120.36 source outside
    webvpn
    group-policy filter internal
    group-policy filter attributes
     vpn-filter value amzn-filter
    username mlsysadmin password E9OpTNVP3nVbSPSb encrypted privilege 15
    username mlsysadmin attributes
     vpn-group-policy DfltGrpPolicy
     vpn-access-hours none
     vpn-simultaneous-logins 3
     vpn-idle-timeout 30
     vpn-session-timeout none
     vpn-filter none
     ipv6-vpn-filter none
     vpn-tunnel-protocol IPSec l2tp-ipsec svc 
     password-storage disable
     group-lock none
    tunnel-group 54.240.217.164 type ipsec-l2l
    tunnel-group 54.240.217.164 general-attributes
     default-group-policy filter
    tunnel-group 54.240.217.164 ipsec-attributes
     pre-shared-key IySxccNmUch6G3dVSgEwBjjGX7bOAcO3
     isakmp keepalive threshold 10 retry 3
    tunnel-group 72.21.209.193 type ipsec-l2l
    tunnel-group 72.21.209.193 general-attributes
     default-group-policy filter
    tunnel-group 72.21.209.193 ipsec-attributes
     pre-shared-key vy.pOkCV01pEtmxe.QNk96xK6Uo_2tD.
     isakmp keepalive threshold 10 retry 3
    class-map NORAND
     match access-list inside_mpc
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map 
      inspect ftp 
      inspect h323 h225 
      inspect h323 ras 
      inspect rsh 
      inspect rtsp 
      inspect esmtp 
      inspect sqlnet 
      inspect skinny  
      inspect sunrpc 
      inspect xdmcp 
      inspect sip  
      inspect netbios 
      inspect tftp 
      inspect ip-options 
    policy-map NORAND
     class NORAND
      set connection random-sequence-number disable
      set connection advanced-options tcp-state-bypass
    policy-map TRAFFIC_SHAPING
     class class-default
      shape average 100000000
    service-policy global_policy global
    service-policy NORAND interface inside
    service-policy TRAFFIC_SHAPING interface outside
    smtp-server 206.225.164.242
    prompt hostname context 
    no call-home reporting anonymous
    : end
    Here are show interface command outputs:
    fw01# show interface ethernet 0/0
    Interface Ethernet0/0 "", is up, line protocol is up
      Hardware is 88E6095, BW 100 Mbps, DLY 100 usec
            Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)
            Input flow control is unsupported, output flow control is unsupported
            Available but not configured via nameif
            MAC address fc5b.397f.dbd5, MTU not set
            IP address unassigned
            23888810 packets input, 6278082364 bytes, 0 no buffer
            Received 7728 broadcasts, 0 runts, 0 giants
            0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
            0 pause input, 0 resume input
            0 L2 decode drops
            35886 switch ingress policy drops
            42947220 packets output, 57958727970 bytes, 0 underruns
            0 pause output, 0 resume output
            0 output errors, 0 collisions, 0 interface resets
            0 late collisions, 0 deferred
            0 rate limit drops
            0 switch egress policy drops
            0 input reset drops, 0 output reset drops
    fw01# show interface ethernet 0/1
    Interface Ethernet0/1 "", is up, line protocol is up
      Hardware is 88E6095, BW 100 Mbps, DLY 100 usec
            Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)
            Input flow control is unsupported, output flow control is unsupported
            Available but not configured via nameif
            MAC address fc5b.397f.dbd6, MTU not set
            IP address unassigned
            59448427 packets input, 58925402473 bytes, 0 no buffer
            Received 547758 broadcasts, 0 runts, 0 giants
            0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
            0 pause input, 0 resume input
            0 L2 decode drops
            58718 switch ingress policy drops
            37419921 packets output, 8188660665 bytes, 0 underruns
            0 pause output, 0 resume output
            0 output errors, 0 collisions, 0 interface resets
            0 late collisions, 0 deferred
            0 rate limit drops
            0 switch egress policy drops
            0 input reset drops, 0 output reset drops
    When we connect a laptop to the router directly, we are able to get the expected speeds. When we connect through the ASA, download speed is topping out around 16mb, while upload is a consistent 75mb+

    Have you tried running without the "service-policy TRAFFIC_SHAPING interface outside" ? Just to check.

  • Very slow download speed with intermittent halts

    Need some help.
    I run Apple os/x latest version and have since yesterday begun to experience constant very slow download speeds.
    I have rebooted the router and I have reset it. I have tested with wireless and wired into router. No real change.
    The results are below and are pretty consistent no matter when or with what computer I test it with.
    This is very frustrating and I would like to know if anyone has experienced this and if there is anything I can do before calling for service.
    Thank you in advance.
    Checking for Middleboxes . . . . . . . . . . . . . . . . . . Done
    SendBufferSize set to [131768]
    running 10s outbound test (client to server) . . . . . 5.44Mb/s
    running 10s inbound test (server to client) . . . . . . 1.94Mb/s
    ------ Client System Details ------
    OS data&colon; Name = Mac OS X, Architecture = x86_64, Version = 10.8.2
    Java data&colon; Vendor = Apple Inc., Version = 1.6.0_37
    ------ Web100 Detailed Analysis ------
    Client Receive Window detected at 359104 bytes.
    10 Mbps Ethernet link found.
    Link set to Full Duplex mode
    Information: throughput is limited by other network traffic.
    Good network cable(s) found
    Normal duplex operation found.
    Web100 reports the Round trip time = 22.89 msec; the Packet size = 1448 Bytes; and
    There were 159 packets retransmitted, 288 duplicate acks received, and 394 SACK blocks received
    The connection stalled 9 times due to packet loss
    The connection was idle 2.01 seconds (16.75%) of the time
    This connection is sender limited 35.49% of the time.
    This connection is network limited 64.51% of the time.
    Excessive packet loss is impacting your performance, check the auto-negotiate function on your local PC and network switch
    Web100 reports TCP negotiated the optional Performance Settings to:
    RFC 2018 Selective Acknowledgment: ON
    RFC 896 Nagle Algorithm: ON
    RFC 3168 Explicit Congestion Notification: OFF
    RFC 1323 Time Stamping: ON
    RFC 1323 Window Scaling: ON
    Information: Network Middlebox is modifying MSS variable
    Server IP addresses are preserved End-to-End
    Information: Network Address Translation (NAT) box is modifying the Client's IP address
    Server says [71.100.xxx.xxx] but Client says [192.168.1.9]

    Both wired or wireless.
    auto - negotiate 
    Thank you.

  • Getting most coverage/download speed out of Three Airport Extremes & One Express

    Aloha Apple Genius's please....HELP:-)
    I have been having the following coverage/download speed issues with my new network installed in a couple of our buildings.
         A) Mac gets 0.5 to 1.5Mbps download and 4.0-5.0Mbps upload and it connects to stongest signal given off by 9WBB Building #2...But Slower Speed
    Sitting on the Porch or in Building #2
    Network Normal:
    Strong Signal
    Slower speed
         B) If I TURN OFF 9WBB Mac gets 15-22Mbps dowload and 20Mbps upload connects to weaker signal given off by 9WB Building #1....But Faster           Speeds.
    Sitting on Porch or in Building #2
    Network limited:
    Weaker signal
    Faster Speed
    QUESTIONS:
    How can I maximize the download speed or manually switch which Airport Exteme my Mac connects to with out having to power down 9WBB Building #2 all the time?
         2. Or can I tell mac to always pick SPEED over SIGNAL STRENGTH??
         3. How can I better monitor my network and speeds?
         4. Can I block users from using network individually?
    I have a network set up with the following schematic:
    Building and Physical Layout of Network below:

    Anyways, I guess what I'm asking is if there are any settings I can use to simply allow my internet to be as fast and as consistent as possible, albeit a rather hopeful and juvenile request.
    The Internet speed vs. the wireless network speed are two distinctly different things, with the wireless network speed, in almost all cases, being much faster. Of course, since most of us see "speed" as the overall time it takes to, let's say, open a web page or download a file from the Internet, it's easy for us to "combine" the two.
    Unless you work with your ISP, there's not much you can do about your Internet speed, but there might be something you can do about your wireless speed.
    Since you mentioned that you have detected about a dozen wireless signals, it is very possible that you may have some form of Wi-Fi interference in the immediate area that is preventing you from getting a good clean signal.
    I suggest you perform a simple site survey, using utilities like the following to determine potential areas of interference, and then, try to either eliminate or significantly reduce them where possible:
    For Macs:
    o KisMAC
    o MacStumbler
    o iStumbler, or
    o IPNetMonitorX
    For PCs:
    o NetStumbler
    o WiFi Hopper
    o WiFi Owl
    o WiFi Manager

  • 3meg DSL Download speed running at dial-up speed

    Since last week I’ve been getting DSL download speeds that are basically dial-up speeds.  I have the 3 meg plan and for the past 10 years or so, I came close to a 2 meg download connection speed regularly.
    Last week my download speed basically disappeared.  I spent hours on the phone with Verizon Tech Support during the week.  (Their standared 72 hours to assign a service call after creating a service ticket is bogus.) A Verizon DSL tech spent 5 hours at my house on Saturday and said the problem is on VERIZON’S END with their servers.  He did it all, replaced internal wires, used his modem for the tests, checked speeds at the NID, took the router out of play, tried to get new wires from the service on the street, and still could not resolve the issue. 
    I show the correct 3360/864kbs connection on my DSL Modem (Actiontec GT701D) but my download speed is averaging 33K to 60K using 4 different speed tests.  DSL disconnects at random also. My upload speed is typically around 700kbs – where it should be.
    My most recent test is from this morning:
    Checking for Middleboxes . . . . . . . . . . . . . . . . . . Done
    SendBufferSize set to [8192]
    running 10s outbound test (client to server) . . . . . 591.76Kb/s
    running 10s inbound test (server to client) . . . . . . 60.33kb/s
    ------ Client System Details ------
    OS data: Name = Windows Vista, Architecture = x86, Version = 6.0
    Java data: Vendor = Sun Microsystems Inc., Version = 1.6.0_24
    ------ Web100 Detailed Analysis ------
    Client Receive Window detected at 17424 bytes.
    Cable modem/DSL/T1 link found.
    Link set to Full Duplex mode
    Information: throughput is limited by other network traffic.
    Good network cable(s) found
    Normal duplex operation found.
    Web100 reports the Round trip time = 106.05 msec; the Packet size = 1452 Bytes; and
    There were 33 packets retransmitted, 59 duplicate acks received, and 63 SACK blocks received
    The connection stalled 4 times due to packet loss
    The connection was idle 1.36 seconds (5.03%) of the time
    This connection is network limited 99.9% of the time.
    Excessive packet loss is impacting your performance, check the auto-negotiate function on your local PC and network switch
    Web100 reports TCP negotiated the optional Performance Settings to:
    RFC 2018 Selective Acknowledgment: ON
    RFC 896 Nagle Algorithm: ON
    RFC 3168 Explicit Congestion Notification: OFF
    RFC 1323 Time Stamping: OFF
    RFC 1323 Window Scaling: ON
    Information: Network Middlebox is modifying MSS variable
    Server IP addresses are preserved End-to-End
    Information: Network Address Translation (NAT) box is modifying the Client's IP address
    Server says [{edited for privacy}] but Client says [192.168.1.100]
    My DSL STATUS from this morning is:
    DSL Status
    VPI: 0
    VCI: 35
    DSL Mode Setting : MMODE
    DSL Negotiated Mode: G.DMT
    Connection Status: Showtime
    Speed (down/up): 3360/864kps
    ATM WoS Class:  UBR
    Near End CRC Errors: 0/0
    Far End CRC Errors: 0/73045
    Near End CRC (Within Last 30 mins): 0/0
    Far End CRC (Within Last 30 mins): 0/0
    Near End RS FEC: 0/68
    Far End RS FEC: 0/0
    Near End FEC (Within Last 30 mins): 0/0
    Far End FEC (Within Last 30 mins): 0/0
    Discarded Packets(Within last 30 mins): 0/0
    SNR Margin (Downstream/Upstream): 0/14
    Attenuation (Downstream/Upstream): 119/30
    This performance drop off is totally unacceptable.  What’s really interesting is that my service call has been closed out as “resolved”.  Which is obviously has not.  I am now being forced to go through support again to “diagnose” my problem.
    I’ve been researching (painfully) these speed issues and have determined they are a chronic problem going back to at least 2006 for many DSL customers.  The issue seems to be they have oversold DSL services and overcrowd their local Central Office servers and routers.  There is supposed to be some performance issue regarding Redbank and Juniper switches.  Redbank is supposed to be more reliable and Juniper aren't so.  I also believe their latest “optimizing” software may also be part of the problem.
    For the first time EVER, I am seriously considering converting to COMCAST because no one at Verizon (other than the DSL tech) will acknowledge they are the cause of my issue.
    Anyone have a realistic idea as to what needs to be done at the Central Office to correct this issue? 
    Thanks for your time.

    Consider yourself lucky. I have had the 3Mb plan for over ten years and initially had regular speeds of 1.5 to 3.0...until a new development was put in a block away, they were connected to Verizon, and my speeds dropped to 205 kbps down/805 kbps up at the copper drop in my basement. Many calls to Verizon resulted in modem upgrades (currently the Westell 6100) and reassurances from Verizons foreign help desk that my service was performing normally. Promises of FIOS soon being available in my area (Cedar Brook, NJ) have kept me hanging on but I stopped holding my breath a few years ago.  Hopefully your service will be restored - mine most likely never will.

  • Poor download speed

    I installed my infinity package yesterday im only getting a download speed of about 1.2 mbs, can anyone help?

    My cabinet is 3/10 mile away as the crow flies, and the copper cable is many years old, the telegraph pole outside my house in the cul de sac has been up for many years now (and the cables from the pole to my house have never been changed). OMFG I dread to think how old actually considering the state of the attached wiring to the underside of my eaves, it looks like it was screwed on in Victorian times.
    BT send an engineer to you to connect some box to your pc, and someone has worked on a green cabinet, but outside your house will be wiring that was put up by the post office when they owned BT as a nationalised industry, it looks that old.
    The 3/10 mile distance is probably way longer in reality and all the way along the streets to me the cabling is joined together here and there (it is not one long continuous wire).
    Next up, there is one decent sized housing estate being supplied by that cabinet, many hundreds of homes, and lots are connected to BT and run multiple wireless and wired devices all the time, and especially after school and evening times, what with xboxes and the likes all playing WOW and on youtube n whatever. Each and every one feeding off a limited supply of broadband being fed to that cabinet from the exchange, and for every one that switches on, the average going round drops.
    If like me you are right at the rear end of the queue for bandwidth you are probably getting a tiny fraction of any bandwidth being promised, and at peak times as all these xboxes are being switched on your bandwidth does as mine does and drops to kilobytes per second, it gets that bad I lose webpages altogether. I have problems on firefox or explorer getting a homepage to load even at peak times.
    Consider a lorry in a place throwing out rice to starving people, the guys are throwing out the stuff but the front keeps taking most of it and the ones right at the back are getting the least.
    Solution.... switch to a provider who supplies fibre to your living room and not to your area, move to a house right beside a cabinet, don't listen to the people on here (who are NOT BT EMPLOYEES but other customers) who cannot solve this problem but only pay lip service, or do as I am doing, and wait until the contract expires and changing to my first solution above.
    Lastly, consider these points ...
    I upgraded to Infinity 2 last July and have NEVER had speeds over 3 mb/sec download, my pc is hard wired to my home hub 3 box (and runs on windows 8 with 4 Gig dual ddr3 ram on an AMD Phenom 2 X2 chip) even though I was told min 25 mb/sec, and the old phone sex lie about "up to 75 mb/sec". It's done over the phone cos eye contact would immediately detect a bare faced lie.
    I have complained over the phone many times and been fed all the nonsense I never even thought was possible, one Indian even told me to hang up, switch off my phone for 2 hours and my speeds would immediately be doubled to 50 mb/sec. 2 hours later, same old shoite service. I have now complained by email and am waiting for a follow up but am not holding my breath.
    If you are still in the cancellation contract period, do it!

  • Apple TV2 Download Speed

    Just curious if there's a way to see connection/download speeds on this. Similar to running speedtest.net app on a phone or ipad. I'm not having any problems, just simple curiosity. I see the signal strength indicator in settings and I know there is a network test that can be run but I've never seen any info after doing that. I assume if it detected a problem you'd get some kind of onscreen message.
    Just in case of a future issue this might enable me to tell whether there was an issue with Apple's servers or with my own internet service.

    Does it? Mine only sends the result to Apple and only tells me if it's not connected.
    Yes, at least mine does. It ask if your experiencing slow downloads and what your connection speed is, runs a download test and reports if the test was successful.

  • E4200 Poor Qos Upload Speed Detection

    I've seen people with occasional issues like this in the past, but has anyone noticed that enabling auto detection of the upstream bandwidth in the qos tab results in a significantly lower than normal maximum upload speed? I have the Blast plan from comcast (20/2 sustained; 30/4 with powerboost). Here are the results.
    With the Qos OFF:
    Estimating capacity:
    Upstream: 4163 Kbps.
    Downstream: 29079 Kbps.
    The measurement will take upto 2.5 minutes. Please wait.
    Checking for traffic shapers:
    Upstream: Burst size: 9894-9970 KB;
    Shaping rate: 2090 Kbps.
    Downstream: Burst size: 19571-19934 KB;
    Shaping rate: 21280 Kbps.
    Estimating capacity:Upstream: 4163 Kbps.Downstream: 29079 Kbps.
    The measurement will take upto 2.5 minutes. Please wait.
    Checking for traffic shapers:
    Upstream: Burst size: 9894-9970 KB;Shaping rate: 2090 Kbps.
    Downstream: Burst size: 19571-19934 KB;Shaping rate: 21280 Kbps.
    With Qos on AUTO:
    Estimating capacity:
    Upstream: 1433 Kbps.
    Downstream: 30919 Kbps.
    The measurement will take upto 3.0 minutes. Please wait.
    Checking for traffic shapers:
    Upstream: No shaper detected.
    Median received rate: 1488 Kbps.
    Downstream: Burst size: 19142-19603 KB;
    Shaping rate: 21317 Kbps.
    With Qos ON Manual 2mbps:
    Estimating capacity:
    Upstream: 1431 Kbps.
    Downstream: 31001 Kbps.
    The measurement will take upto 3.0 minutes. Please wait.
    Checking for traffic shapers:
    Upstream: No shaper detected.
    Median received rate: 1456 Kbps.
    Downstream: Burst size: 19087-19563 KB;
    Shaping rate: 21280 Kbps.
    I don't work for Cisco. I'm just here to help.
    Solved!
    Go to Solution.

    I can confirm these identical issues.  With speed measured via speedtest.net and firmware 1.0.02:
    QoS off, I get 36Mb down, 6.7Mb up
    QoS on with Auto upstream detection I get 35-36Mb down, but very erratic, 1Mb up.  Also, it takes a few seconds longer (very noticeable) for the upstream test to even start.
    QoS on with 6Mbits specified manually I get 36Mb stable down and around 4Mb up (no noticeable delay on starting the upstream tests).
    QoS on with 10Mbits specified manually (basically I lied to it), I get back to 36Mb stable down and about 6.5Mb up.
    All of these tests are very repeatable.
    Not only would I like to see the Auto fixed, but I think taking such a large hit in download speed is a major problem.  The packets for higher priority services should be prioritized, not reserved.  My one QoS device (my Ooma Telo) was completely quiet during all of this testing so my speedtest traffic should have had nearl all of my bandwidth, no?

  • In Firefox can not see the Downloads window, in the jump in the boot to be seen - the download speed Downloaded much and now can not see how to fix it?

    in Firefox can not see the Downloads window, in the jump in the boot to be seen - the download speed
    Downloaded much and now can not see how to fix it?

    I hate the new downloads-in-a-tab scheme. This was an unnecessary change in my book (if it aint broke, don't "fix it").
    So in order to get it back, I performed the about:config browser.download.useToolkitUI change, but now all I get is a blank download window that pops up every time I download something.
    Is there something else that I need to do? I've checked the change and it was saved, but it didn't resolve my issue as much as it just caused me a new issue.

  • WRT310N Playstation 3 Slow Download speed and general lag

    Hey guys, I just recently bought the WRT310N and got both of my computers working with it. One is wired directly into the router, while the other is running off wireless. My Playstation 3 is able to connect to the router but I am getting an extremely slow connection speed.
    Right now, both PC's get about 6.4-6.5 Mbps download speed while my Playstation is anywhere from 600 Kbs to 1.2 Mbps. I have plugged in my Playstation 3 directly into the modem and got a speed of 3.2 Mbps and was downloaded a demo very fast, but I do not recieve anywhere near those results when using it wireless.
    Any advice? I have tried opening the ports, but that only seemed to slow it down. A couple of days ago I opened the ports specific to the game NHL 10 and for two days I was getting such a good speed in the game that it felt like I was playing offline, which was great! Then this morning, it just seemed do a complete 180. Now when I play the game I get an extreme amount of lag, and my other games like CoD4 get random lag spikes. Like, I'll be running and I get a lag spike which seems to happen fairly consistently every minute or so.
    Any advice? Should I try opening the ports again or what?
    Message Edited by Nimer on 10-02-2009 03:58 PM

    I think you need to adjust the wireless settings of your Router, The wireless settings on your Router must have been setup to its default that's the reason you are receiving low signal strength on your PS3.
     Open an Internet Explorer browser page on your wired computer(desktop).In the address bar type - 192.168.1.1 and press Enter...Leave Username blank & in Password use admin in lower case...
    For Wireless Settings, please do the following : -
    Click on the Wireless tab
    - Here select manual configuration...Wireless Network mode should be mixed...
    - Provide a unique name in the Wireless Network Name (SSID) box in order to differentiate your network from your neighbours network...
    - Set the Radio Band to Standard-20MHz and change the Standard channel to 11-2.462GHz...Wireless SSID broadcast should be Enabled and then click on Save Settings...
    Please make a note of Wireless Network Name (SSID) as this is the Network Identifier...
    For Wireless Security : -
    Click on the Sub tab under Wireless > Wireless Security...
    Change the Wireless security mode to WPA, For Encryption, select TKIP...For Passphrase input your desired WPA Key. For example , MySecretKey , This will serve as your network key whenever you connect to your wireless network. Do NOT give this key to anyone and remember the key.
    NOTE : Passphrase should be more that 8 characters...
    Click on Advanced Wireless Settings
    Change the Beacon Interval to 75 >>Change the Fragmentation Threshold to 2304, Change the RTS Threshold to 2304 >>Click on "Save Settings"...
    Now see if you can locate your Wireless Network and attempt to connect...

  • Loss of download speed using airport extreme and express.

    I have Wifi using an Airport extreme base station and an airport express extender.  However, the download speed drops from 21 Mbps to 8 Mbps. Any suggestions to boost the express other than an ethernet connection which would be difficult.

    Temporarily, power down the AirPort Express and take speed measurement at that exact location.
    Whatever that is.....likely in the 8-10 Mpbs range......is what the Express will try to "extend".
    In other words, the Express can only extend the bandwidth or speed that it receives. It cannot make the connection that it receives go any faster. In that regard, the term "repeater" is probably a more accurate description of what the Express is trying to accomplish.
    If you want the Express to extend faster speeds, then it must be located closer to the AirPort Extreme. In addition, anything that you can do to reduce any obstructions in the signal path between the AirPorts will help.
    Ideally, you want a line-of-sight relationship between the AirPorts to help reduce the amount of speed loss that occurs with any wireless connection.

  • New Infinity 2 poor real life download speeds

    Hi
    I'm hoping someone can help. I had infinity 2 installed on Tuesday and have had poor download speeds since. Now I use mainly iPads and iPhones for connecting to the internet.
    My connection downstream on my modem says I'm connected at 78.12 Mbps however I can stand right next to it and try download something from sky go and this downloads at 11-12mbps. This doesn't seem right to me however as it is wireless devices the BT help centre will not help me.
    Solved!
    Go to Solution.

    Are you sure that it is your speeds that are slow or are you possibly confusing your Megabyte (MB) with Megabit (Mb)
    A Megabyte (used for file size) and a Megabit (used for download speeds). People often assume that a download speed of 1 Megabit per second (1 Mbps) will allow them to download a 1 Megabyte file in one second. This is not the case, a Megabit is 1/8 as big as a Megabyte, meaning that to download a 1MB file in 1 second you would need a connection of 8Mbps. Most downloads are shown as MB/s
    If this is not the problem can you use this speed tester then carry out the further diagnostics and post back a screen shot of all the results including your IP profile for up and down. This test must be done with a wired connection for an accurate reading.
    http://speedtest.btwholesale.com/

  • Slow Internet download speed, OSX 10.9.5

    Since updated to 10.9.5, my Mac Pro Internet download speed down to 7 Mbps,
    and same on My MacBook Pro 10.9.5 too. both use to be 70 Mbps.
    I am paying $50.00 extra to get the highest speed from Time Warner.
    My iMac is 10.9.3, tops 70 Mbps.
    My iPhone 5s tops tops 30 Mbps
    All in same WiFi network.
    Upload speed all seem to be fine with 5 Mbps.
    Mac Pro = Mid 2010
    Processor  2.8 GHz Quad-Core Intel Xeon
    Memory  16 GB 1066 MHz DDR3 ECC
    Graphics  ATI Radeon HD 5770 1024 MB
    Mac Book Pro = Retina, 13-inch Late 2012
    Memory = 8 GB
    Something wrong!

    Even the 'respected' tools like Onyx, if you look at what (each and every update) states in the "what is new" and changes will be to improve compatibility.
    Never use or install anything (and I include OS X updates in that category) without cloning your system and having TimeMachine that is current, and backup(s) that will be off line.
    Some cannot be trashed or deleted or removed without using an "uninstall app" or the installer, doing so without can mean having to reinstall first.
    Or wipe the drive and restore from a known good backup set.
    Some tips:
    https://discussions.apple.com/thread/6522256
    What to look for if your system is slower than normal etc:
    https://discussions.apple.com/thread/4873022
    for malware, check out this user tip (and his other pages too!)

  • V e e e r r y   S l o o o o w  Movie Rental Download Speeds

    My setup: In my home office is a cable modem connected to my locally owned and operated ISP's coax feed. It's a city operated fiber network (Ashland Fiber Network), not a ComCast/Charter/Verizon conglomerate. The modem is connected to a Time Capsule (500 MB) via ethernet. Also connected to the Time Caspsule via Ethernet is a 2.4 GHz 24" iMac. The Apple TV is in my living room about 30' away through one wood-frame wall.
    I get consistent >8 Mb/sec download speeds from Speedtest.net both on my office (Ethernet) iMac and on my MacBook via 802.11g while sitting next to the Apple TV in my living room. The Apple TV shows 5 bars on its signal strength meter, and is running the latest (2.02) software. I have the Airport Utility setup to run 802.11n (802.11b/g compatible) so that it'll work with both the Apple TV and my 802.11g MacBook. There are no 2.4 GHz wireless phones in my house, and no other WiFi devices connected. There are several other WiFi networks within range in my neighborhood, but I use WPA2 Personal security to isolate my network.
    My problem: I have tried only 1 SD movie download. but it took 37 minutes to reach "Ready to Play," and then choked after playing for 56 minutes. So rather than wait for more of the movie to download, I went to bed and watched the rest of it the next day. I've rented 2 HD movies, the first download notice told me that it would take 13 hours to be ready to play, and the next said 11 hours. Both times I just went to bed and watched the movie the next day.
    Trailers generally take anywhere from 2-5 mins. to begin playing, and they almost always choke after about a minute and have to download more to continue playing. They play much faster on my iMac when downloaded from Apple's Quicktime site, though I can't be sure if different servers are involved there.
    This scenario does not jibe at all with what Apple tells me I should expect from the Apple TV, nor with what I read about here on the Apple Discussion boards.
    Things I've tried: 1) Changing the WiFi channel from Auto to a discrete channel--I've tried four different channels now. 2) Switching to 802.11n only--both at 2.4 GHz and at 5 Ghz. 3) Unplugging and removing the batteries from my 5.8 GHz wireless phones. 4) Moving the Apple TV a 6' HDMI cable's length away from the TV and sound system in my living room. 4) Resetting everything several times, even once back to 2.0 before reinstalling 2.02. 5) I even unplugged the microwave in the kitchen. About the only obvious thing I haven't yet tried is stringing an ethernet cable from my Time Capsule to the Apple TV because I don't have one that long and would rather not strip down my entire setup just to test that. But it looks like I'm going to have to.
    I've had four conversations with Apple tech support, the last one after being bumped up to level 2 support. They had me do (among other things) a 100-ping test using Network Utility between the my iMac and the Apple TV--no dropped packets and the network speed was, according to them, well within spec. When I told them all the other stuff I've tried, they had no suggestion other than: "Something is interfering with your signal."
    I took the Apple TV to my local Apple Authorized Dealer (the nearest Apple Store is 300 miles away). It checked out fine and ran great on their network. I got to try downloading a few trailers there and they ran almost instantaneously. Now, they informed me that their network runs at ~15 Mb/sec, but they also have about 30 computers hooked up to it.
    Anyway, I read here that almost all of you are seeing much faster download speeds on your Apple TVs, even those of you with DSL. And it seems pretty clear that I'm experiencing some sort of interference here, but can't seem to locate the source. So, my question is: What other possible sources of interference might I be getting, and how might I go about locating them?

    cause i bot stock wrote:
    How does downloading via your iMac respond?
    I haven't tried downloading a movie from iTunes to see if there's a substantial difference, and you can't rent HD movies from iTunes, only SD. Trailers download faster, but there's no telling if they're coming from the same servers as Apple TV's trailers (nor if iTunes movies are, for that matter).
    I'm quick to blame the time capsule and time machine. Similar to your problems with AppleTV, I've never had time machine work properly. All it does is suck up all my resources while taking days to do anything.
    Unlike some, I've had zero setup or operating problems with my Time Capsule. Works like a charm and doesn't seem to slow anything down on my iMac as far as I can tell.

Maybe you are looking for

  • Firefox 11 freezes and is lagging after few minutes. Youtube Videos are laggy while the sound is normal. Can you help me to solve this problem?

    If I restart my browser everthing works just fine for at least 5 minutes. When I watch several youtube videos, the lag comes back and the video starts to freeze aboud every second for just a faction of a second. The sound is stil played properly it o

  • How to use "&Total physical pages" in the format trigger?

    Hi all: How should I to use the system variable "&Physical page number" and "&Total physical pages" in the format trigger? I can not use these 2 variables in the format trigger directly or i will reveive an error message. Thank You!

  • Privacy settings on photoshop express app

    I downloaded the photoshop express app to my iphone.  I initially chose not to allow it to 'work' from my camera roll.  Now, I realize I do need that and need to find how to allow this.  The directions are to go the privacy settings and change.  Howe

  • Adobe Programs Not Working-Need Help

    All my Adobe programs are unresponsive in my Mac Book Pro. Every time I open a program, after it loads up it virtually freezes. Every click I do, even if its not meant to do anything brings up the rainbow wheel, meaning a big operation is being done,

  • Photoshop and Font Book

    Just upgraded from Snow Leopard to Mountain Lion and Photoshop (CS3) no longer recognises FontBook's management... I'm just seeing all the fonts in the font library(s) whether I have them disabled in FontBook or not. Is this a FontBook or Photoshop i