Dual stack multi-home BGP

I have a design I'm working on which will require among other things dual stack across MPLS. Configuring CE routers for dual stack seems very straight forward, however I'm having trouble finding documentation describing the BGP config for multihoming and load sharing with 2 routers and 2 service providers. I've configured this quite a few times with HSRP and BGP for IPv4 similar to this example:
http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml#conf5
Am I looking at this wrong or are these scenarios just not widely published yet?
Any help is greatly appreciated!
thanks,
Josh

Hi Josh,
You will have to understand the MBGP address families. One of the basic rule of MBGP is that when I'm advertising a route from a specific address family, the next hop has to be from the same address family. So, you will have to make sure the next hop is from the same address family. Couple of examples for you:
1. IPv6 NLRI in IPv4
router bgp 201
bgp router-id 192.168.30.1
neighbor 150.1.1.2 remote-as 301
address-family ipv6
neighbor 150.1.1.2 activate
neighbor 150.1.1.2 route-map SETNH out
network 2192:10::/48
route-map SETNH permit 10
set ipv6 next-hop 2150:1:1::3
2. IPv4 NLRI in IPv6
router bgp 201
bgp router-id 192.168.30.1
neighbor 2150:1:1::2 remote-as 301
address-family ipv4
neighbor 2150:1:1::2 activate
neighbor 2150:1:1::2 route-map SETNH out
network 192.10.0.0
route-map SETNH permit 10
set ip next-hop 150.1.1.3
I also came across this document which should help you: http://fengnet.com/book/Cisco.IOS.Cookbook.2nd/I_0596527225_CHP_25_SECT_11.html
Regards,
Salman

Similar Messages

  • Dual stack BGP Configuration guide for enterprise CPE

    Hi,
    I couldn't find the config guide for BGP in a IPv4 & IPv6 dual stack environment for CPE in Cisco website. Hope someone can share the URL.
    Thanks

    The following URL shows how to configure Multi-protocol BGP - http://www.cisco.com/en/US/docs/ios-xml/ios/iproute_bgp/configuration/15-mt/irg-15-mt-book.html.
    hth,
    -jim

  • Disable portal,km startup in multi-application dual stack

    Hello,
    We have a dual stack ECC installation with ESS,MSS,Portal and XECO on the java stack. We are currenty trying to run debug against the XECO components on the java stack. It appears that the debugger is getting very slow due to the multiple java applications. We would like to disble portal(km,cm), ess and mss for a few weeks while we complete our debugging with XECO.
    Is there anyway to disable the startup of portal,ess and mss?
    thanks in advance
    Vipin

    Hello Vipin,
    You can turn off any Java application easily from Visual Admin.
    Just login into Visual Admin and goto Cluster -> Server -> Services -> Deploy then in Runtime tab select Radio button Application. You will see all your Java application here. If you see check mark in front of your application, the app is running but if you see "x" sign then it's stopped.
    Select your application and click on "Stop Application" button on right side.
    Hope this will help you.
    Bijay

  • Dual-Stack LNS - ppp negotiation fails if no ipv6 prefix assigned by Radius

    Hello,
    We have an LNS (asr1k), dual-stack CPE and Radius server.
    Everything works fine if both ipv4 and ipv6 prefix is assigned to CPE by Radius
    If we set Radius server not to assign v6 prefix, we expect to build up an ipv4-only session over ppp.
    This is not what happens. PPP negotiation fails with the following debug lines:
    IPv6 DHCP_AAA: No authorization data from SSS
    Vi2.2364 PPP DISC: Non-PPP hang up
    some config parts of LNS:
    no ipv6 source-route
    ipv6 unicast-routing
    ipv6 dhcp binding track ppp
    ipv6 dhcp pool IPv6_DHCP_POOL
    ipv6 dhcp pool POOL_DHCP_PD
    ipv6 multicast-routing
    ipv6 multicast rpf use-bgp
    interface Virtual-Template99
     mtu 1460
     ip unnumbered Loopback0
     ip tcp adjust-mss 1420
     no logging event link-status
     ipv6 enable
     no ipv6 nd prefix framed-ipv6-prefix
     no ipv6 nd ra suppress
     ipv6 dhcp server POOL_DHCP_PD allow-hint
     peer default ip address pool adslpool_1 adslpool_2
     ppp max-configure 3
     ppp authentication pap AAA_AUTHEN_PPP_noc3x
     ppp authorization AAA_AUTHOR_NET_noc3x
     ppp accounting AAA_ACCT_NET_noc3x
     ppp ipcp address required
     ppp ipcp address accept
     ppp ipcp no-renegotiation send-termreq
     ppp link reorders
     ppp timeout retry 5
     ppp timeout ncp 30
     ppp timeout authentication 30
    end
    Can anyone help?
    Regards,
    Antal

    Have opend a case with cisco. The solution for me is to put
    no ipv6 dhcp ppp terminate
    in to the global config.
    Hope that helps anyone who has the same problem.

  • Dual Stack BW System refresh

    Hi All,
    We have to perform dual stack BW system refresh from production system to quality system and both are hosted on different hosts.For abap only systems generally we take online backup of production system and restor it to target and follow standard system refresh procedure.
    We have followed same strategy for dual stack systems and perform same stpes as followed in abap only systems but afterwards java was not up and running.
    So we planned to take export of database(ABAP+JAVA) and import it on target server.But since we cannot afford downtime for our BW production system so during export we unmark the option "STop Running System" so as to avoid downtime but our query is that since we are not stopping dual stack BW system then how the database will be in consistent state after import of database.
    Also please suggest if there is any alternate best proceduere that ensures dual stack BW system refresh by ensuirng no downtime of production system.
    Regards
    Joy Garg

    Hi Srinivas,
    We are trying to follow the same procedure,i have doene everything from scrap as per your recommendation but while importing and at step of entering export dump location i.e. Migration Depot screen on entering export dump location it is throwing error:
    You entered: /oracle/BWT/sapdata19/export_dualstack/JAVA Found the label SAP:JMIG:700::: but need the label SAP:MIG::EXPORT(1/::*
    Also please note that during export, a directory pack gets created in SDM home of source system and we have not transfer any of its file to export dump:
    euxc54:bwcadm 112> cd pack
    euxc54:bwcadm 113> ll
    total 2419644
    -rw-r-----   1 bwcadm     sapsys     506116963 Aug 22 13:21 packedOrigin_com.adobe.jar
    -rw-r-----   1 bwcadm     sapsys     727762223 Aug 22 13:20 packedOrigin_sap.com.jar
    -rw-r-----   1 bwcadm     sapsys      423957 Aug 22 13:21 packedSCAs.jar
    -rw-r-----   1 bwcadm     sapsys     4535940 Aug 22 13:21 sdmrepository.sdc
    euxc54:bwcadm 114> pwd
    /usr/sap/BWC/DVEBMGS01/SDM/program/pack
    ================================================================================
    Also please note that structure of export dump generated is as :
    euxc54:bwcadm 115> cd /oracle/BWT/sapdata19/export_dualstack
    euxc54:bwcadm 116> cd JAVA
    euxc54:bwcadm 117> ll
    total 48
    drwxrwxr-x   5 bwcadm     sapsys          96 Aug 22 13:24 APPS
    drwxrwxr-x   6 bwcadm     sapsys          96 Aug 22 13:07 DB
    drwxrwxr-x   2 bwcadm     sapsys          96 Aug 22 13:08 JDMP
    -rw-rw-r--   1 bwcadm     sapsys          19 Aug 22 13:07 LABEL.ASC
    -rw-rw-r--   1 bwcadm     sapsys          14 Aug 22 13:07 LABELIDX.ASC
    drwxrwxr-x   2 bwcadm     sapsys          96 Aug 22 13:22 SDM
    -rw-rw-r--   1 bwcadm     sapsys         193 Aug 22 13:07 SOURCE.PROPERTIES
    drwxrwxr-x   2 bwcadm     sapsys          96 Aug 22 13:18 TOOLS
    =================================================================================
    Database is Oracle 10g while OS is HP UX and note that ABAP syetm on refreshed is running fine.
    Please suggest.
    Regards
    Joy garg
    Edited by: Joy Garg on Aug 22, 2011 3:53 PM

  • Error in phase import Homogeneous system copy from a BI 7.3 dual stack ABAPJAVA

    Hi
    I'm doing a Homogeneous system copy from a BI 7.3 dual stack ABAP+JAVA system with an Oracle DB (11g version, 11.2.0.3.0 patch level) with AIX ibm OS.
    Before starting export I've executed in the source system the report SMIGR_CREATE_DDL, as described in sap note 888210, and I generated *.SQL files.
    After, during the import in the target system I get the following error message:
    vi /expdb2/tmpDB0/sapinst_instdir/NW730/ORA/ORA/COPY/ORA/SYSTEM/STD/AS/import_monitor.log
    INFO: 2014-03-08 00:21:57 com.sap.inst.migmon.LoadTask run_report
    Monitor jobs: running 0, waiting 1, completed 60, failed 5, total 66  finish processing of package SAP0000
    You can see below the detail of the 5 packages in error:
    SAPAPPL0_1_5
    DbSlExecute: rc = 99
      (SQL error 2216)
      error message returned by DbSl:
    ORA-02216: tablespace name expected
    (DB) INFO: disconnected from DB
    /usr/sap/DB2/SYS/exe/uc/rs6000_64/R3load: job finished with 1 error(s)
    /usr/sap/DB2/SYS/exe/uc/rs6000_64/R3load: END OF LOG: 20140307141347
    SAPZPSA
    DbSlExecute: rc = 99
      (SQL error 2216)
      error message returned by DbSl:
    ORA-02216: tablespace name expected
    (DB) INFO: disconnected from DB
    SAPDODS
    DbSlExecute: rc = 99
      (SQL error 922)
      error message returned by DbSl:
    ORA-00922: missing or invalid option
    (DB) INFO: disconnected from DB
    SAPDFACT
    DbSl Trace: Error 1741 in exec_immediate() from oci_execute_stmt(), orpc=0
    DbSl Trace: ORA-01741 occurred when executing SQL stmt (parse error offset=8126464)
    (DB) ERROR: DDL statement failed
    (  ALTER TABLE "/BI0/F0TCT_C01"    ADD PARTITION "/BI0/F0TCT_C010000001131" VALUES LESS THAN ( 0000001131  )    TABLESPACE "" )
    DbSlExecute: rc = 99
      (SQL error 1741)
      error message returned by DbSl:
    ORA-01741: illegal zero-length identifier
    (DB) INFO: disconnected from DB
    SAPZOSO
    DbSl Trace: Error 922 in exec_immediate() from oci_execute_stmt(), orpc=0
    DbSl Trace: ORA-00922 occurred when executing SQL stmt (parse error offset=242024448)
    (DB) ERROR: DDL statement failed
    (CREATE TABLE "/BIC/B0000989000"    ("REQUEST" VARCHAR2 (000090)      DEFAULT ' ' NOT NULL,    "DATAPAKID" VARCHAR2 (000018)      DEFAULT '000000' NOT NULL,    "PART
    NO" NUMBER (000010)      DEFAULT 0 NOT NULL,    "RECORD" NUMBER (000010)      DEFAULT 0 NOT NULL,    "PLANT" VARCHAR2 (000012)      DEFAULT ' ' NOT NULL,    "MATERIA
    L" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "RPA_CURUOM" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "RPA_MVF" NUMBER (000017, 000002)      DEFAULT 0 NOT N
    ULL,    "PRICE_UNIT" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "RPA_QTYUOM" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "RT_SSMFGR" VARCHAR2 (000024)
        DEFAULT '00000000' NOT NULL,    "BASE_UOM" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "FRE_PLNPUR" VARCHAR2 (000036)      DEFAULT ' ' NOT NULL,    "FRE_MINS
    TK" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "FRE_SERLEV" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "FRE_SELCLS" VARCHAR2 (000003)      DEFAULT '
    0' NOT NULL,    "FRE_REPLST" VARCHAR2 (000006)      DEFAULT ' ' NOT NULL,    "ABCKEY" VARCHAR2 (000003)      DEFAULT ' ' NOT NULL,    "RECORDMODE" VARCHAR2 (000003)
        DEFAULT ' ' NOT NULL,    "RT_SERVLEV" VARCHAR2 (000003)      DEFAULT ' ' NOT NULL,    "RT_SUPS" VARCHAR2 (000003)      DEFAULT ' ' NOT NULL,    "VAL_TYPE" VARCH
    AR2 (000030)      DEFAULT ' ' NOT NULL,    "PUR_GROUP" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "RT_VPNEU" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,
    "CURRENCY" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "RT_VRKPE" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "DISMM" VARCHAR2 (000006)      DEFAULT ' '
    NOT NULL,    "SALES_UNIT" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "RT_VP_BT" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,    "RT_VPE_BT" NUMBER (000017,
    000003)      DEFAULT 0 NOT NULL,    "RT_VP_NT" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,    "RT_VPE_NT" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "R
    T_VWAERBT" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "RT_VWAERNT" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "RT_VPMEIBT" VARCHAR2 (000009)      DEFAULT '
    ' NOT NULL,    "RT_VPMEINT" VARCHAR2 (000009)      DEFAULT ' ' NOT NULL,    "LOC_CURRCY" VARCHAR2 (000015)      DEFAULT ' ' NOT NULL,    "UNIT" VARCHAR2 (000009)
      DEFAULT ' ' NOT NULL,    "CM_MCATDIV" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "CM_CDT1" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "CM_CDT2" VARCHAR2
    (000054)      DEFAULT ' ' NOT NULL,    "CM_CDT3" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "CM_CDT4" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL,    "CM_HIEID"
    VARCHAR2 (000006)      DEFAULT ' ' NOT NULL,    "CPSTLC" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,    "CPSVLC" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL
    ,    "STOCK_VAL" NUMBER (000017, 000002)      DEFAULT 0 NOT NULL,    "STOCK_QTY" NUMBER (000017, 000003)      DEFAULT 0 NOT NULL,    "RT_SEASON" VARCHAR2 (000012)
      DEFAULT ' ' NOT NULL,    "RT_SEASYR" VARCHAR2 (000012)      DEFAULT '0000' NOT NULL,    "CALDAY" VARCHAR2 (000024)      DEFAULT '00000000' NOT NULL,    "CALWEEK"
    VARCHAR2 (000018)      DEFAULT '000000' NOT NULL,    "RF_BNDID" VARCHAR2 (000012)      DEFAULT ' ' NOT NULL,    "/BIC/ZCATTR3" VARCHAR2 (000006)      DEFAULT ' ' NOT
    NULL,    "/BIC/ZCSTYLE" VARCHAR2 (000006)      DEFAULT ' ' NOT NULL,    "/BIC/ZCIMAGE" VARCHAR2 (000006)      DEFAULT ' ' NOT NULL,    "/BIC/ZCBRNDTYP" VARCHAR2 (000
    003)      DEFAULT ' ' NOT NULL,    "/BIC/ZCGROUPE" VARCHAR2 (000054)      DEFAULT ' ' NOT NULL)    PCTFREE 10    PCTUSED 00    INITRANS 001    TABLESPACE    STORAGE (
    INITIAL    0000000016 K            NEXT        0000001024 K            MINEXTENTS  0000000001            MAXEXTENTS  2147483645            PCTINCREASE 0000
        FREELISTS  001            FREELIST GROUPS 01)      PARTITION BY RANGE ("PARTNO")      (      PARTITION "/BIC/B00009890000000000002" VALUES LESS THAN      (00000
    00002)      NOCOMPRESS      ) )
    DbSlExecute: rc = 99
      (SQL error 922)
      error message returned by DbSl:
    ORA-00922: missing or invalid option
    (DB) INFO: disconnected from DB

    hello,
    Before anything update DB shared lib, R3load, R3ldctl and R3szchk in the target system. Also Check in source system if you have any tables o index missing in db02 transaction, If this system wa upgraded from a previous release please check TAORA and IAORA tables in source system and check all the tablespaces named in those tables are created in the target system.
    let me know how it goes.
    Regards,
    Michael

  • Dual Stack NW 7.0 installation with R/3 Backend as UME

    I have a quick question guys. I am about to install a dual stack NW system with ADS(SQL server database on windows) and will use a R/3 Enterprise running on unix as the UME datasource. Now this R/3 enterprise backend already acts as bakend for Portal system and uses sap logon tickets and as such already has the user SAPJSF.   Now when i actually perform the NW 7.0 installation and enter a master password during the course, would this override the SAPJSF user in R/3 backend system at all.
    What are the general problems that are caused with using an existing ABAP only system as the UME for your Java stack(Dual stack actually) systems. Can you advise.
    Regards
    Kalyan

    Hi,
    Now when i actually perform the NW 7.0 installation and enter a master password during the course,
    would this override the SAPJSF user in R/3 backend system at all.
    NO....Not at all..
    SAPJSF user is used for the communication between ABAP  and JAVA stacks. SAPJSF user is an independent user of each independent ABAP stack.
    ABAP data/user-store is the place where the users, roles and authorizations of an ABAP System are stored.
    And with the same concept, the UME is the same mechanism for users, roles, permissions of an JAVA system.
    After installation of your new NW ABAP+JAVA Stack, you will have to specify the SAPJSF user of ur old R/3 ABAP system which you want to use as User Data Store for ur Newly installed Java System's UME.
    In ABAP System section u will have to provide all details of ur SAP R/3 application server, which ur portal is already using as User Data Store.
    What are the general problems that are caused with using an existing ABAP only system
    as the UME for your Java stack(Dual stack actually) systems. Can you advise.
    It depends on the usage of your new application server.
    Regards
    Bhavik G. Shroff

  • Can we have multi-Home CRS/ASM on same server?

    Hi All,
    I'm studying the feasibility for below situation (sorry i'm new in RAC)
    I'm not sure whether it can setup in HP-UX-11.23 Itanium box or not (Not OpenVMS)
    We have two node e.g. node1 and node2 in RAC environment.
    In node1, we plan to create one instance for each customer (Let say 10 customer, we will create 10 instances on same server).
    For each instances (ORACLE_HOME), can we have their own ASM software (ASM instance) and CRS software (CRS HOME) instead of create one and share with all instances.
    We're looking for multi-home concept, so that if one of our customer want to upgrade/patches oracle, it will NOT affect other customer.
    Any idea, or any website can share with me?
    Thanks in advance.
    Best Regards,
    klnghau
    Edited by: klnghau on Oct 15, 2010 8:51 AM

    Let say, we have 10 instances in one box, each database will have their RDBMS homes, if we can not have multiple ASM instances or CRS home.
    Whenever we want to apply patches on one of the instances, definitely other instances will be affected.
    Just want to know what is the best deploy/best practice to apply patches in such environment?I think the first 'best' practice is to not have multiple instances on a single server. But if you have to do it, I'd say virtualisation might help you so that each instance lives in it's own virtual machine with it's own operating system. That way, you can also patch the OS and reboot it and only affect a single database instance. The only problem with RAC might be that not all virtualization platforms are supported with RAC
    Bjoern

  • Question about the number of ERS instances in a dual-stack MCS environment

    Hello to the group.
    I have a simple question for those running a NetWeaver 7.0 (i.e. 2004s) dual stack (ABAP/JAVA) setup in an MCS environment. On each individual node, do you have two separate ERS processes running on the node (as seen in Task Manager) that is opposite to the system running the ASCS/SCS instances? If so, do you have a set of profiles for each of these ERS processes (I am guessing that is true)?
    Thanks in advance for your help.
    J. Haynes

    Has anyone found a good description of the process that runs after one node fails over to another one? help.sap.com mentions that the ASCS will restart and run the command enstatus.cmd but I cannot find what is supposed to happen after that. Is the ERS service itself stopped?
    Thanks
    J. Haynes

  • EHP4 Dual stack

    hi guys,
    we plan to upgrade Enterprise Dual stack(ABAP+JAVA) System to EHP4 system.
    In EHP4 upgrade document it says, No dual stack supported for EHP4 installation..was that mean
    only for Installation or upgrade too.
    Seperate SID is required for EHP4 system after upgrade? Please confirm.
    thanks

    hi jaichan,
    yes, you are right ..For new installation of SAP ERP to EHP4 level, you cannot install dual stack system..i have read in sap note 855534..please find below the extract from this note:
    As of SAP Business Suite 7, you can no longer install Dual Stack Application Systems (ABAP+Java).
    If you want to use both SAP Business Suite ABAP and Java Components in your system landscape, you have to proceed as follows:
    1. Install a separate ABAP-based SAP Business Suite system.
    2. Install the required Java components in a separate Java-based SAP system.
    3. Configure the connection of the Java-based SAP system to the ABAP-based SAP Business Suite back-end system.
    The SAP Business Suite 7 comprises: EHP4 for SAP ERP 6.0, SAP CRM 7.0, SAP SCM 7.0, SAP PLM 7.0, SAP SRM 7.0
    As of now you will find the latest recommendations at a central place in SDN:
    https://www.sdn.sap.com/irj/sdn/landscapedesign -> Distribution Models
    You will also find information about the deployment of SAP NetWeaver usage types and the SAP Business Suite there.
    but you can upgrade your previously installed SAP ERP dual stack system without having seperate SID's thing...
    We have upgraded around 50 of our systems without any problem
    thanks sunny

  • PI 7.1(dual stack) and PI 7.31(Single stack) -

    Friends,
    I have a proxy to proxy scenario - Proxy --> PI --> Proxy
    We have two servers PI 7.1(dual stack) and PI 7.31(Single stack)
    i did the development in ESR and my ESR is pointing to PI 7.1, when i execute the scenario i receive one error message "receiver could not be determined", i ensured that all my input is correct, still i get the same error message.
    the expectation is my scenario should point to PI 7.31, Can some one help me where and what settings i need to make in-order to make it work.
    Please Note: All my data is correct and i read some scn forums wherein they asked to refresh the cache , i have refreshed the cache also still the problem persists.
    Thanks in advance!

    Iñaki Vila
    Communication component in ID is the same as sender side.
    could you share your sender configuration?
    Did you mean Tcode - SXMB_ADM and under that Sender/Receiver configuration
    Krupa Rao Atluri
    In ID steps are correctly defined.
    I spoke to my colleague he hinted that at RUN TIME we want to point to PI7.31, he mentioned config change needed in SXMB_ADM
    any further inputs from any one could be useful.

  • Mapping error in PI 7.4 dual stack

    Dear Experts,
        Recently we upgraded our system from PI 7.1 to PI 7.4 dual stack.
    Scenerio is ECC->PI->SOAP(Webservice) synchronous
    Issue in detail:
         We are creating a invoice in ECC system through PI its updating in third party site using SOAP webservice and will get a reference number from that site and then updating in ECC as in synchronous way.
    Invoice data's are reached PI sucessfully from ECC but it not updating in the site and getting below mapping error after upgarded to PI 7.4.
    Your points will be highly appreciable.
    Kindly help to sort out this issue.
    Best Regards,
    Monikandan

    Hi Monikandan,
    It seems you are trying the sign the payload in your java mapping. So, looking at the attached error, there could be 2 possibilities:
    1) Either there is no certificate with alias: *_PRD
    2) This certificate is stored in some "System" type keystore view which is not accessible from you mapping code. Try to move your certificate to some "User" keystore view.
    Thanks & regards,
    Piyush

  • Parameterized mapping in PI 7.31 Dual Stack

    Hi All,
    I am working on PI 7.31 Dual Stack. I am getting the below exception in parameterized mapping:
    com.sap.aii.utilxi.misc.api.BaseRuntimeException; com.sap.aii.mapping.api.UndefinedParameterException: The input-parameter TestVal does not exist.
    I could test in MM test tab but facing the issue in runtime. Please suggest me where I am going wrong.
    Thanks,
    Madhurima

    Hi Madhurima,
    Have you checked if your PI version and patch level is being affected with this note  1933139 - Errors during execution of operation mapping with message mapping parameters names different from the operation mapping parameter names?
    Regards.

  • Issue while creating Component Based Message Alerting in PI 7.31 Dual Stack

    Hi,
    We tried to implement Component Based Message Alerting following the steps mentioned in the below blog.
    http://scn.sap.com/community/pi-and-soa-middleware/blog/2012/03/25/michals-pi-tips-component-based-message-alerting
    Ours is PI 7.31 dual stack. However, after setting up the job with my own user id, I am getting the below error inside the log of Jobs tab:
    javax.jms.JMSSecurityException: You do not have permissions: action alertingVP.queue and instance:name alertingVP.queue
    action consumer
    instance jms/queue/xi/monitoring/alert/ALERT-TO-MAIL
    Please let us know what permission is required to set up the job.
    Thanks,
    Rahul

    Hi, 
    Now I am able to receive alert in my mailbox. But it's coming with improper content.
    I have set up the job at an interval of every 2 minutes in NWA, and in case if only 1 message fails in IE, in ideal case, I should receive only 1 message details in alert.
    However, in every 2 minutes, I am receiving junk data and the number is increasing for the particular scenario for which the alert has been created. Also the Error Category mentioned is showing improper.
    But in table SXMSALERTCONTENT I am able to view only the newly added failed entry.
    An erroneous alert email content is pasted below:
    63 messages failed for "Test_XXX" on "af.s0i.saps0i"
    Root cause: -1
    To navigate to the failed messages in the local message monitor use this link
    The first 1 messages of that data collection:
    "AdapterNamespace": "http://sap.com/xi/XI/System",
    "AdapterType": "File",
    "Channel": "FileSender_XXX",
    "ChannelParty": "",
    "ChannelService": "XXXXX",
    "Component": "af.s0i.saps0i",
    "ErrCat": "",
    "ErrCode": "",
    "ErrLabel": "-1",
    "ErrText": "Configured source directory '\\Outbound\\XXX\\CREMAS' does not exist",
    "FromParty": "",
    "FromService": "XXX",
    "Interface": "Z_CREMAS_SUSMM.CREMAS03",
    "Namespace": "urn:sap-com:document:sap:idoc:messages",
    "RuleId": "3a64dd6e1b1d3e58aff62ea70c97cb80",
    "Timestamp": "2013-02-01T09:43:23Z",
    "ToParty": "",
    "ToService": ""
    The failed message however do not relate to the 'source directory does not exist' issue. Please help.
    Thanks,
    Rahul

  • How to restart Java Engine in ABAP+JAVA dual stack installation ?

    Dear Experts
    if i use stopsap r3 in this dual stack installation - it stops both ABAP & JAVA Web Application Servers.
    I want to restart only JAVA Weba pplication server.
    How do it ?
    Thaks in Advance !
    Rgds

    But theoritically  they are 2 indpeendent installations like
    AS ABAP
    AS JAVA
    ..Do you aggree ?? really am not good on basics!!
    During the installation also -  if select AS ABAP & AS JAVA  - it will become dual installation
    and it does not show
    any dependency while installing that AS JAVA  requires AS ABAP.[Installation Component Selection and Dependency Screen shot|http://i303.photobucket.com/albums/nn153/S0002919350/SAP%20Issues/Oracle_Patches.jpg]
    Installation Component Selection and Dependency Screen shot
    Is it because if AS ABAP is down - AS JAVA UME is 001 client - and Java authentication fails ?
    Can we de attatch from ABAP UME for my requirement like - running JAVA WAS alone w/o ABAP.
    Regards
    PR
    Regards
    Edited by: P.R. SRINIVAS on Jun 16, 2008 4:15 PM

Maybe you are looking for