File Adapor QoS

File Adaptor support EO and EOIO...right?.

Ash,
Yes. Please see this help:
http://help.sap.com/saphelp_nw04/helpdata/en/0d/5ab43b274a960de10000000a114084/content.htm
---Satish

Similar Messages

  • File Adapter -QOS

    it seems to be File Adapter supports for all QOS -BE,EO,EOIO..
    is that not a right assumption?
    thanks-GS

    Indeed..
    but a couple of days back, I have sent this link to XI beginner..
    http://help.sap.com/saphelp_nw2004s/helpdata/en/0d/5ab43b274a960de10000000a114084/content.htm
    but he was confused since the question was asked in XI certification..I think we need to take this to SAP.. anybody would prefer to get the answer from them, pls
    thanks-Gopal

  • File- XI- RFC, JDBC

    Hello Gurus.
    I have a scenario where i have to load File to JDBC (Oracle) and RFC (SAP) in parallel.
    If my file is QoS (EO), then do I have to use BPM to send the message to JDBC and RFC,
    or I can just create two Receivers, and the message will split in the pipeline on IE?
    The file is loaded once in Quarter, every 3 months.
    Thanks in advance...

    "In Parallel" means you may have to use BPM where you can have a parforeach block to simultaneously send the message to both the receivers.
    But i see why this process can be done in a sequence. If so , BPM is not required. You just have to MAP the Outbound to 2 inbounds, namely IDOC and the RFC.
    Raj

  • Error installing enet

    This is what I get after a pacman -Sy enet:
    (1/1) checking for file conflicts [#####################] 100%
    error: could not prepare transaction
    error: failed to commit transaction (conflicting files)
    enet: /usr/include/enet/callbacks.h exists in filesystem
    enet: /usr/include/enet/enet.h exists in filesystem
    enet: /usr/include/enet/list.h exists in filesystem
    enet: /usr/include/enet/protocol.h exists in filesystem
    enet: /usr/include/enet/time.h exists in filesystem
    enet: /usr/include/enet/types.h exists in filesystem
    enet: /usr/include/enet/unix.h exists in filesystem
    enet: /usr/include/enet/utility.h exists in filesystem
    enet: /usr/include/enet/win32.h exists in filesystem
    enet: /usr/lib/libenet.a exists in filesystem
    errors occurred, no packages were upgraded
    The funny thing is, no package seems to own these files, pacman -Qos enet doesn't come up with anything, but these files exist. Oh and no, enet is not already installed on my computer.
    edit:
    The enet-version I'm trying to install is "enet-1.1-1"
    Last edited by hybrid (2007-08-02 14:30:05)

    pacman -Syf enet may do the trick.

  • File Splitting for Large File processing in XI using EOIO QoS.

    Hi
    I am currently working on a scenario to split a large file (700MB) using sender file adapter "Recordset Structure" property (eg; Row, 5000). As the files are split and mapped, they are, appended to a destination file. In an example scenario a file of 700MB comes in (say with 20000 records) the destination file should have 20000 records.
    To ensure no records are missed during the process through XI, EOIO, QoS is used. A trigger record is appended to the incoming file (trigger record structure is the same as the main payload recordset) using UNIX shellscript before it is read by the Sender file adapter.
    XPATH conditions are evaluated in the receiver determination to eighther append the record to the main destination file or create a trigger file with only the trigger record in it.
    Problem that we are faced is that the "Recordset Structure" (eg; Row, 5000) splits in the chunks of 5000 and when the remaining records of the main payload are less than 5000 (say 1300) those remaining 1300 lines get grouped up with the trigger record and written to the trigger file instead of the actual destination file.
    For the sake of this forum I have a listed a sample scenario xml file representing the inbound file with the last record wih duns = "9999" as the trigger record that will be used to mark the end of the file after splitting and appending.
    <?xml version="1.0" encoding="utf-8"?>
    <ns:File xmlns:ns="somenamespace">
    <Data>
         <Row>
              <Duns>"001001924"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Cage_Code>"3NQN1"</Cage_Code>
              <Extract_Code>"A"</Extract_Code>
         </Row>
         <Row>
              <Duns>"001001925"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Cage_Code>"3NQN1"</Cage_Code>
              <Extract_Code>"A"</Extract_Code>
         </Row>
         <Row>
              <Duns>"001001926"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Cage_Code>"3NQN1"</Cage_Code>
              <Extract_Code>"A"</Extract_Code>
         </Row>
         <Row>
              <Duns>"001001927"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Cage_Code>"3NQN1"</Cage_Code>
              <Extract_Code>"A"</Extract_Code>
         </Row>
         <Row>
              <Duns>"001001928"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Cage_Code>"3NQN1"</Cage_Code>
              <Extract_Code>"A"</Extract_Code>
         </Row>
         <Row>
              <Duns>"001001929"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Cage_Code>"3NQN1"</Cage_Code>
              <Extract_Code>"A"</Extract_Code>
         </Row>
         <Row>
              <Duns>"9999"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Cage_Code>"3NQN1"</Cage_Code>
              <Extract_Code>"A"</Extract_Code>
         </Row>
    </Data>
    </ns:File>
    In the sender file adapter I have for test purpose changed the "Recordset structure" set as "Row,5" for this sample xml inbound file above.
    I have two XPATH expressions in the receiver determination to take the last record set with the Duns = "9999" and send it to the receiver (coominication channel) to create the trigger file.
    In my test case the first 5 records get appended to the correct destination file. But the last two records (6th and 7th record get sent to the receiver channel that is only supposed to take the trigger record (last record with Duns = "9999").
    Destination file: (This is were all the records with "Duns NE "9999") are supposed to get appended)
    <?xml version="1.0" encoding="UTF-8"?>
    <R3File>
         <R3Row>
              <Duns>"001001924"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Extract_Code>"A"</Extract_Code>
         </R3Row>
         <R3Row>
              <Duns>"001001925"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Extract_Code>"A"</Extract_Code>
         </R3Row>
         <R3Row>
              <Duns>"001001926"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Extract_Code>"A"</xtract_Code>
         </R3Row>
              <R3Row>
              <Duns>"001001927"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Extract_Code>"A"</Extract_Code>
         </R3Row>
              <R3Row>
              <Duns>"001001928"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Extract_Code>"A"</Extract_Code>
         </R3Row>
    </R3File>
    Trigger File:
    <?xml version="1.0" encoding="UTF-8"?>
    <R3File>
              <R3Row>
              <Duns>"001001929"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Ccr_Extract_Code>"A"</Ccr_Extract_Code>
         </R3Row>
              <R3Row>
              <Duns>"9999"</Duns>
              <Duns_Plus_4>""</Duns_Plus_4>
              <Ccr_Extract_Code>"A"</Ccr_Extract_Code>
         </R3Row>
    </R3File>
    I ve tested the XPATH condition in XML Spy and that works fine. My doubts are on the property "Recordset structure" set as "Row,5".
    Any suggestions on this will be very helpful.
    Thanks,
    Mujtaba

    Hi Debnilay,
    We do have 64 bit architecture and still we have the file processing problem. Currently we are splitting the file into smaller chuncks and processsing. But we want to process as a whole file.
    Thanks
    Steve

  • QOS File to SOAP scenario

    I have a File to SOAP scenario which processes a file with many records and calls a webservice once per record.
    The QOS of the sender File adapter is set to 'Exactly Once' but the SOAP messages have QOS 'Exactly Once In Order'.
    I would like the SOAP messages to have QOS 'Exactly Once' to avoid messages going into 'Holding' status after an error occurs with a previous message.
    Any suggestions greatfully received.
    Thanks
    Mark Briggs

    Thanks for your suggestions. This scenario does not use BPM.
    This is an asynchronous scenario as the sender is file based. The QOS of the File sender Adapter is set to 'Exactly Once'. I do not think it is possible to set the QOS of the receiver SOAP adapter. I understood that the QOS of the receiver was determined by the QOS of the sender.
    The records in the source file are independent of each other and so I do not want subsequent messages to go into a holding status when a record is in error.
    Is there any way to make the QOS of the receiver SOAP adapter 'Exactly Once'?

  • Question on QoS for File-- SOAP synchronous high volume interface

    Is it possible to have a File to SOAP (sender file adapter --> receiver SOAP adapter, synchronous - response needed by sender ) scenario with FIFO (first in first out). This is a high volume interface (about 8 messages/second). If FIFO possible, will a failed message block the succeeding messages?
    My understanding is that QoS of receiver SOAP CC is Best Effort.
    Thank you.

    yes..EOIO will block the queues if its predecessor are not in final state...
    for ur design u can rfer the below wiki...instead of RFC u can use soap adapter..
    http://wiki.sdn.sap.com/wiki/display/XI/File-RFC-File%28Without%20BPM%29

  • QOS in File scenario

    In Sender  File CC has QOS as BE, EOIO, EO => can be asynchronous as well as synchronous
    but in Receiver CC has QOS as EOIO, EO but not have BE==> not synchronous at receiver side.
    Why???

    hi gabriel,
    >>Receiver CC has QOS as EOIO, EO
    receiver cc doznot have QOS. it takes qos from integration engine (the one that is specified for sender's side)
    file interface can only be asynch and never synch. althoh u have an option of specifying it as BE (at sender side)...even if u do it ur response scenario will fail as file will never send a response and at other side will never wait for a response!!
    [reward if helpful]
    regards,
    latika.

  • File adapter with QoS=EOIO  Is there any filesize limitation?

    Dear Experts,
    I'm using a File/FTP Sender adapter with Quality of Service = EOIO (Exactly Once In Order) to keep the polled order of the files.
    In the processing parameters I defined a queue name and everything is working well for small (~1 MByte) files.
    But if I want to transfer bigger (~25 MByte) files, the whole Java stack collapses and the system has to be restarted.
    Is there any size limitation for this own defined queues?
    Have you any experience with this kind of processing?
    Any comments / experiences are welcome!
    Best regards,
    Andras

    Hello,
    there are several files to poll, we have to keep the alphabetical order of them.
    It seems, that we have this issue only with EOIO. (EO works good)
    After the system has restarted, the first file from the queue was processed, but with a n error message "Could not delete file 'filename.dat' after processing: java.lang.NullPointerException"
    (the delete option is on after the transfer)
    Is there any possibility to check the mentioned "QuicSized" settings?
    I just wanted to know, if there is an "unofficial" size limit of these queues.
    Thank you!

  • File Server Role: Slow access for "opened files" and slow Explorer browsing

    Since we migrated our fileserver from Windows Server 2008 R2 to Windows Server 2012 we are facing two major problems:
    1. Opening files which are already opened by other users takes about 1 minute before the file actually opens. This is not only for Office files such as Excel and Word, but also for other (not office) files. Again, this problem only rises when the file(s)
    is/are already opened by another user. There seems to be a sort of "Lock" check time which is about 45 to 60 seconds.
    2. The other problem is browsing via Explorer through the network drive (all clients are Windows 7 clients). Half of the time there is some kind of "hick up" with displaying the results of the folder. I cannot figure out a patern, but if there
    is no "hick up" then browsing is very fast (also in the busiest times of the working day)... If there is a "hick up" the result can take about 50 seconds to display the content of a folder.
    I suspect the SMB implementation / settings of Windows Server 2012 which are causing the problems...
    Things I tried:
    1. Changed the Oplocks wait time to 10 seconds (which is the minimum). The result is that openening files does indeed go some faster (still taking about 45 seconds).
    2. Disabled SMB2: the result is that browsing is fast... Opening files does go faster. BUT: we are then facing other problems like some files are not able to open... This setting was, after getting a lot of complaints from the users, changed back to enabled
    SMB2.
    3. Within the NIC card properties I disabled "QoS packet Scheduler", "Link-Layer Topology Discovery Mapper I/O Driver", "Link-Layer Topology Discovery Responder" and IPv6 (as we only use IPv4).
    All above with not the promising results.
    The server is a dedicated (virtual machine on vSphere 5.1) fileserver.
    Please Advice since this is not workable, and we have postponed the migration of the fileserver for our aother location.

    Hi Dave,
    I suggest you disable all third party applications like Anti-Virus application to test if it could reduce the waiting time when accessing a file.
    Here are some related threads below that could be useful to you:
    DFS Slowness when Opening Microsoft Documents and Excel Spreadsheets
    http://social.technet.microsoft.com/Forums/windowsserver/en-US/61ec9a99-0027-44cb-815c-0da9276c1c96/dfs-slowness-when-opening-microsoft-documents-and-excel-spreadsheets?forum=winservergen
    Opening files over network takes long time
    http://social.technet.microsoft.com/Forums/windows/en-US/c8ddb65f-8a17-4cee-afd4-dfc09e99d562/opening-files-over-network-takes-long-time?forum=w7itpronetworking
    opening folder or file takes over a minute on Windows 2008R2 File server
    http://social.technet.microsoft.com/Forums/windowsserver/en-US/b9aa98c4-3ef7-4e6d-810d-6099e72b33f6/opening-folder-or-file-takes-over-a-minute-on-windows-2008r2-file-server?forum=winserverfiles
    Best Regards,
    Amy Wang

  • File to SOAP,error in sender file adapter

    Hi,
    I am doing a scenario FILE to SOAP where In file adapter I am using Quality od service as Exactly once in order.I am getting the below error.It works fine when I use QOS=Exactly once.Not sure why,can you guys please help me.Can we really use QOS-EOIO for sender file adapter,where exacly do we use it.
    Thanks
      <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    - <!--  Call Adapter  -->
    - <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">
      <SAP:Category>XIAdapterFramework</SAP:Category>
      <SAP:Code area="MESSAGE">GENERAL</SAP:Code>
      <SAP:P1 />
      <SAP:P2 />
      <SAP:P3 />
      <SAP:P4 />
      <SAP:AdditionalText>com.sap.aii.af.ra.ms.api.DeliveryException: invalid content type for SOAP: TEXT/HTML</SAP:AdditionalText>
      <SAP:ApplicationFaultMessage namespace="" />
      <SAP:Stack />
      <SAP:Retry>M</SAP:Retry>
      </SAP:Error>
    Edited by: guest xi on Apr 16, 2008 11:55 AM

    Hi,
    Thanks for your replies guys.I diid give the queue name ,I dont know what is causing the error.Now even QOS=EO which was working fine before is throwing an error.I am using the same file name for both
    <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    - <!--  Call Adapter   -->
    - <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">
      <SAP:Category>XIAdapterFramework</SAP:Category>
      <SAP:Code area="MESSAGE">GENERAL</SAP:Code>
      <SAP:P1 />
      <SAP:P2 />
      <SAP:P3 />
      <SAP:P4 />
      <SAP:AdditionalText>com.sap.aii.af.ra.ms.api.DeliveryException: invalid content type for SOAP: TEXT/HTML</SAP:AdditionalText>
      <SAP:ApplicationFaultMessage namespace="" />
      <SAP:Stack />
      <SAP:Retry>M</SAP:Retry>
      </SAP:Error>

  • Cisco 7206 has with LLQ QOS and cpu 85 %

    hi all ,
    i want to mention issue about cisco router 7206 npeg2 :
    can this router handle traffic  780 Mbps  as download  and 75 MBps as upload ?? with cpu 85 % and with LLQ  qos ??
    im asking this question because my QOS althoug it matched alot of traffic , it some time get slow and seems that QOS not working fine , im sure that my work is  fine, because it was fine , but recent days i added more bw   ???!!!!!
    dont know if  need more memory for router for QOS :
    ===============================================================
    7200Gateway#sh memory
                    Head    Total(b)     Used(b)     Free(b)   Lowest(b)  Largest(b)
    Processor    6B97A80   1883669308   114125456   1769543852   1768174580   1760364316
          I/O   78000000    67108864     4482572    62626292    62598896    62617884
    Transient   77000000    16777216       22196    16755020    16222412    16728368
              Processor memory
    Address      Bytes     Prev     Next Ref     PrevF    NextF Alloc PC  what
    06B97A80 0000010004 00000000 06B9A1C4 001  -------- -------- 01A493D8  CEF: fib
    06B9A1C4 0000000028 06B97A80 06B9A210 000  87F3D04  87FD620  015FC24C  AAA Attr Binary/String
    06B9A210 0000004700 06B9A1C4 06B9B49C 001  -------- -------- 01AC85B4  ADJ: adjacency
    06B9B49C 0000004100 06B9A210 06B9C4D0 001  -------- -------- 0011245C  HTTP CORE
    06B9C4D0 0000004100 06B9B49C 06B9D504 001  -------- -------- 00112548  HTTP CORE
    06B9D504 0000004100 06B9C4D0 06B9E538 001  -------- -------- 00112548  HTTP CORE
    06B9E538 0000004100 06B9D504 06B9F56C 001  -------- -------- 00112548  HTTP CORE
    06B9F56C 0000004100 06B9E538 06BA05A0 001  -------- -------- 00112548  HTTP CORE
    06BA05A0 0000000756 06B9F56C 06BA08C4 001  -------- -------- 0343C38C  Process
    06BA08C4 0000000204 06BA05A0 06BA09C0 001  -------- -------- 0343FAB4  Process Events
    06BA09C0 0000022764 06BA08C4 06BA62DC 001  -------- -------- 04055CB4  IPSM Octet Str
    06BA62DC 0000014488 06BA09C0 06BA9BA4 001  -------- -------- 0405C0C4  ipsm IPSEC Fai
    06BA9BA4 0000004100 06BA62DC 06BAABD8 001  -------- -------- 00112548  H
    ===========================================================================
    ==========================================
    7200Gateway#sh version
    Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 12.4(24)T7, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2012 by Cisco Systems, Inc.
    Compiled Tue 28-Feb-12 12:53 by prod_rel_team
    ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)
    7200Gateway uptime is 2 weeks, 5 days, 19 hours, 43 minutes
    System returned to ROM by power-on
    System image file is "disk2:/c7200p-adventerprisek9-mz.124-24.T7.bin"
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    If you require further assistance please contact us by sending email to
    [email protected].
    Cisco 7206VXR (NPE-G2) processor (revision A) with 1966080K/65536K bytes of memory.
    Processor board ID 13252317
    MPC7448 CPU at 1666Mhz, Implementation 0, Rev 2.2
    6 slot VXR midplane, Version 2.0
    Last reset from power-on
    PCI bus mb1 (Slots 1, 3 and 5) has a capacity of 600 bandwidth points.
    Current configuration on bus mb1 has a total of 0 bandwidth points.
    This configuration is within the PCI bus capacity and is supported.
    PCI bus mb2 (Slots 2, 4 and 6) has a capacity of 600 bandwidth points.
    Current configuration on bus mb2 has a total of 0 bandwidth points.
    This configuration is within the PCI bus capacity and is supported.
    Please refer to the following document "Cisco 7200 Series Port Adaptor
    Hardware Configuration Guidelines" on Cisco.com <http://www.cisco.com>
    for c7200 bandwidth points oversubscription and usage guidelines.
    1 FastEthernet interface
    3 Gigabit Ethernet interfaces
    2045K bytes of NVRAM.
    250880K bytes of ATA PCMCIA card at slot 2 (Sector size 512 bytes).
    65536K bytes of Flash internal SIMM (Sector size 512K).
    Configuration register is 0x2102
    ==============================================================
    7200Gateway#sh processes cpu
    CPU utilization for five seconds: 85%/84%; one minute: 84%; five minutes: 84%
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
       1          32         416         76  0.00%  0.00%  0.00%   0 Chunk Manager   
       2       32788      342520         95  0.00%  0.05%  0.05%   0 Load Meter      
       3           0           1          0  0.00%  0.00%  0.00%   0 chkpt message ha
       4           0           1          0  0.00%  0.00%  0.00%   0 EDDRI_MAIN      
       5     2624584      213262      12306  0.00%  0.03%  0.04%   0 Check heaps     
       6          56         373        150  0.00%  0.00%  0.00%   0 Pool Manager    
       7           0           2          0  0.00%  0.00%  0.00%   0 Timers          
       8           0           2          0  0.00%  0.00%  0.00%   0 ATM AutoVC Perio
       9           0           2          0  0.00%  0.00%  0.00%   0 ATM VC Auto Crea
      10          16       28543          0  0.00%  0.00%  0.00%   0 IPC Dynamic Cach
      11           0           1          0  0.00%  0.00%  0.00%   0 IPC Zone Manager
      12         688     1670887          0  0.00%  0.00%  0.00%   0 IPC Periodic Tim
      13         520     1670887          0  0.00%  0.00%  0.00%   0 IPC Deferred Por
      14           0           1          0  0.00%  0.00%  0.00%   0 IPC Seat Manager
      15           0           1          0  0.00%  0.00%  0.00%   0 IPC BackPressure
      16     9007072    30711869        293  1.35%  0.15%  0.11%   0 EnvMon          
      17           0           1          0  0.00%  0.00%  0.00%   0 OIR Handler     
      18           0           1          0  0.00%  0.00%  0.00%   0 Crash writer    
      19        1380        3892        354  0.00%  0.00%  0.00%   0 ARP Input       
      20        1584     1784473          0  0.00%  0.00%  0.00%   0 ARP Background  
      21           0           2          0  0.00%  0.00%  0.00%   0 ATM Idle Timer  
      22           0           1          0  0.00%  0.00%  0.00%   0 CEF MIB API     
      23           4         134         29  0.00%  0.00%  0.00%   0 AAA high-capacit
      24           0           1          0  0.00%  0.00%  0.00%   0 AAA_SERVER_DEADT
      25           0           1          0  0.00%  0.00%  0.00%   0 Policy Manager  
      26           0           2          0  0.00%  0.00%  0.00%   0 DDR Timers      
      27           0           5          0  0.00%  0.00%  0.00%   0 Entity MIB API  
      28           0           2          0  0.00%  0.00%  0.00%   0 Serial Backgroun
      29           0           1          0  0.00%  0.00%  0.00%   0 RO Notify Timers
      30           0           1          0  0.00%  0.00%  0.00%   0 RMI RM Notify Wa
      31          28         281         99  0.00%  0.00%  0.00%   0 EEM ED Syslog   
      32           0           2          0  0.00%  0.00%  0.00%   0 SMART           
      33         724     1712571          0  0.00%  0.00%  0.00%   0 GraphIt         
      34           0           2          0  0.00%  0.00%  0.00%   0 Dialer event    
      35           0           1          0  0.00%  0.00%  0.00%   0 SERIAL A'detect 
      36           0           2          0  0.00%  0.00%  0.00%   0 XML Proxy Client
      37           0           2          0  0.00%  0.00%  0.00%   0 VSA background  
      38           0           1          0  0.00%  0.00%  0.00%   0 VSA Cleanup Proc
      39           0           1          0  0.00%  0.00%  0.00%   0 Critical Bkgnd  
      40        4348      444483          9  0.00%  0.00%  0.00%   0 Net Background  
      41           0           2          0  0.00%  0.00%  0.00%   0 IDB Work        
      42          32         501         63  0.00%  0.00%  0.00%   0 Logger          
      43        1236     1710802          0  0.00%  0.00%  0.00%   0 TTY Background  
      44       16504     1712627          9  0.07%  0.00%  0.00%   0 Per-Second Jobs 
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
      45          20          34        588  0.00%  0.00%  0.00%   0 IF-MGR control p
      46           8          40        200  0.00%  0.00%  0.00%   0 IF-MGR event pro
      47           0           1          0  0.00%  0.00%  0.00%   0 Inode Table Dest
      48           0           1          0  0.00%  0.00%  0.00%   0 IKE HA Mgr      
      49           0           1          0  0.00%  0.00%  0.00%   0 IPSEC HA Mgr    
      50           4           4       1000  0.00%  0.00%  0.00%   0 rf task         
      51       12808      179149         71  0.00%  0.00%  0.00%   0 Net Input       
      52        1304      342532          3  0.00%  0.00%  0.00%   0 Compute load avg
      53      610136       28974      21058  0.00%  0.00%  0.00%   0 Per-minute Jobs 
      54           0           1          0  0.00%  0.00%  0.00%   0 Token Daemon    
      55           4       10570          0  0.00%  0.00%  0.00%   0 Transport Port A
      56        1272      505453          2  0.00%  0.00%  0.00%   0 HC Counter Timer
      57           0           1          0  0.00%  0.00%  0.00%   0 Coproc Event Pro
      58           0           1          0  0.00%  0.00%  0.00%   0 POS APS Event Pr
      59           0           1          0  0.00%  0.00%  0.00%   0 SONET alarm time
      60           0           1          0  0.00%  0.00%  0.00%   0 CSP Timer       
      61         204           4      51000  0.00%  0.00%  0.00%   0 USB Startup     
      62           0           2          0  0.00%  0.00%  0.00%   0 FPD Management P
      63           0           1          0  0.00%  0.00%  0.00%   0 FPD Action Proce
      64           0           2          0  0.00%  0.00%  0.00%   0 VNM DSPRM MAIN  
      65           0           1          0  0.00%  0.00%  0.00%   0 RF_INTERDEV_DELA
      66           0           1          0  0.00%  0.00%  0.00%   0 RF_INTERDEV_SCTP
      67         464     1712577          0  0.00%  0.00%  0.00%   0 ISA Common Helpe
      68           0           2          0  0.00%  0.00%  0.00%   0 Flash MIB Update
      69           0          58          0  0.00%  0.00%  0.00%   0 Flash Card Oir  
      70           0           1          0  0.00%  0.00%  0.00%   0 CES Line Conditi
      71           0           1          0  0.00%  0.00%  0.00%   0 CF_INTERDEV_SCTP
      72           0           1          0  0.00%  0.00%  0.00%   0 Async write proc
      73           0           2          0  0.00%  0.00%  0.00%   0 Ethernet CFM    
      74         736     1670893          0  0.00%  0.00%  0.00%   0 Ethernet Timer C
      75           0           1          0  0.00%  0.00%  0.00%   0 delayed evt hand
      76          28         112        250  0.00%  0.00%  0.00%   0 AAA Server      
      77           0           1          0  0.00%  0.00%  0.00%   0 AAA ACCT Proc   
      78           0           1          0  0.00%  0.00%  0.00%   0 ACCT Periodic Pr
      79           0           2          0  0.00%  0.00%  0.00%   0 AAA Dictionary R
      80         744     1670882          0  0.00%  0.00%  0.00%   0 BGP Scheduler   
      81           0           2          0  0.00%  0.00%  0.00%   0 Ethernet OAM Pro
      82           0           2          0  0.00%  0.00%  0.00%   0 Ethernet LMI    
      83           0           2          0  0.00%  0.00%  0.00%   0 CEF switching ba
      84        3684       14726        250  0.00%  0.00%  0.00%   0 ADJ resolve proc
      85           8          30        266  0.00%  0.00%  0.00%   0 IP ARP Adjacency
      86           0           1          0  0.00%  0.00%  0.00%   0 IP ARP Retry Age
      87     3481296     6804010        511  0.00%  0.02%  0.01%   0 IP Input        
      88           0           1          0  0.00%  0.00%  0.00%   0 ICMP event handl
      89           0           9          0  0.00%  0.00%  0.00%   0 TurboACL        
      90           0           2          0  0.00%  0.00%  0.00%   0 TurboACL chunk  
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
      91           0           1          0  0.00%  0.00%  0.00%   0 IPv6 Echo event 
      92          16        2854          5  0.00%  0.00%  0.00%   0 MOP Protocols   
      93           0           1          0  0.00%  0.00%  0.00%   0 LSP Tunnel FRR  
      94           0           1          0  0.00%  0.00%  0.00%   0 MPLS Auto-Tunnel
      95           0           3          0  0.00%  0.00%  0.00%   0 PPP Hooks       
      96           0           1          0  0.00%  0.00%  0.00%   0 Async write proc
      97           0           1          0  0.00%  0.00%  0.00%   0 SSS Manager     
      98           0           1          0  0.00%  0.00%  0.00%   0 SSS Feature Mana
      99           0           1          0  0.00%  0.00%  0.00%   0 SSS Feature Time
    100           0           2          0  0.00%  0.00%  0.00%   0 Spanning Tree   
    101           0           1          0  0.00%  0.00%  0.00%   0 X.25 Encaps Mana
    102          20          96        208  0.00%  0.00%  0.00%   0 SSM connection m
    103           0           1          0  0.00%  0.00%  0.00%   0 AC Switch       
    104           4        5709          0  0.00%  0.00%  0.00%   0 Authentication P
    105           0           1          0  0.00%  0.00%  0.00%   0 Auth-proxy AAA B
    106           0           2          0  0.00%  0.00%  0.00%   0 EAPoUDP Process 
    107           0           2          0  0.00%  0.00%  0.00%   0 IP Host Track Pr
    108           0           2          0  0.00%  0.00%  0.00%   0 KRB5 AAA        
    109        1152       49386         23  0.00%  0.00%  0.00%   0 IP Background   
    110        2276       28582         79  0.00%  0.00%  0.00%   0 IP RIB Update   
    111          60       34442          1  0.00%  0.00%  0.00%   0 CEF background p
    112        6784     2485297          2  0.00%  0.00%  0.00%   0 CEF: IPv4 proces
    113          12         104        115  0.00%  0.00%  0.00%   0 ADJ background  
    114           0           2          0  0.00%  0.00%  0.00%   0 PPP IP Route    
    115           0           2          0  0.00%  0.00%  0.00%   0 PPP IPCP        
    116           0           1          0  0.00%  0.00%  0.00%   0 IP Traceroute   
    117        7292     7550370          0  0.00%  0.00%  0.00%   0 TCP Timer       
    118        1300       10511        123  0.00%  0.00%  0.00%   0 TCP Protocols   
    119           0           1          0  0.00%  0.00%  0.00%   0 Socket Timers   
    120       18228       11429       1594  0.00%  0.00%  0.00%   0 HTTP CORE       
    121           0           2          0  0.00%  0.00%  0.00%   0 RLM groups Proce
    122           0           1          0  0.00%  0.00%  0.00%   0 L2X Data Daemon 
    123           0           1          0  0.00%  0.00%  0.00%   0 ac_atm_state_eve
    124           0           2          0  0.00%  0.00%  0.00%   0 SNMP Timers     
    125        1320     1710737          0  0.00%  0.00%  0.00%   0 RUDPV1 Main Proc
    126           0           1          0  0.00%  0.00%  0.00%   0 bsm_timers      
    127         568     1710728          0  0.00%  0.00%  0.00%   0 bsm_xmt_proc    
    128           0           1          0  0.00%  0.00%  0.00%   0 COPS            
    129           0           2          0  0.00%  0.00%  0.00%   0 Dialer Forwarder
    130           0           3          0  0.00%  0.00%  0.00%   0 Flow Exporter Ti
    131           0           2          0  0.00%  0.00%  0.00%   0 ATM OAM Input   
    132           0           2          0  0.00%  0.00%  0.00%   0 ATM OAM TIMER   
    133           0           1          0  0.00%  0.00%  0.00%   0 RARP Input      
    134           0           1          0  0.00%  0.00%  0.00%   0 IPv6 Inspect Tim
    135           0           1          0  0.00%  0.00%  0.00%   0 LAPB Process    
    136           0           2          0  0.00%  0.00%  0.00%   0 LFDp Input Proc 
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
    137           0           1          0  0.00%  0.00%  0.00%   0 PAD InCall      
    138           0           2          0  0.00%  0.00%  0.00%   0 X.25 Background 
    139           0           2          0  0.00%  0.00%  0.00%   0 PPP Bind        
    140           0           2          0  0.00%  0.00%  0.00%   0 PPP SSS         
    141           0           1          0  0.00%  0.00%  0.00%   0 MQC Flow Event B
    142       35504   424737438          0  0.23%  0.25%  0.23%   0 HQF Shaper Backg
    143        4068    17031478          0  0.00%  0.00%  0.00%   0 RBSCP Background
    144           0           2          0  0.00%  0.00%  0.00%   0 SCTP Main Proces
    145           0           1          0  0.00%  0.00%  0.00%   0 VPDN call manage
    146           0           1          0  0.00%  0.00%  0.00%   0 CHKPT EXAMPLE   
    147           0           1          0  0.00%  0.00%  0.00%   0 CHKPT DevTest   
    148           0           1          0  0.00%  0.00%  0.00%   0 IPS Process     
    149           0           2          0  0.00%  0.00%  0.00%   0 IPS Auto Update 
    150           0           2          0  0.00%  0.00%  0.00%   0 SDEE Management 
    151         948     3338807          0  0.00%  0.00%  0.00%   0 Inspect process 
    152           0           1          0  0.00%  0.00%  0.00%   0 xcpa-driver     
    153          52      136947          0  0.00%  0.00%  0.00%   0 FW DP Inspect pr
    154        1112     3338806          0  0.00%  0.00%  0.00%   0 CCE DP URLF cach
    155           0           2          0  0.00%  0.00%  0.00%   0 URL filter proc 
    156           0           1          0  0.00%  0.00%  0.00%   0 XSM_EVENT_ENGINE
    157         144      171238          0  0.00%  0.00%  0.00%   0 XSM_ENQUEUER    
    158          68      171238          0  0.00%  0.00%  0.00%   0 XSM Historian   
    159           0           1          0  0.00%  0.00%  0.00%   0 Select Timers   
    160           4           2       2000  0.00%  0.00%  0.00%   0 HTTP Process    
    161           0           2          0  0.00%  0.00%  0.00%   0 CIFS API Process
    162           0           2          0  0.00%  0.00%  0.00%   0 CIFS Proxy Proce
    163           0           1          0  0.00%  0.00%  0.00%   0 Crypto HW Proc  
    164          56      114166          0  0.00%  0.00%  0.00%   0 ACE policy loade
    165         156       68505          2  0.00%  0.00%  0.00%   0 CRM_CALL_UPDATE_
    166       36688      172862        212  0.00%  0.00%  0.00%   0 BGP I/O         
    167           0           2          0  0.00%  0.00%  0.00%   0 AAA Cached Serve
    168           0           2          0  0.00%  0.00%  0.00%   0 ENABLE AAA      
    169           0           1          0  0.00%  0.00%  0.00%   0 EM Background Pr
    170           0           1          0  0.00%  0.00%  0.00%   0 Key chain liveke
    171           0           2          0  0.00%  0.00%  0.00%   0 LINE AAA        
    172          44         112        392  0.00%  0.00%  0.00%   0 LOCAL AAA       
    173           0          42          0  0.00%  0.00%  0.00%   0 MPLS Auto Mesh P
    174           0           2          0  0.00%  0.00%  0.00%   0 TPLUS           
    175           0           2          0  0.00%  0.00%  0.00%   0 VSP_MGR         
    176           0           1          0  0.00%  0.00%  0.00%   0 FW_TEST_TRP     
    177           0           1          0  0.00%  0.00%  0.00%   0 EPM MAIN PROCESS
    178           4           3       1333  0.00%  0.00%  0.00%   0 Crypto WUI      
    179           0           2          0  0.00%  0.00%  0.00%   0 Crypto Support  
    180           0           1          0  0.00%  0.00%  0.00%   0 IPSECv6 PS Proc 
    181           0           1          0  0.00%  0.00%  0.00%   0 CCVPM_HTSP      
    182           0           1          0  0.00%  0.00%  0.00%   0 CCVPM_R2        
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
    183           0           1          0  0.00%  0.00%  0.00%   0 EPHONE MWI Refre
    184           0        1903          0  0.00%  0.00%  0.00%   0 FB/KS Log HouseK
    185           0           2          0  0.00%  0.00%  0.00%   0 EPHONE MWI BG Pr
    186           0           1          0  0.00%  0.00%  0.00%   0 Skinny HW confer
    187           0           1          0  0.00%  0.00%  0.00%   0 CCSWVOICE       
    188      206492      114180       1808  0.00%  0.00%  0.00%   0 BGP Scanner     
    189           0           1          0  0.00%  0.00%  0.00%   0 http client proc
    190           0           3          0  0.00%  0.00%  0.00%   0 BGP Event       
    191           0           1          0  0.00%  0.00%  0.00%   0 QOS_MODULE_MAIN 
    192           0           1          0  0.00%  0.00%  0.00%   0 RPMS_PROC_MAIN  
    193           0           1          0  0.00%  0.00%  0.00%   0 VoIP AAA        
    194           0           2          0  0.00%  0.00%  0.00%   0 Dialog Manager  
    195         184         104       1769  0.00%  0.00%  0.00%   0 crypto engine pr
    196           0           4          0  0.00%  0.00%  0.00%   0 Crypto CA       
    197           0           1          0  0.00%  0.00%  0.00%   0 Crypto PKI-CRL  
    198       28008       64288        435  0.00%  0.00%  0.00%   0 encrypt proc    
    199      384768       28300      13596  0.00%  0.00%  0.00%   0 crypto sw pk pro
    200           8          27        296  0.00%  0.00%  0.00%   0 Crypto INT      
    201         456        2019        225  0.00%  0.00%  0.00%   0 Crypto IKE Dispa
    202        2128        2714        784  0.00%  0.00%  0.00%   0 Crypto IKMP     
    203           0           1          0  0.00%  0.00%  0.00%   0 IPSEC manual key
    204         180       85737          2  0.00%  0.00%  0.00%   0 IPSEC key engine
    205           0           1          0  0.00%  0.00%  0.00%   0 CRYPTO QoS proce
    206          28         142        197  0.00%  0.00%  0.00%   0 Crypto ACL      
    207           0           1          0  0.00%  0.00%  0.00%   0 Crypto PAS Proc 
    208           0           1          0  0.00%  0.00%  0.00%   0 GDOI GM Process 
    209           0           1          0  0.00%  0.00%  0.00%   0 UNICAST REKEY   
    210           0           1          0  0.00%  0.00%  0.00%   0 UNICAST REKEY AC
    211           0           1          0  0.00%  0.00%  0.00%   0 MV64 TDR Process
    212           0           1          0  0.00%  0.00%  0.00%   0 IMA Traps       
    213           0           1          0  0.00%  0.00%  0.00%   0 SYSMGT Events   
    214           0           2          0  0.00%  0.00%  0.00%   0 Control-plane ho
    215           0           1          0  0.00%  0.00%  0.00%   0 DATA Transfer Pr
    216           0           1          0  0.00%  0.00%  0.00%   0 DATA Collector  
    217           0           1          0  0.00%  0.00%  0.00%   0 Async write proc
    218         116         292        397  0.00%  0.00%  0.00%   0 AAA SEND STOP EV
    219         136      171243          0  0.00%  0.00%  0.00%   0 RMON Recycle Pro
    220           0           2          0  0.00%  0.00%  0.00%   0 RMON Deferred Se
    221           0           1          0  0.00%  0.00%  0.00%   0 Syslog Traps    
    222           0           2          0  0.00%  0.00%  0.00%   0 EEM ED Resource 
    223           0           2          0  0.00%  0.00%  0.00%   0 EEM ED Routing  
    224           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Track    
    225          80       53575          1  0.00%  0.00%  0.00%   0 Crypto cTCP proc
    226           0           1          0  0.00%  0.00%  0.00%   0 IP SLAs Ethernet
    227           4           1       4000  0.00%  0.00%  0.00%   0 RMON Packets    
    228         820     1709984          0  0.00%  0.00%  0.00%   0 trunk conditioni
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
    229           0           1          0  0.00%  0.00%  0.00%   0 trunk conditioni
    230          12         120        100  0.00%  0.00%  0.00%   0 EEM Server      
    231           4           2       2000  0.00%  0.00%  0.00%   0 Call Home proces
    232          52         260        200  0.00%  0.00%  0.00%   0 Syslog          
    233           0           1          0  0.00%  0.00%  0.00%   0 VPDN Test       
    234           0           2          0  0.00%  0.00%  0.00%   0 EEM Policy Direc
    235           0           2          0  0.00%  0.00%  0.00%   0 EEM ED CLI      
    236           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Counter  
    237           0           3          0  0.00%  0.00%  0.00%   0 EM ED GOLD      
    238           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Interface
    239           0           3          0  0.00%  0.00%  0.00%   0 EEM ED IOSWD    
    240           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Ipsla    
    241           0           3          0  0.00%  0.00%  0.00%   0 EEM ED None     
    242           0           2          0  0.00%  0.00%  0.00%   0 EEM ED Nf       
    243           0           3          0  0.00%  0.00%  0.00%   0 EEM ED OIR      
    244           0           3          0  0.00%  0.00%  0.00%   0 EEM ED RF       
    245           0           3          0  0.00%  0.00%  0.00%   0 EEM ED SNMP     
    246           0           2          0  0.00%  0.00%  0.00%   0 EEM ED SNMP Noti
    247          36       42890          0  0.00%  0.00%  0.00%   0 EEM ED Timer    
    248           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Test     
    249           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Config   
    250           0           3          0  0.00%  0.00%  0.00%   0 EEM ED Env      
    251           0           3          0  0.00%  0.00%  0.00%   0 EEM ED RPC      
    252           0           2          0  0.00%  0.00%  0.00%   0 cpf_process_msg_
    253           0           1          0  0.00%  0.00%  0.00%   0 Key Proc        
    254          36       28543          1  0.00%  0.00%  0.00%   0 Call Home Timer 
    255           0           1          0  0.00%  0.00%  0.00%   0 tHUB            
    256           0           1          0  0.00%  0.00%  0.00%   0 Async write proc
    257         104         953        109  0.00%  0.00%  0.00%   0 SSH Event handle
    258          16       28543          0  0.00%  0.00%  0.00%   0 Secure Login    
    259          84          54       1555  0.00%  0.00%  0.00%   0 Tunnel Security 
    260          56          67        835  0.00%  0.00%  0.00%   0 Crypto SS Proces
    261           0           1          0  0.00%  0.00%  0.00%   0 cpf_process_tpQ 
    262           0           1          0  0.00%  0.00%  0.00%   0 TCP Listener    
    263           0           2          0  0.00%  0.00%  0.00%   0 IP Flow Top Talk
    264        1180     3338804          0  0.00%  0.00%  0.00%   0 IP NAT Ager     
    265           0           1          0  0.00%  0.00%  0.00%   0 IP NAT WLAN     
    266          24       28563          0  0.00%  0.00%  0.00%   0 IP SLAs Event Pr
    267      434504     1489526        291  0.00%  0.00%  0.00%   0 IP SNMP         
    268      170304      877961        193  0.00%  0.00%  0.00%   0 PDU DISPATCHER  
    269      495704      877992        564  0.00%  0.00%  0.00%   0 SNMP ENGINE     
    270           0           2          0  0.00%  0.00%  0.00%   0 IP SNMPV6       
    271           0           1          0  0.00%  0.00%  0.00%   0 SNMP ConfCopyPro
    272           0           1          0  0.00%  0.00%  0.00%   0 SNMP Traps      
    273     1185420     1715196        691  0.00%  0.00%  0.00%   0 NTP             
    274         412          29      14206  0.00%  0.00%  0.00%   0 VTEMPLATE Backgr
    PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process
    275       18608      174262        106  0.00%  0.00%  0.00%   0 BGP Router      
    276          36       27171          1  0.00%  0.00%  0.00%   0 DFS flush period
    277           8          12        666  0.00%  0.00%  0.00%   0 Collection proce
    278          16         651         24  0.00%  0.00%  0.00%   0 CRYPTO IKMP IPC 
    279        1724         850       2028  0.00%  0.00%  0.00%   2 SSH Process     
    281           0           1          0  0.00%  0.00%  0.00%   0 Skinny MOH Event
    282          64      173856          0  0.00%  0.00%  0.00%   0 Skinny Socket Se
    283           0        1451          0  0.00%  0.00%  0.00%   0 Web Write Housek
    ==============================================================
    wish to help ASAP

    JosephDoherty wrote:DisclaimerThe   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.Liability DisclaimerIn   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.PostingThe fact you are matching with any ACLs, will decrease maximum performance.The fact you are using a policy-may, will decrease maximum performance.The fact is a -G2 only has finite capacity.In other words, what you're seeing might be completely normal for your traffic volume, your traffic composition and your configuration.If you believe your router is overloaded, and generally above 75% CPU might be so considered, either you'll need a faster device (see ASR 1Ks), or you might try changing your configuration to decrease your configuration load on the router.What's your CPU load if your remove the policy-map from the interface?If removing the policy-map from the interface shows a significant CPU loading decrease - QED.If you need/desire such QoS, then you'll want a "faster" router.You might be also able to decrease your CPU a little by some "tuning".  I already mention the TurboACL feature statement.  With ACLs, fewer are faster, and how they ordered (especially without TurboACL) impacts CPU.  How you order you class-maps, within a policy, and how the match statements are ordered will also have some impact on the CPU load.  If buffers are being allocated/deallocated, that too will impact CPU loading.  I assume CEF is enabled, but for some traffic, flow caching might decrease CPU load.Remember a software based router, like the 7200s, are, more or less, a computer that takes your configuration and determines what's to be done with every packet it "sees".  The more your configuration requires for per packet analysis, the more load for each packet.There are whitepapers addressing high CPU load caused by "process switching", but what you posted appears to be mostly all interrupt processing, which is "fast path", or optimal, packet forwarding.  There's not much you can normally do to improve against that, other than insuring your configuration is as optimal as possible for your needs (again, things like sequencing/ordering of statements).
    hi ,
    thanks very very much for this nice information,
    let me answer you :
    you said that NPE G2 has finite capacity , but how to know this full capacity ???
    i mean that my policy map is matching the traffic , but the matched traffic is not being enhancemend ??!!!
    last about two weeks , the matched traffic of youtube was excellent and no interrupt durting the my rush hour.
    i didnt change any thing, but my bw increased from 730 Mbps to 760Mbps ,
    im un able to make sure that i need to chnage my platform to faster one.
    agian
    my cpu is 60 % without QOS
    after QOS it increase to 80-85 %
    agian ,
    about NBAR
    i want to tell you that i cant depend on NBAR , as an example , im matching the ips of videos of facebook , i cant depend on NBAR because it is https videos.
    but in summary ,
    my qos is matching well , but i have no real enhancement for my traffic.
    did you face my issue before  ???
    i mean have you see like my problem ?
    like my router platform  with cpu over 80 % and 750Mbps , and matched qos without good result ??
    note that i upgraded to iso 15 , but seems same issue !!!
    regards

  • File(FTP) Adapter doesn't pick any file from FTP server

    Hi All,
    This is a strange problem. I am trying to pick all the file from a FTP server using File Name: . . But the file adapter doesn't pick any file from the directory. When  I change it to a specific file name eg. ABC.txt then it picks up the file ABC.txt only.
    My requirement is to pick up all files in the directory and I just do not seem to understand what is wrong. I have used this wildcard option several times earlier and it always worked fine. But in this case, this does not work.
    I changed the FTP server to point to an internal FTP server and it works fine.
    I have checked all my parameters and everything looks okay. Like I mentioned earlier, if you specify exact file name, it picks up the file.
    Any guess as to what is going on here?

    Transport Protocol: FTP
    Message Protocol: File
    source directory: /test or test ( <b>either one works</b>)
    file name: * or . or *.txt <b>nothing works</b>
    server: ftp server name
    port: 21
    data connection: passive
    user: ******
    pass: ******
    connect mode: permanently
    transfer mode: text
    QOS: exactly once
    poll: 10 secs
    processing mode: archive ( <b>changed to test and delete as well, but made no difference</b>.)
    archive dir: dir path
    file type: text
    adapter specific attributes:
    checked: set adapter specific attributes
    and file name.
    status: active.

  • How to apply Qos in the precedence of cache server

    m in an isp  and iwant to apply the QOS to enhance my network internet performance
    actually i  have two requests , i will start with showing brief topology about my network and start asking the questions .
    here is the topology below :
    from the topology above , my access is only on R1 which is BGP internet gateway router and R2 is my ISP router.
    1- i want to apply Qos on R1 so that a subnet of 32 ips to have gurantee bandwidth of 30M .
    assume  the subnet  is 10.20.30.0/27  that need to be bw gurantee .
    2- i want the download traffic by idman or ftp on my Router R1 dont exceed 50 % of my total bw .
    i mean that i have 450M bandwith from my isp , & sometimes we have a  slow in browsing , so i want to enhance the browsing quality because  its more important that downloading files from internet.
    here is my two requests above , i dont know how it will work with the precedence of the cache server .
    anyway , i will paste my config of router and i will replace my puplic ips with xxx for privacy .
    7200Gateway#sh run
    Building configuration...
    Current configuration : 10149 bytes
    upgrade fpd auto
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname 7200Gateway
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    logging buffered 50000
    enable secret xxxxxxxxxxxxxx
    no aaa new-model
    ip source-route
    ip wccp 80 redirect-list CACHE80
    ip wccp 90 redirect-list CACHE90
    ip cef
    no ip domain lookup
    ip accounting-threshold 4294967295
    login block-for 180 attempts 3 within 60
    login quiet-mode access-class telnet
    login on-failure log
    login on-success log
    no ipv6 cef
    multilink bundle-name authenticated
    username xxxxxx password xxxxx
    archive
    log config
      hidekeys
    interface GigabitEthernet0/1
    description LAN
    bandwidth 230000
    ip address 10.160.150.2 255.255.255.0
    ip wccp 80 redirect in
    ip policy route-map CACHE-REDIRECT
    load-interval 30
    duplex auto
    speed auto
    media-type rj45
    negotiation auto
    interface FastEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    interface GigabitEthernet0/2
    description Cache
    bandwidth 150000
    ip address x.x.x.x 255.255.255.248
    ip wccp redirect exclude in
    load-interval 30
    duplex auto
    speed 1000
    media-type rj45
    negotiation auto
    interface GigabitEthernet0/3
    description Internet
    bandwidth 230000
    ip address x.x.x.x 255.255.255.252
    ip wccp 90 redirect in
    load-interval 30
    duplex full
    speed 1000
    media-type sfp
    negotiation auto
    router bgp zzzzzzz
    no synchronization
    bgp log-neighbor-changes
    network xxxx mask xxxxx
    network xxxx mask xxxx
    network xxxx mask xxxxx
    network xxxx mask xxxx
    network xxxx mask xxxxx
    network xxxx mask xxxx
    redistribute connected
    redistribute static
    neighbor zzzzzzzz remote-as zzzzzzz
    neighbor zzzzzzz password zzzzzzz
    neighbor zzzzzz route-map Pipo out
    no auto-summary
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 xxxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    no ip http server
    no ip http secure-server
    ip flow-top-talkers
    top 200
    sort-by bytes
    cache-timeout 5000
    ip access-list extended bb
    permit ip xxxx.xxxx.xx.0 0.0.1.255 any
    ip access-list extended CACHE80
    permit tcp xxxxxxx any eq www
    ip access-list extended CACHE90
    permit tcp any xxxxx.0 0.0.0.255
    ip access-list extended pipo
    permit ip xxxxx xxxxxxx any
      permit ip xxxxx xxxxxxx any
    ip access-list extended private
    permit tcp 172.16.0.0 0.0.255.255 any eq www
    permit ip 10.20.30.0 0.0.0.255 any
    ip access-list extended telnet
    permit ip xxxxxx xxxxxxx.255.255 any log
    permit ip xxxx xxxxx 0.0.0.255 any log
    ip prefix-list bb seq 5 permit xxxxx
    ip prefix-list bbseq 10 permit xxxxxx
    logging history size 500
    no cdp run
    route-map pipo permit 10
    match ip address prefix-list pipo1
    route-map pipo permit 20
    match ip address prefix-list newsubnet
    set metric 500
    set origin incomplete
    set as-path prepend xxxxxxxxx
    route-map permit 10
    match ip address prefix-list bibo
    route-map CACHE-REDIRECT permit 10
    match ip address  private
    set ip next-hop 1vvvvvv
    route-map CACHE-REDIRECT permit 20
    match ip address bibo e1
    set ip next-hop vvvvvv
    route-map CACHE-REDIRECT permit 30
    match ip address pipo
    set ip next-hop vvvvvvvvvv
    route-map CACHE-REDIRECT permit 100
    snmp-server community xxxxxx RO
    control-plane
    dial-peer cor custom
    line con 0
    password xxxxxxxx
    logging synchronous
    login
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    exec-timeout 60 0
    password xxxxxxxxxxxxxxxxx
    logging synchronous
    login local
    end

    Hi Vinay,
    Please check the program. I have used the replace statement but it is not working.
    IF NOT v_sap_bom_rec IS INITIAL.
    Spliting the records at '~' delimiter
        SPLIT v_sap_bom_rec AT c_del INTO  wa_bom_file-model_name
                                           wa_bom_file-product_code
                                           wa_bom_file-description
                                           wa_bom_file-product_type
                                           wa_bom_file-mfg_part_num
                                           wa_bom_file-mfg_part_desc.
        REPLACE cl_abap_char_utilities=>horizontal_tab IN wa_bom_file-mfg_part_desc WITH space .
        wa_bom_file-status = c_status.
        APPEND wa_bom_file  TO i_bom_file.
    But it is not working.
    Please help me..
    Thanks
    Neelima

  • How to change default FCoE QoS class - Nexus 5020

    I see that on a Nexus 5020, the default FCoE QoS class is 50%. I am not using FCoE so I would like to adjust this value to 0%. I switch complains and says I can't change default values. How should I go about getting around this to eliminate the FCoE queue and give 100% BW to default? Thanks.

    No. The default classloader is a builtin classloader in
    the JRE. You can use other classloaders.
    The java.net.URLClassLoader is provided in
    the JDK. That's the only one. Otherwise you
    should subclass ClassLoader and implement
    the loadClass method (f.i.
    loadClass("my.program") {
    String file="my.program".replace('.','/') + ".class";
    // find the file in classpath
    // read the class file in a byte[]
    return defineClass(byte[]);
    although this is not the advised way to do it. Search the web for how to implement a classloader directly.

Maybe you are looking for