Frame-relay - config a router as a switch

I am trying to configure a router as a frame-relay switch called R3.
R1 (S0/1) is connected to my Frame-Relay Switch R3 (S1/0). R3 has a further 3 connections (S1/1, S1/2 & S1/3) to R2, R4 &R5. So R1 uses subinterfaces.
I am having problems configuring the switch to say connect R1 to R2.
Here is my R1 config:
Interface Serial0/0
No ip address
Encapsulation frame-relay
interface Serial0/0.1 point-to-point
ip address 10.1.1.1 255.255.255.0
frame-relay interface-dlci 16
interface Serial0/0.2 point-to-point
ip address 10.1.2.1 255.255.255.0
frame-relay interface-dlci 17
interface Serial0/0.3 point-to-point
ip address 10.1.3.1 255.255.255.0
frame-relay interface-dlci 18
Here is my Frame-Relay switch (R3) config:
frame-relay switching
Interface Serial1/0
No ip address
Encapsulation frame-relay
Clock rate 64000
Frame-relay intf-type dce
interface Serial1/0.1 point-to-point
frame-relay interface-dlci 16
interface Serial1/0.2 point-to-point
frame-relay interface-dlci 17
interface Serial1/0.3 point-to-point
frame-relay interface-dlci 18
Interface Serial1/1
No ip address
Encapsulation frame-relay
Clock rate 64000
frame-relay interface-dlci 20
Interface Serial1/2
No ip address
Encapsulation frame-relay
Clock rate 64000
frame-relay interface-dlci 21
Interface Serial1/3
No ip address
Encapsulation frame-relay
Clock rate 64000
frame-relay interface-dlci 22
Here is my R2 config:
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay interface-dlci 20
Normally I would enter the frame-relay switch command?
Frame-relay route 16 interface s1/1 20
I want to use subinterrfaces and not multipoint.
Why does this not work?? I cannot get connectivity from R1 to R2!

John
It is fine to use subinterfaces on R1 and R2 (in fact it is best practice to use point to point subinterface for Frame Relay). But I do not believe that you can do subintefaces on the router that is acting as the switch. I believe that the key elements of the router as frame relay switch include: frame-relay switching (which you have), Frame-relay intf-type dce (which you have), and Frame-relay route 16 interface s1/1 20 (which you need to add in place of the subinterfaces with DLCI identifier).
HTH
Rick

Similar Messages

  • Frame Relay point to point

    Hi All,
    I have configured below point to point link with FR switch in GNS 3.
    below is the configuration for the senario.
    R1#sh run int serial 0/0
    Building configuration...
    Current configuration : 144 bytes
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    clock rate 2000000
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    end
    R1#sh run int serial 0/0.101
    Building configuration...
    Current configuration : 118 bytes
    interface Serial0/0.101 point-to-point
    ip address 10.1.1.1 255.255.255.252
    frame-relay interface-dlci 101
    end
    ==============================
    R2#sh run int serial 0/0
    Building configuration...
    Current configuration : 144 bytes
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    clock rate 2000000
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    end
    R2#sh run int serial 0/0.201
    Building configuration...
    Current configuration : 118 bytes
    interface Serial0/0.201 point-to-point
    ip address 10.1.1.2 255.255.255.252
    frame-relay interface-dlci 201
    end
    ======================
    FR switch is port 1-101 for R1 serial 0/0 & Port 2-201 for R2 serial 0/0
    Below is the status for the sh frame-relay map
    R1#sh frame-relay map
    Serial0/0.101 (up): point-to-point dlci, dlci 101(0x65,0x1850), broadcast status defined, active
    R2#sh frame-relay map
    Serial0/0.201 (down): point-to-point dlci, dlci 201(0xC9,0x3090), broadcast status deleted
    Serial0/1.201 (administratively down): point-to-point dlci, dlci 201(0xC9,0x3090), broadcast status deleted
    Please let me know where i am making a mistake.

    Hello
    You mentioned a FR switch, if so these routers interfaces should not be clocking - as they should be both DTE's
    Delete the config (sub interfaces and default the serial interfaces ,also shut/no shut them and re apply the config)
    res
    Paul
    Please don't forget to rate any posts that have been helpful.
    Thanks.

  • Voice over Frame-Relay

    Hi,
    Customer of me has several sites connected with leased lines. The leased lines have frame-relay encapsulation (frame-relay back-to-back)
    The line has two pvc's configured, one for voice and one for data. The voice PVC works fine. On the data pvc we want to put some QoS.
    Here is the partial configuration:
    interface Serial0
    bandwidth 2000
    no ip address
    encapsulation frame-relay
    no ip route-cache cef
    ip route-cache flow
    no ip mroute-cache
    frame-relay intf-type dce
    interface Serial0.1 point-to-point
    ip address 10.xx.xx.1 255.255.255.252
    no ip mroute-cache
    frame-relay interface-dlci 120
    interface Serial0.2 point-to-point
    ip address 10.0.0.1 255.255.255.252
    no ip mroute-cache
    frame-relay interface-dlci 100
    class VOICE
    vofr cisco
    map-class frame-relay VOICE
    frame-relay cir 512000
    frame-relay voice bandwidth 256000
    frame-relay fragment 320
    frame-relay fair-queue
    Question is can I just apply a service policy out to the data DLCI or doi i also have to enable frame-relay traffic shaping?
    Thanks,
    JH

    The disadvantage of shaping is that it will actually limit you bandwidth. That is, you won't be able to use the circuit at full capacity, because of the artificial limitation induced by shaping. This is particularly true for a situation like you where the actual circuits is a leased line, and not a FR network.
    A better approach would be to reconfigure for simple hdlc encap, and run VoIP instead. This way, you would have all the QOS features you need for voice and data, and be able to use the full capacity with a much simpler configuration.
    Actually, even if you want to retain the FR encapsulation and the voice over FR approach, still using a single PVC would be better, for the same reasons given above.
    Hope this helps, please rate post if it does!

  • Configuring Frame-Relay and the Frame-Relay Switch To Participate in WAN Routing

    Hey,
    My WAN in my voice lab is currently functional between all of my routers HQ, BR1, and BR1 with full-mesh connectivity.  I am using my PSTN router for the frame-relay switching as is shown in the attached configs.  I have used the connect commands for the PVC routing logic.  
    connect HQ-BR1 Serial0/3/0 101 Serial0/2/0 201 
    connect HQ-BR2 Serial0/3/0 102 Serial0/2/1 301 
    connect BR1-BR2 Serial0/2/0 202 Serial0/2/1 302 
    My question concerns the possibility of getting the PSTN router to participate in the WAN and the OSPF routing process?  The connect command tells how the PVCs are to be connected and pass through the PSTN router.  Is there anyway to do it so that a PVC connects to the PSTN router itself?
    I would specifically like to create a connection between the HQ and PSTN router over the WAN.  If anyone has any insight on this I would really appreciate it.
    Thank you.

    Hello Adam,
    you don't need to do FR switching.
    You just need to configure a back to back PVC associated to a p2p subinterface under PSTN router interface se0/3/0 and HQ:se0/1/0. the new PVC can be 103 on both sides
    PSTN
    interface ser0/3/0.103 point-to-point
    ip address 10.1.13.1 255.255.255.0
    frame-relay interface-dlci 103
    HQ
    interface ser0/1/0.103 point-to-point
    ip address 10.1.13.1 255.255.255.0
    frame-relay interface-dlci 103
    note: I was able to do this using the older syntax frame-relay route under interface configuration on frame relay switch. I would expect to work for you too with newer syntax connect.
    Hope to help
    Giuseppe

  • Frame relay switch

    can anyone tell me how to set up a frame relay switch on my 1700 roouter with 2 serial connections, I want this to act like my isp. I believe this can be done, it is for testing in my home lab
    thanks
    Carlos

    Hi Carl,
    Yes you can cofigure router as a frame relay switch.
    Check this link
    http://www.cisco.com/warp/public/125/fr_switching.pdf
    Just check the config for router Americas in that link and you will get to know how to switch the dlci.
    To get a complete know how about Frame Relay have a look at this link
    http://www.cisco.com/en/US/tech/tk713/tk237/tech_configuration_examples_list.html
    HTH, if yes please rate the post.
    Ankur

  • 2621 as a Frame Relay switch & terminal server?

    Is it unwise to use a 2621 as a combined Frame Relay switch & terminal server in a home lab? Both functions seem to move a general-purpose router into the dedicated use category.
    Likewise, is it true than configuring a router to serve as a Frame Relay switch isn't memory intensive?
    If I am wrong in my assumptions, please feel free to correct my misperceptions.
    Thanks.

    Using the 2621 for frame and TS should be fine. I do it in my lab and have never had a problem.

  • Frame-relay interface-dlci switched command

    Hi,
    I want to understand the frame-relay interface-dlci switched command on router.
    I know it is used for local switching, but what this command exectly does? is it emulating router to behave like a frame-relay switch for particular interfaces (not all interfaces)?
    To use this command router serial interface needs to be have only layer 2 information or it can use that interface for layer 3 connectivity also?
    regards
    Devang Patel

    Hi,
    Thanks for your replies...
    In FRoMPLS we use connect configuration on global configuration mode with xconnect command to configure FRoMPLS. then how frame-replay interface-dlci switched will work with FRoMPLS, will it add any additional feature to configuration? I am just trying to understand the use of this command.
    will after putting this command i will have functionality to configure L2 and L3 VLAN configuration on same interface?
    am i correct with my understanding posted in this reply as well as my initial post?
    thanks,
    Devang Patel

  • Ipx over frame relay and route redistribution

    Hi,
    When I configure ipx over frame-relay multipoint interface, I need to run eigrp and disable the split horizon, and I'm running ipx rip on the same router thus, redistribution is automatic by default. This will cause potential routing loop when the route is advertised back from the same interface. In this situation, I have few questions:
    1. How to prevent routing loop in this situation?
    2. What is the administrative distance for ipx rip, eigrp, nslp?
    3. How does eigrp and rip convert the metric?
    Thank you
    Fujin

    Often times complex configuration issues are best addressed in an interactive session with one of our trained technical assistance engineers. While other forum users may be able to help, it’s often difficult to do so for this type of issue.
    To utilize the resources at our Technical Assistance Center, please visit http://www.cisco.com/tac and to open a case with one of our TAC engineers, visit http://www.cisco.com/tac/caseopen
    If anyone else in the forum has some advice, please reply to this thread.
    Thank you for posting.

  • Connection from remote sites (Frame Relay WAN) to AS/400 dissapears

    Hello,
    We have the following problem appearing in our environment:
    All connections from remote sites dissapears unexpected from AS/400. After 2-3 minutes remote users get normal connectivity again.
    The environment is the the following:
    Frame Relay/ATM WAN (Frame Relay on remote sites and ATM in datacenter) comes to Cisco 7204VXR router which connected to LAN switch with 10/100/1000 ports. AS/400 with Fast Ethernet interface also connected to the similar LAN switch. CEF is enabled on the router, IOS version 12.4.3a. We have ETHSTD *ALL parameter set on AS/400. Remote users uses TCP/IP and Telnet but there are a number of 5494 controllers wich uses SNA.
    We got the problem for the first time after we enabled CEF on the router.
    I suspect that the cause of problem is Ethernet frames of different standards due to ETHSTD *ALL, but can neither reproduce the problem nor understand why it behaves so.
    Have anybody had similar problem?
    I would be very thanksfull if somebody can help me to solve it.
    Thank you in advance.
    //Mikhail Galiulin

    Hi Martin,
    Cisco 7200 itself can access AS/400 as well as all other hosts in the same with AS/400 LAN. There is no any outage in communications which goes to another LAN segment via Netscreen firewall while the communication via Cisco is down. Only those hosts which connected via Cisco are experiencing the problem. I can not say where the traceroute from AS/400 stucks (there are other people who maintain the machine and they never could catch the exact moment of outage).
    To turn off CEF I treat as the last option actually and unfortunatelly there is no guarantee that software upgrade will help (we have 12.4.3a now).
    So first of all I'm trying to understan WHY it happens because I can not see any systematics in the problem appearance. It can happen 3 times under 2 days and then dissapear for 1-2 months...
    //Mikhail Galiulin

  • Frame Relay Configuration

    All,
    Sorry for asking this, but I have been beating my head against the wall here. I am getting a T1 installed in my residence for internet connectivity. I am using an old wic-1-dsu-t1-v1 in a 2610 router. I am unable to get this configuration working. I have a very simple configuration so far on the router, but I am unable to get this to come up. I have put the show run below. Some of the commands are default and are not showing up. Obviously I have changed the ip's to generic ones below. Any ideas?
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    hostname JSS-2610-001
    memory-size iomem 10
    ip subnet-zero
    interface Ethernet0/0
     no ip address
     shutdown
    interface Serial0/0
     no ip address
     shutdown
    interface Serial0/1
     no ip address
     shutdown
    interface Serial0/2
     no ip address
     encapsulation frame-relay IETF
     frame-relay lmi-type ansi
    interface Serial0/2.21 point-to-point
     ip address 1.1.1.3 255.255.255.252
     frame-relay interface-dlci 16   
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.1.1.2
    ip http server
    line con 0
     speed 115200
    line aux 0
    line vty 0 4

    Sorry when I transposed the ip's to post i made a mistake in them. 1.1.1.2 is my address and 1.1.1.1 is the gateway for them (their side of the t1). I have it configure correctly on my router with the real ip's.
    Here is the post to the rest of your questions:
    Serial0/2 is up, line protocol is up 
      Hardware is PQUICC with Fractional T1 CSU/DSU
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation FRAME-RELAY IETF, loopback not set
      Keepalive set (10 sec)
      LMI enq sent  16787, LMI stat recvd 16788, LMI upd recvd 0, DTE LMI up
      LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
      LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
      FR SVC disabled, LAPF state down
      Broadcast queue 0/64, broadcasts sent/dropped 2812/0, interface broadcasts 15
      Last input 00:00:04, output 00:00:04, output hang never
      Last clearing of "show interface" counters 1d22h
      Input queue: 0/75/3/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
         Conversations  0/1/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         16791 packets input, 249054 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 1 giants, 0 throttles
         3350 input errors, 1097 CRC, 1758 frame, 0 overrun, 0 ignored, 495 abort
         19638 packets output, 1080335 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 output buffer failures, 0 output buffers swapped out
         6 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    JSS-2610-001#show frame-relay pvc 
    PVC Statistics for interface Serial0/2 (Frame Relay DTE)
                  Active     Inactive      Deleted       Static
      Local          1            0            0            0
      Switched       0            0            0            0
      Unused         0            0            0            0
    DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2.21
      input pkts 0             output pkts 2834         in bytes 0         
      out bytes 844139         dropped pkts 0           in FECN pkts 0         
      in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
      in DE pkts 0             out DE pkts 0         
      out bcast pkts 2809       out bcast bytes 841611    
      pvc create time 1d22h, last time pvc status changed 15:31:28
    Is it possible the carrier just hasn't "activated" the circuit?

  • Map-class frame-relay , policy map

    Does a service-policy output have to be applied to an interface for qos to work?
    here is the config but there is nothing applied to the serial interface..
    Thanks for your help
    policy-map 256/128KVoice
    class 256/128KVoice
    priority 112
    class class-default
    fair-queue
    map-class frame-relay 256/128KVoice
    frame-relay cir 128000
    frame-relay bc 1280
    frame-relay be 600
    frame-relay mincir 128000
    no frame-relay adaptive-shaping
    frame-relay fair-queue
    frame-relay fragment 150
    frame-relay ip rtp priority 16384 16380 210
    interface Serial0/0
    bandwidth 1544
    ip address xxx.xxx.xxx.xxx 255.255.255.255
    ip route-cache flow
    no fair-queue
    service-module t1 timeslots 1-24

    Hello,
    Will QOS will work in this way  where class is put on WAN interface where it should be service  policy.
    router#sh run interface Se0/0/0.1
    Building  configuration...
    Current configuration : 239 bytes
    interface  Serial0/0/0.1 point-to-point
    bandwidth 2048
    ip address XXXX
    ip nat outside
    frame-relay  interface-dlci 555
      class COS-OUT-S0/0/0.1   
    end
    COS-OUT-S0/0/0.1 is defined as policy map  with class of voice and video.
    When checking on WAN int #sh policy-map  interface  Se0/0/0.1 , can see output of service policy input/output with policy map  recpective classes and packets match entries.Is  QOS working with this  configuration?
    Appreciate any input on this.
    Regards,
    Brajesh.

  • Is Low MTU (ie 320) for VoIP over Frame-relay can be used to avoid serialization delay for large data packets?

    In order to provide voice quality for VoIP, is FR fragmentation equivalent to lowering the MTU size for the serial subinterface of a Frame relay subinterface?
    Is there any isues like stop communications, using Low MTU ?

    If the router belongs to any of the
    platform listed below, then use
    FRF12 for you fragmentation. The MTU size
    lowering also works but this can cause a high over
    head as it can't be specified on a per dlci level.
    With multiple dlci i.e. subinterfaces use per dlci fragmentation.. this helps reduce the overhead of changing the MTU size of the physical interface.
    Snip config example.( __Must be configured on both side of the termination___)
    PHONE 3333312---ROUTERA ----DLCI 100----ROUTERB ---PHONE 2111123
    ROUTER A
    dial-peer voice 1 voip
    destination-pettern 2T
    session target ipv4:10.10.10.2
    int ser 0/0
    encap frame-relay
    frame-relay traffic-shaping
    no ip address
    interface serial0/0.1 point-to-point
    ip add 10.10.10.1 255.255.255.252
    frame-relay interface-dlci 100
    class voice
    map-class frame-relay voice
    frame cir 64000
    frame bc 640
    frame mincir 64000
    frame-relay ip rtp priority 16384 16383 48
    frame fragment 80
    frame fair-queue 64 256 0
    ROUTER B
    dial-peer voice 3 voip
    destination-pettern 3T
    session target ipv4:10.10.10.1
    int ser 0/0
    encap frame-relay
    frame-relay traffic-shaping
    no ip address
    interface serial0/0.1 point-to-point
    ip add 10.10.10.2 255.255.255.252
    frame-relay interface-dlci 100
    class voice
    map-class frame-relay voice
    frame cir 64000
    frame bc 640
    frame mincir 64000
    frame-relay ip rtp priority 16384 16383 48
    frame fragment 80
    frame fair-queue 64 256 0
    This should help if your router is
    c2600, c3600, mc3810, c7200, c1750
    all running the right level of IOS.
    12.1(5)T and above should work well.

  • Why is everything on my Frame-relay network working fine with different encapsulation types ?

    I have a cisco frame-relay switch with the encapsulation type on IETF.
    I have a cisco router with
    the encapsulation type on cisco.
    Still everything works fine.
    How come when it is a different dlsi byte structure ?
    Is it because also my switch is a cisco and it uses cisco encap afterall ?

    A cisco router will understand both the IETF and normal Cisco encapsulation when receiving data regardless of configuration. However, depending on the configuration, it will only send one type.

  • Cdp ? in Frame Relay environment

    Hi,
    I have set up a lab to look at F/R with a partial mesh and sub-interfaces.
    I have 3 DTE routers connected to a Frame Switch. One Router named 'middle' has the sub-interfaces configured on it. The other 2 routers named 'Top' & 'Bottom' are just physical interfaces.
    I used RIP to route the two networks between Top & Middle and Bottom & Middle respectively. The F/R side has gone well, however, CDP switched itself off on both of the physical interfaces on routers Top & Bottom !!!
    Is there a good reason for this ?
    To rectify this I have simply enabled cdp on both the serial interfaces.
    Regards,
    Phil.

    Hi Phil,
    CDP is disabled by default on (physical) serial interfaces configured for frame-relay encapsulation. That is also the case on multipoint frame-relay interfaces. That is standard IOS behaviour. I think it's due to the fact that these interface types do not inherently support multicast.
    Hope that helps - pls rate the post if it does.
    Paresh

  • Begining frame-relay

    Hello All,
    Can some please take the pain to take me through each step in configuring a frame-relay plz?
    I'm determined for CCNA and cannot afford the tuition but can afford three routers as explained by the book im using. Unfortunately i cannot gather all the wants me to get(probably misconception) in order to set-up frame relay.
    Please i need the steps to guide as if to a lay man i.e what goes from one router to the other, type of cable to link them etc and to what port, how the remaining two routers will particiapte etc
    Hope somebody can help?

    Hi, newnetman
    Here is the step-by-step
    1.Go to ebay and buy the following stuff
    One set of 4-serial port router. Two affordable options are 2520 and 2610+NM-4A/S.This will be your frame-relay switch
    Three set of 2-serial port routers. To make things simple, I would suggest 2501(it has 2 fixed serial port) or 2610+WIC-1T(in this case, you have only 1 serial port, but it is not a problem for our lab building)
    three pieces of Back to Back DCE/DTE DB60 Crossover Cables. You might want to add one cable to connect 2 routers(not frame-relay) so you can practice PPP without the need to re-wire the cable.
    2.Connect each router according the following cabling plan
    FR.s0R1.s0
    FR.s1R2.s0
    FR.s2R3.s0
    R1.s1R2.s1 (Suppose you have additional cables and additional ports)
    Each cable has one side marked as DCE and the other side marked as DTE. To make things simple we choose the DCE site to be connected to the FR and the DTE site to be connected to a normal router.(FR.s0 means serial port #0 of Frame-relay switch, FR.s1 means serial port #1 of Frame-relay switch,etc)
    3.Copy the commands I write on the attached file and paste to your Frame-Relay
    Here I give you 3 PVCs :
    R1.s0.102<--->R2.s0.201
    R1.s0.103<--->R3.s0.301
    R2.s0.203<--->R3.s0.302
    If you want create your own pvcs with different value, just substitute the above numbers to your own
    4.Last step. Finish the PVC on R1,R2, and R3, but for being a CCNA candidate, that's what you must know and configure it by yourself, isn't it?(Anyway, if you still feel difficult on this step, just let me know.)
    Good Lucks
    SSLIN
    P.S. It takes me a while to write this step-by-step. I'm happy doing it. I feel no pain.

Maybe you are looking for