H323 Bind issues

(config-subif)#h323-gateway voip bind srcaddr xxx.xxx.xxx.xxx
Bind IP Address configured. Please remove before reconfiguring
I am getting this message despite no bind address configured. anyone seen this issues before?
RTR#sh run   | include bind
RTR#
Any advise will be much appreciated.

version 15.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
service compress-config
hostname RTR
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.150-1.M4.bin
boot-end-marker
card type e1 0 1
logging buffered 4096
aaa new-model
aaa session-id common
network-clock-participate wic 1
no ipv6 cef
no ip source-route
ip cef
ip vrf 3RD_PARTY
 rd
 route-target export
 route-target import
ip vrf DATA
 rd
 route-target export
 route-target import
ip vrf forwarding
no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 172.27.165.1 172.27.165.25
ip dhcp excluded-address 172.27.165.129
ip dhcp pool VLAN1
   network 172.27.165.0 255.255.255.192
   dns-server xxx.xxx.xxx.xxx
   default-router 172.27.165.1
   option 150 ip XXX.XXX.XXX
   lease 3
ip dhcp pool VLAN133
   network 172.27.165.128 255.255.255.192
   default-router 172.27.165.129
   lease 0 3
no ip domain lookup
multilink bundle-name authenticated
isdn switch-type primary-net5
crypto pki token default removal timeout 0
voice-card 0
voice rtp send-recv
voice service voip
 fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
 modem passthrough nse codec g711ulaw
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
voice class h323 1
  h225 timeout tcp establish 3
  call start fast
voice translation-rule 100
 rule 1 /^.*/ /xxxxxxxxx/
voice translation-profile MAPOUTSIDE
 translate calling 100
hw-module pvdm 0/0
redundancy
controller E1 0/1/0
 line-termination 75-ohm
 pri-group timeslots 1-31
 description ### PABX ###
controller E1 0/1/1
interface GigabitEthernet0/0
 description ### Trunk  ###
 no ip address
 duplex auto
 speed auto
interface GigabitEthernet0/0.1
 description ### Managment, Server and Voice network ###
 encapsulation dot1Q 1 native
 ip address 192.168.1.1 255.255.255.0 secondary
 ip address 172.27.165.1 255.255.255.192
 no ip redirects
interface GigabitEthernet0/0.2
 description ### Lan ###
 encapsulation dot1Q 800
 ip vrf forwarding DATA
 no ip redirects
 ip tcp adjust-mss 1400
 bridge-group 2
 bridge-group 2 input-address-list 702
interface GigabitEthernet0/0.5
 description ### Riverbed AUX Port ###
 encapsulation dot1Q 5
 no ip redirects
 ip nat outside
 ip virtual-reassembly
interface GigabitEthernet0/0.133
 description ### Internet Wifi ###
 encapsulation dot1Q 133
 ip vrf forwarding 3RD_PARTY
 no ip redirects
 ip accounting output-packets
 bridge-group 33
 bridge-group 33 input-address-list 733
 bridge-group 33 output-address-list 733
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
interface GigabitEthernet0/2.950
  bandwidth 1024
 encapsulation dot1Q 950
 ip address 172.27.165.254 255.255.255.252
 ip flow ingress
 ip flow egress
interface GigabitEthernet0/2.951
  bandwidth 768
 encapsulation dot1Q 951
 ip vrf forwarding DATA
 ip address 172.27.165.250 255.255.255.252
 ip flow ingress
 ip flow egress
 rate-limit output 768000 8000 8000 conform-action transmit exceed-action drop
interface GigabitEthernet0/2.952
 bandwidth 256
 encapsulation dot1Q 952
 ip vrf forwarding 3RD_PARTY
 ip address 172.27.165.246 255.255.255.252
 ip flow ingress
 ip flow egress
 rate-limit output 256000 8000 8000 conform-action transmit exceed-action drop
interface GigabitEthernet0/2.959
 encapsulation dot1Q 959 native
 ip address 172.27.165.242 255.255.255.252
 ip flow ingress
 ip flow egress
interface Serial0/0/0
 bandwidth 1024
 no ip address
 encapsulation frame-relay
 load-interval 30
 no keepalive
 priority-group 1
 ignore dcd
 no clock rate 2000000
interface Serial0/0/1
 no ip address
 shutdown
 clock rate 2000000
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn timer T310 120000
 isdn protocol-emulate network
 isdn incoming-voice voice
 no cdp enable
interface BVI2
 ip vrf forwarding DATA
 ip address 192.168.1.1 255.255.255.0 secondary
 ip address 172.16.199.1 255.255.255.0
 no ip redirects
 ip accounting output-packets
 ip nbar protocol-discovery
 ip tcp adjust-mss 1400
interface BVI33
 ip vrf forwarding 3RD_PARTY
 ip address 172.27.165.129 255.255.255.192
 ip accounting output-packets
ip forward-protocol nd
no ip http server
no ip http secure-server
ip flow-top-talkers
 top 20
 sort-by bytes
 cache-timeout 30000
ip nat inside source list 150 interface GigabitEthernet0/0.5 overload
ip route 0.0.0.0 0.0.0.0 172.27.165.253 name default
ip route vrf 3RD_PARTY 0.0.0.0 0.0.0.0 172.27.165.245 name Default
ip route vrf DATA 0.0.0.0 0.0.0.0 172.27.165.249 name Default
control-plane
bridge 2 protocol ieee
bridge 2 route ip
bridge 33 protocol ieee
bridge 33 route ip
no call rsvp-sync
voice-port 0/1/0:15
voice-port 0/2/0
voice-port 0/2/1
voice-port 0/2/2
voice-port 0/2/3
dial-peer voice 100 pots
 description ### PABX ###
 destination-pattern XXXXXXXX
 port 0/1/0:15
 forward-digits all
dial-peer voice 2000 voip
 preference 2
 destination-pattern .T
 progress_ind setup enable 3
 session target ipv4:xxx.xxx.xxx.xxx
 voice-class codec 1
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 playout-delay nominal 130
 playout-delay mode fixed
 fax-relay ecm disable
 fax rate 9600
 fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
 clid network-number XXXXXXXX
 no vad
dial-peer voice 2001 voip
 preference 1
 destination-pattern .T
 progress_ind setup enable 3
 session target ipv4:xxx.xxx.xxx.xxx
 voice-class codec 1
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 playout-delay nominal 130
 playout-delay mode fixed
 fax-relay ecm disable
 fax rate 9600
 fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
 clid network-number XXXXXXXX
 no vad

Similar Messages

  • Attachment binding issue in workflow

    Hi All,
    I have used FM 'SAP_WAPI_ATTACHMENT_ADD ' in method of my workflow. Here after executing this FM i m getting id of the attachment for this workitem. But now i need to assign this to  '_Attach_Objects' of workflow container. so please help me for this binding issue. which i need to bind from method to> task to> workflow. so from next step onwards in workflow i will get that attachment.
    Smit Shah

    Hi,
    1) In the T.code SWO1, you have to create a custom method for the BO, there execute that method and check whether it working fine
    2) Then goto  T.code PFTC and Create a Task (Task no. will generate automatically), then call this method and generate the binding
    3) Goto  T.code SWDD and call that Task by assigning that Task no. and assign the binding
    Then test your workflow.
    For the Binding see this [link|http://help.sap.com/saphelp_nw04/helpdata/en/c8/bfc39b0fc57a49a0291378f8be0cd6/frameset.htm].
    Regards,
    Surjith

  • A data-binding issue with a combo box.

    Hi,
    Iu2019m having a data-binding issue with a combo box.  The field it is bound to is an integer.  The valid values in the combo box are 1, 2, and 3.  If I add a record when it is set to 1 or 2, the value gets stored correctly.  If I add a record when it is set to 3, it is stored as 1.  However, I can bring up the record just added on the form, change it to 3, and click u201CUpdateu201D and it is saved correctly as 3.  If I change it so that the valid values are 4, 5, and 6, it saves a 1 regardless of what is selected in the combo box.  It looks like the combo box is correctly bound for updates but not for adds.  The table is a master type UDO.  Any ideas?  Iu2019m somewhat committed to the field being an integer.  I'm using 2007A PL47.
    Thanks,
    Mike
    Edited by: Mike Angelastro on Jul 1, 2009 2:43 PM

    I tried a few things on my own.  The result is that I decided that it was not a good idea to use a combo box bound to an integer (numeric) field.  I donu2019t think the SDK can handle it.  The reason it was an integer field in the first place is that before I changed it to a combo box it was a group of two option buttons.  Option buttons use an integer (numeric) field.  This worked just fine until I added a third option; the SDK didnu2019t handle the third option correctly when adding records.  I thought that using a combo box instead would fix that.  I was wrong; the problem remained.  So I decided to use a character (alphanumeric) field instead.  This works just fine.
    So here is my advice:  Never use option buttons if they need to be bound to the database; a combo box will actually work better when bound to the database.  But use a character (alphanumeric) field.
    Edited by: Mike Angelastro on Jul 5, 2009 9:15 PM

  • [svn:cairngorm3:] 17187: Fixed binding issue on the source property of the contact's picture

    Revision: 17187
    Revision: 17187
    Author:   [email protected]
    Date:     2010-08-04 13:44:35 -0700 (Wed, 04 Aug 2010)
    Log Message:
    Fixed binding issue on the source property of the contact's picture
    Modified Paths:
        cairngorm3/trunk/samples/insync/insync-modularExtended-contacts/src/insync/contacts/prese ntation/ContactForm.mxml

    Revision: 17187
    Revision: 17187
    Author:   [email protected]
    Date:     2010-08-04 13:44:35 -0700 (Wed, 04 Aug 2010)
    Log Message:
    Fixed binding issue on the source property of the contact's picture
    Modified Paths:
        cairngorm3/trunk/samples/insync/insync-modularExtended-contacts/src/insync/contacts/prese ntation/ContactForm.mxml

  • [svn:cairngorm3:] 17186: Fixed binding issue on the source property of the contact's picture

    Revision: 17186
    Revision: 17186
    Author:   [email protected]
    Date:     2010-08-04 13:43:41 -0700 (Wed, 04 Aug 2010)
    Log Message:
    Fixed binding issue on the source property of the contact's picture
    Modified Paths:
        cairngorm3/trunk/samples/insync/insync-basic/src/insync/presentation/ContactForm.mxml

    Revision: 17186
    Revision: 17186
    Author:   [email protected]
    Date:     2010-08-04 13:43:41 -0700 (Wed, 04 Aug 2010)
    Log Message:
    Fixed binding issue on the source property of the contact's picture
    Modified Paths:
        cairngorm3/trunk/samples/insync/insync-basic/src/insync/presentation/ContactForm.mxml

  • SQL query / binding issues on my web page

    This may or maynot be the place to ask, but maybe someone can
    tell me what
    to look at...
    I created a page some time back.. and its displays a few
    fields of data
    based on the id passed to it..
    This works fine, but now that we are trying to improve the
    site a little,
    they want some additonal information displayed
    on the page.. so those changes were made about 2 weeks ago...
    now that some
    of the newer records contain the data
    they want displayed, some data is not displaying.. or it will
    display and
    other fields ( that were displaying before ) are now
    missing.. the web page hasnt been touched in 2 weeks.. if we
    execute the
    store procedure within SQL and within our web program
    it always returns the correct data.. but the fields that i
    have binded to
    the page are taking on a life of there own...
    Not sure if anyone has had this problem, but its getting
    annoying.. when i
    execute this within SQL it returns all the values requested.
    If i execute it
    within dreamweaver to show me what results i will get back it
    works there..
    but after i bind the fields to my page and view it only some
    or all my
    fields do not display any data... but if i play around with
    the order of my
    select statement below i can get some fields to display and
    other
    disappear... and i dont ever touch my webpage again...
    Can anyone shed some light on this issue? Or is there a
    better way to
    display my results so that what i get back with my query will
    always
    display....
    here is my stored procedure that im calling
    SET NOCOUNT ON;
    SELECT
    c.cfname,c.clname,c.cid,h.termcode,h.hiredate,h.lastdate,h.cdateh,
    h.cdatet,h.startdate,h.managername,h.termby,
    availsun1,availsun2,availmon1,availmon2,availtue1,availtue2,
    availwed1,availwed2,availthur1,availthur2,availfri1,availfri2,
    availsat1,availsat2,h.comby,ssn_dash = dbo.SSN_dash(cssn),
    Home = dbo.PhoneNumber_complete_format(chphone),
    Mobile = dbo.PhoneNumber_complete_format(cmphone),
    Other = dbo.PhoneNumber_complete_format(cophone),
    Jobtitle =
    case
    when c.st = '90' then
    (select top 1 j.jobtitle from has.dbo.JobCodes j where j.hjob
    = h.jobid and
    j.hlocation = 'DC')
    else
    (select top 1 j.jobtitle from has.dbo.JobCodes j where j.hjob
    = h.jobid and
    j.hlocation <> 'DC')
    end,
    (Select T.term_reason
    From has.dbo.termcodes T, has_arc.dbo.EmpTermHistory H
    where T.term_val = H.termcode and h.cid = @cid) as
    TermReason,
    Days = @day,
    Months = @month,
    Years = @year
    FROM has_arc.dbo.EmpCandidate C, has_arc.dbo.EmpTermHistory H
    WHERE C.cid = @cid AND C.cid = H.cid
    END
    ASP, SQL2005, DW8 VBScript

    And when it says read the columns left to right... i would
    imagine that
    means my select statement should select the columns in the
    order of which
    they are in the tables?
    so in my case.. if HomePhone is last column in my table it
    should be the
    last in the select statement?
    ASP, SQL2005, DW8 VBScript
    "Daniel" <[email protected]> wrote in message
    news:[email protected]...
    > Now when you say TEXT type.. your refering to the data
    types i have setup
    > in the database? correct
    >
    > Within the database the fields that im querying are
    pretty much all
    > varchar a few are date and one int
    >
    >
    >
    >
    > --
    > ASP, SQL2005, DW8 VBScript
    > "Joris van Lier" <[email protected]> wrote in
    message
    > news:[email protected]...
    >>
    >>
    >> "Daniel" <[email protected]> wrote in message
    >> news:[email protected]...
    >>> This may or maynot be the place to ask, but
    maybe someone can tell me
    >>> what
    >>> to look at...
    >>>
    >>> I created a page some time back.. and its
    displays a few fields of data
    >>> based on the id passed to it..
    >>> This works fine, but now that we are trying to
    improve the site a
    >>> little,
    >>> they want some additonal information displayed
    >>> on the page.. so those changes were made about 2
    weeks ago... now that
    >>> some
    >>> of the newer records contain the data
    >>> they want displayed, some data is not
    displaying.. or it will display
    >>> and
    >>> other fields ( that were displaying before ) are
    now
    >>> missing.. the web page hasnt been touched in 2
    weeks.. if we execute the
    >>> store procedure within SQL and within our web
    program
    >>> it always returns the correct data.. but the
    fields that i have binded
    >>> to
    >>> the page are taking on a life of there own...
    >>>
    >>> Not sure if anyone has had this problem, but its
    getting annoying.. when
    >>> i
    >>> execute this within SQL it returns all the
    values requested. If i
    >>> execute it
    >>> within dreamweaver to show me what results i
    will get back it works
    >>> there..
    >>> but after i bind the fields to my page and view
    it only some or all my
    >>> fields do not display any data... but if i play
    around with the order of
    >>> my
    >>> select statement below i can get some fields to
    display and other
    >>> disappear... and i dont ever touch my webpage
    again...
    >>>
    >>> Can anyone shed some light on this issue? Or is
    there a better way to
    >>> display my results so that what i get back with
    my query will always
    >>> display....
    >>>
    >>> here is my stored procedure that im calling
    >>> SET NOCOUNT ON;
    >>> SELECT
    >>>
    c.cfname,c.clname,c.cid,h.termcode,h.hiredate,h.lastdate,h.cdateh,
    >>> h.cdatet,h.startdate,h.managername,h.termby,
    >>>
    availsun1,availsun2,availmon1,availmon2,availtue1,availtue2,
    >>>
    availwed1,availwed2,availthur1,availthur2,availfri1,availfri2,
    >>> availsat1,availsat2,h.comby,ssn_dash =
    dbo.SSN_dash(cssn),
    >>> Home = dbo.PhoneNumber_complete_format(chphone),
    >>> Mobile =
    dbo.PhoneNumber_complete_format(cmphone),
    >>> Other =
    dbo.PhoneNumber_complete_format(cophone),
    >>> Jobtitle =
    >>> case
    >>> when c.st = '90' then
    >>> (select top 1 j.jobtitle from has.dbo.JobCodes j
    where j.hjob = h.jobid
    >>> and
    >>> j.hlocation = 'DC')
    >>> else
    >>> (select top 1 j.jobtitle from has.dbo.JobCodes j
    where j.hjob = h.jobid
    >>> and
    >>> j.hlocation <> 'DC')
    >>> end,
    >>> (Select T.term_reason
    >>> From has.dbo.termcodes T,
    has_arc.dbo.EmpTermHistory H
    >>> where T.term_val = H.termcode and h.cid = @cid)
    as TermReason,
    >>> Days = @day,
    >>> Months = @month,
    >>> Years = @year
    >>>
    >>> FROM has_arc.dbo.EmpCandidate C,
    has_arc.dbo.EmpTermHistory H
    >>> WHERE C.cid = @cid AND C.cid = H.cid
    >>> END
    >>>
    >>>
    >>> --
    >>> ASP, SQL2005, DW8 VBScript
    >>
    >>
    >> Are any of these fields by chance of TEXT type (or
    other Binary Large
    >> OBject type)?
    >> In this case there are certain limitations the text
    fields must be the
    >> last in your SQL statement and may only
    >> be retrieved ONCE reliably.
    >>
    >> <%
    >> Dim myTextVar
    >> myTextVar = Recordset.Fields.Item("TEXTFIELD").value
    >> %>
    >> <% If NOT IsNull(myTextVar) Then%>
    >> <%=(Replace(myTextVar, chr(13),
    "<BR>"))%>
    >> <% End If ' NOT IsNull(myTextVar) %>
    >>
    >> Here's an excerpt from the Microsoft Site
    >>
    >> When dealing with BLOB fields from Microsoft SQL
    Server, you must put
    >> them
    >> to the right of non-BLOB columns in the resultset.
    To be safe, you should
    >> also read the columns in left-to-right order, so if
    you have two BLOB
    >> columns as the last two columns in your resultset,
    read the first one and
    >> then the second. Do not read them in the reverse
    order.
    >> MS:
    http://support.microsoft.com/support/kb/articles/q175/2/39.asp
    >>
    >> Joris van Lier
    >
    >

  • SQL query / binding issues within dreamweaver

    Not sure if anyone has had this problem, but its getting
    annoying.. when i
    execute this within SQL it returns all the values requested.
    If i execute it
    within dreamweaver to show me what results i will get back it
    works there..
    but after i bind the fields to my page and view it only some
    or all my
    fields do not display any data... but if i play around with
    the order of my
    select statement below i can get some fields to display and
    other
    disappear... and i dont ever touch my webpage again...
    Can anyone shed some light on this issue? Or is there a
    better way to
    display my results so that what i get back with my query will
    always
    display....
    here is my stored procedure that im calling
    SET NOCOUNT ON;
    SELECT
    c.cfname,c.clname,c.cid,h.termcode,h.hiredate,h.lastdate,h.cdateh,
    h.cdatet,h.startdate,h.managername,h.termby,
    availsun1,availsun2,availmon1,availmon2,availtue1,availtue2,
    availwed1,availwed2,availthur1,availthur2,availfri1,availfri2,
    availsat1,availsat2,h.comby,ssn_dash = dbo.SSN_dash(cssn),
    Home = dbo.PhoneNumber_complete_format(chphone),
    Mobile = dbo.PhoneNumber_complete_format(cmphone),
    Other = dbo.PhoneNumber_complete_format(cophone),
    Jobtitle =
    case
    when c.st = '90' then
    (select top 1 j.jobtitle from has.dbo.JobCodes j where j.hjob
    = h.jobid and
    j.hlocation = 'DC')
    else
    (select top 1 j.jobtitle from has.dbo.JobCodes j where j.hjob
    = h.jobid and
    j.hlocation <> 'DC')
    end,
    (Select T.term_reason
    From has.dbo.termcodes T, has_arc.dbo.EmpTermHistory H
    where T.term_val = H.termcode and h.cid = @cid) as
    TermReason,
    Days = @day,
    Months = @month,
    Years = @year
    FROM has_arc.dbo.EmpCandidate C, has_arc.dbo.EmpTermHistory H
    WHERE C.cid = @cid AND C.cid = H.cid
    END
    ASP, SQL2005, DW8 VBScript

    Can anyone help shed some light on this?
    ASP, SQL2005, DW8 VBScript
    "Daniel" <[email protected]> wrote in message
    news:ff3ud8$10k$[email protected]..
    > Not sure if anyone has had this problem, but its getting
    annoying.. when i
    > execute this within SQL it returns all the values
    requested. If i execute
    > it within dreamweaver to show me what results i will get
    back it works
    > there.. but after i bind the fields to my page and view
    it only some or
    > all my fields do not display any data... but if i play
    around with the
    > order of my select statement below i can get some fields
    to display and
    > other disappear... and i dont ever touch my webpage
    again...
    >
    > Can anyone shed some light on this issue? Or is there a
    better way to
    > display my results so that what i get back with my query
    will always
    > display....
    >
    > here is my stored procedure that im calling
    > SET NOCOUNT ON;
    > SELECT
    >
    c.cfname,c.clname,c.cid,h.termcode,h.hiredate,h.lastdate,h.cdateh,
    > h.cdatet,h.startdate,h.managername,h.termby,
    >
    availsun1,availsun2,availmon1,availmon2,availtue1,availtue2,
    >
    availwed1,availwed2,availthur1,availthur2,availfri1,availfri2,
    > availsat1,availsat2,h.comby,ssn_dash =
    dbo.SSN_dash(cssn),
    > Home = dbo.PhoneNumber_complete_format(chphone),
    > Mobile = dbo.PhoneNumber_complete_format(cmphone),
    > Other = dbo.PhoneNumber_complete_format(cophone),
    > Jobtitle =
    > case
    > when c.st = '90' then
    > (select top 1 j.jobtitle from has.dbo.JobCodes j where
    j.hjob = h.jobid
    > and j.hlocation = 'DC')
    > else
    > (select top 1 j.jobtitle from has.dbo.JobCodes j where
    j.hjob = h.jobid
    > and j.hlocation <> 'DC')
    > end,
    > (Select T.term_reason
    > From has.dbo.termcodes T, has_arc.dbo.EmpTermHistory H
    > where T.term_val = H.termcode and h.cid = @cid) as
    TermReason,
    > Days = @day,
    > Months = @month,
    > Years = @year
    >
    > FROM has_arc.dbo.EmpCandidate C,
    has_arc.dbo.EmpTermHistory H
    > WHERE C.cid = @cid AND C.cid = H.cid
    > END
    >
    >
    > --
    > ASP, SQL2005, DW8 VBScript
    >

  • XML JAXB Binding issue

    Hi All
    Im using Webservices in which i need to Bind my XML to Java objects and reverse. Im trying to use JAXB (1.0) Ref Imp from SUN as binding framework. The problem which im facing is that for elements like:
    <xs:element name="inputRequests">
    <xs:complexType>
    <xs:sequence>
    <xs:element maxOccurs="unbounded" name="inputData" type="data" />
    </xs:sequence>
    </xs:complexType>
    </xs:element>
    JAXB genetrates:
    1. InputRequest - Interface
    2. InputRequestImpl - Class
    3. InputRequestType - Interface
    4. InputRequestTypeImpl - Class
    in InputRequestType it has generated a getter method
    public java.util.List getInputData();
    but no setter method for 'inputData'.
    Can any one help on that how we can set a sequence element in JAXB classes. I even used JAXB 2.0, but faced same issue...
    No Setter for a LIST :-(((

    That method, getInputData() is returning a reference to a List Object that is already instantiated. Once you retrieve the reference, you can invoke all the methods in the List interface, but if there is a way to reassign the reference to refer to a different list, I'm not aware of one.
    I believe that limitation is necessary my the nature of JAXB. A JAXB Object, in your case a List, is guaranteed to be marshaled and unmarshaled to XML, if you redefine the reference to some arbitrary List, how could JAXB guarantee its functionality?
    I may be way off base here, I'm no JAXB expert by any means.
    Rather than redefining the reference to a different List, you have to manipulate the List
    ...getInputData().clear();
    ...getInputData().addAll(myRequestList);Right?

  • Binding issue in 12.1.2?

    Our application is running on 11.1.2.4 just fine.
    I migrated it over to 12.1.2 yesterday and I noticed that when I was executing dynamic SQL to build out my VO that when it goes to set up the binding it throws an exception:
    ADF_FACES-60098:Faces lifecycle receives unhandled exceptions in phase RENDER_RESPONSE 6
         javax.el.ELException: java.lang.NullPointerException
    at javax.el.BeanELResolver.getValue(BeanELResolver.java:310)
    at com.sun.faces.el.DemuxCompositeELResolver._getValue(DemuxCompositeELResolver.java:176)
    at      com.sun.faces.el.DemuxCompositeELResolver.getValue(DemuxCompositeELResolver.java:203)
    at com.sun.el.parser.AstValue.getValue(AstValue.java:138)
    at com.sun.el.parser.AstValue.getValue(AstValue.java:183)
    at      com.sun.el.ValueExpressionImpl.getValue(ValueExpressionImpl.java:224)
    at org.apache.myfaces.trinidad.bean.FacesBeanImpl.getProperty(FacesBeanImpl.java:73)
    at
    Here is the code that doesn't work:
    <pre jivemacrouid="_13764864521421785" ___default_attr="plain" jivemacro="code" class="jive_text_macro jive_macro_code jivemacrouid_13764864521421785">
    <af:table value="#{bindings.DynamicSOVO1.collectionModel}" var="row"
                              rows="#{bindings.DynamicSOVO1.rangeSize}" summary="xxx"
                              emptyText="#{bindings.DynamicSOVO1.viewable ? 'No data to display.' : 'Access Denied.'}"
                              fetchSize="#{bindings.DynamicSOVO1.rangeSize}" rowBandingInterval="0"
                              filterModel="#{bindings.DynamicSOVO1Query.queryDescriptor}"
                              queryListener="#{bindings.DynamicSOVO1Query.processQuery}" filterVisible="true" varStatus="vs"
                              selectedRowKeys="#{bindings.DynamicSOVO1.collectionModel.selectedRow}"
                              selectionListener="#{bindings.DynamicSOVO1.collectionModel.makeCurrent}" rowSelection="single"
                              id="t1" autoHeightRows="5" styleClass="AFStretchWidth"
                              rendered="true" columnStretching="column:c6" width="900px"                         
                              binding="#{pageFlowScope.SOSearchBean.soTable}"
                              partialTriggers="::cbSOSearch">
                        <af:column sortProperty="#{bindings.DynamicSOVO1.hints.ORDER_NUMBER.name}" filterable="true" rowHeader="unstyled"
                                   sortable="true" headerText="Order #" id="c1" width="60">
                            <af:outputText value="#{row.ORDER_NUMBER}" id="ot12"/>
                        </af:column>
    When I have the <af:column> without the binding to the DynamicSOVO1 it works fine and displays correctly. When I bind it then it throws the error

    I resolved the issue. I guess it just need to be binded again.

  • Container binding issue

    Hi All,
       I have modified a SAP workflow and seem to have problems ppassing sata between steps, The first step I use object CA_WRTOFF method Write-off. This completes a write off. After this step variable DOCUMENTNUMBER is filled with the created document number.
    In the next step I want to display the document, I use object CA_DOC method display. The main parameter it neeeds is document number. I try to use the generate binding. It will pass &CA_DOC& to &_WI_OBJECT_ID&. from workflow to step, both these objects contain document number.
    However when I look in SWEL at the display document step &_WI_OBJECT_ID&. says no instaance under value? How can I populate this value. I try to manually add document number to the binding but am told I cannot use &_WI_OBJECT_ID&.  as a target. I have CA_DOC set as inport and export. Any idea's?? I am on a 4.6 system
    Thanks

    Hi First of all thanks for your patience,
       Second I seem to have passed the document number but it still is not actually passing to the document number field in trans FPE3 (I mentiooned FP08 in error before, that is ultimately my goal which I will clarify)
    Ok here is what I am trying to accomplish
    The original SAP wrtoff workflow CA_WRTOFF activates with event FP04 create writeoff, my company does not like the fact that when it goes to an approver the writeoff is held in limbo. This allows others access to the write off amount. So they have asked me to restructure the workflow.
    The event link as above is CA_WRTOFF with event trigger approval required as above, the first thing I do in the workflow is complete the writeoff with object CA_WRTOFF method writeoff. I then send a user decision to the approver asking if he wants to display document, accept write-off, reverse write-off. I use CAA_DOC display for the display as CA_WRTOFF does not have document number associated with it.
    In the last few moments I changed my binding in the display to coyp all elements except system, this has passed the document number to the display container. When the approver clicks on the display item it brings him to transaction FPE3 but does not populate the document number in FPE3. So the real issue is to have the display method take the approver to FPE3 and fill in the document number so all the approver has to do is hit enter.
    Again thanks for your time and patience, Much appreciated. I am an ABAPPER but quite new to work flows.
    George

  • JNDI binding issue

    Hi everyone, I'm having an issue with a not bound exception. According to the logs, I'm getting the not bound exception with the following details:
    The excerpt is here: 04/24/08 11:44:42.692 Info: [ProcessWrapper] org.springframework.beans.factory.BeanCreationExce ption: Error creating bean with name 'myDataSource' defined in ServletContext resource [WEB-INF/applicationContext.xml]: Invocation of init method failed; nested exception is javax.naming.NamingException: Could not dereference object [Root exception is javax.naming.NameNotFoundException: WRP not bound]
    It looks for me that Spring is doing the lookup correctly but failing to find the resource in JNDI. What I found for binding in the log is following.
    04/24/08 11:44:31.302 Info: [ProcessWrapper] 11:44:31,302 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=DefaultD S' to JNDI name 'javaefaultDS'
    04/24/08 11:44:31.552 Info: [ProcessWrapper] 11:44:31,552 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=ConnectionFactoryBinding,name=J msXA' to JNDI name 'java:JmsXA'
    04/24/08 11:44:31.614 Info: [ProcessWrapper] 11:44:31,614 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=MACRAE' to JNDI name 'java:MACRAE'
    We can see these JNDI names are successfully bound. WRP is the app which I am trying to run, MACRAE is another app that works in that environment. The web server is JBoss running in a DataSynapse grid server. Any tips on how to get the binding fixed?

    OK, I seem to be getting a new exception, not sure if I did any change but ran into this exception in the logs,
    11/08/24 18:45:08 ----YOGI----the exception from this specific block is javax.naming.Reference cannot be cast to javax.sql.DataSource*
    From what I read on the web, this is prevalent in glassfish and jboss. The reason could be that missing j2ee.jar in classpath or duplicate jdbc jars. I added j2ee.jar to my application library in oc4j dint resolve the issue. I removed jdbc jar from the OAS lib folder and restarted, it dint help.
    Any other clues, anyone?

  • LDAP Binding issue.

    Hi,
    I've been testing out the novell ldap library against an openldap
    server and found an issue with the binding.
    When I try to do the following (c#):
    Code:
    string password = "MyPass"
    LdapConnection conn = new LdapConnection();
    conn.Connect("ldap", 389);
    conn.Bind("uid="michael",ou=people,o=myfirm", password + "test"); // should not authenticate as I add test to the password string.
    This seems to authenticate me all fine and don't give me a ldap
    exception that I get if "MyPass" is wrong. So as long as the password is
    correct I can add whatever chars to the end and it will still
    authenticate.
    Am I doing something wrong or is this a bug?
    Regards,
    Michael.
    mikeso
    mikeso's Profile: http://forums.novell.com/member.php?userid=48915
    View this thread: http://forums.novell.com/showthread.php?t=367505

    Did some more testing with our operations deparment and this seems to be
    an error on our ldap server with some users.
    Sorry for taking up your time.
    Regards,
    Michael.
    mikeso
    mikeso's Profile: http://forums.novell.com/member.php?userid=48915
    View this thread: http://forums.novell.com/showthread.php?t=367505

  • OC4J port binding issue

    This thread is in OC4J/J2EE forum, but it feels like it could be an Redhat AS2.1 port handling issue, so I'm copying here...
    I'm having some problems with OC4J standalone. Starting and stopping OC4J gives error:
    "Error starting HTTP-Server: Address already in use"
    and sometimes "Error starting ORMI-Server. Unable to bind socket: Address already in use
    and almost always "Error starting JMS-Server: Unable to bind socket: Address already in use
    Starting and stopping a few times usually results in a successful restart, but this is intermittent success and not predictable. Reallocating with a different port numbers means successful start fist time, but then it follows the same pattern.
    This is OC4J standalone 9.0.3 pure java deployed on Linux RHAS 2.1...
    Java version is 1.3.1.1_02-b02
    My start and stop scripts look like this :
    startoc4j.csh
    #!/bin/csh
    java -Xmx100m -Xms100m -Dscm.logon=true -jar oc4j.jar -userThreads &
    stopoc4j.csh
    #!/bin/csh
    java -jar admin.jar ormi://localhost:50501 admin ias_admin1 -shutdown
    Has anyone seen this before? Is there a standard start / stop script for OC4J standalone on UNIX that I can use?
    Thanks,
    Mark

    This was found to be a JRE on Linux bug. Solution was to upgrade to Javasoft 1.4.1...

  • CF11 - CFGRID & CFSELECT binding issue

    We just upgraded to CF11 and one of our apps had pieces stop functioning. We have figured out most of it, however one of our cfgrids is having issues. When the page is loaded the cfgrid hits the CFC that is specified in the bind settings (passes in the default employee ID of 0 and returns no data). When we select an employee name from the dropdown menu, we receive a 400 error saying the page can't be found. When the select is changed, it looks like it reverts to the root path instead of the cfc specific in the bind argument. Does anyone have any idea on the direction we should go to fix this? The exact same code works on CF8... but is completely broken on CF11.
    Thanks for your help.

    BKBK Sorry for the confusion... we set an array for the arguments, below is the full block of code.
    <cfform id="evaluation" name="evaluation">
    <div style="height:30px; margin-top:10px;">
    <div style=" margin-right:10px; float:left;">
    <cfselect name="employee" query="EmployeeList" value="affiliateID" display="empName" queryPosition="below">
    <option value="0" selected="selected">--- Select an employee ---</option>
    </cfselect>
    </div>
    </div>
        <cfset args = structNew()>
    <cfset args.name = "ExistingEvals">
    <cfset args.format = "html">
    <cfset args.bindOnLoad = "true">
    <cfset args.bind = "cfc:empEval.getCompletedEvals({cfgridpage},{cfgridpagesize},{cfgridsortcolumn},{cfgridso rtdirection},{employee})">
    <cfset args.stripeRows = true>
    <cfset args.selectColor = "##D9E8FB">
    <cfset args.selectmode = "row">
    <cfset args.selectOnLoad = "false">
    <cfset args.autowidth = "no">
    <cfset args.width = "335px">
        <cfset args.pageSize = "6">
    <cfset args.height = "200px">
    <div style=" margin-top:5px;">
    <cfgrid name="employeeEvals" attributeCollection="#args#">
    <cfgridcolumn name="empAffiliateID" display="no">
    <cfgridcolumn name="FY" display="no">
    <cfgridcolumn name="evaluationID" display="no">
    <cfgridcolumn name="typeID" header="Eval Type" display="yes" width="75">
    <cfgridcolumn name="FY" header="Fiscal Year" display="yes" width="90">
    <cfgridcolumn name="Status" header="Status" display="yes" width="125">
    <!---<cfgridcolumn name="Date" header="Date" display="yes">--->
    </cfgrid>

  • Parameter Binding Issue

    I have an advanced function that that looks something like this:
    function Audit-System
    [CmdletBinding()]
    param(
    [Parameter(Position=0,Mandatory=$True,ValueFromPipeline=$True,ValueFromPipelinebyPropertyName=$True)]
    [Alias("Name")]
    [string[]]$ComputerName
    Process
    foreach($computer in $ComputerName)
    ## Do stuff for every computer
    Write-Verbose $computer
    The followimg work ok:
    "computer1","computer2" | Audit-System
    Audit-System "computer1","computer2"
    Audit-System "computer1"
    The following doesn't work:
    Get-ADComputer -Filter * SearchBase "CN=Computers,DC=contoso,DC=com" | Audit-System -Verbose
    I would have thought that because the [Microsoft.ActiveDirectory.Management.ADComputer] has a 'Name' property parameter binding would have matched it up with my $ComputerName parameter. Why doesn't this work?

    What version of PowerShell are you running? I have this working running PowerShell V4 and also having installed  KB2928680 which
    fixed a known issue with PowerShell V4 and the use of -Properties * with Get-ADUser and Get-ADComputer.
    Interesting. I still need to pipe through select on a fully patched Win8.1 and Win7 (with V4 installed).
    Don't retire TechNet! -
    (Don't give up yet - 12,700+ strong and growing)
    Disregard this. After more testing (this time using the function), I run into the same issue. Appears that this particular issue is still occurring. I know there is a connect issue submitted for this, but wasn't able to locate it (at the time of this post).
    Boe Prox
    Blog |
    Twitter
    PoshWSUS |
    PoshPAIG | PoshChat |
    PoshEventUI
    PowerShell Deep Dives Book

Maybe you are looking for

  • Transfer of data from one iTunes account to another

    My son has been using my iTunes account for games. Got him a 5th gen iPod touch. Can I transfer his data from my iTunes acct to a brand new iTunes account ? He is so ovewhelmed that he will lose his data .

  • Getting saved ipod stopwatch sessions onto my mac?

    I could have sworn that there was a way to sync the stopwatch from the ipod to the desktop or right into itunes but I've searched and can find nothing on this board, google or the ipod manual. was I dreaming this? did apple kill this feature in a ver

  • Error message from mail

    For the past few weeks I've been getting an error about not being able to receive mail, but I can, sometimes. Recently switched internet providers but it was happening prior to that. Any thoughts would be appreciated. Haven't changed any settings on

  • 11 GB Limitation in Solaris 8?

    I am new to Solaris. Noticed I cannot set up the OS to use all of my 43GB Maxtor drive, and only uses 11 GB. Is this a fundemental limitation? Can the rest of the disk be setup via the GUI? Any help or recommended patches (yes, I have looked) is grea

  • No matter what i do i cant restore my iPod and iTunes will not recognize it

    no matter what i do i cannot restore my iPod to factory settings and iTunes will not recognize my iPod but Windows will (i've tried everything) please help me