Hardlinking via Finder or SSH

Hi,
I am running a mac mini as a file server connected to a drobo to store all my files in a central place. The issue that I am having is that I would like to use hard links instead of aliases, is there a way to do this from a remote machine or the machine itself in Finder?
As another way to do it i tried logging into the mac mini using terminal and creating the hard linked files manually, When I remotely issue the command that works perfectly in a local terminal window it tells me that the operation is unsupported. How can this be? I would have assumed that once connected it should be the same as being on the machine itself.
Any help please?
Regards
D

As long as the hardlinks are between directories both residing on the same device, you can do this via ssh.
ssh remote.system.addr 'cd /somewhere/useful;ln /otherdir/file hardlink.file'
However, if this is for backup purposes, then you should know that Time Machine effectively does this when it does its hourly backups. It uses hardlinks to avoid having multiple copies of the same file.
The "rsync -E --compare-dest=reference.directory.tree" command can be used to create incremental backups where files that are the same as what is currently in the reference directory tree are hardlinked to the new directory tree instead of creating a new copy.
There is an open source perl script (rsnapshot) that will manage backups that use rsync --compare-dest and provides hourly, daily, weekly, monthly backups and manages the incremental backups. rsnapshot via ssh can be used to reach out from your Mac mini and backup multiple systems in your home, and if you configure things correctly you can backup systems across the internet. rsnapshot will require some hands on setup for a Mac environment, but if you want to get your hands dirty, it might be what you are looking for.

Similar Messages

  • Irregular failure to authenticate OpenDirectory users via password-based ssh

    TL;DR - my Yosemite Open Directory server irregularly fails to properly authenticate users (via password-based ssh). 
    I recently moved an Open Directory server from an Xserve running 10.6 to a new Mini running 10.10.  I archived the OD config on the Xserve and then took it offline.  Then I brought the Mini online using the same hostname/IP address, created a new OD master using the archived configuration.  Everything seemed to work well, however sometimes the server will not authenticate users via password when logging in with ssh/sftp/scp.  This is also true of a few OS X machines that bind to the OD server (i.e. they usually authenticate users properly, but sometimes fail for no discernable reason). 
    The failures are only for password authentication using ssh.  Other mechanisms do not exhibit the auth failures.  For instance, AFP and SMB user auth never fails (with proper credentials).  Nor do users to a FileMaker Server machine that authenticate via the OD server have problems.  Public key based ssh authentication never fails.  Local accounts (non-OD, aka "Local Network Accounts") also do not fail using password-based authentication.
    The failures are irregular.  The only pattern that I can find at all is that sometimes when the failures start happening, they keep happening continuously until...at some point they work properly again.  That is, they may fail from 11:15 am to 2:01 pm, and if so, then all of them fail in that time range.  Sometimes that time range lasts seconds, sometimes it lasts hours.
    The time range failure pattern is host specific.  For instance, if password authentication is failing on the main OD server, authentication may be fine on the other bound machines.  If authentication is failing on one of the bound machines, then it may be fine on all others and fine on the OD server itself.
    The failure pattern does not seem to correlate to any other events or activity on the server (even remotely).  CPU utilization never gets above about 15%.  Memory utilization is similarly very low.  Network traffic is occasionally high, but it does not seem in any way related to the auth failures.  There are not other log messages that occur before or after the failures with any consistency.
    I've been monitoring the auth failures by attempting to login to the OD server and two other bound hosts once per minute so that I can tell when the auth is failing (before getting calls from the users). 
    The adaptive firewall is not running on the OD server.  Nor is any other firewall.
    Below are a comparison of the system.log entries for a failed and successful auth (I've stripped out those lines that are identical in both instances).  The log entries have been sanatized as described.
    Rebooting the OD server does not affect the bound clients' authentication.  Rebooting the OD server is problematic, and I cannot do it often.  When I do, sometimes failures start soon after reboot, and sometimes that don't come back for many hours - again, no discernable pattern.
    If anyone has any ideas what I can do to discover the source of this problem and come up with a solution, I'd very much appreciate it.  Note that I'm aware that I can export all users and group and reconstruct a new, clean OD master, but without the ability to save the passwords, this becomes a large logisitcal problem, and I'm saving it as a last resort (particularly since if it doesn't solve my problem, I will have inconvenienced many users and be right back in the same place).
    Thanks for reading.
    First failure:
        Feb 11 00:00:20 odserver.myorg.gov kdc[67]: TGS-REQ [email protected] from 127.0.0.1:65373 for host/[email protected] [canonicalize, forwardable]
        Feb 11 00:00:20 odserver.myorg.gov opendirectoryd[67268]: GSSAPI Error:  Miscellaneous failure (see text (unable to reach any KDC in realm ODSERVER.MYORG.GOV, tried 2 KDCs (negative cache))
        Feb 11 00:00:20 odserver.myorg.gov sshd[72974]: error: PAM: authentication error for myusername from clienthost.myorg.gov via 10.50.50.50
        Feb 11 00:00:20 odserver.myorg.gov sshd[72974]: Connection closed by 10.50.50.99 [preauth]
    Now successful auth:
        Feb 11 01:03:20 odserver.myorg.gov kdc[67]: TGS-REQ [email protected] from 127.0.0.1:63978 for host/[email protected] [canonicalize, forwardable]
        Feb 11 01:03:20 odserver.myorg.gov kdc[67]: TGS-REQ [email protected] from 127.0.0.1:62346 for ldap/[email protected] [canonicalize, forwardable]
        Feb 11 01:03:20 odserver.myorg.gov sshd[73786]: Accepted keyboard-interactive/pam for myusername from 10.50.50.99 port 53361 ssh2
        Feb 11 01:03:20 odserver.myorg.gov NetAuthSysAgent[73789]: GetStatus: connecting to self not allowed
       Feb 11 01:03:20 odserver.myorg.gov NetAuthSysAgent[73789]: ERROR: AFP_GetServerInfo - connect failed 62
    I've sanitized the entries as follows, replacing...
    My username by myusername
    The ssh source host IP address by 10.50.50.99
    The ssh source hostname by clienthost.myorg.gov
    The server hostname by odserver.myorg.gov
    The server hostname (in caps) by ODSERVER.MYORG.GOV
    The server IP address by 10.50.50.50

    Hello James,
    I have not had a chance to look for the Router configuration document, however, for one of my certificate exams I did configure Authentication Proxy on an IOS router. The config for that lab was:
    aaa new-model
    aaa authentication login default group tacacs+ local
    aaa authorization auth-proxy default group tacacs+ local
    aaa session-id common
    ip auth-proxy name AUTHPROXY http inactivity-time 60
    interface FastEthernet0/0
    ip address 192.168.250.19 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet0/1
    ip address 192.168.200.120 255.255.255.0
    ip access-group 110 in
    ip nat inside
    ip virtual-reassembly
    ip auth-proxy AUTHPROXY
    duplex auto
    speed auto
    ip route 0.0.0.0 0.0.0.0 192.168.250.1
    ip http server
    ip http authentication aaa
    no ip http secure-server
    ip nat inside source list nat interface FastEthernet0/0 overload
    ip access-list extended nat
    permit ip 192.168.200.0 0.0.0.255 any
    access-list 110 permit ip any any
    tacacs-server host 192.168.250.20
    tacacs-server key cisco123
    end
    Please check if the commands are supported on your router as well.
    If this ws helpful please rate.
    Regards.

  • I deleted the photos via Finder and empty trash long time ago. The thing is, that I want to recover one event or album.  The event appears in the iphoto but when open, it shows "!". Is it possible to recover the photos?

    I deleted the photos via Finder and empty trash long time ago. The thing is, that I want to recover one event or album.  The event appears in the iphoto but when open, it shows "!". Is it possible to recover the photos?

    No.  When you removed the photos via the finder you damage the library.  Photos should always be removed from the library using iPhoto, never with the Finder.
    If you have a Time Machine backup of the library from before you deleted the photos you can restore the library to the Desktop and export that album from it to import into your current library.
    It's been too long to be able to try one of the file recovery applications.  You sure to have overwritten those files with new files since them.
    OT

  • I don't remember my passcode and can't restore it via find my phone or through iTunes.

    I just recently found my iPad that I haven't used in about a year after getting a Mac. I don't remember the passcode that I had on it so I can't get into it. I went onto iCloud.com and tried to erase everything via find my phone so that I could get into it, but it won't work until the iPad is connected to the internet. Wifi is on, but the iPad isn't connecting. I tried hooking it up to my computer and restoring it to factory settings that way, but it said that I have to turn off find my phone first. So I went back to the iCloud website and removed the iPad from my apple ID thinking this would turn off any find my phone things connected to my iPad. Apparently I was wrong. So now I am locked out from trying whatever pass codes come to mind because I have put the wrong one in too many times, the data won't erase because it's not connected to the internet, and I can't restore it because it is waiting to connect to the internet to erase the data. On top of all that, since it is an older iPad, I can't chat with apple support without paying $29.00. So is there anything else I can try to get this unlocked or do I just have a $300 paperweight?

    FORCE IPAD INTO RECOVERY MODE
    1. Turn off iPad
    2. Turn on computer and launch iTunes (make sure you have the latest version of iTune)
    3. Plug USB cable into computer's USB port
    4. Hold Home button down and plug the other end of cable into docking port.
    DO NOT RELEASE BUTTON until you see picture of iTunes and plug
    5. Release Home button.
    ON COMPUTER
    6. iTunes has detected iPad in recovery mode. You must restore this iPad before it can be used with iTunes.
    7. Select "Restore iPad"...
    Note:
    1. Data will be lost if you do not have backup
    2. You must follow step 1 to step 4 VERY CLOSELY.
    3. Repeat the process if necessary.

  • When I try to copy files from my computer (just pics) to my iPhone's media folder via Finder under 10.7, I get this error...

    I'm using MacFuse to connect via Finder. It worked before, even on 10.7. But since I cannected th eiPhone to my Windows 7 dual boot partition, now it won't work! Maybe it was just a coincidence, not sure. Just returns this error:
    "The operation can’t be completed because an unexpected error occurred (error code -8003)."
    I get this one when I try to copy files OFF of the iPhone:
    "The operation can’t be completed because an unexpected error occurred (error code -8072)."
    Sounds like a permissions error to me. So I fixed permissions on my Mac with disc utility, but same problem. Then chmod with terminal the media folder. Did nothing. So I can't change permissions, and they're not broken. What could've happened? I'm like, locked out of my device!

    Repair Apple Application Support.
    START/CONTROL PANEL/PROGRAMS N FEATURES/highlight APPLE APPLICATION SUPPORT, then click the REPAIR button

  • Can't connect via Finder but works with everything else

    The Time Capsule is working fine with Time Machine and Airport.  However when I try to connect via Finder, it just says 'Connecting...' and never changes.  When I hit 'Connect As...', nothing happens.  I have rebooted the TC and deleted all passwords from the keychain but that didnt help.  Latest OSX updates and firmware update installed.

    I powered down and was relieved to hear the fan jolt and the drive spin so that looks good.
    Wireless is currently the only method I've been using to connect to the TC with my macbook because as of right now I dont have a USB->ethernet adapter but I will pick one up later today to see if that changes anything.  The cable modem is connected via ethernet though and that seems to be working fine.
    The LED is solid green when the modem is plugged in and flashing orange when it is not.
    Here is the log after a power cycle, at first I did not have the cable modem plugged in and attempted to access via Finder with no luck. Then shortly after, I plugged in the cable modem and tried Finder again. Its interesting that attempting to access the drive via Finder does not create any activity in the log. 
    I will try to cool down overnight and hope I can get at the data.  At this point, my main goal is to retrieve the files.  And then get a new local backup solution asap.  I am currently doing a full online backup to Crashplan but with 500GBs, its going to be weeks before it finishes uploading. 
    Jul 13 05:47:42
    Severity:5
    Initialized (firmware 7.5.2).
    Jul 13 05:47:54
    Severity:5
    Deauthenticating with station ff:ff:ff:ff:ff:ff (reserved 3).
    Jul 13 05:47:54
    Severity:5
    Deauthenticating with station ff:ff:ff:ff:ff:ff (reserved 2).
    Jul 13 05:47:54
    Severity:5
    Rotated CCMP group key.
    Jul 13 05:48:12
    Severity:5
    Associated with station 14:10:9f:d5:8e:bb
    Jul 13 05:48:12
    Severity:5
    Installed unicast CCMP key for supplicant 14:10:9f:d5:8e:bb
    Jul 13 05:48:13
    Severity:5
    Binding added for udp, 0.0.0.0:32769 to 10.0.1.3:5353 with lifetime 7200
    Jul 13 05:48:23
    Severity:5
    Connection accepted from [fe80::1610:9fff:fed5:8ebb%bridge0]:50904.
    Jul 13 05:48:26
    Severity:5
    Connection accepted from [fe80::1610:9fff:fed5:8ebb%bridge0]:50905.
    Jul 13 05:48:42
    Severity:5
    Connection accepted from [fe80::1610:9fff:fed5:8ebb%bridge0]:50906.
    Jul 13 05:48:44
    Severity:5
    Connection accepted from [fe80::1610:9fff:fed5:8ebb%bridge0]:50907.
    Jul 13 05:48:44
    Severity:5
    Connection accepted from [fe80::1610:9fff:fed5:8ebb%bridge0]:50908.
    Jul 13 05:49:36
    Severity:5
    (WAN) link state is Up.
    Jul 13 05:49:36
    Severity:5
    Internet configuration leased [IPv4] -- host <69.204.228.249/255.255.254.0> gateway <69.204.228.1> dns <209.18.47.61 209.18.47.62> wins <> lease <43200> domain <nyc.rr.com>
    Jul 13 05:49:36
    Severity:5
    Binding added for udp, 69.204.228.249:32769 to 10.0.1.3:5353 with lifetime 7200
    Jul 13 05:49:38
    Severity:5
    Internet configuration leased [IPv6] -- host <2604:2000:ffc0:27:5c41:d64:1455:8715> dns <> delegated <>
    Jul 13 05:49:38
    Severity:5
    Internet configuration leased [IPv6] -- host <> dns <> delegated <2604:2000:1009:c07c::/64>
    Jul 13 05:49:38
    Severity:5
    IPv6 route advertised [flags=ADDRESS DNS=NONE]
    Jul 13 05:49:39
    Severity:5
    Clock synchronized to network time server time.apple.com (adjusted +6 seconds).
    Jul 13 05:49:42
    Severity:5
    Binding added for udp, 69.204.228.249:32769 to 10.0.1.3:5353 with lifetime 7200
    Jul 13 05:49:51
    Severity:5
    Internet configuration leased [IPv4] -- host <69.204.228.249/255.255.254.0> gateway <69.204.228.1> dns <209.18.47.61 209.18.47.62> wins <> lease <43186> domain <nyc.rr.com>
    Jul 13 05:49:51
    Severity:5
    Binding added for udp, 69.204.228.249:32769 to 10.0.1.3:5353 with lifetime 7200

  • Unable to view photos in iPhoto, although all pictures are still accessible via Finder?

    Last week, I was trying to import some pictures from a USB flash drive. During the import, I got an error that some of the pictures were corrupt and iPhoto '08 7.1.5 stopped the process. At that time, iPhoto still showed all my events and pictures correctly.
    The next day however, iPhoto was completely empty and did not show any event/picture. It simply says 'no photos' at the bottom (in Dutch):
    None of the rebuilding features solve the problem (iPhoto 6 and later: Rebuilding the iPhoto library).
    Via Finder, I'm able to access the iPhoto library (and I only see 1 library at the location) and view the master files all sorted per year. All pictures open perfectly when I double click them in preview.
    If I simply try to drag these pictures to iPhoto, I get an error saying that they are unrecognised/unreadable:
    How do I get these events/pictures back in iPhoto?
    Thanks for your help!

    It appears you'll haver to do the following:
    Starting over from scratch with new library
    Start over with a new library and import the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from your original library as follows:
    1. Open the library package like this.
    2. Launch iPhoto with the Option key held down and, when asked, select the option to create a new library.
    3. Drag the subfolders of the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from the open iPhoto Library package into the open iPhoto window a few at a time.
    This will create a new library with the same Events (but not necessarily the same Event names) as the original library but will not keep the metadata, albums, books slideshows and other projects.
    Note:  your current library will be left untouched for further attempts at a fix if so desired.

  • TS4006 how to check my iphone location in my macbook pro via find my iphone or imac software ?

    just give me idea
    bcz i have sync my id in my 2 different iphone and also i synced my id in my macbook pro 15 inch but in my macbook
    how to chek my iphone location in my mac via find my iphone or my mac software

    Log into icloud.com and go to the Find My iPhone page to track your mac.  Your mac must be using wifi to be found (wired to a router doesn't work).

  • HT201365 Hi all, im from dubai. someone stolen my iphone5. i was trying to erase my data via find my iphone. in the end there was a notification that remove. i have click remove. then it never shows my device in find my iphone. how can i see my device in

    Hi all, im from dubai. someone stolen my iphone5. i was trying to erase my data via find my iphone. in the end there was a notification that remove. i have click remove. then it never shows my device in find my iphone. how can i see my device in my pc...?

    Here's an interesting bit: iTunes will let me restore my iPod touch from backup: it's still running iOS 4.3.3. I figured as much... there's backups showing in the Preferences -> Devices list for both devices (and even my old, long gone iPod touch 2G), but my iPhone (on iOS5) isn't giving me any such option. I remember I had to downgrade before to get the backup restored (something went haywire in the setup assistant, and I couldn't restore a backup from iTunes there)... If it was possible to go to iOS 5.0 rather than 5.0.1 I would just do the same thing again, but iOS 5.0.1 isn't an option. I attached a screenshot. Hopefully Apple can get this nonsense sorted out; I think iOS 5 might be the root of this, somehow.

  • HT201413 i erased my iphone 5 from another iphone 5 ... i cant restore it now... what shall i do... i erased it via find my iphone

    i erased my iphone 5 from another iphone 5 ... i cant restore it now... what shall i do... i erased it via find my iphone

    Restore it.
    If you desire help, providing details of what happens when trying to restore it is the only way we can offer help.

  • Can't Acces VM neither via browser nor ssh

    I have one instance of gitlab created via vm-depot and it was wornking very fine for some months. Then it suddenly stopped. I can't access it via browser and ssh neither and it has a lot of important projects saved that i don't wanna lose. I checked the
    endpoins and they are ok. I also tried to reboot and set it to a smaller size but it did't work... I don't know what to do, please help me.

    Hi,
    You might want to recreate the VM by deleting the existing VM and retaining the attached disk. You can then attach the same to the new VM.
    Recovery Steps can be Scripted or Manual. To perform the same, suggest you to have a look at the below article
    http://blogs.msdn.com/b/mast/archive/2014/11/20/recovering-azure-vm-by-attaching-os-disk-to-another-azure-vm.aspx
    Hope this helps !
    Regards,
    Sowmya

  • My MacBook Air was stolen and the id changed before I could erase it via "Find iPhone" app - can Apple erase my machine if I provide my serial number?

    My MacBook Air was stolen and the id changed before I could erase it via "Find iPhone" app - can Apple erase my machine if I provide my serial number?

    My MacBook Air was stolen and the id changed before I could erase it via "Find iPhone" app - can Apple erase my machine if I provide my serial number?

  • Recovering lost files on a Mac deleted by overwriting a folder via finder

    Last night I was moving a folder with sub folders full of VIDEOS, MUSIC, PHOTOS, SONY EX1 VIDEO FILES, FINAL CUT FILES, word docs to another internal drive via finder. within seconds I aborted the operation
    I had everything in one folder then I dragged over to the other drive, then dragged it back but I aborted the process. Original folder size was about 300GB. When I try to restart the process, I noticed the folder size dramatically was reduced to about 130GB so checked the folder for my datas, numbers of them were missing. Is there a process such as "UNDO" or SYSTEM RESTORE that could help restore those file? I have not turned the computer off since this happened. Help please!!!

    +*Stop using the drive immediately+* to stop further loss due to files being overwritten.
    You need specialized +Data Recovery+ software, or a service that performs the function. It's not cheap, and there are no guarantees.
    The app mentioned here most often is +Data Rescue 3,+ but I haven't used it myself, so can't recommend it over any of the others.
    Some of these have a free "trial mode," that will tell you if there's anything to be recovered, and perhaps recover a single file. For more, you have to pay the $$.
    You'll also need another drive to receive anything it can recover.
    Look for apps or services under +Data Recovery+ via Google, VersionTracker.com, or MacUpdate.com.

  • How do I stop extra windows or programs from opening automatically when I access my Applications folder via Finder?

    Each time I access my Applications folder via Finder, a bunch of ejectable windows or previously downloaded programs open up on the desktop. I have ejected each one or placed it in the trash, but it still happens. How do I stop this from happening?

    I asked the same question on Yahoo! Answers, and I was advised to reinstall Firefox, which I have just done (with version 3.6.8). The problem seems to be solved. Prior to doing this, I attempted to uninstall my previous version, but Control Panel wouldn't let me do this, nor would Windows Explorer allow me to send the whole Mozilla Firefox folder to the Recycle Bin. I went to Plan C, which was to delete all the subfolders in the main folder, followed by the leftover files, and finally empty the Recycle bin. Then I used Internet Explorer to download the newer version of Firefox, and installed it. No more extra home pages, so far.

  • I just used "Erase" via "Find my phone" to erase and rest my MBP. It's caused my MBP to be locked. I entered correct 4 digit PIN and it seemed to accept it, but it won't allow use of the internal drive. Yosemite loaded. Anyone else had same problem?

    I just used "Erase" via "Find my phone" to erase and reset my MBP. It's caused my MBP to be locked. I entered correct 4 digit PIN and it seemed to accept it, but it won't allow use of the internal drive. Yosemite loaded. Anyone else had same problem?

    Greetings Fraser Alexander,
    Erasing your Mac shouldn't harm your internal hard drive but erasing does clear Yosemite and everything else off of it.  Are you not able to restore it with your Time Machine backup?
    iCloud: Erase your device
    If you erase then find your Mac, you can restore the information on the Mac using a Time Machine backup. For more information, see the Apple Support article Recover your entire system. If you set an EFI firmware password on your Mac before it was lost, then erase it and later find it, you may need to take your Mac to an authorized repair center to unlock it before you can use it again.
    OS X Yosemite: Recover your entire system
    Take care,
    Nubz

Maybe you are looking for

  • Logic Pro X - Disk is too slow or System Overload. (-10010)

    Hi there, I'm a professional music user and recently switched from Pro-Tools to Logic due to PT11's lack of third party plug-in support at the moment. I was looking forward to leaving behind the error messages of Pro-Tools for the supposed plain sail

  • Problem in Sales Register  in XL Reporter

    Hi Experts I have a problem in Sales Register. It show double quantity and linetotal in most of invoices. I search a lot but could not find the problem. When I compose a new sales report from Sales AR module , here it show the same error, double qty

  • How to read an excel file into the datatable in sdk code( AddonApplication)

    Hi Experts, Please let me know the code ,how to write an excel file to the datatable and based on the datatable it should write to the database table. help would be appreciated... Regards, Vijay Kumar Edited by: Haroon Rasheed on Oct 29, 2011 10:40 P

  • "How to Resolve ORA-29532 Java 2 Permission Problems in RDBMS 8.1.6 and 8.1.7"

    I'm in the process of publishing the following note (134280.1), titled "How to Resolve ORA-29532 Java 2 Permission Problems in RDBMS 8.1.6 and 8.1.7". It will be accessible from Oracle Support's "Metalink" site. "How to Resolve ORA-29532 Java 2 Permi

  • Restricted stock used in intra-company stock transfer

    Hi, Can anyone give me the link about the description and difference between unrestricted stock, restricted stock and blocked stock? And for intra-company stock transfer(in one company code), I would like to post goods issue with restriced stock. and