Help needed in lists

Hi
   I have to fill data manually in the fields of lists, and I need a save button, to save the data in the data base.
for this scenario, which type of list is suitable..
Any useful suggestions will awarded..
Thanks!

use ALV List or Grid Function module,when you fill the fieldcatalog keep EDIT = 'X' and so that it works like Input.
See the below thread :
ALV fieldcat-edit
Reward Points if it is helpful
Thanks
Seshu

Similar Messages

  • Help needed in list item...need to display employee of a selected dept

    Hi All,
    I am very beginner in D2K technology.I am using 10g Forms.
    Could you please help me...
    I have created a list item which contains dept_id=10,20,30....
    My requirement is when i will change the value of dept_id(select dept_id=20),the employees belong to that dept will display(need to display 5 employees of dept 20).
    I hav created two block--block2 and block3
    In block2,there is a list item
    In block3,there is a display item and i changed the properties number of record displayed to 10 of the block.
    I atteched a trigger when-list-changed and the code is :
    select last_name into :block3.item14 from employees where department_id=:block2.item4;
    But It is not working.....
    Thanks in Advance,
    Tapan.
    Edited by: user630863 on Aug 8, 2010 9:20 PM
    Edited by: user630863 on Aug 8, 2010 9:55 PM

    okk..well still i don't know the purpose of the form on which you are working why not the database block for emp?..but the requirement you are asking can be done through following code...
    Trigger - WHEN-LIST-CHANGED
    DECLARE
      CURSOR F_Cur IS
        SELECT ename
        FROM emp
        WHERE deptno = :list_item_name;
    BEGIN
      GO_BLOCK('BLOCK3');
      FIRST_RECORD;
      CLEAR_BLOCK;
      FOR G_CUR IN F_CUR LOOP
        :block3.item_name:=G_CUR.ename;
        NEXT_RECORD;
      END LOOP;
      FIRST_RECORD;
    END;
    Note: in the BLOCK3 there should be one item navigable by cursor. I mean if block3 is having only one item which is name item and it is display item then GO_BLOCK built-in will not work. So, you will need to create one more in block3 or make that name item as text item and set update_allowed to NO from the items' property.
    -Ammad

  • Help needed on listing out all tag names using XML Rules in ExtendScript(InDesign)

    Given a document with elements already in place, I am looking for a snippet of code to walk down the XML tree only two levels
    deep to printout the names of each of the tags (not attributes).  I am just using javascript in extendscipt to accomplish this.  Ultimately,
    I want to provide this list in a checkbox dialog and use those checked items to develop a TOC.  This latter part, I have in place.
    It is just the pushing of the tag element names into an array that seems to be cumbersome for me at this point.
    Any shortcut snippets out there that someone can provide?
    A shorter version of this request....Is there anyway to just list out all element.markupTag.name of an XML tree, not knowing the xpath naming?
    Using "//*" obviously is not working....

    well..
    Document.xmlTags.everyItem().name will get you a array of all the xml tags in the document. Maby that will help you?
    another way, and you can use it recursively:
    myObject.xmlElements.everyItem().markupTag.name
    will get you an array of tag names. use something like: http://stackoverflow.com/a/15806501 to remove duplicates.. and.. enjoy

  • Security API help needed / howto list user in group

    Hi there,
    i have tried all example programs of the hyperion security api. hard work to correct the errors in these scripts.
    now i can create native groups an users and can create groups on groups or put users in native groups.
    i have read the java doc / reference for the security api too but its not possible for me to list users of a group (group reference by name).
    is there anybody who can help with a code sample to list users of a group like "testgroup" ?
    something like (...getGroups(context,"testgroup")...) ??
    Best Regards
    Kai

    Please don't cross-post. It is considered very rude to do that here:
    http://forum.java.sun.com/thread.jspa?threadID=5233033&messageID=9953169#9953169

  • *Help Needed* Adding multiple emails/mailing list in the email subscription

    Help Needed
    Hi,
    Can someone help me in adding multiple email address/mailing list in the email subscription for interactive reports in Apex 4.
    pls mail me at [email protected]
    Regards,
    Sunny

    The doc does not mention a separator for the email addresses because we only support one email address per subscription. I have logged a task for our next release to look at expanding it and allowing multiple.
    -- Sharon

  • Help needed Displaying ALV  Secondary list without using oops concept

    Hi Experts
    Help needed Displaying ALV  Secondary list without using oops concept.
    its urgent
    regds
    rajasekhar

    hi chk this code
    ******************TABLES DECLARATION*****************
    TABLES : VBAP,MARA.
    *****************TYPE POOLS**************************
    TYPE-POOLS : SLIS.
    ****************INTERNAL TABLES**********************
    DATA : BEGIN OF IT_VBAP OCCURS 0,
    VBELN LIKE VBAP-VBELN, "SALES DOCUMENT
    POSNR LIKE VBAP-POSNR, "SALES DOCUMENT ITEM
    MATNR LIKE VBAP-MATNR, "MATERIAL NUMBER
    END OF IT_VBAP.
    ****************TEMPORARY VARIABLES******************
    DATA : V_VBELN LIKE VBAP-VBELN."SALES DOCUMENT
    DATA : V_MTART LIKE MARA-MTART. "MATERIAL TYPE
    *****************FIELD CATALOG***********************
    DATA : IT_FIELDCAT TYPE SLIS_T_FIELDCAT_ALV,
           WA_FIELDCAT TYPE SLIS_FIELDCAT_ALV.
    ****************LAYOUT*******************************
    DATA : WA_LAYOUT TYPE SLIS_LAYOUT_ALV.
    ***************VARIANT*******************************
    DATA : G_VARIANT LIKE DISVARIANT.
    ****************SAVE*********************************
    DATA : G_SAVE(1) TYPE C.
    *****************EVENTS******************************
    DATA : XS_EVENTS TYPE SLIS_ALV_EVENT,
           G_EVENTS TYPE SLIS_T_EVENT.
    ******************PF STATUS**************************
    DATA : PF_STATUS TYPE SLIS_FORMNAME VALUE 'SET_PF_STATUS'.
    ******************USER COMMAND************************
    DATA : USER_COMMAND TYPE SLIS_FORMNAME VALUE 'SET_USER_COMMAND',
           R_UCOMM LIKE SY-UCOMM.
    ****************SELECTION SCREEN************************
    SELECT-OPTIONS : S_VBELN FOR VBAP-VBELN.
    ***************AT SELECTION SCREEN*********************
    AT SELECTION-SCREEN.
      PERFORM VALIDATE.
    **************START-OF-SELECTION**************************
    START-OF-SELECTION.
      PERFORM GET_DETAILS.
      PERFORM FIELDCAT.
      PERFORM LAYOUT.
      PERFORM VARIANT.
      PERFORM SAVE.
      PERFORM EVENTS.
      PERFORM ALV_DISPLAY.
    *********************FORMS*******************************************
    *&      Form  validate
          text
    -->  p1        text
    <--  p2        text
    FORM VALIDATE .
      SELECT SINGLE VBELN
                    FROM VBAP
                    INTO V_VBELN
                    WHERE VBELN IN S_VBELN.
      IF SY-SUBRC <> 0.
        MESSAGE E000 WITH 'enter valid vbeln'.
      ENDIF.
    ENDFORM.                    " validate
    *&      Form  get_details
          text
    -->  p1        text
    <--  p2        text
    FORM GET_DETAILS .
      SELECT VBELN
             POSNR
             MATNR
             FROM VBAP
             INTO TABLE IT_VBAP
             WHERE VBELN IN S_VBELN.
      IF SY-SUBRC <> 0.
        MESSAGE E000 WITH 'no details found'.
      ENDIF.
    ENDFORM.                    " get_details
    *&      Form  fieldcat
          text
    -->  p1        text
    <--  p2        text
    FORM FIELDCAT .
      WA_FIELDCAT-TABNAME = 'IT_VBAP'.
      WA_FIELDCAT-FIELDNAME = 'VBELN'.
      WA_FIELDCAT-OUTPUTLEN = 10.
      WA_FIELDCAT-SELTEXT_L = 'SALES DOC'.
      APPEND WA_FIELDCAT TO IT_FIELDCAT.
      CLEAR WA_FIELDCAT.
      WA_FIELDCAT-TABNAME = 'IT_VBAP'.
      WA_FIELDCAT-FIELDNAME = 'POSNR'.
      WA_FIELDCAT-OUTPUTLEN = 6.
      WA_FIELDCAT-SELTEXT_L = 'ITEM'.
      APPEND WA_FIELDCAT TO IT_FIELDCAT.
      CLEAR WA_FIELDCAT.
      WA_FIELDCAT-TABNAME = 'IT_VBAP'.
      WA_FIELDCAT-FIELDNAME = 'MATNR'.
      WA_FIELDCAT-OUTPUTLEN = 18.
      WA_FIELDCAT-SELTEXT_L = 'MATERIAL NO'.
      APPEND WA_FIELDCAT TO IT_FIELDCAT.
      CLEAR WA_FIELDCAT.
    ENDFORM.                    " fieldcat
    *&      Form  LAYOUT
          text
    -->  p1        text
    <--  p2        text
    FORM LAYOUT .
      WA_LAYOUT-ZEBRA = 'X'.
    ENDFORM.                    " LAYOUT
    *&      Form  VARIANT
          text
    -->  p1        text
    <--  p2        text
    FORM VARIANT .
      CLEAR G_VARIANT.
      G_VARIANT-REPORT = SY-REPID.
    ENDFORM.                    " VARIANT
    *&      Form  SAVE
          text
    -->  p1        text
    <--  p2        text
    FORM SAVE .
      CLEAR G_SAVE.
      G_SAVE = 'A'.
    ENDFORM.                    " SAVE
    *&      Form  EVENTS
          text
    -->  p1        text
    <--  p2        text
    FORM EVENTS .
      CLEAR XS_EVENTS.
      XS_EVENTS-NAME = SLIS_EV_TOP_OF_PAGE.
      XS_EVENTS-FORM = 'TOP_OF_PAGE'.
      APPEND XS_EVENTS TO G_EVENTS.
    ENDFORM.                    " EVENTS
    *&      Form  TOP_OF_PAGE
          text
    FORM TOP_OF_PAGE.
      WRITE :/ ' INTELLI GROUP'.
    ENDFORM.                    "TOP_OF_PAGE
    *&      Form  ALV_DISPLAY
          text
    -->  p1        text
    <--  p2        text
    FORM ALV_DISPLAY .
      CALL FUNCTION 'REUSE_ALV_LIST_DISPLAY'
       EXPORTING
      I_INTERFACE_CHECK              = ' '
      I_BYPASSING_BUFFER             =
      I_BUFFER_ACTIVE                = ' '
         I_CALLBACK_PROGRAM             = SY-REPID
         I_CALLBACK_PF_STATUS_SET       = PF_STATUS
         I_CALLBACK_USER_COMMAND        = USER_COMMAND
      I_STRUCTURE_NAME               =
         IS_LAYOUT                      = WA_LAYOUT
         IT_FIELDCAT                    = IT_FIELDCAT
      IT_EXCLUDING                   =
      IT_SPECIAL_GROUPS              =
      IT_SORT                        =
      IT_FILTER                      =
      IS_SEL_HIDE                    =
      I_DEFAULT                      = 'X'
         I_SAVE                         = G_SAVE
         IS_VARIANT                     = G_VARIANT
         IT_EVENTS                      = G_EVENTS
      IT_EVENT_EXIT                  =
      IS_PRINT                       =
      IS_REPREP_ID                   =
      I_SCREEN_START_COLUMN          = 0
      I_SCREEN_START_LINE            = 0
      I_SCREEN_END_COLUMN            = 0
      I_SCREEN_END_LINE              = 0
    IMPORTING
      E_EXIT_CAUSED_BY_CALLER        =
      ES_EXIT_CAUSED_BY_USER         =
        TABLES
          T_OUTTAB                       = IT_VBAP
       EXCEPTIONS
         PROGRAM_ERROR                  = 1
         OTHERS                         = 2
      IF SY-SUBRC <> 0.
        MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
                WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
      ENDIF.
    ENDFORM.                    " ALV_DISPLAY
    *&      Form  SET_PF_STATUS
          text
    FORM SET_PF_STATUS USING EXTAB TYPE SLIS_T_EXTAB.
      SET PF-STATUS 'Z50651_PFSTATUS' EXCLUDING EXTAB.
    ENDFORM.                    "SET_PF_STATUS
    *&      Form  SET_USER_COMMAND
          text
    FORM SET_USER_COMMAND USING R_UCOMM
                                RS_SELFIELD TYPE SLIS_SELFIELD.
      CASE R_UCOMM.
        WHEN 'DC'.
          READ TABLE IT_VBAP INDEX RS_SELFIELD-TABINDEX.
          IF SY-SUBRC = 0.
            SELECT SINGLE MTART
                          FROM MARA
                          INTO V_MTART
                          WHERE MATNR = IT_VBAP-MATNR.
            IF SY-SUBRC <> 0.
       MESSAGE E000 WITH 'NO MATERIAL DESCRIPTION FOR SELECTED MATERIAL NO'.
            ELSE.
              WRITE :/ 'MATERIAL NO :',IT_VBAP-MATNR.
              WRITE :/ 'MATERIAL TYPE :' , V_MTART.
            ENDIF.
          ENDIF.
        WHEN 'BACK'.
          LEAVE TO SCREEN 0.
        WHEN 'EXIT'.
          LEAVE TO SCREEN 0.
        WHEN 'CLOSE'.
          CALL TRANSACTION 'SE38'.
      ENDCASE.
    REPORT  Z_ALV_INTERACTIVE  MESSAGE-ID ZMSG_50651
                                    LINE-SIZE 100
                                    LINE-COUNT 60
                                    NO STANDARD PAGE HEADING.
    ******************TABLES DECLARATION*****************
    TABLES : VBAP,MARA.
    *****************TYPE POOLS**************************
    TYPE-POOLS : SLIS.
    ****************INTERNAL TABLES**********************
    DATA : BEGIN OF IT_VBAP OCCURS 0,
    VBELN LIKE VBAP-VBELN, "SALES DOCUMENT
    POSNR LIKE VBAP-POSNR, "SALES DOCUMENT ITEM
    MATNR LIKE VBAP-MATNR, "MATERIAL NUMBER
    END OF IT_VBAP.
    ****************TEMPORARY VARIABLES******************
    DATA : V_VBELN LIKE VBAP-VBELN."SALES DOCUMENT
    DATA : V_MTART LIKE MARA-MTART. "MATERIAL TYPE
    *****************FIELD CATALOG***********************
    DATA : IT_FIELDCAT TYPE SLIS_T_FIELDCAT_ALV,
           WA_FIELDCAT TYPE SLIS_FIELDCAT_ALV.
    ****************LAYOUT*******************************
    DATA : WA_LAYOUT TYPE SLIS_LAYOUT_ALV.
    ***************VARIANT*******************************
    DATA : G_VARIANT LIKE DISVARIANT.
    ****************SAVE*********************************
    DATA : G_SAVE(1) TYPE C.
    *****************EVENTS******************************
    DATA : XS_EVENTS TYPE SLIS_ALV_EVENT,
           G_EVENTS TYPE SLIS_T_EVENT.
    ******************PF STATUS**************************
    DATA : PF_STATUS TYPE SLIS_FORMNAME VALUE 'SET_PF_STATUS'.
    ******************USER COMMAND************************
    DATA : USER_COMMAND TYPE SLIS_FORMNAME VALUE 'SET_USER_COMMAND',
           R_UCOMM LIKE SY-UCOMM.
    ****************SELECTION SCREEN************************
    SELECT-OPTIONS : S_VBELN FOR VBAP-VBELN.
    ***************AT SELECTION SCREEN*********************
    AT SELECTION-SCREEN.
      PERFORM VALIDATE.
    **************START-OF-SELECTION**************************
    START-OF-SELECTION.
      PERFORM GET_DETAILS.
      PERFORM FIELDCAT.
      PERFORM LAYOUT.
      PERFORM VARIANT.
      PERFORM SAVE.
      PERFORM EVENTS.
      PERFORM ALV_DISPLAY.
    *********************FORMS*******************************************
    *&      Form  validate
          text
    -->  p1        text
    <--  p2        text
    FORM VALIDATE .
      SELECT SINGLE VBELN
                    FROM VBAP
                    INTO V_VBELN
                    WHERE VBELN IN S_VBELN.
      IF SY-SUBRC <> 0.
        MESSAGE E000 WITH 'enter valid vbeln'.
      ENDIF.
    ENDFORM.                    " validate
    *&      Form  get_details
          text
    -->  p1        text
    <--  p2        text
    FORM GET_DETAILS .
      SELECT VBELN
             POSNR
             MATNR
             FROM VBAP
             INTO TABLE IT_VBAP
             WHERE VBELN IN S_VBELN.
      IF SY-SUBRC <> 0.
        MESSAGE E000 WITH 'no details found'.
      ENDIF.
    ENDFORM.                    " get_details
    *&      Form  fieldcat
          text
    -->  p1        text
    <--  p2        text
    FORM FIELDCAT .
      WA_FIELDCAT-TABNAME = 'IT_VBAP'.
      WA_FIELDCAT-FIELDNAME = 'VBELN'.
      WA_FIELDCAT-OUTPUTLEN = 10.
      WA_FIELDCAT-SELTEXT_L = 'SALES DOC'.
      APPEND WA_FIELDCAT TO IT_FIELDCAT.
      CLEAR WA_FIELDCAT.
      WA_FIELDCAT-TABNAME = 'IT_VBAP'.
      WA_FIELDCAT-FIELDNAME = 'POSNR'.
      WA_FIELDCAT-OUTPUTLEN = 6.
      WA_FIELDCAT-SELTEXT_L = 'ITEM'.
      APPEND WA_FIELDCAT TO IT_FIELDCAT.
      CLEAR WA_FIELDCAT.
      WA_FIELDCAT-TABNAME = 'IT_VBAP'.
      WA_FIELDCAT-FIELDNAME = 'MATNR'.
      WA_FIELDCAT-OUTPUTLEN = 18.
      WA_FIELDCAT-SELTEXT_L = 'MATERIAL NO'.
      APPEND WA_FIELDCAT TO IT_FIELDCAT.
      CLEAR WA_FIELDCAT.
    ENDFORM.                    " fieldcat
    *&      Form  LAYOUT
          text
    -->  p1        text
    <--  p2        text
    FORM LAYOUT .
      WA_LAYOUT-ZEBRA = 'X'.
    ENDFORM.                    " LAYOUT
    *&      Form  VARIANT
          text
    -->  p1        text
    <--  p2        text
    FORM VARIANT .
      CLEAR G_VARIANT.
      G_VARIANT-REPORT = SY-REPID.
    ENDFORM.                    " VARIANT
    *&      Form  SAVE
          text
    -->  p1        text
    <--  p2        text
    FORM SAVE .
      CLEAR G_SAVE.
      G_SAVE = 'A'.
    ENDFORM.                    " SAVE
    *&      Form  EVENTS
          text
    -->  p1        text
    <--  p2        text
    FORM EVENTS .
      CLEAR XS_EVENTS.
      XS_EVENTS-NAME = SLIS_EV_TOP_OF_PAGE.
      XS_EVENTS-FORM = 'TOP_OF_PAGE'.
      APPEND XS_EVENTS TO G_EVENTS.
    ENDFORM.                    " EVENTS
    *&      Form  TOP_OF_PAGE
          text
    FORM TOP_OF_PAGE.
      WRITE :/ ' INTELLI GROUP'.
    ENDFORM.                    "TOP_OF_PAGE
    *&      Form  ALV_DISPLAY
          text
    -->  p1        text
    <--  p2        text
    FORM ALV_DISPLAY .
      CALL FUNCTION 'REUSE_ALV_LIST_DISPLAY'
       EXPORTING
      I_INTERFACE_CHECK              = ' '
      I_BYPASSING_BUFFER             =
      I_BUFFER_ACTIVE                = ' '
         I_CALLBACK_PROGRAM             = SY-REPID
       I_CALLBACK_PF_STATUS_SET         = PF_STATUS
         I_CALLBACK_USER_COMMAND        = USER_COMMAND
      I_STRUCTURE_NAME               =
         IS_LAYOUT                      = WA_LAYOUT
         IT_FIELDCAT                    = IT_FIELDCAT
      IT_EXCLUDING                   =
      IT_SPECIAL_GROUPS              =
      IT_SORT                        =
      IT_FILTER                      =
      IS_SEL_HIDE                    =
      I_DEFAULT                      = 'X'
         I_SAVE                         = G_SAVE
        IS_VARIANT                      = G_VARIANT
         IT_EVENTS                      = G_EVENTS
      IT_EVENT_EXIT                  =
      IS_PRINT                       =
      IS_REPREP_ID                   =
      I_SCREEN_START_COLUMN          = 0
      I_SCREEN_START_LINE            = 0
      I_SCREEN_END_COLUMN            = 0
      I_SCREEN_END_LINE              = 0
    IMPORTING
      E_EXIT_CAUSED_BY_CALLER        =
      ES_EXIT_CAUSED_BY_USER         =
        TABLES
          T_OUTTAB                       = IT_VBAP
       EXCEPTIONS
         PROGRAM_ERROR                  = 1
         OTHERS                         = 2
      IF SY-SUBRC <> 0.
        MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
                WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
      ENDIF.
    ENDFORM.                    " ALV_DISPLAY
    *&      Form  SET_PF_STATUS
          text
    FORM SET_PF_STATUS USING EXTAB TYPE SLIS_T_EXTAB.
      SET PF-STATUS 'STANDARD' EXCLUDING EXTAB.
    ENDFORM.                    "SET_PF_STATUS
    *&      Form  SET_USER_COMMAND
          text
    FORM SET_USER_COMMAND USING R_UCOMM
                                RS_SELFIELD TYPE SLIS_SELFIELD.
      CASE R_UCOMM.
        WHEN 'DC'.
          READ TABLE IT_VBAP INDEX RS_SELFIELD-TABINDEX.
          IF SY-SUBRC = 0.
            SELECT SINGLE MTART
                          FROM MARA
                          INTO V_MTART
                          WHERE MATNR = IT_VBAP-MATNR.
            IF SY-SUBRC <> 0.
       MESSAGE E000 WITH 'NO MATERIAL DESCRIPTION FOR SELECTED MATERIAL NO'.
            ELSE.
              WRITE :/ 'MATERIAL NO :',IT_VBAP-MATNR.
              WRITE :/ 'MATERIAL TYPE :' , V_MTART.
      SUBMIT SLIS_DUMMY WITH P_MATNR EQ IT_VBAP-MATNR
                        WITH P_MTART EQ V_MTART.
            ENDIF.
          ENDIF.
        WHEN 'BACK'.
          LEAVE TO SCREEN 0.
        WHEN 'EXIT'.
          LEAVE TO SCREEN 0.
        WHEN 'CLOSE'.
          CALL TRANSACTION 'SE38'.
      ENDCASE.
    plz reward if useful

  • Help needed : Extension manager cs6 not listing products

    Help needed to Adobe extension manager cs6 to show all my cs6 products
    I downloaded Extension manager from here Adobe - Exchange : Download the Adobe Extension Manager
    My Computer windows xp 32bit
    My Photosop version cs6
    My Dreamweaver version cs6
    I installed photoshop here : C:\Program Files\Adobe\Adobe Dreamweaver CS6
    and my XManConfigfile
    <?xml version="1.0" encoding="UTF-8"?>
    <Configuration>
        <VariableForExMan>
            <Data key="$sharedextensionfolder">$shareddatafolder/Adobe/Dreamweaver CS6/$LOCALE/Configuration/Extensions</Data>
            <Data key="$dreamweaver">$installfolder</Data>
            <Data key="$dreamweaver/Configuration">$userdatafolder/Adobe/Dreamweaver CS6/$LOCALE/Configuration</Data>
            <Data key="$UserBinfolder">$userdatafolder/Adobe/Dreamweaver CS6/$LOCALE</Data>
            <Data key="NeedOperationNotification">true</Data>
            <Data key="QuitScript">dw.quitApplication()</Data>
            <Data key="SupportedInSuite">CS6</Data>
            <Data key="HostNameForCSXS">DRWV</Data>
            <Data key="ProductVersion">12.0</Data>
            <Data key="Bit">32</Data>
    <Data key="DefaultLocale">en_US</Data>
    </VariableForExMan> 
    </Configuration>
    Extension manager installed here : C:\Program Files\Adobe\Adobe Extension Manager CS6
    Photoshop Installed here: C:\Program Files\Adobe\Adobe Photoshop CS6
    and my XManConfigfile
    <?xml version="1.0" encoding="UTF-8"?>
    <Configuration>
        <VariableForExMan>
            <Data key="EmStorePath">$SharedRibsDataFolder/Adobe/Extension Manager</Data>
            <Data key="$photoshopappfolder">$installfolder</Data>
            <Data key="$pluginsfolder">$photoshopappfolder/Plug-Ins</Data>
            <Data key="$presetsfolder">$photoshopappfolder/Presets</Data>
            <Data key="$platform">Win</Data>
            <Data key="$actions">$presetsfolder/Actions</Data>
            <Data key="$blackandwhite">$presetsfolder/Black and White</Data>
            <Data key="$brushes">$presetsfolder/Brushes</Data>
            <Data key="$channelmixer">$presetsfolder/Channel Mixer</Data>
            <Data key="$colorbooks">$presetsfolder/Color Books</Data>
            <Data key="$colorrange">$presetsfolder/Color Range</Data>
            <Data key="$colorswatches">$presetsfolder/Color Swatches</Data>
            <Data key="$contours">$presetsfolder/Contours</Data>
            <Data key="$curves">$presetsfolder/Curves</Data>
            <Data key="$customshapes">$presetsfolder/Custom Shapes</Data>
            <Data key="$duotones">$presetsfolder/Duotones</Data>
            <Data key="$exposure">$presetsfolder/Exposure</Data>
            <Data key="$gradients">$presetsfolder/Gradients</Data>
            <Data key="$huesat">$presetsfolder/Hue Sat</Data>
            <Data key="$imagestatistics">$presetsfolder/Image Statistics</Data>
            <Data key="$keyboardshortcuts">$presetsfolder/Keyboard Shortcuts</Data>
            <Data key="$layouts">$presetsfolder/Layouts</Data>
            <Data key="$lenscorrection">$presetsfolder/Lens Correction</Data>
            <Data key="$levels">$presetsfolder/Levels</Data>
            <Data key="$liquifymeshes">$presetsfolder/Liquify Meshes</Data>
            <Data key="$menucustomization">$presetsfolder/Menu Customization</Data>
            <Data key="$optimizedcolors">$presetsfolder/Optimized Colors</Data>
            <Data key="$optimizedoutputSettings">$presetsfolder/Optimized Output Settings</Data>
            <Data key="$optimizedsettings">$presetsfolder/Optimized Settings</Data>
            <Data key="$patterns">$presetsfolder/Patterns</Data>
            <Data key="$reducenoise">$presetsfolder/Reduce Noise</Data>
            <Data key="$replacecolor">$presetsfolder/Replace Color</Data>
            <Data key="$scripts">$presetsfolder/Scripts</Data>
            <Data key="$selectivecolor">$presetsfolder/Selective Color</Data>
            <Data key="$shadowhighlight">$presetsfolder/Shadow Highlight</Data>
            <Data key="$smartsharpen">$presetsfolder/Smart Sharpen</Data>
            <Data key="$styles">$presetsfolder/Styles</Data>
            <Data key="$textures">$presetsfolder/Textures</Data>
            <Data key="$tools">$presetsfolder/Tools</Data>
            <Data key="$variations">$presetsfolder/Variations</Data>
            <Data key="$webphotogallery">$presetsfolder/Web Photo Gallery</Data>
            <Data key="$workspaces">$presetsfolder/Workspaces</Data>
            <Data key="$zoomify">$presetsfolder/Zoomify</Data>
         <Data key="$hueandsaturation">$presetsfolder/Hue and Saturation</Data>
         <Data key="$lights">$presetsfolder/Lights</Data>
         <Data key="$materials">$presetsfolder/Materials</Data>
         <Data key="$meshes">$presetsfolder/Meshes</Data>
         <Data key="$rendersettings">$presetsfolder/Render Settings</Data>
         <Data key="$volumes">$presetsfolder/Volumes</Data>
         <Data key="$widgets">$presetsfolder/Widgets</Data>
            <Data key="$localesfolder">$photoshopappfolder/Locales</Data>
            <Data key="$additionalplugins">$localesfolder/$LOCALE/Additional Plug-ins</Data>
            <Data key="$additionalpresets">$localesfolder/$LOCALE/Additional Presets</Data>
            <Data key="$localeskeyboardshortcuts">$localesfolder/$LOCALE/Additional Presets/$platform/Keyboard Shortcuts</Data>
            <Data key="$localesmenucustomization">$localesfolder/$LOCALE/Additional Presets/$platform/Menu Customization</Data>
            <Data key="$localesworkspaces">$localesfolder/$LOCALE/Additional Presets/$platform/Workspaces</Data>
            <Data key="$automate">$pluginsfolder/Automate</Data>
            <Data key="$digimarc">$pluginsfolder/Digimarc</Data>
            <Data key="$displacementmaps">$pluginsfolder/Displacement Maps</Data>
            <Data key="$effects">$pluginsfolder/Effects</Data>
            <Data key="$extensions">$pluginsfolder/Extensions</Data>
            <Data key="$fileformats">$pluginsfolder/File Formats</Data>
            <Data key="$filters">$pluginsfolder/Filters</Data>
            <Data key="$imagestacks">$pluginsfolder/Image Stacks</Data>
            <Data key="$importexport">$pluginsfolder/Import-Export</Data>
            <Data key="$measurements">$pluginsfolder/Measurements</Data>
            <Data key="$panels">$pluginsfolder/Panels</Data>
            <Data key="$parser">$pluginsfolder/Parser</Data>
         <Data key="$3dengines">$pluginsfolder/3D Engines</Data>
            <Data key="$lightingstyles">$pluginsfolder/Filters/Lighting Styles</Data>
            <Data key="$matlab">$photoshopappfolder/MATLAB</Data>
            <Data key="UserExtensionFolder">$photoshopappfolder</Data>
            <Data key="$photoshop">$UserDataFolder/Adobe/Adobe Photoshop CS6/Configuration</Data>
            <Data key="DisplayName">Photoshop CS6 32</Data>
            <Data key="ProductName">Photoshop32</Data>
            <Data key="FamilyName">Photoshop</Data>
            <Data key="ProductVersion">13.0</Data>
            <Data key="IconPath">Configuration/PS_exman_24px.png</Data>
            <Data key="SupportedInSuite">CS6</Data>
            <Data key="HostNameForCSXS">PHSP</Data>
            <Data key="Bit">32</Data>
        </VariableForExMan> 
    </Configuration>
                                                                        Please someone help me i cant install any photoshop extension because of this issue,,,

    Waiting for your reply ...thanks
    Here is the results
    I installed photoshopcs6 illustrator cs6 dreamweaver cs6 illustrator cs6 in the system , But nothing seems
    Result: BridgeTalk Diagnostics
      Info:
      Name = estoolkit-3.8
      Status = PUMPING
      Path
      Version = 2.0
      Build = ES 4.2.12
      Next serial number = 40
      Logging: = OFF
      Now = 15:55:49
      Messages:
      Message Version = 2.05
      Authentication = ON
      Digest = ON
      Thread: estoolkit-3.8#thread
      Avg. pump interval = 55ms
      Last pump = 62ms ago
      Ping: 7
      ECHO_REQUEST: ECHO_RESPONSE
      Timeout = undefined
      Handler = undefined
      STATUS: PUMPING
      Timeout = undefined
      Handler = undefined
      MAIN: MAIN
      Timeout = undefined
      Handler = installed
      LAUNCHED: LAUNCHED
      Timeout = undefined
      Handler = installed
      DIAGNOSTICS: DIAGNOSTICS
      Timeout = undefined
      Handler = installed
      INFO: INFO
      Timeout = undefined
      Handler = installed
      SETUPTIME: thread=0ms, left=16ms
      Timeout = undefined
      Handler = undefined
      Instances: 3
      estoolkit-3.8#dbg:
      msg[15:55:49]: 00000035
      @BT>Version = 2.05
      Target = estoolkit-3.8#dbg
      Sender = estoolkit-3.8#dbg
      Sender-ID = localhost:win3788
      Timeout = 15:55:50
      Type = Ignore
      Response-Request = Timeout
      Headers = (no headers)
      Timestamp = 15:55:49
      Serial-Number = 35
      Received = undefined
      Result = undefined
      Error = undefined
      Body = (empty)
      Incoming: 1
      Outgoing: 0
      Handler: 9
      ExtendScript = for all messages
      Error = for only msg #25
      Error = for only msg #27
      Error = for only msg #31
      Result = for only msg #35
      Error = for only msg #35
      Timeout = for only msg #35
      Result = for only msg #37
      Error = for only msg #37
      estoolkit-3.8#estk:
      msg[15:55:49]: 00000037
      @BT>Version = 2.05
      Target = estoolkit-3.8#estk
      Sender = estoolkit-3.8#dbg
      Sender-ID = localhost:win3788
      Timeout = 16:05:49
      Type = Debug
      Response-Request = Result Error
      Headers = (no headers)
      Timestamp = 15:55:49
      Serial-Number = 37
      Received = undefined
      Result = undefined
      Error = undefined
      Body: 107 bytes
      Text = <get-properties engine="main" object="$.global" exclude="undefined,builtin,prototype" all="true" max="20"/>
      Incoming: 1
      Outgoing: 0
      Handler: 1
      ExtendScript = for all messages
      estoolkit-3.8: (main)
      Incoming: 0
      Outgoing: 0
      Handler: 1
      ExtendScript = for all messages
      Targets: 1
      Connector = PCD
      Installed: 0
      Running: 0
      exman-6.0:
      Path = C:\Program Files\Adobe\Adobe Extension Manager CS6\Adobe Extension Manager CS6.exe
      Display Name = Adobe Extension Manager CS6
      MsgAuthentication = ON
      MsgDigest = ON
      ESTK = OFF
      BundleID = com.adobe.exman
      Status = (not running)
      ExeName = Adobe Extension Manager CS6.exe
      Installed: 1
      Running: 0
      Groups = (no groups defined)

  • Help need to switch Muse site to BC on a allready hosted plan

    Hi,  i also posted on BC forum...
    I have a client that was in a hurry to have his emails accounts before the entire website.
    So i went on and bought the email marketing plan (cos he will also need to do email campains) an pointed his domain everything is working fine, at this moment he has his accounts the domain is live.
    The site would be just a small 7-10 pages not to complicated.
    Has a graphic designer (who has venture into Business catalyst cos it had all the solutions i needed, well that's what the promotional videos said anyway) I made a site in Muse.
    First i did a temporary page thats says "comming soon", and then i made the entire site, all the design and menu but with blank pages cos the client didnt have all the content yet (and still dont have). I uploaded that site to a sub directory so he could see the evolution.
    He approved the design, yay!
    At the end of the process, he told me he needed to have full control with the editor. (style, images, bulleted list, need to put downloadable document like pdf etc.) i told him that he could only modify what was allready there with the Muse in Browser editing (that he saw when i made the pitch using another site) he was impress with the way it worked.
    so i told him i would have to remake "template".
    I thought of using a BC template, and modify the looks to adapt to my client image, Of course, use a responsive theme so he could make the change at one place only. (cos in Muse you need to make the changes on the 3 layouts).
    Now, i created a new temporary site using one of the new responsive template available.
    How can i import that new site onto his live domain? In other words, how can a switch from a theme made in Muse, to a BC template?
    cant i just delete everything in the root folder, and upload the entire new site via ftp?
    please help me find the solution. i am a bit in a panic here
    hope you could understand my lousy English.
    Sincerely,
    i.d.

    This would need to be transparent for m'y client...
    Y
    Envoyé de mon iPhone
    Le 2014-04-20 à 15:29, Sanjit_Das <[email protected]> a écrit :
    Re: help need to switch Muse site to BC on a allready hosted plan
    created by Sanjit_Das in Help with using Adobe Muse CC - View the full discussion
    Thanks for additional details.
    Unfortunately we cannot change site template of a live site in BC , but as a workaround Create a site from BC using the template you wish to use then publish the site from Muse to the site created from BC and transfer the contents stored from live site to trial site. Ater final transition is done , you can delete the already paid site and make live the new trial site which includes new site template.
    Thanks,
    Sanjit
    Please note that the Adobe Forums do not accept email attachments. If you want to embed a screen image in your message please visit the thread in the forum to embed the image at http://forums.adobe.com/message/6314730#6314730
    Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page: http://forums.adobe.com/message/6314730#6314730
    To unsubscribe from this thread, please visit the message page at http://forums.adobe.com/message/6314730#6314730. In the Actions box on the right, click the Stop Email Notifications link.
    Start a new discussion in Help with using Adobe Muse CC at Adobe Community
    For more information about maintaining your forum email notifications please go to http://forums.adobe.com/thread/416458?tstart=0.

  • Help needed:Printing HTML file using javax.print

    Hi
    I am using the following code which i got form the forum for rpinting an HTML file.
    The folllowing code is working fine, but the problem is the content of HTML file is not getting printed. I am geeting a blank page with no content. What is the change that is required in the code? ALso is there any simpler way to implement this. Help needed ASAP.
    public boolean printHTMLFile(String filename) {
              try {
                   JEditorPane editorPane = new JEditorPane();
                   editorPane.setEditorKit(new HTMLEditorKit());
                   //editorPane.setContentType("text/html");
                   editorPane.setSize(500,500);
                   String text = getFileContents(filename);
                   if (text != null) {
                        editorPane.setText(text);                    
                   } else {
                        return false;
                   printEditorPane(editorPane);
                   return true;
              } catch (Exception tce) {
                   tce.printStackTrace();
              return false;
         public String getFileContents(String filename) {
              try {
                   File file = new File(filename);
                   BufferedReader br = new BufferedReader(new FileReader(file));
                   String line;
                   StringBuffer sb = new StringBuffer();
                   while ((line = br.readLine()) != null) {
                        sb.append(line);
                   br.close();
                   return sb.toString();
              } catch (Exception tce) {
                   tce.printStackTrace();
              return null;
         public void printEditorPane(JEditorPane editorPane) {
                   try {
                        HTMLPrinter htmlPrinter = new HTMLPrinter();
                        htmlPrinter.printJEditorPane(editorPane, htmlPrinter.showPrintDialog());
                   } catch (Exception tce) {
                        tce.printStackTrace();
         * Sets up to easily print HTML documents. It is not necessary to call any of the setter
         * methods as they all have default values, they are provided should you wish to change
         * any of the default values.
         public class HTMLPrinter {
         public int DEFAULT_DPI = 72;
         public float DEFAULT_PAGE_WIDTH_INCH = 8.5f;
         public float DEFAULT_PAGE_HEIGHT_INCH = 11f;
         int x = 100;
         int y = 80;
         GraphicsConfiguration gc;
         PrintService[] services;
         PrintService defaultService;
         DocFlavor flavor;
         PrintRequestAttributeSet attributes;
         Vector pjlListeners = new Vector();
         Vector pjalListeners = new Vector();
         Vector psalListeners = new Vector();
         public HTMLPrinter() {
              gc = null;
              attributes = new HashPrintRequestAttributeSet();
              flavor = null;
              defaultService = PrintServiceLookup.lookupDefaultPrintService();
              services = PrintServiceLookup.lookupPrintServices(flavor, attributes);
              // do something with the supported docflavors
              DocFlavor[] df = defaultService.getSupportedDocFlavors();
              for (int i = 0; i < df.length; i++)
              System.out.println(df.getMimeType() + " " + df[i].getRepresentationClassName());
              // if there is a default service, but no other services
              if (defaultService != null && (services == null || services.length == 0)) {
              services = new PrintService[1];
              services[0] = defaultService;
         * Set the GraphicsConfiguration to display the print dialog on.
         * @param gc a GraphicsConfiguration object
         public void setGraphicsConfiguration(GraphicsConfiguration gc) {
              this.gc = gc;
         public void setServices(PrintService[] services) {
              this.services = services;
         public void setDefaultService(PrintService service) {
              this.defaultService = service;
         public void setDocFlavor(DocFlavor flavor) {
              this.flavor = flavor;
         public void setPrintRequestAttributes(PrintRequestAttributeSet attributes) {
              this.attributes = attributes;
         public void setPrintDialogLocation(int x, int y) {
              this.x = x;
              this.y = y;
         public void addPrintJobListener(PrintJobListener pjl) {
              pjlListeners.addElement(pjl);
         public void removePrintJobListener(PrintJobListener pjl) {
              pjlListeners.removeElement(pjl);
         public void addPrintServiceAttributeListener(PrintServiceAttributeListener psal) {
              psalListeners.addElement(psal);
         public void removePrintServiceAttributeListener(PrintServiceAttributeListener psal) {
              psalListeners.removeElement(psal);
         public boolean printJEditorPane(JEditorPane jep, PrintService ps) {
                   if (ps == null || jep == null) {
                        System.out.println("printJEditorPane: jep or ps is NULL, aborting...");
                        return false;
                   // get the root view of the preview pane
                   View rv = jep.getUI().getRootView(jep);
                   // get the size of the view (hopefully the total size of the page to be printed
                   int x = (int) rv.getPreferredSpan(View.X_AXIS);
                   int y = (int) rv.getPreferredSpan(View.Y_AXIS);
                   // find out if the print has been set to colour mode
                   DocPrintJob dpj = ps.createPrintJob();
                   PrintJobAttributeSet pjas = dpj.getAttributes();
                   // get the DPI and printable area of the page. use default values if not available
                   // use this to get the maximum number of pixels on the vertical axis
                   PrinterResolution pr = (PrinterResolution) pjas.get(PrinterResolution.class);
                   int dpi;
                   float pageX, pageY;
                   if (pr != null)
                        dpi = pr.getFeedResolution(PrinterResolution.DPI);
                   else
                        dpi = DEFAULT_DPI;
                   MediaPrintableArea mpa = (MediaPrintableArea) pjas.get(MediaPrintableArea.class);
                   if (mpa != null) {
                        pageX = mpa.getX(MediaPrintableArea.INCH);
                        pageY = mpa.getX(MediaPrintableArea.INCH);
                   } else {
                        pageX = DEFAULT_PAGE_WIDTH_INCH;
                        pageY = DEFAULT_PAGE_HEIGHT_INCH;
                   int pixelsPerPageY = (int) (dpi * pageY);
                   int pixelsPerPageX = (int) (dpi * pageX);
                   int minY = Math.max(pixelsPerPageY, y);
                   // make colour true if the user has selected colour, and the PrintService can support colour
                   boolean colour = pjas.containsValue(Chromaticity.COLOR);
                   colour = colour & (ps.getAttribute(ColorSupported.class) == ColorSupported.SUPPORTED);
                   // create a BufferedImage to draw on
                   int imgMode;
                   if (colour)
                        imgMode = BufferedImage.TYPE_3BYTE_BGR;
                   else
                        imgMode = BufferedImage.TYPE_BYTE_GRAY;
                   BufferedImage img = new BufferedImage(pixelsPerPageX, minY, imgMode);
                   Graphics myGraphics = img.getGraphics();
                   myGraphics.setClip(0, 0, pixelsPerPageX, minY);
                   myGraphics.setColor(Color.WHITE);
                   myGraphics.fillRect(0, 0, pixelsPerPageX, minY);
                        java.awt.Rectangle rectangle=new java.awt.Rectangle(0,0,pixelsPerPageX, minY);
                   // call rootView.paint( myGraphics, rect ) to paint the whole image on myGraphics
                   rv.paint(myGraphics, rectangle);
                   try {
                        // write the image as a JPEG to the ByteArray so it can be printed
                        Iterator writers = ImageIO.getImageWritersByFormatName("jpeg");
                        ImageWriter writer = (ImageWriter) writers.next();
                                       // mod: Added the iwparam to create the highest quality image possible
                        ImageWriteParam iwparam = writer.getDefaultWriteParam();
                        iwparam.setCompressionMode(ImageWriteParam.MODE_EXPLICIT) ;
                        iwparam.setCompressionQuality(1.0f); // highest quality
                        ByteArrayOutputStream out = new ByteArrayOutputStream();
                        ImageOutputStream ios = ImageIO.createImageOutputStream(out);
                        writer.setOutput(ios);
                        // get the number of pages we need to print this image
                        int imageHeight = img.getHeight();
                        int numberOfPages = (int) Math.ceil(minY / (double) pixelsPerPageY);
                        // print each page
                        for (int i = 0; i < numberOfPages; i++) {
                             int startY = i * pixelsPerPageY;
                             // get a subimage which is exactly the size of one page
                             BufferedImage subImg = img.getSubimage(0, startY, pixelsPerPageX, Math.min(y - startY, pixelsPerPageY));
                                                 // mod: different .write() method to use the iwparam parameter with highest quality compression
                             writer.write(null, new IIOImage(subImg, null, null), iwparam);
                             SimpleDoc sd = new SimpleDoc(out.toByteArray(), DocFlavor.BYTE_ARRAY.JPEG, null);
                             printDocument(sd, ps);
                             // reset the ByteArray so we can start the next page
                             out.reset();
                   } catch (PrintException e) {
                        System.out.println("Error printing document.");
                        e.printStackTrace();
                        return false;
                   } catch (IOException e) {
                        System.out.println("Error creating ImageOutputStream or writing to it.");
                        e.printStackTrace();
                        return false;
                   // uncomment this code and comment out the 'try-catch' block above
                   // to print to a JFrame instead of to the printer
                   /*          JFrame jf = new JFrame();
                             PaintableJPanel jp = new PaintableJPanel();
                             jp.setImage( img );
                             JScrollPane jsp = new JScrollPane( jp );
                             jf.getContentPane().add( jsp );
                             Insets i = jf.getInsets();
                             jf.setBounds( 0, 0, newX, y );
                             jf.setDefaultCloseOperation( JFrame.DISPOSE_ON_CLOSE );
                             jf.setVisible( true );*/
                   return true;
              * Print the document to the specified PrintService.
              * This method cannot tell if the printing was successful. You must register
              * a PrintJobListener
              * @return false if no PrintService is selected in the dialog, true otherwise
              public boolean printDocument(Doc doc, PrintService ps) throws PrintException {
                   if (ps == null)
                   return false;
                   addAllPrintServiceAttributeListeners(ps);
                   DocPrintJob dpj = ps.createPrintJob();
                   addAllPrintJobListeners(dpj);
                   dpj.print(doc, attributes);
                   return true;
              public PrintService showPrintDialog() {
                   return ServiceUI.printDialog(gc, x, y, services, defaultService, flavor, attributes);
              private void addAllPrintServiceAttributeListeners(PrintService ps) {
                   // add all listeners that are currently added to this object
                   for (int i = 0; i < psalListeners.size(); i++) {
                   PrintServiceAttributeListener p = (PrintServiceAttributeListener) psalListeners.get(i);
                   ps.addPrintServiceAttributeListener(p);
              private void addAllPrintJobListeners(DocPrintJob dpj) {
                   // add all listeners that are currently added to this object
                   for (int i = 0; i < pjlListeners.size(); i++) {
                   PrintJobListener p = (PrintJobListener) pjlListeners.get(i);
                   dpj.addPrintJobListener(p);
              // uncomment this also to print to a JFrame instead of a printer
              /* protected class PaintableJPanel extends JPanel {
                   Image img;
                   protected PaintableJPanel() {
                        super();
                   public void setImage( Image i ) {
                        img = i;
                   public void paint( Graphics g ) {
                        g.drawImage( img, 0, 0, this );
    Thanks
    Ram

    Ram,
    I have had printing problems too a year and a half ago. I used all printing apis of java and I still find that it is something java lacks. Now basically you can try autosense. To check whether your printer is capable of printing the docflavor use this PrintServiceLookup.lookupPrintServices(flavor, aset); . If it lists the printer then he can print the document otherwise he can't. I guess that is why you get the error.
    Regards,
    Kevin

  • I need a list of all the organizational units, sub organizational units,

    I need a list of all the organizational units, sub organizational
    units,and their security groups which are present in all sub OUs

    Hi,
    There are lots of way to export OU, Sub OU and Security Group.
    1> Open AD console > run query > export with CSV file.
    2> Run “CSVD” command as per your requirement.
    3>Download Manage Engine Software > Install to any computer of Domain member > Set credential for domain controller access > Export the customized information, as per your requirement with XLS, PDF,
    CSV or Ect.
    3rd option is very easy to export customized reports
    Deepak Kotian.
    MCP, MCTS, MCITP Exchange 2010 Ent. Administrator
    Disclaimer:
    Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!
    All the opinions expressed here is mine. This posting is provided "AS IS"
    with no warranties or guarantees and confers no right

  • Need a list of all services, processes and servers

    Hi experts,
    i'm totally new to this but i need a list of all services, processes and servers. Is there a easy way to get them?
    I try to create a tool where you are able to virtually shutdown servers and then you can see what happends to the services and processes. Hope someone can help me.
    Thanks
    btw - sorry for my english

    i'm not sure if you all understand what i'm trying to do so i'll ty to explain it
    first i'll try to explain how i understand SOA
    - there are several servers on which the services run
    - a service is only runnable if his server is active
    - a process consists of several services
    - if one of these services isn't runnable anymore the whole process isn't runnable too
    - there are user who use one or more processes
    - if one of the used processes is not able to run the user will be affected
    the tool i'm trying to write should automatically import the descriped information (server-, service-, process- and userlists) from a given SAP-Systemand then you can switch virtually a server to see which services, processes and user would be affected.
    This would be fine if you want to shut down a server for maintance work or something like that.
    so i hope you understand my problem and you are able to help me
    again i want to excuse for my english and my wimpy knowledge about the SOA Architecture of SAP

  • 1941W configuration help needed

    Our Deployment Scenario:-
    1941W Gigabit Ethernet 0/0 is connected to the PPOE connection of the ISP.
    Gigabit Ethernet 0/1 is connected to the wired LAN
    I have created 2 wireless radio Cisco_Kamran_BGN which is operating at 2.4 Ghz Devices and Cisco_Kamran_A which is operating at 5Ghz Devices.
    I have created 2 VLans for the Wireless.
    Vlan 10 for Cisco_Kamran_A        192.168.10.x
    Vlan 11 for Cisco _Kamran_BGN   192.168.11.X
    The problem is the Wireless users are not getting the IP address from the respective DHCP server which has been configured on the Router.
    Can please any from the community help me and show me where I am missing the configuration.
    Please find my router  & ap configuration below.
    Router Configuration
    Router#
    sh run
    Building configuration...
    Current configuration : 3022 bytes
    ! No configuration change since last restart
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$TdQt$npYeaf/W0kRElcfMggzJ31
    no aaa new-model
    service-module wlan-ap 0 bootimage autonomous
    no ipv6 cef
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.1.1 192.168.1.50
    ip dhcp excluded-address 192.168.10.1 192.168.10.10
    ip dhcp excluded-address 192.168.11.1 192.168.11.10
    ip dhcp pool DHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 195.229.241.222 213.42.20.20
    ip dhcp pool Cisco_Kamran_A
    network 192.168.11.0 255.255.255.0
    default-router 192.168.11.1
    dns-server 195.229.241.222 213.42.20.20
    ip dhcp pool Cisco_Kamran_BGN
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    dns-server 195.225.241.222 213.42.20.20
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    license udi pid CISCO1941W-E/K9 sn FCZ1553C1VK
    hw-module ism 0
    redundancy
    bridge irb
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered GigabitEthernet0/0
    arp timeout 0
    no mop enabled
    no mop sysid
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface Wlan-GigabitEthernet0/0
    description Internal switch interface connecting to the embedded AP
    switchport mode trunk
    no ip address
    interface Vlan1
    no ip address
    interface Vlan10
    ip address 192.168.10.1 255.255.255.0
    ip access-group DSL_ACCESSLIST in
    ip nat inside
    ip virtual-reassembly in
    interface Vlan11
    ip address 192.168.11.1 255.255.255.0
    ip access-group DSL_ACCESSLIST in
    ip nat inside
    ip virtual-reassembly in
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxx password 0 xxxxxx
    ppp ipcp route default
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list DSL_ACCESSLIST interface Dialer1 overload
    ip access-list extended DSL_ACCESSLIST
    permit ip 192.168.0.0 0.0.255.255 any
    control-plane
    line con 0
    password xxxxxx
    login
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
    password xxxxxx
    login
    transport input all
    scheduler allocate 20000 1000
    end
    Router#
    Router#
    Router#
    Access Point Configuration
    ap#
    ap#
    ap#
    sh run
    Building configuration...
    Current configuration : 2603 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname ap
    enable secret 5 $1$JxdQ$a2/00bWJuhUKP9QLC94YD/
    no aaa new-model
    dot11 syslog
    dot11 ssid Cisco_Kamran_A
       authentication open
       authentication key-management wpa
       guest-mode
       wpa-psk ascii 7 1045081417161C5A555C7A7B
    dot11 ssid Cisco_Kamran_BGN
       authentication open
       authentication key-management wpa
       guest-mode
       wpa-psk ascii 7 020D05561907017015165949
    username Cisco password 7 14341B180F0B
    bridge irb
    interface Dot11Radio0
    description 802.11bgn radio
    no ip address
    no ip route-cache
    encryption mode ciphers aes-ccm
    broadcast-key change 3600
    ssid Cisco_Kamran_BGN
    antenna gain 0
    station-role root
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface Dot11Radio1
    description 802.11a radio
    no ip address
    no ip route-cache
    encryption mode ciphers aes-ccm
    ssid Cisco_Kamran_A
    antenna gain 0
    no dfs band block
    channel dfs
    station-role root
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0
    description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
    no ip address
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface GigabitEthernet0.10
    description 802.11a bridge
    encapsulation dot1Q 10
    no ip route-cache
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0.11
    description 802.11bgn bridge
    encapsulation dot1Q 11
    no ip route-cache
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface BVI1
    ip address dhcp client-id GigabitEthernet0
    no ip route-cache
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    no activation-character
    line vty 0 4
    login local
    end
    ap#
    ap#
    ap#

    Hi Stepehen,
    Did the configuration as per your advice  but i am getting the below mentioned error which i have highlighted it in red. Please advice what needs to be done.
    Home
    Re: 1941W configuration help needed
    created by Stephen Rodriguez in Getting     Started with Wireless - View the full discussion
    conf t
    interface     Dot11Radio0
    no ssid     Cisco_Kamran_BGN
    no encryption mode     ciphers aes-ccm
    exit
    interface     Dot11Radio1
    no encryption mode     ciphers aes-ccm
    no ssid     Cisco_Kamran_A
    exit
    dot11 ssid     Cisco_Kamran_A
    vlan 10
    dot11 ssid     Cisco_Kamran_BGN
    vlan 11
    exit
    interface     Dot11Radio0
    encryption vlan 11     mode ciphers aes
    ssid     Cisco_Kamran_BGN
    exit
    interface     dot11radio0.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio 0.11
    encapsulation     dot1q 11
    bridge-group 11
    Configuration of     subinterfaces and main interface
    within the same bridge     group is not permitted
    exit
    interface     Dot11Radio1
    encryption vlan 10     mode ciphers aes-ccm
    ssid     Cisco_Kamran_A
    interface     dot11radio1.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio1.10
    encapuslation     dot1q 10
    bridge-group 10
    Configuration of subinterfaces and main     interface
    within the same bridge     group is not permitted
    end
    wr
    Reply to this message by going to Home
    Start a new discussion in Getting Started with Wireless at Home

  • I need the list of Topics in SAP XI

    Hi To All,
    I Need the list of topics in SAP XI will you please send the list of topics...
    Thanks & Regards
    Satish Patnaik

    Hi Sateesh,
    I think you are new to Integration.I would suggest you to go thru all the topics in SAP XI and then you will get a good idea whether every topic is important or not
    Anyways ,In the present market
    1)proxy.
    2)Message monitoring
    3)BPM
    4)Java Mapping
    5)Context change
    These topics are important for interview point of view.
    Also,
    They may ask you like
    1) What the business systems used ? (Note this is SLD related)
    2) They will give you scenario and aks you howmany BS,TS and logical names
    you will create
    3) Some more things on SWC versions, SAP R/3 Settings like pushing IDOC
    receive IDOC ...etc
    4) Naming conventions you used ? for BS, LS,TS.....
    5) Why sender IDOC,HTTP adpter not required? explain in detail ?
    6) What adapters you used ? Tell all the parameters?
    7) Any java mapping written? how to write? Packages? UDF....
    8) Mapping functions details...like node functions etc....
    Scenario's what they asked me ...:::))))
    1) SOAP to RFC to SOAP explain in details what you will do
    2) Multiple files to Single IDOC using BPM
    3) RDBMS to SAP R/3
    4) Can you built Sysn-Async Bridge in BPM ? How ?
    5) How to write ABAP/Java proxies ? Write all the steps?
    6) How will you alert Configuration ? give T.Codes?
    7) Given one exp...asked create multi mapping ?
    kindly reward if found helpful.
    cheers,
    Hema.

  • F4 help in ALV list

    Hi.
    I have a problem with f4 help in alv list.
    There is a field in my alv list which have a domain. This domain has its own values in value range.
    I have found how to show f4 help according to system tables ( for example kunnr in kna1 ) but I need to show this value range values as f4 help in my alv list.
    Please help me.
    Thanks.

    hi
    try this example
    REPORT zoo_alvf4 .
    DATA : alvgrid TYPE REF TO cl_gui_alv_grid,
    custom_container TYPE REF TO cl_gui_custom_container,
    fieldcatalog TYPE lvc_t_fcat.
    table to contain fields that require f4...............................
    DATA : lt_f4 TYPE lvc_t_f4 WITH HEADER LINE.
    DATA : ok_code TYPE sy-ucomm.
    TABLES : zemployee_c7.
    TYPES : BEGIN OF ty_emp,
    empid LIKE zemployee_c7-empid,
    empname LIKE zemployee_c7-empname,
    END OF ty_emp.
    DATA : i_emp TYPE TABLE OF ty_emp.
    DATA : wa_emp TYPE ty_emp.
    SELECT-OPTIONS : s_empid FOR zemployee_c7-empid.
    CLASS lcl_event_handler DEFINITION.
    PUBLIC SECTION.
    METHODS :
    handle_on_f1 FOR EVENT onf1 OF cl_gui_alv_grid
    IMPORTING e_fieldname es_row_no er_event_data,
    handle_on_f4 for event onf4 of cl_gui_alv_grid
    importing e_fieldname es_row_no er_event_data
    ENDCLASS.
    CLASS lcl_event_handler IMPLEMENTATION.
    METHOD handle_on_f1.
    IF e_fieldname = 'EMPID'.
    CALL SCREEN 3001.
    ENDIF.
    to prevent processing of standard f1 help............................
    er_event_data->m_event_handled = 'X'.
    ENDMETHOD.
    Method handle_on_f4.
    endmethod.
    ENDCLASS.
    start of selection....................................................
    START-OF-SELECTION.
    SELECT empid empname FROM zemployee_c7
    INTO CORRESPONDING FIELDS OF TABLE i_emp
    WHERE empid IN s_empid.
    CALL SCREEN 3000.
    MODULE status_3000 OUTPUT.
    SET PF-STATUS 'ZTOOL'.
    SET TITLEBAR 'ZTITLE'.
    IF alvgrid IS INITIAL.
    CREATE OBJECT custom_container
    EXPORTING
    container_name = 'ZCONTAINER'.
    CREATE OBJECT alvgrid
    EXPORTING
    i_parent = custom_container.
    PERFORM prepare_f4.
    CALL METHOD alvgrid->register_f4_for_fields
    EXPORTING
    it_f4 = lt_f4[]
    creating instance for event handler..................................
    DATA : event_handler TYPE REF TO lcl_event_handler.
    CREATE OBJECT event_handler.
    SET HANDLER event_handler->handle_on_f1 FOR alvgrid.
    SET HANDLER event_handler->handle_on_f4 FOR alvgrid.
    preparing field catalog..............................................
    PERFORM prepare_fieldcatalog CHANGING fieldcatalog.
    CALL METHOD alvgrid->set_table_for_first_display
    EXPORTING
    I_BYPASSING_BUFFER =
    I_BUFFER_ACTIVE =
    I_CONSISTENCY_CHECK =
    I_STRUCTURE_NAME =
    IS_VARIANT =
    I_SAVE =
    I_DEFAULT = 'X'
    IS_LAYOUT =
    IS_PRINT =
    IT_SPECIAL_GROUPS =
    IT_TOOLBAR_EXCLUDING =
    IT_HYPERLINK =
    IT_ALV_GRAPHICS =
    IT_EXCEPT_QINFO =
    CHANGING
    it_outtab = i_emp
    it_fieldcatalog = fieldcatalog
    IT_SORT =
    IT_FILTER =
    EXCEPTIONS
    INVALID_PARAMETER_COMBINATION = 1
    PROGRAM_ERROR = 2
    TOO_MANY_LINES = 3
    others = 4
    IF sy-subrc <> 0.
    MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
    ENDIF.
    ENDIF.
    ENDMODULE. " STATUS_3000 OUTPUT
    preparing field catalog...............................................
    FORM prepare_fieldcatalog CHANGING i_fieldcatalog TYPE lvc_t_fcat.
    DATA : ls_fcat TYPE lvc_s_fcat.
    ls_fcat-fieldname = 'EMPID'.
    ls_fcat-ref_table = 'ZEMPLOYEE_C7'.
    ls_fcat-coltext = 'EMPLOYEE ID'.
    APPEND ls_fcat TO i_fieldcatalog.
    CLEAR ls_fcat.
    ls_fcat-fieldname = 'EMPNAME'.
    ls_fcat-ref_table = 'ZEMPLOYEE_C7'.
    ls_fcat-coltext = 'EMPLOYEE NAME'.
    APPEND ls_fcat TO i_fieldcatalog.
    ENDFORM.
    MODULE user_command_3000 INPUT.
    CASE ok_code.
    WHEN 'BACK'.
    LEAVE TO SCREEN 0.
    WHEN 'EXIT'.
    LEAVE PROGRAM.
    ENDCASE.
    ENDMODULE. " USER_COMMAND_3000 INPUT
    MODULE user_command_3001 INPUT.
    CASE ok_code.
    WHEN 'SAVE'.
    LEAVE TO SCREEN 0.
    WHEN 'BACK'.
    LEAVE TO SCREEN 0.
    ENDCASE.
    ENDMODULE. " USER_COMMAND_3001 INPUT
    MODULE status_3001 OUTPUT.
    SET PF-STATUS 'GUI'.
    SET TITLEBAR 'TITLE'.
    ENDMODULE. " STATUS_3001 OUTPUT
    preparing fields to be registered for f4 help.........................
    FORM prepare_f4.
    lt_f4-fieldname = 'EMPNAME'.
    lt_f4-register = 'X'.
    lt_f4-getbefore = 'X'.
    lt_f4-chngeafter = 'X'.
    APPEND lt_f4.
    ENDFORM.
    Regards

  • Need Help Need Help PLZ PLZ

    my problem is that i have made a calendar by using jtable and i can't highlight or put any sign to keep track on date, but the biggest problem is that i have to submit this project after two days, so i will appreciate any help or tips from you. Here is my code:
    CODE
    /*Contents of CalendarProgran.class */
    //Import packages
    import javax.swing.*;
    import javax.swing.event.*;
    import javax.swing.table.*;
    import java.awt.*;
    import java.awt.event.*;
    import java.util.*;
    public class CalendarProgram{
    static JLabel lblMonth, lblYear;
    static JButton btnPrev, btnNext;
    static JTable tblCalendar;
    static JComboBox cmbYear;
    static JFrame frmMain;
    static Container pane;
    static DefaultTableModel mtblCalendar; //Table model
    static JScrollPane stblCalendar; //The scrollpane
    static JPanel pnlCalendar;
    static int realYear, realMonth, currentYear, currentMonth;
    public static void main (String args[]){
    //Look and feel
    try {UIManager.setLookAndFeel(UIManager.getSystemLookAndFeelClassName());}
    catch (ClassNotFoundException e) {}
    catch (InstantiationException e) {}
    catch (IllegalAccessException e) {}
    catch (UnsupportedLookAndFeelException e) {}
    //Prepare frame
    frmMain = new JFrame ("Gestionnaire de clients"); //Create frame
    frmMain.setSize(330, 375); //Set size to 400x400 pixels
    pane = frmMain.getContentPane(); //Get content pane
    pane.setLayout(null); //Apply null layout
    frmMain.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE); //Close when X is clicked
    //Create controls
    lblMonth = new JLabel ("January");
    lblYear = new JLabel ("Change year:");
    cmbYear = new JComboBox();
    btnPrev = new JButton ("<<");
    btnNext = new JButton (">>");
    mtblCalendar = new DefaultTableModel(){public boolean isCellEditable(int rowIndex, int mColIndex){return false;}};
    tblCalendar = new JTable(mtblCalendar);
    stblCalendar = new JScrollPane(tblCalendar);
    pnlCalendar = new JPanel(null);
    //Set border
    pnlCalendar.setBorder(BorderFactory.createTitledBorder("Calendar"));
    //Register action listeners
    btnPrev.addActionListener(new btnPrev_Action());
    btnNext.addActionListener(new btnNext_Action());
    cmbYear.addActionListener(new cmbYear_Action());
    //Add controls to pane
    pane.add(pnlCalendar);
    pnlCalendar.add(lblMonth);
    pnlCalendar.add(lblYear);
    pnlCalendar.add(cmbYear);
    pnlCalendar.add(btnPrev);
    pnlCalendar.add(btnNext);
    pnlCalendar.add(stblCalendar);
    //Set bounds
    pnlCalendar.setBounds(0, 0, 320, 335);
    lblMonth.setBounds(160-lblMonth.getPreferredSize().width/2, 25, 100, 25);
    lblYear.setBounds(10, 305, 80, 20);
    cmbYear.setBounds(230, 305, 80, 20);
    btnPrev.setBounds(10, 25, 50, 25);
    btnNext.setBounds(260, 25, 50, 25);
    stblCalendar.setBounds(10, 50, 300, 250);
    //Make frame visible
    frmMain.setResizable(false);
    frmMain.setVisible(true);
    //Get real month/year
    GregorianCalendar cal = new GregorianCalendar(); //Create calendar
    realMonth = cal.get(GregorianCalendar.MONTH); //Get month
    realYear = cal.get(GregorianCalendar.YEAR); //Get year
    currentMonth = realMonth; //Match month and year
    currentYear = realYear;
    //Add headers
    String[] headers = {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}; //All headers
    for (int i=0; i<7; i++){
    mtblCalendar.addColumn(headers);
    tblCalendar.getParent().setBackground(tblCalendar.getBackground()); //Set background
    //No resize/reorder
    tblCalendar.getTableHeader().setResizingAllowed(false);
    tblCalendar.getTableHeader().setReorderingAllowed(false);
    //Single cell selection
    tblCalendar.setColumnSelectionAllowed(true);
    tblCalendar.setRowSelectionAllowed(true);
    tblCalendar.setSelectionMode(ListSelectionModel.SINGLE_SELECTION);
    //Set row/column count
    tblCalendar.setRowHeight(38);
    mtblCalendar.setColumnCount(7);
    mtblCalendar.setRowCount(6);
    //Populate table
    for (int i=realYear-100; i<=realYear+100; i++){
    cmbYear.addItem(String.valueOf(i));
    //Refresh calendar
    refreshCalendar (realMonth, realYear); //Refresh calendar
    public static void refreshCalendar(int month, int year){
    //Variables
    String[] months = {"January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December"};
    int nod, som; //Number Of Days, Start Of Month
    //Allow/disallow buttons
    btnPrev.setEnabled(true);
    btnNext.setEnabled(true);
    if (month == 0 && year <= realYear-10){btnPrev.setEnabled(false);} //Too early
    if (month == 11 && year >= realYear+100){btnNext.setEnabled(false);} //Too late
    lblMonth.setText(months[month]); //Refresh the month label (at the top)
    lblMonth.setBounds(160-lblMonth.getPreferredSize().width/2, 25, 180, 25); //Re-align label with calendar
    cmbYear.setSelectedItem(String.valueOf(year)); //Select the correct year in the combo box
    //Clear table
    for (int i=0; i<6; i++){
    for (int j=0; j<7; j++){
    mtblCalendar.setValueAt(null, i, j);
    //Get first day of month and number of days
    GregorianCalendar cal = new GregorianCalendar(year, month, 1);
    nod = cal.getActualMaximum(GregorianCalendar.DAY_OF_MONTH);
    som = cal.get(GregorianCalendar.DAY_OF_WEEK);
    //Draw calendar
    for (int i=1; i<=nod; i++){
    int row = new Integer((i+som-2)/7);
    int column = (i+som-2)%7;
    mtblCalendar.setValueAt(i, row, column);
    //Apply renderers
    tblCalendar.setDefaultRenderer(tblCalendar.getColumnClass(0), new tblCalendarRenderer());
    static class tblCalendarRenderer extends DefaultTableCellRenderer{
    public Component getTableCellRendererComponent (JTable table, Object value, boolean selected, boolean focused, int row, int column){
    if (column == 0 || column == 6){
    setBackground(new Color(255, 220, 220));
    else{
    setBackground(new Color(255, 255, 255));
    super.getTableCellRendererComponent(table, value, selected, focused, row, column);
    return this;
    static class btnPrev_Action implements ActionListener{
    public void actionPerformed (ActionEvent e){
    if (currentMonth == 0){ //Back one year
    currentMonth = 11;
    currentYear -= 1;
    else{ //Back one month
    currentMonth -= 1;
    refreshCalendar(currentMonth, currentYear);
    static class btnNext_Action implements ActionListener{
    public void actionPerformed (ActionEvent e){
    if (currentMonth == 11){ //Foward one year
    currentMonth = 0;
    currentYear += 1;
    else{ //Foward one month
    currentMonth += 1;
    refreshCalendar(currentMonth, currentYear);
    static class cmbYear_Action implements ActionListener{
    public void actionPerformed (ActionEvent e){
    if (cmbYear.getSelectedItem() != null){
    String b = cmbYear.getSelectedItem().toString();
    currentYear = Integer.parseInt(b);
    refreshCalendar(currentMonth, currentYear);

    Welcome to the forum. You will need to learn a couple things if you want to receive help and not get flamed to death:
    1) All code needs to be posted within code tags. You can read up on them here:
    http://forum.java.sun.com/help.jspa?sec=formatting
    You want to make it as easy as possible for the volunteers here to help you. That means making your code readable.
    2) Do not put "urgent" "need help" "hurry please" in your posts if you are smart. Definitely don't put them in the header of the post. The urgency is yours, not ours. Putting that stuff in there only turns people off. If you have a problem deemed worthwhile by the volunteers here, if you have put thought into your post so you make it easy as possible for others to help you, and if you show some effort on your own, you are almost guaranteed to get timely help.
    3) List all error messages completely.
    4) Keep all necessary code, get rid of all unnecessary code. Your code should be compilable on its own, but it should not contain anything that isn't necessary for demonstrating your problem.
    5) Specifics:
    Why are you throwing out all those exceptions?
    Why is everything in one big huge GUI class? Break your code down into functional units. Make sure the logic works in a non-GUI way, THEN add a GUI class.
    Why the huge main method? The main should be short and sweet.
    Why the static inner classes? Do you know what is the difference between static inner classes and non-static inner classes?
    Why all the static variables anyway? You are doing procedural programming with an OOP language. You should use OOP if you can with an OOP language.
    Sorry, but this code looks like it was thrown together in a big hurry. I think that you have a lot of work to do. Good luck!

Maybe you are looking for